Open Source Software

Making Business Applications accessible

Els Van Vossel
Fabien Pinckaers

Integrate your Logistic Processes with

OpenERP

Efficient Warehouse Management with Sales and Purchases Integration

Open Object Press
Open Source Software
Making Business Applications accessible to All Companies

OpenERP
Integrate your Logistic Processes with OpenERP:
Efficient Warehouse Management with Sales and Purchases Integration
by Els Van Vossel and Fabien Pinckaers

This book is published under free license
Creative Commons-BY-NC-SA
http://creativecommons.org/licenses/by-nc-nd/2.0/be/deed.en_US

You are free:
  * to share — to copy, distribute, display, and perform the work
  * to remix — to make derivative works

Under the following conditions:
  * Attribution. You must attribute the work by stating «The authors of the original work are Els Van Vossel and Fabien Pinckaers» with at least the same prominence as in the original work and as in any other attributions for this work (but not in any way that suggests that they endorse you or your use of the work).
  * Noncommercial. You may not use this work for commercial purposes.
  * Share Alike. If you alter, transform, or build upon this work, you may distribute the resulting work only under the same or similar license to this one.

First Edition

Many of the designations used by manufacturers and suppliers to distinguish their products are claimed as trademarks. Where those designations appear in this book, and Open Object Press was aware of a trademark claim, the designations have been printed in initial capitals.

While every precaution has been taken in the preparation of this book, the publisher and the authors assume no responsibility for errors or omissions, or for damages resulting from the use of the information contained herein.
Special Thanks to Marc Laporte, Olivier Laurent, Gary Malherbe and Grégory Dethier

OpenERP is a trademark of OpenERP S.A.
The software is available under the AGPL license version 3.
Open Object Press
40, Chaussée de Namur
1367 Grand-Rosière
http://openerp.com/

From the same Editor


The Authors: Els Van Vossel and Fabien Pinckaers
# Contents

## Foreword
- Open Source Software: Making Business Applications accessible ........................ xi
- The OpenERP Solution .................................................................................... xii
- Structure of this book .................................................................................... xii
- About the authors ........................................................................................... xiii
  - Fabien Pinckaers ....................................................................................... xiii
  - Els Van Vossel ............................................................................................. xiii
- Acknowledgements ........................................................................................ xiv

## I First Steps: Driving a Purchase/Warehouse/Sales Flow

1. Configuring your OpenERP ................................................................. 1
2. Complete Example: Sell, Check the Stock, Purchase .......................... 7
3. Let's get Started and Configure a New Instance .................................. 17
   3.1 Business Example ............................................................................. 17
   3.2 Basic Settings ................................................................................... 18
   3.3 Get your Database Up and Running without Demo Data .................. 18
   3.4 Fit your Needs .................................................................................. 21
     3.4.1 Configuring Accounts ............................................................... 22
     3.4.2 Configuring Journals ................................................................. 26
     3.4.3 Configuring the Main Company ............................................... 26
     3.4.4 Creating Partner Categories, Partners and their Contacts ........ 28
     3.4.5 Creating Products and their Categories .................................... 30
     3.4.6 Stock Locations ......................................................................... 31
     3.4.7 Setting up a Chart of Accounts .................................................. 33
     3.4.8 Make a Backup of the Database ............................................... 34
   3.5 Testing a Complete Purchase Cycle according to an Example .......... 35
3.5.1 Purchase Order ................................................................. 36
3.5.2 Receiving Goods ............................................................... 37
3.5.3 Invoice Control ................................................................. 38
3.5.4 Paying the Supplier ............................................................ 39
3.6 Testing a Complete Sales Cycle according to an Example ......................... 40
  3.6.1 Sales Order ................................................................. 40
  3.6.2 Preparing Goods for Shipping to Customers .................................. 41
  3.6.3 Invoicing Goods ............................................................. 41
  3.6.4 Customer Payment ......................................................... 42

II Advanced Features in Sales Quotation Management .................................. 43

4 Driving your Sales ........................................................................ 45
  4.1 Managing your Sales Quotations ................................................ 45
  4.2 Packaging ............................................................................ 52
  4.3 Alerts .................................................................................... 53
  4.4 Configuring your Sales Order for Delivery and Invoicing ...................... 56
    4.4.1 Configuring Orders .......................................................... 56
    4.4.2 Picking Mode ................................................................. 56
  4.5 Management of Carriers ................................................................ 57
    4.5.1 Tariff Grids ..................................................................... 57
    4.5.2 Delivery Modes ............................................................... 59
    4.5.3 Delivery based on Ordered Quantities .................................... 59
    4.5.4 Delivery based on Shipped Quantities .................................... 59
  4.6 Keep Track of your Margins ......................................................... 60
    4.6.1 Margins on Sales Orders ..................................................... 60
    4.6.2 Margins by Product .......................................................... 61
    4.6.3 Margins by Project .......................................................... 63
  4.7 Pricing Policies ........................................................................ 64
    4.7.1 Creating Price Lists .......................................................... 65
    4.7.2 Example of a Pricelist ....................................................... 68
    4.7.3 Pricelists and Managing Currencies ...................................... 71
  4.8 Rebates at the End of a Campaign ................................................ 71
4.9 Keeping Track of Open Orders ........................................ 73
4.10 Changing Order Layout .............................................. 74

III Advanced Features in Purchase Quotation Management 77

5 Driving your Purchases .............................................. 79
  5.1 All the Elements of a Complete Workflow ....................... 79
    5.1.1 Setting up your Database ........................................ 79
    5.1.2 Price Request from the Supplier ................................. 79
    5.1.3 Goods Receipt .................................................. 83
    5.1.4 Control of Invoicing ............................................. 83
    5.1.5 Control based on Orders ........................................ 85
    5.1.6 Control based on Goods Receipt ................................. 85
    5.1.7 Tenders .......................................................... 86
    5.1.8 Price Revisions ................................................. 87
  5.2 Purchase Analysis through Analytic Accounts ................... 89
    5.2.1 Powerful Statistics ............................................. 89
    5.2.2 To Each Enterprise its own Analytic Chart of Accounts .... 91

IV Managing your Warehouse ........................................ 99

6 Your Warehouse ..................................................... 101
  6.1 Understanding Double-Entry Stock Management ................ 103
  6.2 Managing Physical Inventory Structure .......................... 106
    6.2.1 Warehouse ..................................................... 106
    6.2.2 Location ....................................................... 109
    6.2.3 Shop .......................................................... 114
    6.2.4 Stock ........................................................ 114
  6.3 Keeping Track of Stock Movements ............................... 118
    6.3.1 Goods Receipts ................................................ 118
    6.3.2 Internal Stock Moves ......................................... 122
    6.3.3 Shipping of Goods ............................................. 124
    6.3.4 Logistics Configuration through Advanced Routes .......... 129
<table>
<thead>
<tr>
<th>Section</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>6.3.5</td>
<td>Procurement Methods – Make to Stock and Make to Order</td>
<td>134</td>
</tr>
<tr>
<td>6.3.6</td>
<td>Choosing Supply Methods</td>
<td>136</td>
</tr>
<tr>
<td>6.3.7</td>
<td>Packaging with Various Logistics Units of Measure</td>
<td>137</td>
</tr>
<tr>
<td>6.4</td>
<td>Scheduling Procurements</td>
<td>140</td>
</tr>
<tr>
<td>6.4.1</td>
<td>Processing Exceptions</td>
<td>140</td>
</tr>
<tr>
<td>6.4.2</td>
<td>Manual Procurement</td>
<td>141</td>
</tr>
<tr>
<td>6.4.3</td>
<td>Sales Forecasts</td>
<td>143</td>
</tr>
<tr>
<td>6.4.4</td>
<td>Production Plan</td>
<td>144</td>
</tr>
<tr>
<td>6.5</td>
<td>Managing Lots and Traceability</td>
<td>145</td>
</tr>
<tr>
<td>6.5.1</td>
<td>Stock Moves</td>
<td>146</td>
</tr>
<tr>
<td>6.5.2</td>
<td>Lots</td>
<td>147</td>
</tr>
<tr>
<td>6.5.3</td>
<td>Traceability</td>
<td>148</td>
</tr>
<tr>
<td>6.6</td>
<td>Scrapping Products</td>
<td>149</td>
</tr>
<tr>
<td>6.7</td>
<td>Identifying Products and Locations with Barcodes and RFID Devices</td>
<td>151</td>
</tr>
<tr>
<td>6.8</td>
<td>Financial Inventory Management</td>
<td>151</td>
</tr>
<tr>
<td>6.8.1</td>
<td>Manual and Real-time Stock Valuation</td>
<td>151</td>
</tr>
<tr>
<td>6.8.2</td>
<td>Managing Transportation Costs</td>
<td>152</td>
</tr>
<tr>
<td>6.9</td>
<td>Organize your Deliveries</td>
<td>154</td>
</tr>
<tr>
<td>6.9.1</td>
<td>The Different Journals</td>
<td>154</td>
</tr>
<tr>
<td>6.9.2</td>
<td>Using the Journals</td>
<td>155</td>
</tr>
<tr>
<td>6.10</td>
<td>Estimating Delivery Dates</td>
<td>157</td>
</tr>
<tr>
<td>6.10.1</td>
<td>Standard Delivery Time</td>
<td>157</td>
</tr>
<tr>
<td>6.10.2</td>
<td>Schedule Logistic Flows according to MRP1 Rules</td>
<td>158</td>
</tr>
<tr>
<td>6.11</td>
<td>Incoming and Outgoing Products Planning</td>
<td>158</td>
</tr>
<tr>
<td>6.12</td>
<td>Managing Inventory Reconciliation</td>
<td>159</td>
</tr>
<tr>
<td>6.13</td>
<td>Building Reports to Track Activity</td>
<td>159</td>
</tr>
<tr>
<td>6.14</td>
<td>Import / Export</td>
<td>160</td>
</tr>
<tr>
<td>6.14.1</td>
<td>Stock</td>
<td>161</td>
</tr>
<tr>
<td>6.14.2</td>
<td>Rental Locations</td>
<td>161</td>
</tr>
<tr>
<td>6.14.3</td>
<td>Consigned Products</td>
<td>163</td>
</tr>
<tr>
<td>6.15</td>
<td>Stock Location Example</td>
<td>163</td>
</tr>
<tr>
<td>7</td>
<td>Multi-Company Environment</td>
<td>167</td>
</tr>
</tbody>
</table>
7.1 Logistics in a Multi-Company Environment ............................................. 168
  7.1.1 Configuration ......................................................................................... 168
  7.1.2 Process: Sales and Purchases ............................................................... 175

V On Site Installation ................................................................. 179

8 OpenERP Installation on Linux .............................................. 181
  8.1 PostgreSQL Server Installation and Configuration ............... 181
    8.1.1 Example on Ubuntu .............................................................................. 181
    8.1.2 Setup a PostgreSQL user for OpenERP ............................................. 182
  8.2 OpenERP Server Installation ................................................................. 184
    8.2.1 Installing the required packages ...................................................... 184
    8.2.2 Downloading the OpenERP Server ................................................. 186
    8.2.3 Testing the OpenERP Server .............................................................. 186
    8.2.4 Installing the OpenERP Server .......................................................... 186
  8.3 OpenERP Client Installation ................................................................. 186
    8.3.1 Installing the required packages ...................................................... 186
    8.3.2 Downloading the OpenERP Client .................................................. 188
    8.3.3 Testing the OpenERP Client .............................................................. 188
    8.3.4 Installing the OpenERP Client .......................................................... 188
    8.3.5 Configuring a PDF Viewer ................................................................. 188
  8.4 OpenERP Web Installation ................................................................. 189
    8.4.1 Downloading & Installing the OpenERP Web Client ............... 189
    8.4.2 Testing the OpenERP Web Client .................................................. 190
    8.4.3 Installing the OpenERP Web Client ................................................. 190
    8.4.4 Web Browser Compatibilities ............................................................ 190

9 OpenERP Installation on Windows ....................................... 193
  9.1 OpenERP All-In-One Installation ....................................................... 193
    9.1.1 Downloading OpenERP All-In-One ............................................. 193
    9.1.2 Installing the OpenERP All-In-One .............................................. 194
    9.1.3 Starting the OpenERP Client .......................................................... 196
  9.2 PostgreSQL Server Installation and Configuration ............... 197
Foreword

Information Systems have played an increasingly visible role over the past several years in improving the competitiveness of business. They are more than just tools for handling repetitive tasks; they will guide and advance all of a company’s daily activities. Integrated Management Software is today very often a key source of significant competitive advantage.

Open Source Software: Making Business Applications accessible

Some may look at the Business Application market as a mature market dominated by a few large key players, with no new business opportunities.

This would be ignoring the market reality. So many customers are frustrated by their experience with existing vendors; so many companies around the world need to have access to business applications, but cannot afford them.

OpenERP believes that business applications should not be a luxury. That any company, anywhere in the world, should be able to afford the best tools to professionally expand business. That is one of the reasons why OpenERP needs to break the existing rules of the ERPs and the Business Applications market.

Customers should use their budget smartly and invest in customizing the application to their specific needs, rather than paying expensive license fees. OpenERP is committed to the Open Source Business Model precisely because Open Source allows for this. Open Source is a disruptive model, as it creates more value for the customers.

For decades, customers have developed applications which remained specific to their own needs, and in the end proved extremely expensive to maintain. Open Source means that customers can benefit from past developments of other companies. Also by contributing to the evolution of the software, the users will enjoy the guarantee that their development will be included in future versions of the software. One of the major advantages is that such a Community brings a wealth of new functionality.

Open Source also allows us to engage with our customers differently. Since there is no licensing cost, any potential customer can download, test and use the software. OpenERP has no need for an expensive sales force to promote the product. OpenERP just needs to make the best product and make it available to customers.

Open Source allows for many barriers in this industry to be broken. The software is available to many companies who could otherwise not afford expensive business applications license fees. The OpenERP solution allows customers to use their money smartly and tailor the software to their individual needs. OpenERP leverages from its customer base to enrich the software and finally eradicate any lock-in to allow customers to use and even drop the software freely.
The OpenERP Solution

OpenERP can build a new breed of business applications, more modular, more customer-friendly, fully web-based, which others cannot due to the heritage of their legacy systems.

OpenERP is a comprehensive suite of business applications including Sales, CRM, Project management, Warehouse management, Manufacturing, Financial management, and Human Resources, just to name a few. More than 1000 OpenERP modules are available from the OpenERP Apps marketplace (http://apps.openerp.com/).

The key to continued logistics success is effective Purchase, Sales & Warehouse Management, and these are precisely the main topics of the book you are reading. OpenERP’s Purchase, Sales and Warehouse features are flexible and highly developed to assist you in managing all aspects of logistics, also in a multicompany environment.

OpenERP allows you to set up advanced push and pull rules to manage complex routes in your warehouses. Purchase proposals and sales forecasts can easily be created from OpenERP. In a few clicks, your sales person can transfer necessary information to the customer about the current and virtual stock. Accountants can have real-time stock valuation for all or selected products.

Structure of this book

In part One, Configuring your OpenERP (page 3) we will show you how to set up an OpenERP database. A step-by-step approach will guide you through a complete workflow to discover OpenERP’s features.

Part Two, Advanced Features in Sales Quotation Management (page 43), guides you from quotation to sales order, explaining several advanced sales features.

In part Three, Advanced Features in Purchase Quotation Management (page 77), you will learn more about price requests, purchase proposals and goods receipt. Several advanced purchase features will also be explained.

Part Four, Managing your Warehouse (page 99), explains the principles of OpenERP’s double-entry stock management. The book will provide you with ways to manage inventories, both on a physical and a financial level. Upstream and Downstream traceability and extensive reporting will be discussed as well. You will also learn more about how to manage push and pull locations in a multicompany environment.

Part Five, On Site Installation (page 179), explains the basic steps to install OpenERP on site. Both Linux and Windows installations will be described.

To manage your logistics, you do not need all the elements described in this book. But we find it very important to include an integrated flow, from the first quotation to the final billing of the customers including all the steps: quotation, order, receiving goods, inventory, shipping and billing.
About the authors

Fabien Pinckaers

Fabien Pinckaers was only eighteen years old when he started his first company. Today, over ten years later, he has founded and managed several new technology companies, all based on Free / Open Source software.

He originated Tiny ERP, now OpenERP, and is the director of two companies including OpenERP S.A., the editor of OpenERP. In a few years time, he has grown the Tiny group from one to sixty-five employees without loans or external fund-raising, and while making a profit.

He has also developed several large scale projects, such as Auction-in-Europe.com, which became the leader in the art market in Belgium. Even today people sell more art works there than on ebay.be.

He is also the founder of the LUG (Linux User Group) of Louvain-la-Neuve, and of several free projects like OpenReport, OpenStuff and Tiny Report. Educated as a civil engineer (polytechnic), he has won several IT prizes in Europe such as Wired and l’Inscene.

A fierce defender of free software in the enterprise, he is in constant demand as a conference speaker and he is the author of numerous articles dealing with free software in the management of the enterprise.

Follow Fabien on his blog http://fptiny.blogspot.com/ or on twitter fpopenerp.

Els Van Vossel

Els Van Vossel always had a dedication to both written and spoken word. Clear and explicit communication is crucial.

Educated as a Professional Translator in Antwerp, she worked as an independent translator on the localization of major ERP software. Els acquired ERP knowledge and decided to start working as a functional ERP consultant and a Technical Communicator for ERP software.

As such, the world of OpenSource software became more and more attractive. She started working with OpenERP software in her free time and doing so, Els really wanted to meet Fabien Pinckaers to share thoughts about documentation strategy. Now Els is reviewing and writing the OpenERP Books.

Being an author of several Software Manuals, she finds it exciting to work on the OpenERP documentation and continuously take it to a higher level. Please note that this is a hell of a job, but Els finds great pleasure in doing it!

Follow Els on her blog http://training-openerp.blogspot.com/ or on twitter elsvanvossel.
Acknowledgements

From Els Van Vossel

Thank you Fabien, for offering me the opportunity to work with OpenERP. I thank all OpenERP team members for their support and understanding. My special thanks to my family who encouraged me to write this book.

From Fabien Pinckaers

I address my thanks to all of the team at OpenERP for their hard work in preparing, translating and re-reading the book in its various forms. My particular thanks to Laurence Henrion and my family for supporting me throughout all this effort.
Part I

First Steps: Driving a Purchase/Warehouse/Sales Flow

To manage your logistics, you do not need all the elements described in this book. But we find it very important to include an integrated flow, from the first quotation to the final billing of the customers including all the steps: quotation, order, receiving goods, inventory, shipping and billing.
Configuring your OpenERP

In this chapter, you can start exploring OpenERP through a basic configuration, with the modules that are discussed in this book. As mentioned before, we want to show an integrated flow, not just logistics management.

Use a web browser of your choice to connect to OpenERP Web.

![Web Client at Startup](image)

Start by creating a new database from the Welcome page by clicking Databases and then completing the following fields on the Create Database form.

- **Super admin password**: by default it is `admin`, if you or your system administrator have not changed it,
- **New database name**: `DemoCompany`,
- **Load Demonstration data** checkbox: checked,
- **Default Language**: `English (US)`,
- **Administrator password**: `admin` (because it is the easiest to remember at this stage, but obviously completely insecure),
- **Confirm password**: `admin`.

Press Create to start creating the database.

Language

You can install OpenERP in many languages. To be able to easily follow the instructions in this book, we recommend you to choose English (US).
OpenERP suggests that you configure your database using a series of questions. In the software, these series of questions are managed through so-called Configuration Wizards.

Click the Start Configuration button to continue.

The next configuration wizard will help you to decide what your user interface will look like, whether the screens will only show the most important fields - Simplified - or whether you also want to see the fields for the more advanced users, the Extended view. Select Extended and click Next to continue.

**User Preferences**

You can easily switch from Simplified to Extended view by changing your User Preferences.

In the next wizard, you can fill your company data, select your company’s base currency and add your company logo which can be printed on reports. Click Next to continue.

Select the Warehouse Management, Purchase Management, Sales Management and Accounting & Finance business applications for installation and click Install. Now OpenERP will start to install these four applications, allowing you to do a complete cycle, from sales / warehouse / purchase to invoice. You will have to wait for the next configuration wizard to be displayed (Loading will appear).

OpenERP’s modularity enables you to install a single Business Application (such as Purchase) if that is all you need. Of course, you can choose to install extra applications such as Sales Management, to handle quotations, sales orders and sales invoices as well. For now, please install Warehouse Management, Purchase Management, Sales Management and Accounting & Finance, as these four Business Applications will be discussed in this book.

**Reconfigure**

Keep in mind that you can change or reconfigure the system any time, for instance through the Reconfigure option in the main bar.
When you choose a business application for installation, OpenERP will automatically propose to add or configure related (smaller) applications to enrich your system. When you install Sales, OpenERP will also ask you whether you want to install Invoicing Journals for instance.

The figure *Selecting Accounting Configuration* (page 5) shows the Accounting Application Configuration screen that appears when you select *Accounting & Finance* to be installed.

![Selecting Accounting Configuration](image)

Select the *Generic Chart of Account* and fill in the Sale Tax (%) applicable in your country. The Purchase Tax will automatically be set as well. Click one of the disk icons in front of the bank accounts to confirm the bank accounts to be created. Then click *Configure* to continue the configuration.

OpenERP Logistics Management offers lots of features. You can easily manage your address book (customers, suppliers, ...), keep track of procurements and sales, manage your warehouse and inventory, and much more.

The figure *Selecting Purchase Configuration* (page 5) shows the Purchases Application Configuration screen that appears when you select *Purchase Management* to be installed.

![Selecting Purchase Configuration](image)

Simply click *Configure* to continue the database creation.

The following wizards will appear:

- Configure your *Sales Management* application: click *Configure* to accept the default settings.
Configure your **Accounting** application: click **Configure** to accept the default settings.

Configure **Sales Order Logistics**: click **Next** to accept the default settings.

OpenERP’s menu will be displayed, because your system is now ready for actual configuration. In the next chapter *Complete Example: Sell, Check the Stock, Purchase* (page 7) you will start working in the Logistics application in a step-by-step approach.

As your business is growing and evolving all the time, your requirements as to the use of OpenERP are likely to change. To sustain your growth, you can easily extend your Logistics Management with other OpenERP business applications, such as HR or CRM, to name some. OpenERP offers this flexibility; you can start with one business application and gradually complete OpenERP to suit your ever changing needs!
In this chapter, we will show you a complete Sales / Purchase / Warehouse flow. We will explain how
to create a product, create a sales order, have an automatic purchase proposal and receive the goods,
deliver to the customer, and get sales and purchase invoices in a step-by-step scenario.

First you will get an explanation about the scenario (what Thomas or one of his colleagues is supposed
to do). Then the Notes will learn you how Thomas (or a colleague of his) enters the information in
OpenERP. For the simplicity of the use case, we will do all of the steps under the Admin user. Please
note that we will not discuss all elements in detail in this chapter. Later in the book, you will find all
required information.

Simplified or Extended View

In OpenERP your user interface will look slightly different according to
the User Preferences. In Simplified view, the screens will only show
the most important fields / tab pages. To see also the fields for the more
advanced users, you should switch to the Extended view. You can
easily switch from Simplified to Extended view by changing your User
Preferences through the Edit Preferences button. For this use case, please
switch to Extended view.

Your company will have a stand at the House & Design Fair to promote a series of products. Thomas,
the salesman, shows the new products to the visiting prospects and customers.

1. Create a new customer

John Smith from the company Clarkson Ltd. visits your stand and decides to order the brandnew Desk
you are promoting. Thomas will have to create this new customer in OpenERP.

New Customer

To create a new customer, Thomas clicks the Sales button in OpenERP’s
main screen. Then he goes to Sales → Address Book → Customers and
clicks the New button. The name of a customer is in blue, because it is a
mandatory field, so Thomas enters Clarkson in that field. He notices that
the Customer check box is already checked. Thomas enters John Smith in
the Contact Name, he selects the Default address type. In the Street
field, Thomas enters London Street 40; he also enters the City London and
the Country United Kingdom as shown in the screenshot below. He takes a
look at the other three tabs and decides to keep the default values. Thomas
then clicks the Save button to store the new customer.
2. Create a new product category and product

Because the desk from the new OfficeSecrets series does not yet exist in OpenERP, Mitchell, the Product Manager, will create this brandnew product as a Make to Order product that will be bought directly from the supplier concerned. He will have to create a new product category for the OfficeSecrets series too.

**Configuring Products**

For more information about configuring products, please refer to the next chapter *Creating Products and their Categories* (page 30).

**Product Category**

Product categories do have an effect on the products assigned to them, and a product may belong to only one category. To create a new product category, Mitchell goes to Warehouse or Sales, selects the menu *Configuration → Product → Products Categories* and clicks *New* to get an empty form for defining a product category. Mitchell enters *OfficeSecrets* in the *Name* field and adds it to the parent category *All products / Sellable*. He leaves the other fields as such, and clicks *Save*.

Then Mitchell will create a new product. Note that he could also have created the new product category directly from the *Product* form.
Product

To create a new product, Mitchell goes to Sales → Products → Products and clicks the New button. The name of a product is in blue, because it is a mandatory field, so he enters **1600 Desk Wave Right-hand W1600x D1200x H725mm Maple** in that field. He notices that the Can be Sold and Can be Purchased check boxes are already checked by default. Mitchell selects the Stockable Product product type, because he wants to keep track of the stock movements of the desks. In the Procurement Method field, Mitchell selects Make to Order, because the company decided to only buy the product at the supplier when there is a sales order for it. The Supply Method will be Buy. He sets the Cost Price to 300 and the Sales Price to 541.25, as shown in the screenshot Product (page 9). Mitchell selects the product category OfficeSecrets. Now he just has to add the supplier from whom he will buy the desks. He clicks the Suppliers tab, then clicks New. He clicks the Magnifying glass to get a list of suppliers, from which he selects **Wood y Wood Pecker**. He sets the minimal quantity to 1 and clicks the Save & Close button. He takes a look at the other tabs and decides to keep the default values. He then clicks the Save button to store the new product.

Figure 2.2: Product

3. Warehouse and locations

Now Thomas will have a look at how the warehouse and the locations have been organised.
Configuring locations

We will not create a warehouse and configure locations in this chapter. For more information, please refer to the chapter *Stock Locations* (page 31) later in this book. Just have a look at the list of locations defined with the demo data.

Warehouse and Location Structure

OpenERP has three predefined top-level location types: **Physical Locations** which define where your stock is physically stored, **Partner Locations** for the customer and supplier stock and **Virtual Locations** representing counterparts for procurement, production and inventory. Thomas clicks *Warehouse → Configuration → Warehouse Management → Locations* to display a list view of the locations.

<table>
<thead>
<tr>
<th>LOCATION NAME</th>
</tr>
</thead>
<tbody>
<tr>
<td>Physical Locations</td>
</tr>
<tr>
<td>Physical Locations/OpenERP S.A.</td>
</tr>
<tr>
<td>Physical Locations/OpenERP S.A./Output</td>
</tr>
<tr>
<td>Physical Locations/OpenERP S.A./Stock</td>
</tr>
<tr>
<td>Physical Locations/OpenERP S.A./Stock/Shelf 1</td>
</tr>
<tr>
<td>Physical Locations/OpenERP S.A./Stock/Shelf 2</td>
</tr>
<tr>
<td>Physical Locations/Shop 1</td>
</tr>
<tr>
<td>Physical Locations/Shop 2</td>
</tr>
<tr>
<td>Partner Locations</td>
</tr>
<tr>
<td>Partner Locations/Customers</td>
</tr>
<tr>
<td>Partner Locations/Customers/European Customers</td>
</tr>
<tr>
<td>Partner Locations/Customers/Non European Customers</td>
</tr>
<tr>
<td>Partner Locations/Internal Shippings</td>
</tr>
<tr>
<td>Partner Locations/Suppliers</td>
</tr>
<tr>
<td>Partner Locations/Suppliers/IT Suppliers</td>
</tr>
<tr>
<td>Partner Locations/Suppliers/IT Suppliers/Generic IT Suppliers</td>
</tr>
<tr>
<td>Partner Locations/Suppliers/IT Suppliers/Maxtor Suppliers</td>
</tr>
<tr>
<td>Virtual Locations</td>
</tr>
<tr>
<td>Virtual Locations/Inventory loss</td>
</tr>
<tr>
<td>Virtual Locations/Procurements</td>
</tr>
</tbody>
</table>

*Figure 2.3: Location Structure*

4. Create a sales quotation
The customer Clarkson asked to receive a quotation for two Office Desks from the OfficeSecrets series. Thomas enters the sales quotation.

Sales Quotation / Order

Thomas goes to Sales → Sales → Sales Orders. He clicks the New button, to make a quotation. He enters Clarkson in the Customer field. Now he can enter the products he will be selling. Next to Sales Order Lines, Thomas clicks the New button to enter sales order lines. He selects the Desk product and changes the quantity to 2 as specified in the screenshot fig-so. Thomas clicks the Save & Close button. Then he clicks Compute to see the total price of the quotation. He opens the Other Information tab because he wants the sales invoice to be created from the picking. So he changes the Shipping Policy to Invoice from the Picking. To print the quotation, he clicks Quotation / Order in the Reports section at the right side of the screen.

Figure 2.4: Sales Order

Price Lists

In this chapter, the Public Pricelist will be used. Later on, you will learn more about creating price lists.

5. Confirm the sales order

John Smith calls Thomas to tell him that he agrees with the quotation. Thomas now confirms the sales order.
Sales Quotation / Order

Thomas goes to Sales → Sales → Sales Orders. He enters Clarkson in the Customer field and then clicks Search. Thomas clicks the sales order to open it. He clicks the Confirm Order button to make a sales order from the quotation. To print the sales order, he clicks Quotation / Order in the Reports section at the right side of the screen.

Order Confirmation

When you click Confirm Order, red text will be displayed at the top of the screen depending on the parameters of the sales order. In our example, you will see two text lines, one about the quotation conversion and another one about the delivery order. You can click the second line to be directed to the delivery order. You can also open the delivery order from the History tab of the sales order.

6. Open the delivery order and run the scheduler

The goods have to be delivered to the customer, but Thomas notices that the desks are not available in stock. Because the Desk was defined as a Make to order & Buy product, OpenERP will automatically create a procurement order on confirmation of a sales order, allowing you to directly generate a purchase order.

OpenERP has a scheduler that will run by default every day. In this case, Jason, your company’s Purchaser, will run the scheduler manually.

Scheduler

Jason goes to Warehouse → Schedulers. He clicks Compute Schedulers because he needs to purchase material and wants to check whether anything needs to be added. In the Wizard, Jason clicks Compute Schedulers to start the computation.

7. Change the purchase request and confirm it

Now OpenERP will have created procurements (in this example purchase requests) for the products that need to be supplied.
CHAPTER 2. COMPLETE EXAMPLE: SELL, CHECK THE STOCK, PURCHASE

**Purchase Requests**

Jason goes to *Purchases → Purchase Management → Request for Quotation*. He notices the purchase request for *Wood y Wood Pecker*, and clicks the yellow pencil to open it in Edit mode. Now he decides to purchase some extra desks, because Luke, the Sales Manager, told him he expects more sales. To do this, he clicks the yellow pencil in front of the order line and changes the quantity to 10. He clicks the *Save & Close* button, then he clicks *Compute* to see the total price of the quotation. From the *Delivery & Invoicing* tab, he specifies that the invoice has to be created from the picking (*Invoicing Control From Picking*). To confirm the purchase order, he just has to click the *Convert to Purchase Order* button.

---

8. Receive the products

The supplier Wood y Wood Pecker sends the goods to your company. Jason receives the goods and enters this receipt in OpenERP.

**Incoming Shipments**

Jason goes to *Warehouse → Warehouse Management → Incoming Shipments*. He notices the incoming shipment for Wood y Wood Pecker, and clicks the green arrow to start receiving the products. He clicks the *Validate* button to confirm that the desks have been received from the supplier. From the *Incoming Shipments* list view, he notices that the Delivery order for the customer is now ready to process (red text at the top of the screen). He wants to check the stock of Desks and goes to *Warehouse → Product → Products*. In the *Name* field, Jason types *desk*, then clicks *Search*. The real stock is 10, the virtual stock is 8, because of the confirmed sales order for two desks.

---

**List versus Form view**

You can receive / deliver goods from both list and form view. You can also receive / deliver goods by product instead of by complete order.

---

9. Create the draft purchase invoice

Because the purchase order was set to be invoiced from the picking, Jason can now create the draft invoice, which allows for easy invoicing control.
Draft Purchase Invoice

Jason returns to Warehouse → Warehouse Management → Incoming Shipments and clicks Clear. He opens the extended filters and clicks the To Invoice button. He ticks the check box in front of the incoming shipment to be invoiced and then clicks the Create Invoice action in the Reports section at the right side of the screen. He selects the Purchase Journal and clicks Create to generate the draft invoice. The screen with the supplier invoice will open. We will get back to this later.

Figure 2.5: Create Invoice from Incoming Shipments

10. Deliver the goods to the customer and create draft sales invoice

The Desks are now available in stock and can be delivered to the customer. In the warehouse, they check the open delivery orders.

Delivery

Randy from the warehouse goes to Warehouse → Warehouse Management → Delivery Orders to check the goods ready for delivery. He clicks the yellow pencil to open the delivery order. He clicks the Process button to deliver the 2 desks, then he clicks Validate.

11. Create the sales invoice

Thomas now checks whether the desks have been delivered to his customer. He can check this from the sales order, or he can tell from the status of the delivery order.
Creating a Sales Invoice

To create the draft sales invoice, Thomas has several possibilities.

He opens Sales → Invoicing → Deliveries to Invoice and selects the corresponding delivery for invoicing by ticking the check box and clicking the Create Invoice action in the Reports section at the right of the screen.

He goes to Warehouse → Warehouse Management → Delivery Orders, and clicks the Create Invoice button.

He goes to the list of sales orders, and opens the sales order concerned. Thomas clicks the History tab, clicks the picking list and then the Create Invoice button. He selects the Sales Journal and clicks the Create button.

The draft invoice is now displayed in list view. Thomas opens the invoice and clicks the Validate button. To print the invoice, he clicks the Print Invoice button, or the Invoices action in the Reports section at the right of the screen. The printed invoice will automatically be added as pdf document to Attachments.

12. Create the purchase invoice

Robin, the accountant, now receives the invoice from his supplier. He can do the invoicing control according to the picking directly from the Purchase Invoices screen.

Invoice Control

Robin goes to Accounting → Suppliers → Supplier Invoices and opens the Wood y Wood Pecker invoice. Robin verifies whether the invoice from the supplier matches this draft invoice created from the picking order. The invoice indeed matches and he clicks the Approve button to confirm the invoice and assign a document number to it.

Purchaser

The purchaser can also do the invoice matching from Purchases → Invoice Control → Supplier Invoices to Receive.

Below you find a graphical representation of the sales flow we explained before; the part from quotation to invoice. This view is available in OpenERP. You can open this Process view by clicking the question mark next to the Sales Order title.
Figure 2.6: From Quotation to Invoice
Let’s get Started and Configure a New Instance

Now that you have discovered some of the many possibilities of OpenERP from a tour of the demonstration database, you will develop a real case. An empty database provides the starting point for testing a classic workflow from product sales to purchase, completing your guided tour and your getting familiar with OpenERP.

A database loaded with demonstration data is very useful to understand OpenERP’s general capabilities. But to explore OpenERP through a lens of your own company’s needs, you should start with an empty database. You will work in this chapter on a minimal database containing no demonstration data, so that there is no confusion about what you created. You will keep the database you have created, to allow you to build on it throughout the rest of this book if you want to.

You will develop a real case through the following phases:

1. Specify a real case;
2. Describe the functional needs;
3. Configure the system with the essential modules;
4. Carry out the necessary data loading;
5. Test the system with your database.

The case is deliberately simple to provide you with a foundation for the more complex situations you might have to handle in your company. Throughout this chapter, we assume that you access OpenERP through its web interface. And it is also assumed (as in the rest of this book) that you are using the latest download of OpenERP version 6, the stable production version at the time of writing (not the trunk version, which is likely to have new and potentially unstable features).

3.1 Business Example

In this example, you will configure a system that enables you to:

- buy products from a supplier,
- stock the products in a warehouse,
- sell these products to a customer.

The system should support all aspects of invoicing, payments to suppliers and receipts from customers.
3.2 Basic Settings

For this business case, you will have to model:

- accounts and account types,
- the suppliers and a supplier category,
- the customers and a customer category,
- some products and a product category,
- an inventory,
- a purchase order,
- a sales order,
- invoices,
- payments.

To test the system, you will need at least one supplier, one customer, one product, a warehouse, a minimal chart of accounts and a bank account.

3.3 Get your Database Up and Running without Demo Data

Please note that the new database you have to create, will not include demo data and only the minimally required functionality as a starting point. You will need to know your super administrator password for this – or you will have to ask your ICT manager for the password to be able to create this database.

Please refer to Configuring your OpenERP (page 3) for more information about how to create a new database that you will give the name of your company.

As a reminder, please find the steps below, without further explanation.

Start by creating a new database from the Welcome page by clicking Databases and then completing the following fields on the Create Database form.

- **Super admin password**: by default it is admin, if you or your system administrator have not changed it,
- **New database name**: YourCompany,
- **Load Demonstration data checkbox**: unchecked,
- **Default Language**: English (US),
- **Administrator password**: admin,
- **Confirm password**: admin.
Press *Create* to start creating the database.

OpenERP suggests that you configure your database using a series of questions. In the software, these series of questions are managed through so-called *Configuration Wizards*.

**Click the Start Configuration button to continue.**

The next configuration wizard will help you to decide what your user interface will look like, whether the screens will only show the most important fields - *Simplified* - or whether you also want to see the fields for the more advanced users, the *Extended* view. Select *Extended* and click *Next* to continue.

**User Preferences**

You can easily switch from Simplified to Extended view by changing your *User Preferences*.

In the next wizard, you can fill your company data, select your company’s base currency and add your company logo which can be printed on reports. Fill out the required data and click *Next* to continue.

**Select the** Warehouse Management, Purchase Management, Sales Management and Accounting & Finance **business applications for installation and click *Install*.** Now OpenERP will start to install these four applications, allowing you to do a complete cycle, from sales / warehouse / purchase to invoice. You will have to wait for the next configuration wizard to be displayed (*Loading* will appear).

![Install Applications](image)

*Figure 3.1: Selecting the Required Functionality*

**Reconfigure**

Keep in mind that you can change or reconfigure the system any time, for instance through the *Reconfigure* option in the main bar.

When you choose a business application for installation, OpenERP will automatically propose to add or configure related (smaller) applications to enrich your system. When you install Sales, OpenERP will also ask you whether you want to install Invoicing Journals for instance.
Skip the step that asks you to configure your Accounting Chart, because you will learn how to create accounts.

In the Purchases Application Configuration screen, simply click Configure to continue the database creation.

The following wizards will appear:

- Configure your Sales Management application: click Configure to accept the default settings (no options checked).
- Configure your Accounting application: click Configure to accept the default settings.
- Configure Sales Order Logistics: click Next to accept the default settings.

OpenERP’s menu will be displayed, because your system is now ready for actual configuration.

<table>
<thead>
<tr>
<th>Setup Wizard</th>
</tr>
</thead>
</table>
| You will have to go through the Setup wizard in steps. You have two options:  

1. If you click the Start Configuration button, OpenERP guides you through a series of steps to: Configure Your Interface - proceed with Simplified (the other option is Extended); and Configure Your Company Information - enter a Company Name and select a Currency for your company. Then OpenERP helps you to install various applications with different functionality through wizards.  

   • OR -  

2. When you click the button Skip Configuration Wizards, you can have the screen as shown in screenshot Starting the minimal database (page 21). Then you can start working with this minimal database (we will not use this option here). |
3.4 Fit your Needs

Functional needs can be provided by core modules from OpenERP. You just have to decide which functionality you want in your system. As explained before, you can click the Check Box of the corresponding application. Another way of installing modules, is to go the Administration → Modules → Modules menu. Here you will find a list of all modules available in OpenERP. You can also check our website http://apps.openerp.com/ for more information about modules.

To manage your logistics, you do not need all the elements described in this book. But we find it very important to include an integrated flow, from the first quotation to the final billing of the customers including all the steps: quotation, order, receiving goods, inventory, shipping and billing.

To manage such a flow, we need at least the following applications:

- Sales Management (the sale module).
- Purchase Management (the purchase module),
- Warehouse Management (the stock module),
- Accounting & Finance (the account module),

If you only want to manage your logistics, the Warehouse Management application will do. Because in this book we want to show a complete flow, you need to install more applications.
When you log on, OpenERP will display the opening screen with all selected business applications installed.

![Figure 3.3: Database with all Required Functionality for this Example](image)

You will create all the elements in the database that you need to carry out the use case. These are specified in the functional requirements.

**Examples**

Of course, we will provide examples for you to configure your database, such as customers and suppliers. Make sure to use your own data instead.

### 3.4.1 Configuring Accounts

You need to start with a minimal set of accounts, and therefore you will need a couple of account types to determine the account’s use, how it will be transferred at year closing, and what category it belongs to. You can structure your accounts into a chart at any time (and, in fact, you can structure them into several additional charts at the same time as you will see in the on line chapter of the OpenERP book), so you do not need to be concerned unduly about structure.

**Account Types**

To create account types, go to *Accounting → Configuration → Financial Accounting → Accounts → Account Types* and click the *New* button. You will need the following six types, the first of which is shown in figure *New Account Type* (page 23). Click *Save* to confirm each account type.
### Table 3.1: Defining Account Types

<table>
<thead>
<tr>
<th>Acc. Type Name</th>
<th>Code</th>
<th>P&amp;L / BS Category</th>
<th>Deferral Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>View</td>
<td>view</td>
<td>/</td>
<td>None</td>
</tr>
<tr>
<td>Income</td>
<td>income</td>
<td>Profit &amp; Loss (Income Accounts)</td>
<td>None</td>
</tr>
<tr>
<td>Expense</td>
<td>expense</td>
<td>Profit &amp; Loss (Expense Accounts)</td>
<td>None</td>
</tr>
<tr>
<td>Cash</td>
<td>cash</td>
<td>Balance Sheet (Assets Accounts)</td>
<td>Balance</td>
</tr>
<tr>
<td>Receivable</td>
<td>receiv</td>
<td>Balance Sheet (Assets Accounts)</td>
<td>Unreconciled</td>
</tr>
<tr>
<td>Payable</td>
<td>pay</td>
<td>Balance Sheet (Liability Accounts)</td>
<td>Unreconciled</td>
</tr>
</tbody>
</table>

#### Figure 3.4: New Account Type

**Accounts**

To create accounts, go to Accounting → Configuration → Financial Accounting → Accounts → Accounts and click the New button.

You need accounts to keep track of your customers and suppliers, two more to sell and buy goods, and one for the payment and receipt of funds. And also one ‘organizing’ account that is just a view of the other five. So basically you will need at least the following six accounts, one of which is shown in New Account (page 24). Click Save to confirm each account.

**Chart of Accounts Structure**

When you create a chart of accounts, you should always start with the main view account to define the chart, as shown in the table (Minimal Chart). This will allow you to easily link new accounts to the correct chart directly.
Table 3.2: Defining Accounts

<table>
<thead>
<tr>
<th>Name</th>
<th>Code</th>
<th>Parent</th>
<th>Internal Type</th>
<th>Account Type</th>
<th>Reconcile</th>
</tr>
</thead>
<tbody>
<tr>
<td>Minimal Chart</td>
<td>0</td>
<td>0 Minimal Chart</td>
<td>View</td>
<td>View</td>
<td>unchecked</td>
</tr>
<tr>
<td>Payable</td>
<td>AP</td>
<td>0 Minimal Chart</td>
<td>Payable</td>
<td>Payable</td>
<td>checked</td>
</tr>
<tr>
<td>Receivable</td>
<td>AR</td>
<td>0 Minimal Chart</td>
<td>Receivable</td>
<td>Receivable</td>
<td>checked</td>
</tr>
<tr>
<td>Bank</td>
<td>B</td>
<td>0 Minimal Chart</td>
<td>Liquidity</td>
<td>Cash</td>
<td>unchecked</td>
</tr>
<tr>
<td>Purchases</td>
<td>P</td>
<td>0 Minimal Chart</td>
<td>Regular</td>
<td>Expense</td>
<td>unchecked</td>
</tr>
<tr>
<td>Sales</td>
<td>S</td>
<td>0 Minimal Chart</td>
<td>Regular</td>
<td>Income</td>
<td>unchecked</td>
</tr>
</tbody>
</table>

The Account Type entry is taken from the list of types that you just created. Although it looks a bit like a text box, it does not behave in quite the same way. A single Del or Backspace keystroke is all you need to delete the whole text, and when you type the name (or part of the name), you still need to associate that text with the entry by clicking the Tab or Enter key to confirm your selection. You can also use the Search icon to open a list of available account types.
Properties

You now define some default properties, so that you do not have to think about which account is used for a certain transaction every time you do something. The main new properties are the four that associate accounts payable and receivable to partners, and expenses and income to product categories.

Create properties using Administration → Configuration → Parameters → Configuration Parameters and then clicking the New button. This menu is only available in Extended view.

**Selecting the correct field**

When you have several fields with the same name, make sure to select the field for which the Field Name corresponds to the property name you are defining. Note that you can also duplicate properties and then change the required fields.

<table>
<thead>
<tr>
<th>Name</th>
<th>Field</th>
<th>Type</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>property_account_payable</td>
<td>Account Payable</td>
<td>Many2One</td>
<td>(account.account) AP Payable</td>
</tr>
<tr>
<td>property_account_receivable</td>
<td>Account Receivable</td>
<td>Many2One</td>
<td>(account.account) AR Receivable</td>
</tr>
<tr>
<td>property_account_expense_categ</td>
<td>Expense Account</td>
<td>Many2One</td>
<td>(account.account) P Purchases</td>
</tr>
<tr>
<td>property_account_income_categ</td>
<td>Income Account</td>
<td>Many2One</td>
<td>(account.account) S Sales</td>
</tr>
</tbody>
</table>

To check the result of your configuration, you can go to Accounting → Customers → Customers and open the form containing your company data. On the Accounting tab, you will notice that both the default account receivable and account payable have been filled.

**Mistakes in configuring accounts and properties**

It is easy to make mistakes in configuring accounts and their properties, but the consequences are not immediately obvious. You will mostly discover mistakes when trying to make a Purchase or Sales Order (see later, for example, Purchase Order (page 36)), where the accounts are required fields or, if you are diligent, when you set up Partners.

If you configure them correctly at this stage, then fields will be completed automatically and you will never know a thing. If you do not configure all this correctly, then you will not be able to save the order form until you have corrected the problem or until you manually set the accounts.

Since this configuration is quite tedious, you would do best by finding a certified Chart of Accounts that has already been set up to meet your needs, and adapt the predefined chart if necessary.
### 3.4.2 Configuring Journals

You will also need to configure some journals, which are used to record the transactions from one account to another when invoices are raised and then paid. Create journals from the menu **Accounting → Configuration → Financial Accounting → Journals → Journals** and then click the **New** button.

**Default Values**

Notice that when you select the journal type, the Display Mode will already be preset. An entry sequence for the journal will be created automatically when you save the journal. The default debit and credit account will be used as a counterpart when encoding manual journal entries. Debit and credit accounts are mandatory for bank journals.

<table>
<thead>
<tr>
<th>Journal Name</th>
<th>Code</th>
<th>Type</th>
<th>Display Mode</th>
<th>Default Debit Account</th>
<th>Default Credit Account</th>
</tr>
</thead>
<tbody>
<tr>
<td>Purchase Journal</td>
<td>PUJ</td>
<td>Purchase</td>
<td>Sale/Purchase Journal View</td>
<td>P Purchases</td>
<td>P Purchases</td>
</tr>
<tr>
<td>Sales Journal</td>
<td>SAJ</td>
<td>Sale</td>
<td>Sale/Purchase Journal View</td>
<td>S Sales</td>
<td>S Sales</td>
</tr>
<tr>
<td>Bank Journal</td>
<td>BNK</td>
<td>Bank and Cheques</td>
<td>Bank/Cash Journal View</td>
<td>B Bank</td>
<td>B Bank</td>
</tr>
</tbody>
</table>

In this example, validating a Purchase Order creates a draft invoice (see later, again for example, *Purchase Order* (page 36)), where a journal is required.

As with accounts and properties, if you configure them correctly at this stage, the fields will be completed automatically and you will never know a thing. If you do not configure all this correctly, there will be errors with the order form or corresponding draft invoice, until you have corrected the problem or until you manually set the journal.

### 3.4.3 Configuring the Main Company

In case you had chosen to **Skip Configuration Wizards** when you first created the database, you may configure your company information in the following manner. Start configuring your database by typing your company’s name in the **Main Company**. When you print standard documents such as quotations, orders and invoices you will find this configuration information used in the document headers and footers.

To do this, click **Sales → Address Book → Customers** and click the name of the only company there, which is **YourCompany**. This gives you a read-only form view of the company, so make it editable by clicking the **Edit** button to the upper left of the form.
Editable Form in the Web Client
When toggling from the list view to the form view of an item, you can generally click its name in the list view to show a non-editable view, or the pencil icon by the left-hand edge of the line to open it in an editable view. You can toggle between editable and non-editable once you are in form view.

Change the contact name to match your first name and name. The company name and the contact name below are just an example.

- **Name**: Ambitious Plumbing Enterprises.
- **Contact Name**: George Turnbull.

Before you save this, look at the partner’s accounting setup by clicking the Accounting tab. The fields **Account Receivable** and **Account Payable** have account values that were taken from the account properties you just created. You do not have to accept those values: you can enter any suitable account you like at this stage, although OpenERP limits the selection to accounts that make accounting sense.

Back at the first tab, General, change any other fields you like, such as the address and phone numbers, then click Save. This changes one Contact for the Partner, which is sufficient for the example.

From the MAIN MENU, click Administration → Companies → Companies and edit the only entry there. Please note that you have to keep your own company data, but for the example we use the Ambitious Plumbing company.

- **Company Name**: AmbiPlum,
- **Partner**: should already show Ambitious Plumbing Enterprises,
- **Report Header**: Ambitious Plumbing,
- **Report Footer 1**: type your slogan, i.e. Best Plumbing Services, Great Prices,
- **Report Footer 2**: type your company details, such as bank account or Ambitious – our Registered Company Details.

Figure Changing Company Details (page 28) shows the effect of this. You can also change various other company-wide parameters for reports and scheduling in the other tabs, and you can upload a company logo of a specific size for the reports. Click Save to store the changes.

You can leave the currency at its default setting of EUR for this example. Or you can change it in this Company and the two default Pricelists (Sales → Configuration → Pricelists → Pricelists) if you did not set the correct company currency in the Configuration Wizard.

**Currency**
The examples in this book are in USD and EUR. You, the reader, can use your home currency instead.
3.4.4 Creating Partner Categories, Partners and their Contacts

You will now create a supplier category and a customer category. Partner categories are useful for organizing groups of partners, but have no special behaviour that affects partners, so you can assign them as you like. Then you will define one supplier and one customer, with a contact for each.

To do this, go to the menu Sales → Configuration → Address Book → Partner Categories and click New to open a new form for defining Partner Categories. Define the two categories that follow by just entering their Category Name and saving them:

- Suppliers,
- Customers.

Then create two partners from the menu Sales → Address Book → Customers. OpenERP allows you to create both suppliers and customers from this menu. Please note that we provide some example data, but of course you should define your own customers and suppliers. Feel free to also complete the address, which we don’t do in our example. Click the New button to open a blank form and then add the following data for the first partner:

- Name: Plumbing Component Suppliers,
- Customer checkbox: unchecked,
- Supplier checkbox: checked,
- Contact Name: Jean Poolley,
- Address Type: Default,
- click Add and select Suppliers to add the category to the Partner Categories field by selecting it from the Search Partner Categories list,
- then save the partner by clicking the Save button.
Figure New Partner Form (page 29) shows the result.

**Contact Types**

If you have recorded several contacts for the same partner you can specify which contact is used for various documents by specifying the Address Type.

For example, the delivery address can differ from the invoice address for a partner. If the Address Types are correctly assigned, OpenERP can automatically select the appropriate address during the creation of the document – an invoice is addressed to the contact that has been assigned the Address Type of Invoice, otherwise to the Default address.

For the second partner, proceed just as you did for the first, with the following data:
• **Name**: Smith and Offspring,

• **Customer checkbox**: checked,

• **Supplier checkbox**: unchecked,

• **Contact Name**: Stephen Smith,

• **Address Type**: Default,

• add Customers in the **Categories** field,

• **Save** the form.

To check your work, you can go to the menu **Sales → Configuration → Address Book → Partner Categories** and click on each category in turn to see the companies in the category.

---

**Multiple Partner Categories**

If this partner was also a supplier, then you would add Suppliers to the categories as well, but there is no need to do so in this example. You can assign a partner to multiple categories at all levels of the hierarchy.

---

### 3.4.5 Creating Products and their Categories

Unlike partner categories and their assigned partners, product categories do have an effect on the products assigned to them – and a product may belong to only one category. Under the main menu link **Warehouse or Sales**, select the menu **Configuration → Product → Products Categories** and click **New** to get an empty form for defining a product category.

Enter **Radiators** in the **Name** field. Click **Save**. You will see that other fields, specifically those in the **Accounting Properties** section, have been automatically filled in with values of accounts and journals. These are the values that will affect products – equivalent fields in a product will take on these values if they, too, are blank when their form is saved.

---

**Property Fields**

Properties have a rather unusual behaviour. They are defined by parameters in the menus in **Administration → Configuration → Parameters → Configuration Parameters**, and they update fields only when a form is saved, and only when the fields are empty at the time the form is saved. You can manually override any of these properties as you need.

Property fields are used throughout the OpenERP system and extensively in a multi-company environment. There, property fields in a partner form can be populated with different values depending on the user’s company. For example, the payment conditions for a partner could differ depending on the company from which it is addressed.
CHAPTER 3. LET'S GET STARTED AND CONFIGURE A NEW INSTANCE

**UOM**

UOM is an abbreviation for Unit of Measure. OpenERP manages multiple units of measure for each product: you can buy in tons and sell in kgs, for example. The conversion between each category is made automatically (so long as you have set up the conversion rate in the product form first).

**Managing Double Units of Measure**

The whole management of stock can be carried out with double units of measure (UOM and UOS – for Unit of Sale). For example, an agro-food company can stock and sell ham by piece, but buy and value it by weight. There is no direct relationship between these two units, so a weighing operation has to be done.

This functionality is crucial in the agro-food industry, and can be equally important in fabrication, chemicals and many other industries.

Now create a new product through the Warehouse or Sales menu:

1. Go to Products → Products and click New.
2. Create a product – type Titanium Alloy Radiator in the Name field.
3. The Product Type field should be assigned as Stockable Product. The fields Procurement Method, Supply method, Default Unit Of Measure, and Purchase Unit Of Measure should stay at their default values. For more information about these methods, please refer to chapter Procurement Methods – Make to Stock and Make to Order (page 134).
4. Enter 57.50 into the Cost Price field and 132.50 into the Sale Price field.
5. Click the Search icon to the right of the Category field to select the Radiators category.
6. Click the Accounting tab, then click Save and observe that Accounting Properties here remain empty. When product transactions occur, the Income and Expense accounts that you have just defined in the Product Category are used by the Product unless an account is specified here, directly in the product, to override that.
7. Once the product is saved, it changes to a non-editable state. If you had entered data incorrectly or left a required field blank, an error message would pop-up, the form would have stayed editable and you would need to click from tab to tab to find a field colored red that would have to be correctly filled in.

**3.4.6 Stock Locations**

Click Warehouse → Inventory Control → Location Structure to see the hierarchy of stock locations. These locations have been defined by the minimal default data loaded when the database was created. You will use this default structure in this example.
OpenERP has three predefined top-level location types, Physical Locations and Partner Locations that act as their names suggest, and Virtual Locations that are used by OpenERP for its own purposes.

1. From the **Main Menu** click **Warehouse → Configuration → Warehouse Management → Locations** to reach a list view of the locations (not the tree view).

2. Click the **Clear** button to display a complete list of all predefined locations.

3. Click the name of a location, such as **Physical Locations/Ambitious Plumbing Enterprises** to open a descriptive form view. Each location has a **Location Type** and a **Parent Location** that defines the hierarchical structure. While you are here you might have to change the location’s name to **Ambitious Plumbing Enterprises**.

4. From the **Main Menu** click **Warehouse → Configuration Warehouse Management → Warehouses** to view a list of warehouses. There is only the one at the moment, named after your company, or in the example **Ambitious Plumbing Enterprises**.

A Warehouse contains an input location, a stock location and an output location for sold products. You can associate a warehouse with a partner to give the warehouse an address. That does not have to be your own company (although it can be); you can easily specify another partner who may be holding stock on your behalf.
Location Structure

Each warehouse is composed of three locations Location Input, Location Output, and Location Stock. Your available stock is given by the contents of the Location Stock and its child locations.

So the Location Input can be placed as a child of the Location Stock, which means that when Location Stock is interrogated for product quantities, it also takes into account the contents of the Location Input. Location Input could be used as a goods-in QC location. The Location Output must never be placed as a child of Location Stock, since items in Location Output, which can be considered to be packed ready for customer shipment, should not be thought of as available for sales elsewhere.

3.4.7 Setting up a Chart of Accounts

You can set up a chart of accounts during the creation of a database, but for this exercise you will start with the minimal chart that you created (just a handful of required accounts without hierarchy, tax or subtotals).

A number of account charts have been predefined for OpenERP, some of which meet the needs of national authorities (the number of those created for OpenERP is growing as various contributors create and freely publish them). You can take one of those without changing it if it is suitable, or you can take any chart as your starting point and design a complete chart of accounts to meet your exact needs, including accounts for inventory, asset depreciation, equity and taxation.

You can also run multiple charts of accounts in parallel – so you can put all of your transaction accounts into several charts, with different arrangements for taxation and depreciation, aggregated differently for various needs.

Before you can use any chart of accounts, you need to specify a Fiscal Year. This defines the different time periods available for accounting transactions.

Create a Fiscal Year manually from Accounting → Configuration → Financial Accounting → Periods → Fiscal Years.

- In the Fiscal Year field, type the name of the current fiscal year (e.g. 2011),
- In the Code field, type the code of the current fiscal year (e.g. 11 or 2011),
- In the Start Date field, type the starting date of your company’s fiscal year (e.g. 01/01/2011),
- In the End Date field, type the ending date of your company’s fiscal year (e.g. 12/31/2011),
- Click the Create Monthly Periods button, if you have monthly declarations or click the Create 3 Months Periods button for quarterly declarations,
- Usually you will also create an extra period 00 to post your opening balance and outstanding invoices. To do this, click the New button, then type 00/2011 as the Period Name, 00/2011 as
the Code and the first day of your financial year as the Start of Period and the End of Period dates. Then check the Opening/Closing Period checkbox.

Click Accounting → Charts → Charts of Accounts to open a Chart of Accounts form where you define exactly what you want to see. Simply click Open Charts to accept the defaults and display a hierarchical structure of the accounts.

### 3.4.8 Make a Backup of the Database

If you know the super-administrator password, make a backup of your database using the procedure described below. Then restore it to a new database: testing.

As a super-administrator, you do not only have rights to create new databases, but also to:

- backup databases,
- delete databases,
- restore databases.

All of these operations can be carried out from the Databases button in the web client’s Login screen.

---

**Backup (copy) a Database**

To make a copy of a database, go to the web Login screen and click the Databases button. Then click the Backup button, select the database you want to copy and enter the super-administrator password. Click the Backup button to confirm that you want to copy the database.

---

**Drop (delete) a Database**

To delete a database, go to the web Login screen and click the Databases button. Then click the Drop button, select the database you want to delete and enter the super-administrator password. Click the Drop button to confirm that you want to delete the database.

---

**Restore a Database**

To restore a database, go to the web Login screen and click the Databases button. Then click the Restore button, click the Choose File button to select the database you want to restore. Give the database a name and enter the super-administrator password. Click the Restore button to confirm that you want to install a new copy of the selected database. To restore a database, you need to have an existing copy, of course.
Duplicating a Database

To duplicate a database, you can:

1. make a backup file on your PC from this database.
2. restore this database from the backup file on your PC, and give it a new name.

This can be a useful way of making a test database from a production database. You can try out the operation of a new configuration, new modules, or just the import of new data.

A system administrator can configure OpenERP to restrict access to some of these database functions so that your security is enhanced in normal production use.

This operation enables you to test the new configuration on testing so that you can be sure everything works as designed. Then if the tests are successful, you can make a new database from, perhaps called live or production, for your real work.

From here on, connect to this new testing database logged in as admin if you can. If you have to make corrections, do that on YourCompany and copy it to a new testing database to continue checking it.

Or you can just continue working with the YourCompany database to get through this chapter. You can recreate YourCompany quite quickly if something goes wrong and you cannot recover from it but, again, you would need to know your super-administrator password for that.

3.5 Testing a Complete Purchase Cycle according to an Example

To familiarize yourself with the system workflow, you will test a purchase-sales workflow in two phases.

The first consists of a product purchase, which requires the following operations:

1. Place a purchase order with Plumbing Component Suppliers for 10 Titanium Alloy Radiators at a unit price of 56.00.
2. Receive these products at your Goods In.
3. Generate a purchase invoice.
4. Pay your supplier.

Then, you will sell some of these products, using this sequence:

1. Receive a sales order for 6 Titanium Alloy Radiators from Smith and Sons, sold at a unit price of 130.00.
2. Dispatch the products.
3. Invoice the customer.
4. Receive the payment.

### 3.5.1 Purchase Order

To place a Purchase Order with your supplier, use the menu *Purchases → Purchase Management → Purchase Orders* and click the *New* button.

Complete the following field:

- **Supplier**: Plumbing Component Suppliers.

As you complete the *Supplier* field, OpenERP automatically completes the *Address* field and the *Pricelist* field from information it takes from the Partner record.

Enter the following information in the Purchase Order Lines (click *New*):

- **Product**: Titanium Alloy Radiator - type in part of this name then press the tab key to complete it, or click the *Search* icon at the end of the line to bring a search box (if product is previously configured)

When you have selected a product on the product line, OpenERP automatically completes the following fields from information it finds in the *Product* record:

- **Product UOM**: the unit of measure for this product,
- **Description**: the detailed description of the product,
- **Scheduled Date**: based on the product lead time,
- **Unit Price**: the unit price of the product,
- **Analytic account**: if any account is specified and if you belong to the User Group *Useability/Analytic Accounting* (see menu *Administration → Users → Users*) then it will appear on the order line (it is not in this example),
- **Taxes**: applicable taxes defined in the partner, if specified, otherwise in the product, if specified (there are no taxes in this example).

You can edit any of these fields to suit the requirements of the purchase order at the time of entry. Change the:

- **Quantity**: 10,
- **Unit Price**: to 56.00.
Save the order line and close the Order Line window by clicking the Save & Close button. You can then save the whole one-line order by clicking Save, which makes the form non-editable.

It is now in a state of Request for Quotation. To approve the quotation, click Convert to Purchase Order, which corresponds to an approval from a manager or from Accounts within your own company and moves the order into Approved state.

If you click the Delivery & Invoicing tab you will see the delivery Destination is your own company’s Stock location and that the invoice was created from the order. It is not entirely obvious at this stage, but the invoice is in a draft state so it can be edited and, crucially, it has no accounting impact yet: it is just ready for your accounting group to activate it.

### 3.5.2 Receiving Goods

After confirming the order, you would wait for the delivery of the products from your supplier. Typically this would be somebody in Stores, who would:

1. Open the menu Warehouse → Warehouse Management → Incoming Shipments.

   **From the Purchase Order**
   
   You could have clicked the Receptions link to the right of the Purchase Order to reach the same screen, but this would confuse the purchasing role with the stores role. That link is very useful during testing and training, however.

2. When the Incoming Shipments window appears, select the name of the entry in the list (IN/00001) to display the Packing List itself – you would usually do a search for the supplier name or order number in a list that was larger than this – then click Process to load the Process Document form.

3. Click Validate to indicate that you are receiving the whole quantity of 10 units.

At this point you have accepted 10 units into your company, in a location that you have already seen.

Using the menu Purchases → Products → Products you can find the product Titanium Alloy Radiators with Real Stock and Virtual Stock 10. Open the product form, and click the Stock by Location link at the right side of the screen to see the Real Stock and Virtual Stock of this product in various locations. Now select the checkbox in front of the Stock and Suppliers locations. The right side menu appears. Click the Location Inventory Overview report to see the inventory valuation for each of these two locations.
Traceability in Double-Entry

OpenERP operates a double-entry stock transfer scheme similar to double-entry accounting. Because of this you can carry out various analyses of stock levels in your warehouse, along with the corresponding levels in Partner Location at your Supplier. The double-entry system, similar to that of accounting, enables you to keep track of stock movements quite easily, and to resolve any errors that occur.

3.5.3 Invoice Control

When you have received an invoice from your supplier (which would usually be sent to your Accounts department), go to the menu Accounting → Suppliers → Supplier Invoices to open a list of supplier invoices waiting for receipt. These invoices enable your Accounts Department to match the the price and quantities ordered against the price and quantities on the supplier’s invoice (and since it is not uncommon to receive an invoice showing details more favourable to the supplier than those agreed at the time of purchase, this is a useful function).

In this example, you created an invoice automatically when you confirmed the supplier’s Purchase Order. That is because the Invoicing Control field on the order was set to From Order (the default option). Other options enable you to create invoices at the time of receiving goods or manually. The initial state of an invoice is Draft.

Now click the invoice for your order PO00001 to display its contents. You can compare the goods that you have recorded there with the invoice received from your supplier. If there is a difference, it is possible to change the invoice lines to, for example, add a delivery charge. Select the correct Invoice Date and click Approve to confirm the invoice and put it into the Open state.
Accounting entries are generated automatically once the invoice is validated. You can check the entry from the Other Info tab, in the Journal Entry field. To see the effects on your chart of accounts, go to the menu Accounting → Charts → Chart of Accounts, and click Open Charts at the Chart of Accounts page to see that you have a debit of 560.00 in the Purchases account and a credit of 560.00 in the Payable account.

### Invoice Control

Should your purchase invoice have to be checked by the purchaser first, he can go to the menu Purchases → Invoice Control → Supplier Invoices to Receive to check whether the invoice corresponds with the order (or the goods receipt according to the Invoice Control settings).

### 3.5.4 Paying the Supplier

Select the menu Accounting → Suppliers → Supplier Invoices and click the Unpaid button for a list of supplier invoices that have not yet been paid. In practice, you would search for the invoice by order number or, more generally, for invoices nearing their payment date. You can type PO00001 in the Source Document box to find the invoice.

Open the invoice and click the Pay Invoice button. It opens the Pay Invoice window in new tab with a description of the payment.

Supplier and Date comes automatically from invoice. You just have to enter the Payment Method (i.e. the corresponding bank journal). When you select the payment method, you will notice that the corresponding invoice is displayed in Supplier Invoices and Outstanding Transactions, and that the Amount is filled automatically. Then click the Validate button to post this entry and consider the invoice as Paid.

### Payment of an Invoice

The method described here is for companies that do not use their accounting system to pay bills, but just to record the payments. If you are using the account module with all its features, other, more efficient, methods let you manage payments, such as entering bank statements, reconciling paperwork, using tools for preparing payments, interfacing with banks.

You can monitor the accounting impact of paying the invoice through the chart of accounts available from the menu Accounting → Charts → Chart of Accounts. OpenERP automatically creates accounting entries from the payment, and can reconcile the payment to the invoice. You now have a new transaction that has debited the Payable account with 560.00 and credited the Bank account.

If you look in Accounting → Journal Entries → Journal Entries you will see both accounting transactions, one in the Purchase Journal and another one in the Bank Journal, both with the Posted state.
3.6 Testing a Complete Sales Cycle according to an Example

3.6.1 Sales Order

In OpenERP, sales proposals and sales orders are managed using documents that are based on the same common functionality as purchase orders, so you will recognize the following documents in general but see changes to their detail and to their workflows. To create a new sales proposal, use the menu Sales → Sales → Sales Orders and click the New button which creates a new order as a Quotation, then:

1. Select the Customer Smith and Offspring. This has the effect of automatically completing several other fields: Ordering Contact, Invoice Address, Shipping Address, and the Pricelist Public Pricelist (EUR). They are all only defaults, so these fields can be modified as you need.

2. Click the New button in Sales Order Lines section to open a Sales Order Lines window.

3. Select the product Titanium Alloy Radiator. Although the Product field is not itself required, it is used by OpenERP to select the specific product so that several other fields can be automatically completed on the order line of the quotation, such as Description, Unit of Measure, Unit Price, Procurement Method, Delivery Lead Time, and Taxes.

4. Change the Quantity (UoM) to 6 and the Unit Price to 130.00. Then click Save & Close and the line appears on the quotation form.

5. On the Other Information tab of this Sales Order, select a Picking Policy of Complete Delivery and a Shipping Policy of Invoice on Order After Delivery from the dropdown menu lists.

6. Return to the first tab Sales Order and validate the document by clicking Confirm Order which calculates prices and changes the order’s state from Quotation to In Progress as shown in screenshot Sales Order Form (page 40). If you were in negotiation with the prospective customer, you would click Compute and Save, to keep the document in Quotation state for as long as necessary.
7. In the last tab of the order History, you can see the Picking List that has been created and you will be able to see any invoices that relate to this order when they are generated.

Go to Sales → Products → Products to display a list of products: just the one, Titanium Alloy Radiator, currently exists in this example. Its Real Stock still shows 10.00 but its Virtual Stock now shows 4.00 to reflect the new future requirement of 6 units for dispatch.

### 3.6.2 Preparing Goods for Shipping to Customers

The stores manager selects the menu Warehouse → Warehouse Management → Delivery Orders to get a list of orders to dispatch. For this example, find the Delivery Order related to the sales order which you have created. You should click the Available button, to see all delivery orders, because your delivery order will be in Confirmed state and not yet in Available state. Open the Delivery Order concerned.

**Running Schedulers**

At the moment, your Sales Order is waiting for products to be reserved to fulfil it. A stock reservation activity takes place periodically to calculate the needs, which also takes customer priorities into account. The calculation can be started from the menu Warehouse → Schedulers → Compute Schedulers. Running this automatically reserves products (i.e. the status will be set to Available if the products are in stock).

If you do not want to have to work out your stock needs but have a lean workflow you can install the mrp_jit (Just In Time) module.

Although OpenERP has automatically been made aware that items on this order will need to be dispatched, it has not yet assigned any specific items from any location to fulfil it. It is ready to move 6.00 Titanium Alloy Radiators from the Stock location to the Customers location, so start this process by clicking Check Availability. The Move line has now changed from the Confirmed state to the Available state.

Then click the Process button to reach the Process Document window, where you click the Validate button to transfer the 6 radiators to the customer.

To analyze stock movements that you have made during these operations, go to Warehouse → Product → Products and select the radiator by clicking the checkbox in front of it, then click the action Stock by Location which is at the right most side to see that your stocks have reduced to 4 radiators and the generic Customers location has a level of 6 radiators.

### 3.6.3 Invoicing Goods

Use the menu Accounting → Customers → Customer Invoices to open a list of Sales invoices generated by OpenERP. If they are in the Draft state, it means that they do not yet have any impact on the accounting system. You will find a draft invoice has been created for the order SO001 once you have dispatched the goods because you had selected Invoice on Order After Delivery.
Once you confirm an invoice, OpenERP assigns it a unique number, and all of the corresponding accounting entries are generated. So open the invoice and click **Validate** to do that and move the invoice into an **Open** state with a number of **SAJ/2011/0001**.

You can send your customer the invoice for payment at this stage. Click **Print Invoice** to get a PDF document that can be printed or emailed to the customer.

The PDF of your invoice will automatically be added as an attachment. This gives you a permanent non-editable record of your invoice on the OpenERP system.

Review your chart of accounts to check the impact of these activities on your accounting. You will see the new revenue line from the invoice.

### 3.6.4 Customer Payment

Registering an invoice payment by a customer is essentially the same as the process of paying a supplier. From the menu **Accounting → Customers → Customer Invoices**, click the name of the invoice that you want to mark as paid:

1. Use the **Payment** button which opens a new window **Pay Invoice**.

2. Select the **Payment Method**, for this example select **Bank Journal** then validate the entry.

![Invoice Form](img)

**Figure 3.11: Invoice Form**

Check your Chart of Accounts as before to see that you now have a healthy bank balance in the **Bank** account.
To manage your logistics, you do not need all the elements described in this book. But we find it very important to include an integrated flow, from the first quotation to the final billing of the customers including all the steps: quotation, order, receiving goods, inventory, shipping and billing.
Driving your Sales

This chapter describes OpenERP’s sales management, following the complete sales order process from quotation to customer order, including the management of deliveries and invoicing. It does not look at customer relations and pre-sales, which are handled by the CRM described in the Customer Relationship Management book.

It also describes the management of carriers, margin control and reporting, price management and the handling of various types of sales discount campaigns.

For this chapter you can continue using the database already created or you can start with a fresh database that includes demonstration data, with sale and its dependencies installed and no particular chart of accounts configured.

4.1 Managing your Sales Quotations

In OpenERP, a quotation and an order are handled in the same form (a Sales Order), but in different states. You can consider an order to be a quotation that has evolved, because it has been confirmed by the customer. Or, conversely, that a quotation is an order that has not been validated or cancelled yet. Both your quotations and sales orders can be opened using the menu Sales → Sales → Sales Orders.

To enter details of a new quotation, you can use the menu Sales → Sales → Sales Orders and then select New. OpenERP opens a new window allowing you to enter data into a new blank quotation form. You can also create a quotation directly from an opportunity, as explained in a previous chapter.

Some information is automatically specified by the system:

- an internal reference for the quotation or order,
- the sales point that the order will be delivered from,
- the order date,
- the pricelist for the current sales order.

You can modify any of that information before validating the quotation. The customer reference is shown in the header of the order. This optional field is for the customer’s own reference – if the customer does not supply one, just leave it empty.

You then enter all the data about the order in the Sales Order tab. Start by entering the customer name, by selecting the correct customer from the list of customers in the system. From the quotation, you can create a new customer on the fly if necessary – press <F1> in the empty Customer field to do that, or type the name, press the Tab key and then click Create. Indeed, when you type a name or part of a name in the Customer field, and OpenERP does not find a corresponding customer, you will see the Create button appear to allow you to directly create the customer with the name you entered.
Once the customer name has been selected, different fields of the order are completed automatically, based on the configuration of the partner form for that customer:

- **Ordering Contact**: person handling the order at the customer end. By default, OpenERP proposes the Ordering Contact at the selected partner.

- **Delivery Address**: address used on the delivery order. By default, OpenERP proposes the delivery address from the partner form. If no specific delivery address is defined, the default address will be used instead.

- **Invoice Address**: address used to send the invoice to the customer. By default, OpenERP proposes the address labelled *Invoice* from the partner form. If no specific invoice address is defined, the default address will be used instead.

- **Pricelist**: will determine both the currency of the quotation and the price that will be used for each product.

- **Payment Term**: available in the *Other Information* tab, it shows the payment method that the customer will follow, for example *30 Days End of Month*.

You can modify any of these fields on the order as you go.

You can also set an analytic account for your order. This account will be used during invoicing to generate accounting entries corresponding to the invoice automatically. This is extremely useful for assigning revenues to the project or case specified by this order.
Analytic Accounts

If you are managing by task, the analytic account to be selected is the one that corresponds to the project for the order. The sales carried out by the order can be allocated to the project so that profitability calculations can be made.

Once the information has been entered, you can enter data for the order lines. To do that, create a new order line as shown in the figure Entering a New Sales Order Line (page 47).

![Figure 4.2: Entering a New Sales Order Line](image)

First of all, select the product that is to be sold to the customer. OpenERP shows some useful information in the list of products to help you making a sales quotation:

- **Real Stock**: physically present in your warehouses. This value depends on the Shop (sales point) selected in the order header. Different shops can be linked to different warehouses, giving different stock levels, or can use the same warehouse.

- **Virtual Stock**: shows a salesperson the quantity that can be sold, taking into account both stock reserved for other orders and the number of products planned to arrive in the short term.

- **Public Price**: the basic sales price for the given product. It provides a basis for the salesperson to be able to judge whether to offer a discount to the customer, and how much the discount should be.

- **Pricelist**: (may not be shown, depending on the installed modules) depends on the pricing conditions attached to the customer, calculated on the list price. This is the price that is proposed by default in the customer quotation, unless it has been modified by the salesperson.
• **Cost Price**: shows the cost price of the product. If the salesperson sells at less than this amount, the company incurs a loss.

![Search Products](image)

Figure 4.3: *Selecting a Product in a Sales Order Line*

Once the product to be sold to the customer has been selected, OpenERP automatically completes all the other required fields: quantity, unit of measure, description, unit price, discount, procurement method, lead times and applicable taxes. All of this information comes from the product form.

**Visible Discount**

If a discounted price is taken from a price list, by default that figure is shown as the sales price to the customer. He will see a discount of 0% along with the unit price that is different from the list price. If you install the module `product_visible_discount` from `extra-addons`, you can configure whether you want to make the discount explicitly visible in an order form as a percentage difference from the list price, or just show a reduced unit price as in the default configuration.

When you enter a quotation, the selected product is presented in the language of the user so that he can see what he is selling. The description of the product sold can also be expressed in the customer’s language. The translation to the customer’s language is used on the quotation or order when it is printed.
One-off Sales

If a product is sold to a customer only once, you do not have to create a completely new product form just for that sale. You can manually complete all the information in the order without actually creating a product: description, price, quantity, lead time, taxes. In this case, OpenERP will not generate a delivery note because the a pure description is not a product, and so it is not in stock.

When all of the products are entered, you can print the quotation and send it to the customer. To do this, click the Quotation / Order link in the Reports section to the right. OpenERP opens the quotation in PDF to enable to you to check it before printing.

When the order is confirmed by the customer, you can confirm the quotation to turn in into a sales order. You can also just cancel the window without confirming the order to leave it in quotation state. To see all the current quotations, you can use the menu Sales → Sales → Sales Orders and click the Quotations filter button.

To follow the process for your order, you can click on the process view (indicated by a question mark) from the order form. OpenERP shows you an interactive process view of that order. For more information about its use, look at ch-process.
Figure 4.5: Printing a Sales Quotation
Figure 4.6: Process View for a Sales order
4.2 Packaging

Products can be managed in several packaged forms. For example, if you sell batteries you can define the following packages for a given battery product:

- Piece: a battery,
- Blister Pack: a pack of 4 batteries,
- Pack of 100 blisters: 400 batteries,
- Palette: 40 packs for a total of 16,000 batteries.

OpenERP’s package management enables you to sell the same product in several different forms. The salesperson could sell separately, one battery or a palette of batteries. In the order, you can select the default packaging type as a function of the quantities ordered.

For example, if the customer wants to buy 30,000 batteries, the salesperson can select the palette package. OpenERP will then propose to sell 32,000 batteries, which corresponds to two palettes. Or the salesperson can select 75 packs.

The available packages are defined in the product form, in the Packaging tab. The first item on the list is the one that will be used by default.

Once a package has been defined on the order, OpenERP will throw up an alert if the ordered quantities do not correspond to the proposed packages. The quantity must be a multiple of the field Quantity by Package defined on the packaging form.

![Figure 4.7: Alert on the Quantities sold compared to the Packaging](image)

Do not confuse the management of packaging with the management of multiple units of measure. The Unit of Measure is used to manage the stock differently according to the various units. With packages, the stock is always managed by individual items, but information about the package to use is supplied to the storesperson along with that item.

Even if the effects are the same, the printed documents will be different. The two following operations have the same effect on stock movement levels, but will be printed differently on the sales order and the packing order as where quantities are concerned:

- 32,000 batteries, delivered on two palettes,
- 2 palettes of batteries, with no information about packaging.

If the customer wants to order a palette and 10 packs, the salesperson can put two order lines on the sales order using the same product with different units of measure.
It is sometimes more useful to define different products than to define several possible packages for the same product. A case of beer in a supermarket is a good example. A case holds 24 bottles, plus the empty case itself. The customer can buy bottles by the piece or a case of 24 bottles at one go.

You could define two packages for the **Bottle of beer**: PCE and case. But this representation does not let you manage the stock and price of empty cases. So you might instead prefer a Bill of Materials, defining and using three different products:

- the empty case for the beer,
- the bottle of beer,
- the case of 24 bottles of beer.

You also define the bill of materials below which determines the make-up of the case of 24 beers:

- Case of 24 bottles of beer: 1 unit,
- Bottle of beer: 24 units,
- Empty case of beer: 1 unit.

Each of these three products has a different price. The products **Bottle of beer** and **Empty case of beer** have a stock level that needs to be managed. The **Case of 24 bottles of beer** has no stock because, if you sell the product, OpenERP automatically moves the stock in two lines, one for the empty case and the other for the 24 individual bottles of beer.

### 4.3 Alerts

To manage alerts on products or partners, you can install the warning module. Once that is installed, you will be able to configure a series of alerts on the partners or products by setting parameters in the new **Warnings** tab on each of the forms.

You can select any of the following types of warnings and create different warnings for purchases and for sales:

- **No Message**: This option will not display a message.
- **Warning**: This option will show the user the message entered.
- **Blocking Message**: The message displayed will cause an exception and block the workflow.

You can activate alerts for a series of events. For each alert, you should enter a message that will be displayed when the event concerned is started.

The available warnings in the partner form are:

- Create a warning for a sales order,
- Create a warning for a purchase order,
• Create a warning for a delivery to a partner (or receiving an item),

• Create a warning when invoicing a partner.

For example, if you enter an alert for the invoicing of a customer, for an accountant entering an invoice for that customer, the alert message will be attached as shown in the figure Alert from Invoicing a Customer (page 55).

The alerts that can be configured on a product form are related to:

• The sales of that product,

• The purchase of that product.

A practical example:

Now when could you use such an alert? Suppose that your customer asks you to never make any deliveries on Tuesday morning, because the street is blocked due to a weekly market. You surely would like your transporter to be aware of this, so it could be useful to have a kind of message printed by default on each delivery order for this customer. To do this, you could create a Warning on the Picking in the Customer form of the partner concerned, saying that no deliveries are allowed on Tuesday morning.
Figure 4.9: Alert from Invoicing a Customer

Figure 4.10: Management of Alerts on Products
4.4 Configuring your Sales Order for Delivery and Invoicing

4.4.1 Configuring Orders

The way the order is configured will determine its future behaviour:

- **Picking Policy**: Partial Delivery or Complete Delivery,
- **Shipping Policy**: Shipping & Manual Invoice, Payment Before Delivery, Invoice on Order After Delivery, and Invoice from Delivery,
- **Invoice on**: Ordered Quantities or Shipped Quantities.

**Configuring your Interface**

If you work in the Simplified view mode, only the Shipping Policy field is visible in the second order tab.

To get to the Extended view mode, go to the Edit Preferences link and select the interface of your choice. You can also use the Reconfigure wizard and configure your interface as Extended, or assign the group Usability – Extended View to the current user.

4.4.2 Picking Mode

The picking mode determines the way the storesperson will do the picking. If the order is put into Partial Delivery mode, the picking order will appear in the list of things for the storesperson to do as soon as any of the products on the order is available. To get the list of items to be done, you can use the menu Warehouse → Outgoing Deliveries. By default, the Available filter button is selected, so you immediately see the list of available pickings.

The storesperson will then be able to make a partial delivery of the quantities actually available and do a second picking operation later when the remaining products are available in stock.

If the picking mode is Complete Delivery, the picking order will not appear in the list of pickings to do until all of the products are available in stock. This way, there will only be a single delivery for any such order.

If the storesperson wants to do so, the delivery mode can be modified on each picking list even after the order has been confirmed.

In the case of invoicing from picking, the cost of delivering the products will be calculated according to multiple deliveries. This risks incurring a higher cost because of the separate deliveries. If invoicing is done from the order, the customer will only be invoiced once for the whole delivery, even if the delivery of several items has already been made.
4.5 Management of Carriers

To manage deliveries in OpenERP, you can install the delivery module. To do that, use the Reconfigure wizard and select Delivery Costs under the Sales Application Configuration section for installation.

This module enables you to manage:

- the different carriers with whom you work,
- the different transport methods,
- cost calculation and invoicing of each delivery,
- the transport methods and their tariffs.

Once the delivery module has been installed, the first thing to do is to configure the different modes of delivery accepted by your company. Go to the menu Warehouse → Configuration → Delivery → Delivery Method to create your company’s delivery modes.

For each delivery mode, you should define the following elements:

- Name of the delivery mode,
- The partner associated with the transport (which can be your own company),
- The associated product.

Let’s give you an example:

<table>
<thead>
<tr>
<th>Carrier</th>
<th>Carrier Partner</th>
<th>Delivery Product</th>
</tr>
</thead>
<tbody>
<tr>
<td>Express Track</td>
<td>Mail Office</td>
<td>Express Track Delivery</td>
</tr>
<tr>
<td>Priority Courier</td>
<td>Mail Office</td>
<td>Courier Express Delivery</td>
</tr>
<tr>
<td>EFG Standard</td>
<td>EFG Inc</td>
<td>Delivery EFG</td>
</tr>
<tr>
<td>EFG Express</td>
<td>EFG Inc</td>
<td>Delivery EFG Express</td>
</tr>
</tbody>
</table>

Information about the invoicing of transport (such as accounts, applicable taxes) is entered in the product linked to the delivery mode. Ideally the product should be configured with Product Type Service and Procurement Method Make to Stock.

You can use the same product for several delivery modes. This simplifies the configuration, but it has the disadvantage that you will not be able to separate your sales figures by delivery mode.

4.5.1 Tariff Grids

Unlike ordinary products, delivery prices are not proposed through pricelists but through delivery grids, designed specifically for this purpose. For each delivery mode, you enter one or several tariff grids. Each grid is used for a given region/destination.
For example, for the postal tariffs for Priority Courier, you generally define the three tariff grids for Mail Office:

- National Courier,
- Courier in Europe,
- Courier Outside Europe.

To define a new delivery grid, use the menu Warehouse → Configuration → Delivery → Delivery Pricelist. Give a name to your delivery grid and define the region for which the tariffs in the grid will apply in the second tab Destination. There you can set:

- A list of countries (for UK or Europe, for example),
- A list of states,
- A range of postal codes (for Paris you might have 75000 – 75900).

Then you have to set the rules for calculating the transport price in the first tab Grid definition. First of all, give the rule a name. Then set the condition for which this rule is applicable, for example Weight < 0.5 kg.

Weights

Weights are always expressed in kilograms. You can define a number with a decimal point or comma, so to set 500g you would put 0.5 in the weight rule.

Next you can set the sales price and the cost price. Prices can be expressed in various ways:

- a fixed price,
- a variable price, as a function of weight, volume, weight x volume or price.

For example, mailing within France using current tariffs would be defined as shown in the table below:

<table>
<thead>
<tr>
<th>Name</th>
<th>Condition</th>
<th>Price</th>
<th>Price Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>S</td>
<td>Weight &lt; 3 kg</td>
<td>6.90</td>
<td>Fixed</td>
</tr>
<tr>
<td>M</td>
<td>Weight &lt; 5 kg</td>
<td>7.82</td>
<td>Fixed</td>
</tr>
<tr>
<td>L</td>
<td>Weight &lt; 6 kg</td>
<td>8.53</td>
<td>Fixed</td>
</tr>
<tr>
<td>XL</td>
<td>Weight &lt; 7 kg</td>
<td>9.87</td>
<td>Fixed</td>
</tr>
</tbody>
</table>

You can also define rules that depend on the total amount on the order. For example to offer fixed price delivery if the total order amount is greater than 150 USD, add the following rule:
4.5.2 Delivery Modes

Once the delivery modes and their corresponding tariffs have been defined, you can use them in a Sales Order. There are two methods for doing that in OpenERP.

- Delivery based on Ordered Quantities,
- Delivery based on Shipped Quantities.

4.5.3 Delivery based on Ordered Quantities

To add the delivery charges (or transport costs) to the quotation, use the button Delivery Costs available on the Sales Order tab of the form. A dialog box opens, asking you to select a delivery mode from the list available.

![Figure 4.11: Adding Transport Costs to an Order](image)

Once the delivery mode has been selected, OpenERP automatically adds a line to the quotation with the amount calculated by the delivery function. This technique enables you to calculate the delivery charge based on the order and then, separately, how the products will really be delivered to the customer.

If you want to calculate the exact delivery charges depending on the actual deliveries, you must use invoicing based on deliveries.

4.5.4 Delivery based on Shipped Quantities

To invoice the delivery according to the items shipped, you set the delivery mode in the Delivery Method field on the second tab of the order, Other Information, to Invoice from Delivery.

You can then confirm the order, and when the goods are available you can also validate the delivery order.

The transport costs will not be added to the sales order, but only to the invoice. When the manager has generated the invoices corresponding to the deliveries carried out, OpenERP automatically adds a line on each invoice corresponding to the delivery charge, calculated on the basis of the items actually sent.

---

Table 4.3: Additional Tariff Rule

<table>
<thead>
<tr>
<th>Name</th>
<th>Condition</th>
<th>Price</th>
<th>Price Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Franked &gt; 150</td>
<td>Price &gt; 150 USD</td>
<td>10</td>
<td>Fixed</td>
</tr>
</tbody>
</table>

---

CHAPTER 4. DRIVING YOUR SALES  59
4.6 Keep Track of your Margins

For every company, keeping a clear sight on and a good control of margins is crucial. Even if you have a good sales level, it will not guarantee company profitability if margins are not high enough. OpenERP provides a number of methods allowing you to monitor your sales margins. The main ones are:

- Margins on a sales order,
- Margins by product,
- Margins by project,
- Using pricelists.

4.6.1 Margins on Sales Orders

If you want to check your margins on sales orders, you can install the sale_margin module by selecting Margins in Sales Orders for installation in the Reconfigure wizard. This will add margins calculated on each order line and on the order total.

The margin on each line is defined as the quantity sold multiplied by the sales price for the customer less the cost price of the products. By default, products are managed using standard price in OpenERP (cost price fixed manually and reviewed once per year). You can change that to Average Price, meaning that the product cost fluctuates with purchases from suppliers. After product receipt you can include fixed costs, such as delivery costs, in the cost of each product. OpenERP supports a third method of updating the cost price of products. This is through the button Update on the product form which lets you automatically recalculate the cost price for the selected product. The cost price is calculated from the raw materials and the operations carried out (if the products have been manufactured internally, so that you have set their costs).
4.6.2 Margins by Product

To track margins by product, install the module `product_margin`. Once the module is installed you can see the margins by product by using the menu `Sales → Products → Product Margins`.

When you have clicked the menu option concerned, OpenERP asks for an analysis period and the state of invoices (draft, open, paid). If no period is given, OpenERP will calculate margins on all of the operations without restriction. By default, however, OpenERP proposes a period of the last 12 months for analysis.

You can also filter the analysis on certain types of invoice:

- All invoices, including unvalidated draft invoices,
- All open and/or paid invoices,
- Paid invoices only.

![Product Margins](image)

Figure 4.13: Product Margins

You then get a margin analysis table. The following fields are displayed for the sales of each product:

- **Avg. Unit Price**: the average unit sales price,
- **Catalog Price**: the list price based on this product,
- **# Invoiced**: the number of sold products that have been invoiced,
- **Sales Gap**: the difference between the revenue calculated from list price and volume, and the actual sales,
- **Turnover**: the actual sales revenue for the product selected,
- **Expected Sale**: the number of products sold multiplied by the list price.
The following fields are given by product for purchases:

- **Avg. Unit price**: the average unit purchase price,
- **Standard price**: the standard cost price of the product for the company,
- **# Invoiced**: the number of purchased products,
- **Purchase Gap**: the difference between the total actual cost and the standard cost multiplied by the number of units purchased,
- **Total Cost**: the total cost of purchases for the product under consideration,
- **Normal Cost**: the number of products sold multiplied by the standard cost price.

The following fields are given by product for margins:

- **Total Margin**,
- **Expected Margin**,
- **Total Margin in percent**,
- **Expected Margin in percent**.
4.6.3 Margins by Project

To manage margins by project, you should install the analytical accounts with management by task. The use of these accounts is described in ch-accounts. Install the module account_analytic_analysis and all of its dependencies. This module adds a tab on the analytic account form to handle the different margins in an analytic account representing a project or a case, and several new reports on those accounts.

Start by opening a project’s analytic account through Project → Billing → Overpassed Accounts and selecting one of them. In the form’s Analysis summary tab you will find the following information:

- The total costs for the analytic account,
- The total amount of invoiced sales,
- The number of hours worked,
- The number of hours remaining to be worked,
- The remaining income,
- The theoretical income (hours worked multiplied by their sale price),
- The number of hours invoiced,
- The real income per hour,
- The real margin.

![Overpassed Accounts](image)

Figure 4.15: Detail of margins for a case
• The theoretical margin taking into account everything yet to be invoiced,
• The real margin rate in percent,
• The last invoicing date,
• The last worked hours,
• The number of hours remaining to be invoiced,
• The amount remaining to be invoiced.

For detailed information on the analytic account you can use any of the several reports available in the toolbar to the right.

### 4.7 Pricing Policies

Some companies are notorious for their complicated pricelists. Many forms of price variation are used, such as end-of-year refunds, discounts, change of terms and conditions with time, various prepayments, cascaded rebates, seasonal promotions, and progressive price reductions.

<table>
<thead>
<tr>
<th>Rebate, Refund, Reduction</th>
</tr>
</thead>
<tbody>
<tr>
<td>In some accounting jurisdictions you have to differentiate between the three following terms:</td>
</tr>
<tr>
<td>• Rebate: reimbursement to the client, usually at the end of the year, that depends on the quantity of goods purchased over a period.</td>
</tr>
<tr>
<td>• Refund: reduction on the order line or invoice line if a certain quantity of goods is purchased at one time or is sold in a framework of a promotional activity.</td>
</tr>
<tr>
<td>• Reduction: a one-off reduction resulting from a quality defect or a variation in a product’s conformance to a specification.</td>
</tr>
</tbody>
</table>

Intelligent price management is difficult, because it requires you to integrate several conditions from clients and suppliers to create estimates quickly or to invoice automatically. But if you have an efficient price management mechanism you can often keep margins raised and respond quickly to changes in market conditions. A good price management system gives you scope for varying any and all of the relevant factors when you are negotiating a contract.

To help you work most effectively, OpenERP’s pricelist principles are extremely powerful yet are based on simple and generic rules. You can develop both sales pricelists and purchase pricelists for products capable of accommodating conditions such as the date period, the quantity requested and the type of product.
Do not confuse the Different Price Specifications

Do not confuse the sales price with the basic price of the product. In OpenERP’s basic configuration, the sales price is the list price specified in the product form, but a customer can have a different sales price depending on the conditions.

The same applies to the purchase price and standard cost. Purchase price is your suppliers’ selling price, which changes in response to different criteria such as quantities, dates, and supplier. This is automatically set by the accounting system. You will find that the two prices have been set by default to the same for all products with the demonstration data, which can be a source of confusion. You are free to set the standard cost to something different.

Each pricelist is calculated from defined policies, so you will have as many sales pricelists as active sales policies in the company. For example, a company that sells products through three sales channels could create the following price lists:

1. Main distribution:
   - pricelist for Walbury,
   - pricelist for TesMart,
2. Postal Sales.
3. Walk-in customers.

A single pricelist can exist in several versions, only one of which is permitted to be active at a given time. These versions let you set different prices at different points in time. So the pricelist for walk-in customers could have five different versions, for example: Autumn, Summer, Summer Sales, Winter, Spring. Direct customers will see prices that change with the seasons.

Each pricelist is expressed in a single currency. If your company sells products in several currencies, you will have to create as many pricelists as you have currencies.

The prices on a pricelist can depend on another list, which means that you do not have to repeat the definition of all conditions for each product. So a pricelist in USD can be based on a pricelist in EUR. If the currency conversion rates between EUR and USD change, or the EUR prices change, the USD rates can be automatically adjusted.

4.7.1 Creating Price Lists

You can define a pricelist from the menu Sales → Configuration → Pricelists → Pricelists.

For each list you should define:

- a Name for the list,
• a Type of list: Sale for customers or Purchase for suppliers,
• the Currency in which the prices are expressed.

Price List Versions

Once the pricelist is defined you have to link at least one version. You can create a new version directly from the pricelist or from the Sales → Configuration → Pricelists → Pricelist Versions menu. The version contains all of the rules that enable you to calculate a price for a product and a given quantity.

Start by setting the Name of this associated version. If the list only has a single version, you can use the same name for the pricelist and the version. In the Price List field, select the pricelist you created (this is not necessary if you create the version directly from the pricelist).

Then set the Start Date and End Date of this version. The fields are both optional: if you do not set any dates the version will be permanently active. Only one version may be active at any one point, so bear this in mind when creating them. Use the Active field in the versions to activate or disable a pricelist version.

Automatically Updating the Sales Pricelist

Any sales pricelist can be set to depend on one of the other pricelists. So you could create your sales pricelist based on the supplier’s purchase pricelist, to which you add a margin. The prices are automatically calculated as a function of the purchase price and need no further manual adjustment.

Calculation Rules

A pricelist version is made up of a set of rules that apply to the basic product prices.

Figure 4.16: Rule in a Pricelist Version

You define the conditions for a rule in the first part of the screen labelled Rules Test Match. The rule applies to the Product or Product Template and/or the named Product Category. If a rule is applied to
a category, then it is automatically applied to all of its subcategories too (using the tree structure for product categories).

If you set a minimum quantity in Min. Quantity, the rule will only apply to a quantity equal to or larger than the quantity set. This way, you can define reduced rates in steps according to the quantities ordered.

Several rules can be applied to an order. OpenERP evaluates these rules by sequence number, to determine which rule(s) to apply to the specified price calculation. If several rules are valid, only the first in sequence is used for the calculation. The Sequence field determines the order, starting with the lowest number and working up.

Once a rule has been selected, the system has to determine how to calculate the price from the rule. This operation is based on the criteria set out in the lower part of the form, labelled Price Computation.

The first field to complete is Based on. Set the way in which the partner price will be calculated, choosing between:

- the Public Price set in the product file,
- the Cost Price set in the product file,
- an Other Pricelist given in the field If Other Pricelist,
- the price that varies as a function of a supplier defined in the Partner section of the product form.

Several other criteria can be considered and added to the list, as you will see in the following section.

Next, various operations can be applied to the basic price to calculate the sales or purchase price for the partner, according to the specified quantities. To calculate it, you apply the formula shown on the form: \[ \text{Price} = \text{Base Price} \times (1 + \text{Field1}) + \text{Field2}. \]

The first field, Field1, defines a discount or a supplement. Set it to -0.20 for a discount of 20% from the basic price. If your price is based on standard cost, you can set 0.15 to get a 15% price uplift compared to the standard costs.

Field2 sets a fixed supplement to the price, expressed in the currency of the pricelist. This amount is just added (or subtracted, if negative) to the amount calculated with the Field1 discount.

Then you can specify a rounding method. The rounding calculation is carried out to the nearest number. For example if you set 0.05 in this example, a price of 45.66 will be rounded to 45.65, and 14,567 rounded to 100 will give a price of 14,600.

<table>
<thead>
<tr>
<th>Swiss Special Situation</th>
</tr>
</thead>
<tbody>
<tr>
<td>In Switzerland, the smallest monetary unit is 5 cents. There are not any 1 or 2 cent coins. So you set OpenERP's rounding to 0.05 to round everything in a Swiss franc pricelist.</td>
</tr>
</tbody>
</table>

The supplement from Field2 is applied before the rounding calculation, which enables some interesting effects. For example, if you want all your prices to end in 9.99, set your rounding to 10 and your supplement to -0.01 in Field2.
Minimum and Maximum margins enable you to guarantee a given margin over the base price. A margin of 10 USD enables you to stop the discount from returning less than that margin. If you put 0 into this field, no effect is taken into account.

Once the pricelist is defined, you can assign it to a partner. Go to the Partner form and select its Sales & Purchases tab. You can then change the Purchase Pricelist and the Sale Pricelist that is loaded by default for the partner.

Decimal Accuracy

There are several configuration settings related to the decimal accuracy of prices, or the number of decimal places to hold with each price field. To change the accuracy of a field, follow these steps:

1. Make sure you have the Extended user interface. The setting is in your user preferences.

2. Go to Administration → Customization → Database Structure → Decimal Accuracy. This list contains a number of predefined elements.

3. Open the entry you want to change. Purchase Price and Sale Price are the most common ones related to prices, but some fields are controlled by the Account entry.

4. Type a new value in the digits field, and save the entry. Do not change the description in the Usage field, or it will stop working.

5. Close the screen where you were editing prices and reopen it. The price field should now have the number of digits you asked for.

4.7.2 Example of a Pricelist

Take the case of an IT systems trading company, for which the following product categories have been configured:

All products

1. Accessories
   - Printers
   - Scanners
   - Keyboards and Mice

2. Computers
   - Portables
   - Large-screen portables
   - Computers
   - Office Computers
   - Professional Computers
In addition, the products presented in the table below are defined in the currency of the installed chart of accounts.

### Table 4.4: Examples of products with their different prices

<table>
<thead>
<tr>
<th>Product</th>
<th>Sale Price</th>
<th>Cost Price</th>
<th>Default supplier price</th>
</tr>
</thead>
<tbody>
<tr>
<td>Acclo Portable</td>
<td>1,200</td>
<td>887</td>
<td>893</td>
</tr>
<tr>
<td>Toshibishi Portable</td>
<td>1,340</td>
<td>920</td>
<td>920</td>
</tr>
<tr>
<td>Berrel Keyboard</td>
<td>100</td>
<td>50</td>
<td>50</td>
</tr>
<tr>
<td>Office Computer</td>
<td>1,400</td>
<td>1,000</td>
<td>1,000</td>
</tr>
</tbody>
</table>

**Default Price Lists**

![Pricelists](image)

Figure 4.17: *Default pricelist after installing OpenERP*

When you install the software, two pricelists are created by default: one for sales and one for purchases. Each of them contains only one pricelist version and only one line in that version.

The price for sales defined in the Default Public Pricelist is set by default to the Public Price of the product, which is the Sales Price in the Product form.

The price for purchases defined in the Default Purchase Pricelist is set by default in the same way to the Cost Price of the product.

**Trading Company**

Take the case of a trading company, where the sales price for resellers can be defined like this:

- For portable computers, the sale price is calculated from the list price of the supplier Acclo, with a supplement of 23% on the cost of purchase.
• For all other products the sales price is given by the standard cost in the product file, to which 31% is added. The price should end in .99.

• The sales price of Berrel keyboards is fixed at 60 for a minimum quantity of 5 keyboards purchased. Otherwise it uses the rule above.

• Assume that the Acclo pricelist is defined in OpenERP. The pricelist for resellers and the pricelist version then contains three lines:

  1. Acclo line:
     - **Product Category**: Portables,
     - **Based on**: Other pricelist,
     - **Pricelist if other**: Acclo pricelist,
     - **Field1**: 0.23,
     - **Priority**: 1.

  2. Berrel Keyboard line:
     - **Product Template**: Berrel Keyboard,
     - **Min. Quantity**: 5,
     - **Field1**: 1.0,
     - **Field2**: 60,
     - **Priority**: 2.

  3. Other products line:
     - **Based on**: Standard Price,
     - **Field1**: 0.31,
     - **Field2**: -0.01,
     - **Rounding**: 1.0.
     - **Priority**: 3.

It is important that the priority of the second rule is set below the priority of the third in this example. If it were the other way around, the third rule would always be applied, because a quantity of 5 is always greater than a quantity of 1 for all products.

Also note that to fix a price of 60 for the 5 Berrel Keyboards, the formula $\text{Price} = \text{Base Price} \times (1 + 1.0) + 60$ has been used.

**Establishing Customer Contract Conditions**

The trading company can now set specific conditions to a customer, such as the company TinAtwo, who might have signed a valid contract with the following conditions:

• For Toshibishi portables, TinAtwo benefits from a discount of 5% of resale price.

• For all other products, the resale conditions are unchanged.

The sales price for TinAtwo, called **TinAtwo contract**, contains two rules:
1. Toshiba Portable:

- **Product**: Toshiba Portable,
- **Based on**: Other pricelist,
- **Pricelist if other**: Reseller pricelist,
- **Field1**: 0.05,
- **Priority**: 1.

2. Other Products:

- **Product**:
- **Based on**: Other pricelist,
- **Pricelist if other**: Reseller pricelist,
- **Priority**: 2.

Once this list has been entered, you should look up the partner form of TinAtwo again. Click the Sales & Purchases tab to set the Sale Pricelist field to TinAtwo Contract. If the contract is only valid for one year, do not forget to set the Start Date and End Date fields in the Pricelist Version.

Then when salespeople prepare an estimate for TinAtwo, the prices proposed will automatically be calculated from the contract conditions.

### 4.7.3 Pricelists and Managing Currencies

If your trading company wants to start a product catalog in a new currency you can handle this several ways:

- Enter the prices in a new independent pricelist and maintain the lists in the two currencies separately,
- Create a field in the product form for this new currency and make the new pricelist depend on this field: prices are then maintained separately, but in the product file,
- Create a new pricelist for the second currency and make it depend on another pricelist or on the product price: the conversion between the currencies will then be done automatically at the prevailing currency conversion rate.

### 4.8 Rebates at the End of a Campaign

If you want to provide discounts on an order, you can use the pricelist system in OpenERP. But we would not be writing about end-of-campaign rebates if no other solution was available. You can also work with end-of-campaign rebates or year-end rebates. The customer pays a certain price during the whole of the campaign or the year, and he will receive a rebate at the end of the campaign according to the sales made throughout the year.
Take the case of contract negotiations with a wholesaler. To get the best selling price, the wholesaler will ask you for a good deal and will sign up to a certain volume of orders over the year.

You can then propose a price based on the volume that the wholesaler agrees to sell. But then you do not have any control over his orders. If at the end of the year the wholesaler has not taken the agreed volumes, you can do nothing. At most you can review his terms for the following year.

Rebates at the end of a campaign can help you avoid this sort of problem. You can propose a contract where the price depends on the usual wholesaler’s terms. You can propose a rebate grid which will be assigned at the end of the year as a function of the actual sales made. Install the discount_campaign module (in extra-addons at the time of writing) to generate rebates at the end of the campaign. Once the modules have been installed, you can configure your campaign using the menu Sales → Configuration → Sales → Discount Campaigns.

**Year-end Rebate**

Most companies use the term *year-end rebate*, where rebates are applied at the end of the year. But of course you can also define rebates for a campaign that lasts less than or more than one year.

![Discount Campaigns](image)

*Figure 4.18: Configuring a Campaign Rebate*

A campaign should have a name, a refund journal (to create the credit notes at the end of the campaign), a start date, and an end date. After entering this information, you should describe the lines of the campaign. Each line can be applied to a product or a category of products. Then set the quantity of products sold from which the discount is applied, and the amount of the rebate as a percentage of the actual sales volume.

When you have defined the campaign, you can activate it by clicking the *Open* button. The figure *Configuring a Discount Campaign for Computers* (page 73) shows a campaign with a rebate on computers which is between 10% and 20% depending on the sales volume.

Once the campaign has been defined and activated, you can assign it to various partners. To do that set a Discount Campaign in the second tab *Sales & Purchases* of the partner form.
Finally, at the end of the campaign, you should close it and OpenERP will automatically generate invoices or credit notes for your partner associated with this campaign. OpenERP opens credit notes in the Draft state so you can modify them before validation. To calculate the amount on the credit note, OpenERP uses all of the invoices sent out during the period of the campaign as a basis.

You can also get an overview of all draft credit notes using the menu Accounting → Customers → Customer Refunds.

### 4.9 Keeping Track of Open Orders

In some industries, customers commonly place orders for a certain volume of products and ask for regular deliveries from an order up to the total amount on it. This principle, called open orders, is managed by the sale_delivery module in OpenERP.

OpenERP handles open orders easily. An open order is an order for a certain quantity of products but whose deliveries are planned for various dates over a period of time.

To do that, you should install the sale_delivery module (in extra-addons at the time of writing). A Sales Order is entered as a normal order, but you also set the total quantity that will be delivered on each order line.

Then you can use the new tab Deliveries on the order to plan the quantities sold and enter your delivery planning there.

In the order lines, OpenERP shows you the quantity planned in addition to the quantity sold. This way, you can verify whether the quantities sold equal the quantities to be delivered. On confirmation of the sales order, OpenERP no longer generates a single delivery order, but plans scheduled dispatches.
Invoicing Mode

If you work with Open Orders, you should set Invoice Control to the mode Shipped Quantities. Then the storesperson will be able to re-plan and change the quantities of the forecast deliveries in the system.

4.10 Changing Order Layout

Install the sale_layout module by selecting Sales Order Layout Improvement and clicking Configure in the Reconfigure wizard. It enables you to have a more flexible template than the standard order forms.

For example, you could put the following in the order lines:

- a horizontal separator line,
- titles and subtitles,
- subtotals at the end of the section,
- comments,
- a page break.

This enables you to lay out a more elaborate, professional-looking quotation page. The module account_invoice_layout (installed automatically on installation of sale_layout), also gives you the same functionality for invoice templates.

The two figures Invoice using Customizable Layout (page 75) and Printed Invoice (page 75) show an invoice template in OpenERP and the resulting printed invoice.
Figure 4.21: Invoice using Customizable Layout

Figure 4.22: Printed Invoice
Part III

Advanced Features in Purchase Quotation Management

To manage your logistics, you do not need all the elements described in this book. But we find it very important to include an integrated flow, from the first quotation to the final billing of the customers including all the steps: quotation, order, receiving goods, inventory, shipping and billing.
In the preceding chapters you saw how to use customer invoices and delivery notes in OpenERP. This chapter is about the management of purchases, the process ahead of these two operations. You will now see how OpenERP handles and simplifies this and the control of purchases from suppliers.

For this chapter you can continue using the database already created or you should start with a fresh database that includes demonstration data, with purchase and its dependencies installed and no particular chart of accounts configured.

5.1 All the Elements of a Complete Workflow

The supplier or purchase order is the document that lets you manage price negotiations, control supplier invoices, handle goods receipts and synchronize all of these documents.

Let us start by looking at the following order workflow:

1. Price request to the supplier,
2. Confirmation of purchase,
3. Receipt and control of products,
4. Control of invoicing.

5.1.1 Setting up your Database

To set up a system for these examples, create a new database with demonstration data in it, and select the Extended interface when you log in as the admin user. You can enter your own company details when asked, or just use the default if you want. Then, using the Configuration Wizard, select Purchase Management in the Install Applications section to install the purchase module, which also installs several other modules as dependencies. Continue the remainder of this chapter logged in as the admin user.

5.1.2 Price Request from the Supplier

To enter data for a new supplier price request (i.e. request for quotation), use the menu Purchases → Purchase Management → Request for Quotation. When you click New, OpenERP opens a blank request for quotation form that you use for requesting prices from a supplier. This is shown in the figure Data Entry for a Purchase Order (page 80). If the price request came from an automatic procurement
created by OpenERP, you will find a reference to the document that generated the request in the *Origin* field.

![Data Entry for a Purchase Order](image)

**Figure 5.1: Data Entry for a Purchase Order**

### Managing Alerts

If you install the *warning* module, you will be able to define alerts that appear when the purchaser enters a price request or order. You can set alerts on the product and on the supplier.

The internal reference, the date and the warehouse the products should be delivered to, are completed automatically by OpenERP, but you can change these values if needed. Next, when you select a supplier, OpenERP automatically completes the contact address for the supplier. The pricelist is also automatically completed from the pricelist in the supplier form. This should bring in all of the conditions that you have negotiated with the supplier for a given period.

### Supplier Selection

Searching for a supplier is limited to all of the partners in the system that have the *Supplier* checkbox checked. If you do not find your supplier, it might be worth checking the whole list of all partners to make sure that the supplier does not yet exist without the Supplier checkbox being checked.

Once the main body of the purchase order has been completed, you can enter the product lines. When you have selected the product, OpenERP automatically completes the other fields in the form:
• **Product UoM**, taken from the *Purchase Unit of Measure* field in the product form,

• The *Description* of the product in the supplier’s language,

• *Scheduled Date*, calculated from the order date and the delivery lead time for the supplier (for the given product),

• *Unit Price*, taken from the supplier’s pricelist,

• *Taxes*, taken from the information on the product form and partner form, depending on the rules seen in *Financial Analysis*.

---

**Product Wording and Code**

When you enter supplier names in the product form, you can set a name and a product code for each individual supplier. If you do that, OpenERP will then use those details instead of your own internal product names for that selected supplier.

---

If you work with management by case, you can also set the analytic account that should be used to report all the purchase costs. The costs will then be reported at the receipt of the supplier invoice.

---

**Management by Case**

Analytic accounts can be very useful for all companies that manage costs by case, by site, by project or by folder. To work with several analytic axes, you should install the module `purchase_analytic_plans`, by selecting *Purchase Analytic Plans* in the *Reconfigure* wizard and clicking *Configure*. 

---

**Figure 5.2: Purchase Order Line**
To make sure that the analytic account is automatically selected according to the partner, the date, the products or the user, you can install the module account_analytic_default (which is installed automatically as a dependency of purchase_analytic_plans).

In the Notes tab of the product line, you can enter a note that will be attached when the order confirmation or price quotation is printed. This note can be predefined on the product form to automatically appear on each order for that product. For example, you can enter “Do not forget to send by express delivery as specified in our contract reference 1234.”

Once the document has been completed, you can print it as a price estimate to send to the supplier. You can set a note for the attention of the supplier in the form’s third tab.

![Request for Quotation](image)

**Figure 5.3: Printing the Supplier Price Quotation**

Then leave the document in the Request for Quotation state. When you receive a response from the supplier, use the menu Purchases → Purchase Management → Requests for Quotation. Select the order and complete its details.

When you want to approve the order, use the button Convert to Purchase Order. The price request then passes into the Approved state. No further changes are possible.
5.1.3 Goods Receipt

Once the order has been approved, OpenERP automatically prepares the goods receipt order in the draft state for you. To get a list of the products you are waiting for from your suppliers, use the menu **Warehouse → Warehouse Management → Incoming Shipments**.

**Purchasing Services**

If you buy services from your supplier, OpenERP does not generate a goods receipt note. There is no service receipt equivalent to a goods receipt.

Select the document that corresponds to the item that you are receiving. Usually, the goods receipt note is found by making a search on the order reference or the supplier name. You can then confirm the receipt of the products.

As described in *Your Warehouse* (page 101), if you receive only part of the order, OpenERP manages the remainder of that order. A second receipt note is then automatically created for the goods not received. You can cancel it if you think that you will never receive the remaining products.

After receiving the goods, OpenERP will show you which orders are open and the state of their receipt and invoicing if you return to the list of orders.

5.1.4 Control of Invoicing

To control supplier invoicing, OpenERP provides three systems as standard, which can differ order by order:
Figure 5.5: List of Open Orders, and their Receipt and Invoice Status

- **From Order**: invoicing based on quantities ordered,
- **From Picking**: invoicing based on quantities received,
- **Manual**: manual invoicing.

The mode of invoicing control is set in the second tab of the purchase order in the field *Invoicing Control*.

Figure 5.6: Purchase Order, Invoice Control
5.1.5 Control based on Orders

If you selected your invoicing control based on orders, OpenERP will automatically generate a supplier invoice in the draft state when the order is confirmed. You can obtain a list of invoices waiting using the menu Accounting → Suppliers → Supplier Invoices and enabling the Draft filter.

When you receive a paper invoice from your supplier, all you need to do is validate the invoice pre-generated by the system. Do not forget to check the price and the quantities. When the invoice is confirmed, the accounting entries represent the cost of purchase and are automatically entered into the system.

The supplier order is automatically set as Paid when you pay the supplier invoice.

This method of controlling invoices is often used in service companies, because the invoiced amounts correspond to the ordered amounts. In logistics, by contrast, you most often work with invoicing controlled by goods receipt.

5.1.6 Control based on Goods Receipt

To control your supplier invoices based on goods receipt, set the field Invoicing Control on the second tab of the order to From Picking.

In this case, no invoice, draft state or any other, is generated by the order. On the goods receipt note, the field Invoice Control is set to To Be Invoiced.

The storesperson can then receive different orders. If he wants to generate the draft invoice for a goods receipt, he can click the action Create Invoice. OpenERP then asks you for the journal for this invoice. It then opens that or the generated invoices (in the case of creating invoices for several receipts at one time) which enables you to modify it before confirming it.

This approach is useful when you receive the invoice at the same time as the item from the supplier. Usually, invoices are sent by post some days later. In this case, the storesperson leaves the item unchanged without generating an invoice. Then, once per day or once per week the accountant will create the draft invoices based on all the receipts for the day. To do that, he uses the menu Purchases → Invoice Control → Purchase Lines Not Invoiced. He clicks the action Create invoices to generate all draft invoices from the list of receipts that have not yet been invoiced. At that point, the accountant can decide if he wants to generate an invoice per item or group all items for the same partner into the same invoice.

Invoices are then handled just like those controlled from On Order. Once the invoice arrives at the accounting service, he just compares it with the invoices waiting to control what the supplier invoices you.
Delivery Charges

To manage delivery charges, install the module `delivery` using the `Reconfigure` wizard and selecting `Delivery Costs` in the `Sales Application Configuration` section. This will automatically add delivery charges to the creation of the draft invoice as a function of the products delivered or ordered.

5.1.7 Tenders

To manage tenders, you should use the module `purchase_requisition`, installed via the `Purchase Requisition` option in the `Reconfigure` wizard. This lets you create several supplier price requests for a single supply requirement. Once the module is installed, OpenERP adds a new `Purchase Requisitions` menu in the `Purchases → Purchase Management`. You can then define the new tenders.

Figure 5.7: Defining a Tender

To enter data for a new tender, use the menu `Purchases → Purchase Management → Purchase Requisitions` and select `New`. OpenERP then opens a new blank tender form. The reference number is set by default and you can enter information about your tender in the other fields.

If you want to enter a supplier’s response to your tender request, add a new draft purchase order into the list on the `Quotation` tab of your tender document. If you want to revise a supplier price in response to negotiations, edit any appropriate purchase order that you have left in the draft state and link that to the tender.

When one of the orders about a tender is confirmed, all of the other orders are automatically cancelled by OpenERP if you selected the Purchase Requisition (exclusive) type. That enables you to accept just
one order for a particular tender. If you select Multiple requisitions, you can approve several purchase orders without cancelling other orders from this tender.

### 5.1.8 Price Revisions

OpenERP supports several methods of calculating and automatically updating product costs:

- **Standard Price:** manually fixed, and
- **Standard Price:** revalued automatically and periodically,
- **Average Price:** updated at each receipt to the warehouse.

This cost is used to value your stock and represents your product costs. Included in that cost is everything directly related to the received cost. You could include such elements as:

- supplier price,
- delivery charges,
- manufacturing costs,
- storage charges.

**Standard Price**

The mode of price management for the product is shown in the tab *Information* on the product form. On each individual product, you can select if you want to work in Standard Price or on weighted Average Price.

**Simplified Interface**

If you work in the Simplified interface mode you will not see the field that lets you manage the price calculation mode for a product. In that case, the default value is Standard Price.

The Standard Price setting means that the product cost is fixed manually for each product in the field *Cost Price*. This is usually revalued once a year based on the average of purchase costs or manufacturing costs.

You usually use standard costs to manage products where the price hardly changes over the course of the year. For example, the standard cost could be used to manage books, or the cost of bread.

Those costs that can be fixed for the whole year bring certain advantages:

- you can base the sale price on the product cost and then work with margins rather than a fixed price per product,
• accounting is simplified because there is a direct relationship between the value of stock and the number of items received.

To get an automated periodic revaluation of the standard price you can use the action Update on the product form, enabling you to update prices of all the selected products. OpenERP then recalculates the price of the products as a function of the cost of raw materials and the manufacturing operations given in the routing.

**Average Price**

Working with standard prices does not lend itself well to the management of the cost price of products when the prices change a lot with the state of the market. This is the case for many commodities and energy.

In this case, you would want OpenERP to automatically set the price in response to each goods receipt movement into the warehouse. The deliveries (exit from stock) have no impact on the product price.

### Calculating the Price

At each goods receipt, the product price is recalculated using the following accounting formula: \( NP = \frac{OP \times QS + PP \times QR}{QS + QR} \), where the following notation is used:

- NP: New Price,
- OP: Old Price,
- QS: Quantity actually in Stock,
- PP: Price Paid for the quantity received,
- QR: Quantity Received.

If the products are managed as a weighted average, OpenERP will open a window that lets you specify the price of the product received at each goods receipt. The purchase price is, by default, set from the purchase order, but you can change the price to add the cost of delivery to the various received products, for example.

![Figure 5.8: Goods Receipt of Products managed in Weighted Average](image)
Once the receipt has been confirmed, the price is automatically recalculated and entered on the product form.

### 5.2 Purchase Analysis through Analytic Accounts

#### 5.2.1 Powerful Statistics

OpenERP enables you to perform analysis of purchases by period (current year, current month, previous month), by state (quotations, orders), supplier, user, product, category, warehouse and so on. This is made possible through a search view accessed through the menu **Purchases → Reporting → Purchase Analysis**.

![Figure 5.9: Analysis of Purchases over the Month by Product](image)

This analysis is carried out on supplier orders and not on invoices or the quantities actually received. To get an analysis by product, use the module *product_margin*. The function of this module is described in detail in the chapter about sales (only in Logistics, not in Manufacturing).

To analyze the received quantities, you can use the statistical reports in Warehouse. To manage purchases by project, you should use analytic accounts. You can set an analytic account on each line of a supplier order. The analytic costs linked to this purchase will be managed by OpenERP from the goods receipt and confirmation of the supplier invoice. The *hr_timesheet_invoice* module lets you re-invoice the analytic costs automatically using parameters in the analytic accounts such as sale pricelist, associated partner company, and maximum amount.

So you can put an invoice order with a defined invoice workflow in place based on the analytic accounts. If you are working **Make to Order**, the workflow will be:

1. Customer Order,
2. Procurement Order on supplier,
3. Receive invoice and goods from the supplier,
4. Delivery and invoicing to the customer.
When re-invoicing based on costs you would get the following workflow:

1. Enter the customer contract conditions from the analytic accounts,
2. Purchase raw materials and write the services performed into the timesheets,
3. Receive the supplier invoice and the products,
4. Invoice these costs to the customer.

**Analytic Multi-plans**

If you want several analysis plans, you should install the module `purchase_analytic_plans`. These let you split a line on a supplier purchase order into several accounts and analytic plans.

Sitting at the heart of your company’s processes, analytic accounts (or cost accounts) are indispensable tools for managing your operations well. Unlike your financial accounts, they are for more than accountants - they are for general managers and project managers, too.

You need a common way of referring to each user, service, or document to integrate all your company’s processes effectively. Such a common basis is provided by analytic accounts (or management accounts, or cost accounts, as they are also called) in OpenERP.

Analytic accounts are often presented as a foundation for strategic enterprise decisions. But because of all the information they pull together, OpenERP’s analytic accounts can be a useful management tool, at the center of most system processes.

There are several reasons for this:

- they reflect your entire management activity,
- unlike the general accounts, the structure of the analytic accounts is not regulated by legal obligations, so each company can adapt it to its needs.

**Independence from General Accounts**

In some software packages, analytic accounts are managed as an extension of general accounts – for example, by using the two last digits of the account code to represent analytic accounts.

In OpenERP, analytic accounts are linked to general accounts but are treated totally independently. So you can enter various different analytic operations that have no counterpart in the general financial accounts.

While the structure of the general chart of accounts is imposed by law, the analytic chart of accounts is built to fit a company’s needs closely.
Just as in the general accounts, you will find accounting entries in the different analytic accounts. Each analytic entry can be linked to a general account, or not, as you wish. Conversely, an entry in a general account can be linked to one, several, or no corresponding analytic accounts.

You will discover many advantages of this independent representation below. For the more impatient, here are some of those advantages:

- you can manage many different analytic operations,
- you can modify an analytic plan on the fly, during the course of an activity, because of its independence,
- you can avoid an explosion in the number of general accounts,
- even those companies that do not use OpenERP’s general accounts can use the analytic accounts for management.

**Who Benefits from Analytic Accounts?**

Unlike general accounts, analytic accounts in OpenERP are not so much an accounting tool for Accounts as a management tool for everyone in the company. (That is why they are also called management accounts.)

The main users of analytic accounts should be the directors, general managers and project managers.

Analytic accounts make up a powerful tool that can be used in different ways. The trick is to create your own analytic structure for a chart of accounts that closely matches your company’s needs.

### 5.2.2 To Each Enterprise its own Analytic Chart of Accounts

To illustrate analytic accounts clearly, you will follow three use cases, each in one of three different types of company:

1. Industrial Manufacturing Enterprise.
2. Law Firm.
3. IT Services Company.

**Case 1: Industrial Manufacturing Enterprise**

In industry, you will often find analytic charts of accounts structured into the departments and products that the company itself is built on.

So the objective is to examine the costs, sales and margins by department and by product. The first level of the structure comprises the different departments, and the lower levels represent the product ranges that the company makes and sells.
In daily use, it is useful to mark the analytic account on each purchase invoice. The analytic account is the one to which the costs of that purchase should be allocated. When the invoice is approved, it will automatically generate the entries for both the general and the corresponding analytic accounts. So, for each entry on the general accounts, there is at least one analytic entry that allocates costs to the department that incurred them.

Here is a possible breakdown of some general accounting entries for the example above, allocated to various analytic accounts:

<table>
<thead>
<tr>
<th>General accounts</th>
<th>Account</th>
<th>Debit</th>
<th>Credit</th>
<th>Account</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Purchase of Raw Material</td>
<td>600</td>
<td>1500</td>
<td></td>
<td>Production / Range 1</td>
<td>-1500</td>
</tr>
<tr>
<td>Subcontractors</td>
<td>602</td>
<td>450</td>
<td></td>
<td>Production / Range 2</td>
<td>-450</td>
</tr>
<tr>
<td>Credit Note for defective materials</td>
<td>600</td>
<td></td>
<td>200</td>
<td>Production / Range 1</td>
<td>200</td>
</tr>
<tr>
<td>Transport charges</td>
<td>613</td>
<td>450</td>
<td></td>
<td>Production / Range 1</td>
<td>-450</td>
</tr>
<tr>
<td>Staff costs</td>
<td>6201</td>
<td>10000</td>
<td></td>
<td>Marketing</td>
<td>-2000</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Commercial</td>
<td>-3000</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Administrative</td>
<td>-1000</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Production / Range 1</td>
<td>-2000</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Production / Range 2</td>
<td>-2000</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Marketing</td>
<td>-450</td>
</tr>
</tbody>
</table>

The analytic representation by department enables you to investigate the costs allocated to each department in the company.

So, the analytic chart of accounts shows the distribution of the company’s costs using the example above:
Table 5.2: Analytic chart of accounts (Case 1)

<table>
<thead>
<tr>
<th>Account</th>
<th>Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>Marketing Department</td>
<td>-2 450</td>
</tr>
<tr>
<td>Commercial Department</td>
<td>-3 000</td>
</tr>
<tr>
<td>Administration Department</td>
<td>-1 000</td>
</tr>
<tr>
<td>Production</td>
<td>-6 200</td>
</tr>
<tr>
<td>Product Range 1</td>
<td>-3 750</td>
</tr>
<tr>
<td>Product Range 2</td>
<td>-2 450</td>
</tr>
</tbody>
</table>

In this example of a hierarchical structure in OpenERP, you can analyze not only the costs of each product range but also the costs of the whole of production. The balance of a summary account (Production) is the sum of the balances of the child accounts.

A report that relates both general accounts and analytic accounts enables you to get a breakdown of costs within a given department. An analysis of the Production / Product Range 1 department is shown in this table:

Table 5.3: Report merging both general and analytic accounts for a department (Case 1)

<table>
<thead>
<tr>
<th>Production / Product Range 1</th>
<th>Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Account</td>
<td>-1 300</td>
</tr>
<tr>
<td>600 – Raw Materials</td>
<td>-1 300</td>
</tr>
<tr>
<td>613 – Transport charges</td>
<td>-450</td>
</tr>
<tr>
<td>6201 – Staff costs</td>
<td>-2 000</td>
</tr>
<tr>
<td>Total</td>
<td>-3 750</td>
</tr>
</tbody>
</table>

The examples above are based on a breakdown of the costs of the company. Analytic allocations can be just as effective for sales. That gives you the profitability (sales - costs) of different departments.

**Representation by Unique Product Range**

This analytic representation by department and by product range is usually used by trading companies and industries.

A variant of this is not to break it down by sales and marketing departments but to assign each cost to its corresponding product range. This will give you an analysis of the profitability of each product range.

Choosing one over the other depends on how you look at your marketing effort. Is it a global cost allocated in some general way, or does each product range have responsibility for its own marketing costs?

**Case 2: Law Firm**

Law firms generally adopt management by case, where each case represents a current client file. All of the expenses and products are then attached to a given file.
A principal preoccupation of law firms is the invoicing of hours worked, and the profitability by case and by employee.

Mechanisms used for encoding the hours worked will be covered in detail in the Human Resources chapter on line. Like most system processes, hours worked are integrated into the analytic accounting. Every time an employee enters a timesheet for a number of hours, that automatically generates analytic accounts corresponding to the cost of those hours in the case concerned. The hourly charge is a function of the employee’s salary. So a law firm will opt for an analytic representation which reflects the management of the time that employees work on the different client cases.

### Example Representation of an Analytic Chart of Accounts for a Law Firm

1. Absences
   - Paid Absences
   - Unpaid Absences

2. Internal Projects
   - Administrative
   - Others

3. Client Cases
   - Client 1
   - Case 1.1
   - Case 1.2
   - Client 2
   - Case 2.1

All expenses and sales are then attached to a case. This gives the profitability of each case and, at a consolidated level, of each client.

Billing for the different cases is a bit unusual. The cases do not match any entry on the general account and nor do they come from purchase or sale invoices. They are represented by the various analytic operations and do not have exact counterparts in the general accounts. They are calculated on the basis of the hourly cost per employee. These entries are automatically created on billing worksheets.

At the end of the month when you pay salaries and benefits, you integrate them into the general accounts but not in the analytic accounts, because they have already been accounted for in billing each account. A report that relates data from the analytic and general accounts then lets you compare the totals, so you can readjust your estimates of hourly cost per employee depending on the time actually worked.

The following table gives an example of different analytic entries that you can find for your analytic account:
Table 5.4: Analytic entries for the account chart (Case 2)

<table>
<thead>
<tr>
<th>Title</th>
<th>Account</th>
<th>Amount</th>
<th>General Account</th>
<th>Debit</th>
<th>Credit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Study the file (1 h)</td>
<td>Case 1.1</td>
<td>-15</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Search for information (3 h)</td>
<td>Case 1.1</td>
<td>-45</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Consultation (4 h)</td>
<td>Case 2.1</td>
<td>-60</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Service charges</td>
<td>Case 1.1</td>
<td>280</td>
<td>705 – Billing services</td>
<td>280</td>
<td></td>
</tr>
<tr>
<td>Stationery purchase</td>
<td>Administrative</td>
<td>-42</td>
<td>601 – Furniture purchase</td>
<td></td>
<td>42</td>
</tr>
<tr>
<td>Fuel Cost -Client trip</td>
<td>Case 1.1</td>
<td>-35</td>
<td>613 – Transports</td>
<td></td>
<td>35</td>
</tr>
<tr>
<td>Staff salaries</td>
<td>Case 1.1</td>
<td>6201</td>
<td>6201 – Salaries</td>
<td></td>
<td>3 000</td>
</tr>
</tbody>
</table>

You will see that it allows you to make a detailed study of the profitability of different transactions. In this example, the cost of Case 1.1 is 95.00 (the sum of the analytic costs of studying the files, searching for information and service charges), but has been invoiced for 280.00, which gives you a gross profit of 185.00.

But an interest in analytical accounts is not limited to a simple analysis of the profitability of different cases.

This same data can be used for automatic recharging of the services to the client at the end of the month. To invoice clients, just take the analytic costs in that month and apply a selling price factor to generate the invoice. Invoicing mechanisms for this are explained in greater detail in ch-services. If the client requires details of the services used on the case, you can then print the service entries in the analytic account for this case.

Invoicing Analytic Costs

Most software that manages billing enables you to recharge for hours worked. In OpenERP, these services are automatically represented by analytic costs. But many other OpenERP documents can also generate analytic costs, such as credit notes and purchases of goods.

So when you invoice the client at the end of the month, it is possible for you to include all the analytic costs, not just the hours worked. So, for example, you can easily recharge the whole cost of your journeys to the client.

Case 3: IT Services Company

Most IT service companies face the following problems:

- project planning,
- invoicing, profitability and financial follow-up of projects,
- managing support contracts.

To deal with these problems, you would use an analytic chart of accounts structured by project and by contract. A representation of that is given in the following example:
The management of services, expenditures and sales is similar to that presented above for lawyers. Invoicing and the study of profitability are also similar.

But now look at support contracts. These contracts are usually limited to a prepaid number of hours. Each service posted in the analytic accounts shows the remaining available hours of support. For the management of support contracts, you would use the quantities and not the amounts in the analytic entries.

In OpenERP, each analytic line lists the number of units sold or used, as well as what you would usually find there – the amount in currency units (USD or GBP, or whatever other choice you make). So you can sum the quantities sold and used on each analytic account to determine whether any hours of the support contract remain. To differentiate services from other costs in the analytic account, you use the concept of the analytic journal. Analytic entries are then allocated into the different journals:

- service journal,
- expense journal,
- sales journal,
- purchase journal.

So to obtain the detailed breakdown of a support contract, you only have to look at the service journal for the analytic account corresponding to the contract in question.
Finally, the analytic account can be used to forecast future needs. For example, monthly planning of staff on different projects can be seen as an analytic budget limited to the service journal. Accounting entries are expressed in quantities (such as number of hours, and numbers of products), and in amounts in units of currency (USD or GBP perhaps).

So you can set up planning on just the basis of quantities. Analyzing the analytic budget enables you to compare the budget (that is, your plan) to the services actually carried out by month end.

<table>
<thead>
<tr>
<th>Cash Budgets</th>
</tr>
</thead>
<tbody>
<tr>
<td>Problems of cash management are amongst the main difficulties encountered by small growing businesses. It is really difficult to predict the amount of cash that will be available when a company is young and rapidly growing.</td>
</tr>
<tr>
<td>If the company adopts management by case, then staff planning can be represented on the analytic accounts report, as you have seen.</td>
</tr>
<tr>
<td>But since you know your selling price for each of the different projects, you can see that it is easy to use the plan in the analytic accounts to more precisely forecast the amounts that you will invoice in the coming months.</td>
</tr>
</tbody>
</table>
Part IV

Managing your Warehouse
OpenERP’s stock management is at once very simple, flexible and complete. It is based on the concept of double entry that revolutionized accounting. The system can be described by Lavoisier’s maxim “nothing lost, everything changed” or, better, “everything moved”. In OpenERP you do not talk of disappearance, consumption or loss of products: instead you speak only of stock moves from one place to another.

Just as in accounting, the OpenERP system manages counterparts to each of its main operations such as receipts from suppliers, deliveries to customers, profit and loss from inventory, and consumption of raw materials. Stock movements are always made from one location to another. To satisfy the need for a counterpart to each stock movement, the software supports different types of stock locations:

- Physical stock locations,
- Partner locations,
- Virtual locations as counterparts for procurement, production and inventory.

Physical locations represent warehouses and their hierarchical structure. These are generally the locations that are managed by traditional stock management systems.

Partner locations represent your customers’ and suppliers’ stocks. To reconcile them with your accounts, these stores play the role of third-party accounts. Reception from a supplier can be shown by the movement of goods from a partner location to a physical location in your own company. As you see, supplier locations usually show negative stocks and customer locations usually show positive stocks.

Virtual locations as counterparts for production are used in manufacturing operations. Manufacturing is characterized by the consumption of raw materials and the production of finished products. Virtual locations are used for the counterparts of these two operations.

Inventory locations are counterparts of the stock operations that represent your company’s profit and loss in terms of your stocks.

The figure Location Structure when OpenERP has just been installed (page 102) shows the initial configuration of the locations when the software is installed (Warehouse → Warehouse Management → Locations).

### Hierarchical Stock Locations

In OpenERP, locations are structured hierarchically. You can structure your locations as a tree, dependent on a parent-child relationship. This gives you more detailed levels of analysis of your stock operations and the organization of your warehouses.
Locations and Warehouses

In OpenERP a Warehouse represents the place where your physical stock is stored. A warehouse can be structured into several locations at multiple levels. Locations are used to manage all types of storage places, such as at the customer and production counterparts.

For this chapter you can continue using the database with demo data from a previous chapter or start with a fresh database that includes demo data, with Warehouse Management and its dependencies installed and any chart of accounts configured.

In this chapter, the following modules will be used:
### Table 6.1: List of modules

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>stock</td>
<td>to handle the stock functions</td>
</tr>
<tr>
<td>stock_planning</td>
<td>to define planning on products</td>
</tr>
<tr>
<td>stock_location</td>
<td>to define pull and push flows</td>
</tr>
<tr>
<td>delivery</td>
<td>to define delivery methods and costs</td>
</tr>
<tr>
<td>account_anglo_saxon</td>
<td>to illustrate the valuation according to the anglo-saxon principles</td>
</tr>
<tr>
<td>sale_journal</td>
<td>to handle stock by journal</td>
</tr>
<tr>
<td>mrp_jit</td>
<td>to illustrate the just-in-time functionality</td>
</tr>
<tr>
<td>sale_supplier_direct_delivery</td>
<td>to directly deliver the product from the supplier to the customer</td>
</tr>
</tbody>
</table>

### 6.1 Understanding Double-Entry Stock Management

To illustrate this concept of stock management, see how stock moves are generated by the following operations:

- Receiving products from a supplier,
- Delivery to a customer,
- Inventory operation for lost materials,
- Manufacturing.

The structure of stock locations is shown by the figure *Location Structure when OpenERP has just been installed* (page 102). Stocks are assumed to be totally empty and no operation is in progress nor planned.

If you order ‘30 bicycles’ from a supplier, OpenERP will do the following operations on receipt of the products:

<table>
<thead>
<tr>
<th>Location</th>
<th>Products</th>
</tr>
</thead>
<tbody>
<tr>
<td>Partner Locations &gt; Suppliers</td>
<td>-30 bicycles</td>
</tr>
<tr>
<td>Physical Locations &gt; OpenERP S.A. &gt; Stock</td>
<td>+30 bicycles</td>
</tr>
</tbody>
</table>

If you deliver 2 bicycles to a European customer, you will get the following transactions for the delivery:

<table>
<thead>
<tr>
<th>Location</th>
<th>Products</th>
</tr>
</thead>
<tbody>
<tr>
<td>Physical Locations &gt; OpenERP S.A. &gt; Stock</td>
<td>-2 bicycles</td>
</tr>
<tr>
<td>Partner Locations &gt; Customers &gt; European Customers</td>
<td>+2 bicycles</td>
</tr>
</tbody>
</table>
When the two operations are complete, you will see the following stock in each location:

Table 6.4: Resulting Stock Situation

<table>
<thead>
<tr>
<th>Location</th>
<th>Products</th>
</tr>
</thead>
<tbody>
<tr>
<td>Partner Locations &gt; Suppliers</td>
<td>-30 bicycles</td>
</tr>
<tr>
<td>Physical Locations &gt; OpenERP S.A. &gt; Stock</td>
<td>+28 bicycles</td>
</tr>
<tr>
<td>Partner Locations &gt; Customers &gt; European Customers</td>
<td>+2 bicycles</td>
</tr>
</tbody>
</table>

So you can see that the sum of the stocks of a product in all the locations in OpenERP is always zero. In accounting you would say that the sum of the debits is equal to the sum of the credits.

Partner locations (customers and suppliers) are not located under your company in the hierarchical structure, so their contents are not considered as part of your own stock. So if you just look at the physical locations inside your own company, those two bicycles are no longer in your company. Although they are no longer in your own physical stock, it is still very useful to see them in your customer’s stock, because that will help when you carry out detailed stock management analysis.

**Consignment Stock**

To manage Consignment Stock, you need to define the location for the consignment customer or supplier as part of your own stock and not as a partner location.

**Accounts**

In managing stock, a gap between the data in the software and real quantities in stock is difficult to avoid. Double-entry stock management gives twice as many opportunities to find an error. If you forget two items of stock, this error will automatically be reflected in the counterpart’s location.

You can make a comparison with accounting, where you will easily find an error because you can look for an anomaly in an account or in the counterparts: if there is not enough in a bank account then that is probably because someone has forgotten to enter a customer’s invoice payment. You always know that the sum of debits must equal the sum of the credits in both accounting and OpenERP’s stock management.

In accounting, all documents lead to accounting entries that form the basis of management accounting. If you create invoices or enter statements of account, for example, the results of the operations are accounting entries on accounts. And it is the same for stock management in OpenERP. All stock operations are carried out as simple stock moves. Whether you pack items, or manufacture them, or carry out a stock inventory operation, stock moves are carried out every time.

You have seen a fairly simple example of goods receipt and product delivery, but some operations are less obvious – a stock inventory operation, for example. An inventory operation is carried out when you compare the stock shown in software with real stock numbers counted in the stores. In OpenERP, with its double-entry stock management, you would use stock moves for this inventory operation. That helps
you manage your stock traceability. Suppose there are 26 bicycles in real stock, but OpenERP shows 28 in the system. You then have to reduce the number in OpenERP to 26. This reduction of 2 units is considered as a loss or destruction of products and the correction is carried out as in the following operation:

Table 6.5: Inventory Operation to Adjust Stock

<table>
<thead>
<tr>
<th>Location</th>
<th>Products</th>
</tr>
</thead>
<tbody>
<tr>
<td>Physical Locations &gt; OpenERP S.A. &gt; Stock</td>
<td>-2 bicycles</td>
</tr>
<tr>
<td>Virtual Locations &gt; Inventory Loss</td>
<td>+2 bicycles</td>
</tr>
</tbody>
</table>

The product stock under consideration then becomes:

Table 6.6: Real and Counterpart Stocks when Operations are Completed

<table>
<thead>
<tr>
<th>Location</th>
<th>Products</th>
</tr>
</thead>
<tbody>
<tr>
<td>Partner Locations &gt; Suppliers</td>
<td>-30 bicycles</td>
</tr>
<tr>
<td>Physical Locations &gt; OpenERP S.A. &gt; Stock</td>
<td>+26 bicycles</td>
</tr>
<tr>
<td>Partner Locations &gt; Customers &gt; European Customers</td>
<td>+2 bicycles</td>
</tr>
<tr>
<td>Virtual Locations &gt; Inventory Loss</td>
<td>+2 bicycles</td>
</tr>
</tbody>
</table>

This example shows one of the great advantages of this approach in terms of performance analysis. After a few months, you can just make a stock valuation of the location Inventory Control → Location Structure → Virtual Locations → Inventory Loss to give you the value of the company’s stock losses in the given period.

Now see how the following manufacturing operation is structured in OpenERP. To make a bicycle you need two wheels and a frame. This means that there should be a reduction of two wheels and a frame from real stock and the addition of a bicycle there. The consumption / production is formalized by moving products out of and into physical stock. The stock operations for this are as follows:

Table 6.7: Stock Situation Resulting from Manufacturing

<table>
<thead>
<tr>
<th>Location</th>
<th>Products</th>
<th>Step</th>
</tr>
</thead>
<tbody>
<tr>
<td>Physical Locations &gt; OpenERP S.A. &gt; Stock</td>
<td>-2 Wheels</td>
<td>Consumption of raw materials</td>
</tr>
<tr>
<td>Virtual Locations &gt; Production</td>
<td>+2 Wheels</td>
<td>Consumption of raw materials</td>
</tr>
<tr>
<td>Physical Locations &gt; OpenERP S.A. &gt; Stock</td>
<td>-1 Frame</td>
<td>Consumption of raw materials</td>
</tr>
<tr>
<td>Virtual Locations &gt; Production</td>
<td>+1 Frame</td>
<td>Consumption of raw materials</td>
</tr>
<tr>
<td>Virtual Locations &gt; Production</td>
<td>-1 Bicycle</td>
<td>Manufacture of finished products</td>
</tr>
<tr>
<td>Physical Locations &gt; OpenERP S.A. &gt; Stock</td>
<td>+1 Bicycle</td>
<td>Manufacture of finished products</td>
</tr>
</tbody>
</table>

So now you have got the outcome you need from the consumption of raw materials and the manufacturing of finished products.
Assessing Created Value
You might already have noticed a useful effect of this approach: if you do a stock valuation in the Virtual Locations > Production location you get a statement of value created by your company (as a negative amount). Stock valuation in any given location is calculated by multiplying quantities of products in stock by their cost. In this case, the raw material value is deducted from the finished product value.

6.2 Managing Physical Inventory Structure

6.2.1 Warehouse

Warehouses are designed for physical locations from which you can deliver to the customer, and to which you receive raw materials. When you buy products from a supplier, you should take account of the Warehouse you use for this purchase. This also enables the end user to not have to choose from a list of locations, but simply a real warehouse. Use the menu Warehouse → Configuration → Warehouse Management → Warehouses, then click New to configure a new warehouse.

A warehouse is defined by a link between three locations:

- The **Location Stock** field shows the place of products available for delivery to a customer directly from this warehouse. Availability is given by all the products in that location and any child locations.

- The **Location Input** field shows where ordered products are received from a supplier in that warehouse. It can be the same as the stock location if, for example, you want to do a quality control operation on your incoming raw materials.

- The **Location Output** field (called Output in the demonstration database) is designed as a buffer zone in which you store all the items that have been picked, but not yet delivered to a customer. You are strongly advised not to put this location within the stock hierarchy but instead at a higher level or at the same level.

Figure 6.2: Warehouse Parameters
You can also set an address for the warehouse. This address should ideally be an address of your company. Once the warehouse has been defined, it can be used in:

- Minimum stock rules,
- Supplier orders,
- Customer orders (using the definition of a point of sale, which is linked to a warehouse).

**Automatic Procurement**

Several methods of automatically procuring products can be carried out by OpenERP:

- the workflow used by products that have the procurement method *Make to Order*,
- using minimum stock rules for *Make to Stock* products,
- using the master production schedule for *Make to Stock* products.

The last two methods are described below.

**Minimum Stock Rules**

To automatically make stock replenishment proposals, you can use minimum stock rules. Go to the menu *Warehouse → Automatic Procurements → Minimum Stock Rules*.

The rule is the following: if the virtual stock for the given location is lower than the minimum stock indicated in the rule, the system will automatically propose a procurement to increase the level of virtual stock to the maximum level given in the rule.

![Figure 6.3: List of Minimum Stock Rules](image)
Conflicts Resolution

You may find draft production or procurement orders to be created although they should not exist. That can happen if the system is badly configured (for example, if you have forgotten to set the supplier on a product).

To check this, look at the list of procurements in the exception state in the menu Warehouse → Schedulers → Procurement Exceptions. More details about processing these exceptions is given in ch-mnf.

We underline that the rule is based on virtual quantities and not just on real quantities. It takes into account the calculation of orders and receipts to come.

Take the following example:

- Products in stock: 15
- Products ordered but not delivered: 5
- Products in manufacturing: 2

The rules defined are:

- Minimum stock: 13
- Maximum stock: 25.

Once the rules have been properly configured, the purchasing manager only needs to look at the list of orders for confirmation with the supplier using the menu Purchases → Purchase Management → Requests for Quotation.

Procurement

Note that the procurement does not require that you buy from a supplier. If the product has a Supply Method Produce, the scheduler will generate a Manufacturing order instead of a supplier order.

You can also set multiple quantities in the minimum stock rules. If you set a multiple quantity of 3 the system will propose procurement of 15 pieces, and not the 13 it really needs. In this case, it automatically rounds the quantity upwards.
Maximum Quantity

Pay attention to the fact that the maximum quantity is not the maximum you will have in stock. If we take the following situation: a company has 10 pieces of product with minimum stock rules defined for this product by Min quantity = 10, Max quantity = 30 and Qty multiple = 12. If an order of 2 pieces comes, a purchase of 24 pieces order will be executed. The first 12 pieces will be ordered to reach the minimum quantity and the other 12 to reach the maximum quantity. At the end, the stock of this product will be equal to 32 pieces.

In a minimum stock rule, when you indicate a warehouse, it suggests a stock location by default in that warehouse. You can change that default location when the scheduler completes.

6.2.2 Location

A location is one component of the warehouses that is used to managed all types of storage places, such as at the customer’s and production counterparts.

There are different types of locations that allow you to structure your warehouses according to your needs. Locations are structured hierarchically to account for the subdivision of a warehouse into sections, aisles, and/or cupboards. The hierarchical view also enables you to structure virtual locations such as production counterparts. That gives you a finer level of analysis. Go to the menu Warehouse → Configuration → Warehouse Management → Locations, then click New to define new locations.

Figure 6.4: Defining a new Stock Location

Here are the different available types of locations:

- **Supplier Location**: virtual location representing the source location for products received
from suppliers,

- **View**: shows that the location is only an organizational node for the hierarchical structure, and cannot be involved in stock moves itself. The view type is not made into a leaf node in a structure – it usually has children.

- **Internal Location**: physical location inside your own stock,

- **Customer Location**: virtual location representing the destination for products sent to customers,

- **Inventory**: virtual location serving as the counterpart for inventory operations used to correct stock levels (physical inventories),

- **Procurement**: virtual location serving as temporary counterpart for procurement operations when you do not yet know the source (supplier or production). Products in this location should be zero after the scheduler run completes,

- **Production**: virtual counterpart location for production operations; consuming raw material and sending finished products,

- **Transit Location for Inter-Companies Transfers**: used as an intermediate location in a multi-company environment.

You can have several locations of the same type. In that case, your product, supplier and warehouse configurations determine the location that is to be used for any given operation.

### Location Addresses

Each location can have a specific address that enables you to create a location for a customer or a supplier, for example. You can then give it the address of that customer or supplier. Go to the partner form to tell OpenERP it should use this location rather than the default location given to partner deliveries.

---

#### Subcontracting Production

You will see in the online chapter Manufacturing that it is possible to assign a location to a manufacturing workcenter. If this location is at a supplier’s, you must give it an address so that OpenERP can prepare a delivery order for the supplier and a receive operation for the manufactured goods. Creating a location specifically for a partner is also a simple solution for handling consigned stocks in OpenERP.
Consignment Stock

Consignment stock is stock that is owned by you (valued in your accounts), but is physically stocked by your supplier. Or, conversely, it could be stock owned by your customer (not valued by you), but stocked in your company. Make sure that you create consignment locations as part of your internal stock.

To enable you to easily consolidate at a higher level, the location definition is hierarchical. This structure is given by the field Parent Location. That also enables you to manage complex cases of product localization.

For example, you could imagine the following scenario: One Company with Two Warehouses

A company has a warehouse in Paris and in Bordeaux. For some orders, you have to deliver the products from Paris, and for others from Bordeaux. But you should also specify a fictitious warehouse that OpenERP uses to calculate whether it should deliver products from Paris or from Bordeaux. To do this in OpenERP, you would create a third warehouse ‘France’ which consolidates the warehouses in Paris and Bordeaux. You create the following physical locations:

- Company
  - Output
    - Warehouses France
      - Warehouse Paris
      - Warehouse Bordeaux

OpenERP will then deliver the goods from the warehouse that has the ordered product in stock. When products are available in several warehouses, OpenERP will select the nearest warehouse. To formalize the notion of distance between warehouses you should use the geographic co-ordinates (X, Y, Z) of the different stores to enable OpenERP to search for the nearest goods. The same co-ordinates could also be used to structure the shelves, aisles and interior rooms in a warehouse.

Linked Locations

Locations in OpenERP can be linked between each other to define paths followed by products. So you can define rules such as: all products that enter the warehouse should automatically be sent to quality control. The warehouse and quality control are represented by two different locations.

Then when a product arrives in a location, OpenERP can automatically suggest that you send the product to another linked location. Three link modes are available:

- Manual Operation,
- Automatic Move,
- Automatic No Step Added.
The *Manual Operation* mode will create an internal move order to the linked location once products arrive in the source locations. This order will wait for a confirmation of the move by a user. This enables you to have a list of moves to do, proposed by the system and confirmed by the storesperson.

The *Automatic Move* mode will do the same, but will not wait for a confirmation from the user. Products will automatically be sent to the linked location without any intervening manual operation to do. This corresponds to the case where, for simplicity, you delete a step in the process so the end user can set off the process automatically.

The *Automatic No Step Added* mode will not include the additional stock move, but will change the destination move transparently to assign the linked location. You could then assign a destination location to which you send all the products that arrive in your warehouse. The storesperson will modify the goods receipt note.

### Product Logistics

The module `stock_location` lets you generate paths to follow, not just at the level of locations, but also at the level of products. It then enables you to manage default locations for a given product or to refer to the products as a function of operations such as quality control, supplier receipt, and after-sales service.

A more detailed explanation of this module, with examples, is given at the end of this chapter.

If there is linking to do, the *Chained Location Type* field allows you to determine the destination location. If the field is set to ‘Customer’, the location is given by the properties of the partner form. If the field is set to `fixed`, the destination location is given by the field `Chained Location If Fixed`.

Some operations take a certain time between order and execution. To account for this lead time, you can set a value in days in the field *Chaining Lead Time*. Then the extra move (automatic or not) will be carried out several days after the original move. If you use the mode *Automatic No Step Added*, the lead time is inserted directly into the initial order. In this way, you can add security lead times at certain control points in the warehouse.

### Structuring Locations

In the next part, you will see that by linking locations you can manage a whole series of complex cases for efficient production management:

- Handling multiple operations for a customer order,
- Tracking import and export by sea transport,
- Managing a production chain in detail,
- Managing rented products,
- Managing consigned products.
To show these concepts, different cases of structuring and configuring these locations are given below. Many other configurations are possible according to company needs.

Examples:

- **Handling customer orders**

Customer orders are usually handled in one of two ways:

- item note (or preparation order), confirmed when the item is ready to send,
- delivery order (or freight note), confirmed when the transporter has delivered the item to a customer.

You use the following stock move in OpenERP to simulate these operations:

- Packing Note: Stock > Output,
- Delivery Order: Output > Customer.

The first operation is automatically generated by the customer order. The second one is generated by the stock management, showing that the Output location is linked to the Customer location. The two operations will be displayed in *Waiting* status. If the Output location is not situated beneath the stock location, you then have to move the item from stock to the place where the item is prepared.

Some companies do not want to work in two steps, because it just seems like extra work to have to confirm a delivery note in the system. You can then set the link mode to ‘Automatic’ to make OpenERP automatically confirm the second step. It is then assumed all the items have automatically been delivered to the customer.

- **Linked production**

The *stock_location* module enables you to manage the linkages by product in addition to doing that by location. You can then create a location structure that represents your production chain by product.

The location structure may look like this:

- Stock
  - Level 1
  - Level 2
    - Link 1
      - Operation 1
      - Operation 2
      - Operation 3
      - Operation 4

You can then set the locations a product or a routing must go through in the relevant form. All products that enter the production chain will automatically follow the predetermined path. You can see the location structure using *Warehouse → Inventory Control → Location Structure*. 
6.2.3 Shop

The counterparts for procurement, inventory and production operations are given by the locations shown in the product form. The counterparts of reception and delivery operations are given by the locations shown in the partner form. The choice of stock location is determined by the configuration of the warehouse, linked to a Shop, which can be defined using Sales → Configuration → Sales → Shop.

Once a shop is defined, you will be able to make sales orders from this shop. You need at least one shop in order to be able to make sales orders.

6.2.4 Stock

In the Product form, the Stock by Location action will give you the stock levels of the various products in any selected location. If you have not selected any location, OpenERP calculates stocks for all of the physical locations. When you are in the Stock by Location view, click the Print button to print the Location Content or the Location Inventory Overview reports.

Availability of Stock

Depending on whether you look at the product from a customer order, or from the menu of a product form, you can get different values for stock availability. If you use the Product menu, you get the stock in all of the physical stock locations. Looking at the product from the order you will only see the report of the warehouse selected in the order.

In this respect, two important fields in the product form are:

- Real Stock: Quantity physically present in your warehouse,
- Virtual Stock: Calculated as follows: real stock – outgoing + incoming.

Virtual Stock

Virtual stock is very useful because it shows what the salespeople can sell. If the virtual stock is higher than the real stock, this means products will be coming in. If virtual stock is smaller than real stock, certain products are reserved for other sales orders or work orders.

Detail of Future Stock

To get more details about future stock, you can click Stock Level Forecast to the right of the product form to get the report Forecast Stock Levels as illustrated below. OpenERP shows a graph of the changes in stock in the days to come, varying as a function of purchase orders, confirmed production and sales orders.
Figure 6.5: Printout of forecast stock levels

**Filter Stock by Location**

By default, in Product list view, the columns Real Stock and Virtual Stock show the stock figures for all stock locations where a product is stored. Use the Extended Filters to enter a specific stock location, if you want to only see the stock in a specific location.

**Lead Times and Locations**

The tab **Procurement & Locations** in the Product form contains information about different lead times and locations. Three lead time figures are available:

- **Customer Lead Time**: lead time promised to the customer, expressed in number of days between the order and the delivery to the customer,

- **Manufacturing Lead Time**: lead time, in days, between a production order and the end of production of the finished product,

- **Warranty (months)**: length of time in months for the warranty of the delivered products.

**Warranty**

The warranty period is used in the Repairs management and after-sales service. You can find more information on this subject in the online chapter about Manufacturing.
Fields in the section *Storage Localisation* are for information only; they do not have any impact on the management of stock.

*Counter-Part Locations Properties* are automatically proposed by the system, but the different values can be modified. You will find counterpart locations for:

- Procurement,
- Production,
- Inventory.

A procurement location is a temporary location for stock moves that have not yet been finalized by the scheduler. When the system does not yet know if procurement is to be done by a purchase or production, OpenERP uses the counterpart location Procurement. In this location, you will find everything that has not yet been planned by the system. The quantities of product in this location cancel each other out.

**Initial Inventory**

Once a product has been defined, use an initial inventory operation to put current quantities into the system by location for the products in stock. Go to the menu *Warehouse → Inventory Control → Physical Inventories* to do your initial inventory.

![Figure 6.6: Defining a New Inventory Operation](image)

116  CHAPTER 6. YOUR WAREHOUSE
Give a name (for example Initial Inventory or Lost Product XYZ) and a date (proposed by default) for each inventory operation.

You have three ways of doing an inventory.

- Click the Import Inventory action and select the location concerned. You can choose to include child locations and set the inventory to zero (especially useful to ensure the count is done correctly).

- You can update the inventory from the Product form. Go to the Information tab, Stocks section, and click the Update button. On confirmation, OpenERP will create a Physical Inventory.

- You can manually add inventory lines. You can then enter data about the quantities available for each product by location. Start by entering the location, for example Stock, and then select the product. OpenERP automatically completes the quantity available for that product in the location shown. You can then change that value to correct the value in stock.

Enter data for a single line in your inventory:

- **Location**: Stock,
- **Product**: PC1 Basic PC,
- **Quantity**: 23 Units.

When your inventory operation is finished, you can confirm it using the Confirm Inventory button to the bottom right of the form. OpenERP will then automatically create the stock moves to close the gaps, as mentioned at the start of this chapter. You can verify the moves generated using the Posted Inventory tab of the inventory operation form.

The correct levels of your product are now in your stock locations. A simple way of verifying this is to reopen the product form to see the quantities available in stock.

---

**Periodical Inventory**

You are usually legally required to do a stock check of all your products at least once a year. As well as doing a complete annual stock check, OpenERP also supports the method of periodical inventory.

That means you can check the stock levels of a proportion of your products every so often. This system is accepted in France as long as you can guarantee that all of your products have been counted at least once per year. To see the last inventory count per product, use the report Warehouse → Reporting → Last Product Inventories.

You can do this the same way for all products and all locations, so you only carry out small inventory operations through the year, rather than a single large stock check at one point in the year (which usually turns out to be at an inconvenient time).
6.3 Keeping Track of Stock Movements

6.3.1 Goods Receipts

In OpenERP, you have the choice between three ways to receive goods from suppliers.

The first method is to manually enter the information in the incoming shipment. To receive the products through this method, you have to go to Incoming Shipments section in the Warehouse Management submenu, click New and then you enter the information about the receipt.

![Figure 6.7: Manual Data Entry for Product Receipt](image)

The second method is to receive products from a generated incoming shipment. To achieve the reception using this method, you have to go to Incoming Shipments section in the Warehouse Management submenu. You will find the list of waiting incoming shipments.

The third method is to receive products by waiting products without looking at the shipment document. You can validate the reception by products in Receive Products section in the :guilabel:`Product Moves` submenu. With this method, you will be able to receive one product, regardless of the document which is attached to this product.

**Receipt of a Supplier Order by Purchase Order**

If you use Purchase Orders in OpenERP, product receipts are automatically generated by the system when the purchase order is confirmed. You do not have to enter any date, just confirm that the quantities ordered match the quantities received.

Incoming Shipments forms are automatically prepared by OpenERP from the purchase management process. You will find a list of all the awaited receipts in the menu Warehouse → Warehouse Management → Incoming Shipments. Use the order number or the supplier name to find the right goods receipt form for confirmation of a goods-in. This approach enables you to control quantities
received by referring to the quantities ordered.

You can also do goods-in data entry manually if there is no order, using the same menu by clicking the New button.

A new goods-in data entry form opens. Enter the supplier data in the Address field and type the reference number from your supplier in the field Origin. You should then enter data about the products received in the lines.

The source location is already completed by default because of your supplier selection. You should then give the destination location where you will place the products. For example, enter Stock. At this stage, you can set a lot number for traceability (this function will be described later in this chapter, so leave this field empty for the moment).

Once the form has been completed, you can confirm the receipt of all the products at the same time using the Process Now button. If you want to enter data for a goods receipt that you are still waiting for, click the button Process Later.
Partial or Complete Reception

When you process the incoming shipment, you can choose between partial or complete.

If you have to validate a partial incoming shipment, click **Process now** and change the number of items according to the quantity received.

![Figure 6.9: Confirm partial reception](image)

Another object will be generated with a back order reference equal to the reference number of the incoming shipment already confirmed.

![Figure 6.10: Process a Partial Incoming Shipment](image)

Once the rest of the order has arrived and has been processed, both orders will be merged.

![Figure 6.11: Form for Entering Goods received from a Supplier Order](image)

The products then arrive in stock and should reflect the quantities shown on the product form.

In the *Incoming Shipments* form, the field *Invoice Control* lets you influence the way you send invoices to suppliers. If this is set to **To be invoiced**, a supplier invoice will now be generated.
automatically in the draft state, based on the goods received. Your accountant then has to confirm this pre-invoicing once the supplier’s invoice is received. This enables you to verify that the invoiced quantities correspond to the quantities received.

### Print the Packing List

In order to print the packing list of an incoming shipment, select the incoming shipment of which you need the details and click Packing List in the panel at the right side of the screen.

This link is available in the Internal Moves and Delivery Orders sections.

In case you received damaged or wrong products, you can return them to the supplier. In the Incoming shipment form, click the Return Products button. A window will open that lets you choose the invoicing process to follow. Once you click Process, a stock move is generated with the same reference number and return to specify that this is a return move.

![Figure 6.12: Stock Move for Returned Products](image)

### Receipt of a Supplier Order by Product

The approach shown above is very useful if goods receipts correspond to the original orders. If your suppliers deliver items that do not necessarily coincide with the orders, however, it is easier to work by products received rather than by orders.

From this version on, you can also handle receptions by product, even from List view. Go to Warehouse → Products Moves → Receive Products.

Filters allow you to easily select receipts to be done, and so on. One way to quickly receive products is to Group by Supplier and select To Do.

This is very useful functionality when your supplier sends the goods for several purchase orders at a time. You can now just receive the products, regardless of the purchase order they come from, simply by clicking the green arrow at the right side of the screen.

The List view offers great flexibility and allows you to rapidly receive products by keeping full functionality! Of course, you can handle both partial and complete receptions, and you can add information about the production lots and packs.

This can be also accomplished from Form view.
6.3.2 Internal Stock Moves

You should install the `stock_location` module (from the list of modules, or through Reconfigure wizard, Advanced Routes) if routing products to customers, from suppliers or in your warehouse is determined by the identity of the product itself.

This will let you configure logistics rules individually for each product. For example, when a specific product arrives in stores, it can automatically be sent to quality control. In this case, it has to be configured as a Push Flow with rules in the Product form. The fields that make up those rules are:

- **Source Location**: the rule only applies if a product comes from this location,
- **Destination Location**: the rule only applies if a product ends up in this location,
• **Automatic Move**: Automatic Move, Manual Operation, Automatic No Step Added,

• **Delay (days)**,

• **Operation**: a free text field which will be included in the automatic stock move proposed by OpenERP.

There are two main logistic flows:

• **Pushed Flows**

• **Pulled Flows**

*Push* flows are useful when the arrival of certain products in a given location should always be followed by a corresponding move to another location, optionally after a certain delay. The original Warehouse application already supports such Push flow specifications on the Locations themselves, but these cannot be refined per product. *Pull* flows are a bit different from Push flows, in the sense that they are not related to the processing of product moves, but rather to the processing of procurement orders. What is being pulled is a need, not directly products. You will now see some examples of using these locations and logistics by product through Pushed Flows for:

- A rentable product,

- A product bought in China, following its freight by ship from port to port,

- A product that you want to send to quality control before putting it in stocks.

We will develop the third scenario: **the quality control**.

You can configure the system to put a given product in the Quality Control bay automatically when it arrives in your company. To do that, you just configure a rule for the product to be placed in the Quality Control location rather than the Input location when the product is received from the supplier.

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source location</td>
<td>Stock</td>
</tr>
<tr>
<td>Destination location</td>
<td>Quality Control</td>
</tr>
<tr>
<td>Automatic Move</td>
<td>Manual Operation</td>
</tr>
<tr>
<td>Shipping Type</td>
<td>Getting Goods</td>
</tr>
<tr>
<td>Delay (days)</td>
<td>0</td>
</tr>
<tr>
<td>Operation</td>
<td>Quality Control</td>
</tr>
</tbody>
</table>

Once this product has been received, OpenERP will automatically manage the request for an internal movement to send it to the Quality Control location. If you want to do this automatically without having to confirm it, in the **Automatic Move** field, select *Automatic Move* or *Automatic No Step Added*. 
With the configuration described in the table above, you will have to confirm the stock move manually once you have received the goods.

If you do not want to confirm the stock move manually, but you want to see the move Suppliers -> Stock then Stock -> Quality Control, change the Automatic Move field and select Automatic Move. With this configuration, you will see the two stock moves.

6.3.3 Shipping of Goods

In the same way as delivering goods, you can ship goods in three different ways:

- manually enter data,
- deliver goods according to a sales order,
- deliver goods by product.
Everything about goods receipt can also be done manually in the same way for a customer delivery. This time, use the automated product delivery processes based on customer orders. Install the sale module (Reconfigure wizard, Sales Management), so that you can proceed further in this section of the chapter.

Now create a new sales order from the menu Sales → Sales → Sales Orders. Enter the following data in this order:

- **Shop**: OpenERP S.A.
- **Customer**: Agrolait
- **Sales order lines**:
  - **Product**: [PC2] Basic+ PC (assembly on order),
  - **Quantity (UoM)**: 3,
  - **Product UoM**: PCE,
  - **Procurement Method**: from stock.

You have already seen that OpenERP shows the available product stock in list view. The real stock is equal to the virtual stock because you have nothing to deliver to customers and you are not waiting for any of these products to be received into stock. The salesperson then has all the information needed to take orders efficiently.

Then confirm the quotation to convert it to an order. If you return to the product form, you will see the virtual stock is now smaller than the real stock.

Start the scheduler through the menu Warehouse → Schedulers → Compute Schedulers. Its functionality will be detailed in ch-mnf. This manages the reservation of products and places orders based on the dates promised to customers, and the various internal lead times and priorities. Three products will be reserved in the order that you created, so they cannot be sold to another customer.
Just in Time

Install the module mrp_jit to schedule each order in real time after it has been confirmed. This means that you do not have to start the scheduler or wait for its periodical start time.

Now have a look at the list of deliveries waiting to be carried out using the menu Warehouse → Warehouse Management → Delivery Orders. You find a line there for your order representing the items to be sent. Double-click the line to see the detail of the items proposed by OpenERP.

States

OpenERP distinguishes between the states **Confirmed** and **Assigned**.

An item is **Confirmed** when it is needed, but the available stock may be insufficient. An item is **Assigned** when it is available in stock and the storesperson reserves it: the necessary products have been reserved for this specific operation.

You can also confirm a customer delivery from a confirmed Sales Order. When you click the *Process* button of *Outgoing Deliveries*, a window opens where you can enter the quantities actually delivered. If you enter a value less than the forecasted one, OpenERP automatically generates a partial delivery note and a new order for the remaining items. For this exercise, just confirm all the products.

However, if you want to look at a partial shipping, an example will be developed at the end of this section.
If you return to the list of current orders, you will see that your order has now been marked as delivered (Done). A progress indicator from 0% to 100% is shown by each order so that the salesperson can follow the progress of his orders at a glance.

![List of Orders with their Delivery State](image)

** Figure 6.20: List of Orders with their Delivery State **

### Negative Stock

Stock Management is very flexible to be more effective. For example, if you forget to enter products at goods-in, this will not prevent you from sending them to customers. In OpenERP, you can force all operations manually using the button *Force Availability*. In this case, your stocks risk to become negative. You should monitor all stocks for negative levels and carry out an inventory correction when that happens.

### Partial Shipping

Should you have to process a partial delivery, you can go to *Warehouse → Warehouse Management → Delivery Orders*, then select the order to process it. In the new window, change the quantity to ship and then confirm it.

If you go back to the list view, you will now see a new delivery order with a back order number equal to the just confirmed order. This is illustrated in the following figure.

![Partial Shipping](image)

** Figure 6.21: Partial Shipping **

In the stock moves, you will see that there are two moves. The first move is for the remaining quantities to ship and the second one is for the shipped goods. There will be more stock moves if you process
partial shipping in more than two times.

![Figure 6.22: Stock Moves in Partial Shipping](image)

**Return Products from Customers**

If a customer returns damaged or wrongly delivered products, you can enter this information in OpenERP via **Warehouse → Warehouse Management → Delivery Orders**.

You have to select the order related to the returned products and click the **Return Products**. A new window will open and will let you choose the invoicing method.

![Figure 6.23: Return Products from Customers](image)

When the product is returned, it will go back to your stock and you will see a stock move from **Customers → Shelf 1**.

![Figure 6.24: Stock Move for a Returned Product](image)

**Just In Time**

By default, scheduling starts automatically once a day. You should make this scheduling execute overnight to ensure that the system does not slow down under a heavy load of scheduling when you are also trying to use it interactively.

To set the start time for the scheduler, go to the menu **Administration → Configuration → Scheduler → Scheduled Actions**. Select the rule called ‘Run mrp scheduler’ and modify the date and time of the next execution. Some companies want to plan orders progressively as they are entered, so they do not wait until procurement orders are planned the next day. Install the module **mrp_jit** (*Reconfigure* wizard,
**Just In Time Scheduling** to handle this. Once the module is installed, each requirement (that could result in a Production or Purchase Order) will be planned in real time as soon as it has been confirmed.

Then if you make a sales order with a product that is Make To Order, the quotation request to a supplier will immediately be generated.

**Delivery from the Supplier or to the Customer**

The `sale_supplier_direct_delivery` module enables you to deliver the product directly from the supplier to the customer. At the time of writing, this module is in extra-addons. The logic that the product follows is configured individually for each product and affects only products marked Make to Order.

This mode does not always make sense. Each order is processed immediately when confirmed. So if an order is to be delivered in three months, the scheduler will reserve goods in stock for each order once it has been confirmed. It would have been more sensible to leave these products available for other orders.

If a Purchase Order’s Invoicing Control is configured From Order, the scheduler will immediately create the corresponding supplier quotation request. It might have been better to delay it for several weeks, if you could have used the lead time to group the purchase with other future orders.

So the negative effects of working with the Just in Time module are:

- Poor priority management between orders,
- Additionally stocked products.

### 6.3.4 Logistics Configuration through Advanced Routes

To configure your logistics for advanced push and pull, you need to install `stock_location` module (*Reconfigure wizard, Advanced Routes*) as explained before. A complete scenario will be developed at the end of this chapter.

This module supplements the **Warehouse** application by adding support for location paths per product, effectively implementing Push and Pull inventory flows.

Typically this could be used to:

- Manage product manufacturing chains,
- Manage default locations per product,
- Define routes within your warehouse according to business needs, such as:
  - Quality Control
  - After Sales Services
  - Supplier Returns
• Help rental management, by generating automated return moves for rented products.

Once this module is installed, an additional Logistics Flows tab appears in the Product form, allowing you to add Push and Pull flow specifications.

Push Flow

Push flows are useful when the arrival of certain products in a given location should always be followed by a corresponding move to another location, optionally after a certain delay.

The core Warehouse Management application already supports such Push Flow specifications on the Locations, but these cannot be refined per product.

A push flow specification indicates which location is chained with another location, as well as the parameters used. As soon as a given quantity of products is moved to the source location, a chained move is automatically foreseen according to the parameters set on the flow specification (destination location, delay, type of move, journal, etc.) The new move may be processed automatically, or may require a manual confirmation, according to what you have defined.

Suppose whenever the demo data product CPU3 enters the Stock location, it first has to be moved to the Quality Control location in order to check the quality.

Look up the product CPU3 using the menu Warehouse → Product → Products.

To have OpenERP accomplish this move automatically, you have to configure the Push flow as follows:

• **Operation:** Receptions to Quality Control
• **Source Location:** Stock
• **Destination Location:** Quality Control
• **Automatic Move:** Automatic No Step Added
• **Delay (days):** 1
• **Shipping Type:** Getting Goods
• **Invoice Status:** Not Applicable

A push flow is related to how stock moves should be generated in order to increase or decrease inventory.
Pull Flow

*Pull flows* are a bit different from Push flows, in the sense that they are not related to the processing of product moves, but rather to the processing of procurement orders. What is being pulled is a *need*, not directly products.

A classical example of a Pull flow is when you have an Outlet company, with a parent Company that is responsible for the supplies of the Outlet.


**Demo Data**

In our demo data example, the Outlet Company is Shop 1, while OpenERP SA is the parent company.

When a new procurement order A (resulting from the confirmation of a Sales Order, for example) is created in the Outlet (Shop 1), it is converted into another procurement B (through a Pull flow of the
‘move’ type) requested from the Holding. When procurement order B is processed by the Holding company (OpenERP SA), and if the product is out of stock, it may be converted into a Purchase Order (C) from the Supplier (Push flow of the ‘Buy’ type). The result is that the procurement order, the need, is pushed all the way between the Customer and Supplier.

Technically, Pull flows allow to process procurement orders differently, not only depending on the product being considered, but also depending on which location holds the “need” for that product (i.e. the destination location of that procurement order).

To explain a pull flow for the product CPU1, we first have to configure the minimum stock rules of CPU1 for the company OpenERP S.A. and Shop 1 using the menu Warehouse → Automatic Procurements → Minimum Stock Rules or by selecting the product concerned and then clicking the Minimum Stock Rules action.

If you work with the demo data, these minimum stock rules have already been defined.

For the company OpenERP S.A.:

- **Min Quantity**: 10
- **Max Quantity**: 50

For the company Shop 1:

- **Min Quantity**: 10
- **Max Quantity**: 20

Look up the product CPU1 using menu Warehouse → Product → Products in order to define the configuration of the pulled flow.

There are two specifications of a pull flow for product CPU1.

**Specification 1:**

- **Name**: Receive from Warehouse
- **Destination Location**: Shop 1
- **Type of Procurement**: Move
- **Source Location**: Internal Shippings
- **Partner Address**: OpenERP S.A., Belgium Gerompont Chaussee de Namur 40
- **Shipping Type**: Getting Goods
- **Procure Method**: Make to Order
Figure 6.26: Pull Flow Specification for Product CPU1

- **Invoice Status**: Not Applicable

**Specification 2:**

- **Name**: Deliver Shop
- **Destination Location**: Internal Shippings
- **Type of Procurement**: Move
- **Source Location**: Stock
- **Partner Address**: Fabien
- **Shipping Type**: Sending Goods
- **Procure Method**: Make to Stock
- **Invoice Status**: Not Applicable

Now sell 1 unit of product CPU1 from the Shop1 (do not forget to confirm your sales order) and run the scheduler using the menu Warehouse → Schedulers → Compute Schedulers. Then check the stock moves for product CPU1 from the menu Warehouse → Traceability → Stock Moves.
Figure 6.27: Stock Move of CPU1 related to Pull Flow Specification

These moves can be explained like this:

[ Customer ] ← [ Shop 1 ] ← Internal Shippings ← Stock ← [ OpenERP S.A. ]

When the company Shop 1 sells one unit of CPU1 to a customer, its stock decreases to 10 units. According to the minimum stock rule of the product CPU1, OpenERP generates a procurement order of 21 units of CPU1 for the company Shop 1 (OP/00007, or another number if you have added extra data). So 21 units of CPU1 move from OpenERP S.A. Stock to Shop 1 according to their internal configuration of Source and Destination Locations.

A pull flow is related to how the procurement process runs in order to find products to increase or decrease inventory.

### 6.3.5 Procurement Methods – Make to Stock and Make to Order

The procurement method determines how the product will be replenished:

- **Make to Stock**: your customers are supplied from available stock. If the quantities in stock are too low to fulfil the order, a Purchase Order (according the minimum stock rules) will be generated in order to get the products required. Example: a classic distributor.

- **Make to Order**: when a customer order is confirmed, you procure or manufacture the products for this order. A customer order ‘Make to Order’ will not modify stock in the medium term because you restock with the exact amount that was ordered. Example: computers from a large supplier assembled on demand.
You find a mix of these two modes used for the different final and intermediate products in most industries. The procurement method shown on the product form is a default value for the order, enabling the salesperson to choose the best mode for fulfilling a particular order by varying the sales order parameters as needed.

The figures *Change in Stock for a Make to Stock Product* (page 135) and *Change in Stock for a Make to Order Product* (page 135) show the change of stock levels for one product managed as *Make to Order* and another managed as *Make to Stock*. The two figures are taken from OpenERP’s *Stock Level Forecast* report, available from the product form.
Logistical Methods

The Make to Stock logistical approach is usually used for high volumes and when the demand is seasonal or otherwise easy to forecast. The Make to Order approach is used for products that are measured, or very expensive to stock or have a short restocking time.

6.3.6 Choosing Supply Methods

OpenERP supports two supply methods:

- Produce: when the product is manufactured or the service is supplied from internal resources.
- Buy: when the product is bought from a supplier.

These are just the default settings used by the system during automated replenishment. The same product can be either manufactured internally or bought from a supplier.

These three fields (Supply Method, Procurement Method, Product Type) determine the system’s behaviour when a product is required. The system will generate different documents depending on the configuration of these three fields when satisfying an order, a price quotation to a supplier or a manufacturing order.

OpenERP manages both stockable products and services. A service bought from a supplier in Make to Order mode, will generate a subcontract order from the supplier in question.

Figure Workflow for Automatic Procurement, depending on the Product Configuration (page 137) illustrates different cases for automatic procurement.

The table below shows all possible cases for the figure Workflow for Automatic Procurement, depending on the Product Configuration (page 137).

<table>
<thead>
<tr>
<th>Procurement Method</th>
<th>Produce</th>
<th>Buy</th>
</tr>
</thead>
<tbody>
<tr>
<td>MTS</td>
<td>Wait for availability</td>
<td>Wait for availability</td>
</tr>
<tr>
<td>MTO</td>
<td>Production Order</td>
<td>Purchase Order</td>
</tr>
</tbody>
</table>

Table 6.9: Consequences of Procurement Methods Make to Stock (MTS) and Make To Order (MTO)

<table>
<thead>
<tr>
<th>Procurement Method</th>
<th>Produce</th>
<th>Buy</th>
</tr>
</thead>
<tbody>
<tr>
<td>MTS</td>
<td>/</td>
<td>/</td>
</tr>
<tr>
<td>MTO</td>
<td>Create task</td>
<td>Subcontract</td>
</tr>
</tbody>
</table>

Table 6.10: Consequences of Procurement Methods when using Services
6.3.7 Packaging with Various Logistics Units of Measure

Units of Measure

OpenERP supports several units of measure. Quantities of the same product can be expressed in several units of measure at once. For example, you can buy grain by the tonne and resell it by kg. You just have to make sure that all the units of measure used for a product are in the same units of measure category.

Categories of Units of Measure

All units of measure in the same category are convertible from one unit to another.

The table below shows some examples of units of measure and their category. The factor is used to convert from one unit of measure to another as long as they are in the same category.
Table 6.11: Example Units of Measure

<table>
<thead>
<tr>
<th>UoM</th>
<th>Category</th>
<th>Ratio</th>
<th>UoM Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Kg</td>
<td>Weight</td>
<td>1</td>
<td>Reference</td>
</tr>
<tr>
<td>Gram</td>
<td>Weight</td>
<td>1000</td>
<td>Smaller</td>
</tr>
<tr>
<td>Tonne</td>
<td>Weight</td>
<td>1000</td>
<td>Bigger</td>
</tr>
<tr>
<td>Hour</td>
<td>Working time</td>
<td>8</td>
<td>Smaller</td>
</tr>
<tr>
<td>Day</td>
<td>Working time</td>
<td>1</td>
<td>Reference</td>
</tr>
<tr>
<td>Half-day</td>
<td>Working time</td>
<td>4</td>
<td>Smaller</td>
</tr>
<tr>
<td>Item</td>
<td>Unit</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>100 Items</td>
<td>Unit</td>
<td>0.01</td>
<td></td>
</tr>
</tbody>
</table>

Depending on the table above, you have 1Kg = 1000g = 0.001 Tonnes. A product in the Weight category could be expressed in Kg, Tonnes or Grammes. You cannot express it in hours or pieces, for example.

Use the menu Warehouse → Configuration → Products → Units of Measure → Units of Measure to define a new unit of measure.

In the definition of a Unit of Measure, you have a Rounding precision factor which shows how amounts are rounded after the conversion. A value of 1 gives rounding to the level of one unit. 0.01 gives rounding to one hundredth.

Secondary Units

OpenERP supports double units of measure. Notice however that the default unit of measure and the purchase unit of measure have to be in the same category. Only the sales unit of measure may be in a different category.

This is very useful in the agro-food industry, for example: you sell ham by the piece, but invoice by the Kg. A weighing operation is needed before invoicing the customer.

To activate the management options for double units of measure, assign the group Useability / Product UoS View to your user.

In this case, the same product can be expressed in two units of measure belonging to different categories for sales and stock/purchase. You can then distinguish between the unit of stock management (the piece) and the unit of invoicing or sales (kg).

![Figure 6.31: Secondary Unit of Measure](image)

In the product form you can set one unit of measure for sales and stock management, and one unit of
measure for purchases.

For each operation on a product, you can use another unit of measure, as long as it can be found in the same category as the two units already defined. If you use another unit of measure, OpenERP automatically handles the conversion of prices and quantities.

So if you have 430 Kg of carrots at 5.30 EUR/Kg, OpenERP will automatically make the conversion if you want to sell in tonnes – 0.43 tonnes at 5300 EUR / tonne. If you had set a rounding factor of 0.1 for the tonne unit of measure, OpenERP will tell you that you have only 0.4 tonnes available.

**Packaging**

The packaging allows you to ship products in several ways. For example, you can ship goods by boxes or by pallets.

At first, you have to define possible packaging. To define the packaging, go to: Warehouse -> Configuration -> Product -> Packaging and click New.

![Packaging definition](image1)

Figure 6.32: *Packaging definition*

To complete the creation of a new packaging, you have to give it a name and a type. Different types are available in OpenERP: Box, Pack, Pallet and Unit.

Once all packaging is defined, you can attach the packaging to your products through the following menu: Warehouse -> Configuration -> Product -> Packaging.

![Defining the Packaging for the Product](image2)

Figure 6.33: *Defining the Packaging for the Product*
6.4 Scheduling Procurements

The master production plan, sometimes called the MPS (Master Production Schedule), enables you to generate forecasts for incoming and outgoing material. It is based on forecasts of inputs and outputs by the logistics manager.

To be able to use the production plan, you must install the `stock_planning` module.

---

**MPS, Procurement and Production**

OpenERP distinguishes between Production, Purchase and Procurement.

Production is manufacturing, Purchase is the acquisition of goods from another party, and Procurement is either one or both of those. So it would be better to call the MPS the Master Procurement Schedule. Which OpenERP does!

---

**Product Trading**

Also called the Production Plan, this tool is also very useful for traded products which are not manufactured. You can use it for stock management with purchased and manufactured products.

---

6.4.1 Processing Exceptions

The set of stock requirements is generated by procurement orders.

In normal system use, you do not need to worry about procurement orders because they are automatically generated by OpenERP and the user will usually work on the results of a procurement: a production order, a purchase order, a sales order and a task.

If there should be configuration problems, the system can remain blocked by a procurement without generating a corresponding document. For example, suppose that you configure a product `Procurement Method` as `Make to Order`, and `Supply Method` as `Produce`, but you have not defined the bill of materials. In that case, procurement of the product will stay blocked in an exception state `No Bill of Materials defined for this product`. You then have to create a bill of materials to solve the problem.

Troubleshooting:

- No bill of materials defined for production: you need to create a BoM or indicate that the product can be purchased instead.
- No supplier available for a purchase: you have to define a supplier in the `Supplier` tab of the product form.
- No address defined on the supplier partner: you have to complete an address for the default supplier for the product concerned.
• No quantity available in stock: you have to create a rule for automatic procurement (for example, a minimum stock rule) and put it in the order, or manually procure it.

Some problems are just those of timing and can be automatically corrected by the system. Use the menu Warehouse → Schedulers → Procurement Exceptions to see all the exceptions.

If a product has to be ‘in stock’, but is not available in your stores, OpenERP will make the exception as ‘temporary’ or ‘to be corrected’. The exception is temporary if the system can procure it automatically, for example, if a procurement rule is defined for minimum stock.

![Figure 6.34: Example of a Procurement in Exception](image)

If no procurement rule is defined, the exception has to be corrected manually by the user. Once the exception is corrected, you can restart by clicking Retry. If you do not do that, OpenERP will automatically recalculate on the next automated requirements calculation.

### 6.4.2 Manual Procurement

To procure internally, you can create a procurement order manually. Use the menu Warehouse → Schedulers → Procurement Exceptions and click the New button to do this.

The procurement order will then be responsible for calculating a proposal for automatic procurement for the product concerned. This procurement will start a task, a purchase order for the supplier or a production depending on the product configuration.

It is better to encode a procurement order rather than direct purchasing or production. This method has the following advantages:

• The form is simpler because OpenERP calculates the different values from other values and defined rules: purchase date calculated from order date, default supplier, raw materials needs, selection of the most suitable bill of materials, etc. 
Figure 6.35: Encoding a New Procurement Order

Figure 6.36: Workflow for Handling a Procurement according to Product Configuration
• The calculation of requirements prioritises the procurements. If you encode a purchase directly, you short-circuit the planning of different procurements.

**Shortcuts**

On the product form you have an ACTIONS shortcut button Create Procurements that lets you quickly create a new procurement order.

### 6.4.3 Sales Forecasts

The first thing you have to do to work with a production plan is define the periods for stock management. Some companies plan daily, others weekly or monthly.

**Stock Management Interval**

The interval chosen for managing stock in the production plan will depend on the length of your production cycle. You generally work daily, weekly or monthly.

If it takes several days to assemble your products, you most likely will define a weekly plan. If your manufacturing cycles take several months, you can work with a monthly plan.

To predefine these periods you can use the Stock and Sales Planning Periods that will automatically generate daily, weekly or monthly periods.

![Figure 6.37: Stock and Sales Planning Periods](image)

Go to the menu Sales → Configuration → Stock and Sales Periods → Create Stock and Sales Periods. A window appears enabling you to automatically define the next periods that will be provided for stock management. For this example, create weekly periods.

Salespeople can then enter their sales forecasts by product and by period using the menu Sales → Sales Forecasts → Sales Forecasts. The forecasts can be made by quantity or by value. For a forecast by amount, OpenERP automatically calculates the quantity equivalent to the estimated amount. This can be modified manually as needed before completion. A salesperson can create sales forecasts manually, or he can use the Create Sales Forecasts wizard in the above menu.
6.4.4 Production Plan

The manager responsible for logistics then plans receipts (manufacturing or purchases) and outgoings (consumption or customer deliveries) by period. From the menu Warehouse → Stock Planning → Create Stock Planning Lines, you can create a stock planning per week for a specific product category. Through Warehouse → Stock Planning → Master Procurement Schedule you can adjust the planning.

For each period and product, OpenERP gives you the following information:

- Stock estimated at the end of the period, calculated as stock in the following period less the total estimated outgoings plus total estimated inputs,
- Closed entries, coming from production or confirmed purchases,
- Forecast inputs for the period, calculated using the incoming entries less the closing amounts,
- Planned inputs entered manually by the logistics manager,
• Closed outgoings which are the consumption of manufacturing waiting and deliveries to be made to customers,

• Forecast outgoings, calculated from the planned outgoings, less the closing amounts,

• Planned outgoings, manually entered by the logistics manager,

• Sales forecasts, which represent the sum of forecasts made by the salespeople.

Figure 6.40: *The Master Production Schedule (MPS)*

The production plan enables the logistics manager to play with the forecast receipts and outgoings and test the impact on the future stock for the product concerned. It enables you, for example, to check that the stock does not fall below a certain level for that product.

You can also open the production plan for past periods. In this case, OpenERP shows you the real stock moves, by period for forecast reports.

If you do not have automated procurement rules for a product, you can start procurement at any time based on the estimates of the production plan. To do this, press the button *Procure Incoming Left* (i.e. remaining) on the *Master Procurement Schedule*. OpenERP plans procurement for an amount equal to the entries forecast.

### 6.5 Managing Lots and Traceability

The double-entry management in OpenERP enables you to run very advanced traceability. All operations are formalized in terms of stock moves, so it is very easy to search for the cause of any gaps in stock moves.
Upstream Traceability

It runs from the raw materials received from the supplier and follows the chain to the finished products delivered to customers. (Note that the name is confusing – this would often be considered a downstream direction. Think of it as Where Used.)

Downstream Traceability

It follows the product in the other direction, from customer to the different suppliers of raw material. (Note that the name is confusing – this would often be considered an upstream direction. Think of it as Where Supplied.)

6.5.1 Stock Moves

Use the menu Warehouse → Traceability → Stock Moves to track past stock transactions for a product or a given location. All the operations are available. You can filter on the various fields to retrieve the operations about an order, or a production activity, or a source location, or any given destination.

![Figure 6.41: History of Stock Movements](image)

Each stock move is in a given state. The various states are:

- **Draft**: the move so far has no effect in the system. The transaction has not yet been confirmed,
- **Confirmed**: the move will be done, so it will be counted in the calculations of virtual stock. But you do not know whether it will be done without problem because the products have been reserved for the move,
- **Validated**: the move will be done and the necessary raw materials have been reserved for the transaction,
• **Done**: the stock move has been done, and entered into the calculations of real stock,

• **Waiting**: in the case of transactions From Order, this state shows that the stock move is blocked waiting for the end of another move,

• **Cancelled**: the stock move was not carried out, so it is not taken into account in either real stock or virtual stock.

Delivery orders, goods receipts and internal picking lists are just documents that group a set of stock moves. You can also consult the history of these documents using the menu Warehouse → Traceability → Packs.

### 6.5.2 Lots

OpenERP can also manage product lots. Two lot types are defined:

- Production lots (batch numbers) are represented by a unique product or an assembly of identical products leaving the same production area. They are usually identified by bar codes stuck on the products. The batch can be marked with a supplier number or your own company numbers.

- Tracking numbers are logistical lots to identify the container for a set of products. This corresponds, for example, to the pallet numbers on which several different products are stocked.

These lots can be encoded onto all stock moves and, specifically, on incoming shipments lines, internal moves and outgoing deliveries.

Figure 6.42: Entering a Line for Production Receipt
To enter the lot number in an operation, you can use an existing lot number or create a new pack. A production lot (batch number) is used for a single product. A tracking number can be used several times for different products, so you can mix different products on a pallet or in a box.

**Simplified View**

In the Simplified view, the tracking numbers cannot be seen: the field is hidden. To get to Extended view mode, assign the group *Useability / Extended View* to the current user, or change the User Preferences.

You can also specify on the product form the operations in which a lot number is required. You can then compel the user to set a lot number for manufacturing operations, goods receipt, or customer packing.

You do not have to encode the lot numbers one by one to assign a unique lot number to a set of several items. You only need to take a stock move for several products line and click the button *Split in Production Lots*. You can then give a lot number prefix (if you want) and OpenERP will complete the prefix in the wizard with a continuing sequence number. This sequence number might correspond to a set of pre-printed barcodes that you stick on each product.

![Split in lots](image)

Figure 6.43: *Splitting a Lot into uniquely Identified Parts*

### 6.5.3 Traceability

If you key in the lot numbers for stock moves as described above, you can investigate the traceability of any given lot number. Go to the menu *Warehouse → Traceability → Production Lots* or *Warehouse → Traceability → Packs*. 
Product Shortcuts

From the product form, the toolbar to the right offers useful information:

- Minimum Stock Rules,
- Stock by Location,
- Product Sales,
- Bills of Material.

Search for a particular lot using the filters for the lot number, the date or the product. Once you can see the form about this lot, several actions can be performed:

- **Upstream Traceability**: from supplier through to customers,
- **Downstream Traceability**: from customer back to suppliers,
- Stock in all the physical and virtual locations.

<table>
<thead>
<tr>
<th>Upstream Traceability</th>
</tr>
</thead>
<tbody>
<tr>
<td>PRODUCT</td>
</tr>
<tr>
<td>Mobile</td>
</tr>
<tr>
<td>Mobile</td>
</tr>
<tr>
<td>Mobile</td>
</tr>
</tbody>
</table>

Figure 6.44: Tracing Upstream in Make to Order

<table>
<thead>
<tr>
<th>Downstream Traceability</th>
</tr>
</thead>
<tbody>
<tr>
<td>PRODUCT</td>
</tr>
<tr>
<td>Mobile</td>
</tr>
<tr>
<td>Mobile</td>
</tr>
<tr>
<td>Mobile</td>
</tr>
<tr>
<td>Mobile</td>
</tr>
<tr>
<td>Mobile</td>
</tr>
<tr>
<td>Mobile</td>
</tr>
<tr>
<td>Mobile</td>
</tr>
</tbody>
</table>

Figure 6.45: Tracing Downstream in Make to Stock

Finally, on a lot, you can enter data on all the operations that have been done for the product. That keeps a useful history of the pre-sales operations.

### 6.6 Scrapping Products

In OpenERP, there are many ways to handle scrap products.

1. **Warehouse → Product Moves → Receive Products**
2. **Warehouse → Product Moves → Deliver Products**

3. **Warehouse → Warehouse Management → Incoming Shipments**

![Figure 6.46: Scrapping from an Incoming Shipment](image1)

4. **Warehouse → Warehouse Management → Internal Moves**

![Figure 6.47: Scrapping from an Internal Move](image2)

5. **Warehouse → Warehouse Management → Delivery Orders**

When you decide to scrap some products, they are transferred to the *Scrap* location. To display the content of this *Virtual Location*, go to :menuselection: *Warehouse → Inventory Control → Location Structure*, then select the virtual locations and display the *Scrap* location.

If you want to transfer the products to another location, you can create a new one and check the *Scrap Location* in the additional information.
6.7 Identifying Products and Locations with Barcodes and RFID Devices

You can the barcode in the product form in the field EAN13.

6.8 Financial Inventory Management

6.8.1 Manual and Real-time Stock Valuation

If you have experience of managing with traditional software, you will know the problem of getting useful indicators. If you ask your accountant for a stock valuation or the value added by production, he will give you a figure.

If you ask for the same figure from your stores manager, you will get an entirely different amount. You have no idea who is right!

In OpenERP, stock management is completely integrated with the accounts, to give strong coherence between the two systems. The double-entry structure of locations enables a very precise correspondence between stocks and accounts.

Each stock movement also generates a corresponding accounting entry in an accounting journal to ensure that the two systems can stay in permanent synchronization.

To do that, set up a general account for each location that should be valued in your accounts. If a product goes to one location or another and the accounts are different in the two locations, OpenERP automatically generates the corresponding accounting entries in the accounts, in the stock journal.

If a stock move will go from a location without an account to a location where an account has been assigned (for example goods receipt from a supplier order), OpenERP generates an accounting entry using the properties defined in the product form for the counterpart. You can use different accounts per
location or link several locations to the same account, depending on the level of analysis needed.

You use this system for managing consigned stocks:

- a supplier location that is valued in your own accounts or,
- a location in your own company that is not valued in your accounts.

*How to Configure Accounting Valuation?*

In the Product form, go to the Accounting tab and select the Real Time (automated) option for Inventory Valuation.

To define your accounts, you have two options. Set them on the product category, or on the product.

1. From the Accounting Stock Properties section, for the Product Category, set the Stock Input Account, the Stock Output Account and the Stock Variation Account,

2. From the Accounting tab, for the Product, set the Stock Input Account and the Stock Output Account.

You can also overwrite the accounts from the Product or the Product Category by defining Stock Input Account and Stock Output Account for a Location.

**account_anglo_saxon**

You can also install the account_anglo_saxon module (Reconfigure wizard, Anglo-Saxon Accounting) to value your stock according to Anglo-saxon principles.

The figure below shows the various accounts that can be used, with and without the account_anglo_saxon module installed.

**6.8.2 Managing Transportation Costs**

In OpenERP, you can handle the delivery methods when installing the delivery module.

This module will allow you:

- To select the delivery company

- To define the delivery pricelist according to the price, the weight or the volume.

Now, in each Delivery Order, two new fields are available to enter the right value to deliver the products to the customer. You can also find a new field in the Sales Order form that enables you to select a delivery method.
Figure 6.49: Setting up Stock Valuation Accounts

Figure 6.50: Define the Delivery Method

Figure 6.51: Define the Delivery Costs

Figure 6.52: Delivery Cost in the Delivery Orders
6.9 Organize your Deliveries

You can manage stock through journals in the same way as you can manage your accounts through journals. This approach has the great advantage that you can define journals in various ways to meet your company’s needs.

For example, a large company may want to organize deliveries by department or warehouse. You can then create a journal and a manager for each department. The different users can work in a journal as a function of their position in the company. That enables you to better structure your information.

A company doing a lot of transport could organize its journals by delivery vehicle. The different delivery orders will then be assigned to a journal representing a particular vehicle. When the vehicle has left the company, you can confirm all the orders that are found in the journal all at the same time.

6.9.1 The Different Journals

Install the Reconfigure option Invoicing Journals for Sales Management or the sale_journal module to work with different journals. This adds two new concepts to OpenERP:

- Invoicing journals,
- Stock journals or Delivery journals.

**Invoicing journals** (Sales → Configuration → Sales → Invoice Types) are used to assign purchase orders and/or delivery orders to a given invoicing journal. Everything in the journal can be invoiced in one go, and you can control the amounts by journal. For example, you can create the following journals: daily invoicing, end-of-week invoicing and monthly invoicing. It is also possible to show the invoicing journal by default in the partner form. Set the Invoicing Method to Grouped (one invoice per customer) or Non Grouped (individual invoices) according to your needs.

**Stock journals** (Warehouse → Configuration → Warehouse Management → Stock Journals) allow you to classify the delivery orders in various ways, such as by department, by salesperson or by type. If a salesperson looks for a delivery order in his own journal, he can easily see the work on current items compared with his own orders.
Default Values

To enter all the orders in his own stock journal, a salesperson can use the default values that are entered in the fields when creating orders.

Finally, the stock journals can also be used as delivery journals to post each item into a delivery journal. For example, you can create journals dated according to customer delivery dates (such as Monday’s deliveries, or afternoon deliveries) or these journals could represent the day’s work for delivery vehicles (such as truck1, truck2).

6.9.2 Using the Journals

You will now see how to use the journals to organize your stock management in practice. After installing the module sale_journal look at the list of partners. In the tab Sales and Purchases on any of them you will now see the field Invoicing Method.

![Partner Form in Invoicing Mode](image)

You can create a new Invoicing Journal for a partner through the menu Sales → Configuration → Sales → Invoice Types. You can decide if the invoices should be grouped or not when generating them in the journal. Create a second invoicing journal End-of-Month Invoicing which you can assign to another partner.

Then enter the data for some sales orders for these two partners. After entering sales order data, the field Invoicing Mode in the second tab Other Information is completed automatically from the partner settings.
Look at the *History* tab of the Sales order, and observe the *Picking List* that has been created. The field *Invoicing Mode* is automatically shown there.

At the end of the day, the invoicing supervisor can display the list by journal. Go to the menu *Sales → Invoicing → Lines to Invoice*. Add a New Filter by selecting *Invoice Type contains Daily*, or any other part of the invoice journal you are using. Select the different orders in the list. You can automatically
carry out invoicing by clicking the action *Make Invoices* (the gears symbol).

**Confirming Invoices**

By default, invoices are generated in the draft state, which enables you to modify them before sending them to the customer. But you can confirm all the invoices in one go by selecting them all from the list and selecting the action *Confirm Draft Invoices*.

At the end of the month the invoicing management does the same work, but in the journal ‘month-end invoicing’.

You can also enter a journal to confirm / cancel all the orders in one go. Then you can do several quotations, assign them to a journal and confirm or cancel them at once.

![Figure 6.57: View of an Order Journal](image)

### 6.10 Estimating Delivery Dates

#### 6.10.1 Standard Delivery Time

In order to define the delivery time, you have to know three things:

- **Customer Lead Time**:
  That is the time you promise to your customer for a delivery. It corresponds to the average delay between the confirmation of the customer order and the delivery of the finished goods. It can be defined in the product form, in the *Procurement and Locations* tab.
  This time will be influenced by the Manufacturing Lead Time and the Delivery Lead Time.

- **Manufacturing Lead Time**:
  This is the time you need to produce one unit of a product. If this product needs other sub-products, the different manufacturing times will be summed. It can also be defined in the product form, in the *Procurement and Locations* tab.

- **Delivery Lead Time**:
  This is the time your supplier needs to deliver the goods. This delay can be defined in the product form in the *Suppliers* tab.
For example, if we have to deliver some products to a customer in a month (in 30 days). You promise to deliver the goods to the customer within 10 days, the manufacturing time is equal to 4 days and our suppliers deliver the raw materials within 3 days.

According to those numbers, we will have to start the process in 23 days if we have to order raw materials.

### 6.10.2 Schedule Logistic Flows according to MRP1 Rules

MRP is a software-based production, planning and inventory control system used to manage the manufacturing process.

It is a computer-based system in which the given Master Schedule is exploded with Bills Of Material, into the required amount of raw material, parts and subassemblies needed to produce the final products in each period.

### 6.11 Incoming and Outgoing Products Planning

To be able to plan incoming and outgoing shipments of products, you have to install the module `stock_planning`.

![Master Procurement Schedule](image)

**Figure 6.58: Planning the Deliveries of Customer Products**

Thanks to this module, you will be able to calculate a planning of the stock for a product.

Planned dates on a packing order are put in each stock move line. If you have a packing order containing several products, not all of the lines necessarily need to be delivered the same day. The minimum and maximum dates in a packing order show the earliest and latest dates on the stock move lines for the packing.
If you move a packing order in the calendar view, the planned date in the stock move lines will automatically be moved as a result.

### 6.12 Managing Inventory Reconciliation

Inventory reconciliation involves two steps: physical and accounting.

Physical inventory steps include taking a written inventory record and comparing it to the actual goods in the company’s warehouses. Counting obsolete and damaged products is also a reconciliation activity.

Reconciliation steps on the accounting side include verification that all inventory purchases are posted, entering adjustments from the physical count and analysing the dollar differences between months. Inventory reconciliation frequency depends on the size, location, and type of inventory in a company’s operations.

### 6.13 Building Reports to Track Activity

With OpenERP, you can build your own reports in order to track the different activities in your warehouses. To create your own reports, you have to install the `base_report_creator`. It will add a submenu in `Administration → Customization → Reporting`.

![Create your Own Reports](image)

Figure 6.59: Create your Own Reports

This newly added section allows you to define for your new report:

- The general configuration:
  The aim of this tab is to choose the models your report will rely on.

- The view parameters
  This tab will define the display of your report. You can choose between the traditional available views (Tree/List, Form, Graph and Calendar) and you can define three different ways to display your report.

- The fields to display
The fields available to display will depend on the models you choose in the General Configuration tab.

When you add a new field to your report, different fields have to be specified:

- Sequence - defines the order in which the fields will be displayed in the report
- Field - the information you want to display in your report
- Grouping method - affects the way the field is displayed. You can choose between Grouped, Sum, Minimum, Count, Maximum and Average
- Graph mode - defines which axe of the graph the field will represent
- Calendar mode - defines the meaning of the field for the calendar (Starting or Ending date, Delay, End Date, Unique Colours)

• The filters on fields

This tab will let you choose which data to display according to the value of a field. It is possible to manually modify or add new filters according to your needs.

• The security

The security tab is used to select the groups that are able to display the report.

Create Report with OpenOffice

You can also create or edit reports with OpenOffice using the base_report_designer module.

In order to add the extension to OpenOffice, load this module and start the configuration. A new window will ask you to Save As a file that contains the extension.

Once you have saved the file, start OpenOffice and go to Tools → Extension Manager, then click Add and select the previously saved file. Restart OpenOffice.org and now you have the extension installed.

Figure 6.60: Extension to Create a Report in OpenOffice

6.14 Import / Export

Managing import / export with foreign companies can sometimes be very complex. Between a departure port and the destination company, products can get stopped for several weeks at sea or somewhere in the numerous transportation stages and customs. To manage such deliveries efficiently it is important to:

- know where your products are,
• know when they are likely to arrive at their destination,
• know your value in transit,
• follow the development of the different steps.

Linked locations in OpenERP enable you to manage all this rather elegantly. You can use a structure like this:

• Suppliers
  – European Suppliers
  – Chinese Suppliers

• In transit
  – Shanghai Port
  – Pacific Ocean
  – San Francisco Port
  – San Francisco Customs

6.14.1 Stock

The transit locations are linked between themselves with a manual confirmation step. The internal stock move is validated at each port and customs arrival. OpenERP prepares all the linked moves automatically.

Intrastat

Companies that do import / export should install the module report_intrastat. This enables them to prepare the reports needed to declare product exports.

You can use the lead times between different locations to account for real delays. Your lead times and stock forecasts are calculated by OpenERP to estimate the arrival of incoming products, so that you can respond to a customer’s needs as precisely as possible.

You can also value the products in transit in your account depending on the chosen stock location configuration.

6.14.2 Rental Locations

You can manage rental locations in OpenERP very simply using the same system of linked locations. Using the stock_location module you can set a return date for rental items sent to a customer location after a certain rental period.
Then the set of real and virtual stocks is maintained daily in real time. The different operations such as delivery and receipt after a few days are automatically suggested by OpenERP which simplifies the work of data entry.

You then have the product list found in the customer locations and your own stock in your stock location. The list of waiting goods receipts is automatically generated by OpenERP using the location links.

Suppose you want to rent a product (PC3) to your customer (Axelor) for 30 days. Two stock movement entries are needed to manage this scenario:

1. Product goes from Stock (your company’s location) to Axelor - Rental Location (your customer location).
2. Product will be returned into Stock (your company’s location) from Axelor - Rental Location (your customer location) after 30 days.

To manage rental products by linking locations, configure a rental location (Axelor - Rental Location) as shown in the following figure using the menu Warehouse → Configuration → Warehouse Management → Locations.

Figure 6.61: Configuration of a Rental Location ‘Axelor - Rental Location’

Through the menu Warehouse → Traceability → Stock Moves, you can create a stock movement entry from Stock to Customer Location (Axelor - Rental Location) in OpenERP for a rental product (PC3).

The stock movement entry from Customer Location (Axelor - Rental Location) to Stock is generated automatically on the proper Scheduled Date by OpenERP when you have confirmed the previous stock movement entry by clicking the Process Now button.
6.14.3 Consigned Products

The principle of linked locations is used to manage consigned products. You can specify that certain products should be returned to you a certain number of days after they have been delivered to customers. When the products have been delivered, OpenERP automatically creates goods receipts for the consigned product. The specified date is obviously approximate but enables you to forecast returns.

6.15 Stock Location Example

In this section, we will develop a more detailed example that includes different concepts seen in the previous sections.

The following example will use the Stock Location types, the Logistic Flows and the Bill Of Materials.

We have two companies: OpenERP SA and OpenERP US.

We have three products: Product A, Product B and Product C. For each product, we will have to define the Stock Location to determine where to take these products.

To make one unit of Product A, we need the Product B and the Product C. So we will have to define a Bill of Material.
Table 6.12: Bill of Materials

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Product</td>
<td>Product A</td>
</tr>
<tr>
<td>Product Qty</td>
<td>1</td>
</tr>
<tr>
<td>Name</td>
<td>Product A</td>
</tr>
<tr>
<td>BoM Type</td>
<td>Normal</td>
</tr>
<tr>
<td>Company</td>
<td>OpenERP US</td>
</tr>
</tbody>
</table>

The different components to produce one unit of Product A are one unit of Product B and one unit of Product C.

Table 6.13: Companies and Products

<table>
<thead>
<tr>
<th>Company</th>
<th>What</th>
</tr>
</thead>
<tbody>
<tr>
<td>OpenERP SA</td>
<td>Sell the Product A</td>
</tr>
<tr>
<td>OpenERP SA</td>
<td>Store the Product C</td>
</tr>
<tr>
<td>OpenERP US</td>
<td>Produce the Product A</td>
</tr>
<tr>
<td>OpenERP US</td>
<td>Store the Product B</td>
</tr>
</tbody>
</table>

Table 6.14: Logistics Flows

<table>
<thead>
<tr>
<th>Name</th>
<th>Type</th>
<th>Product</th>
<th>Goal of the flow</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ask for Production</td>
<td>Pull</td>
<td>Product A</td>
<td>OpenERP SA asks OpenERP US to produce the Product A</td>
</tr>
<tr>
<td>Launch Production</td>
<td>Pull</td>
<td>Product A</td>
<td>OpenERP US launches the production of the Product A</td>
</tr>
<tr>
<td>Send Product to Transit</td>
<td>Pull</td>
<td>Product C</td>
<td>OpenERP US asks for the Product C to OpenERP SA</td>
</tr>
<tr>
<td>Get Product from Transit</td>
<td>Pull</td>
<td>Product C</td>
<td>OpenERP US receives the Product C</td>
</tr>
</tbody>
</table>

Here are the details of the different flows:

Figure 6.63: Ask for Production

With this configuration, when a Sales Order for 3 units of Product A is confirmed and the scheduler has been launched, you will have the following procurements:

And the following stock moves have been generated:

Because we are working in two different companies, different stock moves have been generated. The products have to move from OpenERP SA to OpenERP US for the products C. After the manufacturing process, the products A have to move from OpenERP US to OpenERP SA to be sold to the customer.
Figure 6.64: Launch Production

Figure 6.65: Send Product to Transit

Figure 6.66: Get Product from Transit

Figure 6.67: Procurements View
Once you have confirmed the different moves for the products B and C, the Manufacturing Order is in *ready to produce* status. So you can run the production of the three units of Product A.

Once again due to the use of two companies, you have to confirm different deliveries. One to deliver the product from OpenERP US to OpenERP SA and another to deliver the product from OpenERP SA to the customer. Now you have to confirm the delivery of the three units from OpenERP SA to OpenERP SA, then to confirm the reception of the products in OpenERP SA and finally, deliver the products to your final customer.
Multi-Company Environment

This part of the book concentrates on the multi-company environment of OpenERP. From version 6.0 of OpenERP, you do not have to install any additional modules to enable the multi-company environment. All components are included in the base modules. All you have to do to work in a multi-company environment, is add the Useability/Multi-Companies group to your user.

The multi-company environment allows you to manage operations from different companies with different warehouses, customers and suppliers, products, ...

In the following chapters, we will perform a complete order flow made by a customer in France that does not handle the stock, but delegates it to another company located in Belgium that will deliver the product to the customer.

In order to achieve this, we will follow the schema define hereunder.

To be able to manage the process, please install the following modules:

- sale
- purchase
- stock
- stock_location, Reconfigure wizard → Advanced route (in order to be able to define pull & push flows)
7.1 Logistics in a Multi-Company Environment

7.1.1 Configuration

Let us start by configuring the different components we need. In the next sections, we will define:

- **The companies’ structure**
  - Companies
  - Charts of Accounts
  - Storage

- **Users, suppliers & customers**

- **The product**
  - Product definition
  - Push & pull flows

### User Group

Go to **Administration → Users → Users** and add the **Useability / Multi Companies** group to your user, to be able to use OpenERP in a multi-company environment.

### Companies Structure

#### Companies

Three companies have to be defined. One mother company (OpenERP) and two children (OpenERP Belgium and OpenERP France).

On the one hand, the two child companies will be used to support the flow of goods. On the other hand, the mother company will be used to aggregate the different information from OpenERP France and OpenERP Belgium.

![Companies Structure](image)

**Figure 7.2: Companies Structure**

To view the companies’ structure, you have to add the group **Useability/Multi Companies** to your user.
Here are the different configurations for the mother and the child companies (for the child companies, do not forget to add a parent company):  

![Figure 7.3: Companies Configuration](image)

**Charts of Accounts**

For each company, you have to define an accounting setting. To do this, go to the Accounting → Configuration → Financial Accounting → New company Financial Setting.

![Figure 7.4: Creating Charts of Accounts](image)

**Accounting Plan**

Each of your companies can have its own specific chart of accounts.
Users, Suppliers & Customers

The users are used to log in to the system and to give the appropriate access rights to each person. This concept is different from the employee who is created through the Human Resources module.

Each company needs a user to manage the different operations to complete the flow. You can create one user for each company, but do not forget to select the appropriate company in the Contact section of the User form after have added the company in the Companies tab.

![Figure 7.5: Defining Users part 1](image1.png)

In addition to the user, the companies need suppliers and customers. For OpenERP France, you can define one customer who will order the product that will be defined later, and for OpenERP Belgium, you can define one supplier who will deliver the product to the company.

The customers and suppliers go in the same object called Partners which can be classified in three ways: customer, supplier and customer and supplier. This has the advantage that you have to update address data only once.

- Customer: log in with the user of OpenERP France, then go to Sales → Address Book → Customers

Product

Definition

Now that we have defined the different actors, we can define our product that will be stored in Belgium and proposed to sell in France. Go to Sales → Products → Products and create a new product with the following specifications:

In the Suppliers tab, you can select the supplier defined above. In the tab Logistical Flows,
• Supplier: log in with the user of OpenERP Belgium, then go to Purchases → Address Book → Suppliers

Figure 7.7: Defining Customers part 1

Figure 7.8: Defining Customers part 2

Figure 7.9: Defining Suppliers part 1

Figure 7.10: Defining Suppliers part 2
we will define the different flows in order to share the different objects between the companies. To order the product in Belgium from a sales order made in France, we will define a *Pull flow*.

**Flows**

In our process, we have to create a pull flow, because the process begins with a need from OpenERP France. OpenERP France needs some products ordered by the customers.

The flow will go through our two child companies. The starting point is OpenERP Belgium that will supply OpenERP France that will supply the goods to the customer.

We can draw the process like this: Customer ← [OpenERP France] ← [OpenERP Belgium] ← Supplier
Managing the Storage

In our configuration, we have to define the way in which we will store the products.

The stock will be managed by OpenERP Belgium that will share the products with the other companies. OpenERP France will manage the sales part for these products.

OpenERP France will “transfer” the sales order to OpenERP Belgium that will ship the goods to the customer.

By default, OpenERP creates some locations and warehouses for the first company. As a consequence, we have to create the other warehouses and locations for our child companies. We will start by creating the warehouses, then we will define specific locations and we will finish by setting up the shops.

Warehouses

In OpenERP, a warehouse represents your places of physical stock. A warehouse can be structured into several locations at multiple levels.

We have to create three new warehouses. One for OpenERP, one for OpenERP Belgium and one for OpenERP France.

![Figure 7.13: Warehouses](image)

Go to `Warehouse → Configuration → Warehouse Management → Warehouses` and create the different warehouses according to the parameters shown in picture `Warehouse Parameters` (page 173).

![Figure 7.14: Warehouse Parameters](image)

Locations

Locations are used to manage all types of storage places, such as at the customer and production counterparts.
In order to store products, we will create one location for the two child companies. It will support the flow of goods between those companies.

![Locations](image1)

**Figure 7.15: Locations**

Go to Warehouse → Configuration → Warehouse Management → Locations and create the different locations with the parameters defined in the picture *Location Parameters* (page 174).

![Location Parameters](image2)

**Figure 7.16: Location Parameters**

**Shops**

OpenERP France needs a shop. The objective of this shop is to allow OpenERP France to receive orders from customers and then send it to OpenERP Belgium for the delivery of the products.

![Defining a Shop](image3)

**Figure 7.17: Defining a Shop**

Go to Sales → Configuration → Sales → Shop to define a shop for OpenERP France.
7.1.2 Process: Sales and Purchases

At this point, we have defined everything that we need, we can now execute the process.

The following example will be structured as follows:

First, we will make a sales order for one unit of our product (Basic PC) in the company OpenERP France for the customer NotSoTiny. Then this will be sent to the company OpenERP Belgium that stocks the Basic PCs. An order of one unit will be sent to OpenERP Belgium from OpenERP France. OpenERP will purchase the product from its supplier (in this case, Dell Belgium). Second, OpenERP France will have to invoice the delivered quantities sent by OpenERP Belgium to NotSoTiny.

Sales Order

At this point, you have to log in with a user of OpenERP France in order to make a Sales Order coming from a customer of this company.

![Figure 7.18: Defining a Sales Order](image)

You should not forget to set the correct parameters in the second tab Other Information to select the good shipping and picking policies. Here we select the Invoice From the Picking as Shipping Policy.

Confirm the Sales Order, then run the Scheduler (Warehouses → Schedulers → Compute Schedulers) and run the Procurement from each company (OpenERP France, OpenERP and OpenERP Belgium).

At this time, a Purchase Order and a Delivery Order have been generated. The Purchase Order is in the Request For Quotation state and you have to convert it into a Purchase Order to confirm the purchase. The Delivery Order is in Not Available state because you have to buy the products before delivery.

Once the purchase order has been confirmed and the reception is completed, we can process the delivery order.
CHAPTER 7. MULTI-COMPANY ENVIRONMENT

176

Delivery Order

Once the delivery order is processed, the products are sent to the customer and we can invoice the order from OpenERP France on the delivered quantities.

The delivery order will be processed from OpenERP Belgium. OpenERP Belgium is the company that manages the stock of products. This company is responsible for the delivery of the products to the final customers. However, the invoicing process will be handled by OpenERP France, because it is the company that received the order from the customer.

From the user of OpenERP France, we can create the invoice for the order (Sales → Invoicing → Lines to Invoice), then pass the invoice from the Draft state to the Open state. To finalize the invoicing process, you have to go to Accounting → Customers → Customers Invoices to execute the payment process.

Figure 7.19: Purchase Order

Figure 7.20: Deliver the Products
Figure 7.21: Create the Invoice

Figure 7.22: Validate the Invoice
Part V

On Site Installation
The installation procedure of OpenERP V6.0 is explained in this chapter. This procedure is well tested on Ubuntu version 10.04.

There are four main procedures that you have to follow in order to run OpenERP V6.0 smoothly:

- PostgreSQL Server Installation and Configuration
- OpenERP Server Installation
- OpenERP Client Installation
- OpenERP Web Installation

### 8.1 PostgreSQL Server Installation and Configuration

#### Methods

The PostgreSQL download page lists the available installation methods. Choose the one that best suits your needs.

#### 8.1.1 Example on Ubuntu

Use the following command at your system’s command prompt to install the `postgresql` package:

```bash
sudo apt-get install postgresql
```

For example:

```bash
openerp@openerp-desktop:/$ sudo apt-get install postgresql
```

For a graphical user interface of `postgresql`, use the following command:

```bash
sudo apt-get install pgadmin3
```

For example:

```bash
openerp@openerp-desktop:/$ sudo apt-get install pgadmin3
```

You can find the new menu item `pgAdmin III` in your Ubuntu system menu from `Applications -> Programming -> pgAdmin III`. 
8.1.2 Setup a PostgreSQL user for OpenERP

When the installations of the required software are done, you must create a PostgreSQL user. This user must be the same as your system user. OpenERP will use this user to connect to PostgreSQL.

Figure 8.1: Figure demonstrating how OpenERP uses the PostgreSQL user to interact with it

Database

Without creating and configuring a PostgreSQL user for OpenERP as described below, you cannot create a database using OpenERP Client.

First Method

The default superuser for PostgreSQL is called postgres. You may need to login as this user first.

```
$ sudo su postgres
password: XXXXXXXXXX
```

Now create PostgreSQL user openerp using the following command:

```
$ createuser openerp
```

```
Shall the new role be a superuser? (y/n) y
```

Make this new user a superuser. Only then you can create a database using OpenERP Client. In short, openerp is the new user created in PostgreSQL for OpenERP. This user is the owner of all the tables created by OpenERP Client.

Now check the list of tables created in PostgreSQL using following command:
postgres@openerp-desktop:/$ psql -l

You can find the table **template1**, run the following command to use this table:

postgres@openerp-desktop:/$ psql template1

To apply access rights to the role **openerp** for the database which will be created from OpenERP Client, use the following command:

```
template1=# alter role openerp with password 'postgres';
```

**Second Method**

Another option to create and configure a PostgreSQL user for OpenERP is shown below:

```
postgres@openerp-desktop:/$ createuser --createdb --username postgres --no-createrole --pwprompt openerp
Enter password for new role: XXXXXXXXXXX
Enter it again: XXXXXXXXXXX
Shall the new role be a superuser? (y/n) y
```

Password

Note that the password is **postgres**.

Option explanations:

- **--createdb**: the new user will be able to create new databases
- **--username postgres**: `createuser` will use the `postgres` user (superuser)
- **--no-createrole**: the new user will not be able to create new users
- **--pwprompt**: `createuser` will ask you the new user’s password
- **openerp**: the new user’s name

To access your database using **pgAdmin III**, you must configure the database connection as shown in the following figure:

You can now start OpenERP Server. You will probably need to modify the OpenERP configuration file according to your needs which is normally located in `~/.openerprc`. 
8.2 OpenERP Server Installation

8.2.1 Installing the required packages

You need to have Python (at least 2.5 for OpenERP v6.0) in your Ubuntu system, which is in-built in Ubuntu version 10.04 and above.

You also need to install the following Python libraries, because OpenERP Server uses these packages. To install the required libraries on your Ubuntu system, you can do the following in your favourite shell:

- **lxml**: lxml is the most feature-rich and easy-to-use library for working with XML and HTML in the Python language.
sudo apt-get install python-lxml

- **mako**: Hyperfast and lightweight templating for the Python platform.
  
  sudo apt-get install python-mako

- **mxdatetime**: Provides the most natural and robust way of dealing with date/time values in Python.
  
  sudo apt-get install python-egenix-mxdatetime

- **python-dateutil**: The dateutil module provides powerful extensions to the standard datetime module, available in Python 2.3+.
  
  sudo apt-get install python-dateutil

- **psycopg2**: Psycopg is the most popular PostgreSQL adapter for the Python programming language.
  
  sudo apt-get install python-psycopg2

- **pychart**: PyChart is a Python library for creating high quality Encapsulated Postscript, PDF, PNG, or SVG charts.
  
  sudo apt-get install python-pychart

- **pydot**: This module provides a full interface to create, handle, modify and process graphs in Graphviz’s dot language.
  
  sudo apt-get install python-pydot

- **pytz**: World Timezone Definitions for Python.
  
  sudo apt-get install python-tz

- **reportlab**: The ReportLab Toolkit is the time-proven, ultra-robust, open-source engine for programmatically creating PDF documents and forms the foundation of RML. It also contains a library for creating platform-independent vector graphics. It is a fast, flexible, cross-platform solution written in Python.
  
  sudo apt-get install python-reportlab

- **pyyaml**: PyYAML is a YAML parser and emitter for Python.
  
  sudo apt-get install python-yaml

- **vobject**: VObject simplifies the process of parsing and creating iCalendar and vCard objects.
8.2.2 Downloading the OpenERP Server

The OpenERP server can be downloaded from the OpenERP website’s download page.

8.2.3 Testing the OpenERP Server

If you only want to test the server, you do not need to install it. Just unpack the archive and start the openerp-server executable:

```
tar -xzf openerp-server-6.0.2.tar.gz
cd openerp-server-6.0.2/bin
python openerp-server.py
```

The list of available command line parameters can be obtained with the `-h` command-line switch:

```
python openerp-server.py -h
```

8.2.4 Installing the OpenERP Server

The OpenERP Server can be installed very easily using the `setup.py` file:

```
tar -xzf openerp-server-6.0.2.tar.gz
cd openerp-server-6.0.2
sudo python setup.py install
```

If your PostgreSQL server is up and running, you can now run the server using the following command:

```
openerp-server
```

If you do not already have a PostgreSQL server up and running, you can read *PostgreSQL Server Installation and Configuration* (page 181).

You can find the OpenERP server configuration file at `~/openerp-server-6.0.2/doc/openerp-server.conf`.

8.3 OpenERP Client Installation

8.3.1 Installing the required packages

You need to have Python (at least 2.5 for OpenERP v6.0) in your Ubuntu system, which is in-built in Ubuntu version 10.04 and above.
You also need to install the following Python libraries, because OpenERP Client uses these packages. To install the required libraries on your Ubuntu system, you can do the following in your favourite shell:

- **gtk**: GTK+ is a highly usable, feature-rich toolkit for creating graphical user interfaces which boosts cross-platform compatibility and an easy-to-use API.

  ```bash
  sudo apt-get install python-gtk2
  ```

- **glade**: Glade is a RAD tool to enable quick & easy development of user interfaces for the GTK+ toolkit and the GNOME desktop environment.

  ```bash
  sudo apt-get install python-glade2
  ```

- **matplotlib**: matplotlib is a Python 2D plotting library which produces publication quality figures in a variety of hard-copy formats and interactive environments across platforms.

  ```bash
  sudo apt-get install python-matplotlib
  ```

- **mxdatetime**: Provides the most natural and robust way of dealing with date/time values in Python.

  ```bash
  sudo apt-get install python-egenix-mxdatetime
  ```

- **xml**: XML support for Python platform.

  ```bash
  sudo apt-get install python-xml
  ```

- **tz**: World Timezone definitions for Python.

  ```bash
  sudo apt-get install python-tz
  ```

- **hippocanvas**: The Hippo Canvas is a Cairo/ GObject/GTK+ based canvas, written in C with support for flexible layout, CSS styling, and initial work on animations.

  ```bash
  sudo apt-get install python-hippocanvas
  ```

- **pydot**: Python interface to Graphviz’s Dot language.

  ```bash
  sudo apt-get install python-pydot
  ```

**PDF Viewer**

You will also need a PDF viewer (e.g. xpdf, acroread, kpdf).

See the *Configuring a PDF Viewer* (page 188) section.
8.3.2 Downloading the OpenERP Client

The OpenERP client can be downloaded from the OpenERP website’s download page.

8.3.3 Testing the OpenERP Client

If you only want to test the client, you do not need to install it. Just unpack the archive and start the openerp-client executable:

```
tar -xzf openerp-client-6.0.2.tar.gz
cd openerp-client-6.0.2/bin
python openerp-client.py
```

The list of available command line parameters can be obtained with the `-h` command-line switch:

```
python openerp-client.py -h
```

8.3.4 Installing the OpenERP Client

The client can be installed very easily using the `setup.py` file:

```
tar -xzf openerp-client-6.0.2.tar.gz
cd openerp-client-6.0.2
sudo python setup.py install
```

You can now run the client using the following command:

```
openerp-client
```

8.3.5 Configuring a PDF Viewer

To preview PDF files, OpenERP Client by default supports:

1. evince
2. xpdf
3. gpdf
4. kpdf
5. epdfview
6. acroread
The client will try to find one of these executables (in this order) in your system and open the PDF document with it.

PDF

For example, if xpdf, kpdf and acroread are the only PDF viewers installed on your system, the OpenERP client will use xpdf for previewing PDF documents.

If you want to use another PDF viewer or if you do not want to use the first one the client will find, you have to edit the OpenERP configuration file, normally located in ~/.openerprc. Find the [printer] section and edit the softpath parameter. For example:

[printer]
softpath = kpdf

8.4 OpenERP Web Installation

8.4.1 Downloading & Installing the OpenERP Web Client

The OpenERP Web Client can be downloaded from the OpenERP website’s download page. You need to install the following Python libraries, because OpenERP Web Client uses these packages:

1. Python >= 2.4
2. CherryPy >= 3.1.2
3. Mako >= 0.2.4
4. Babel >= 0.9.4
5. FormEncode >= 1.2.2
6. simplejson >= 2.0.9
7. pyparsing >= 1.5.0

There is no need to install the above packages one by one. You can just run the following commands in your favourite shell:

$ sudo apt-get install python python-dev build-essential
$ sudo apt-get install python-setuptools

This will install dependencies required for the following:
$ cd /path/to/openerp-web-6.0.2/lib
$ ./populate.sh
$ cd ..

This will install all required dependencies in private lib directory, and you do not need to install anything.

8.4.2 Testing the OpenERP Web Client

If you only want to test the web client, you do not need to install it. Just unpack the archive and start the openerp-web executable:

```
tar -xzf openerp-web-6.0.2.tar.gz
cd openerp-web-6.0.2/
python openerp-web.py
```

The list of available command line parameters can be obtained with the `-h` command line switch:

```
python openerp-web.py -h
```

8.4.3 Installing the OpenERP Web Client

The OpenERP Web Client can be installed very easily using the `setup.py` file:

```
tar -xzf openerp-web-6.0.2.tar.gz
cd openerp-web-6.0.2
sudo python setup.py install
```

You can now run the OpenERP Web Client using the following command:

```
openerp-web
```

you can find the OpenERP Web Client configuration file at `~/openerp-web-6.0.2/doc/openerp-web.conf`.

8.4.4 Web Browser Compatibilities

Supported Browsers

*OpenERP Web Client* is known to work best with *Mozilla* based web browsers. Here is a list of supported browsers:

1. Firefox >= 3.6
2. Internet Explorer >= 7.0
3. Safari >= 4.1
4. Google Chrome >= 9.0
5. Opera >= 10.0

**Flash Plugin**

Your browser should have the Flash plugin installed because *OpenERP Web Client* uses some Flash components.

Apply the following command in order to install the Flash plugin on an Ubuntu system:

```
$ sudo apt-get install flashplugin-nonfree
```
In this chapter, you will see the installation of OpenERP v6.0 on a Windows system. This procedure is well-tested on Windows 7.

You have two options for the installation of OpenERP on a Windows system:

- **All-In-One Installation** This is the easiest and quickest way to install OpenERP. It installs all components (OpenERP Server, Client, Web and PostgreSQL database) pre-configured on one computer. This installation is recommended if you do not have any major customizations.

- **Independent Installation** If you choose this mode of installation, all the components required to run OpenERP will have to be downloaded and installed separately. You will have to opt for an independent installation if you plan to install the components on separate machines. This mode is also practical if you are already working with or plan to use a different version of PostgreSQL than the one provided with the All-In-One installer.

### 9.1 OpenERP All-In-One Installation

Each time a new release of OpenERP is made, OpenERP supplies a complete Windows auto-installer for it. This contains all of the components you need – the PostgreSQL database server, the OpenERP application server, the GTK application client and the Web client.

This auto-installer enables you to install the whole system in just a few mouse clicks. The initial configuration is set up during installation, making it possible to start using it very quickly, as long as you do not want to change the underlying code. It is aimed at the installation of everything on a single PC, but you can later connect GTK clients from other PCs, Macs and Linux boxes to it as well.

#### 9.1.1 Downloading OpenERP All-In-One

The first step is to download the OpenERP All-In-One installer. At this stage, you must choose which version to install – the stable version or the development version. If you are planning to put it straight into production we strongly advise you to choose the stable version.
Stable Versions and Development Versions

OpenERP development proceeds in two parallel tracks: stable versions and development versions.

New functionality is integrated into the development branch. This branch is more advanced than the stable branch, but it can contain undiscovered and unfixed faults. A new development release is made every month or so, and OpenERP has made the code repository available so you can download the very latest revisions if you want.

The stable branch is designed for production environments. Here, releases of new functionality are made only about once a year after a long period of testing and validation. Only bug fixes are released through the year on the stable branch.

To download OpenERP for Windows, follow these steps:

2. Click the Downloads button at the right, then, under Windows Auto-Installer, select All-In-One.
3. Before you can proceed with the download, you will be asked to fill an online form with your contact and company details and information regarding your interest in OpenERP.
4. Once you submit the online form, the All-In-One Windows installer (currently openerp-allinone-setup-6.0.2.exe) becomes available for download.
5. Save the file on your PC - it is quite a substantial size because it downloads everything including the PostgreSQL database system (version 8.3, at the time of writing), so it will take some time.

9.1.2 Installing the OpenERP All-In-One

To install OpenERP and its database, you must be signed in as an Administrator on your PC.

If you have previously tried to install the All-In-One version of OpenERP, you will have to uninstall that first, because various elements of a previous installation could interfere with your new installation. Make sure that all Tiny ERP, OpenERP and PostgreSQL applications are removed: you are likely to have to restart your PC to finish removing all traces of them.

Double-click the installer file to install OpenERP and accept the default parameters on each dialog box as you go. The All-In-One installer is the simplest mode of installation and has the following steps:

- 1. Select installation language The default is English. The other option is French.
- 2. Welcome message Carefully follow the recommendations given in this step.
- 3. Licence Agreement It is important that you accept the GNU General Public License to proceed with installation.
• 4. **Select components to install** You can proceed with the default install type All In One, which will install the OpenERP Server, GTK Desktop Client, Web Client and PostgreSQL Database (version 8.3, at the time of writing). Or, you may customize your installation by selecting only the components you require.

• 5. **Configure PostgreSQL connection** The installer will suggest default parameters to complete your PostgreSQL connection configuration. You may accept the defaults, or change it according to your requirement.

• 6. **Select folder for installation** By default, OpenERP is installed in `C:\Program Files\OpenERP 6.0`. To install in a different folder, browse for a different location(folder) in this step.

• 7. **Install** The automatic installation of OpenERP begins and you can view its progress.
8. **Finish** On successful installation of OpenERP, you will get an appropriate confirmation. You can click *Finish* to close the setup wizard.

9.1.3 Starting the OpenERP Client

You do not need to manually start the OpenERP Server, because it is installed as a Windows service. But you may trigger various actions from the shortcuts created in the *Start* menu for *OpenERP GTK Client 6.0*, *OpenERP Server 6.0* and *PostgreSQL 8.3*. The OpenERP Client can be opened, ready to use the OpenERP system, once you have completed the All-In-One installation.

You will find the *OpenERP Client* icon on your desktop, which you double-click to access the OpenERP client interface. Use the menu *File → Connect...* to connect to a database. As this would be the first time you are using OpenERP since its installation, your database will be empty. You can create a new database through *File → Databases → New database*. 

---

Figure 9.3: *PostgreSQL configuration*

Figure 9.4: *End of setup wizard*
9.2 PostgreSQL Server Installation and Configuration

In this chapter, you will see how to configure PostgreSQL for its use with OpenERP. The following procedure is well-tested on PostgreSQL v9.0.

9.2.1 Installing PostgreSQL Server

You can download the Windows installer from the PostgreSQL download page. Depending on your need, choose either the One Click Installer or the pgInstaller and run the executable you have just downloaded.

9.2.2 Setup a PostgreSQL User

When the required software installations are complete, you must create a PostgreSQL user. OpenERP will use this user to connect to PostgreSQL.

Add a User

Start a Windows console (run the cmd command in the Search programs and files text box of the Start menu).

Change the directory to the PostgreSQL bin directory (e.g. C:\Program Files\PostgreSQL\9.0\bin) or add this directory to your PATH environment variable.

The default superuser for PostgreSQL is called postgres. The password was chosen during the PostgreSQL installation.

In your Windows console, type:

```
C:\Program Files\PostgreSQL\9.0\bin>createuser.exe --createdb --username postgres --pwprompt openpg
Enter password for new role: openpgpwd
Enter it again: openpgpwd
Shall the new role be a superuser? (y/n) y
Password: XXXXXXXXXX
```
* line 1 is the command itself
* line 2 asks you the new user’s password
* line 3 asks you to confirm the new user’s password
* line 4 new role is superuser or not?
* line 5 asks you the *postgres* user’s password

**Option explanations:**

- `--createdb`: the new user will be able to create new databases
- `--username postgres`: `createuser` will use the `postgres` user (superuser)
- `--no-createrole`: the new user will not be able to create new users
- `--pwprompt`: `createuser` will ask you the new user’s password
- `openpg`: the new user’s name. Alternatively, you may specify a different username.
- `openpgpwd`: the new user’s password. Alternatively, you may specify a different password.

---

**Password**

In OpenERP v6, `openpg` and `openpgpwd` are the default username and password used during the OpenERP Server installation. If you plan to change these defaults for the server, or have already installed the server with different values, you have to use those user configuration values when you create a PostgreSQL user for OpenERP.

---

Now use `pgAdmin III` to create database “openerpdemo” with owner “openpg”:

```sql
CREATE DATABASE openerpdemo WITH OWNER = openpg ENCODING = 'UTF8';
COMMENT ON DATABASE openerpdemo IS 'OpenERP Demo DB';
```

If you have installed the OpenERP Server, you can start it now. If needed, you can override the server configuration by starting the server at a Windows console and specifying command-line options. For more on this, refer the section *Customized Configuration* (page 201).

To change a user’s password in any Windows version, execute the following:

```bash
net user <accountname> <newpassword>
e.g. net user postgres postgres
```

If it is a domain account, just add “/DOMAIN” at the end.

If you want to delete it, just execute:

```bash
net user <accountname> /delete
```
Case-Insensitive Search Issue

For an installation which needs full UTF8 character support, consider using postgres >= 8.2.x. Using versions prior to this, OpenERP search will not return the expected results for case-insensitive searches, which are used for searching partners, products etc.

Example:

```
SELECT 'x' FROM my_table WHERE 'bét' ilike 'BÉT'
--matches only in 8.2.x
```

9.3 OpenERP Server Installation

The OpenERP Server 6.0 installation works with disks formatted in NTFS (not a FAT or FAT32 partition). The following installation procedure has been well-tested on Windows 7.

### Windows Versions

OpenERP Server does not work on Windows 98 or ME; for obvious reasons – these cannot be formatted using NTFS.

You will need a PostgreSQL server up and running. If it is not the case, you can read the *PostgreSQL Server Installation and Configuration* (page 197) section.

9.3.1 Downloading the OpenERP Server

The OpenERP Server can be downloaded from OpenERP website’s download page. Under *Windows Auto-Installer*, choose *Server* to download the OpenERP Server standalone.

9.3.2 Installing the OpenERP Server

Execute the installer you have just downloaded. It has the following stages:

1. **Select installation language** The default is *English*. The other option is *French*.

2. **Welcome message** Carefully follow the recommendations given in this step.

3. **Licence Agreement** It is important that you accept the GNU General Public License to proceed with installation.

4. **Select folder for installation** By default, OpenERP Server is installed in `C:\Program Files\OpenERP 6.0\Server`. To install in a different folder, browse for a different location(folder) in this step.
5. **Configure PostgreSQL connection** The installer will suggest default parameters to complete your PostgreSQL connection configuration. You may accept the defaults, or change it according to your requirement.

![Configure PostgreSQL connection](image)

**PostgreSQL configuration**

6. **Create shortcuts** Select a folder in the *Start* menu where you would like to create the program’s shortcuts.

![Create shortcuts](image)

**Create Start menu shortcuts**

7. **Install** The automatic installation of OpenERP Server begins and you can view its progress.

8. **Finish** On successful installation of OpenERP Server, you will get an appropriate confirmation. You can click *Finish* to close the setup wizard.

**End of setup wizard**

The OpenERP Server installs as a Windows service. This means you do not have to start the server each time you start the computer and it runs without the need of an open user session.
9.3.3 Customized Configuration

To initialize the server with configurations of your choice, you have to invoke it at the Windows Command prompt with the options you wish to override.

Navigate to the installation directory in `C:\Program Files\OpenERP 6.0\Server\` and type the command but do not execute it yet:

```
openerp-server.exe -d <db_name> -r <db_user> -w <db_password>
--db_host=<postgresql_server_address>
--db_port=<port_no> --logfile="<logfile>"
```

The initialization of OpenERP Server provides necessary information for connection to the PostgreSQL database and the choice of data to load. Here is the explanation of used options:

- `-d <db_name>`: Name of the database created for OpenERP Server.
- `-r <db_user>`: Name of the PostgreSQL user (role).
- `-w <db_password>`: Password of the PostgreSQL user.
- `--db_host=<postgresql_server_address>`: Address of the server where PostgreSQL is. If you have installed PostgreSQL on the same computer as OpenERP Server, you can enter `localhost`, else, the IP address or the name of the distant server.
- `--db_port=<port_no>`: Port number where PostgreSQL listens. The default is 5432.
- `--stop-after-init`: This option stops the server after initialization.
- `--logfile="<logfile>"`: specify an alternate logfile where all the output of server will be saved. The default is `C:\Program Files\OpenERP 6.0\Server\openerp-server.log`.

Before the execution of this command you have to decide the purpose of the database created in OpenERP.

Sample command:
openerp-server.exe -d openerpdemo -r openpg -w openpgpwd
--db_host=localhost --logfile="C:\Users\tiny\Desktop\demo_db.log"
--db_port=5430 --stop-after-init

Here you have to enter the username and password specified in the PostgreSQL connection configuration during server installation.

When you execute the initialization command, if you specify a logfile, the server runtime output is written to that file, and you will not see any server output in the prompt window. You have only to wait until the prompt comes back.

Deciding about the purpose of the database

You can initialize the database with OpenERP Server to:

1. Take a look at the system with modules installed and demo data loaded
2. Install a new clean database system (without demo data)
3. Upgrade an existing version

With modules and demo data

If you execute the sample command above, you will get a database with only base modules installed and loaded with demo data. To initialize OpenERP Server with additional modules and its demo data, you need to add this option to the above command:

- i <module name>

Sample command:

openerp-server.exe -d openerpdemo --stop-after-init -i sale

This command will initialize the OpenERP Server with the module sale and its dependencies, and fill its PostgreSQL database with their related demo data. As can be seen, you must specify the target database for the module installation.

To install more than one module, specify a comma-separated module list at the command-line.

Without demo data (or new clean version)

Execute the command with an option excluding the demo data:

--without-demo=all
This will load base modules (and other modules if -i option is used), but will not load its demo data.

Sample command usage:

```
openerp-server.exe -d openerpdemo --stop-after-init --without-demo=all
```

If you have already initialized the database with demo data loaded, you can create a new database and execute the above command on it.

**Update the database**

Execute the command with an option that updates the data structures:

```
--update=all
```

Sample command usage:

```
openerp-server.exe -d openerpdemo --stop-after-init --update=all
```

### 9.3.4 Monitoring the OpenERP Server

The service and some runtime information is accessible through the Computer Management console in Administrative Tools.

![Computer Management Console](image)

**OpenERP Server 6.0 in the Services list**

Here, you can define how the service should act in case of server failure. Access the service’s properties by double-clicking **OpenERP Server 6.0** in the list.

**Recovery tab to set service failure response**

The Computer Management logging service offers additional information about the execution of the OpenERP Server, for example, the startup or shutdown information of the service.
OpenERP Server runtime output can be found in the default logfile. Given that the server is now running as a Windows service, it does not output any runtime messages. For this, the logfile is the only option. Access it from the Start menu, through the View log link in the group of shortcuts for OpenERP Server 6.0. Alternatively, use the path C:\Program Files\OpenERP 6.0\Server\openerp-server.log.

OpenERP Server log file

You can find out whether OpenERP Server is running by invoking Windows Task Manager. When you look at the Processes tab, you will see OpenERPService.exe and openerp-server.exe, both having SYSTEM as their user (to see these, Show processes from all users must be enabled in the Task Manager).
The services in Windows Task Manager

9.3.5 Congratulations, you have successfully installed OpenERP Server

For more information, please take a look at Additional Installation Information and Troubleshooting (page 210), where you can find some troubleshooting examples.

9.4 OpenERP Client Installation

You must install, configure and run the OpenERP Server before using the OpenERP Client. The client needs the server to run. You can install the server application on your computer, or on an independent
server accessible by network.

9.4.1 Downloading the OpenERP Client

The OpenERP Client can be downloaded from OpenERP website’s download page. Under Windows Auto-Installer, choose Client to download the OpenERP Client standalone.

9.4.2 Installing the OpenERP Client

Click the executable installation file you have just downloaded, and proceed with the following steps:

- **1. Select installation language** The default is English. The other option is French.
- **2. Welcome message** Carefully follow the recommendations given in this step.
- **3. Licence Agreement** It is important that you accept the GNU General Public License to proceed with installation.
- **4. Select folder for installation** By default, OpenERP Client is installed in C:\Program Files\OpenERP 6.0\Client. To install in a different folder, browse for a different location(folder) in this step.
- **5. Create shortcuts** Select a folder in the Start menu where you would like to create the program’s shortcuts.

Create Start Menu Shortcuts

- **6. Install** The automatic installation of OpenERP Client begins and you can view its progress.
- **7. Finish** On successful installation of OpenERP Client, you will get an appropriate confirmation. Click Finish to close the setup wizard.

End of Configuration Wizard
9.4.3 Starting the OpenERP Client

The installation program creates shortcuts in the main program menu and on the desktop, which you can use to start the client. Be sure to have an OpenERP Server running somewhere (on your computer or a distant server) to be able to use the client software.

Log in to openerpdemo database using default username and password:

- Username = admin
- Password = admin

Enjoy!

Connecting to the Demo Database

9.5 OpenERP Web Installation

You must install, configure and run the OpenERP Server before using the OpenERP Web. The web client needs the server to run. You can install the server application on your computer, or on an independent server accessible by network.
9.5.1 Downloading the OpenERP Web

The OpenERP Web can be downloaded from OpenERP website’s download page. Under Windows Auto-Installer, choose Web to download the OpenERP Web standalone.

9.5.2 Installing the OpenERP Web

Click the executable installation file you have just downloaded, and proceed with the following steps:

- 1. **Select installation language**  The default is English. The other option is French.
- 2. **Welcome message**  Carefully follow the recommendations given in this step.
- 3. **Licence Agreement**  It is important that you accept the OpenERP Public License (OEPL) Version 1.1 to proceed with installation. This licence is based on the Mozilla Public Licence (MPL) Version 1.1.

![OpenERP Public Licence](image)

**OpenERP Public Licence**

- 4. **Select folder for installation**  By default, OpenERP Web is installed in `C:\Program Files\OpenERP 6.0\Web`. To install in a different folder, browse for a different location(folder) in this step.

- 5. **Create shortcuts**  Select a folder in the Start menu where you would like to create the program’s shortcuts.

  **Create Start Menu Shortcuts**

- 6. **Install**  The automatic installation of OpenERP Web begins and you can view its progress.

- 7. **Finish**  On successful installation of OpenERP Web, you will get an appropriate confirmation. Click Finish to close the setup wizard.

The Windows service for OpenERP Web Server is also installed and is set up to start the server automatically on system boot.
9.5.3 Starting the Web Client

The web server being initialized and the settings saved, you can start the OpenERP Web Client.

Use a web browser of your choice to connect to OpenERP Web. If your web client is installed on the same computer as the server, you can navigate to http://localhost:8080 to connect to the OpenERP web version. If the server is installed on a separate computer, you must know the name or IP address of the server over the network and navigate to http://<server_address>:8080 to connect to OpenERP.

![Figure 9.6: Web Client at Startup](image_url)
9.6 Troubleshooting and Windows Complementary Install Information

9.6.1 PostgreSQL Administration

OpenERP Server Connection Error with PostgreSQL

If you are initializing a database from the command-line with a custom username/role (-r) and password (-w), ensure that you have created a corresponding PostgreSQL user for the same. Otherwise you may encounter error messages as shown below:

```
User authentication failure
```

You may also face another problem similar to this situation:

```
Database connection failure
```

In this case, check if the service `postgresql-9.0 - PostgreSQL Server 9.0` is running in the Services Manager (Control Panel → System and Security → Administrative Tools → Services).

*PostgreSQL 9.0 in the Services list*

You can edit the service configuration to start PostgreSQL as a service on system boot. This is usually the default.

*Configure PostgreSQL 9.0 service*

If your PostgreSQL service is running, but you get connection errors, you can restart the service.

*Restarting the service*
CHAPTER 9. OPENERP INSTALLATION ON WINDOWS

---

**postgres-9.0 - PostgreSQL Server 9.0 Properties (Local Computer)**

**General**

- **Service name**: postgres 9.0
- **Display name**: postgres 9.0 - PostgreSQL Server 9.0
- **Description**: Provides relational database storage

**Path to executable**: C:\Program Files\PostgreSQL\9.0\bin\pg_ctl.exe

**Startup type**: Automatic

**Help me configure**: Automatic (Delayed Start)

**Service status**: Disabled

You can specify the start parameters that apply when you start the service from here.

**Start parameters**: 

---

**Services (Local)**

- **Stop**
- **Start**
- **Pause**
- **Resume**

---

**Properties**

---
Index

A
  absences, 94
  access, 35
  account
    chart, 33
  account types, 22
  accountant, 85
  accounts
    configuring, 22
  alerts, 53
  allocation
    cost, 92, 96
  analytic
    chart of accounts, 91
  Analytic Accounts, 89

B
  backup
    database, 34

C
  carriers, 57
  category
    partner, 27
    product, 30
  chart of accounts, 33
    analytic, 91
  contact
    partner, 27
  control
    delivery, 56
    invoicing, 56
  cost
    allocation, 92, 96

D
  database
    backup, 34
    drop, 34
    duplicate, 35
  restore, 34
  delivery
    control, 56
  delivery grid, 57

E
  export
    stock management, 160

F
  Flow, 6
  forecasts, 143

I
  import
    stock management, 160
  Installation
    OpenERP All-In-One (Windows), 193
    OpenERP Client (Linux), 186
    OpenERP Client (Windows), 205
    OpenERP Server (Linux), 184
    OpenERP Server (Windows), 199
    OpenERP Web (Linux), 189
    OpenERP Web (Windows), 207
    PostgreSQL, 181
    PostgreSQL (Windows), 196
    Windows installation quirks, 209
  installation
    administrator, 194
    Windows (all-in-one), 194
  invoicing
    control, 56

J
  journals
    configuring, 25

L
  location structure, 32
  Logistics, 6, 99

M
  Main Company
configuring, 26
Master Procurement Schedule, 139
Master Production Schedule, 139
Module
mrp_jit, 125
Sale, 125
module
account, 21, 39
account_analytic_analysis, 63
account_analytic_default, 81
account_invoice_layout, 74
delivery, 57, 85
discount_campaign, 72
hr_timesheet_invoice, 89
mrp_jit, 41, 128
product, 21
product_extended, 60, 88
product_margin, 61, 89
product_visible_discount, 48
profile_manufacturing, 57
purchase, 21, 79
purchase_analytic_analysis, 81
purchase_analytic_plans, 81, 90
purchase_tender, 86
report_intrastat, 161
sale, 21
sale_delivery, 73
sale_journal, 154
sale_layout, 74
sale_margin, 60
sale_supplier_direct_delivery, 129
stock, 21, 103
stock_location, 161
stock_planning, 143
warning, 53, 80
MPS, 139
multi-company logistic, 167
OpenERP versions, 193
OpenERP Web
Installation (Linux), 189
Installation (Windows), 207
P
partner, 27
category, 27
contact, 27
PDF viewer, 188
plan
production, 143
PostgreSQL
Installation, 181
Installation (Windows), 196
setup a database, 181
setup a database (Windows), 197
setup a user, 181
setup a user (Windows), 197
price, 66
pricelist
create, 65
default pricelist, 69
pricelists
version, 66
product, 30
category, 30
properties
defining, 24
Purchase, 6
purchase
tender, 86
Purchasing, 77
R
Real Case, 15
rent, 161
S
Sales, 6
Sales Management, 43
Stock
Double-Entry, 103
Inventory operation, 104
Location, 109
Location types, 109
Negative, 127
Stock check, 104
Warehouse, 106
stock
  journal, 154
  location, 31
Stock Management, 99

T
tender, 86
traceability
  downstream, 145
  upstream, 145
traceability (stock), 148
trading company, 69

W
warning, 53