Open ERP, a modern approach to integrated business management

Release 6.0.0

Fabien Pinckaers
Geoff Gardiner
Els Van Vossel
## Organize your Partners
- Advanced Customer Relations
- Helpdesk Calendars
- Analyzing Performance
- Automating actions using rules
- Using the e-mail gateway
- Supplier relationship management
- Profiling

## Advanced Customer Relations

## Helpdesk Calendars

## Analyzing Performance

## Automating actions using rules

## Using the e-mail gateway

## Supplier relationship management

## Profiling

### Communication Tools
- Microsoft Outlook interface
- Mozilla Thunderbird interface

### Marketing Campaigns

### Manage your Books

#### How to keep track of your Invoicing & Payments
- Invoicing Workflow

#### From Invoice to Payment
- Accounting Workflow and Automatic Invoice Creation
- Invoices
- Accounting Entries
- Payment Management

#### Financial Analysis
- Reporting
- Statutory Taxes and Chart of accounts
- Company Financial Analysis

#### Configuring Accounts from A to Z
- Chart of Accounts
- Journals
- Periods and Financial Years
- Payment Terms
- Opening Entries

### Effective Management of Operations

#### Analytic Accounts
- To each enterprise its own Analytic Chart of Accounts
- Putting Analytic Accounts in Place
- Analytic Entries
- Financial Analysis

#### Lead & Inspire your People
- Managing Human Resources
- Timesheets
- Keeping Track of Expenses
- Hire New People
- Inspire your People

#### Deliver Quality Services
- Managing Service Contracts

#### Drive your Projects
- Project Management
19.2 Long Term Project Planning ................................................. 234
19.3 Planning to Improve Leadership ....................................... 236
19.4 The Art of Productivity without Stress ................................. 239

VI Manage your Warehouse and Get your Manufacturing done 243

20 Your Warehouse 247
20.1 Understanding Double-Entry Stock Management .................. 248
20.2 From Supplier to Customer ............................................... 250
20.3 Stocks ........................................................................ 254
20.4 Basic Logistics Configuration .......................................... 262
20.5 Logistics Configuration in a Multi-Company Environment ....... 268
20.6 Import / Export ............................................................. 272
20.7 Warehouses ................................................................ 275
20.8 Scheduling ................................................................... 277
20.9 Management of Lots and Traceability ................................. 279
20.10 Management by Journal .................................................. 282
20.11 Advanced Elements of Stock Management ....................... 284

21 Manufacturing 293
21.1 Management of production .............................................. 293
21.2 Bills of Materials ............................................................ 294
21.3 Multi-level Bills of Materials ............................................. 297
21.4 Manufacturing ............................................................... 301
21.5 Workflow for complete production ................................... 302
21.6 Production order in detail ............................................... 308
21.7 Scheduling .................................................................... 310
21.8 Calculation of lead times ................................................ 310
21.9 Operations .................................................................... 312
21.10 Events and barcodes ...................................................... 317
21.11 Treatment of exceptions .............................................. 319
21.12 Manual procurement .................................................... 320
21.13 Management of waste products and secondary products .. 321
21.14 Management of repairs ................................................. 322

VII Manage your Business 327

22 Driving your Sales 331
22.1 Sales Quotations ............................................................ 331
22.2 Packaging ..................................................................... 335
22.3 Alerts .......................................................................... 336
22.4 Control Deliveries and Invoicing ..................................... 338
22.5 Management of Carriers ................................................ 339
22.6 Keep Track of your Margins ............................................. 341
22.7 Pricing Policies ............................................................. 344
22.8 Rebates at the End of a Campaign .................................. 350
22.9 Open Orders .................................................................. 351
22.10 Layout Templates .......................................................... 352

23 Driving your Purchases 355
23.1 All the Elements of a Complete Workflow ......................... 355
23.2 Purchase Analysis .......................................................... 363
23.3 Analytic Accounts .......................................................... 364
XI Conclusion

33 You are not alone
   33.1 Bypass the technical difficulties by using the SaaS offer
   33.2 Consult the available resources

Index
Part I

Foreword
Information Systems have played an increasingly visible role over the past several years in improving the competitiveness of business. More than just tools for handling repetitive tasks, they are used to guide and advance all of a company’s daily activities. Integrated management software is today very often a key source of significant competitive advantage.

The standard response to a need for responsiveness, reliability, and rapidly increasing expectations is to create an organization based on departments with a clear linear structure, integrated around your operating processes. To increase efficiency amongst salespeople, accountants, logistics staff and everyone else you should have a common understanding of your problems.

For this you need a common language for shared references, policies and communication. An ERP (Enterprise Resource Planning) system provides the ideal platform for this common reference point.
Risks and integration costs are important barriers to all the advantages you gain from such systems. That is why, today, few small- and medium-sized companies use ERP. In addition, the larger ERP vendors such as SAP, Microsoft and Oracle have not been able to reconcile the power and comprehensive cover of an ERP system with the simplicity and flexibility wanted by the users. But this is exactly what small and medium enterprises are looking for.

The development processes of Open Source Software, and the new business models adopted by their developers, provide a new way of resolving such cost and quality issues for this kind of enterprise software.

To make an ERP system fully available to small and medium enterprises, cost reduction is the first priority. Open source software makes it possible to greatly reduce development costs by aggressive reuse of open source software libraries; to eliminate intermediaries (the distributors), with all of their expensive sales overhead; to cut out selling costs by free publication of the software; and to considerably reduce the marketing overhead.

Since there is open interaction among thousands of contributors and partners working on the same project, the quality of the resulting software greatly benefits from the scrutiny. And you cannot be everything at once: accountant, software developer, salesperson, ISO 9001 quality professional, specialist in agricultural products, expert in the customs and habits of pharmaceutical vendors, just as a start.

Faced with these wide-ranging requirements, what could be better than a worldwide network of partners and contributors? Every single person adds own contributions according to his or her professional competence. Throughout this book you will see that the results exceed any reasonable expectations when such work is well organized.

But the real challenge of development is to make this solution simple and flexible, as well as complete. And to reach this level of quality you need a leader and co-ordinator who can organize all of these activities. So the development team of Tiny ERP, today called OpenERP, is responsible for most of the organization, synchronization and coherence of the software.

And OpenERP offers great performance in all these areas!
Because of its modularity, collaborative developments in OpenERP have been cleanly integrated, enabling any company to choose from a large list of available functions. As with most open source software, accessibility, flexibility and ease of use are important keywords for development. Experience has shown that there is no need to train users for several months on the system, because they can just download it and use it directly.

So you will find modules to suit all kinds of needs, allowing your company to build its customized system by simply grouping and configuring the most suitable modules. Hundreds of modules are available.

They range from specific modules like the EDI interface for agricultural products, which has been used to interface with Match and Leclerc stores, up to the generic demonstration automation module for ordering sandwiches, which can take care of the eating preferences of your staff.

The results are rather impressive. OpenERP (once called Tiny ERP when it started out) is a Management Software that is downloaded more than any other in the world, with over 600 downloads per day. Today it is available in 18 languages and has a worldwide network of partners and contributors. More than 800 developers participate in the projects on the collaborative development system.

To our knowledge, OpenERP is the only management system which is routinely used not only by big companies but also by very small companies and independent companies. This diversity is an illustration of the software’s flexibility: a rather elegant coordination between people’s functional expectations of the software and great ease of use.

And this diversity is also found in the various sectors and trades which use the software, including agricultural products, textiles, public auctions, IT, and trade associations.

Last but not least, such software has arisen from the blend of high code quality, well-judged architecture and use of free technologies. In fact, you may be surprised (if you are an IT person) to find that the download size of OpenERP is only around 6 MB. When that is expanded during installation its size is mostly attributable to all the official translations that are packaged with it, not the operating code. We’ve moved a long way from the days when the only people who could be expected to benefit from ERP were the owners of a widget factory on some remote industrial estate.

### 2.1 Why this book?

Many books set out to tell readers about the management of enterprise, and equally many aim to instruct the reader in the use of a piece of specialized software. We are not aiming to add to those lists because our approach is intended to be different.

Having restructured and reorganized many businesses, we wanted our management experience to generate a work that is both instructive and practical. It was important for us not to write a manual about OpenERP, but instead a work that deals with advanced management techniques realized through these IT tools. You will see what management practices might be useful, what is possible, and then how you could achieve that in OpenERP.

This is what we will consider OpenERP to be: not an end in itself but just the tool you use to put an advanced management system into place.
2.2 Who is it for?

Written by two CEOs who have been successful with new technologies, this book is aimed at directors and managers who have an ambition to improve the performance of their whole company’s management team. They are likely to already have significant responsibilities and possess the influence to get things done in their company.

It is likely that most readers will come from small- and medium-sized enterprises (up to a few hundred staff), and independent companies, because of the breadth of functions that need to be analyzed and involved in change. The same principles also apply to larger companies, however.
CHAPTER
THREE

STRUCTURE OF THIS BOOK

Part One, *First steps with OpenERP*, starts with the installation of OpenERP. If you have already installed OpenERP you can directly take your first steps on a guided tour in the *Guided Tour* chapter. If you are already familiar with OpenERP or Tiny ERP you can use the *How does it apply to your Business?* chapter to find out how to create a new workflow from scratch in an empty database with nothing to distract you. Or you can skip directly to the *Keep track of your Customers & Suppliers* chapter in the *Boost your Sales & Deliver Great Services* part, to start with details of OpenERP’s functional modules.

Part Two, *Boost your Sales & Deliver Great Services*, deals with Supplier and Customer Relationship Management (SRM & CRM). You will find the elements necessary for managing an efficient sales department there, and automating tasks to monitor performance.

Part Three, *Manage your Books*, is devoted to general accounting and its key role in the management of the whole enterprise.

Part Four, *Effective Management of Operations*, handles all the operational functions of enterprise management: Human Resources for managing projects, through financial analyses supplied by analytic (or cost) accounts. You will see how using OpenERP can help you optimize your leadership of an enterprise.

Part Five, *Manage your Warehouse and Get your Manufacturing done*, describes the physical movement of Stocks and their Manufacturing (the transformation or products and services into other products).

Part Six, *Manage your Business*, deals with Purchasing and Selling goods and services.

Part Seven, *Process and Document Management*, is focused on the Process description and Documentation & Knowledge handling that OpenERP manages.

Finally Part Eight, *System Administration and Implementation*, structured in two chapters, explains first how to administer and configure OpenERP, then provides a methodology for implementing OpenERP in your enterprise.
Note: About the authors

**Fabien Pinckaers**

Fabien Pinckaers was only eighteen years old when he started his first company. Today, over ten years later, he has founded and managed several new technology companies, all based on Free/Open Source software. He originated Tiny ERP, now OpenERP, and is the director of two companies including Tiny sprl, the editor of Open ERP. In three years he has grown the Tiny group from one to sixty-five employees without loans or external fund-raising, and while making a profit.

He has also developed several large scale projects, such as Auction-in-Europe.com, which become the leader in the art market in Belgium. Even today people sell more art works there than on ebay.be.

He is also the founder of the LUG (Linux User Group) of Louvain-la-Neuve, and of several free projects like OpenReport, OpenStuff and Tiny Report. Educated as a civil engineer (polytechnic), he has won several IT prizes in Europe such as Wired and l’Inscene.

A fierce defender of free software in the enterprise, he is in constant demand as a conference speaker and he is the author of numerous articles dealing with free software in the management of the enterprise.

Follow Fabien on his blog [http://fptiny.blogspot.com/](http://fptiny.blogspot.com/) or on twitter fpopenerp.

**Geoff Gardiner**

Geoff has held posts as director of services and of IT systems for international companies and in manufacturing. He was Senior Industrial Research Fellow at Cambridge University’s Institute for Manufacturing where he focused on innovation processes.

He founded Seath Solutions Ltd ([http://www.seathsolutions.com/](http://www.seathsolutions.com/)) to provide services in the use of Open Source software, particularly Open ERP, for business management.

Author of articles and books focusing on the processes and technology of innovation, Geoff is also an active contributor to the Open ERP project. He holds an MBA from Cranfield School of Management and an MA in Engineering and Electrical Sciences from Trinity Hall, Cambridge. He is a member of the Institution of Engineering and Technology and of the Society of Authors.

Having observed, suffered, and led process implementation projects in various organizations, he has many thoughts to share on the successful adoption of an effective management automation tool.

**Els Van Vossel**

Els Van Vossel always had a dedication to both written and spoken word. Clear and explicite communication is crucial.

Educated as a Professional Translator in Antwerp, she worked as an independent translator on the localization of major ERP softwares. Els acquired ERP knowledge and decided to start working as a functional ERP consultant and a Technical Communicator for ERP software.

As such, the world of OpenSource software became more and more attractive. She started working with OpenERP software in her free time and doing so, Els really wanted to meet Fabien Pinckaers to share thoughts about documentation and training strategy. At a Partner Meeting she heard Fabien was looking for someone to manage the trainings & documentation. This was absolutely an opportunity to be qualified, and now Els is the OpenERP Training Program Manager and in this job responsible for the worldwide training and certification program of OpenERP.

Being an author of several Software Manuals, it is a great challenge to work on the OpenERP documentation and continuously take it to a higher level. Please note that this is a hell of a job, but Els finds great pleasure in doing it!

Follow Els on her blog [http://training-openerp.blogspot.com/](http://training-openerp.blogspot.com/) or on twitter elsvanvossel.
DEDICATION

From Geoff Gardiner
My gratitude goes to my co-author, Fabien Pinckaers, for his vision and tenacity in developing Tiny ERP and OpenERP, and the team at OpenERP for its excellent work on this.

OpenERP relies on a philosophy of Open Source and on the technologies that have been developed and tuned over the years by numerous talented people. Their efforts are greatly appreciated.

Thanks also to my family for their encouragement, their tolerance and their constant presence.

From Els Van Vossel
Thank you Fabien, for offering me the opportunity to work with OpenERP. Thanks to my documentation team for helping me to get a first V6.0.0 version of the documentation! In the near future, I dedicate myself to restructuring the documentation completely and manage to get a real Business-oriented version. For that, already in advance I thank the OpenERP team for their support.

From Fabien Pinckaers
I address my thanks to all of the team at OpenERP for their hard work in preparing, translating and re-reading the book in its various forms. My particular thanks to Laurence Henrion and my family for supporting me throughout all this effort.
Part II

First steps with OpenERP
OpenERP is an impressive software system, being easy to use and yet providing great benefits in helping you manage your company. It is easy to install under both Windows and Linux compared to other enterprise-scale systems, and offers unmatched functionality.

The objective of this first part of the book is to help you start discovering OpenERP in practice.

The first chapter, *Installation and Initial Setup*, gives detailed guidance for installing it. If you are not a system administrator, or if you have already installed OpenERP, or if you are planning to use an online SaaS provider, then you can skip this chapter and move straight to the next chapter, *Guided Tour*. There we take you on a step-by-step guided tour using the information in the demonstration database.

If you have already used OpenERP (or Tiny ERP) a bit then you can move to the third chapter in this part of the book. In *How does it apply to your Business?* you can try out a real case, from scratch in a new database, by developing a complete business workflow that runs from purchase to sale of goods.

![Figure 4.1: Options for reading this part of the book](image)

---

**Figure 4.1: Options for reading this part of the book**
We want to make it very easy for you to test OpenERP or put it into full production. You have at least three starting points:

- no need to install OpenERP, you can test it through http://demo.openerp.com,
- evaluate it on line at http://www.openerp.com and ask OpenERP for a SaaS trial hosted at http://www.openerp.com/online, or the equivalent service at any of OpenERP’s partner companies,
- install it on your own computers to test it in your company’s system environment.

Before installing OpenERP, you may like to test the features and performance of the system according to your company’s needs. In such a scenario, you are recommended to use the OpenERP Online Free Trial Subscription. You can get a month’s free trial on OpenERP’s http://www.openerp.com/online, which enables you to get started quickly without incurring costs for integration or for buying computer systems.

You will be required to enter some basic details during the registration process which will enable you to get started as well as receive support. After successful registration, you will be able to configure and use OpenERP online.

Many of OpenERP’s partner companies will access this, and some may offer their own similar service. This service should be particularly useful to small companies that just want to get going quickly and at low cost.

OpenERP Online always uses the latest official stable version of OpenERP. The OpenERP Online offer includes several services: hosting, database management, stable security update, backups, maintenance, bug fixing and migrations.

After the free trial expires, you may choose to continue using OpenERP Online, especially if you would like to bypass technical difficulties. This server is also recommended for small companies with fewer than about fifteen employees. It is provided in the form of a monthly subscription with a fixed price per user. You can find the details of current pricing and payment options at http://www.openerp.com/online.

For every subscription, the following hardware resources are provided:

1. One application server for OpenERP, with web and GTK access
2. Two incremental backup servers
3. An access to the control center, backup and monitoring system

It also includes the following services:

- Maintenance services:
  - bug fixes analyzed within 3 open days
  - migrations to each new version
  - security updates.
- Hosting at high bandwidth in our Europe or U.S. data-centers
- Maintenance and 24/7 monitoring of your servers
Using the online offer, you may also take benefit of services at an extra fee on OpenERP Online: support, trainings, help to customize or configure, data importation, etc. You can also contact an OpenERP partner; most of them provide services on OpenERP Online as well.
INSTALLATION AND INITIAL SETUP

Installing OpenERP under Windows or Linux to get familiar with the software should take you only half an hour or so and needs only a couple of operations.

The first operation is to install the application and database server on a server PC (that is a Windows or Linux or Macintosh computer).

You have a choice of approaches for the second operation: either install a web server (most probably on the original server PC) to use with standard web clients that can be found on anybody’s PC, or install application clients on each intended user’s PC.

When you first install OpenERP, you will set up a database containing a little functionality and some demonstration data to test the installation.

**Note:** Renaming from Tiny ERP to OpenERP
Tiny ERP was renamed to OpenERP early in 2008 so somebody who has already used Tiny ERP should be equally at home with Open ERP. The two names refer to the same software, so there is no functional difference between versions 4.2.X of OpenERP and 4.2.X of Tiny ERP. This book applies to versions of OpenERP from 6.0.0 onwards, with references to earlier versions from time to time.

**Note:** The SaaS, or “on-demand”, offer
SaaS (Software as a Service) is delivered by a hosting supplier and paid in the form of a monthly subscription that includes hardware (servers), system maintenance, provision of hosting services, and support.
You can get a month’s free trial on OpenERP’s http://www.openerp.com/online, which enables you to get started quickly without incurring costs for integration or for buying computer systems. Many of OpenERP’s partner companies will access this, and some may offer their own similar service.

This service should be particularly useful to small companies that just want to get going quickly and at low cost. It gives you immediate access to an integrated management system that has been built on the type of enterprise architecture used in banks and other large organizations. OpenERP is that system, and is described in detail throughout this book.

Whether you want to test OpenERP or to put it into full production, you have at least three starting points:

- no need to install OpenERP, you can test it through http://demo.openerp.com,
- evaluate it on line at http://www.openerp.com and ask OpenERP for a SaaS trial hosted at http://ondemand.openerp.com, or the equivalent service at any of OpenERP’s partner companies,
- install it on your own computers to test it in your company’s system environment.

There are some differences between installing OpenERP on Windows and on Linux systems, but once installed, both systems offer the same functionality so you will not generally be able to tell which type of server you are using.

**Note:** Linux, Windows, Mac
Although this book deals only with installation on Windows and Linux systems, the same versions are also available for Macintosh on the official website of OpenERP.
Websites for OpenERP
- Main Site: http://www.openerp.com,
- SaaS or OpenERP OnLine Site: http://www.openerp.com/online,
- Documentation Site: http://doc.openerp.com/,
- Community discussion forum where you can often receive informed assistance: http://www.openobject.com/forum.

Tip: Current documentation
The procedure for installing OpenERP and its web server are sure to change and improve with each new version, so you should always check each release’s documentation – both packaged with the release and on the website – for exact installation procedures.

Once you have completed this installation, create and set up a database to confirm that your OpenERP installation is working. You can follow earlier chapters in this part of the book to achieve this.

6.1 The architecture of OpenERP

To access OpenERP you can:
- use a web browser pointed at the OpenERP client-web server, or
- use an application client (the GTK client) installed on each computer.

The two methods of access give very similar facilities, and you can use both on the same server at the same time. It is best to use the web browser if the OpenERP server is some distance away (such as on another continent) because it is more tolerant of time delays between the two than the GTK client is. The web client is also easier to maintain, because it is generally already installed on users’ computers.

Conversely you would be better off with the application client (called the GTK client because of the technology it is built with) if you are using a local server (such as in the same building). In this case the GTK client will be more responsive, so more satisfying to use.

Note: Web client and GTK client
There is little functional difference between the two OpenERP clients - the web client and the GTK client at present. The web client offers more functionality for instance for Calendar view, Gantt view, . When you are changing the structure of your OpenERP installation (adding and removing modules, perhaps changing labels) you might find the web client to be irritating because of its use of caching. Caching speeds it all up by keeping a copy of data somewhere between the server and your client, which is usually good. But you may have made changes to your installation that you cannot immediately see in your browser. Many apparent faults are caused by this! The workaround is to use the GTK client during development and implementation where possible. The OpenERP company will continue to support two clients for the foreseeable future, so you can use whichever client you prefer.

An OpenERP system is formed from three main components:
- the PostgreSQL database server, which contains all of the databases, each of which contains all data and most elements of the OpenERP system configuration,
- the OpenERP application server, which contains all of the enterprise logic and ensures that OpenERP runs optimally,
- the web server, a separate application called the Open Object client-web, which enables you to connect to OpenERP from standard web browsers and is not needed when you connect using a GTK client.
Figure 6.1: The architecture of OpenERP

**Note:** Terminology: client-web – server or client?
*The client-web component can be thought of as a server or a client depending on your viewpoint.*
*It acts as a web server to an end user connecting from a web browser, but it also acts as a client to the OpenERP application server just as a GTK application client does.*
*So in this book its context will determine whether the client-web component is referred to as a server or a client.*

**Note:** eTiny
*The web application used to be known as “eTiny”. Its name changed to “client-web” as Tiny ERP was renamed to OpenERP, but its characteristics have generally stayed the same.*

**Note:** PostgreSQL, the relational and object database management system.
*It is a free and open-source high-performance system that compares well with other database management systems such as MySQL and FirebirdSQL (both free), Sybase, DB2 and Microsoft SQL Server (all proprietary). It runs on all types of Operating System, from Unix/Linux to the various releases of Windows, via Mac OS X, Solaris, SunOS and BSD.*

These three components can be installed on the same server or can be distributed onto separate computer servers if performance considerations require it.

If you choose to run only with GTK clients you will not need the third component – the client-web server – at all. In this case OpenERP’s GTK client must be installed on the workstation of each OpenERP user in the company.

### 6.2 The installation of OpenERP

Whether you are from a small company investigating how OpenERP works, or you are part of the IT staff of a larger organization and have been asked to assess OpenERP’s capabilities, your first requirement is to install it or to find a working installation.

The table below summarizes the various installation methods that will be described in the following sections.
Table 6.1: Comparison of the different methods of installation on Windows or Linux

<table>
<thead>
<tr>
<th>Method</th>
<th>Average Time</th>
<th>Level of Complexity</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>OpenERP Demo</td>
<td>No installation</td>
<td>Simple</td>
<td>Very useful for quick evaluations because no need to install anything.</td>
</tr>
<tr>
<td>All-in-one Windows Installer</td>
<td>A few minutes</td>
<td>Simple</td>
<td>Very useful for quick evaluations because it installs all of the components pre-configured on one computer (using the GTK client).</td>
</tr>
<tr>
<td>Independent installation on Windows</td>
<td>Half an hour</td>
<td>Medium</td>
<td>Enables you to install the components on different computers. Can be put into production use.</td>
</tr>
<tr>
<td>Ubuntu Linux packages</td>
<td>A few minutes</td>
<td>Simple</td>
<td>Simple and quick but the Ubuntu packages are not always up to date.</td>
</tr>
<tr>
<td>From source, for all Linux systems</td>
<td>More than half an hour</td>
<td>Medium to slightly difficult</td>
<td>This is the method recommended for production environments because it is easy to keep it up to date.</td>
</tr>
</tbody>
</table>

Each time a new release of OpenERP is made, OpenERP supplies a complete Windows auto-installer for it. This contains all of the components you need – the PostgreSQL database server, the OpenERP application server and the GTK application client.

This auto-installer enables you to install the whole system in just a few mouse clicks. The initial configuration is set up during installation, making it possible to start using it very quickly as long as you do not want to change the underlying code. It is aimed at the installation of everything on a single PC, but you can later connect GTK clients from other PCs, Macs and Linux boxes to it as well.

The first step is to download the OpenERP installer. At this stage you must choose which version to install – the stable version or the development version. If you are planning to put it straight into production we strongly advise you to choose the stable version.

**Note:** Stable versions and development versions

OpenERP development proceeds in two parallel tracks: stable versions and development versions. New functionality is integrated into the development branch. This branch is more advanced than the stable branch, but it can contain undiscovered and unfixed faults. A new development release is made every month or so, and OpenERP has made the code repository available so you can download the very latest revisions if you want. The stable branch is designed for production environments. Releases of new functionality there are made only about once a year after a long period of testing and validation. Only bug fixes are released through the year on the stable branch.

To download the version of OpenERP for Windows, follow these steps:

2. Click the **Downloads** button at the right, then, under **Windows Auto-Installer**, select **All-in-One**.
3. This brings up the demonstration version Windows installer, currently **openerp-allinone-setup-6.0.0**.
4. Save the file on your PC - it is quite a substantial size because it downloads everything including the PostgreSQL database system, so it will take some time.

To install OpenERP and its database you must be signed in as an Administrator on your PC. Double- click the installer file to install it and accept the default parameters on each dialog box as you go.

If you had previously tried to install the all-in-one version of OpenERP, you will have to uninstall that first, because various elements of a previous installation could interfere with your new installation. Make sure that all Tiny ERP, OpenERP and PostgreSQL applications are removed: you are likely to have to restart your PC to finish removing all traces of them.

The OpenERP client can be opened, ready to use the OpenERP system, once you have completed the all-in-one installation. The next step consists of setting up the database, and is covered in the final section of this chapter *Creating the database.*
6.2.1 Independent Installation on Windows

System administrators can have very good reasons for wanting to install the various components of a Windows installation separately. For example, your company may not support the version of PostgreSQL or Python that is installed automatically, or you may already have PostgreSQL installed on the server you are using, or you may want to install the database server, application server and web server on separate hardware units.

For this situation you can get separate installers for the OpenERP server and client from the same location as the all-in-one auto-installer. You will also have to download and install a suitable version of PostgreSQL independently.

You must install PostgreSQL before the OpenERP server, and you must also set it up with a user and password so that the OpenERP server can connect to it. OpenERP’s web-based documentation gives full and current details.

Connecting users on other PCs to the OpenERP server

To connect other computers to the OpenERP server you must set the server up so that it is visible to the other PCs, and install a GTK client on each of those PCs:

1. Make your OpenERP server visible to other PCs by opening the Windows Firewall in the Control Panel, then ask the firewall to make an exception of the OpenERP server. In the Exceptions tab of Windows Firewall click Add a program... and choose OpenERP Server in the list provided. This step enables other computers to see the OpenERP application on this server.

2. Install the OpenERP client (openerp-client-6.X.exe), which you can download in the same way as you downloaded the other OpenERP software, onto the other PCs.

Tip: Version matching
You must make sure that the version of the client matches that of the server. The version number is given as part of the name of the downloaded file. Although it is possible that some different revisions of client and server will function together, there is no certainty about that.

To run the client installer on every other PC you will need to have administrator rights there. The installation is automated, so you just need follow the different installation steps.

To test your installation, start by connecting through the OpenERP client on the server machine while you are still logged in as administrator.

Note: Why sign in as a PC Administrator?
You would not usually be signed in as a PC administrator when you are just running the OpenERP client, but if there have been problems in the installation it is easier to remain as an administrator after the installation so that you can make any necessary fixes than to switch users as you alternate between roles as a tester and a software installer.

Start the GTK client on the server through the Windows Start menu there. The main client window appears, identifying the server you are connected to (which is localhost – your own server PC – by default). If the message No database found, you must create one appears then you have successfully connected to an OpenERP server containing, as yet, no databases.
Note: Connection modes

In its default configuration at the time of writing, the OpenERP client connects to port 8069 on the server using the XML-RPC protocol (from Linux) or port 8070 using the NET-RPC protocol instead (from Windows). You can use any protocol from either operating system. NET-RPC is quite a bit quicker, although you may not notice that on the GTK client in normal use. OpenERP can run XML-RPC, but not NET-RPC, as a secure connection.

Resolving errors with a Windows installation

If you cannot get OpenERP to work after installing your Windows system you will find some ideas for resolving this below:

1. Is the OpenERP Server working? Signed in to the server as an administrator, stop and restart the service using Stop Service and Start Service from the menu Start → Programs → OpenERP Server.

2. Is the OpenERP Server set up correctly? Signed in to the server as Administrator, open the file openerp-server.conf in \Program Files\OpenERP AllInOne and check its content. This file is generated during installation with information derived from the database. If you see something strange it is best to entirely reinstall the server from the demonstration installer rather than try to work out what is happening.
3. Is your PostgreSQL running? Signed in as administrator, select Stop Service from the menu Start → Programs → PostgreSQL. If after a couple of seconds, you read The PostgreSQL4OpenERP service has stopped then you can be reasonably sure that the database server was working. Restart PostgreSQL.

4. Is the database accessible? Still in the PostgreSQL menu, start the pgAdmin III application which you can use to explore the database. Double-click the PostgreSQL4OpenERP connection. You can find the password in the OpenERP server configuration file. If the database server is accessible you will be able to see some information about the empty database. If it is not, an error message will appear.

5. Are your client programs correctly installed? If your OpenERP GTK clients have not started, the swiftest approach is to reinstall them.

6. Can remote client computers see the server computer at all? Check this by opening a command prompt window (enter cmd in the window Start → Run...) and enter ping <address of server> there (where <address of server> represents the IP address of the server). The server should respond with a reply.

7. Have you changed any of the server’s parameters? At this point in the installation the port number of the server must be 8069 using the protocol XML-RPC.

8. Is there anything else in the server’s history that can help you identify the problem? Open the file openerp-server.log in C:\Program Files\OpenERP AllInOne\Server\openerp-server.log (which you can only do when the server is stopped) and scan through the history for ideas. If something looks strange there, contributors to the OpenERP forums can often help identify the reason.

6.2.2 Installation on Linux (Ubuntu)

This section guides you through installing the OpenERP server and client on Ubuntu, one of the most popular Linux distributions. It assumes that you are using a recent release of Desktop Ubuntu with its graphical user
interface on a desktop or laptop PC.

Note: Other Linux distributions
Installation on other distributions of Linux is fairly similar to installation on Ubuntu. Read this section of the book so that you understand the principles, then use the online documentation and the forums for your specific needs on another distribution.

For information about installation on other distributions, visit the documentation section by following Services → Documentation on http://www.openerp.com. Detailed instructions are given there for different distributions and releases, and you should also check if there are more up to date instructions for the Ubuntu distribution as well.

Technical procedure: Initial installation and configuration

Upgrade of Ubuntu packages and installation of OpenERP and pgadmin:

```bash
$ sudo apt-get update
$ sudo apt-get upgrade
$ sudo apt-get install openerp-server openerp-client pgadmin3
```

To avoid having some of the labels untranslated in the GTK client, install the language-pack-gnome-YOURLANG-base package. The following command installs the Spanish language pack:

```bash
$ sudo apt-get install language-pack-gnome-es-base
```

PostgreSQL version 8.4 has been used at the time of writing. You may have to replace the version number in the commands below with your own PostgreSQL version number if it differs. Postgres Database configuration:

```bash
$ sudo vi /etc/postgresql/8.4/main/pg_hba.conf
```

Replace the following line:

```
# “local” is for Unix domain socket connections only
local all all ident
```

with:

```
# “local” is for Unix domain socket connections only
local all all md5
```

Restart Postgres:

```bash
$ sudo /etc/init.d/postgresql-8.4 restart
```

* Restarting PostgreSQL 8.4 database server [ OK ]

The following two commands will avoid problems with /etc/init.d/openerp-web INIT script:

```bash
$ sudo mkdir /home/openerp
$ sudo chown openerp.nogroup /home/openerp
```

Create a user account called openerp with password “openerp” and with privileges to create Postgres databases:

```bash
$ sudo su postgres
$ createuser openerp -P
Enter password for new role: (openerp)
Enter it again:
Shall the new role be a superuser? (y/n) n
```
Shall the new role be allowed to create databases? (y/n) y
Shall the new role be allowed to create more new roles? (y/n) n

Quit from user postgres:
$ exit
exit

Edit OpenERP configuration file:
$ sudo vi /etc/openerp-server.conf

Replace the following two lines (we don’t force to use a specific database and we add the required password to gain access to postgres):

db_name =
db_user = openerp
db_password = openerp

We can now restart openerp-server:
$ sudo /etc/init.d/openerp-server restart

Restarting openerp-server: openerp-server.

Check out the logs:
$ sudo cat /var/log/openerp.log

[2009-06-14 21:06:09,315] INFO:objects:initialising distributed objects services
[2009-06-14 21:06:09,502] INFO:web-services:the server is running, waiting for connections...

OpenERP is now up and running, connected to Postgres database on port 5432 and listening on ports 8069 and 8070

$ ps uaxww | grep -i openerp
openerp 5686 0.0 1.2 84688 26584 pts/7 S1+ 12:36 0:03 /usr/bin/python ./openerp-server.py
$ sudo lsof -i :8069
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
python 5686 openerp 3u IPv4 116555 0t0 TCP *:8069 (LISTEN)
Start the OpenERP GTK client by clicking its icon in the Applications → Internet → OpenERP Client menu, or by opening a terminal window and typing openerp-client. The OpenERP login dialog box should open and show the message No database found you must create one!

Although this installation method is simple and therefore an attractive option, it is better to install OpenERP using a version downloaded from http://openerp.com. The downloaded revision is likely to be far more up to date than that available from a Linux distribution.

**Note:** Package versions

Maintaining packages is a process of development, testing and publication that takes time. The releases in OpenERP packages are therefore not always the latest available. Check the version number from the information on the website before installing a package. If only the third digit group differs (for example 6.0.1 instead of 6.0.2) then you may decide to install it because the differences may be minor – bug fixes rather than functionality changes between the package and the latest version.

**Manual installation of the OpenERP server**

In this section you will see how to install OpenERP by downloading it from the site http://openerp.com, and how to install the libraries and packages that OpenERP depends on, onto a desktop version of Ubuntu. Here is a summary of the procedure:

1. Navigate to the page http://openerp.com with your web browser,
2. Click the Download button on the right side,
3. Download the client and server files from the Sources section into your home directory (or some other location if you have defined a different download area).

To download the PostgreSQL database and all of the other dependencies for OpenERP from packages:

1. Start Synaptic Package Manager, and enter the root password as required.
2. Check that the repositories main, universe and restricted are enabled.
3. Search for a recent version of PostgreSQL (such as postgresql-8.4 then select it for installation along with its dependencies.
4. Select all of OpenERP’s dependences, an up-to-date list of which should be found in the installation documents on OpenERP’s website, then click Apply to install them.

**Note:** Python programming language

Python is the programming language that has been used to develop OpenERP. It is a dynamic, non-typed language that is object-oriented, procedural and functional. It comes with numerous libraries that provide interfaces to other languages and has the great advantage that it can be learnt in only a few days. It is the language of choice for large parts of NASA’s, Google’s and many other enterprises’ code. For more information on Python, explore http://www.python.org.

Once all these dependencies and the database are installed, install the server itself using the instructions on the website.

Open a terminal window to start the server with the command openerp-server, which should result in a series of log messages as the server starts up. If the server is correctly installed, the message [...] waiting for connections... should show within 30 seconds or so, which indicates that the server is waiting for a client to connect to it.
Manual installation of OpenERP GTK clients

To install an OpenERP GTK client, follow the steps outlined in the website installation document for your particular operating system.

Open a terminal window to start the client using the command `openerp-client`. When you start the client on the same Linux PC as the server you will find that the default connection parameters will just work without needing any change. The message **No database found, you must create one!** shows you that the connection to the server has been successful and you need to create a database on the server.

Creating the database

You can connect other GTK clients over the network to your Linux server. Before you leave your server, make sure you know its network address – either by its name (such as `mycomputer.mycompany.net`) or its IP address (such as `192.168.0.123`).

**Note:** Different networks
Communications between an OpenERP client and server are based on standard protocols. You can connect Windows clients to a Linux server, or vice versa, without problems. It is the same for Mac versions of OpenERP – you can connect Windows and Linux clients and servers to them.

To install an OpenERP client on a computer under Linux, repeat the procedure shown earlier in this section. You can connect different clients to the OpenERP server by modifying the connection parameters on each client. To do that, click the **Change** button in the connection dialog and set the following fields as needed:

- **Server**: name or IP address of the server over the network,
• *Port*: the port, whose default is 8069 or 8070.

• *Connection protocol*: XML-RPC or NET-RPC.

![Server](image)

*Figure 6.6: Dialog box for defining connection parameters to the server*

It is possible to connect the server to the client using a secure protocol to prevent other network users from listening in, but the installation described here is for direct unencrypted connection.

**If your Linux server is protected by a firewall you will have to provide access to port** 8069 or 8070 for users on other computers with OpenERP GTK clients.

**Installation of an OpenERP web server**

Just as you installed a GTK client on a Linux server, you can also install the OpenERP client-web server. You can install it from sources after installing its dependencies from packages as you did with the OpenERP server, but OpenERP has provided a simpler way to do this for the web client – using a system known as ez_setup.

Before proceeding, confirm that your OpenERP installation is functioning correctly with a GTK client. If it is not, you will need to go back now and fix it, because you need to be able to fully use it for the next stages.

To install client-web follow the up-to-date instructions in the installation document on the website.

<table>
<thead>
<tr>
<th>Note: Ez tool</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ez is the packaging system used by Python. It enables the installation of programs as required just like the packages used by a Linux distribution. The software is downloaded across the network and installed on your computer by ez_install. ez_setup is a small program that installs ez_install automatically.</td>
</tr>
</tbody>
</table>

The OpenERP Web server connects to the OpenERP server in the same way as an OpenERP client using the NET-RPC protocol. Its default setup corresponds to that of the OpenERP server you have just installed, so should connect directly at startup.

1. At the same console as you’ve just been using, go to the OpenERP web directory by typing `cd openerp-web-6.X`.

2. At a terminal window type `openerp-web` to start the OpenERP Web server.
You can verify the installation by opening a web browser on the server and navigating to http://localhost:8080 to connect to the OpenERP web version as shown in the figure **OpenERP web client at startup**. You can also test this from another computer connected to the same network if you know the name or IP address of the server over the network – your browser should be set to http://<server_address>:8080 for this.

**Verifying your Linux installation**

You have used default parameters so far during the installation of the various components. If you have had problems, or you just want to set this up differently, the following points provide some indicators about how you can set up your installation.

**Tip: psql and pgAdmin tools**

PSQL is a simple client, executed from the command line, that is delivered with PostgreSQL. It enables you to execute SQL commands on your OpenERP database.

If you prefer a graphical utility to manipulate your database directly you can install pgAdmin III (it is commonly installed automatically with PostgreSQL on a windowing system, but can also be found at http://www.pgadmin.org/).

1. The PostgreSQL database starts automatically and listens locally on port 5432 as standard: check this by entering `sudo netstat -anpt` at a terminal to see if port 5432 is visible there.

2. The database system has a default role of **postgres** accessible by running under the Linux postgres user: check this by entering `sudo su postgres -c psql` at a terminal to see the psql startup message – then type `\q` to quit the program.

3. If you try to start the OpenERP server from a terminal but get the message `socket.error: (98, 'Address already in use')` then you might be trying to start OpenERP while an instance of OpenERP is already running and using the sockets that you have defined (by default 8069 and 8070). If that is a surprise to you then you may be coming up against a previous installation of OpenERP or Tiny ERP, or something else using one or both of those ports.

   Type `sudo netstat -anpt` to discover what is running there, and record the PID. You can check that the PID corresponds to a program you can dispense with by typing `ps aux | grep <PID>` and you can then stop the program from running by typing `sudo kill <PID>`. You need additional measures to stop it from restarting when you restart the server.

4. The OpenERP server has a large number of configuration options. You can see what they are by starting the server with the argument `-help`. By default the server configuration is stored in the file `.terp_serverrc` in the user’s home directory (and for the postgres user that directory is /var/lib/postgresql).

5. You can delete the configuration file to be quite sure that the OpenERP server is starting with just the default options. It is quite common for an upgraded system to behave badly because a new version server cannot work with options from a previous version. When the server starts without a configuration file it will write a new one once there is something non-default to write to it – it will operate using defaults until then.
6. To verify that the system works, without becoming entangled in firewall problems, you can start the OpenERP client from a second terminal window on the server computer (which does not pass through the firewall). Connect using the XML-RPC protocol on port 8069 or NET-RPC on port 8070. The server can use both ports simultaneously. The window displays the log file when the client is started this way.

7. The client setup is stored in the file .terprc in the user’s home directory. Since a GTK client can be started by any user, each user would have their setup defined in a configuration file in their own home directory.

8. You can delete the configuration file to be quite sure that the OpenERP client is starting with just the default options. When the client starts without a configuration file it will write a new one for itself.

9. The web server uses the NET-RPC protocol. If a GTK client works but the web server does not, then the problem is either with the NET-RPC port or with the web server itself, and not with the OpenERP server.

**Hint: One server for several companies**
You can start several OpenERP application servers on one physical computer server by using different ports. If you have defined multiple database roles in PostgreSQL, each connected through an OpenERP instance to a different port, you can simultaneously serve many companies from one physical server at one time.

### 6.3 Database Creation

Use the technique outlined in this section to create a new database, openerp_ch01. This database will contain the demonstration data provided with OpenERP and a large proportion of the core OpenERP functionality. You will need to know your super administrator password for this – or you will have to find somebody who does have it to create this database.

**Note: The super-administrator password**
Anyone who knows the super-administrator password has complete access to the data on the server – able to read, change and delete any of the data in any of the databases there. After first installation, the password is admin. This is the hard-coded default, and is used if there is no accessible server configuration file. If your system has been set up so that the server configuration file can be written to by the server then you can change the password through the client. Or you could deliberately make the configuration file read-only so that there is no prospect of changing it from the client. Either way, a server systems administrator can change it if you forget it.

So if your system is set to allow it, you can change the superadmin password through the GTK client from the menu File → Databases → Administrator Password, or through the web client by logging out (click the Logout link), clicking Databases on the login screen, and then clicking the Password button on the Management screen. The location of the server configuration file is typically defined by starting the server with the --config command line option.

![Image](OpenERP.png)

**Figure 6.8: Changing the super-administrator password through the web client**

### 6.3.1 Creating the database

If you are using the GTK client, choose File → Databases → New database in the menu at the top left. Enter the super-administrator password, then the name of the new database you are creating.
If you are using the web client, click Databases on the login screen, then Create on the database management page. Enter the super-administrator password, and the name of the new database you are creating.

In both cases you will see a checkbox that determines whether you load demonstration data or not. The consequences of checking this box or not affect the whole use of this database.

In both cases you will also see that you can choose the Administrator password. This makes your database quite secure because you can ensure that it is unique from the outset. (In fact many people find it hard to resist admin as their password!)

6.3.2 Database openerp_ch01

Wait for the message showing that the database has been successfully created, along with the user accounts and passwords (admin/XXXX and demo/demo). Now that you have created this database you can extend it without having to know the super-administrator password.

Tip: User Access
The combination of username/password is specific to a single database. If you have administrative rights to a database you can modify all users. Alternatively you can install the users_ldap module, which manages the authentication of users in LDAP (the Lightweight Directory Access Protocol, a standard system), and connect it to several OpenERP databases. Using this, many databases can share the same user account details.

Note: Failure to create a database
How do you know if you have successfully created your new database? You are told if the database creation has been unsuccessful. If you have entered a database name using prohibited characters (or no name, or too short a name) you will be alerted by the dialog box Bad database name! explaining how to correct the error. If you have entered the wrong super-administrator password or a name already in use (some names can be reserved without your knowledge), you will be alerted by the dialog box Error during database creation!.

Since this is the first time you have connected to this database you will be asked a series of questions to define the database parameters. You may choose to Skip Configuration Wizards or Start Configuration. If you choose to configure your application, you may proceed with the following steps:

1. Configure Your Interface: select Simplified and click Next.
2. Configure Your Company Information: replace the proposed default of OpenERP S.A. by your own company name, complete as much of your address as you like. You can set the currency that your company uses or leave the default setting. You may also add your company logo which will be visible on reports and other documents. Click Next.
3. Install Applications: check the applications you need and then click Install. For now, do not install any application.
Once configuration is complete you are connected to your OpenERP system. Its functionality is very limited because you have selected a Simplified interface with no application installed, but this is sufficient to demonstrate that your installation is working.

![Company Configuration](image)

Figure 6.10: Defining your company during initial database configuration

### 6.3.3 Managing Databases

As a super-administrator you do not only have rights to create new databases, but also to:

- delete databases,
- backup databases,
- restore databases.

All of these operations can be carried out from the menu `File → Databases...` in the GTK client, or from the `Databases` button in the web client’s `Login` screen.

**Tip:** Duplicating a database

To duplicate a database you can:

1. make a backup file on your PC from this database.
2. restore this database from the backup file on your PC, giving it a new name as you do so.

This can be a useful way of making a test database from a production database. You can try out the operation of a new configuration, new modules, or just the import of new data.

A system administrator can configure OpenERP to restrict access to some of these database functions so that your security is enhanced in normal production use.

You are now ready to use databases from your installation to familiarize yourself with the administration and use of OpenERP.

### 6.4 New OpenERP functionality

The database you have created and managed so far is based on the core OpenERP functionality that you installed. The core system is installed in the file system of your OpenERP application server, but only installed into an OpenERP database as you require it, as is described in the next chapter, Guided Tour.

What if you want to update what is there, or extend what is there with additional modules?

- To update what you have, you would install a new instance of OpenERP using the same techniques as described earlier in this section, Database Creation.
• To extend what you have, you would install new modules in the `addons` directory of your current OpenERP installation. There are several ways of doing that.

In both cases you will need to be a root user or Administrator of your OpenERP application server.

6.4.1 Extending Open ERP

To extend OpenERP you will need to copy modules into the `addons` directory. That is in your server’s `openerp-server` directory (which differs between Windows, Mac and some of the various Linux distributions and not available at all in the Windows all-in-one installer). If you look there you will see existing modules such as `product` and `purchase`. A module can be provided in the form of files within a directory or a zip-format file containing that same directory structure.

You can add modules in two main ways – through the server, or through the client. To add new modules through the server is a conventional system administration task. As root user or another suitable user, you would put the module in the `addons` directory and change its permissions to match those of the other modules.

To add new modules through the client you must first change the permissions of the `addons` directory of the server, so that it is writeable by the server. That will enable you to install OpenERP modules using the OpenERP client (a task ultimately carried out on the application server by the server software).

**Tip: Changing permissions**

A very simple way of changing permissions on the Linux system you are using to develop an OpenERP application is to execute the command `sudo chmod 777 <path_to_addons>` (where `<path_to_addons>` is the full path to the `addons` directory, a location like `/usr/lib/python2.5/site-packages/openerp-server/addons`).

Any user of OpenERP who has access to the relevant administration menus can then upload any new functionality, so you would certainly disable this capability for production use. You will see examples of this uploading as you make your way through this book.
CHAPTER
SEVEN

GUIDED TOUR

Starting to discover OpenERP, using demonstration data supplied with the system, is a good way to familiarize yourself with the user interface. This guided tour provides you with an introduction to many of the available system features.

You would be forgiven a flicker of apprehension when you first sit at your computer to connect to OpenERP, since ERP systems are renowned for their complexity and for the time it takes to learn how to use them. These are, after all, Enterprise Resource Planning systems, capable of managing most elements of global enterprises, so they should be complicated, should not they? But even if this is often the case for proprietary software, OpenERP is a bit of an exception in the class of management software.

Even though OpenERP is a comprehensive software, the user interface and workflow management facilities are quite simple and intuitive to use. For this reason, OpenERP is one of the few software packages with reference customers in both very small businesses (typically requiring simplicity) and large accounts (typically requiring wide functional coverage).

A two-phase approach provides a good guide for your first steps with OpenERP:

1. Using a database containing demonstration data to get an overview of OpenERP’s functionality (described in this chapter, Guided Tour)
2. Setting up a clean database to configure and populate a limited system for yourself (described in the next chapter, How does it apply to your Business?).

To read this chapter effectively, make sure that you have access to an OpenERP server. The description in this chapter assumes that you are using the OpenERP web client unless it states otherwise. The general functionality differs little from one client to the other.

7.1 Database creation

Use the technique outlined in Installation and Initial Setup to create a new database, openerp_ch02. This database will contain the demonstration data provided with Open ERP and a large proportion of the core Open ERP functionality. You will need to know your super administrator password for this – or you will have to find somebody who does have it to create this seed database.

Start the database creation process from the Login page by clicking Databases and then completing the following fields on the Create Database form:

- **Super admin password**: by default it is admin, if you or your system administrator have not changed it,
- **New database name**: openerp_ch02,
- **Load Demonstration data checkbox**: checked,
- **Default Language**: English (US),
- **Administrator password**: admin (because it is easiest to remember at this stage, but obviously completely insecure),
- **Confirm password**: admin.
7.2 To connect to OpenERP

Since this is the first time you have connected to OpenERP you will be given the opportunity to configure the system. You may choose to either Skip Configuration Wizards or Start Configuration. We shall proceed with system configuration by clicking Start Configuration. Configuration consists of a set of wizards that help you through options for the installed modules. Hardly anything is installed so this is a very simple process at the moment.

1. Configure Your Interface : select Simplified and click Next.

2. At the Company Configuration step you should select your own Company Name and Currency. You may add your company address, contact and other details and a logo, if you have one, that appears on reports. Then, click Next.

3. The Install Applications section would enable you to add applications to your system. For now, click Skip to proceed without installing any applications. You are now connected to OpenERP and can start using the system as an Administrator.

Once you are displaying the main menu you are able to see the following screen items, as shown in screenshot The Main Menu of the openerp_ch02 database:

- the name of the database you are logged into and, just below it, the current user name,
- the ONLINE SUPPORT button, which gives you an overview of the support services provided by OpenERP which is available for subscription,
- the Preferences toolbar to the top right, showing the links to the HOME page, REQUESTS system, EDIT PREFERENCES page, ABOUT, HELP and LOGOUT button,
- just below you will find shortcuts (which the user can customize) and links to the menu items of installed applications,
- a collection of interesting and useful widgets are available on the right of the home page beside the main menu.

![Image](image-url)

Figure 7.1: The Main Menu of the openerp_ch02 database

Two menus are available at the moment:

- Sales
- Administration

7.2.1 Preferences toolbar

When you are connected to OpenERP the topmost toolbar indicates which user you are connected as. So it should currently be showing Administrator (unless you logged in as another user and it is reflecting the name of that user instead).

You will find the Preferences toolbar to its right containing a set of useful links. First, you will find a link to the HOME page. This takes you to either the Home page containing links to the available menus or to another window or dashboard, depending on the user configuration. In the case of the openerp_ch02 database, so far the Home page is the Main Menu. But in general each user of the system is presented with a dashboard that is designed to show performance indicators and urgent documents that are most useful to someone of the user’s position in the company. You will see how to assign dashboards to different users in a later chapter, Configuration & Administration.
Tip: Multi-nationals and time zones

If you have users in different countries, they can configure their own timezone. Timestamp displays are then adjusted by reference to the user's own localization setting.

So if you have a team in India and a team in England, the times will automatically be converted. If an Indian employee sets her working hours from 9 to 6 that will be converted and saved in the server's timezone. When the English users want to set up a meeting with an Indian user, the Indian user's available time will be converted to English time.

The REQUESTS link is found beside the HOME link. It is only visible if you are logged into a database. If your database is new it will show number of requests as 0. You can click on that link to look at requests that have been sent to you at any time.

The next element in the toolbar is a link to EDIT PREFERENCES. By clicking that link you get a dialog box where the current user can set his interface in the Current Activity tab; and in the Preferences tab, set his password, a timezone, a working language, e-mail and a signature:

- The Interface field in the Current Activity tab allows the user to switch between the Simplified and Extended interfaces.
- The Language field enables the user's working language to be changed. But first the system must be loaded with other languages for the user to be able to choose an alternative, which is described in the next subsection of this chapter. This is a mandatory field.
- The Timezone setting indicates the user's location to Open ERP. This can be different from that of the server. All of the dates in the system are converted to the user's timezone automatically.
- The Menu Tips checkbox gives the user the choice to have tips displayed on each menu action.
- The Change Password button gives users the opportunity to change their own password. It opens a new dialog box where users may change the password and must logout and login again after the change. You should take steps (perhaps written policies) to prevent users making these too trivial.
- The Email field is for storing the current user's default e-mail address.
- The Signature field gives the user a place for the signature attached to messages sent from within OpenERP.

The ABOUT link gives information about the development of the Open ERP software and various links to other information.

The HELP link directs the user to the online documentation of OpenERP where extensive help is available on a host of topics.

The LOGOUT link enables you to logout and return to the original login page. You can then login to another database, or to the same database as another user. This page also gives you access to the super-administrator functions for managing databases on this server.

Installing a new language

Each user of the system can work in his or her own language. More than twenty languages are currently available besides English. Users select their working language using the Preferences link. You can also assign a language to a partner (customer or supplier), in which case all the documents sent to that partner will be automatically translated into that language.

Attention: More information about languages

The base version of Open ERP is translated into the following languages: English, German, Chinese, Spanish, Italian, Hungarian, Dutch, Portuguese, Romanian, Swedish and Czech.

But other languages are also available: Arabic, Afghan, Austrian, Bulgarian, Indonesian, Finnish, Thai, Turkish and Vietnamese.

As administrator you can install a new main working language into the system.
1. Select Administration in the Menu Toolbar and click Translations → Load an Official Translation in the main menu window,

2. Select the language to install, French for example, and click Load,

3. The system will intimate you when the selected language has been successfully installed. Click Close to return to the menu.

To see the effects of this installation change the preferences of your user to change the working language (you may first need to ensure that you have explicitly selected English as your language, rather than keep the default, before you are given the French option). You may have to reload the page to see the effects. The main menu is immediately translated in the selected language. If you are using the GTK client you will first have to close the menu then open a new main menu to start seeing things in the new language.

**Note: Navigating the menu**

From this point in the book navigation from the main menu is written as a series of menu entries connected by the → character. Instead of seeing “Select Administration in the Menu toolbar then click Translations > Load an Official Translation” you will just get “use menu Administration → Translations → Load an Official Translation”.

**Requests as a mechanism for internal communication**

Requests are a powerful communication mechanism between users of the system. They are also used by Open ERP itself to send system messages to users.

They have distinct advantages over traditional emails:

- requests are linked to other Open ERP documents,
- an event’s history is attached to the request,
- you can monitor events effectively from the messages they have sent.

Open ERP uses this mechanism to inform users about certain system events. For example if there is a problem concerning the procurement of a product a request is sent by Open ERP to the production manager.

Send a request to get an understanding of its functionality:

1. Click on the REQUESTS link that should currently be showing number of requests as 0. This opens a window that lists all of your waiting requests.

2. Click New to create and send a new request.

3. Complete the subject of the request, such as How are things? then give a description of the enquiry in the field.

4. Click the Search button to the right of the To field in the Request tab and select Administrator in the window that opens (that is the user that you are already connected as).

5. You can then link this request to other system documents using the References field, which could, for example, be a partner or a quotation or a disputed invoice.

6. Click Send to send the request to the intended recipient – that is yourself in this case. Then click HOME to return to the original screen.
To check your requests:

1. Click on the **REQUESTS** link (which may now show the number of requests as 1) to open a list of your requests. The list of requests then opens and you can see the requests you have been sent there.

2. Click the **Edit** icon, represented by a pencil, at the left hand end of the request line. That opens the request in edit mode.

3. You can then click the **Reply** button and make your response in the **Description** field of the **Request** tab that appears in place of the original message.

4. Click **Send** to save your response and send it to the original sender.

**Note: Requests vs. Email**

The advantage of an Open ERP request compared with a set of emails about one thread of discussion is that a request contains all of the conversation in one place. You can easily monitor a whole discussion with the appropriate documents attached, and quickly review a list of incomplete discussions with the history within each request.

To look at the request history (the user needs to set the interface as **Extended** to use this feature), and close the request:

1. Click on the **History** tab in the **Request** form to see the original request and all of the responses. By clicking on each line you could get more information on each element.

2. Return to the first tab, **Request** and click **Close** to set it to **closed**. This then appears greyed out.

**Tip: Trigger Date**

*You can send a request with a future date. This request will not appear in the recipient’s waiting list until the indicated date. This mechanism is very useful for setting up alerts before an important event.*

### 7.2.2 Configuring Users

The database you created contains minimal functionality but can be extended to include all of the potential functionality available to Open ERP. About the only functions actually available in this minimal database are Customers and Currencies – and these only because the definition of your main company required this. And because you chose to include demonstration data, both Customers and Currencies were installed with some samples. Because you logged in as Administrator, you have all the access you need to configure users. Click **Administration → Users → Users** to display the list of users defined in the system. A second user, **Demo User**, is also present.
in the system as part of the demonstration data. Click the Demo User name to open a non-editable form on that user.

Click the Groups tab to see that the demo user is a member of only the Employee group, and is subject to no specialized rules. The user Administrator is different, as you can see if you follow the same sequence to review its definition. It is a member of the Administration / Configuration and the Administration / Access Rights groups, which gives it more advanced rights to configure new users.

**Tip: Groups and Users**

Users and groups provide the structure for specifying access rights to different documents. Their setup answers the question “Who has access to what?”

Click Administration → Users → Groups to open the list of groups defined in the system. If you open the form view of the Administration / Configuration group by clicking its name in the list, the first tab Users gives you the list of all the users who belong to this group.

You can also see in the Menus tab, the list of menus reserved for this group. By convention, the Administration / Configuration in Open ERp has rights of access to the Configuration menu in each section. So Sales / Configuration is found in the list of access rights but Sales is not found there because it is accessible to all users. Click the Access Rights tab and it gives you details of the access rights for that group. These are detailed later in Configuration & Administration.

You can create some new users to integrate them into the system. Assign them to predefined groups to grant them certain access rights. Then try their access rights when you login as these users. Management defines these access rights as described in Configuration & Administration.

**Note:** Changes to default access rights

New versions of OpenERP differ from earlier versions of OpenERP and Tiny ERP in this area: many groups have been predefined and access to many of the menus and objects are keyed to these groups by default. This is quite a contrast to the rather liberal approach in 4.2.2 and before, where access rights could be defined but were not activated by default.

### 7.2.3 Managing partners

In Open ERP, a partner represents an entity that you do business with. That can be a prospect, a customer, a supplier, or even an employee of your company.

**List of Partners**

Click Sales → Address Book → Customers in the main menu to open the list of partners who are customers. Then click the name of the first partner to get hold of the details – a form appears with information about the company, such as its corporate name, its primary language, its reference and whether it is a Customer and/or a Supplier. You will also find several other tabs on it:

- the General tab contains information about different contacts at that partner, postal information, communication information and the categories it belongs to.
- the Sales & Purchases tab contains information that is slightly less immediate.
- the History tab (visible if you install other modules like crm) contains the history of all the events that the partner has been involved in. These events are created automatically by different system documents: invoices, orders, support requests and so on, from a list that can be configured in the system. These give you a rapid view of the partner’s history on a single screen.
- the Notes tab is an area for free text notes.

To the right of the form is a list of Reports, Actions, Links and Attachments related to a partner. Click some of them to get a feel for their use.
Partner Categories enable you to segment different partners according to their relation with you (client, prospect, supplier, and so on). A partner can belong to several categories – for example it may be both a customer and supplier at the same time.

But there are also Customer and Supplier checkboxes on the partner form, which are different. These checkboxes are designed to enable OpenERP to quickly select what should appear on some of the system drop-down selection boxes. They, too, need to be set correctly.

Partner Categories

You can list your partners by category using the menu Sales → Configuration → Address Book → Partners Categories. Click a category to obtain a list of partners in that category.
Figure 7.4: Categories of partner

The administrator can define new categories. So you will create a new category and link it to a partner:

1. Use Sales → Configuration → Address Book → Partners Categories to reach the list of categories in a list view.

2. Click New to open an empty form for creating a new category

3. Enter My Prospects in the field Category Name. Then click on the Search icon to the right of the Parent Category field and select Prospect in the list that appears.

4. Then save your new category using the Save button.

You may add exiting partners to this new category using the Add button in the Partners section.

**Tip:** Required Fields

*Fields colored blue are required. If you try to save the form while any of these fields are empty the field turns red to indicate that there is a problem. It is impossible to save the form until you have completed every required field.*

You can review your new category structure using the list view. You should see the new structure of Prospects / My Prospects there.

Figure 7.5: Creating a new partner category
To create a new partner and link it to this new category open a new partner form to modify it.

1. Type **New Partner** into the **Name** field.

2. In the **General** tab, click the *Add* button under the **Categories** section and select your new category from the list that appears: **Prospect / My Prospects**.

3. Then save your partner by clicking **Save** The partner now belongs in the category **Prospect / My Prospects**.

4. Monitor your modification in the menu **Sales → Configuration → Address Book → Partners Categories.** Select the category **Prospect / My Prospects**. The list of partners opens and you will find your new partner there in that list.

---

**Tip:** **Searching for documents**

*If you need to search through a long list of partners it is best to use the available search criteria rather than scroll through the whole partner list. It is a habit that will save you a lot of time in the long run as you search for all kinds of documents.*

---

**Note:** **Example Categories of partners**

A partner can be assigned to several categories. These enable you to create alternative classifications as necessary, usually in a hierarchical form.

Here are some structures that are often used:

- geographical locations,
- interest in certain product lines,
- subscriptions to newsletters,
- type of industry.

---

### 7.3 Installing new functionality

All of Open ERP’s functionality is contained in its many and various modules. Many of these, the core modules, are automatically loaded during the initial installation of the system and can be updated online later. Although they are mostly not installed in your database at the outset, they are available on your computer for immediate installation. Additional modules can also be loaded online from the official Open ERP site [http://openerp.com](http://openerp.com). These modules are inactive when they are loaded into the system, and can then be installed in a separate step.

You will start by checking if there are any updates available online that apply to your initial installation. Then you will install a CRM module to complete your existing database.

---

#### 7.3.1 Updating the Modules list

Click **Administration → Modules → Update Modules List** to start the updating tool. The **Module Update** window opens notifying the user that Open ERP will look at the server side for adding new modules and updating existing ones.

Click **Update** to start the update on the server side. When it is complete you will see a **Module update result** section indicating how many new modules were added and how many existing modules were updated. Click **Open Modules** to return to the updated list.

---

**Note:** **Modules**

*All the modules available on your computer can be found in the addons directory of your Open ERP server. Each module there is represented by a directory carrying the name of the module or by a file with the module name and .zip appended to it. The file is in ZIP archive format and replicates the directory structure of unzipped modules.*
Tip: Searching through the whole list
The list of modules shows only the first available modules. In the web client you can search or follow the First / Previous / Next / Last links to get to any point in the whole list, and you can change the number of entries listed by clicking the row number indicators between Previous and Next and selecting a different number from the default of 20.
If you use the GTK client you can search, as you would with the web client, or use the selection field (currently showing 80) to the top right of the window to change the number of entries returned by the search from its default limit of 80, or its default offset of 0 (starting at the first entry) in the whole list.

7.3.2 The Configuration / Reconfigure wizard

One of the new features of OpenERP is the Configuration wizard. Once run, the Reconfigure shortcut will appear. This wizard provides an easy way to install modules thanks to its user-friendly and easy-to-use interface. The user may invoke this wizard at his own convenience using the shortcut Reconfigure, found just below the database and user name in the web-client or in the Shortcut menu in the GTK client. The same Configuration dialog box appears that you may have encountered at the time of installing a new database. Why did we call it the Reconfigure wizard? Indeed, because it allows the user to review installed applications and install related additional features or simply to install new applications on the fly.

When you go through the various steps in the wizard, you will come across some options that are checked and greyed. These are applications already installed. In the openerp_ch02 database configuration, you may see that the Customer Relationship Management option is already checked because this Business Application has been installed in this database. Install extra applications simply by checking the corresponding options and clicking Install or click Skip to stop the configuration. You will eventually also come across the CRM Application Configuration step which you may use to add features to your CRM application. For now, select the Claims option and click Configure. This will in turn install the crm_claim module.

![Reconfigure wizard showing Customer Relationship Management application as installed](image)

You may continue adding features this way, skip configuration steps or simply exit from this wizard. When you feel the need to load your system with additional features, you may invoke the Reconfigure wizard again at any point.

Note: You can also change the Configuration Wizard through the Administration → Configuration → Configuration Wizards → Configuration Wizards.
7.3.3 Installing an application / module from the Modules list

You will now install a module named google_map, which will enable you to add a feature to the partner form to open the location directly in Google Maps. This is part of the core installation, so you do not need to load anything to make this work.

Open the list of modules from Administration → Modules → Modules. Search for the module by entering the name google_map in the Name field on the search screen then clicking it in the list that appears to open it. The form that describes the module gives you useful information such as its version number, its status and a review of its functionality. Click Schedule for Installation and the status of the module changes to To be installed.

**Tip:** From now on you can schedule and install modules from list view too. Notice the buttons on the right side and the action button to install.

![Image of Installation of the Google Maps module](image)

**Figure 7.7: Installation of the Google Maps module**

**Tip:** Technical Guide

If you select a module in any of the module lists by clicking on a module line and then on Technical Guide at the top right of the window, OpenERP produces a technical report on that module. It is helpful only if the module is installed.

This report comprises a list of all the objects and all the fields along with their descriptions. The report adapts to your system and reflects any modifications you have made and all the other modules you have installed.

Then, either use the menu Administration → Modules → Apply Scheduled Upgrades, or from the Actions section click Apply Scheduled Upgrades, then Start update on the Module Upgrade form that appears. Close the window when the operation has completed. Return to the Sales menu; you will see the new menu Products has become available.

**Tip:** Refreshing the menu in the GTK client

After an update in the GTK client you will have to open a new menu to refresh the content – otherwise you will not see the new menu item. To do that use the window menu Form → Reload / Undo or use the shortcut Ctrl+R.

7.3.4 Installing a module with its dependencies

Now install the Warehouse Management module using the same process as before. Start from Administration → Modules → Modules.

1. Get the list of modules, and search for the stock module in that list.
2. Schedule the module for installation by clicking Schedule for Installation.
3. Do the same for account.
4. Click Apply Scheduled Upgrades on the action toolbar to the right.
5. Click Start update to install both modules.
6. After a few seconds, when the installation is complete, you may close this dialog box.
7. You will see details of all the features installed by the modules on a new Features tab on the module form.
When you return to the Warehouse menu you will find the new menu items under it like Warehouse → Warehouse Management → Incoming Shipments, Warehouse → Products Moves, which are a part of the Warehouse management system. You will also see all the accounting functions that are now available in the Accounting menu.

There is no particular relationship between the modules installed and the menus added. Most of the core modules add complete menus but some also add submenus to menus already in the system. Other modules add menus and submenus as they need. Modules can also add additional fields to existing forms, or simply additional demonstration data or some settings specific to a given requirement.

**Note: Dependencies between modules**

The module form shows two tabs before it is installed. The first tab gives basic information about the module and the second gives a list of modules that this module depends on. So when you install a module, OpenERP automatically selects all the necessary dependencies to install this module.

That is also how you develop the profile modules: they simply define a list of modules that you want in your profile as a set of dependencies.

Although you can install a module and all its dependencies at once, you cannot remove them in one fell swoop – you would have to uninstall module by module. Uninstalling is more complex than installing because you have to handle existing system data.

**Note: Uninstalling modules**

Although it works quite well, uninstalling modules is not perfect in OpenERP. It is not guaranteed to return the system exactly to the state it was in before installation.

So it is recommended that you make a backup of the database before installing your new modules so that you can test the new modules and decide whether they are suitable or not. If they are not then you can return to your backup. If they are, then you will probably still reinstall the modules on your backup so that you do not have to delete all your test data.

If you wanted to uninstall you would use the menu Administration → Modules → Modules and then uninstall them in the inverse order of their dependencies: stock, account.

### 7.3.5 Installing additional functionality

To discover the full range of OpenERP’s possibilities you can install many additional modules. Installing them with their demonstration data provides a convenient way of exploring the whole core system. When you build on the openerp_ch02 database you will automatically include demonstration data because you checked the Load Demonstration Data checkbox when you originally created the database. Click Administration → Modules → Modules to give you an overview of all of the modules available for installation.

To test several modules you will not have to install them all one by one. You can use the dependencies between modules to load several at once.

### 7.4 What’s new in OpenERP

#### 7.4.1 General Features

- OpenERP has been structured as Business Applications and its menu has been changed to match this,
- Great Improvements as to Usability, not in the least in the Web version,
- Simplified versus Extended view,
- When you search for a record, e.g. a customer / supplier, the web version will propose to create the new partner when no existing partner is found,
- When you click a Business Application in the Web version, the related Dashboard will be opened,
- To display the process view, click the Question Mark next to the title in the web version,
- Menutips & Tooltips will be displayed to explain more about the active screen,
• Dynamic Filters which allow you to easily create and save your own filters, with Group by options, Extended filters, and much more,

• User Roles are no longer used, they have been integrated in the User Groups,

• The Administrator will now only have the rights according to the user groups that have been assigned to him,

• Multicompany has been integrated in the core of OpenERP and does not require the installation of modules. You just have to add the User Group Useability / Multi-Company,

• Perform actions, such as update status, confirm, delete, ... directly from List View,

• Use communication tools such as Fetchmail, Outlook & Thunderbird integration and CalDAV / WebDAV (also available on Android & Iphone),

• Create your own e-mail templates for use throughout OpenERP,

• Use the Scheduler for other objects than Manufacturing,

• Click the star in the web version to quickly create a shortcut for a screen you often use,

• When you perform an action in List view in the web version, (i.e. change the status of a lead), OpenERP will display a bar containing information about this change. You can click the link to open the lead concerned.

7.4.2 Business Application-related Features

Sales Management

• CRM has been integrated in the Sales Management Business Application,

• Geolocalization module, also allowing you to send qualified opportunities directly to external partners,

• Manage your Marketing Campaigns and send automated e-mails based on your own templates,

• For Leads, OpenERP will check the email address of the contact and when found for an existing partner, it will propose to merge the new contact with the corresponding partner,

• Create your company wiki for Sales FAQ,

• History tab in the Customer form to keep track of all events,

Warehouse Management

• Push & Pull rules for stock locations have been extended and integrated with multicompany,

• Configure units of measure by reference unit, bigger then / smaller then reference unit,

• Update stock level from the Product form and automatically create a physical inventory for it.

Accounting & Financial Management

• By default, only one Entry Sequence available for a journal. If you want to have two sequences to be used for your journal numbering, please install the account_sequence module,

• Separate numbering now also available for Bank Journals,

• Quickly enter Journal Entries from List View from the Journal Items menu. Configure your journal with default debit & credit accounts, select the journal in the Journal Items List View, click New and start creating new entries,

• Chart of Accounts and Chart of Taxes can be displayed for a selected period,

• OpenERP added a flexible, easy Invoicing module allowing you to keep track of your accounting, even when you are not an accountant. If you install the Invoicing module, in Simplified view, you will only have the Invoicing items. You shouldn’t use both Invoicing and Accounting,

• Use the Financial Management Configuration Wizard to easily select features you want to use.
• On installation of a predefined Chart of Accounts, the wizard also proposes default bank and cash accounts, and default Sales and Purchase taxes,

• On a journal you can set whether OpenERP should perform a check whether the invoice date is in the current period. This used to be a separate module,

• Different journal types for Refunds and Invoices,

• When creating a new journal, parameters are preset according to the journal type. The Entry Sequence for the journal is automatically created on Save,

• Cash Box, possible to keep a real cash register.

Project Management

• Improved Gantt chart in the Web version,

• Long Term Planning that can be calculated according to the working time of each employee involved in the project with the new Scheduler feature,

• On creation of a new project, OpenERP automatically creates the corresponding Analytic Account in the Projects chart of accounts. You no longer have access to the analytic account from the Project.

Manufacturing Management

• Scrap consumed or finished goods and have the related stock moves automatically,

• Consume products partially or completely.

Human Resources Management

• Manage your evaluation process,

• Keep track of your recruitments and receive applicant mails directly in OpenERP, including attachments.

7.5 Getting started with OpenERP

You will now explore the database openerp_ch02 with these profile modules installed to give you an insight into the coverage of the core Open ERP software.

Tip: Translating new modules

When you have installed a new module and are using additional languages to English you have to reload the translation file. New terms introduced in these modules are not translated by default. To do this use Administration → Translations → Load an Official Translation.

Depending on the user you are connected as the page appears differently. Using the installation sequence above, certain dashboards may be assigned as various users’ home pages. They show a summary of the information required to start the day effectively. A project dashboard might contain:

• a list of the tasks to carry out,

• a list of the tasks which is assigned to current user,

• a list of sprints,

• a list of issues assigned to current user,

• a graph of Planned vs Total hours,

• a graph of Remaining hours by Project,

• a graph of Open Issues by Creation Date.

Each of the lists can be reordered simply by clicking the heading of a column – first in ascending then in descending order as you click repeatedly. To get more information about any particular entry click on the name in the first column, or if you want to show a particular panel click Zoom above it.
A user’s home page is automatically reassigned during the creation or upgrading of a database. It is custom to assign a dashboard to someone’s home page but any OpenERP screen can be assigned to the home page of any user.

**Tip: Creating shortcuts**

Each user has access to many menu items from the menu. But in general an employee uses only a small part of the system’s functions. So you can define shortcuts for the most-used menus. These shortcuts are personal for each user. To create a new shortcut just click the ‘*’ of the header of the view in web client. To remove a shortcut just click the link and again click ‘*’ of the header of the view.

The following sections present an overview of the main functions of OpenERP. Some areas are covered in more detail in the following chapters of this book and you will find many other functions available in the optional modules. Functions are presented in the order that they appear on the main menu.

### 7.5.1 Basic Concepts

#### Partners & Contacts

To get familiar with the OpenERP user interface, you will start working with information about partners. Clicking **Sales → Address Book → Customers** brings up a list of partners that were automatically loaded when you created the database with **Load Demonstration Data** checked.

#### Search for a partner

Above the partner list you will see a search form that enables you to quickly filter the partners.

The **Customers** filter is enabled by default showing partners who are customers. If you have applied no filter, the list shows every partner in the system. For space reasons this list shows only the first few partners. If you want to display other records you can search for them or navigate through the whole list using the **First, Previous, Next, Last** arrows.
Note: List limits
By default the list in the GTK client shows only the first 80 records, to avoid overloading the network and the server.
But you can change that limit by clicking the selection widget (showing 80 by default) to the right of the search criteria.
Similarly the list in the web client shows only the first 20, 50, 100, 500 or unlimited records.
The actual number can be switched by clicking the link between the PREVIOUS and NEXT buttons and selecting one of the other limits.

In the web version, if you click the name of a partner, the form view corresponding to that partner opens in Read-Only mode. In the list you could alternatively click the pencil icon to open the same form in Edit mode. Once you have a form you can toggle between the two modes by clicking Save or Cancel when in Edit mode and Edit when in Read-Only mode.

Partner form

The partner form contains several tabs, all referring to the current record:

- General,
- Sales & Purchases,
- Accounting,
- History,
- Notes.

The fields in a tab are not all of the same type – some (such as Name) contain free text, some (such as the Language) enable you to select a value from a list of options, others give you a view of another object (such as Partner Contacts – because a partner can have several contacts) or a list of links to another object (such as Partner Categories). There are checkboxes (such as the Active field in the Sales & Purchases tab), numeric fields (such as Credit Limit in the Accounting tab) and date fields (such as Date).
The History tab gives a quick overview of partner activities – an overview of useful information such as Leads and Opportunities, Meetings, Phone Calls, Emails and Tasks. Events are generated automatically by OpenERP from changes in other documents that refer to this partner.

It is possible to add events manually which directly relate to the corresponding form, such as a note recording a phone call. To add a new event click New in the Phone Calls section. That opens a new Phone Call pop-up form enabling a phone-call event to be created and added to the current partner.

Possible Partner Actions

To the right of the partner form is a toolbar containing a list of possible Reports, Actions and quick Links about the partner displayed in the form.

You can generate PDF documents for the selected object (or, in list view, about one or more selected objects) using certain buttons in the Reports section of the toolbar:

- **Labels**: print address labels for the selected partners,
- **Overdue Payments**: print a letter to notify the selected partners of overdue payments,

Certain actions can be started by the following buttons in the Actions section of the toolbar:

- **SMS Send**: enables you to send an SMS to selected partners. This system uses the bulk SMS facilities of the Clickatell® company http://clickatell.com,
- **Mass Mailing**: enables you to send an email to a selection of partners,
- **Create Opportunity**: opens a window to create an opportunity for the partner.

Tip: Reports, Actions and Links in the GTK client

When you are viewing a form in the GTK client, the buttons to the right of the form are shortcuts to the same Reports, Actions and Links as described in the text. When you are viewing a list (such as the partner list) those buttons are not available to you. Instead, you can reach Reports and Actions through two of the buttons in the toolbar at the top of the list – Print and Action.

Partners are used throughout the OpenERP system in other documents. For example, the menu Sales → Sales Orders brings up all the Sales Orders in list view. Open an order in form view and click the name of a partner, even when the form is read-only. The Partner form will open.

Tip: Right-clicks and shortcuts

In the GTK client you do not get hyperlinks to other document types. Instead, you can right-click in a list view to show the linked fields (that is fields having a link to other forms) on that line.

In the web client you will see hyperlink shortcuts on several of the fields on a form in Read-Only mode, allowing you to be taken directly to the corresponding form. When the web form is in Edit mode, you can instead right-click the mouse button in the field, to get all of the linked fields in a pop-up menu just as you would with the GTK client.

You can quickly give this a try by going to any one of the sales orders in Sales → Sales Orders. See where you can go from the Customer field using either the web client with the form in both read-only and in edit mode, or with the GTK client.
Before moving on to the next topic, take a quick look at the Sales → Configuration → Address Book menu, particularly Partner Categories and Localisation menus. They contain some of the demonstration data that you installed when you created the database.

**Products**

In OpenERP, *product* is used to define a raw material, a stockable product, a consumable or a service. You can work with whole products or with templates that separate the definition of products and variants (*extra module*).

For example if you sell t-shirts in different sizes and colors:

- the product template is the “T-shirt” which contains information common to all sizes and all colors,
- the variants are “Size:S” and “Color:Red”, which define the parameters for that size and color,
- the final product is thus the combination of the two – t-shirt in size S and color Red.

The value of this approach for some sectors is that you can just define a template in detail and all of its available variants briefly rather than every item as an entire product.

**Note:** Example Product templates and variants

A product can be defined as a whole or as a product template and several variants. The variants can be in one or several dimensions, depending on the installed modules.

For example, if you work in textiles, the variants on the product template for “T-shirt” are:

- Size (S, M, L, XL, XXL),
- Colour (white, grey, black, red),
- Quality of Cloth (125g/m2, 150g/m2, 160g/m2, 180g/m2),
- Collar (V, Round).

This separation of variant types requires the optional module *product_variant_multi*. Using it means that you can avoid an explosion in the number of products to manage in the database. If you take the example above it is easier to manage a template with 15 variants in four different types than 160 completely different products. This module is available in *extra-addons*.

The Sales → Products menu gives you access to the definition of products and their templates and variants.

**Tip:** Consumables

*In OpenERP a consumable is a physical product which is treated like a stockable product, with the exception that stock management is not taken into account by the system. You could buy it, deliver it or produce it but OpenERP will always assume that there is enough of it in stock. It never triggers a procurement exception.*
Open a product form to see the information that describes it. The demonstration data show several types of products, which gives quite a good overview of the options.

Price lists (Sales → Configuration → Pricelists) determine the purchase and selling prices and adjustments derived from the use of different currencies. The Default Purchase Pricelist uses the product’s Cost Price field for the Purchase price to be calculated. The Public Pricelist uses the product’s Sale Price field to calculate the Sales price in quotations.

Price lists are extremely flexible and enable you to put a complete price management policy in place. They are composed of simple rules that enable you to build up a rule set for most complex situations: multiple discounts, selling prices based on purchase prices, price reductions, promotions on product ranges and so on.

You can find many optional modules to extend product functionality, such as:

- membership: for managing the subscriptions of members of a company,
- product電子: for managing electronic products,
- product_extended: for managing production costs,
- product_expiry: for agro-food products where items must be retired after a certain period,
- product_lot_foundry: for managing forged metal products.

All of the above modules are found in extra-addons, except for the membership and the product_expiry module.

### 7.5.2 Boost your Sales

OpenERP provides many tools for managing relationships with partners. These are available through the Sales menu.

**Tip:** CRM & SRM

CRM stands for Customer Relationship Management, a standard term for systems that manage client and customer relations. SRM stands for Supplier Relationship Management, and is commonly used for functions that manage your communications with your suppliers.

Through Customer Relationship Management, OpenERP allows you to keep track of:

- Leads
- Opportunities
- Meetings
- Phone Calls
- Claims
- Helpdesk and Support
- Fund Raising

OpenERP ensures that each case is handled effectively by the system’s users, customers and suppliers. It can automatically reassign a case, track it for the new owner, send reminders by email and raise other OpenERP documentation and processes.

All operations are archived, and an email gateway lets you update a case automatically from emails sent and received. A system of rules enables you to set up actions that can automatically improve your process quality by ensuring that open cases never escape attention.

As well as those functions, you have got tools to improve the productivity of all staff in their daily work:

- an email client plugin for Outlook and Thunderbird enabling you to automatically store your emails and their attachments in the Knowledge Management (previously Document Management System) integrated with OpenERP,
- interfaces to synchronize your Contacts and Calendars with OpenERP,
• sync your meetings on your mobile phone,
• build a 360° view on your Customer,
• integration with Google applications.

You can implement a continuous improvement policy for all of your services, by using some of the statistical tools in OpenERP to analyze the different communications with your partners. With these, you can execute a real improvement policy to manage your service quality.

The management of customer relationships is detailed in the second section of this book (see Boost your Sales & Deliver Great Services).

7.5.3 Manage your Books

The chapters in Manage your Books in this book are dedicated to general and analytic accounting. A brief overview of the functions to introduce you to this Business Application.

Accounting is totally integrated into all of the company’s functions, whether it is general, analytic, budgetary or auxiliary accounting. OpenERP’s accounting function is double-entry and supports multiple company divisions and multiple companies, as well as multiple currencies and languages.

Accounting that is integrated throughout all of the company’s processes greatly simplifies the work of entering accounting data, because most of the entries are generated automatically while other documents are being processed. You can avoid entering data twice in OpenERP, which is commonly a source of errors and delays.

So OpenERP’s accounting is not just for financial reporting – it is also the anchorpoint for many of a company’s management processes. For example if one of your accountants puts a customer on credit hold then that will immediately block any other action related to that company’s credit (such as sales or delivery).

OpenERP also provides integrated analytical accounting, which enables management by business activity or project and provides very detailed levels of analysis. You can control your operations based on business management needs, rather than on the charts of accounts that generally meet only statutory requirements.

OpenERP added a flexible, easy Invoicing module allowing you to keep track of your documents and payments, even when you are not an accountant. This will allow smaller business to keep track of their payments without having to implement a complete accounting system.

Keep track of your Cash Moves by using the new OpenERP Cash Box.

7.5.4 Lead & Inspire your People

OpenERP’s Human Resources Management Business Application provides functionality such as:

• Manage your Employees, Contracts & Staff Performance,
• Talent Acquisition,
• Keep track of Holidays and Sickness Leaves,
• Manage the Evaluation Process,
• Keep track of Attendances & Timesheets,
• Track Expenses.

Most of these functions are provided from optional modules whose name starts with hr_ rather than the core hr module, but they are all loaded into the main Human Resources menu.

The different issues are handled in detail in the fourth part of this book Effective Management of Operations, dedicated to internal organization and to the management of a services business.
7.5.5 Drive your Projects

OpenERP’s project management tools enable you to define tasks and specify requirements for those tasks, efficient allocation of resources to the requirements, project planning, scheduling and automatic communication with partners.

All projects are hierarchically structured. You can review all of the projects from the menu Project → Projects. Then select Gantt view to obtain a graphical representation of the project.

![Figure 7.11: Project Planning](image)

You can run projects related to Services or Support, Production or Development – it is a universal module for all enterprise needs.

Project management is described in Drive your Projects.

7.5.6 Driving your Sales

The Sales menu gives you roughly the same functionality as the Purchases menu – the ability to create new orders and to review the existing orders in their various states – but there are important differences in the workflows.

Confirmation of an order triggers the delivery of goods, and invoicing timing is defined by a setting in each individual order.

Delivery charges can be managed using a grid of tariffs for different carriers.

7.5.7 Driving your Purchases

Purchases enables you to track your suppliers’ price quotations and convert them into Purchase Orders as you require. OpenERP has several methods of monitoring invoices and tracking the receipt of ordered goods.

You can handle partial deliveries in OpenERP, so you can keep track of items that are still to be delivered on your orders, and you can issue reminders automatically.

OpenERP’s replenishment management rules enable the system to generate draft purchase orders automatically, or you can configure it to run a lean process, driven entirely by current production needs.

You can also manage purchase requisitions to keep track of quotations sent to a multitude of suppliers.

7.5.8 Organise your Warehouse

The various sub-menus under Warehouse together provide operations you need to manage stock. You can:

- define your warehouses and structure them around locations you choose,
- manage inventory rotation and stock levels,
- execute packing orders generated by the system,
• execute deliveries with delivery notes and calculate delivery charges,
• manage lots and serial numbers for traceability,
• calculate theoretical stock levels and automate stock valuation,
• create rules for automatic stock replenishment.

Packing orders and deliveries are usually defined automatically by calculating requirements based on sales. Stores staff use picking lists generated by OpenERP, produced automatically in order of priority.

Stock management is, like accounting, double-entry. So stocks do not appear and vanish magically within a warehouse, they just get moved from place to place. And, just like accounting, such a double-entry system gives you big advantages when you come to audit stock because each missing item has a counterpart somewhere.

Most stock management software is limited to generating lists of products in warehouses. Because of its double-entry system OpenERP automatically manages customer and suppliers stocks as well, which has many advantages: complete traceability from supplier to customer, management of consigned stock, and analysis of counterpart stock moves.

Furthermore, just like accounts, stock locations are hierarchical, so you can carry out analyses at various levels of detail.

### 7.5.9 Get Manufacturing done

OpenERP’s production management capabilities enable companies to plan, automate and track manufacturing and product assembly. OpenERP supports multi-level bills of materials and lets you substitute subassemblies dynamically, at the time of sales ordering. You can create virtual subassemblies for re-use on several products with phantom bills of materials.

**Note:** BOMs, routing, workcenters

These documents describe the materials that make up a larger assembly. They are commonly called Bills of Materials or BOMs. They are linked to routings which list the operations needed to carry out the manufacturing or assembly of the product. Each operation is carried out at a workcenter, which can be a machine or a person.

Production orders based on your company’s requirements are scheduled automatically by the system, but you can also run the schedulers manually whenever you want. Orders are worked out by calculating the requirements from sales, through bills of materials, taking current inventory into account. The production schedule is also generated from the various lead times defined throughout the system, using the same route.

The demonstration data contain a list of products and raw materials with various classifications and ranges. You can test the system using this data.

### 7.5.10 Share your Knowledge through Efficient Document Management and Being Mobile

OpenERP integrates a complete document management system that not only carries out the functions of a standard DMS, but also integrates with all of its system-generated documents such as Invoices and Quotations. Moreover, it it keeps all of this synchronized. You can define your own directory structure and tell OpenERP to automatically store documents such as Invoices in the DMS.

OpenERP provides an FTP Interface for the Document Management System. You will not only be able to access documents from OpenERP, but you can also use a regular file system with the FTP client. FTP is just a way of getting access to files without needing to use an OpenERP client, to allow you to access files from anywhere. You can also add documents to be stored in OpenERP directly through the FTP system in the corresponding OpenERP directory. These documents will automatically be accessible from the form concerned in OpenERP.

The Knowledge system is also well-integrated with e-mail clients such as Thunderbird and Outlook. It also allows you to sync your calendars (CalDAV).
7.5.11 Measure your Business Performance

To measure your business performance OpenERP provides two interesting features:

- Dashboards
- Statistical Reports

On a single page, Dashboards give you an overview of all the information that is important to you. In OpenERP each application has its own dashboard which opens by default when you select the specific application. As for example Administration Dashboard will open when you click the Administration menu.

**Note:** Dashboards

Unlike most other ERP systems and classic statistically-based systems, OpenERP can provide dashboards for all system users, and not just managers and accountants.

Each user can have his own dashboard, adapted to his needs, enabling him to manage his own work effectively. For example a developer using the Project Dashboard can see information such as a list of open tasks, tasks delegated to him and an analysis of the progress of the relevant projects.

Dashboards are dynamic, letting you navigate easily around the whole information base. Using the icons above a graph, for example, you can filter the data or zoom into the graph. You can click any element of the list to get detailed statistics on the selected element.

Dashboards can be customized to fit the needs of each user and each company.

**Note:** Creating or customizing dashboards

OpenERP contains a Dashboard Editor. Create your own dashboard to fit your specific needs in only a few clicks. Go to the Administration → Customization → Reporting → Dashboard Definition menu to define your own dashboard.

The **Statistical Analysis** is one of the crucial thing for decision making process in any business. The OpenERP provides Statistical Reports for each application. As for example you can access the statistical analysis of Sales-related information from the menu Sales → Reporting → Sales Analysis. You can search and group the data using this Statistical Report.

7.5.12 Track your Process Flows

Many documents have a workflow of their own, and also take part in cross-functional processes. Take a document that could be expected to have a workflow, such as a Sales Order, and then click the ? button above its form to see the full process.

![Figure 7.12: Process for a Sales Order](image)

You can see where a particular document is in its process, if you have selected a single document, by the solid bar on one of the process nodes. You also link to documents and menus for each of the stages.

There is a clear distinction between a cross-functional process (that is currently only shown in the web client) and the detailed document workflow (that is shown in both the web client from a process node, and the GTK client from the Plugins > Execute a Plugin... menu and clicking either the Print Workflow or the Print Workflow (Complex) option.)
Alongside the document management system, the process visualization features make OpenERP far better for documentation than similar systems.

7.5.13 Need more?

You have been guided through a brisk, brief overview of many of the main functional areas of OpenERP. Some of these – a large proportion of the core modules – are treated in more detail in the following chapters.

You can use the menu Administration → Modules → Modules to find the remaining modules that have been loaded into your installation but not yet installed in your database. Some modules have only minor side-effects to OpenERP (such as google_maps), some have quite extensive effects (such as the various charts of accounts), and some make fundamental additions.

But there are now more than hundred modules available. You can install them according to your needs.

A brief description is available for each module, but the most thorough way of understanding their functionality is to install one and try it. So, pausing only to prepare another test database to try it out on, just download and install the modules that appear interesting.

7.5.14 Tips & Tricks

Overview of Shortcut Keys

- Shortcuts for OpenERP

<table>
<thead>
<tr>
<th>Shortcut Key</th>
<th>What does it do?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+H</td>
<td>Contextual Help</td>
</tr>
<tr>
<td>Ctrl+O</td>
<td>Connect</td>
</tr>
<tr>
<td>Ctrl+Q</td>
<td>Quit</td>
</tr>
</tbody>
</table>

- Shortcuts for OpenERP Form

<table>
<thead>
<tr>
<th>Shortcut Key</th>
<th>What does it do?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+D</td>
<td>Delete</td>
</tr>
<tr>
<td>Ctrl+F</td>
<td>Find</td>
</tr>
<tr>
<td>Ctrl+G</td>
<td>Go To Resource ID</td>
</tr>
<tr>
<td>Ctrl+L</td>
<td>Switch to List/Form</td>
</tr>
<tr>
<td>Ctrl+N</td>
<td>New</td>
</tr>
<tr>
<td>Ctrl+P</td>
<td>Preview in PDF</td>
</tr>
<tr>
<td>Ctrl+Page Down</td>
<td>Next Tab</td>
</tr>
<tr>
<td>Ctrl+Page Up</td>
<td>Previous Tab</td>
</tr>
<tr>
<td>Ctrl+R</td>
<td>Reload/Undo</td>
</tr>
<tr>
<td>Ctrl+S</td>
<td>Save</td>
</tr>
<tr>
<td>Ctrl+T</td>
<td>Menu</td>
</tr>
<tr>
<td>Ctrl+W</td>
<td>Close Tab</td>
</tr>
<tr>
<td>Page Down</td>
<td>Next</td>
</tr>
<tr>
<td>Page Up</td>
<td>Previous</td>
</tr>
<tr>
<td>Shift+Ctrl+D</td>
<td>Duplicate</td>
</tr>
<tr>
<td>Shift+Ctrl+H</td>
<td>New Home Tab</td>
</tr>
<tr>
<td>Shift+Ctrl+Y</td>
<td>Repeat latest action</td>
</tr>
</tbody>
</table>
Shortcuts for OpenERP when editing a resource in a popup window

<table>
<thead>
<tr>
<th>Shortcut Key</th>
<th>What does it do?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+Enter</td>
<td>Save and Close window</td>
</tr>
<tr>
<td>Ctrl+Esc</td>
<td>Close window without Saving</td>
</tr>
</tbody>
</table>

Shortcuts in relation field

<table>
<thead>
<tr>
<th>Shortcut Key</th>
<th>What does it do?</th>
</tr>
</thead>
<tbody>
<tr>
<td>F1</td>
<td>Add new Field/Line on the fly</td>
</tr>
<tr>
<td>F2</td>
<td>Look up information</td>
</tr>
<tr>
<td>F3</td>
<td>Zoom on current field</td>
</tr>
</tbody>
</table>

Shortcuts in text entries

<table>
<thead>
<tr>
<th>Shortcut Key</th>
<th>What does it do?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+C</td>
<td>Copy selected text</td>
</tr>
<tr>
<td>Ctrl+V</td>
<td>Paste selected text</td>
</tr>
<tr>
<td>Ctrl+X</td>
<td>Cut selected text</td>
</tr>
<tr>
<td>Enter</td>
<td>Auto-complete text field</td>
</tr>
<tr>
<td>Shift+Tab</td>
<td>Previous editable widget</td>
</tr>
<tr>
<td>Tab</td>
<td>Next editable widget</td>
</tr>
</tbody>
</table>

Filters

The Advanced Search View is a new feature of OpenERP v6 which provides a very user-friendly filtering mechanism for the end user to easily look up desired records from the list.

The perfect example of an advanced search view is the Statistical Report of OpenERP. Such a report shows the statistical summary with filtered results to the end user.

Usually an Advanced Search is composed of three elements, the Filter buttons at the top, the Extended Filters, and the Group by option. These filters are dynamic, so according to filters you apply, extra columns may be added to the view.

You can also easily combine filters; an arrow will be displayed and you will get a structure according to the order in which you clicked the Filter buttons.

Let’s show an example. The statistical report for project tasks is Task Analysis which can be displayed using the menu Project → Reporting → Tasks Analysis when you have installed the Project Management module.

![Task Analysis](image.png)

Figure 7.14: Task Analysis

You can see the Advanced Search View in the light green shaded area.

You can filter the information of a task according to the Group by features.

Click for instance the Stage button in Group by, and then click Task to analyse your tasks by stage and then by task.

This Advanced Search View can also be attached to any List View of an object and hence increase the search facility when a user looks up the record in list view.
Figure 7.15: Search the Tasks which are ‘In Progress’ with Group by Project and State
Now that you have discovered some of the many possibilities of Open ERP from a tour of the demonstration database, you will develop a real case. An empty database provides the starting point for testing a classic workflow from product purchase to sale, completing your guided tour and your familiarization with Open ERP.

A database loaded with demonstration data is very useful for understanding Open ERP’s general capabilities. But to explore Open ERP through a lens of your own company’s needs you should start with an empty database. You will work in this chapter on a minimal database containing no demonstration data so that there is no confusion about what you created. And you will keep the database you have created so that you can build on it throughout the rest of this book if you want to.

You will develop a real case through the following phases:

1. Specify a real case.
2. Describe the functional needs.
3. Configure the system with the essential modules.
4. Carry out the necessary data loading.
5. Test the system with your database.

The case is deliberately extremely simple to provide you with a foundation for the more complex situations you will handle in reality. Throughout this chapter it is assumed that you are accessing Open ERP through its web interface. And it is also assumed (as in the rest of this book) that you are using the latest download of Open ERP version 6, the stable production version at the time of writing (not the trunk version, which is likely to have new and potentially unstable features).

### 8.1 Business Example

Configure a system that enables you to:

- buy products from a supplier,
- stock the products in a warehouse,
- sell these products to a customer.

The system should support all aspects of invoicing, payments to suppliers and receipts from customers.

### 8.2 Basic Settings

For working out the business case you will have to model:
• the suppliers,
• the customers,
• some products,
• inventory for despatch,
• a purchase order,
• a sale order,
• invoices,
• payments.

To test the system you will need at least one supplier, one customer, one product, a warehouse, a minimal chart of accounts and a bank account.

8.3 Get your Database Up and Running with Demo Data

Use the technique outlined in Database Creation to create a new database, openerp_ch03. This database will be free of data and contain the least possible amount of functionality as a starting point. You will need to know your super administrator password for this – or you will have to find somebody who does have it to create this seed database. You will not be able to use the openerp_ch1 or openerp_ch2 databases that you might have created so far in this book because they both contain demonstration data.

Start the database creation process from the Welcome page by clicking Databases and then completing the following fields on the Create new database form, as shown in Creating a blank database:

- **Super admin password**: by default it’s admin, if you or your system administrator have not changed it,
- **New database name**: openerp_ch03,
- **Load Demonstration data checkbox**: not checked (this step is very important, but catches out many people),
- **Default Language**: English,
- **Administrator password**: admin (because it is easiest to remember at this stage, but obviously completely insecure),
- **Confirm password**: admin.

Then click Create to create the database and move to the setup screen Setting up a blank database - first screen.
After a short delay you are connected to the new openerp_ch03 database as user admin with the password you gave it. You will have to go through the Setup wizard in steps:

When you click on the button Skip Configuration Wizard, you can have the following screen. Then you can start working with this minimal database.

![Figure 8.3: Starting the minimal database](image)

If you click on the Start Configuration button then OpenERP helps you to install various applications with different functionality through the following wizard.

![Figure 8.4: Configuring a database with other applications and functionality when you select Extended view option](image)

### 8.4 Fit your Needs

All of the functional needs are provided by core modules from Open ERP. You need to just decide which functionality you want in your system. Click on the Check Box of corresponding application in the wizard **Configuration wizard used to install the required applications when you select the Simplified view option**. For the instance, we need following application.

- product management (the **product** module),
- inventory control (the **stock** module),
- accounting and finance (the **account** module),
- purchase management (the **purchase** module),
- sales management (the **sale** module).
For that the configuration wizard should be like this.

Figure 8.5: Configuration wizard used to install the required applications when you select the Simplified view option

After the follow through the complete wizard you can have the system that can perform all required functionality.

Figure 8.6: Database with all required functionality for this example

If you want to reconfigure your system then click on the Reconfigure link appeared in the header of Database with all required functionality for this example.

8.5 Database setup

You will create all the elements in the database that you need to carry out the use case. These are specified in the functional requirements.

8.5.1 Configuring Accounts

You need to start off with a minimal set of accounts, and to do that you will need a couple of account types. You can structure your accounts into a chart at any time (and, in fact, you can structure them into several additional charts at the same time as you will see in the chapter Configuring Accounts from A to Z), so you do not need to be concerned unduly about structure.
**Account Types**

Create account types using *Accounting → Configuration → Financial Accounting → Accounts → Account Types* and then clicking the *New* button. You will need the following four types, the first of which is shown in figure *New Account Type*.

<table>
<thead>
<tr>
<th>Acc. Type Name</th>
<th>Code</th>
<th>P&amp;L / BS Category</th>
<th>Sign on Reports</th>
<th>Deferral Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>View</td>
<td>view</td>
<td>/</td>
<td>Positive</td>
<td>None</td>
</tr>
<tr>
<td>Income</td>
<td>income</td>
<td>Profit &amp; Loss (Income Accounts)</td>
<td>Positive</td>
<td>Unreconciled</td>
</tr>
<tr>
<td>Expense</td>
<td>expense</td>
<td>Profit &amp; Loss (Expense Accounts)</td>
<td>Positive</td>
<td>Unreconciled</td>
</tr>
<tr>
<td>Cash</td>
<td>cash</td>
<td>Balance Sheet (Assets Accounts)</td>
<td>Positive</td>
<td>Balance</td>
</tr>
</tbody>
</table>

**Accounts**

Create accounts using *Accounting → Configuration → Financial Accounting → Accounts → Accounts* and then clicking the *New* button.

You need accounts to handle the purchase and sales orders that have not yet been paid, two more for the receipt and shipping of goods, and one for the payment and receipt of funds. And one ‘organizing’ account that is just a view of the other five. So you will need the following six accounts, one of which is shown in *New Account*.

<table>
<thead>
<tr>
<th>Name</th>
<th>Code</th>
<th>Internal Type</th>
<th>Parent</th>
<th>Account Type</th>
<th>Reconcile</th>
</tr>
</thead>
<tbody>
<tr>
<td>Minimal Chart</td>
<td>0</td>
<td>View</td>
<td>0 Minimal Chart</td>
<td>View</td>
<td>unchecked</td>
</tr>
<tr>
<td>Payable</td>
<td>AP</td>
<td>Payable</td>
<td>0 Minimal Chart</td>
<td>Expense</td>
<td>checked</td>
</tr>
<tr>
<td>Receivable</td>
<td>AR</td>
<td>Receivable</td>
<td>0 Minimal Chart</td>
<td>Income</td>
<td>checked</td>
</tr>
<tr>
<td>Cash</td>
<td>C</td>
<td>Liquidity</td>
<td>0 Minimal Chart</td>
<td>Cash</td>
<td>unchecked</td>
</tr>
<tr>
<td>Purchases</td>
<td>P</td>
<td>Regular</td>
<td>0 Minimal Chart</td>
<td>Expense</td>
<td>unchecked</td>
</tr>
<tr>
<td>Sales</td>
<td>S</td>
<td>Regular</td>
<td>0 Minimal Chart</td>
<td>Income</td>
<td>unchecked</td>
</tr>
</tbody>
</table>
The Account Type entry is taken from the list of types that you just created. Although it looks a bit like a text box, it does not behave in quite the same way. A single Del or Backspace keystroke is all you need to delete the whole text, and when you type the name (or part of the name) you still need to associate that text with the entry by clicking the Search icon to the right of the field.

**Properties**

You now define some default properties so that you do not have to think about which account is used for which transaction every time you do something. The main new properties are the four that associate accounts payable and receivable to partners, and expenses and income to product categories.

Create properties using Administration → Configuration → Parameters → Configuration Parameters and then clicking the New button.

<table>
<thead>
<tr>
<th>Name</th>
<th>Field</th>
<th>Type</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>property_account_payable</td>
<td>Account Payable</td>
<td>Many2One</td>
<td>(account.account) AP Payable</td>
</tr>
<tr>
<td>property_account_receivable</td>
<td>Account Receivable</td>
<td>Many2One</td>
<td>(account.account) AR Receivable</td>
</tr>
<tr>
<td>property_account_expense_categ</td>
<td>Expense Account</td>
<td>Many2One</td>
<td>(account.account) P Purchases</td>
</tr>
<tr>
<td>property_account_income_categ</td>
<td>Income Account</td>
<td>Many2One</td>
<td>(account.account) S Sales</td>
</tr>
</tbody>
</table>
Tip: Mistakes in configuring accounts and properties
It is easy to make mistakes in configuring the accounts and their properties, but the consequences are not immediately obvious. You will mostly discover mistakes when trying to make a Purchase or Sale Order (see later, for example, Purchase Order), where the accounts are required fields or, if you are diligent, when you set up Partners. If you configure them correctly at this stage then fields will be completed automatically and you will never know a thing. If you do not configure all this correctly then you will not be able to save the order form until you have corrected the problem or until you manually set the accounts.

Since this configuration is quite tedious you would be best finding a certified Chart of Accounts that has already been set up to meet your needs, if you can find one.

8.5.2 Configuring Journals

You will also need to configure some journals, which are used to record the transactions from one account to another when invoices are raised and then paid. Create journals from the menu Accounting → Configuration → Financial Accounting → Journals → Journals and then clicking the New button.

<table>
<thead>
<tr>
<th>Journal Name</th>
<th>Code</th>
<th>Type</th>
<th>Display Mode</th>
<th>Entry Sequence</th>
<th>Default Debit Account</th>
<th>Default Credit Account</th>
</tr>
</thead>
<tbody>
<tr>
<td>Purchase Journal</td>
<td>PUJ</td>
<td>Purchase</td>
<td>Sale/Purchase</td>
<td>Purchase</td>
<td>P Purchases</td>
<td>P Purchases</td>
</tr>
<tr>
<td>Sale Journal</td>
<td>SAJ</td>
<td>Sale</td>
<td>Sale/Purchase</td>
<td>Sale Journal</td>
<td>S Sales</td>
<td>S Sales</td>
</tr>
<tr>
<td>Bank Journal</td>
<td>BNK</td>
<td>Cash</td>
<td>Cash Journal View</td>
<td>Account Journal</td>
<td>C Cash</td>
<td>C Cash</td>
</tr>
</tbody>
</table>

Tip: Mistakes in configuring journals
It is easy to make mistakes in configuring the journals, too, and the consequences are also not immediately obvious. You will mostly discover mistakes when creating an invoice (which happens at different points in the process depending on your configuration). In this example, validating a Purchase Order creates a draft invoice (see later, again for example, Purchase Order), where a journal is required.

As with accounts and properties, if you configure them correctly at this stage then the fields will be completed automatically and you will never know a thing. If you do not configure all this correctly then there will be errors with the order form or corresponding draft invoice until you have corrected the problem or until you manually set the journal.

8.5.3 Configuring the Main Company

Start to configure your database by renaming the Main Company from its default of OpenERP S.A. to the name of your own company or (in this case) another example company. When you print standard documents such as quotations, orders and invoices you will find this configuration information used in the document headers and footers.

To do this, click Sales → Address Book → Customers and click the name of the only company there, which is OpenERP S.A.. This gives you a read-only view form view of the company, so make it editable by clicking the Edit button to the upper left of the form.

Tip: Editable form in the web client
When toggling from the list view to the form view of an item, you can generally click its name in the list view to show a non-editable view or the pencil icon by the left-hand edge of the line to open it in an editable view. You can toggle between editable and non-editable once you are in form view.

Change the following:

- **Name**: Ambitious Plumbing Enterprises,
- **Contact Name**: George Turnbull.
Before you save this, look at the partner’s accounting setup by clicking the tab Accounting. The fields Account Receivable and Account Payable have account values in them that were taken from the account properties you just created. You do not have to accept those values: you can enter any suitable account you like at this stage, although Open ERP constrains the selection to ones that make accounting sense.

Back at the first tab, General, change any other fields you like, such as the address and phone numbers, then Save. This changes one Contact for the Partner, which is sufficient for the example.

From the MAIN MENU, click Administration → Companies → Companies and edit the only entry there:

- **Company Name**: AmbiPlum,
- **Partner**: should already show Ambitious Plumbing Enterprises,
- **Report Header**: Ambitious Plumbing,
- **Report Footer 1**: Best Plumbing Services, Great Prices,
- **Report Footer 2**: Ambitious - our Registered Company Details.

Figure Changing company details shows the effect of this. You can also change various other company-wide parameters for reports and scheduling in the other tabs, and you can upload a company logo of a specific size for the reports. Click Save to store this.

You can leave the currency at its default setting of EUR for this example. Or you can change it in this Company and the two default Pricelists (Sales → Configuration → Pricelists → Pricelists) if you feel compelled to do that.

**Note:** Currency

The examples in this book are in USD and EUR. You, the reader, could use your home currency (perhaps CAD, CNY, GBP, or Rs) in their place.

### 8.5.4 Creating partner categories, partners and their contacts

You will now create a suppliers category and a customers category. Partner categories are useful for organizing groups of partners but have no special behavior that affects partners, so you can assign them as you like. Then you will define one supplier and one customer, with a contact for each.

To do this use the menu Sales → Configuration → Address Book → Partner Categories and click New to open a new form for defining Partner Categories. Define the two categories that follow by just entering their Category Name and saving them:

- Suppliers,
- Customers.

Then create two partners from the menu Sales → Address Book → Customers. Click on the New button to open a blank form and then add the following data for the first partner first:
• Name: Plumbing Component Suppliers,
• Customer checkbox: unchecked,
• Supplier checkbox: checked,
• Contact Name: Jean Poolley,
• Address Type: Default,
• add Suppliers to the Partner Categories field by selecting it from the Search List,
• then save the partner by clicking the Save button.

Figure New Partner Form shows the result.

Figure 8.10: New Partner Form

Note: Contact Types
If you have recorded several contacts for the same partner you can specify which contact is used for various documents by specifying the Address Type.
For example the delivery address can differ from the invoice address for a partner. If the Address Types are correctly assigned, then Open ERP can automatically select the appropriate address during the creation of the document – an invoice is addressed to the contact that has been assigned the Address Type of Invoice, otherwise to the Default address.

For the second partner, proceed just as you did for the first, with the following data:

• Name: Smith and Offspring,
• Customer checkbox: checked,
• **Supplier checkbox**: unchecked,
• **Contact Name**: Stephen Smith,
• **Address Type**: Default.

Then add Customers in the Categories field. Save the form. To check your work you can go to the menu Sales → Configuration → Address Book → Partner Categories and click on each category in turn to see the companies in the category.

**Note**: Multiple Partner Categories
If this partner was also a supplier then you would add Suppliers to the categories as well, but there is no need to do so in this example. You can assign a partner to multiple categories at all levels of the hierarchy.

### 8.5.5 Creating products and their categories

Unlike partner categories and their assigned partners, product categories do have an effect on the products assigned to them – and a product may belong to only one category. Under the main menu link Warehouse or Sale, select the menu Configuration → Products → Products Categories and click New to get an empty form for defining a product category.

Enter Radiators in the Name field. You will see that other fields, specifically those in the Accounting Properties section, have been automatically filled in with values of accounts and journals. These are the values that will affect products – equivalent fields in a product will take on these values if they, too, are blank when their form is saved. Click Save.

**Note**: Properties fields
Properties have a rather unusual behavior. They are defined by parameters in the menus in Administration → Configuration → Parameters → Configuration Parameters, and they update fields only when a form is saved, and only when the fields are empty at the time the form is saved. You can manually override any of these properties as you need.

Properties fields are used all over the Open ERP system and particularly extensively in a multi-company environment. There, property fields in a partner form can be populated with different values depending on the user’s company.

For example the payment conditions for a partner could differ depending on the company from which it is addressed.

**Note**: UOM
UOM is an abbreviation for Unit of Measure. Open ERP manages multiple units of measure for each product: you can buy in tons and sell in kgs, for example. The conversion between each category is made automatically (so long as you have set up the conversion rate in the product form first).

**Tip**: Managing double units of measure
The whole management of stock can be carried out with double units of measure (UOM and UOS – for Unit of Sale). For example an agro-food company can stock and sell ham by piece but buy and value it by weight. There is no direct relationship between these two units so a weighing operation has to be done.

This functionality is crucial in the agro-food industry, and can be equally important in fabrication, chemicals and many other industries.

Now create a new product through the Warehouse or Sale menu:

1. Go to Product → Products and click New.
2. Create a product – type Titanium Alloy Radiator in the Name field.
3. Click the Search icon to the right of the Category field to select the Radiators category.
4. The Product Type field should be assigned as Stockable Product. The fields Procurement Method, Supply method, Default Unit Of Measure, and Purchase Unit Of Measure should also stay at their default values.
5. Enter 57.50 into the Cost Price field and 132.50 into the Sale Price field.

![Product Form](image)

Figure 8.11: Product Form

6. Click the Accounting tab, then click Save and observe that Accounting Properties here remain empty. When product transactions occur, the Income and Expense accounts that you have just defined in the Product Category are used by the Product unless an account is specified here, directly in the product, to override that.

7. Once the product is saved it changes to a non-editable state. If you had entered data incorrectly or left a required field blank, an error message would pop-up, the form would have stayed editable and you would need to click from tab to tab to find a field colored red that would have to be correctly filled in.

8.5.6 Stock locations

Click Warehouse → Inventory Control → Location Structure to see the hierarchy of stock locations. These locations have been defined by the minimal default data loaded when the database was created. You will use this default structure in this example.

Open ERP has three predefined top-level location types, Physical Locations and Partner Locations that act as their names suggest, and Virtual Locations that are used by Open ERP for its own purposes.

1. From the Main Menu click on Warehouse → Configuration → Warehouse Management → Locations to reach a list view of the locations (not the tree view).

2. Click on the name of a location, such as Physical Locations/OpenERP S.A. to open a descriptive form view. Each location has a Location Type and a Parent Location that defines the hierarchical structure. While you are here you should change the location’s name to Ambitious Plumbing Enterprises, since it was named before you changed the company name.

3. From the Main Menu click Warehouse → Configuration Warehouse Management → Warehouses to view a list of warehouses. There is only the one at the moment, which should also be renamed from OpenERP S.A. to Ambitious Plumbing Enterprises.

A Warehouse contains an input location, a stock location and an output location for sold products. You can associate a warehouse with a partner to give the warehouse an address. That does not have to be your own
company (although it can be); you can easily specify another partner who may be holding stock on your behalf.

Note: Location Structure

Each warehouse is composed of three locations: Location Input, Location Output, and Location Stock. Your available stock is given by the contents of the Location Stock and its child locations. So the Location Input can be placed as a child of the Location Stock, which means that when Location Stock is interrogated for product quantities, it also takes account of the contents of the Location Input. Location Input could be used as a goods-in QC location. The Location Output must never be placed as a child of Location Stock, since items in Location Output, which can be considered to be packed ready for customer shipment, should not be thought of as available for sale elsewhere.

8.5.7 Setting up a chart of accounts

You can set up a chart of accounts during the creation of a database, but for this exercise you will start with the minimal chart that you created (just a handful of required accounts without hierarchy, tax or subtotals).

A number of account charts have been predefined for Open ERP, some of which meet the needs of national authorities (the number of those created for Open ERP is growing as various contributors create and freely publish them). You can take one of those without changing it if it is suitable, or you can take anything as your starting point and design a complete chart of accounts to meet your exact needs, including accounts for inventory, asset depreciation, equity, and taxation.

You can also run multiple charts of accounts in parallel – so you can put all of your transaction accounts into several charts, with different arrangements for taxation and depreciation, aggregated differently for various needs.

Before you can use any chart of accounts for anything you need to specify a Fiscal Year. This defines the different time periods available for accounting transactions. An initial Fiscal Year was created during the database setup so you do not need to do any more on this. You can also create Fiscal year manually from Accounting → Configuration → Financial Accounting → Periods → Fiscal Years

Click Accounting → Charts → Charts of Accounts to open a Chart of Accounts form where you define exactly what you want to see. Click Open Charts to accept the defaults and see a hierarchical structure of the accounts.

8.5.8 Make a backup of the database

If you know the super-administrator password, make a backup of your database using the procedure described at the very end of Installation and Initial Setup. Then restore it to a new database: testing.

This operation enables you to test the new configuration on testing so that you can be sure everything works as designed. Then if the tests are successful you can make a new database from openerp_ch03, perhaps called live or production, for your real work.

From here on, connect to this new testing database logged in as admin if you can. If you have to make corrections, do that on openerp_ch03 and copy it to a new testing database to continue checking it.

Or you can just continue working with the openerp_ch03 database to get through this chapter. You can recreate openerp_ch03 quite quickly if something goes wrong and you cannot recover from it but, again, you would need to know your super-administrator password for that.

8.6 Driving a Purchase / Sales Flow

To familiarize yourself with the system workflow you will test a purchase-sale workflow in two phases.

The first consists of product purchase, which requires the following operations:

1. Place a purchase order with Plumbing Component Suppliers for 10 Titanium Alloy Radiators at a unit price of 56.00.

2. Receive these products at your Goods In.
3. Generate a purchase invoice.
4. Pay your supplier.

Following this, you will sell some of these products, using this sequence:

1. Receive a sales order for 6 Titanium Alloy Radiators from Smith and Sons, sold at a unit price of 130.00.
2. Despatch the products.
3. Invoice the customer.
4. Receive the payment.

8.6.1 Purchase Order

To place a Purchase Order with your supplier, use the menu Purchases → Purchase Management → Purchase Orders and click on New button.

Complete the following field:

- **Supplier**: Plumbing Component Suppliers.

As you complete the Supplier field, Open ERP automatically completes the Address field and the Price List field from information it takes out of the Partner record.

Enter the following information:

- **Product**: Titanium Alloy Radiator - type in part of this name then press the tab key to complete it, or click the Search icon at the end of the line to bring a search box. (if product is previously configured)

When you have selected a product on the product line, Open ERP automatically completes the following fields from information it finds in the Product record:

- **Product UOM**: the unit of measure for this product,
- **Description**: the detailed description of the product,
- **Scheduled date**: based on the product lead time,
- **Unit price**: the unit price of the product,
- **Analytic account**: if any account is specified then it will appear on the order line (it is not in this example),
- **Taxes**: applicable taxes defined in the partner, if specified, otherwise in the product, if specified (there are not any in this example).

You can edit any of these fields to suit the requirements of the purchase order at the time of entry. Change the:

- **Quantity**: 10,
- **Unit Price** to 56.00.

Save the order line and close the Order Line window by clicking the Close button. You can then confirm the whole one-line order by clicking Save, which makes the form non-editable.

It is now in a state of Request for Quotation, so click Convert to Purchase Order, which corresponds to an approval from a manager or from Accounts within your own company and moves the order into Confirmed state.

Finally click Approved by Supplier to indicate the supplier’s acknowledgment of the order. The order becomes Approved.

If you click the Delivery & Invoices tab you will see the delivery Destination is your own company’s Stock location and that the invoice was created from the order. It is not entirely obvious at this stage, but the invoice is in a draft state so it can be edited and, crucially, has no accounting impact yet: it is just ready for your accounting group to activate it.
8.6.2 Receiving Goods

After confirming the order you would wait for the delivery of the products from your supplier. Typically this would be somebody in Stores, who would:

1. Open the menu Warehouse → Warehouse Management → Incoming Shipments using the expand/collapse icon.

   **Note:** From the Purchase Order
   You could have clicked the Receptions link to the right of the Purchase Order to reach the same screen, but this would confuse the purchasing role with the stores role. That link is very useful during testing and training, however.

2. When the Receptions window appears, select the name of the entry in the list (IN/00002) to display the Packing List itself – you would usually do a search for the supplier name or order number in a list that was larger than this – then click Process to load the Process Document form.

3. Click Validate to indicate that you are receiving the whole quantity of 10 units.

At this point you have accepted 10 units into your company, in a location that you have already seen.

Using the menu Purchases → Products → Products you can find the product Titanium Alloy Radiators with Real Stock and Virtual Stock 10. From the product form click on the link at the right most side Stock by Location you can see the Real Stock and Virtual Stock of this product in various locations. Now click on the Location Inventory Overview Report to see the inventory valuation per location.

---

**Tip:** Traceability in double-entry

Open ERP operates a double-entry stock transfer scheme similar to double-entry accounting. Because of this you can carry out various analyses of stock levels in your warehouse, along with the corresponding levels in Partner Location at your Supplier. The double-entry system, analogous to that of accounting, enables you to keep track of stock movements quite easily, and to resolve any errors that occur.

8.6.3 Invoice Control

When you have received an invoice from your supplier (which would usually be sent to your Accounts department) go to the menu Accounting → Suppliers → Supplier Invoices to open a list of supplier invoices waiting for receipt. These invoices enable your Accounts Department to match the the price and quantities ordered against the price.
and quantities on the supplier's invoice (and since it is not uncommon to receive an invoice showing details more favourable to the supplier than those agreed at the time of purchase, this is a useful function).

In this example, you created an invoice automatically when you confirmed the supplier's Purchase Order. That is because the Invoicing Control field on the order was set to From Order (the default option). Other options enable you to create invoices at the time of receiving goods or manually. The initial state of an invoice is Draft.

Now click the invoice for your order PO00001 to display its contents. You can compare the goods that you have recorded there with the invoice received from your supplier. If there is a difference it is possible to change the order lines to, for example, add a delivery charge. Click Validate to confirm the invoice and put it into the Open state.

Accounting entries are generated automatically once the invoice is validated. To see the effects on your chart of accounts, use the menu Accounting → Charts → Chart of Accounts, then click Open Charts at the Account charts page to see that you have a debit of 560.00 in the Purchases account and a credit of 560.00 in the Payable account.

### 8.6.4 Paying the supplier

Select the menu Accounting → Suppliers → Supplier Invoices and click on the Unpaid button for a list of supplier invoices that have not yet been paid. Write the PO00001 in Source Document text itself to find the invoice. In practice you would search for the invoice by order number or, more generally, for invoices nearing their payment date.

Click on Pay Invoice button in the supplier invoice form. It opens the Pay invoice window in new tab with a description of the payment.

**Supplier and Date** comes automatically from invoice. You need to just enter the Payment Method. After that click on Validate button to post this entry.

**Note:** Payment of an invoice

The method described here is for companies that do not use their accounting system to pay bills – just to record them. If you are using the account module fully other, more efficient, methods let you manage payments, such as entering account statements, reconciling paperwork, using tools for preparing payments, interfacing with banks.

You can monitor the accounting impact of paying the invoice through the chart of accounts available from the menu Accounting → Charts → Chart of Accounts. OpenERP automatically creates accounting entries from the payment and can reconcile the payment to the invoice. You now have a new transaction that has debited the Payable account with 560.00 and credited the Cash account.

If you look in Accounting → Journal Entries → Journal Entries you will see both accounting transactions, one in each of the Purchase Journal and Bank Journal in Draft state.

### 8.6.5 From Sales Proposal to Sales Order

In Open ERP, sales proposals and sales orders are managed using documents that are based on the same common functionality as purchase orders, so you will recognize the following documents in general but see changes to their detail and to their workflows. To create a new sales proposal, use the menu Sales → Sales → Sales Orders and click on New button which creates a new order in a state of Quotation, then:

1. Select the Customer Axelor. This has the effect of automatically completing several other fields: Ordering Contact, Invoice Address, Shipping Address, and the Pricelist Public Pricelist (EUR). They are all only defaults so these fields can be modified as you need.
2. Click the Create new record icon to open a Sales Order Lines window.
3. Select the product Titanium Alloy Radiator Although the Product field is not itself required, it is used by Open ERP to select the specific product so that several other fields can be automatically completed on the order line of the proposal, such as Description, Product UoM, Unit Price, Procure Method, Delivery Delay, and Taxes.
4. Change the Quantity to 6 and the Unit Price to 130.00. Then click Save and the line appears on the quotation form.

5. On the Other Information tab of this Sales Order select a Packing Policy of Complete Delivery and Shipping Policy of Invoice on Order After Delivery from their dropdown menu lists.

6. Return to the first tab Sale Order and validate the document by clicking Confirm Order which calculates prices and changes the order’s state from Quotation to In Progress as shown in screenshot Sales Order Form. If you were in negotiation with the prospective customer you would keep clicking Compute and Save keeping the document in Quotation state for as long as necessary.

![Sales Order Form](image)

**Figure 8.13: Sales Order Form**

7. In the last tab of the order, History you can see the Packing List that is been created and you will be able to see any invoices that relate to this order when they are generated.

From the Sales → Products → Products to display a list of products: just the one, Titanium Alloy Radiator, currently exists in this example. Its Real Stock still shows 10.00 but its Virtual Stock now shows 4.00 to reflect the new future requirement of 6 units for despatch.

### 8.6.6 Preparing goods for shipping to customers

The stores manager selects the menu Warehouse → Warehouse Management → Delivery Orders to get a list of orders to despatch. For this example find the Delivery Order related to the sale order which you have created.

**Tip: Running Schedulers**

At the moment your Sales Order is waiting for products to be reserved to fulfil it. A stock reservation activity takes place periodically to calculate the needs, which also takes customer priorities into account. The calculation can be started from the menu Warehouse → Schedulers → Compute Schedulers. Running this automatically reserves products. If you do not want to have to work out your stock needs but have a lean workflow you can install the mrp_jit (Just In Time) module.

Although Open ERP has automatically been made aware that items on this order will need to be despatched, it has not yet assigned any specific items from any location to fulfil it. It is ready to move 6.00 Titanium Alloy Radiators from the Stock location to the Customers location, so start this process by clicking Check Availability. The Move line has now changed from the Confirmed state to the Available state.
Then click the Process button to reach the Process Document window, where you click the Validate button to transfer the 6 radiators to the customer.

To analyze stock movements that you have made during these operations use Warehouse → Product → Product and find this product then click on the action Stock by Location which is at the right most side to see that your stocks have reduced to 4 radiators and the generic Customers location has a level of 6 radiators.

8.6.7 Invoicing Goods

Use the menu Accounting → Customers → Customer Invoices to open a list of Sales invoices generated by Open ERP. If they are in the Draft state, which means that they do not yet have any presence in the accounting system. You will find a draft invoice has been created for the order SO00008 once you have despatched the goods because you would selected Invoice on Order After Delivery.

Once you confirm an invoice, Open ERP assigns it a unique number, and all of the corresponding accounting entries are generated. So open the invoice and click Validate to do that and move the invoice into an Open state with a number of SAJ/2011/001.

You can send your customer the invoice for payment at this stage. Click Print Invoice to get a PDF document that can be printed or emailed to the customer.

You can also attach the PDF document to the Open ERP invoice record. Save the PDF somewhere convenient on your PC (such as on your desktop). Then click the Add button to the top right of the invoice form (it looks like a clipboard). Browse to the file you just saved (record.pdf if you did not change its name). This gives you a permanent non-editable record of your invoice on the Open ERP system.

Review your chart of accounts to check the impact of these activities on your accounting. You will see the new revenue line from the invoice.

8.6.8 Customer Payment

Registering an invoice payment by a customer is essentially the same as the process of paying a supplier. From the menu Accounting → Customers → Customer Invoices, click the name of the invoice that you want to mark as paid:

1. Use the Payment button which opens new window Pay Invoice.

2. Select the Payment Method, for this example select Cash then validate the entry.
Figure 8.14: *Invoice Form*

Check your Chart of Accounts as before to see that you now have a healthy bank balance in the **Cash** account.
Part III

Boost your Sales & Deliver Great Services
The Sales department is the engine of your company. Sales success drives staff motivation and boosts your company’s dynamics, which in turn enables you to keep innovating and lay the foundations for future success.

The key to continued sales success is effective Customer Relationship Management (most often known as CRM). OpenERP’s CRM features are flexible and highly developed to assist you in managing all aspects of partner relationships. Analytic tools help you understand your performance drivers, and the automation of data and processes drives your company to new levels of efficiency.

OpenERP can share information through its interfaces to the most common email clients, calendars and mobile phones, minimizing disruption to your operations when you first install it. Your staff can build on their previous productivity by continuing to use their email and office systems, now connected to OpenERP, transferring to the OpenERP interface only if they need to.

This book will help you value your customer and partner relations even more.
CHAPTER NINE

TRACKING LEADS & OPPORTUNITIES

Whatever business your company is doing, every single sales act is related to your Customer. Time to come up to your Customer’s Expectations!

9.1 What is in it for you?

• Track, drive and optimize your sales activities! Handle your full sales workflow, from lead to invoice.
• Access all information such as partners (accounts) & contacts in one place, directly at hand when you need it, even when you are working at home!
• Offer an excellent Customer Service by improving issues management and automating follow up.
• Be Mobile and sync your Calendars with your mobile device.
• Link important e-mails to the CRM directly from your current mailbox (Outlook & Thunderbird). Easily integrate your e-mails with OpenERP so that you can reply from your own mailbox and have the answer stored in your CRM automatically.
• Complete history of every action and transaction related to your valued customers and partners.
• Drive your Marketing Campaigns!
• Measure your business through up-to-date dashboards and reporting!

Use the OpenERP CRM application as from the very first business contact - either personal, by e-mail, through a contact form on your website, ... OpenERP allows your sales team to concentrate on their deals and manage the full sales flow (lead qualification -> opportunity tracking -> quotation -> sales order) while keeping a global vision of each stage.

9.1.1 Terminology

**Lead** A lead represents a prospect (potential customer) or a future sales opportunity. A lead usually is not qualified and not assigned to a sales person for follow-up. Example: a business card, a database of potential customers.

**Opportunity** A sales opportunity represents a potential contract. Each opportunity has to be followed up by a salesperson spending time to make a quotation or cancel the opportunity.

OpenERP Customer Relationship management helps you boost the pre-sales activities of managing leads and opportunities. Manage complex relationships between partners and contacts, be mobile, and automate your sales flow as much as possible. We will also develop some business cases to show you an example of how to use OpenERP in your company.
Managing your Potential Customer Contacts

The standard way of representing partners and contacts throughout OpenERP and many other enterprise systems (such as phone contact applications) is a partner with multiple contacts. Partner is the word for any entity that you do business with - a supplier, a customer, a prospect, ... In other CRM applications, a partner is also referred to as Account. The example below illustrates OpenERP default way of handling Partners and their Contacts.

![Default Partner & Contacts Relationship](image)

According to your Business, the standard way of linking several contacts to one partner may not be flexible enough for you. Of course, OpenERP provides an alternative, the `base_contact` module. This allows you to share the same contact, holding different positions, with several partners. You only need to enter the contact once and link it to the partners concerned. Any changes to contact information only need to be applied once.

The two figures Default Partner & Contacts Relationship and Base_contact module installed show the structure of partners and contacts in the form of UML classes both without and with the `base_contact` module. This is a clear way to illustrate the complexities that may be accomplished.

![Base_contact module installed](image)

The concrete example may even better illustrate the concept of multiple relationships between contacts and partners (companies). The figure Base_contact module installed shows two companies having several addresses (places of business) and several contacts attached to these addresses.

In this example you will find the following elements:

- The ABC bank has two places of business, represented by the addresses of ABC Belgium and ABC Luxembourg,
- The addresses of Dexey France and Dexey Belgium belong to the Dexey company,
- At the office of ABC Luxembourg, you have the contacts of the director (D. Smith) and the accountant (A. Doe),
- Mr Doe holds the post of accountant for ABC Luxembourg and Dexey France,
• Mr D. Smith is director of Dexey France and Dexey Belgium and we also have his private address which is not attached to a partner.

According to your Configuration, OpenERP provides three menus to access the same information:

• List of partners: \textit{Sales} $\rightarrow$ \textit{Address Book} $\rightarrow$ \textit{Customers},

• List of Addresses: \textit{Sales} $\rightarrow$ \textit{Address Book} $\rightarrow$ \textit{Addresses},

• List of contacts: \textit{Sales} $\rightarrow$ \textit{Address Book} $\rightarrow$ \textit{Contacts},

If you correct or change a contact name in the contact form, the changes will be applied to all the posts occupied in the different companies.

The screen below represents a partner form. You can see several possible addresses there and a list of contacts below each address. For each contact you see a name, a function, a phone number and an email.

Figure 9.3: A partner form with the base_contact module installed

If you click the line, you can get more details about the function (such as start date, end date and fax) or enter into the contact form (such as personal phone, different posts occupied, and personal blog). You can also add a photo to your contact form.

Figure 9.4: Detail of a job post occupied by a contact at a partner
Partner management is included in the OpenERP base modules. To manage partner relations you have to install the Sales Management module. Then configure the system to meet your needs.

For this chapter you should create a new database with demo data through the Configuration Wizard. Select Customer Relationship Management and configure the CRM according to your needs by selecting the appropriate modules. OpenERP’s modularity enables you to install only the CRM module if your requirements are limited to customer relationships.

When creating the new database, OpenERP suggests that you configure it using a series of questions:

- Simplified or Extended mode: select simplified and click OK.
- Select the Customer Relationship Management functionality to install.

OpenERP proposes a selection from preconfigured functions for CRM:
• managing a prospect database,
• managing and tracking opportunities,
• managing meetings and the company calendar,
• managing presales,
• managing phone calls,
• managing after-sales service,
• managing technical service,
• tracking bugs and new functional requests,
• share sales knowledge.

You see that OpenERP’s CRM module is not limited just to Customer Relationships but is designed to generate all types of relations with a partner: such as suppliers, employees, customers, prospects. This part will focus on customer relationships. The other CRM functions are similar to use, so you should not have huge problems with understanding those functions.

The following cases will be looked at in this chapter:

• Prospect Management,
• Opportunity Management,
• Management of the Company Calendar,
• Management of Phone Calls.

The figure Selecting parameters for CRM modules for the reader of this chapter shows the CRM module configuration screen that appears when you selected the CRM to be installed.

![Selecting parameters for CRM modules for the reader of this chapter]

If you have installed the management of prospects and opportunities, OpenERP implements the following workflow for the qualification of prospects and future opportunities.

![Process of converting a prospect into a customer or opportunity]
Lead Management

A lead represents a possible business or sales. Usually it is the first step in your sales cycle, and therefore it contains valuable information. However, the most common mistake is that this information too often gets lost because it is registered nowhere, or such key information is not accessible when you need it.

Often leads are not registered centrally, which makes it very difficult to find the appropriate information.

Leads can be assigned to a Sales Team for follow up (see Sales → Configuration → Sales → Sales Teams). Each user can be added to a default Sales team which can be specified in the Preferences. You can also escalate a lead to another Sales team, according to the tree structure you defined for your sales teams. Per sales team, you can assign a responsible user and a generic e-mail address that will be used. You can also assign specific stages.

When a lead requires follow up, it will be converted to a sales opportunity. OpenERP checks whether a partner with the e-mail address from the lead form already exists, and then proposes to link the contact to the existing partner.

The following events could result in the creation of one or several leads, either manually or automatically:

- An email sent to one of your company’s generic email addresses, such as sales@mycompany.com,
- A business card from a prospective customer met briefly at an exhibition: you have to contact him again to qualify the lead and to know if there is any possibility of a key sales opportunity,
- A database of potential customers in a given sector and region. The potential customers have to be contacted again individually or through a mass mailing to determine which contacts require further follow-up,
- An interesting contact that you met during a business networking event. You have to qualify it before assigning a salesperson to the contact,
- A form completed on your website directly integrated into OpenERP. Before converting the form into a sales proposition or opportunity, you should read and handle the person’s request.

**Note:** Separation of sales services
Some companies will have a presales and a sales department. The role of the presales department is to acquire and qualify new leads, and the role of the sales department is to crystallize the sales opportunities or work with existing customers.

Employees in the presales department will usually work on leads. Once these leads are converted into customers or sales opportunities the sales department pays individual attention to each opportunity.

Storing your Business Cards effectively

New prospects are usually entered as a lead in the system. This means that you do not create a partner form or sales opportunity until you have qualified whether the lead is interesting or not. If the new contact is indeed interesting you then enter the data on into a partner form and, eventually, a sales opportunity.

To enter a lead manually use the menu Sales → Sales → Leads and click the New button. A form opens to let you enter data about this new contact.
Leads have a status that depends on the qualification work that has been carried out:

- **Draft**: the lead data has been entered, any work has not yet been done and a salesperson has not yet been assigned to the request,
- **Open**: the lead is being handled,
- **Closed**: the lead has been converted into a partner and/or a sales opportunity,
- **Waiting**: the lead is waiting for a response from the customer,
- **Cancelled**: the lead has been cancelled because the salesperson has decided that it is not worth following up.

You can use the arrows (even from List view) to change the status (qualification) of a lead.

On the **Communication & History** tab in the Lead form, you can see the action history for this lead. You can also add internal notes and change the status while adding such a note.

### Importing a Leads Database

You can also import a huge list of leads. That may be useful if you have bought a database of potential prospects and you want to load them all into the system to handle them all at the same time.

To do that you should start with a list of leads in CSV format. If your prospects are provided in another format it is easy to convert them to the CSV format using Microsoft Excel or OpenOffice Calc. Open the leads list using the menu **Sales → Sales → Leads**. At the bottom of the list click on the **Import** link. OpenERP opens a form for importing the data.
You then define which columns are present in your CSV file in the correct order. Select your file and click on **Import**. Check in the chapter about system administration, **Configuration & Administration**, for more information on import and export.

**Tip:** Various Imports

Importing and Exporting data in OpenERP is a generic function available to all resources. So you can import and export such lists as partners, sales opportunities, accounting entries, products and price lists.

There are other methods of generating leads automatically or semi-automatically:

- through a Contact Form on your Website;
- Using the Outlook or Thunderbird plugin to insert new leads directly from an e-mail client when a salesperson sees promising e-mails;
- Using the e-mail gateway for each incoming e-mail from a certain address (such as info@mycompany.com) which allows you to create a lead automatically from the contents of the e-mail;
- Using OpenERP’s XML-RPC web-services to connect to a form on your website.

These different methods are described later in this book.

### Organizing leads

To help the users organize and handle leads efficiently, OpenERP provides several menus in the CRM system that can be used depending on the needs of each:

The **Sales → Sales → Leads** can be used for several things:

- Click New to start creating a new lead.
- This view displays a list of all the leads (both open and not) which you are linked to,
- You can display a list of all your leads that you still need to handle (your open, draft and pending leads),
- You can display a list of all your leads that are still waiting for a customer response (usually in Pending status). This enables you to check periodically on your work to do,
- You can display a list of all the leads assigned to different salespeople. This menu (as those beneath it) are used by managers to check each person’s work.

Leads are prioritized. Salespeople should ideally start working on leads from the top of the list. Open a form to describe the lead. At this stage, they contact the suspected customer by email or phone and enter the result of the contact on the lead form.

They can then change the status of the lead to a state that depends on the response from the suspect:
Converting Leads into Customers or Opportunities

If a lead is interesting, you convert it into a partner / opportunity in the system. You can do this in one step (convert to opportunity, and if partner does not exist, OpenERP will create it or merge it) or in two steps (first create partner, then convert to opportunity).

Click the button Create next to the Customer field to create a new partner or link to an existing partner.

OpenERP shows a window allowing you to select:

- whether you want to create a new partner,
- whether you want to add this contact to an existing partner (merge).

Then OpenERP opens a partner form with the information from the lead entered into it. At this stage you can add more information such as the exact partner address and the contact details.

The partner created is automatically attached to the lead, which enables you to keep complete traceability from the lead. Have a look at the Communication & History tab in the lead.

If the salesperson thinks that there is a real opportunity with the lead, following the contact he had with the prospect, he can convert it into a sales opportunity using the button Convert to Opportunity.

**Tip:** When you click the Convert to Opportunity button and the email address of the new contact is filled out, OpenERP will check whether this email address corresponds to one found for an existing partner. If so, OpenERP will directly propose to merge the new contact with the partner found.

OpenERP opens a window allowing you to select:

- whether you want to create a new opportunity,
- whether you want to add this lead to an existing opportunity (merge).

OpenERP then opens a window with the title of the opportunity (lead description) and the partner. Fill out the estimated revenue and the success rate of converting to a sale.

![Create Opportunity](image)

**Figure 9.13: Converting a lead into a sales opportunity**

Some companies have more advanced processes for the qualification of a lead. They pass through several steps, such as first call, renewing contact, waiting for a verbal agreement. You can easily configure this by creating your own stages through Sales → Configuration → Leads & Opportunities → Stages. Use the sequence number to determine the order of the stages, i.e. 10 for First Call, 20 for Renewing Contact and so on.

You can then use your own stages through the Stage field that is found up to the right of the lead definition. To move it automatically to the next step, you can use the button that looks like a right arrow.

**Tracking your Opportunities**

While a lead represents the first contact with a prospect yet to be qualified, a sales opportunity represents a potential contract. Each opportunity must be followed up by a salesperson spending time to qualify the opportunity, either by making a quotation or cancelling the opportunity.

- **Cancelled:** not to be followed as a lead,
- **Waiting:** waiting for a response from the suspect.
Leads are generally handled en masse, with the automation of certain responses or emails. Opportunities, on the contrary, are usually tracked one by one by the salespeople because an opportunity involves a negotiation process.

Just like for leads, OpenERP provides specific menus to handle sales opportunities efficiently. All opportunities can be found in the menu Sales → Sales → Opportunities.

To quickly create a new opportunity, use the menu Sales → Sales → Opportunities and click the New button. You usually do this when the opportunity is direct and has not been generated from a lead. It can also be useful to create a shortcut to this menu so that you can quickly open a new opportunity form when you need to – after a phone call, or an email, that needs follow-up.

In other cases, an opportunity may be generated from a lead. Fill out the Next Action Date to ensure good follow-up. Use the filters to group by Priority and then click the Next Action Date column to sort by next action date.

The salesperson uses the menu Sales → Sales → Opportunities to track his opportunities by applying proper filters. After various customer contacts, the salesperson can enter the information into the form to describe the activity. The Communication & History tab provides a history of all the information about the activity. The activities are automatically reported on the partner form of the associated customer. To see this, click the History tab in the partner form.

When a lead has been converted into an opportunity, the latter can be assigned to any salesperson. Then you designate an opportunity manager in the company who is responsible for assigning the new opportunities to different salespeople to suit their specialty, location or availability.

You can also use Automated Rules to automatically assign opportunities or change their status.

Also the sales manager can use the menu Sales → Sales → Opportunities and click the Salesman or Group By tab. This gives you a list of all opportunities assigned to a salesperson. The manager can easily find unassigned opportunities, then enter the salesperson responsible for the opportunity into the field Salesman.

When you answer to an opportunity from the Communication & History tab, you can directly have the status of the opportunity changed. You can also add a Global CC, even with multiple email addresses separated by ‘;’. This makes sure that when any email regarding this opportunity is sent, all the persons defined in Global CC will be notified.

Figure 9.14: History of events in a partner form
Geolocalize your Opportunities

You can geolocalize your opportunities by using the module `crm_partner_assign`.

Install the `crm_partner_assign` module to use geolocalization when assigning opportunities to partners.

- Through `Sales → Configuration → Leads & Opportunities → Partner Grade`, create Partner grades, such as Gold Partner, Silver Partner, Ready Partner. These grades will be used to determine who gets assigned which kind of opportunities.
- Assign the grades to the partners on the `Geo Localization` tab of the partner form. Also assign a weight to determine the probability of assigning opportunities to a partner.
- Click the `Geo Localize` button to determine the GPS coordinates according to the address of the partner.

**Opportunities / Assignation tab**

- Convert a lead from a partner nearby to an opportunity. Press the `Geo Assign` button on the `Assignation` tab of the opportunity. The most appropriate partner will be assigned.

**Note:** You can also use the geo localization without using the GPS coordinates.

- Click the Forward button to automatically send a mail to the assigned partner with all the details of the opportunity and the prospect.
- On the Geo Localization tab of the partner form, the assigned opportunity will be displayed. Of course, you can reassign the opportunity to another partner.
- Use the Opportunity Assignment Analysis for your reporting.

**Tip:** Use the geolocalization together with the `google_map` module. This installs a Map button. When clicked, it will open a browser with the partner’s location displayed in Google Maps.

In the partner form, the `Geo Localization` tab gives you the information you need.

![Geo Localization in partner form](Figure 9.15: Geo Localization in partner form)

Planning your Meetings effectively

There are several methods for entering a new meeting with a partner. The first method is to enter the meeting directly in the company calendar. To do that, use the menu `Sales → Meetings → Meetings`.

You can use the monthly, weekly or daily views to plan a meeting. To move between one mode and another use the buttons above and to the right of the calendar.
In the calendar you distinguish between multi-day (recurring) events and events that last only for a few hours. Multi-day events have a colored background whereas single events have a colored font. Each event has a color that represents the user that created the meeting. You can filter the different users by selecting them from the list at the left of the screen.

To enter a new meeting into the system you can click the day and the hour for a new meeting. In the weekly and daily views you can also press the left mouse button on the calendar and slide the mouse along to create an event of several hours. OpenERP then opens an entry screen for a new meeting.

You can also add reminders to your meetings and send invitations, either to persons from your own company, partner contacts or external people (just specify the email address directly in the invitation).
Tip: Consolidated Calendar

The advantage of integrated management is that the enterprise calendar will group several system events. Then in the OpenERP calendar you will automatically find both these meetings and such information as business opportunities, technical interventions, or requests for staff meetings.

Track your Phone Calls

OpenERP allows you to manage incoming and outgoing calls.

Call management can be used for particular needs, such as:

- Entering customer calls so that you keep a record of the communication attached to a partner or a sales opportunity,
- Managing a call centre with operators who handle lists of calls to carry out one after another.

To enter details of a phone call, use one of the two following menus:

- Sales → Phone Calls → Inbound to register incoming calls,
- Sales → Phone Calls → Outbound to register outgoing calls,

The phone call will then be visible in the History tab of the Partner form to give you complete visibility of the events for a customer or supplier.

Of course, OpenERP also allows you to schedule a phone call directly from an opportunity form through the related Schedule/Log Call button.
KEEP TRACK OF YOUR CUSTOMERS & SUPPLIERS

It is often said that the customer is king. You would treat all your customers as royalty, at the center of your attention if you had a way of keeping your eyes on them at all times. OpenERP’s CRM module is designed to make this aim a reality, helping employees of the business understand their customers’ needs better, and automating their communication efforts.

Tip: CRM & SRM
CRM is the abbreviation for Customer Relationship Management, and SRM is Supplier Relationship Management.

If you want to focus on your customers, you need tools to make that focus easy. Tools that will capture all the knowledge you have available, tools that will help you analyze what you know, and tools that will make it easy to use all of that knowledge and analysis.

A crucial advantage that OpenERP gives you over other CRM applications is that OpenERP knows more about your customers and your ability to supply them because it is handling all of your accounting, sales, purchases, manufacturing and fulfilment as well as linking to all of your internal staff. OpenERP’s crm business application uses that information and offers several significant features that enable you and your staff to monitor and control your supplier and customer relationships effectively, such as delegating issues to the most appropriate people, keeping a history of communications and events, qualifying prospects and detecting problems.

It also uses several statistical tools that can analyze relationships quantitatively – your customer service performance and the quality of your suppliers, for example. Using performance analysis, you can easily put a policy of real continuous improvement in place by developing an automatic rules-based system in OpenERP.

To minimize re-typing work, OpenERP provides an email gateway that links your emails to the databases. This is a significant feature – many of your staff members can then use OpenERP automatically through their email client without ever logging into it themselves and having to learn a new system.

Finally, at the end of this chapter you will see an efficient method of qualifying prospects or customers that enables you to offer a service tailored to the potential value of different prospects.

For this chapter you should start with a fresh database that includes demo data, install the Customer Relationship Management application.

10.1 Organize your Partners

In OpenERP, a partner represents all the entities that you can do business with. Some possible types of partners are:

• suppliers,
• manufacturers,
• customers,
• employees,
• prospects.

The concept of a partner here is much more flexible than in many other management applications because a partner can correspond to one type or a combination of several of these types. This avoids double data-entry and provides greater flexibility in the features available.

So a partner can be both your supplier and your customer at the same time. This feature is particularly important when you have subsidiaries or franchises since transactions between the parent and its subsidiaries in these cases will generally be two-way.

10.1.1 Creating and Updating Partners

To create a new customer or get a list of customers using demonstration data, use the menu Sales → Address Book → Customers.

![A customer form](image)

Figure 10.1: A customer form

To create a new partner in OpenERP (a company, customer, supplier, ...) you should at least enter the company’s Name in the partner form.

Documentation to be completed.

**Note:** Blue fields are mandatory, but a field may become mandatory according to data entered in previous fields.

10.1.2 Customizing Partner Fields

In the web version, click Manage Views if you want to customize the Partner view to your needs. You can add fields, delete fields or change the order of fields.

10.1.3 Performing Actions on Partners

To the right of the customer form you will find all of the actions, reports and shortcuts available for the selected partner.

Print a reminder letter from the Action bar, or create a new opportunity for a customer.

Another Action enables you to quickly send an SMS message.
Tip: Send an SMS message
To send an SMS message from standard Open ERP you will have to place an order with the bulk SMS gateway operator Clickatell™ http://clickatell.com. You will then receive an API number, a login and a password which you can use in OpenERP to send SMS messages to your partners. Or you can just develop a new module based on the inbuilt SMS functions, targeted at any of the other SMS service suppliers, and use that instead.

To send an SMS message to a partner or a selection of several partners, first select the partners then click the Send SMS Action icon.

10.1.4 Filtering your Partners

Open the Customer list view to discover the search options allowing you to easily filter your partners. You can group by Salesman to see which customers have already been assigned to a salesman or not. Click the button at the right (the icon of the person) to see the customers you are responsible for.

These filters also allow you to quickly set lists of customers for which you want to do specific actions.

10.1.5 Contacts / Addresses

You can have several contacts for one partner. Contacts represent company employees that you are in contact with, along with their address details. For each address you can indicate the address type (Default, Invoice, Delivery, Contact or Other). Based on this, OpenERP can supply an address that matches the contact’s function when generating documents in various stages through an Order process.

Contacts can be entered into the first (General) tab of the Customer form, or you can get direct access to the list of addresses through the Sales → Address Book → Addresses menu.

You can search for a subset of Partners and Contacts using the search view.

Note: Independent partners or physical people
If you want to represent a physical person rather than a company, in OpenERP, that person’s name can be typed directly into the Name field on the Partner form. In this case do not put in any Contact Name.

10.1.6 Partner Categories

OpenERP uses hierarchical categories to organize all of its partners. To reach the list of available partner categories, use the menu Sales → Configuration → Address Book → Partner Categories.

Figure 10.2: List of Partner Category
Double-click one of the categories in the partner category structure to get a list of the partners in that category. If you click on a category that has subcategories you will get a list of all of the partners in the main category and in all of its subcategories.

Because categories are structured in a hierarchical manner, you can apply an action at any level of the structure: a marketing promotion activity, for example, can be applied either to all customers, or selectively only to customers in one category and its subcategories.

The tree structure is also very useful when you are running the various statistical reports. You can structure reports at any level of the hierarchy using this partner segmentation.

In the following sections you will see how to assign partners to categories manually (perhaps for a newsletter subscription or as a hot prospect), or automatically using segmentation rules.

Use the menu Sales → Configuration → Address Book → Partner Categories and click the New button to define a new category.

10.2 Advanced Customer Relations

OpenERP also supplies several tools to improve and automate relationships with partners. They will not be described in detail here, just briefly introduced.

The Web client allows you to define specific access rules to allow your customers to access useful information, such as orders or deliveries.

10.2.1 Fetchmail

The Fetchmail functionality lets you interface the CRM with incoming and outgoing e-mails. You can install this feature when you configure the CRM or by installing the fetchmail module. It also allows you to create an object in OpenERP from an e-mail you receive. Simply define the generic mail address you want to use, such as sales@openerp.com, and link it to the crm.lead object. Every mail that is sent to this address, will automatically created as a lead for you to qualify. The Outlook and Thunderbird plugins let you easily create contacts from your mail client in OpenERP. You can also link e-mails (with attachments) to OpenERP, to avoid information getting lost. Both plugins enable you to create sales leads based on exchanges you have with the customer.

10.2.2 Automated Actions

The rules for automating actions enable you to send emails automatically based on the event, such as assigning opportunities to the most appropriate person. To access the CRM rules, use the menu Sales → Configuration → Automated Actions → Automated Actions.

10.2.3 Profiling

The segmentation tools let you create partner groups and act on each segment differently according to questionnaires. For example you could create pricelists for each of the segments, or start phone marketing campaigns by segment. To enable the management of segmentation you should install the module crm_profiling, which can also be achieved from the Configuration Wizard.

10.2.4 Report Designer

The base_report_designer module enables you to create letter templates in OpenOffice and automate letters for different prospects. OpenERP also has e-mail templates to simplify the creation of mass mailing.
10.3 Helpdesk Calendars

The OpenERP client can display any type of resource in the form of a timetable. You can generate calendar views for each of your cases as you create menus for those cases.

So if you want to implement a shared calendar for your calendar in OpenERP all you need to use the menu *Sales → Meetings → Meetings*.

You will get menus enabling you to manage calendars for each employee, and you will also get a shared calendar for the company. This calendar view is totally dynamic. You can move an event or change its duration just using your mouse.

![Monthly view of the meeting calendar for cases](image)

**Figure 10.3: Monthly view of the meeting calendar for cases**

You can change the view and return to the list view, forms or graphs by using the buttons at the top right. Open ERP’s usual search tools and filters enable you to filter the events displayed in the calendar or, for example, to display the calendar for only some employees at a time.
10.4 Analyzing Performance

Since all of your customer communications are integrated into the OpenERP system, you can analyse the performance of your teams in many ways.

You can use menu Sales → Reporting to view different statistical reports.

As for example statistical analysis of HelpDesk can be seen using the menu Sales → Reporting → Helpdesk Analysis and switch to Graph view.
Analyzing the performance of your HelpDesk support team

The system shows you statistics per user and it is possible to filter on each section and use other criteria for searching. For example, you can type in a date range, click Filter, and see the graph change to reflect the new data.

By default, the system provides a list containing the following information for each month, user and section, and an indication of the state of each set of information:

- number of cases,
- average delay for closing the request,
- estimated revenue for a business opportunity,
- estimated cost,
- estimate of revenue multiplied by the probability of success, to give you an estimated weighted revenue figure.

Tip: Navigating through the statistics
You can obtain more information about a user or a case section from these reports, drilling down into the data displayed.
In the web client you click the appropriate text string on one of the lines (such as Demo User or Helpdesk and Support) to open a form for it, and then click one of the buttons in the Action toolbar to the right of the User or Section form that is displayed.
In the GTK client you would right-click over the text instead – this brings up a context menu with the same options as the web client would give you.

You can specify that the graph view, say, appears by default so that you can consistently present the information more visually.

10.5 Automating actions using rules

Analyzing figures gives you a better basis for managing all of your services and customer and supplier relationships. But you can do more than just display the figures graphically from time to time.

If the performance of a section, a user or a category of a case is beginning to cause concern then you can use OpenERP’s rules system to monitor the situation more closely. Rules enable you to automatically trigger actions depending on criteria you define for each case. They provide a good way of implementing a proper continuous improvement policy for your customer relations and quality of service.

Using these rules you could:

- automatically send emails to the client during different phases of a support request, to keep the client up to date with progress,
- assign the case to another person if the case manager is on holiday,
• send a reminder to the supplier if their response is delayed too long,
• always mark a case as urgent if it is from a major client,
• transfer the case to technical services if the request is about a technical fault.

To define new rules use the menu Sales → Configuration → Automated Actions → Automated Actions and click the New button.

Figure 10.6: Form to enter the Automated Action

The criteria for activating this rule are defined on the main part of the screen. These criteria are:

• a condition about the initial state (for example during the creation of a case – initial state: None, eventual state: Draft),
• a condition about the destination state (for example at the closure of a case to send a confirmation or thank you e-mail),
• the case section to which the rule applies,
• the category for the case,
• a condition about the manager of the case (for example to send copies of case progress to a manager if the client request is handled by a trainee),
• a condition about the priority level (for example to provide different types of reaction depending on the urgency of the request),
• a partner or a category to be applied to the rule,
• a date for the trigger
  – reporting by the date of creation
  – reporting by date of the last action
  – reporting by the length of time that it is been active.

If you have defined several criteria OpenERP will apply the rule only if all of the criteria are valid.

You define the action that will be taken if the rule is met in the second tab of the lower part of the setup window. The following actions are included:

• change the state of the case,
• move the case to a new section,
• assign the case to a system manager,
• change the priority of a case,
• send a reminder to the case manager or a partner,
• attach information (or not) to a reminder,
• send copies of the case discussion to specified email addresses,
• send a predefined email.

Note: Example 1 Improvement in the quality of support

For example, on the graph that analyses the performance of team support in Figure 4-6 you can see that the Demo User takes an average time of 3 days and 4 hours to close a customer support request. This is too long. After analyzing the data in depth, you can see that most cases were closed in less than two days, but some may take more than ten days.

If you think that the quality of service should be improved you can automate certain actions. You could send copies of the discussion to a technical expert if the case remains open for longer than two days, defined by the following rule:

– Rule Name: Copy to an expert after 2 days,
– Case state from: Open,
– Case state to: Open,
– Responsible: Demo User,
– Trigger Date: Creation date,
– Delay after trigger date: 2 days,
– Add watchers (cc): expert@mycompany.com,
– Remind responsible: Yes.

After the rule has been defined, the expert will receive a copy of the whole discussion between the Demo User and the customer for every case that remains unclosed after two days. He will be able to interact with the discussion to avoid lengthy delays on complex problems.

Some companies use several support levels. The first level is handled by the least qualified support people and the higher levels by users who have the advantage of more experience. A user on level 1 can escalate the case to a higher level when necessary.

To systematically train employees at level 1 you can create the following rule: when the case has been escalated they will continue to be copied on the progress of the case. If a user at support level 1 can not handle a request he can escalate it to level 2. Then when an expert at level 2 answers the customer’s request, the level 1 support person also receives the answer to the problem that he could not originally handle. So your team can be educated automatically from listening in to the passage of live support calls.

Suppose that you supply two types of support contract to your customers: Gold and Normal. You can then create a rule which raises the priority of a case automatically if the partner is in the Gold Support Contract category. Define the case this way:

– Rule Name: Priority to Gold Partners,
– Case state from: /,
– Case state to: Open,
– Partner Category: Support Contract / Gold,
– Set priority to: High.

Improved client relations can flow from using such rules intelligently. With the statistical control system you can manage certain SLAs (Service Level Agreements) with your customers without a great deal of effort on your part. So you can be selective in replying to those of your partners based on the specific quality of service that you are contracted to supply.
Note: Example 2 Tracking supplier quality

Remember that an Open ERP partner can be a supplier as much as a customer. You can use the same mechanism for the management of supplier quality as you do for customer support.

If any of your staff detect a quality problem with a product from a supplier they should create a new case in the Quality section. If the email gateway is installed all you need to do is copy an email to a specified address (for example complaints@mycompany.com) while sending your email of complaint to the supplier. The case is automatically created in Open ERP and the supplier’s email response will close the case and be placed automatically in the case history.

In this case the user can add corrective or preventative actions to conform to ISO 9001, without having to enter every action into OpenERP – most of the information comes just from the emails.

The system’s statistics provide analyses about the number and the cost of quality problems from different suppliers. If certain suppliers do not offer the service quality that you expect you can automatically create rules that:

- send a reminder to the supplier after a few days if the case still remains open
- remind the production manager to call the supplier and resolve the situation if the case has not been closed within a week
- select and qualify your suppliers on the basis of their quality of service

10.6 Using the e-mail gateway

To automate the creation of current cases you can install the e-mail gateway.

The e-mail gateway enables you to use OpenERP’s CRM without necessarily using the OpenERP interface. Users can create up-to-date cases just by sending and receiving emails. This system works with the major current email clients such as Microsoft Outlook, Thunderbird and Evolution.

![Schematic showing the use of the e-mail gateway](figure10_7.jpg)

**Figure 10.7: Schematic showing the use of the e-mail gateway**

10.6.1 Installation and Configuration

To use the e-mail gateway you must install the Fetchmail module. You might need a system administrator to carry out this work.

Install the Fetchmail module from the Configuration Wizard (CRM Configuration Wizard, Synchronization, Fetch Emails), or install it from the modules list.

**Step 1**

Go to **Tools → Configuration → Email Template → Email Accounts** to define the e-mail smtp settings.

In the **Description** field, type the visible name you would like to use for the account.

In **Server**, type the mail server, i.e. smtp.googlemail.com.

Type the SMTP port (e.g. 587), configure the other settings according to the specifications of your server.
Add the User Information, such as e-mail address for which the mails will enter OpenERP, i.e. support@mycompany.com, the user name and the password. Configure the other settings to your needs.

Save and click the Test Outgoing Connection button to check whether the settings are correct.

When everything is correctly configured. Approve the account. OpenERP will automatically create a Scheduler for the mails. You can also send/receive mails manually by clicking the Send/Receive button.

Step 2

Go to Sales > Configuration > Emails > Email Servers to define the e-mail server settings.

Assign a Name and select the Server Type, i.e. IMAP Server.

Click Add Attachments if you want to include attachments for the mails received / sent.

Enter the Server Information, check SSL if necessary, i.e. imap.googlemail.com and the Login Information.

You can also choose to send an automatic reply on receipt of the mail. You can configure the mail here from the Email Server Action field.

Assign the Model to use when a new e-mail arrives, i.e. choose Helpdesk (crm.helpdesk) if you want every new e-mail that arrives to be created as a helpdesk case.

Click Confirm to confirm the account settings.

On every e-mail check, OpenERP will create a new helpdesk case, or any other object according to the model you specified. You can of course create as many accounts as you want and link them to different objects.

10.6.2 Creating and maintaining cases

Each time you start fetchmail it downloads all the e-mails and creates or updates the cases in CRM. You can turn fetchmail into a daemon to check all new emails every five minutes by using the OpenERP scheduler.

If you want to receive customer requests by e-mail you must first create a rule that automatically assigns new cases to a specified user. You must then verify that this user possesses a suitable e-mail address in the Address field within OpenERP.

To find out if the new e-mail should create a new case or update an existing case, OpenERP analyzes the subject line of the email. Existing cases are identified by the case number in the subject line, for example Re: [101] Problem with ...

When a customer sends a new request by e-mail the case is automatically created and the e-mail is transferred by the gateway to the user responsible for new cases, changing the subject line to add the case identifier. The user can then respond by emailing or by using the OpenERP interface to the case. If the user responds by e-mail the case can be automatically closed in OpenERP, keeping the responses in the history list. If the partner responds again, the case is reopened.

10.7 Supplier relationship management

To manage supplier relations, you should install the crm_claim module. You will then be able to manage supplier complaints and integrate them with your emails and document management.

To do that, use the Reconfigure wizard. Ensure Customer Relationship Management is installed. Once you have installed the crm module, check the checkbox by the Claims option during configuration. OpenERP will then create a menu in your working database for managing supplier complaints.
Once the module is installed you can use the menu Sales → After-Sales Services → Claims.

The CRM module has many reports predefined. Through the menu Sales → Reporting → Claims Analysis you can analyse:

- the number and the severity of the complaints by supplier or user,
- the response time of your suppliers to your requests,
- the supplier problems by type.
10.8 Profiling

10.8.1 Using Call Center Features

You can manually encode calls that happen or you can pass them into OpenERP. But for mass campaigns, you can import a list of phone calls to make. To do this, click the import link at the bottom of the list of phone calls. On the GTK client use the toolbar button Form → Import data... at the top.

The different operators can be assigned calls and handle them one by one using the menu Sales → Phone Calls → Outbound.

The operator can open the calls one by one. For each call, after having contacted the customer, the operator can click on one of the following buttons:

- **Cancel**: you cancel the call. For example you could cancel the call if you have tried to call them more than three times.
- **Held**: you have spoken to the customer by phone. In this case the operator can change the case section and send it to sales opportunities, for example. You could alternatively leave it in this state if you do not need to carry out any more actions with this customer.
- **Not Held**: the customer has not been called, you will try to call him again later.

10.8.2 Establishing the profiles of prospects

During presales activities it is useful to qualify your prospects quickly. You can pose a series of questions to find out what product to offer to the customer, or how quickly you should handle the request.

**Tip: Profiling**

This method of rapidly qualifying prospects is often used by companies who carry out presales by phone. A prospect list is imported into the Open ERP system as a set of partners and the operators then pose a series of questions to each prospect by phone.

Responses to these questions enable each prospect to be qualified automatically which leads to a specific service being offered based on their responses.

As an illustration, take the case of the OpenERP company which offers a service based on the OpenERP software. The company goes to several exhibitions and encounters dozens of prospects over a few days. It is important to handle each request quickly and efficiently.

The products offered by OpenERP at these exhibitions are:

- training on OpenERP – for independent people or small companies,
- partner contract – for IT companies that intend to offer an OpenERP service,
- OpenERP as SaaS – for small companies,
- a meeting in conjunction with a partner to provide a demonstration aimed at providing a software integration – for companies that are slightly larger.

The OpenERP company has therefore put a decision tree in place based on the answers to several questions posed to prospects. These are given in the following figure Example of profiling customer prospects by the OpenERP company.
Figure 10.10: Example of profiling customer prospects by the OpenERP company

The sales person starts by asking the questions mentioned above and then with a couple of minutes of work can decide what to propose to the prospective customer.

At the end of the exhibition prospects’ details and their responses to the questionnaire are entered into OpenERP. The profiling system automatically classifies the prospects into appropriate partner categories.

This enables your sales people to follow prospects up efficiently and adapt their approach based on each prospect’s profile. For example, they can send a letter based on a template developed for a specific partner category. They would use OpenERP’s report editor and generator for their sales proposition, such as an invitation to a training session a week after the show.

10.8.3 Using profiles effectively

To use the profiling system you will need to install OpenERP’s crm_profiling module. It is part of the core OpenERP system in version 6.0.0 so you do not have to download it separately from addons-extra.

You can also use the Reconfiguration Wizard and add Profiling.

Once the module is installed you can create a list of questions and the possible responses through the menu Sales → Configuration → Leads & Opportunities → Questions.

To obtain the scheme presented earlier you can create the following questions and responses:

<table>
<thead>
<tr>
<th>Questions</th>
<th>Possible Responses</th>
</tr>
</thead>
<tbody>
<tr>
<td>Journalist ?</td>
<td>Yes / No</td>
</tr>
<tr>
<td>Industry Sector ?</td>
<td>IT / ERP Consultant / Services / Industry / Others</td>
</tr>
<tr>
<td>Number of Staff ?</td>
<td>1 / 2-20 / 21-50 / 51-100 / 101-500 / 500+</td>
</tr>
<tr>
<td>Contact’s job function ?</td>
<td>Decision-maker / Not decision-maker</td>
</tr>
<tr>
<td>Already created a specification for the work ?</td>
<td>Yes / Soon / No</td>
</tr>
<tr>
<td>Implementation budget ?</td>
<td>Unknown / &lt;100k / 101-300k / &gt;300k</td>
</tr>
</tbody>
</table>

For instance, a sales person specializing in large accounts for the service sector could have a profile defined like this:

- **Budget for integration**: Unknown, 100k–300k or >300k.
- **Already created a specification for the work?** Yes.
- **Industry Sector?** Services.

When entering the details of a specific prospect, the prospect’s answers to various questions can be entered in the Profiling tab of the partner form. OpenERP will automatically assign prospects to the appropriate partner category based on these answers.

Customers corresponding to a specific search profile can be treated as a priority. The sales person can access the profile of the large active accounts easily.
OpenERP provides all the information you need to pursue your company's business opportunities effectively. But to stay productive with all the information you have to handle it is essential that you can keep using your normal communication tools by interfacing them with OpenERP, and not be limited just to OpenERP's interface.

OpenERP can do most things you need to pursue your business opportunities. But there can be quite a bit to learn, which reduces your efficiency while you are learning. And if that is true for a heavy user of the system, it is double true for an occasional user or someone who already makes heavy use of standard mail clients and cannot easily change.

So for those who need to continue using their traditional mail clients to maintain their efficiency, OpenERP can be connected to Outlook and Thunderbird. Your users can participate in many OpenERP-maintained processes without ever leaving their familiar environment, and can avoid double data entry yet easily link information to OpenERP's database automatically.

The two following modules are described:

- Mozilla Thunderbird Interface,
- Microsoft Outlook Interface.

The chapter is a mix of installation and configuration instructions, and basic interaction exercises.

For this chapter you should start with a fresh database that includes demo data, with sale and crm and their dependencies installed and no particular chart of accounts configured.

You will also need to have administrator access to your Windows PC to install the Outlook adapter described in the chapter.

### 11.1 Microsoft Outlook interface

The Microsoft Outlook plugin enables you to carry out a series of OpenERP operations directly from the Outlook e-mail client:

- create a contact or partner from an e-mail,
- save an e-mail and its attachments in OpenERP,
- send any attachment to an OpenERP document (such as proposals, projects, and tasks).

This might be useful for sending documents about a customer project to the corresponding project in OpenERP, attaching documents to an order (such as proof of payment and order receipts), attaching documents to an employee file (such as a CV or annual appraisal).

**Tip:** Outlook versions

The Microsoft Outlook plugin works with Microsoft Outlook 2003 and 2007 but not with Outlook Express
11.1.1 Installing the Outlook plugin

- Step 1: install the Outlook plugin in OpenERP

Use the OpenERP Configuration Wizard and install the Customer Relationship Management application. In the CRM Application Configuration dialog under Plug-In, select MS-Outlook. Then the Outlook Plug-In wizard appears. Next to the Outlook Plug-in field, click the Save As button to save the plugin to your desktop (or any other location on your computer).

You can also download the installation manual by clicking the green arrow next to Installation Manual. Another way to use the Outlook plugin, is by installing the OpenERP module outlook. When you install this module, the same Configuration Wizard as explained before will be displayed. Follow the same instructions.

- Step 2: Prerequisites
1. Install Python 2.6+
Download from http://www.python.org/ftp/python/2.6.6/python-2.6.6.msi
or for 64bit system http://www.python.org/ftp/python/2.6.6/python-2.6.6.amd64.msi. Run the .exe file to install the software.

2. Python for Windows extensions -
PyWin32, this module for python must be installed for the appropriate version of Python.
http://sourceforge.net/projects/pywin32/files/pywin32/Build%20214/pywin32-214.win32-py2.6.exe/download or for 64bit system

3. Specify the python folder in the system path (typically with this installer C:Python26)

How to set the path in Windows XP
For Windows XP: http://www.computerhope.com/issues/ch000549.htm

How to set the path in Windows 7
To change the system environment variables, follow the steps below.

- From the Windows button, select Control Panel, then click System.
- Click Remote Settings to open the System Properties window.
- In the System Properties window, click the Advanced tab.
- In the Advanced section, click the Environment Variables button.
- Finally, in the Environment Variables window (as shown below) under System Variables, highlight the Path directory.
  click Edit and add ;C:Python26.

4. If you are using MS Outlook 2007 than you are required to install "Microsoft Exchange Server MAPI Client and Collaboration Data Objects 1.2.1 (CDO 1.21)" from
Double-click Exchange Cdo to install it.

5. If you are using MS Outlook 2003, be sure to install the built-in Cdo component.

- Step 3: install the OpenERP extension in Outlook.
  1. Double-click the file "OpenERP-Outlook-addin.exe" that you saved on your desktop. Confirm the default settings.
  2. Double-click the file "Register plugin" in the OpenERP Outlook Addin folder (typically in C:Program Files).
11.1.2 Configuring the Outlook plugin

When you have executed Installation Step 1, Step 2 and Step 3, the first thing to do is connect Outlook to OpenERP. A little configuration needs to be done.

**Tip:** If you want the OpenERP connection to be shown as a separate toolbar, go to the menu View → Toolbars. Select OpenERP.

- Go to the menu Tools and select Configuration. If this raises an error, make sure to check the rights to that particular folder.

A configuration window appears enabling you to enter configuration data about your OpenERP server.

![Figure 11.1: How to Connect to the Server](image)

1. On the Configuration Settings tab, under Connection Parameters click the Change button and type your server settings and xml-rpc port, e.g. http://127.0.0.1:8069,
2. Select the database you want to connect to, and type the user and the password required to log in to the database,
3. Click the Connect button,
4. On the Configuration Settings tab, under Webserver Parameters click the Change button and type your web server settings, e.g. http://localhost:8080,
5. Click the Open button to test the connection.

When your connection has succeeded, you would typically want to configure Outlook to fit your needs.

To define extra document types, go to the Document Settings tab. This is the place where you can add objects from OpenERP that you wish to link mails to. The default installation comes with a number of predefined documents, such as Partners, Leads and Sales Orders.

Here is an example of how to configure extra document types. Suppose you would like to link mails to a meeting.

1. In the Title, type Meeting,
2. In the Document, type the object from OpenERP, in this example crm.meeting,
3. In the Image, select an icon you would like to use,
4. Click the Add button to actually create the document type.

**Note:** To find the object you need in OpenERP, go to the menu Administration → Customization → Database Structure → Objects. OpenERP will only show objects for which the corresponding Business Applications / Modules have been installed. You can only add objects to Outlook that are available in the selected database.

11.1.3 Using the Outlook plugin

You can use the menu Tools for several things.
The *Push* option allows you to archive e-mails to OpenERP, either to new document types or to existing ones. It also allows you to create a new contact.

The *Partner* allows you to open the Partner in OpenERP according to the e-mail (i.e. contact e-mail address) selected.

With *Document*, you can open the document concerned in OpenERP. Make sure you are logged in to the web version to use this functionality.

- Link a mail to an existing document in OpenERP

![Figure 11.2: How to Access OpenERP from Outlook?](image)

To archive an e-mail in OpenERP from Outlook, select the e-mail and click the *Push* button. Alternatively you can open the menu *Tools* → *Push*: the *Push to OpenERP* screen will open.

In the *Link to an Existing Document* section, select an object to which you like to add to your email and its attachments. You can select any object you defined in the *Document Settings* section and attach the selected mail to the selected record. The plugin also allows you to select several documents at once, simply by selecting a document and pressing the *ctrl* button when selecting the next document.

Do not forget to click the *Search* button to refresh the Documents list when you have selected a different document type.

- Create a New Document

This feature can be used to create any of the configured document types in the *Document Settings* tab. Suppose you would like to create a new lead from an e-mail. In the *Create a New Document* section, select *CRM Lead*, then click the *Create* button. A new lead will be created in OpenERP from the selected e-mail.

- Create a New Contact / Partner

If you cannot find a partner or contact for your e-mail in OpenERP, the Outlook plugin allows you to create one on the fly simply by using the information contained in the e-mail.

Select the e-mail from which you want to create a new contact, then click the *Push* button. In the *Create a New Contact* section, click the *New Contact* button. This option offers two possibilities: either you just create a contact (address), or you create a partner with the contact linked to it.

- When you just want to create a new contact, complete the address data in the dialog box and click the *Save* button. The contact will then be created in OpenERP.

- When you also want to create a new partner, complete the contact data. Then click the *Create Partner* button, add the partner’s name and click the *Save* button.

- You can also add a new contact to an existing partner. Click the *Search* button next to the Partner field and select the corresponding partner from the list. Then complete the contact data and click the *Save* button.
11.2 Mozilla Thunderbird interface

With the Mozilla Thunderbird plugin you can carry out a series of OpenERP operations directly from Thunderbird, such as:

- create a contact or partner from an e-mail,
- save an e-mail and its attachments in OpenERP,
- send any attachment to an OpenERP document (such as proposals, projects, and tasks).

This might be useful for sending documents about a customer project to the corresponding project in OpenERP, attaching documents to an order (such as proof of payment and order receipts), attaching documents to an employee file (such as a CV or annual appraisal).

11.2.1 Installing the Thunderbird plugin

- Step 1: install the Thunderbird plugin in OpenERP

Use the OpenERP Configuration Wizard and install the Customer Relationship Management application. In the CRM Application Configuration dialog under Plug-In, select Thunderbird. Then the Thunderbird Plug-In wizard appears. Next to the Thunderbird Plug-in field, click the Save As button to save the plugin to your desktop (or any other location on your computer).

You can also download the installation manual by clicking the orange arrow next to Installation Manual.
Another way to use the Thunderbird plugin, is by installing the OpenERP module `thunderbird`. When you install this module, the same Configuration Wizard as explained before will be displayed. Follow the same instructions.

- Step 2: install the OpenERP extension in Thunderbird.

To do that, use the file `openerp_plugin.xpi` that you saved on your desktop.

Then proceed as follows:

1. From Thunderbird, open the menu `Tools → Add-ons`.
2. Click Extensions, then click the `Install` button.
3. Go to your desktop and select the file `openerp_plugin.xpi`. Click Open.
4. Click `Install Now` then restart Thunderbird.

Once the extension has been installed, a new OpenERP menu item is added to your Thunderbird menubar.

**Tip: Thunderbird version**
The OpenERP plugin for Thunderbird works as from Thunderbird version 2.0. So check your Thunderbird version before installing, and download the latest version that you need from the following address: http://www.mozilla.org/products/thunderbird/

### 11.2.2 Configuring the Thunderbird plugin

When you have executed Installation Step 1 and Step 2, the first thing to do is connect Thunderbird to OpenERP. A little configuration needs to be done.

**Note:** Before starting the configuration, make sure your gtk server and web server are running (xml-rpc should be allowed).

Go to the OpenERP menubar and select `Configuration`.

A configuration window appears enabling you to enter configuration data about your OpenERP server.

![Configuration Window](image)

**Figure 11.4: How to Connect to the Server**

1. On the **Configuration Settings** tab, under **Connection Parameters** click the `Change` button and type your server settings and xml-rpc port, e.g. `http://127.0.0.1:8069`,
2. Select the database you want to connect to, and type the user and the password required to log in to the database,
3. Click the `Connect` button,
4. On the **Configuration Settings** tab, under **Webserver Parameters** click the `Change` button and type your web server settings, e.g. `http://localhost:8080`,
5. Click the `Open` button to test the connection.

When your connection has succeeded, you would typically want to configure Thunderbird to fit your needs.

To define extra document types, go to the **Document Settings** tab. This is the place where you can add objects from OpenERP that you wish to link mails to. The default installation comes with a number of predefined documents, such as Partners, Leads and Sales Orders.
Here is an example of how to configure extra document types. Suppose you would like to link mails to a purchase order.

1. In the **Title**, type Purchase Order,
2. In the **Document**, type the object from OpenERP, in this example `purchase.order`,
3. In the **Image**, select an icon you would like to use,
4. Click the **Add** button to actually create the document type.

**Note:** To find the object you need in OpenERP, go to the menu **Administration** → **Customization** → **Database Structure** → **Objects**. OpenERP will only show objects for which the corresponding Business Applications / Modules have been installed. You can only add objects to Thunderbird that are available in the selected database.

![Figure 11.5: How to Add Extra OpenERP Document Types to Thunderbird?](image)

### 11.2.3 Using the Thunderbird plugin

You can use the menu **OpenERP** for several things.

The **Push** option allows you to archive e-mails to OpenERP, either to new document types or to existing ones. It also allows you to create a new contact.

The **Partner** allows you to open the Partner in OpenERP according to the e-mail (i.e. contact e-mail address) selected.

With **Document**, you can open the document concerned in OpenERP. Make sure you are logged in to the web version to use this functionality. You have to open the mail to use this feature.

- Link a mail to an existing document in OpenERP

![Figure 11.6: How to Access OpenERP from Thunderbird?](image)

To archive an e-mail in OpenERP from Thunderbird, select the e-mail and click the **Push** button. Alternatively you can open the menu **OpenERP** → **Push**: the **Push to OpenERP** screen will open.

In the **Link to an Existing Document** section, select an object to which you like to add to your email and its attachments. You can select any object you defined in the **Document Settings** section and attach the
selected mail to the selected record. The plugin also allows you to select several documents at once, simply by selecting a document and pressing the ctrl button when selecting the next document.

Do not forget to click the Search button to refresh the Documents list when you have selected a different document type.

- Create a New Document

This feature can be used to create any of the configured document types in the Document Settings tab. Suppose you would like to create a new lead from an e-mail. In the Create a New Document section, select CRM Lead, then click the Create button. A new lead will be created in OpenERP from the selected e-mail.

- Create a New Contact / Partner

If you cannot find a partner or contact for your e-mail in OpenERP, the Thunderbird plugin allows you to create one on the fly simply by using the information contained in the e-mail.

Select the e-mail from which you want to create a new contact, then click the Push button. In the Create a New Contact section, click the New Contact button. This option offers two possibilities: either you just create a contact (address), or you create a partner with the contact linked to it.

- When you just want to create a new contact, complete the address data in the dialog box and click the Save button. The contact will then be created in OpenERP.

- When you also want to create a new partner, complete the contact data. Then click the Create Partner button, add the partner’s name and click the Save button.

- You can also add a new contact to an existing partner. Click the Search button next to the Partner field and select the corresponding partner from the list. Then complete the contact data and click the Save button.

![Figure 11.7: Creating a contact on the fly from Thunderbird](image)

- Open the Document created in OpenERP

To access archived data from different documents in OpenERP you can use the menu OpenERP → Document which allows you to access the document in OpenERP directly from your e-mail.

**Tip: Knowledge Management**
The Thunderbird plugin is compatible with OpenERP’s Knowledge (i.e. Document) Management. If you install the Knowledge application you will be able to:
- search through the content of your company’s documents (those that have the type .doc, .pdf, .sxw and .odt) and also in archived emails,
- have a shared file system that is connected to various OpenERP documents to share information and access it with your favorite browser,
- organize and structure your documents (such as projects, partners and users) in OpenERP’s system.

**Note:** Testing the Thunderbird plugin
If you install the Thunderbird plugin as described, explore its functionality as described in this section using the database you installed.
11.3 Marketing Campaigns

OpenERP offers a set of modules allowing you to easily create and track your Marketing Campaigns. With the Marketing application you define your direct marketing campaigns, which can be displayed in List or Diagram view (process).

To use the email functionality, you have to configure your email account. Go to Sales > Configuration > Emails > Email Servers. Configure your server (i.e. Google), example below. The object defines where you want the emails to enter (e.g. as a Lead). (See Using the e-mail gateway)

Click the Fetch email button to get the emails directly. OpenERP also automatically creates a Scheduled Action to fetch the mails every 5 minutes. The email is automatically created as a lead (according to the object used).

11.3.1 Automate your leads with Marketing Campaigns

Example with the email marketing campaign we follow at OpenERP for our SAAS offer.

Whenever someone subscribes to OpenERP online he/she fills a form which becomes the lead of OpenERP SaaS offer Campaign. Our SaaS salesperson triggers the marketing campaign by sending an introductory email of services we offer and thanking for subscribing for the one month free trial. Based on the response, we plot whether the lead is interested in OpenERP SAAS offer, Training or buying the OpenERP book. Significantly these are our subsets and based on their cues we send them email catering that respective needs. If they respond back, they are converted into an opportunity and thereby on subscription of our services they become our partner. In lack of response, we sent them another reminder regarding the offer after a weeks duration. If they still did not respond, our salesperson gives a voluntary call inquiring their needs. Hence like a flowchart we can trigger a respective activity for every possible cues. The chances of leads going unattended becomes very low, and for every lead we have a predefined method of treating it and we could measure it with our goals. Based on the goals we can also evaluate the effectiveness of our campaign and analyze if there is a room of improvement.

What are the questions you should focus on?

Designing every marketing campaign is mostly a long term process and the success of any campaign depends on the research and the effectiveness in the selection of customers in the campaign. There are certain questions that every marketeer always asks while designing a campaign.

- What would be our marketing campaign?
- Who would be the target audience?
- How would we measure the effectiveness of our campaign?

The OpenERP campaign works on the basic principle of lead automation. A lead is created based on a specific response by a customer towards a stimuli. E.g: Filling the subscription form on your website. The first step is defining the campaign i.e. the sequence of steps to be performed. On defining the campaign we trigger a set of activities in the marketing campaign module of OpenERP. Based on the lead automation we define the sequence of steps we ought to follow, the modes of creating and processing these activities and the cost involved with these campaign. Thus after each activity and based on its respective stimuli we can trigger the next event of the respective campaign.

Why is the Segment important?

The two most important points for any successful campaign are the adoption of a concrete methodology of execution and choosing the right segment: a target loop of customers to whom our campaign would be directed. Inappropriate focus on segment would result in the campaign being misfired and our efforts would reach deaf ears.

Through the Segment tab in the Campaign module we can define our segment for the Campaign activity, since it is possible that with every step downwards our segment gets narrowed in terms of number. You can also synchronize the entire campaign steps based on our defined segments.

How is Marketing Campaign related to CRM?
The Marketing Campaign module is closely synchronized with the Sales Management Business Application (CRM). Initially, let us consider the segment we cater in the campaign as Leads. Goals are set for each campaign which would be considered as a desired state. Once a lead accomplishes our objective criteria of goals we change their status by converting them into Opportunity (i.e. we should give focused attention to those leads). Once the lead satisfies our final objective we would consider them as a partner/customer and close that lead.

Email Templates

For each email template, you can have OpenERP generate a Wizard Action / Button that will be related to the object. So if you choose to do marketing campaigns for leads, the action will be added to the right side panel of the Lead form.

11.3.2 Defining a Marketing Campaign in OpenERP

Please notice that it requires some technical knowledge to configure Marketing Campaigns. To be able to see, create, edit campaign, users need to be in the Marketing / User group.

0. Introduction

A campaign defines a workflow of activities that items/objects entering the campaign will go through. Items are selected by segments. Segments are automatically processed every few hours and inject new items into the campaign, according to a given set of criteria. It is possible to watch the campaign as it is running, by following the campaign “workitems”. A workitem represents a given object/item passing through a given campaign activity. Workitems are left behind when the item proceeds to the next activities. This allows an easy analysis and reporting on the running campaign. Each activity may execute an action upon activation depending on a dynamic condition. When the condition is not met, the workitem is cancelled/deleted; if the condition is met, the action is executed, the workitem is marked as Done, and propagated to the next activities.

1. Campaigns (Marketing → Campaigns → Campaigns)

Campaign Each campaign is made of activities and transitions, and must be defined on any specific object the system knows about (e.g. Leads, Opportunities, Employees, Partners).

Mode

A campaign can be in one of 4 modes:

- **Test Directly**: process the whole campaign in one go, ignoring any delay put on transitions, and does not actually execute the actions, so the result is simply the set of corresponding campaign workitems (see below). Any time a segment adds new items in the campaign they will be processed in the same manner.

- **Test in Real time**: process the campaign but does not actually execute the actions, so the result is simply the set of corresponding campaign workitems (see below). Any time a segment adds new items in the campaign they will be processed in the same manner.

- **Manual confirmation**: No action will be executed automatically, a human intervention is needed to let workitems proceed into the flow. It is like a step-by-step manual process using the Campaign Followup menu. You can ignore the time delays and force any step of the campaign, implementing the campaign at your pace i.e. (you have a test email and want to see if the steps and templates work to your liking). You will see that the actions set are defined as to do and Done and the page has to be refreshed to see the next activities defined by the campaign note: the campaign sends real messages to the actual targets, be warned.

- **Normal**: the campaign is processed normally, all actions are executed automatically at the scheduled date. Pay attention that in this status, the campaign sends real messages to the actual targets.

Regardless of the current mode of the campaign, any workitem can be manually executed or cancelled at any time (even if it is scheduled in the future) through Campaign Followup.

Resource Specifies where the campaign will get the information from, i.e. the OpenERP object linked (e.g. Leads, Opportunities, Employees, Partners).
**Activities**  Activities are steps in the campaign. Each activity is optionally linked to previous and next activities through transitions.

Each activity has:

- one optional condition that stops the campaign,
- one action to be executed when the activity is activated and the condition is True (could be a ‘do nothing’ action),
- one optional signal (ignore it),
- a start flag (see below).

**Start Activity**  Activities that have the Start flag set will receive a new workitem corresponding to each new resource/object entering the campaign. It is possible to have more than one Start Activity, but not less than one.

**Activity Conditions**

[A Boolean expression, made of clauses combined using boolean operators: AND, OR, NOT]  Each condition is the criterion that decides whether the activity is going to be activated for a given workitem, or just cancelled. It is an arbitrary expression composed of simple tests on attributes of the object, possibly combined using or, and & not operators.

See section 6.1 at bottom for reference on Comparators.

The individual tests can use the “object” name to refer to the object/resource it originates from (e.g the lead), using a “dot notation” to refer to its attributes. Some examples on a CRM Lead resource:

- `object.name == ‘GTK Survey Lead’` would select only leads whose title is exactly “GTK Survey Lead”.
- `object.state == ‘pending’` would select Pending leads only,
- `object.country_id.code == ‘be’` would select leads whose country field is set to Belgium,
- `object.country_id.name == ‘Belgium’` would select leads whose country field is set to Belgium.

Tests can also use a ‘workitem’ name to refer to the actual item denoting the position of the object in the campaign. This can be useful to access some specific attributes, such as the segment that selected this item. Some examples:

- `workitem.segment_id.name == ‘GTK Survey EU Zone1 - Industry Consulting/Technology’` would select leads that entered this campaign through the “GTK Survey EU Zone1 - Industry Consulting/Technology” segment,
- ‘EU Zone1’ in `workitem.segment_id.name` would select only leads that entered the campaign through a segment that has “EU Zone1” in its name.

**Tip:**  In the GTK client you can use “Help > Enable Debug mode tooltips” to see the attribute name of every field in a form. These are the same that you can use during import/export with CSV files.

You can also use the special formula `re.search(PATTERN_TO_SEARCH, ATTRIBUTE_TO_SEARCH)` where `PATTERN_TO_SEARCH` is a character string delimited with quotes, and `ATTRIBUTE_TO_SEARCH` uses the dot notation above to refer to a field of the object. For example for CRM leads:

- `re.search(‘Plan to sell: True’, object.description)` would be true if the Notes on a Lead contain this text: “Plan to sell: True”. Be careful that all spaces etc. do matter, so you may use the special pattern characters as detailed at the bottom to account for small variations,
- `re.search(‘Plan to.*True’, object.description)` would be true if the Notes on a Lead contain this text: “Plan to” followed later on by “True”.

You can combine individual tests using boolean operators and parentheses. Some examples on a CRM Lead resource:
object.state != 'pending' and ( re.search('Plan to sell:.*True',object.description) and not re.search('Plan to use:.*True',object.description) ) would be true if the lead is NOT in Pending state and it contains “Plan to sell” but not “Plan to use”

11.3.3 Guidelines for creating a campaign

- It is a good idea to have an initial activity that will change some fields on the objects entering the campaign to mark them as such, and avoid mixing them in other processes (e.g. set a specific state and Sales Team on a CRM lead being processed by a campaign). You can also define a time delay so that the campaign seems more human (note if the answer comes in a matter of seconds or minutes it is computer generated).

- Put a stop condition on each subsequent activity in the campaign to get items out of the campaign as soon as the goal is achieved (e.g. every activity has a partial condition on the state of the item, if CRM Leads stops being Pending, the campaign ends for that case).

2. Email Templates (Marketing → Configuration → Email Template → Templates)

Email templates are composed of the following information:

- The Email headers: to, from, cc, bcc, subject
- The raw HTML body, with the low-level markup and formatting
- The plaintext body

Headers and bodies can contain placeholders for dynamic contents that will be replaced in the final email with the actual content.

3. Campaign Segments

Segments are processed automatically according to a predefined schedule set in the menu Administration → Configuration → Scheduled Actions. It could be set to process every 4 hours or every minute for example. This is the only entry point in a campaign at the moment.

Segment filters

Segments select resources via filters, exactly the same kind of filter that can be used in advanced search views on any list in OpenERP. You can actually create them easily by saving your advanced search criteria as new filters.

Filters mainly consist in a domain expressing the criteria of selection on a model (the resource). See the section 10.3 at the bottom for more information on the syntax for these filters.

For Leads, the following filter would select draft Leads from any European country with “Plan for use: True” or “Plan for sell: False” specified in the body: [
  ['type', '=', 'lead'],
  ['state', '=', 'draft'],
  ['country_id.name', 'in', ['Belgium', 'Netherlands', 'Luxembourg', 'United Kingdom', 'France', 'Germany', 'Finland', 'Denmark', 'Norway', 'Austria', 'Switzerland', 'Italy', 'Spain', 'Portugal', 'Ireland'],
  ('description', 'ilike', 'Plan for use: True'),
  ('description', 'ilike', 'Plan for sell: False')
]

6. Miscellaneous References, Examples

6.1 Reference of Comparison Operators:

- ==: Equal
- !=: Not Equal
- <: Bigger than
- >: Smaller Than
- <=: Bigger than or equal to
- >=: Smaller than or equal to
- in: to check that a given text is included somewhere in another text. e.g “a” in “dabc” is True

6.2 Reference of Pattern/Wildcard characters

- . (dot) represents any character (but just one)
• * means that the previous pattern can be repeated 0 or more times
• + means that the previous pattern can be repeated 1 or more times
• ? means that the previous pattern is optional (0 or 1 times)
• .* would represent any character, repeated in 0 or more occurrences
• .+ would represent at least 1 character (but any)
• 5? would represent an optional 5 character

6.3 Reference of filter domains

Generic format is: [ (criterion_1), (criterion_2) ] to filter for resources matching both criterions. It is possible to combine criterions differently with the following operators:

• ‘&’ is the boolean AND operator and will make a new criterion by combining the next 2 criterions (always 2). This is also the implicit operator when no operator is specified.
  – for example: [ (criterion_1), ‘&’, (criterion_2), (criterion_3) ] means criterion_1 AND (criterion_2 AND criterion_3)

• ‘|’ is the boolean OR operator and will make a new criterion by combining the next 2 criterions (always 2)
  – for example: [ (criterion_1), ‘|’, (criterion_2), (criterion_3) ] means criterion_1 AND (criterion_2 OR criterion_3)

• ‘!’ is the boolean NOT operator and will make a new criterion by reversing the value of the next criterion (always only 1)
  – for example: [ (criterion_1), ‘!’, (criterion_2), (criterion_3) ] means criterion_1 AND (NOT criterion_2 AND criterion_3)

Criterion format is: ( ‘field_path_operand’, ‘operator’, value )

Where:

• field_path_operand specifies the name of an attribute or a path starting with an attribute to reach the value we want to compare
• operator is one of the possible operator:
  – ‘=’, ‘!=’ : equal and different
  – ‘<’, ‘>’, ‘>=’, ‘<=’ : greater or lower than or equal
  – ‘in’, ‘not in’ : present or absent in a list of value. Values must be specified as [ value1, value2 ], e.g. [ ‘Belgium’, ‘Croatia’ ]
  – ‘ilike’ : search for string value in the operand
• value is the text or number or list value to compare with field_path_operand using comparator
Part IV

Manage your Books
When it is well integrated with the management system, an accounting system offers a company special benefits in addition to the obvious abilities it should have to report on the financial position. This part deals with the practical aspects of accounting, and accounting’s role throughout the whole company.

OpenERP’s accounting modules enable you not only to manage your operations clearly, following the workflow from invoicing to payment, but also to use various tools for financial analysis based on both real-time data and recent history depending on the analysis.

Your accounting structure can be completely configured from A to Z to match the needs of your company very closely.


12.1 Invoicing Workflow

In OpenERP, the Invoicing Workflow is very simple. You can see it in the following figure.

An invoice can be generated from various other documents like a Sales Order, a Purchase Order and also at the time of confirmation of a shipment.

The Invoicing system in OpenERP allows you to keep track of your accounting, even when you are not an accountant. It provides an easy way to follow up your suppliers and customers.

# So the systematic treatment of Invoicing Workflow is very important. Whenever an # invoice is generated, it will be created in Draft state with no impact on your # Accounting System. For instance, an invoice status can be changed to Open by an accountant after review or to Pro-forma status by any other user. The next step in the workflow will be the Paid status for the invoice. An invoice can be cancelled if it is not paid.

12.1.1 Customer Receipts / Supplier Vouchers

When you sell products to a customer, you can give him an invoice or a Sales Receipt which is also called Customer Receipt. Sales Receipts are merely a kind of sales ticket and not a real invoice.
When the sales receipt is confirmed, it creates journal items automatically and you can record the customer payment related to this sales receipt.

You can create and modify the sales receipt using the menu Accounting → Customers → Sales Receipt.

![Sales Receipt](image)

**Figure 12.2: Defining a Customer Receipt**

When you create a new Sales Receipt you have to enter the Customer for which you want to create a voucher. You can also define Sales lines in the Sales Information tab. Here you have to define Account, Amount and Description. At the bottom of the form you can have two options for Payment: one is Pay Directly and another is Pay Later or Group Funds. You have to enter Account in the case of the Pay Directly option. The Total amount displays automatically with calculation of tax when you click the Compute Tax button.

After validating the sales receipt, you can print the voucher by clicking the Voucher Print action at the upper right side. The voucher will be printed as follows.

![Sales Voucher](image)

**Figure 12.3: Sales Voucher**

When you purchase products from a supplier, a Supplier Voucher (a ticket) is given to you which is also called
Notes Payable in accounting terminology. When a supplier voucher is confirmed, it creates journal items automatically and you can record the supplier payment related to this purchase receipt.

You can create and modify the supplier voucher through the menu Accounting → Suppliers → Supplier Vouchers.

The Supplier Voucher form looks like the Sales Receipt form. In this form carefully select the journal. After validating the Supplier Voucher you can print it using the Voucher Print action.

12.1.2 Keep Track of your Payments

You should efficiently keep track of payments of your customers and suppliers. Sales Payment allows you to register the payments you receive from your customers. In order to record a payment, you have enter the customer, the payment method (= the journal) and the payment amount. OpenERP
will propose to you automatically the reconciliation of this payment with the open invoices or sales receipts.

You can do this in OpenERP using the menu Accounting → Customers → Customer Payment.

![Customer Payment Form](image)

**Figure 12.6: Customer Payment Form**

To create a new Customer Payment, select the customer and Payment Method. You can add invoices and other transactions in the Payment Information tab. Now select the proper Payment Difference, i.e. Keep Open and Reconcile with Write-Off. In the case of Reconcile with Write-Off the write-off amount will come automatically but you have to enter the Write-Off account so that accounting entries can be generated by OpenERP.

The supplier payment form allows you to track the payment you do to your suppliers. When you select a supplier, the payment method and an amount for the payment, OpenERP will propose to reconcile your payment with the open supplier invoices or bills.

Through the menu Accounting → Suppliers → Supplier Payment, click the New button to create a new Supplier Payment.

![Supplier Payment Form](image)

**Figure 12.7: Supplier Payment Form**

To create a new Supplier Payment, select the supplier and Payment Method. You can create the Supplier Invoices and Outstanding transactions lines by selecting the invoice lines as well outstanding expenses. Now select the
proper Payment Difference, i.e. Keep Open and Reconcile with Write-Off.

OpenERP provides various features to keep track of your invoicing and payment. The simple workflow of invoicing with efficient encoding of the payment process of your customer and supplier makes OpenERP more adoptable. In this section we discuss Customer Receipt and Supplier Voucher as well Customer Payment and Supplier Payment process.
13.1 Accounting Workflow and Automatic Invoice Creation

The chart *Accounting workflow for invoicing and payment* shows the financial workflow followed by each invoice.

![Accounting workflow for invoicing and payment](image)

Figure 13.1: *Accounting workflow for invoicing and payment*

In general, when you use all of OpenERP’s functionality, invoices do not need to be entered manually. Draft invoices are generated automatically from other documents such as Purchase Orders.

13.1.1 Draft Invoices

The system generates invoice proposals which are initially set to the Draft state. While these invoices remain unconfirmed they have no accounting impact within the system. There is nothing to stop users creating their own draft invoices if they want to.

You can create draft customer invoice manually using the menu *Accounting → Customers → Customer Invoices*.

The information that is needed for invoicing is automatically taken from the Partner form (such as payment conditions and the invoice address) or from the Product (such as the account to be used) or from a combination of the two (such as applicable Taxes and the Price of the product).

**Tip:** Draft invoices

*There are several advantages in working with Draft invoices:*

- You have got an intermediate validation state before the invoice is approved. This is useful when your accountants are not the people creating the initial invoice, but are still required to approve it before the invoice is entered into the accounts.
- It enables you to create invoices in advance, without approving them at the same time. You are also able to list all of the invoices awaiting approval.

13.1.2 Open or Pro Forma Invoices

You can approve (or validate) an invoice in the Open or Pro Forma state. A Pro Forma invoice does not yet have an invoice number, but the accounting entries on the invoice that is created correspond to the amounts that OpenERP will record as the customer’s payables.
An open invoice has a unique invoice number. The invoice is sent to the customer and is marked on the system as awaiting payment.

### 13.1.3 Reconciliation and Payments

In OpenERP an invoice is considered to be paid when its accounting entries have been reconciled with the payment entries. If there has not been a reconciliation an invoice can remain in the open state until you have entered the payment.

**Tip:** *Payment and reconciliation*

To avoid surprises, it is important to understand the idea of reconciliation and its link with invoice payment. You will find the Paid/Reconciled checkbox on an invoice. It is checked if the Journal Entry of the invoice has been totally reconciled with one or several Journal Entries of payment.

**Note:** *Reconciliation*

Reconciliation links entries in an account that cancel each other out – they are reconciled to each other (sum of credits = sum of debits). This is generally applied to payments against corresponding invoices.

Without the reconciliation process, OpenERP would be incapable of marking invoices that have been paid. Suppose that you have got the following situation for the Smith and Offspring customer:

- Invoice 145: 50,
- Invoice 167: 120,
- Invoice 184: 70.

If you receive a payment of 120, OpenERP will delay reconciliation because there is a choice of invoices to pay. It could either reconcile the payment against invoices 145 and 184 or against invoice 167.

You can cancel an invoice if the Allow Cancelling Entries function has been activated in the journal and the entries have not yet been reconciled. You could then move it from Canceled, through the Draft state to modify it and regenerate it.

**Tip:** *Treatment in Lots*

Usually, different transactions are grouped together and handled at the same time rather than invoice by invoice. This is called batch work or lot handling. You can select several documents in the list of invoices: check the checkboxes of the interesting lines using the web client and click the appropriate shortcut button at the right; or shift-click the lines using the mouse in the GTK client and use the action or print button at the top – these give you the option of a number of possible actions on the selected objects.

At regular intervals, and independently of the invoices, an automatic import procedure or a manual accounts procedure can be used to bring in bank statements. These comprise all of the payments of suppliers and customers and general transactions, such as between accounts.

When an account is validated, the corresponding accounting entries are automatically generated by OpenERP. Invoices are marked as paid when accounting entries on the invoice have been reconciled with accounting entries about their payment.

This reconciliation transaction can be carried out at various places in the process, depending on your preference:

- at data entry for the accounting statement,
- manually from the account records,
• automatically using OpenERP’s intelligent reconciliation.

You can create the accounting records directly, without using the invoice and account statements. To do this, use the rapid data entry form in a journal. Some accountants prefer this approach because they are used to thinking in terms of accounting records rather than in terms of invoices and payments.

You should really use the forms designed for invoices and bank statements rather than manual data entry records, however. These are simpler and are managed within an error-controlling system.

13.1.4 Records-based accounting system

All the accounting transactions in OpenERP are based on records, whether they are created by an invoice or created directly.

So customer reminders are generated quickly from the list of unreconciled entries in the trade receivables account for that partner. In a single reminder you will find the whole set of unpaid invoices as well as unreconciled payments, such as advance payments.

Similarly, financial statements such as the general ledger, account balance, aged balance (or chronological balance) and the various journals are all based on accounting entries. It does not matter if you generated the entry from an invoice form or directly in the invoice journal. It is the same for the tax declaration and other statutory financial statements.

When using integrated accounting, you should still go through the standard billing process because some modules are directly dependent on invoice documents. For example, a sales order can be configured to wait for payment of the invoice before triggering a delivery. In such a case, OpenERP automatically generates a draft invoice to send to the client.

13.2 Invoices

In OpenERP, the concept of “invoice” includes the following documents:

• The Customer Invoice
• The Supplier Invoice
• A Customer Credit Note or Customer Refund
• A Supplier Credit Note or Supplier Refund

Only the invoice type and the representation mode differ for each of the four documents. But they are all stored in the same object type in the system.

You get the correct form for each of the four types of invoice from the menu you use to open it. The name of the tab enables you to tell the invoice types apart when you are working on them.

Note: Types of invoice

There are many advantages in deriving the different types of invoice from the same object. Two of the most important are:

• In a multi-company environment with intercompany invoicing, a customer invoice in one company becomes a supplier invoice for the other;
• This enables you to work and search for all invoices from the same menu. If you are looking for an invoicing history, OpenERP provides both supplier and customer invoices in the same list, as well as credit notes.

Note: Credit Note

A credit note is a document that enables you to cancel an invoice or part of an invoice.

To access customer invoices in OpenERP, use the submenus of Accounting → Customers → Customer Invoices and for supplier invoice use the submenu of Accounting → Suppliers → Supplier Invoices.

Most of the time, invoices are generated automatically by OpenERP as they are generated from other processes in the system. So it is not usually necessary to create them manually, but simply approve or validate them. OpenERP uses the following different ways of generating invoices:
• from Supplier or Customer Orders,
• from receipt or dispatch of goods,
• from work carried out (timesheets, see Lead & Inspire your People),
• from closed tasks (see Drive your Projects),
• from fee charges or other rechargeable expenses (see Deliver Quality Services).

The different processes generate Draft invoices. These must then be approved by a suitable system user and sent to the customer. The different invoicing methods are detailed in the following sections and chapters.

It is also possible to enter invoices manually. This is usually done for invoices that are not associated with an order (usually purchase orders) or Credit Notes. Also if the system has not been configured correctly you might need to edit the invoice before sending it to the customer.

For example, if you have not realized that the customer is tax-exempt, the invoice you generate from an order will contain tax at the normal rates. It is then possible to edit this out of the invoice before validating it.

### 13.2.1 Entering a Customer Invoice

The principle of entering data for invoices in OpenERP is very simple, as it enables non-accountant users to create their own invoices. This means that your accounting information can be kept up to date all the time as orders are placed and received, and their taxes are calculated.

At the same time it allows people who have more accounting knowledge to keep full control over the accounting entries that are being generated. Each value proposed by OpenERP can be modified later if needed.

Start by manually entering a customer invoice. Use Accounting → Customers → Customer Invoices and click on New button for this.

A new invoice form opens for entering information.

![Figure 13.2: Entering a New Invoice](image)

The document is composed of three parts:

• the top of the invoice, with customer information,
• the main body of the invoice, with detailed invoice lines,
• the bottom of the page, with detail about the taxes, and the totals.

To enter a document in OpenERP you should always fill in fields in the order they appear on screen. Doing it this way means that some of the later fields are filled in automatically from the selections made in earlier fields. So select the Customer, and the following fields are completed automatically:

• the invoice address corresponds to the customer contact that was given the address type of Invoice in the partner form (or otherwise the address type of Default),
• the partner account corresponds to the account given in the Accounting which is found in a tab of the partner form.
• a specific or a default payment condition can be defined for this partner in the Accounting tab of the partner form. Payment conditions are generated by rules for the payment of the invoice. For example: 50% in 21 days and 50% in 60 days from the end of the month.

Note: Properties fields
The Properties fields on the Partner form or the Product form are multi-company fields. The value that the user sees in these fields depends on the company that the user works for.
If you work in a multi-company environment that is using one database, you have several charts of accounts. Asset and liability accounts for a partner depend on the company that the user works for.

Tip: Seeing partner relationships
You can reach more information from certain relation fields in OpenERP:
• In the web client in read-only mode a relation is commonly a hyperlink - it takes you to the main form for that entity, with all of the actions and links.
• In the web client in edit mode you can press the keyboard Ctrl button at the same time as right-clicking in the field to get a context menu with links and other options.
• And in the GTK client you can right-click the field to get that same context menu.
So one way or another you can rapidly reach the partner’s:
• current sales and purchases,
• CRM requests,
• open invoices,
• accounts records,
• payable and receivable accounts.

You can add more detailed additional information to the invoice and select the currency that you want to invoice in.

Once the invoice heading is saved you must enter the different invoice lines. You could use either of two techniques:

• enter the whole field manually,
• use a product to complete the different fields automatically.

Tip: Invoice Line Description
The invoice line description is more of a title than a comment. If you want to add more detailed comments you can use the field in the second tab Notes.

So select the product Basic PC in the product field in an invoice line. The following fields are then completed automatically:

• Description : this comes from the product, in the language of the partner,
• Account : determined by the purchase or sales account defined in the product properties. If no account is specified in the product form, OpenERP uses the properties of the category that the product is associated with.
• Unit of Measure : this is defined by default in the product form,
• Unit Price : this is given by the sales price in the product form and is expressed without taxes,
• Taxes : provided by the product form and the partner form.
Tip: Managing the Price with Tax Included
By default, OpenERP invoices and processes the price without taxes – they are managed as a separate amount. OpenERP can manage tax inclusive prices when you check the Tax Included in Price field true when configuring the tax.

Note: Information about the Product
When you are entering invoice data, it can sometimes be useful to get hold of more information about the product you are invoicing. Since you are already in edit mode, you would press the Ctrl key and use a right mouse-click on the Product field (in both the web and the GTK clients). Then select the available reports. OpenERP provides three standard reports about the product:
- forecasts of future stock,
- product cost structure,
- location of the product in your warehouses.

You can enter several invoice lines and modify the values that are automatically completed by OpenERP. Once the invoice lines have been entered, you can click Compute Taxes on the invoice to get the following information:
- details of tax calculated,
- tax rate,
- total taxes,
- total price.

In the Taxes area at the bottom left of the invoice you will find the details of the totals calculated for different tax rates used in the invoice.

Tip: Tax Calculations
You can double-click one of the lines in the tax summary areas in the invoice. OpenERP then shows you the detail of the tax charges which will form your tax declaration at the end of the period.
It shows you the total that will be computed in the different parts of the legal declaration. This enables you to manage the declaration in OpenERP automatically.

Before approving the invoice you can modify the date and the accounting period, which are entered by default as today’s date. These fields are found on the second tab Other Info.

Note: Invoice layout
If you want to make your invoice layout more elaborate you can install the module account_invoice_layout. This enables you to add various elements between the lines such as subtotals, sections, separators and notes.

Click Validate when you want to approve the invoice. It moves from the Draft state to the Open state.

When you have validated an invoice, OpenERP gives it a unique number from a defined sequence. By default it takes the form Journal Code/Year/Sequence Number for example SAJ/2010/005. You cannot modify an invoice number, but instead you should modify the sequence numbers through the menu Administration → Configuration → Sequences → Sequences.

Accounting entries corresponding to this invoice are automatically generated when you approve the invoice. You see the details by clicking the entry in the Journal Entry field and searching there for the account moves.
generated by that invoice number.

13.2.2 Tax Management

Details on the product form determine the selection of applicable taxes for an invoice line. By default OpenERP takes account of all the taxes defined in the product form.

Take the case of the following product

- Applicable taxes:
  - TVA: 19.6% type TVA
  - DEEE: 5.5, type DEEE

**Note:** *DEEE tax*

*The DEEE tax (disposal of electronic and electrical equipment) is an ecological tax that was imposed in France from 2009. It is applied to batteries to finance their recycling and is a fixed sum that is applied to the before-tax amount on the invoice.*

If you trade with a company in your own country, and your country has a DEEE-type tax, the applicable taxes for this invoice could be:

- DEEE: 5.5,
- TVA: 19.6%.

If you sell to a customer in another company in the community (intracommunity), instead, then tax is not charged. In the partner form the tab *Accounting* the field *Fiscal Position* maintain the information whether the customer is within the region or not. When you create an invoice for this customer, OpenERP will calculate the following taxes on the product:

- DEEE: 5.5,
- TVA intracommunity: 0%.

If you have not entered the parameters in the customer form correctly, OpenERP will suggest incorrect taxes in the invoice. That is not a real issue, because you can always modify the information directly in the invoice before approving it.

**Tip:** *Occasional Invoices*

*When you create an invoice for a product that will only be bought or sold once you do not have to encode a new product. Instead, you will have to provide quite a bit of information manually on the invoice line:*

- sales price,
- applicable taxes,
- account,
- product description.

13.2.3 Cancelling an Invoice

By default OpenERP will not allow you to cancel an invoice once it has been approved. Since accounting entries have been created, you theoretically cannot go back and delete them. However, in some cases it is more convenient to cancel an invoice when there is an error than to produce a credit note and reconcile the two entries. Your attitude to this will be influenced by current legislation in your accounting jurisdiction and your adherence to accounting purity.

OpenERP accommodates either approach. Install the account_cancel module. Then allow cancelling an invoice by checking the box *Allow Cancelling Entries* in the Journal corresponding to this invoice. You will then be allowed to cancel the invoice if the following two conditions are met:

1. The accounting entries have not been reconciled or paid: if they have, then you will have to cancel the reconciliation first.
2. The accounting period or the fiscal year has not already been closed: if it is closed then no modification is possible.

Cancelling an invoice has the effect of automatically modifying the corresponding accounting entries.

When the invoice has been cancelled you could then put it back into the **Draft** state. So you could modify it and approve it again later.

**Tip:** Numbering invoices
Some countries require you to have contiguously numbered invoices (that is, with no break in the sequence). If, after cancelling an invoice that you are not regenerating, you find yourself with a break in the numbering you have to go and modify the sequence, redo the invoice and replace the sequence number with its original value.

You can control the sequences using the menu **Administration** → **Configuration** → **Sequences** → **Sequences**.

Cancelling an invoice will cause a break in the number sequence of your invoices. You are strongly advised to recreate this invoice and re-approve it to fill the hole in the numbering if you can.

**Tip:** Duplicating a document
The duplication function can be applied to all the system documents: you can duplicate anything – a product, an order, or a delivery.

**Note:** Duplicating invoices
Instead of entering a new invoice each time, you can base an invoice on a similar preceding one and duplicate it. To do this, first search for a suitable existing one. In the web client, show the invoice in read-only (non-editable) form view, then click Duplicate. In the GTK client, select Form → Duplicate from the top menu.

The duplication creates a new invoice in the **Draft** state. That enables you to modify it before approving it. Duplicating documents in OpenERP is an intelligent function, which enables the duplicated invoice to be given its own sequence number, today's date, and the draft state, even if the preceding invoice has been paid.

**Note:** Saving Partner Preferences
OpenERP has many functions to help you enter data quickly. If you invoice the same products frequently for the same partner you can save the last invoice preferences using conditional default values.

To test this functionality, create an invoice for a partner and add some lines (from the GTK client). Then hold Ctrl and click with the right mouse button on the contents of the Invoices field and select Set as default. Check the box that indicates this default should apply only to you.

Then the next time you create an invoice these invoice lines will be automatically created and you will only have to modify the quantities before confirming the invoice.

For taxes you could put the default amount in the invoice lines (in France it would be 19.6%, in Belgium 21%, in the UK 17.5% or 15%). Doing this you will not forget to add tax when you are manually entering invoices.

(The capabilities of the GTK client are more extensive than those of the web client. You can set defaults for multiple lines in the GTK client but only a single line in the web client, so you need to be quite sure what is possible before you use this functionality routinely.)

**Note:** Getting Information by Navigating to it
As you are creating an invoice you will often find you need extra information about the partner to help you complete the invoice. As described earlier, you can navigate to other information linked to this partner by right-clicking, such as:

- Monthly Turnover
- Benefit Details,
- Most Recent Invoices,
- Latest Orders - Sales Order, Purchase Order.

Do the same to get information about the products you are invoicing. For example: is there enough stock? When will you be getting more stocks in? What are the costs and normal list prices for this product?

By making this information easily accessible while you are invoicing, OpenERP greatly simplifies your work in creating the invoice.
13.2.4 Creating a Supplier Invoice

The form that manages supplier invoices is very similar to the one for customer invoices. However, it is been adapted to simplify rapid data entry and monitoring of the amounts recorded.

**Tip:** Entering data

Many companies do not enter data on supplier invoices but simply enter accounting data corresponding to the purchase journal. This particularly applies to users that have focused on the accounting system rather than all the capabilities provided by an ERP system. The two approaches reach the same accounting result: some prefer one and others prefer the other depending on their skills. However, when you use the Purchase Management functions in OpenERP you should work directly on invoices because they are provided from Purchase Orders or Goods Receipt documents.

To enter a new supplier invoice, use the menu Accounting → Suppliers → Supplier Invoices.

Everything is similar to the customer invoice, starting with the Journal unless the default is acceptable, and then the Supplier, which will automatically complete the following fields:

- Invoice Address,
- Partner Account.

Unlike the customer invoice you do not have to enter payment conditions – simply a Due Date if you want one. If you do not give a due date, OpenERP assumes that this invoice will be paid in cash. If you want to enter more complete payment conditions than just the due date, you can use the Payment Term field which you can find on the second tab Other Info.

You must also enter the invoice Total with taxes included. OpenERP uses this amount to check whether all invoice lines have been entered correctly before it will let you validate the invoice.

Indicate the Currency if the invoice is not going to use the default currency, then you can enter the Invoice lines.

Just like the customer invoice you have the choice of entering all the information manually or use a product to complete many of the fields automatically. When you enter a product, all of the following values are completed automatically:

- the product Account is completed from the properties of the product form or the Category of the product if nothing is defined on the product itself,
- the Taxes come from the product form and/or the partner form, based on the same principles as the customer invoice,
- the Quantity is set at 1 by default but can be changed manually,
- set the Unit Price from the total price you are quoted after deducting all the different applicable taxes,

Click Compute Taxes to ensure that the totals correspond to those indicated on the paper invoice from the supplier. When you approve the invoice, Open ERP verifies that the total amount indicated in the header correspond to the sum of the amounts without tax on the invoice lines and the different applicable taxes.

OpenERP automatically completes the Date Invoiced and the accounting period.

**Note:** Dates and Accounting Periods

Accounting periods are treated as legal period declarations. For example a tax declaration for an invoice depends on the accounting period and not on the date of invoicing.

Depending on whether your declarations are made monthly or quarterly, the fiscal year contains either twelve or four accounting periods.

The dates are shown in the document you created in the accounting system. They are used for calculating due dates.

The two pieces of information do not have to have the same date. If, for example, you receive an invoice dated 5th January which relates to goods or services supplied before 31st December, the invoice may be coded into the December accounting period and thus be recognized in that period for the tax declaration, while the invoice can remain 5th January which remains the basis of the due date for payment.
You can find that the amounts do not correspond with what your supplier has given you on paper for reasons that can include:

- the supplier made a calculation error,
- the amounts have been rounded differently.

**Tip:** Rounding Tax

It often happens that a supplier adds 1 to the total because the tax calculation has been rounded upwards. Some tax amounts are not valid because of this rounding.

For example it is impossible to arrive at the amount of 145.50 if you’re working to a precision of 2 decimal places and a rate of 19.6%:

- \( 121.65 \times 1.196 = 145.49 \)
- \( 121.66 \times 1.196 = 145.51 \)

In this case you can modify a value in the lines that the total’s based on, or the total amount of taxes at the bottom left of the form: both are editable so that you can modify them to adjust the total.

When the totals tally you can validate the invoice. OpenERP then generates the corresponding accounting entries. You can manage those entries using the Account fields on the invoice and on each of the invoice lines.

### 13.2.5 Credit Notes / Refunds

Entering a customer credit note is almost identical to entering a customer invoice. You just start from the menu Accounting → Customers → Customer Refunds.

Similarly, entering a supplier credit note is the same as that of the supplier invoice and so you use the menu Accounting → Suppliers → Supplier Refunds.

It is easy to generate a credit note quickly from an existing invoice. To do this, select a customer or supplier invoice which is in Open or Paid state and click Refund button. OpenERP opens a new payment invoice form for you in the Draft state so that you can modify it before approval.

**Tip:** Crediting several invoices

You can credit more than one customer invoice using the menu Accounting → Customers → Customer Payment. You can find the Invoices and outstanding transactions and Credits for the particular customers. Enter the amount in the field Paid Amount and validate it.

### 13.2.6 Payments

The invoice is automatically marked as paid by OpenERP once invoice entries have been reconciled with payment entries. You yourself do not have to mark the invoices as paid: OpenERP manages that when you reconcile your payments.

**Tip:** Reconciling a credit note

Generally you reconcile the invoice’s accounting entries with their payment(s). But you can also reconcile an invoice with the entries from the corresponding credit note instead, to mutually cancel them.

You have seen the Payment button in the invoice form which is in Open state. This lets you enter payments and get entries reconciled very quickly.

You can also manage the payment of invoices when you are entering bank statements and cash transactions. These allow better control of financial transactions and permit greater flexibility in areas such as:

- advance and partial payments of invoices,
- payment of several invoices by several payments,
- fine-grained management of different due dates on the same invoices,
- management of adjustments if there are different amounts to those on the invoice.
13.3 Accounting Entries

Various methods can be used to create accounting entries. You have already seen how an invoice creates its own entries, for example.

This section deals with

• managing bank statements,
• managing cash,
• manual journal entries,

Here we will show you how to enter financial transactions. In OpenERP you can handle bank statements and also a cash register. Use different journals for these two kinds of transaction. According to the journal type selected, you will have a different screen.

13.3.1 Managing Bank Statements

OpenERP provides a visual tool for managing bank statements that simplifies data entry into accounts. As soon as a statement is validated, the corresponding accounting entries are automatically generated by OpenERP. So non-accounting people can enter financial transactions without having to worry about things such as credit, debit and counterparts.

To enter a bank statement, go to the menu Accounting → Bank and Cash → Bank Statements. A data entry form for bank statements then opens as shown in figure Data Entry Form for a Bank Statement.

![Figure 13.4: Data Entry Form for a Bank Statement](image)

The statement reference Name and the Date are automatically suggested by OpenERP. The Name will be filled with the statement number at confirmation of the bank statement. You can configure your own reference by managing sequences in the Administration → Configuration → Sequences menu.

Then select the correct Journal. Ideally, when you are configuring your company you would create at least one journal for each bank account and one journal for petty cash in your company. So select the journal corresponding to the bank account whose statement you are handling.

The currency that you are using for the statement line is that of the selected journal. If you are entering statement lines for an account in American Dollars (USD), the amounts must be entered in USD. The currency is automatically converted into the company’s main currency when you confirm the entry, using the rates in effect at the date of entry. (This means that you would need valid currency conversion rates to be created first. Go to Accounting → Configuration → Miscellaneous → Currencies menu.)

OpenERP automatically completes the initial balance based on the closing balance of the preceding statement. You can modify this value and force another value. This lets you enter statements in the order of your choice. Also if you have lost a page of your statement you can enter the following ones immediately and you are not forced to wait for a duplicate from the bank.

So, complete the closing balance which corresponds to the new value in the account displayed on your bank statement. This amount will be used to control the operations before approving the statement.

Then you must enter all the lines on the statement. Each line corresponds to a banking transaction.
Enter the transaction line. You have two ways of entering financial transactions: manually or through the Import Invoices button.

### 13.3.2 Manual entry

When you type the Partner name, OpenERP automatically proposes the corresponding centralisation account. The total amount due for the customer or supplier is pre-completed (Amount). This gives you a simple indication of the effective payment. You must then enter the amount that appears on your statement line: a negative sign for a withdrawal and a positive sign for a cash payment or deposit.

In the *Payment* press F1 to reconcile your payment directly with the corresponding accounting entry or entries to be paid.

### 13.3.3 Import Invoices

Click the *Import Invoices* button, then click Add to select the invoices for which your payment will have to be reconciled. Click OK to confirm your selection; the statement line will automatically be added with the corresponding reconciliation.

![Figure 13.5: Reconciliation from Data Entry of the Bank Statement](image)

**Note:** Reconciliation

*Other methods of reconciliation are possible: from accounting entries, when saving the payment directly on an invoice, or using the automatic reconciliation tool.*

*You can carry out either a full or a partial reconciliation.*

If you see a difference between the payment and the invoices to reconcile, you can enter the difference in the second part of the form *Write-off*. You have to set an account for the adjustment. The main reasons explaining the difference are usually:

- profit or loss,
- exchange differences,
- discounts given for fast payment.

When the reconciliation is complete - that is the payment is equal to the sum of the due payments and the adjustments - you can close the reconciliation form.

The reconciliation operation is optional – you could very well do it later or not do it at all. However, reconciliation has got two significant effects:

- marking that the invoices have been paid,
- preventing the payment and invoice amounts from appearing on customer reminder letters. Unless you have reconciled them, a customer will see the invoice and payment amounts on his reminder letter (which will not alter the balance due since they will just cancel each other out).
Finally, once you have entered the complete bank statement, you can validate it. OpenERP then automatically generates the corresponding accounting entries if the calculated balance equals the final balance indicated in the Closing Balance field. The reconciled invoices are marked as paid at that point.

You can also enter general accounting entries for e.g. banking costs. In such cases, you can enter the amounts directly in the corresponding general accounts.

A user with advanced accounting skills can enter accounting entries directly into the bank journal from Accounting → Journal Entries → Journal Items. The result is the same, but the operation is more complex because you must know the accounts to use and must have mastered the ideas of credit and debit.

### 13.3.4 Cash Management

To manage cash, you can use the menu Accounting → Bank and Cash → Cash Registers. At the start of the day you set the opening amount of cash in the entry (Opening Balance). Then Open the Cash journal to start making entries from the Cash Transactions tab.

All the transactions throughout the day are then entered in this statement. When you close the cash box, generally at the end of the day, enter the amounts on the Cashbox tab, in the Closing Balance section. Then confirm the statement to close the day’s cash statement and automatically generate the corresponding accounting entries. Note that the Calculated balance and the Cashbox balance need to be equal before you can close the cashbox.

**Tip:** Confirming the statement

Accounting entries are only generated when the cash statement is confirmed. So if the total statement has not been approved (that is to say during the day, in the case of petty cash) partner payments will not have been deducted from their corresponding account.

### 13.3.5 Manual Entry in a Journal

Invoices and statements produce accounting entries in different journals. But you could also create entries directly in a journal (line by line) without using the dedicated journal views. This functionality is often used for miscellaneous entries.

To make manual entries, go to the following menu Accounting → Journal Entries → Journal Items. In the Journal field from the filter, select the journal in which you want to post, then click Find. When you select a journal in this filter, you do not have to fill in the journal when posting new entries.

Let’s give the example of a purchase invoice. Note however that these entries are usually generated automatically by OpenERP.

Click the New button. Fill these fields manually in the following order:

- **Journal Entry**: leave this field empty so that OpenERP can fill it in automatically from the next sequence number (first draft, then validated) for the journal,
- **Ref.**: reference from the invoice or entry,
• **Date**: effective date of the entry, will be preset with today’s date
• **Period**: financial period, will be preset with the current period
• **Partner**: partner concerned,
• **Account**: general account (e.g. purchase account *Products Purchase*),
• **Name**: description of the invoice line (e.g. *PC2*),
• **Debit**: here you type the debit amount.
• **Journal**: here you select the journal in which you want to post.
• **Credit**: here you type the credit amount, e.g. 1196.

Press the *Enter* key on your keyboard to validate the first line. The next draft move number is assigned to your accounting entry. Your line is then colored red and takes the Unbalanced state. When a line is in the draft state, it is not yet reflected in the accounts. OpenERP will not validate that line until the balancing entry is made (so the credit amounts must balance the debit amounts for that set of entries).

OpenERP now proposes the balancing accounting line to be filled in. If the account used (in this case account 600000) includes taxes by default OpenERP automatically proposes taxes associated with the amount entered. At this stage you can modify and validate this second line of the account, or replace it with other information such as a second purchase line.

When you have entered all of the data from your lines, OpenERP automatically proposes counterpart entries to you, based on the credit entries.

**Tip:** Completing a balancing entry

*When an accounting entry is matched, OpenERP moves it to the Valid state automatically and prepares to enter the next data. Do not forget to definitely post the valid entries by clicking the Action button and selecting Post Journal Entries.*

*If you want to add some other balancing lines you can enter the number of the entry on the new line that you are entering. In such a case the whole line stays Draft until the whole set balances to zero.*

### 13.3.6 Reconciliation Process

The reconciliation operation consists of matching entries in different accounts to indicate that they are related. Generally reconciliation is used for:

- matching invoice entries to payments so that invoices are marked as paid and customers do not get payment reminder letters for those entries (reconciliation in a customer account),
- matching deposits and cheque withdrawals with their respective payments,
- matching invoices and credit notes to cancel them out.

A reconciliation must be carried out on a list of accounting entries by an accountant, so that the sum of credits equals the sum of the debits for the matched entries.

Reconciliation in OpenERP can only be carried out in accounts that have been configured as reconcilable (the Reconcile field).

# .. todo:: # .. tip:: Do not confuse: account reconciliation and bank statement reconciliation

# It is important not to confuse the reconciliation of accounting entries with bank statement # reconciliation. # Account reconciliation consists of linking account entries with each other, while statement reconciliation consists of # verifying that your bank statement corresponds to the entries of that account in your accounting system. # You can perform statement reconciliation using the menu Accounting → Periodical Processing → Statements → # Statements Reconciliation.

There are different methods of reconciling entries. You have already seen the reconciliation of entries while doing data entry in an account. Automatic and manual reconciliations are described here.
**Automatic Reconciliation**

For automatic reconciliation, you will be asking OpenERP to search for entries to reconcile in a series of accounts. OpenERP tries to find entries for each partner where the amounts correspond.

Depending on the level of complexity that you choose (= power) when you start running the tool, the software could reconcile from two to nine entries at the same time. For example, if you select level 5, OpenERP will reconcile for instance three invoices and two payments if the total amounts correspond. Note that you can also choose a maximum write-off amount, if you allow payment differences to be posted.

![Figure 13.6: Form for Automatic Reconciliation](image)

To start the reconciliation tool, click **Accounting → Periodical Processing → Reconciliation → Automatic Reconciliation**.

A form opens, asking you for the following information:

- **Accounts to Reconcile**: you can select one, several or all reconcilable accounts,
- the dates to take into consideration (Starting Date / Ending Date),
- the Reconciliation Power (from 2 to 9 ),
- checkbox Allow write off to determine whether you will allow for payment differences.
- information needed for the adjustment (details for the Write-Off Move).

**Note**: Reconciling

You can reconcile any account, but the most common accounts are:

- all the Accounts Receivable – your customer accounts of type Debtor,
- all the Accounts Payable – your supplier accounts of type Creditor.

The write-off option enables you to reconcile entries even if their amounts are not exactly equivalent. For example, OpenERP permits foreign customers whose accounts are in different currencies to have a difference of up to, say, 0.50 units of currency and put the difference in a write-off account.

**Tip**: Limit write-off adjustments

You should not make the adjustment limits too large. Companies that introduced substantial automatic write-off adjustments have found that all employee expense reimbursements below the limit were written off automatically!

**Note**: Default values

If you run the automatic reconciliation tool regularly, you should set default values for each field by pressing the Ctrl key and using the right-click mouse button (when the form is in edit mode using the web client), or just right-click using the GTK client. The resulting context menu enables you to set default values. This means that you will not have to retype all the fields each time.

**Manual Reconciliation**

For manual reconciliation, open the entries for reconciling an account through the menu **Accounting → Periodical Processing → Reconciliation → Manual Reconciliation**.
You can also call up manual reconciliation from any screen that shows accounting entries. Select entries that you want to reconcile. OpenERP indicates the sum of debits and credits for the selected entries. When these are equal you can click the Reconcile Entries button to reconcile the entries.

**Note:** Example Real Case of Using Reconciliation

Suppose that you are entering customer order details. You wonder what is outstanding on the customer account (that is the list of unpaid invoices and unreconciled payments). To review it from the order form, navigate to the Partner record and select the view Receivables and Payables. OpenERP opens a history of unreconciled accounting entries on screen.

![Figure 13.7: Unreconciled Accounting Entries](image)

After running the Reconcile Entries wizard, these lines can no longer be selected and will not appear when the entries are listed again. If there is a difference between the two entries, OpenERP suggests you to make an adjustment. This “write-off” is a compensating entry that enables a complete reconciliation. You must therefore specify the journal and the account to be used for the write-off.

For example, if you want to reconcile the following entries:

<table>
<thead>
<tr>
<th>Date</th>
<th>Ref.</th>
<th>Description</th>
<th>Account</th>
<th>Debit</th>
<th>Credit</th>
</tr>
</thead>
<tbody>
<tr>
<td>12 May 11</td>
<td>INV23</td>
<td>Car hire</td>
<td>4010</td>
<td>544.50</td>
<td></td>
</tr>
<tr>
<td>25 May 11</td>
<td>INV44</td>
<td>Car insurance</td>
<td>4010</td>
<td>100.00</td>
<td></td>
</tr>
<tr>
<td>31 May 11</td>
<td>PAY01</td>
<td>Invoices n° 23, 44</td>
<td>4010</td>
<td>644.00</td>
<td></td>
</tr>
</tbody>
</table>

On reconciliation, OpenERP shows a difference of 0.50. At this stage you have two possibilities:

- do not reconcile, and the customer receives a request for 0.50,
- reconcile and accept an adjustment of 0.50 that you will take from the P&L account.

OpenERP generates the following entry automatically:

<table>
<thead>
<tr>
<th>Date</th>
<th>Ref.</th>
<th>Description</th>
<th>Account</th>
<th>Debit</th>
<th>Credit</th>
</tr>
</thead>
<tbody>
<tr>
<td>03 Jun 11</td>
<td>AJ001</td>
<td>Adjustment: profits and losses</td>
<td>4010</td>
<td>0.50</td>
<td></td>
</tr>
<tr>
<td>03 Jun 11</td>
<td>AJ001</td>
<td>Adjustment: profits and losses</td>
<td>XXX</td>
<td></td>
<td>0.50</td>
</tr>
</tbody>
</table>

The two invoices and the payment will be reconciled in the first adjustment line. The two invoices will then be automatically marked as paid.

### 13.4 Payment Management

OpenERP gives you forms to prepare, validate and execute payment orders. This enables you to manage issues such as:

1. Payment provided on several due dates.
2. Automatic payment dates.
3. Separating payment preparation and payment approval in your company.
4. Preparing an order during the week containing several payments, then creating a payment file at the end of the week.
5. Creating a file for electronic payment which can be sent to a bank for execution.
6. Splitting payments depending on the balances available in your various bank accounts.

13.4.1 How to Manage your Payment Orders?

To use the tool for managing payments you must first install the module `account_payment`, or install `Supplier Payments` from the Configuration Wizard. It is part of the core OpenERP system.

The system lets you enter a series of payments to be carried out from your various bank accounts. Once the different payments have been registered you can validate the payment orders. During validation you can modify and approve the payment orders, sending the order to the bank for electronic funds transfer.

For example if you have to pay a supplier’s invoice for a large amount you can split the payments amongst several bank accounts according to their available balance. To do this you can prepare several Draft orders and validate them once you are satisfied that the split is correct.

This process can also be regularly scheduled. In some companies, a payment order is kept in Draft state and payments are added to the draft list each day. At the end of the week the accountant reviews and confirms all the waiting payment orders.

Once the payment order is confirmed there is still a validation step for an accountant to carry out. You could imagine that these orders would be prepared by an accounts clerk, and then approved by a manager to go ahead with payment.

**Tip:** Payment Workflow

An OpenERP workflow is associated with each payment order. Select a payment order and if you are in the GTK client click Plugins → Print workflow from the top menu.

You can integrate more complex workflow rules to manage payment orders by adapting the workflow. For example, in some companies payments must be approved by a manager under certain cash flow or value limit conditions.

![Workflow: Payment Order Workflow](image)

In small businesses it is usually the same person who enters the payment orders and who validates them. In this case you should just click the two buttons, one after the other, to confirm the payment.

13.4.2 Prepare and Transfer Orders

To enter a payment order, use the menu Accounting → Payment → Payment Orders.
OpenERP then proposes a reference number for your payment order. You then have to choose a payment mode from the various methods available to your company. These have to be configured when you set the accounting system up using menu Accounting → Configuration → Miscellaneous → Payment Mode. Some examples are:

- Cheques
- Bank transfer,
- Visa card on a bank account,
- Petty cash.

Then you set the Preferred date for payment:

- Due date: each operation will be effected at the invoice deadline date,
- Directly: the operations will be effected when the orders are validated,
- Fixed date: you must specify an effective payment date in the Scheduled date if fixed field that follows.

The date is particularly important for the preparation of electronic transfers because banking interfaces enable you to select a future execution date for each operation. So to configure your OpenERP most simply you can choose to pay all invoices automatically by their deadline.

You must then select the invoices to pay. They can be entered manually in the field Payment Line, but it is easier to add them automatically. For that, click Select Invoices to Pay and OpenERP will then propose lines with payment deadlines. For each deadline you can see:

- the invoice Effective date,
- the reference Ref. and description of the invoice, Name,
- the deadline for the invoice,
- the amount to be paid in the company’s default currency,
- the amount to be paid in the currency of the invoice.
You can then accept the payment proposed by OpenERP or select the entries that you will pay or not pay on that order. OpenERP gives you all the necessary information to make a payment decision for each line item:

- account,
- supplier’s bank account,
- amount that will be paid,
- amount to pay,
- the supplier,
- total amount owed to the supplier,
- due date,
- date of creation.

You can modify the first three fields on each line: the account, the supplier’s bank account and the amount that will be paid. This arrangement is very practical because it gives you complete visibility of all the company’s trade payables. You can pay only a part of an invoice, for example, and in preparing your next payment order OpenERP automatically suggests payment of the remainder owed.

When the payment has been prepared correctly, click **Confirm Payments**. The payment then changes to the Confirmed state and a new button appears that can be used to start the payment process. Depending on the chosen payment method, OpenERP provides a file containing all of the payment orders. You can send this to the bank to make the payment transfers.

In future versions of OpenERP it is expected that the system will be able to prepare and print cheques.

As usual, you can change the start point for the payment workflow from the Administration → Customization → Workflow menus.

Accounting is at the heart of managing a company: all the company’s operations have an impact here. It has an informational role (how much cash is there? what debts need to be repaid? what is the stock valuation?) and, because of the information it provides, a reliable and detailed accounting system can and should have a major decision-making role.

In most companies, accounting is limited to producing statutory reports and satisfying the directors’ curiosity about certain strategic decisions, and to printing the balance sheet and the income statement several times a year. Even then there is often several weeks of delay between reality and the report.

**Note:** **Valueing your accounting function**

In many small companies, the accounting function is poorly treated. Not only do you see the data for documents being entered into the system twice, but also the results are often just used to produce legal documents and regular printouts of the balance sheet and income statements some weeks after the closing dates.

By contrast, integrating your accounts with your management system means that you can:

- reduce data entry effort – you only need to do it once,
- run your processes with the benefit of financial vision: for example in managing projects, negotiating contracts, and forecasting cash flow,
- easily get hold of useful information when you need it, such as a customer’s credit position.

So accounting is too often underused. The information it brings makes it a very effective tool for running the company if it is integrated into the management system. Accounting information really is necessary in all of your company’s processes for it to be effective, for example:

- for preparing quotations it is important to know the precise financial position of the client, and to see a history of any delays in payment,
- if a given customer has exceeded its credit limit, accounting can automatically stop further deliveries to the customer,
- if a project budget is 80% consumed but the project is only 20% complete you could renegotiate with the client, or review and rein in the objectives of the project,
• if you need to improve your company’s cash flow then you could plan your service projects on the basis of billing rates and payment terms of the various projects, and not just delivery dates – you could work on short-term client projects in preference to R&D projects, for example.

OpenERP’s general accounting and analytic accounting handle these needs well because of the close integration between all of the application modules. Furthermore, the transactions, the actions and the financial analyses happen in real time, so that you can not only monitor the situation but also manage it effectively. The account module in OpenERP covers general accounting, analytic accounting, and auxiliary and budgetary accounting. It is double-entry, multi-currency and multi-company.

Note: Accounting
• General accounting (or financial accounting) is for identifying the assets and liabilities of the business. It is managed using double-entry accounting which ensures that each transaction is credited to one account and debited from another.
• Analytical accounting (or management accounting, or cost accounting) is an independent accounting system which reflects the general accounts but is structured along axes that represent the company’s management needs.
• Auxiliary accounting reflects the accounts of customers and/or suppliers.
• Budgetary accounts predefine the expected allocation of resources, usually at the start of a financial year.

Tip: Multi-company
There is a choice of methods for integrating OpenERP in a multi-company environment:
• if the companies hold few documents in common (such as products, or partners - any OpenERP resource), you could install separate databases,
• if the companies share many documents, you can register them in the same database and install OpenERP’s multi-company documents to finely manage access rights,
• you can synchronize specified document types in several databases using the base_synchro module.

One of the great advantages of integrating accounts with all of the other modules is in avoiding the double entry of data into accounting documents. So in OpenERP an Order automatically generates an Invoice, and the Invoice automatically generates the accounting entries. These in turn generate tax submissions, customer reminders, and so on. Such strong integration enables you to:

• reduce data entry work,
• greatly reduce the number of data entry errors,
• get information in real time and enable very fast reaction times (for bill reminders, for example),
• exert timely control over all areas of company management.

Tip: For accountants
You can configure the Accounting application using the information given in the configuration wizard.

With appropriate rights management, this allows trustees to provide customers with real-time access to their data. It also gives them the opportunity to work on certain documents that have no direct accounting impact, such as budgets.
This can provide an added-value service that greatly improves the interaction between trustees and their clients.

All the accounts are held in the default currency (which is specified in the company definition), but each account and/or transaction can also have a secondary currency (which is defined in the account). The value of multi-currency transactions is then tracked in both currencies.

For this chapter you should start with a fresh database that includes demo data, with Sales Management installed and a generic chart of accounts.
CHAPTER

FOURTEEN

FINANCIAL ANALYSIS

This chapter is dedicated to statutory taxation and financial reporting from OpenERP. Whether you need reports about customers and suppliers, or statements for various statutory purposes, OpenERP enables you to carry out a whole range of parametric analyses regarding the financial health of your company.

Whether you want to analyze the general health of your company or review the status of an Account Receivable in detail, your company’s accounts are the place to define your various business indicators.

To show you the most accurate picture of your business, OpenERP’s accounting reports are flexible, and the results are calculated in real time. This enables you to automate recurring actions and to change your operations quickly when a company-wide problem (such as cash reserves dropping too low or receivables climbing too high) or a local problem (a customer that has not paid, or a project budget overspend) occurs.

This chapter describes the various reports and financial statements supplied by OpenERP’s accounting modules. It also describes how OpenERP handles purchase and sales taxation, and the related tax reporting.

For this chapter you should start with a fresh database that includes demo data, with sale and its dependencies installed and no particular chart of accounts configured.

14.1 Reporting

Open ERP provides many tools for managing customer and supplier accounts. You will see here:

• financial analysis of partners, to understand the reports that enable you to carry out an analysis of all of your partners,

• multi-level reminders, which is an automatic system for preparing reminder letters or emails when invoices remain unpaid,

• detailed analysis of individual partners.

14.1.1 Financial Analysis of Partners

When members of your accounts department sign on to the Open ERP system, they can immediately be presented with the Accounting Dashboard. By default it contains a useful graph for analyzing Receivables. Then look at it using the menu Accounting → Reporting → Dashboard → Accounting Dashboard.
In the dashboard, the graph at the right entitled *Aged Receivables* represents your receivables week by week. That shows you at a glance the cumulative amount of your customer debtors by week.

All of Open ERP’s graphs are dynamic. So you can, for example, filter the data by clicking *Zoom* and then *Filter* on the Search form. Or just click on *Zoom* to open in a larger window for a graph, then click *Search* to display this in a list view.

To obtain a more detailed report of the aged balance (or order by past date) use the menu *Accounting → Reporting → Generic Reporting → Partners → Aged Partner Balance*.

When opening that report, Open ERP asks for the name of the company, the fiscal period and the size of the interval to be analyzed (in days). Open ERP then calculates a table of credit balance by period. So if you request an interval of 30 days Open ERP generates an analysis of creditors for the past month, past two months, and so on.

For an analysis by partner you can use the partner balance that you get through the menu *Accounting → Reporting → Generic Reporting → Partners → Partner Balance*. The system then supplies you with a PDF report containing one line per partner representing the cumulative credit balance.

If you want detailed information about a partner you can use the partner ledgers that you reach through the menu *Accounting → Reporting → Generic Reporting → Partners → Partner Ledger*.
Finally you can look up individual account entries by searching for useful information. To search for account entries:

You can use the menu Accounting → Reporting → Statistic Reports → Entries Analysis.

**Tip:** Exporting entries

It is helpful to remember that you can export all types of resource in Open ERP. From the web client you need to navigate to a search list for the resource then click the Export link at the bottom left of the list. From the GTK client you would use the menu Form → Export data. This enables you to easily make your own analysis in Microsoft Excel or OpenOffice.org Calc, by exporting accounting entries.

### 14.1.2 Multi-step Reminders

To automate the management of followups (reminders) you must install the module `account_followup`.

Once the module is installed configure your levels of followup using the menu Accounting → Configuration → Miscellaneous → Follow-Ups.

The levels of follow-up are relative to the date of creation of an invoice and not the due date. This enables you to put payment conditions such as ‘payable in 21 days’ and send a reminder in 30 days, or the converse.

For each level you should define the number of days and create a note which will automatically be added into the reminder letter. The sequence determines the order of the level in ascending order.

**Table 14.1: Example of configuring followup levels**

<table>
<thead>
<tr>
<th>Sequence</th>
<th>Level</th>
<th>Days</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Level 1</td>
<td>15 days net</td>
<td>First payment reminder</td>
</tr>
<tr>
<td>2</td>
<td>Level 2</td>
<td>30 days net</td>
<td>Second reminder</td>
</tr>
<tr>
<td>3</td>
<td>Level 3</td>
<td>45 days from end of month</td>
<td>Put on notice</td>
</tr>
</tbody>
</table>

You can send your reminders by mail and/or email with the menu Accounting → Periodical Processing → Billing → Send followups.

---

**Figure 14.4: Partner ledger**

**Figure 14.5: Form for preparing follow-up letters**
Open ERP presents you with a list of partners who are due reminders, which you can modify before starting the procedure. On the second tab of the form you can supply the information you will send in the email reminder.

The system then gives you a PDF report with all of the reminder letters for each partner. Each letter is produced in the language of the partner (if that is available) and you can therefore get letters in several languages in the same PDF on several pages.

You should check the due date of customers and/or suppliers before starting the reminder procedure. You get a list of unreconciled entries accounts. You can then modify the date and the last follow-up and the level of reminder for each entry.

To obtain a detailed statistical report of dent follow-ups use the menus in Accounting → Reporting → Generic Reporting → Partners → Follow-ups Sent.

The different reports are standard Open ERP screens, so you can filter them and explore the elements in detail.

![Summary screen for follow-ups](image)

**Figure 14.6: Summary screen for follow-ups**

### 14.1.3 Partner Information

In daily use of Open ERP a manager will often need to search quickly for financial information amongst partner data. For this she can use the buttons to the right of form when she opens a partner form, to go directly to:

- a follow-up letter from the Overdue payments Report button,
- the list of open Invoices,
- a shortcut to Journal Items,
- the unclosed CRM requests from Open cases,
- a shortcut to the unreconciled Receivables and Payables.

The exact links depend on the modules that are installed in Open ERP.

These links are also available to her using the navigation features such as right-clicking partner fields in the GTK client.

The Overdue payments report produces a PDF document which is used for follow-up but it does not modify any of the partner’s accounting entries. Its use does not increase the follow-up level so you can run this report repeatedly without any problem.

In Open ERP you can search for a partner on the basis of the value of its trade receivables. So search for partners with a credit amount between 1 and 99999999 and you will get a list of partners that owe you payment. You can then select the whole list and print follow-up letters for them all.

To the right of the partner form there is a shortcut to Invoices. This link includes all of the invoices defined in the systems, namely:

- customer invoices,
- supplier invoices,
• credit notes,
• supplier credit notes.

**Tip:** Reminders from accounting entries
Companies that do not have computerized records tend to keep track of payments from invoices and paperwork and not from a formal partner account. It is better to create reminder letters from a partner’s account receivable than from unpaid bills, however. By using the Open ERP system you can easily take account of all advances, unreconciled payments, credit notes and credit payments. So it is better to send a letter based on the accounting entries of invoices and unreconciled payments than just on a list of unpaid invoices.

In the links appearing on the partner form, two buttons enable the opening of partner accounting entries:

- **Journal Items**,
- **Receivables & Payables**.

The first button is useful for obtaining a historical analysis of the customer or supplier. You can get information about such significant items as sales volume and payment delays. The second button is a filter which shows only the open trade credits and debits for the partner.

### 14.2 Statutory Taxes and Chart of accounts

This section deals with statutory taxes and accounts which are legally required from the company:

• the taxation structure provided by Open ERP,
• the accounts ledgers,
• account balance (used to produce the income statement and balance sheet),
• the different journals (general, centralized and detailed),
• the tax declaration.

**Tip:** Other declarations
*In addition to the legal declarations available in the accounts modules, Open ERP supplies declarations based on the functionality in other modules. You can, for example, install the report_intrastat module for intra-stat declarations about sending goods to and receiving goods from other countries.*

### 14.2.1 Taxation

You can attach taxes to financial transactions so that you can

• add taxes to the amount that you pay or get paid,
• report on the taxes in various categories that you should pay the tax authorities,
• track taxes in your general accounts,
• manage the payment and refund of taxes using the same mechanisms that Open ERP uses for other monetary transactions.

Since the detailed tax structure is a mechanism for carrying out governments’ policies, and the collecting of taxes so critical to their authorities, tax requirements and reporting can be complex. Open ERP has a flexible mechanism for handling taxation that can be configured through its GUI or through data import mechanisms to meet the requirements of many various tax jurisdictions.

The taxation mechanism can also be used to handle other tax-like financial transactions, such as royalties to authors based on the value of transactions through an account.
Setting up a Tax Structure


Three main objects are involved in the tax system in Open ERP:

- a **Tax Case** (or **Tax Code**), used for tax reporting, that can be set up in a hierarchical structure so that multiple codes can be formed into trees in the same way as a Chart of Accounts.
- a **Tax**, the basic tax object that contains the rules for calculating tax on the financial transaction it is attached to, and is linked to the General Accounts and to the Tax Cases. A tax can contain multiple child taxes and base its calculation on those taxes rather than the base transaction, providing considerable flexibility. Each tax belongs to a **Tax Group** (currently just VAT or Other).
- the **General Accounts**, that record the taxes owing and paid. Since the general accounts are discussed elsewhere in this part of the book and are not tax-specific, they will not be detailed in this section.

You can attach zero or more **Supplier Tax** and **Customer Tax** items to products, so that you can account separately for purchase and sales taxes (or Input and Output VAT – where VAT is Value Added Tax). Because you can attach more than one tax, you can handle a VAT or Sales Tax separately from an Eco Tax on the same product.

Your Tax Declaration

Tax Cases are also known in Open ERP as Tax Codes. They are used for tax reporting, and can be set up in a hierarchical structure to form trees in the same way as a Chart of Accounts.

To create a new Tax Case, use the menu Accounting → Configuration → Financial Accounting → Taxes → Tax Codes. You define the following fields:

- **Tax Case Name**: a unique name required to identify the Case,
- **Company**: a required link that attaches the Case to a specific company, such as the Main Company,
- **Case Code**: an optional short code for the case,
- **Parent Code**: a link to a parent Tax Case that forms the basis of the tree structure like a Chart of Accounts,
- **Coefficient for parent**: choose 1.00 to add the total to the parent account or -1.00 to subtract it,
- **Description**: a free text field for documentation purposes.

You can also see two read-only fields:

- **Year Sum**: a single figure showing the total accumulated on this case for the financial year.
- **Period Sum**: a single figure showing the total accumulated on this case for the current financial period (perhaps 1 month or 3 months).

You will probably need to create two tax cases for each different tax rate that you have to define, one for the tax itself and one for the invoice amount that the tax is based on. And you will create tax cases that you will not link to Tax objects (similar to General Account View types) just to organize the tree structure.

To view the structure that you have constructed you can use the menu Accounting → Charts → Chart of Taxes. This tree view reflects the structure of the Tax Cases and shows the current tax situation.
Define Taxes

Tax objects calculate tax on the financial transactions that they are attached to, and are linked to the General Accounts and to the Tax Cases.

To create a new Tax Case, use the menu Accounting → Configuration → Financial Accounting → Taxes → Taxes.

![Figure 14.8: Definition of Tax](image)

You define the following fields:

- **Tax Name**: a unique name required for this tax (such as 12% Sales VAT),
- **Company**: a required link to a company associated with the tax, such as the Main Company,
- **Tax Type**: a required field directing how to calculate the tax: Percent, ‘Fixed’, None or Python Code, (the latter is found in the Compute Code field in the Special Computation tab),
- **Applicable Type**: a required field that indicates whether the base amount should be used unchanged (when the value is Always) or whether it should be processed by Python Code in the Applicable Code field in the Special Computation tab when the value is Given by Python Code),
- **Amount**: a required field whose meaning depends on the Tax Type, being a multiplier on the base amount when the Tax Type is Percent, and a fixed amount added to the base amount when the Tax Type is Fixed,
- **Include in base amount**: when checked, the tax is added to the base amount and not shown separately,
- **Domain**: is only used in special developments, not in the core Open ERP system,
- **Invoice Tax Account**: a General Account used to record invoiced tax amounts, which may be the same for several taxes or split so that one tax is allocated to one account,
- **Refund Tax Account**: a General Account used to record invoiced tax refunds, which may be the same as the Invoice Tax Account or, in some tax jurisdictions, must be separated,
- **Tax on Children**: when checked, the tax calculation is applied to the output from other tax calculations specified in the Childs Tax Account field (so you can have taxes on taxes), otherwise the calculation is applied to the base amount on the transaction,
- **Tax included in Price**: when checked, the total value shown includes this tax,
- **Tax Application**: selects whether the tax is applicable to Sale, Purchase or All transactions,
- **Child Tax Accounts**: other tax accounts that can be used to supply the figure for taxation.
Tip: Using Child Taxes
You can use child taxes when you have a complex tax situation that you want to hide your end users from. For example, you might define a motor mileage expenses product with a composite tax made up of two child taxes – a non-reclaimable private element and a reclaimable business element (which is the case in some European countries).
When your staff come to claim motor mileage, they do not need to know about this taxation, but the accounting impact of their claim will be automatically managed in Open ERP.

The fields above apply the taxes that you specify and record them in the general accounts but do not provide you with the documentation that your tax authorities might need. For this use the Tax Definition tab to define which Tax Cases should be used for this tax:

- **Account Base Code**: tax case to record the invoiced amount that the tax is based on,
- **Account Tax Code**: tax case to record the invoiced tax amount
- **Refund Base Code**: tax case to record the refund invoice amount that the tax is based on,
- **Refund Tax Code**: tax case to record the refund invoice tax amount.

Taxes on Products and Accounts

When you have created a tax structure consisting of Tax Cases and Tax objects, you can use the taxes in your various business objects so that financial transactions can be associated with taxes and tax-like charges.

Tip: Retail Customers
When you are retailing to end users rather than selling to a business, you may want to (or be required to) show tax-inclusive prices on your invoicing documents rather than a tax-exclusive price plus tax.

You can assign multiple taxes to a Product. Assuming you have set up the appropriate taxes, you would use the menu **Sales → Products → Products** to open and edit a Product definition, then:

- select one or more **Sale Taxes** for any products that you might sell, which may include a **Sales Tax** or **Output VAT**, and a **Sales Eco Tax**,
- select one or more **Purchase Taxes** for any products that you might purchase, which may include a **Purchase Tax** or **Input VAT**, and a **Purchase Eco Tax**.

Generally, when you make a purchase or sale, the taxes assigned to the product are used to calculate the taxes owing or owed.

Note: Tax regions

The third-party module **import_export** (currently in addons-extra can be used to extend Open ERP’s tax system, so that you can assign taxes to different accounts depending on the location of the Partner. The Partner is given a new Partner Location field that can be set to Local, Europe or Outside, so that taxes and tax bases can be channelled to different accounts.

This module could be the basis of more ambitious location-based tax accounting.

And you can assign multiple taxes to an account so that when you transfer money through the account you attract a tax amount. In such a case, this ‘tax’ may not be legally-required taxation but something tax-like, for example authors’ royalties or sales commission.

14.2.2 General Ledger and Trial Balance

To print the General Ledger you can use the menu **Accounting → Reporting → Legal Reports → Accounting Reports → General Ledger**. You will find the following wizard which is used to filter the resulting report.
Select the proper option and journal from the above wizard to print the **General Ledger**.

**Figure 14.10: General Ledger**

**Tip:** Simulated balance

While you are printing account balances, if you have installed the `account_simulation` module from addons-extra, Open ERP asks you which level of simulation to execute. Results will vary depending on the level selected. You could, for example, print the balance depending on various methods of amortization:

- the normal IFRS method,
- the French method.

More generally it enables you to make analyses using other simulation levels that you could expect.

To print the **Trial Balance** you can use this menu **Accounting → Reporting → Legal Reports → Accounting Reports → Trial Balance**. This report allows you to print or generate a pdf of your trial balance allowing you to quickly check the balance of each of your accounts in a single report.
14.2.3 The Accounting Journals

To configure the different journals use the menu Accounting → Configuration → Financial Accounting → Journals → Journals.

Note: Journals

Note there are different types of journal in Open ERP

• accounting journals (detailed in this chapter),
• purchase journals (for distributing supplies provided on certain dates),
• sales journals (for example classifying sales by their type of trade),
• the invoice journals (to classify sales by mode of invoicing - daily / weekly / monthly - and automating the tasks).

To get access to these different journals install the modules sale_journal (found at the time of writing in addons, so available in a standard installation) and purchase_journal (found in addons-extra at the time of writing, so needing special installation).

OpenERP provide three main reports regarding the journals:

• To print Journals using menu Accounting → Reporting → Legal Reports → Journals → Journals.

• To print General Journals using menu Accounting → Reporting → Legal Reports → Journals → General Journals.
• To print Centralizing Journal using menu Accounting → Reporting → Legal Reports → Journals → Centralizing Journal.

14.2.4 Tax Declaration

Information required for a tax declaration is automatically generated by Open ERP from invoices. In the section on invoicing you will have seen that you can get details of tax information from the area at the bottom left of an invoice.

You can also get the information from the accounting entries in the columns to the right.

Open ERP keeps a tax chart that you can reach from the menu Accounting → Charts → Chart of Accounts. The structure of the chart is for calculating the tax declaration but also all the other taxes can be calculated (such as the French DEEEE).

![Figure 14.14: Example of a Belgian TVA (VAT) declaration](image)

The tax chart represents the amount of each area of the tax declaration for your country. It is presented in a hierarchical structure which lets you see the detail only of what interests you and hides the less interesting subtotals. This structure can be altered as you wish to fit your needs.

You can create several tax charts if your company is subject to different types of tax or tax-like accounts, such as:

• authors’ rights,

• ecotaxes such as the French DEEE for recycling electrical equipment.

Each accounting entry can then be linked to one of the tax accounts. This association is done automatically by the taxes which had previously been configured in the invoice lines.

Tip: Tax declaration
Some accounting software manages the tax declaration in a dedicated general account. The declaration is then limited to the balance in the specified period. In Open ERP you can create an independent chart of taxes, which has several advantages:

• it is possible to allocate only a part of the tax transaction,

• it is not necessary to manage several different general accounts depending on the type of sale and type of tax,

• you can restructure your chart of taxes as you need.

At any time you can check your chart of taxes for a given period using the report Accounting → Reporting → Generic Reporting → Taxes → Taxes Reports.

This data is updated in real time. That is very useful because it enables you to preview at any time the tax that you owe at the start and end of the month or quarter.
Furthermore, for your tax declaration you can click on one of the tax accounts to investigate the detailed entries that make up the full amount. This helps you search for errors such as when you have entered an invoice at full tax rate when it should have been zero-rated for an inter-community trade or for a charity.

In some countries, tax can be calculated on the basis of payments received rather than invoices sent. In this instance choose Base on Payments instead of Base on Invoices in the Select period field. Even if you make your declaration on the basis of invoices sent and received it can be helpful to compare the two reports to see the amount of tax that you pay but haven’t yet received from your customers.

14.3 Company Financial Analysis

You will see here the analysis tools for your company’s financial situation, in particular:

- Management Indicators
- Budgets
- The Accounting Dashboard

14.3.1 Management Indicators

Note: Financial Indicators
Indicators, sometimes called financial ratios, are tools for analyzing a company’s finances. They enable you to compare two accounts or sets of accounts from the balance sheet or the profit and loss account, in the form of a ratio. They also let you measure the financial health of a company and make comparisons from one year to the next or against those of other companies.

To define financial indicators in Open ERP you should install the module account_report. When installing the module the usual financial indicators are registered in Open ERP.

You can consult your indicators, calculated in real time, from the menu Financial Management ‒> Reporting ‒> Custom Reports.

Indicators defined by default in Open ERP are the following:

- **Indicators of Working Capital**: determines if the company can pay its short term debts in normal conditions. It is calculated from \((\text{Stocks} + \text{Cash} + \text{Current Assets}) / \text{Current Liabilities}\).

- **Financial Ratios**: enables you to calculate the company’s liquidity. It is defined as follows: \((\text{Current Assets} - \text{Stocks}) / \text{Current Liabilities}\).

- **Fixed Assets**: in a going concern, the value of fixed assets are covered in the first place by owners’ capital and in the second place by all of the long term liabilities. Ideally this indicator will be greater than 1.

Tip: Calculation of indicators
Calculating indicators can take quite a while in Open ERP because you have to analyse the whole company’s accounting entries. So it is best not to calculate all of the indicators at once, but just a small selection to keep calculation time within limits.

Time analysis of indicators

You can analyze the financial indicators along two axes. You must have a figure calculated at a particular instant of time when you compare accounts, balances and the ratios between them. But you can also calculate a time series to follow the change of a given indicator throughout the life of the company. To do a temporal analysis of your indicators, you must install the module account_report from the set of modules in addons-extra.

Once this module is installed, you can click on a financial indicator to get a graph of its evolution in time.
Defining your own indicators

You can define your own indicators in Open ERP using the menu Accounting → Reporting → Generic Reporting → Reporting → Custom reporting.

You should make sure that the accounts that you base indicators on are given unique account codes, because codes are used in the creation of formulae. Create a formula using the syntax indicated in the instructions at the bottom of the form:

- Sum of debits in a general account: `debit('12345')`,
- Sum of credits in a general account: `credit('12345')`,
- Balance of a general account: `balance('12345')`,
- Value of another indicator: `report ('IND')`.

where:

- 12345 represents the code of a general account,
- IND represents the code of another indicator.

So, using this notation, the cash ratio is defined by `balance('4', '5') / balance('1')` – that is the balance in accounts 4 and 5 divided by the balance in account 1.

14.3.2 Good Management Budgeting

Open ERP manages its budgets using both General and Analytic Accounts. You will see how to do this here for General Accounts and then in Analytic Accounts for Analytical Accounts. Install `account_budget` to be able to do this.
Use the menu Accounting → Budgets → Budgets to define a new budget by clicking on New button.

![Budget form](image1)

**Figure 14.17: Budget form**

**Tip: Budget Revisions**

Even though you can modify a budget at any time to make a revision of it, it is best if you do not do that. Rather than edit an existing budget document, make a new version so that you can keep your original estimates safe for comparison. This lets you analyze your changing perspectives of the company from revision to revision.

Begin data entry by entering a Name, a Code, and a Start Date and an End Date in your new budget. Then you can define the budgeted amounts within that period, one by one. For each, you define:

- an Analytic Account
- a Budgetary Position: for example Sales or Purchases,
- a Start Date and End Date for the use of the budget,
- a Planned Amount in the default currency of the chart of accounts.

Once it is completed you can save your budget.

To print a budget and make calculations of expenditure to budget use the menu Accounting → Budgets → Budgets Open ERP then gives you a list of available budgets. Select one or more budgets and then click Print Budgets to create the report for each in a date range of your choosing. The figure Printing a budget gives an example of a budget produced by Open ERP.

![Printing a budget](image2)

**Figure 14.18: Printing a budget**

You could also use the menu Accounting → Reporting → Generic Reporting → Budgets → Budget Lines. This gives a budgetary analysis report for each budget line.
14.3.3 The Accounting Dashboard

You can open the Accounting Dashboard using the menu Accounting → Reporting → Dashboard → Accounting dashboard.

![Accounting Dashboard](image)

Figure 14.19: Accounting Dashboard

Open ERP gives you an accounting dashboard that can be presented to your accounting staff as they sign into the system (if you have set it as their Home Page). This dashboard provides an analysis of the company’s financial health at a glance.

The description of the different parts of the dashboard, from top to bottom then from left to right is as follows:

- **Customer Invoices to Approve**: gives the list of invoices waiting to be approved by an accountant.
- **Company Analysis**: gives the credit, debit and balance of all account type.
- **Treasury**: shows balance per Account
- **Aged receivables**: gives a weekly graph of the receivables that haven’t yet been reconciled.

In each panel of the Accounting Dashboard you can click the Zoom button at the top right to investigate the detail of your financial indicators.

The Accounting Dashboard is dynamically integrated, which means that you can navigate easily through the data if you want more detail about certain factors, and edit the entries if necessary.
Accounts must be configured to meet your company’s needs. This chapter explains how to modify your chart of accounts, journals, access rights, initial account balances, and default values for the initial configuration of your Open ERP accounts.

Assuming that it calculates sufficiently accurately, the best accounting software would be marked out by its usability and simplicity of data entry, and flexibility in configuring its different components. You would be able to easily modify the accounting module to meet your own needs so that you could optimize it for the way you want to use it.

Open ERP lets you adapt and reconfigure many functions to ease the task of data entry:

- adding controls for data entry,
- customizing the screens,
- filling fields automatically during data entry with data that is already known to the system.

For this chapter you should start with a fresh database that includes demo data, with sale and its dependencies installed and no particular chart of accounts configured.

### 15.1 Chart of Accounts

You view active charts of accounts using the menu Account → Charts → Charts of Accounts, and Open Charts for the selected year and account moves.

**Note:** Hierarchical charts

Most accounting software packages represent their charts of accounts in the form of a list. You can do this in Open ERP as well if you want to, but its tree view offers several advantages:

- it lets you show and calculate only the accounts that interest you,
- it enables you to get a global view of accounts (when you show only summary accounts),
- it simplifies searches semantically,
- it is more intuitive, because you can search for accounts on the basis of their classification,
- it is flexible because you can easily restructure them.

The structure of the chart of accounts is hierarchical, with account subtotals called account views. You can develop a set of account views to contain only those elements that interest you.

To get the detail of the account entries that are important to you, all you need to do is click the account’s Code (if you have no codes, you can select the line, then click Switch to get the account definition, then click the Entries in the LINKS part of the toolbar).

Displaying the chart of accounts can take several seconds because Open ERP calculates the debits, credits and balance for each account in real time.
15.1.1 Using a Preconfigured Chart of Accounts

On installation, the software is given a default chart of accounts that is the same regardless of your country. To install the chart of accounts and tax definitions for your own country install the module `l10n_XX` where `XX` represents your country code in two letters. For example to get the chart of accounts for France install the module `l10n_fr`.

Some of these pre-built modules are comprehensive and accurate, others have rather more tentative status and are simply indicators of the possibilities. You can modify these, or build your own accounts onto the default chart, or replace it entirely with a custom chart.

15.1.2 Creating a Chart of Accounts

To add, modify or delete existing accounts, use the menu `Accounting → Configuration → Financial Accounting → Accounts → Accounts`.

![Figure 15.1: Definition of an account](image)

**Tip:** Multi-lingual fields

In Open ERP multi-lingual fields are marked by a small flag to their right. Click on the flag to get a translation of the value of the field in the different installed languages. You can also edit the translation. This enables you to efficiently manage other languages as you need them. The field’s value appears in the language of the logged-in user or, in the case of reports printed for a partner, that of the partner.

The main account fields are:

- **Name**: Gives the account a name.
- **Account Type**: account types determine an account’s use in each journal. By default the following types are available `View`, `Receivable`, `Payable`, `Income`, `Expense`, `Tax`, `Cash`, `Asset`, `Equity`. You can add new types through the menu `Accounting → Configuration → Financial Accounting → Accounts → Account Types`. Use the `View` type for accounts that make up the structure of the charts and have no account data inputs of their own.
- **Internal Type**: internal types has special effects in OpenERP. By default the following types are available `View`, `Regular`, `Receivable`, `Payable`, `Liquidity`, `Consolidation`, `Closed`. 

---

182
Note: Type of account
The account types are mainly used as an informative title. The only two types that have any particular effect are Receivables and Payables.
These two types are used by reports on partner credits and debits. They are calculated from the list of unreconciled entries in the accounts of one of these two types.

- **Code**: the code length is not limited to a specific number of digits. Use code 0 for all root accounts.
- **Secondary Currency**: forces all the moves for this account to have this secondary currency.
- **Reconcile**: determines if you can reconcile the entries in this account. Activate this field for partner accounts and for chequing (checking) accounts.
- **Parents**: determines which account is the parent of this one, to create the tree structure of the chart of accounts.
- **Default Taxes**: this is the default tax applied to purchases or sales using this account. It enables the system to generate tax entries automatically when entering data in a journal manually.

The tree structure of the accounts can be altered as often and as much as you wish without recalculating any of the individual entries. So you can easily restructure your account during the year to reflect the reality of the company better.

### 15.1.3 Virtual Charts of Accounts

The structure of a chart of accounts is imposed by the legislation in effect in the country of concern. Unfortunately that structure does not always correspond to the view that a company’s CEO needs.

In Open ERP you can use the concept of virtual charts of accounts to manage several different representations of the same accounts simultaneously. These representations can be shown in real time with no additional data entry.

So your general chart of accounts can be the one imposed by the statutes of your country, and your CEO can then have other virtual charts as necessary, based on the accounts in the general chart. For example the CEO can create a view per department, a cash-flow and liquidity view, or consolidated accounts for different companies.

The most interesting thing about virtual charts of accounts is that they can be used in the same way as the default chart of accounts for the whole organization. For example you can establish budgets from your consolidated accounts or from the accounts from one of your companies.

**Tip:** Virtual accounts

Virtual accounts enable you to provide different representations of one or several existing charts of accounts. Creating and restructuring virtual accounts has no impact on the accounting entries. You can then use the virtual charts with no risk of altering the general chart of accounts or future accounting entries. Because they are used only to get different representation of the same entries they are very useful for:

- consolidating several companies in real time,
- depreciation calculations,
- cash-flow views,
- getting more useful views than those imposed by statute,
- presenting summary charts to other users that are appropriate to their general system rights.

So there are good reasons for viewing the execution of financial transactions through virtual charts, such as budgets and financial indicators based on special views of the company.

To create a new chart of accounts you should create a root account using the menu Accounting → Configuration → Financial Accounting → Accounts → Accounts. Your top level account should have Code 0 and Type View. Then you can choose your structure by creating other accounts of Type View as necessary. Check your virtual structure using the menu Financial Management → Charts → Charts of Accounts.

You have to set Internal Type = Consolidation and set Consolidated Children Accounts to make Account Consolidate.

Finally, when you have got your structure, you must make the general accounts and virtual accounts match. For that search the general accounts and ensure that each non-View account there also has a virtual account in the...
field *Parents*.

You can then check through your general chart of accounts as well as your virtual charts which give you another representation of the company. All the actions and states in your general account are also available in the virtual accounts.

Finally you can also make virtual charts of accounts from other virtual charts. That can give an additional dimension for financial analysis.

### 15.2 Journals

All your accounting entries must appear in an accounting journal. So you must, at a minimum, create a Sales Journal for customer invoices, a Purchase Journal for supplier invoices and a Cash Journal for cash and bank transactions.

#### 15.2.1 Configuring a Journal

To view, edit or create new journals use the menu *Accounting* → *Configuration* → *Financial Accounting* → *Journals* → *Journals*.

![Figure 15.2: Definition of an accounting journal](image)

You have to associate a view with each journal. The journal view indicates the fields that must be visible and required to enter accounting data in that journal. The view determines both the order of the fields and the properties of each field. For example the field *Account Number* must appear when entering data in the bank journal but not in the other journals.

Before creating a new view for a journal check that there is nothing similar already defined for another journal. You should only create a new view for new types of journal.

**Note:** Customizing views

You will often have to edit a journal view. For example, for a journal in a foreign currency you add a field for the currency and this currency must be in the journal view.

Conversely, to simplify data entry the journal view for the bank is quite different from one of the invoicing journals.

You can create a sequence for each journal. This sequence gives the automatic numbering for accounting entries. Or several journals can use the same sequence if you want to define one for them all.

The credit and debit account by default permit the automatic generation of counterpart entries when you are entering data in the journal quickly. For example, in a bank journal you should put an associated bank account for default matching credits and debits, so that you do not have to create counterparts for each transaction manually.
A journal can be marked as being centralized. When you do this, the counterpart entries will not be owned by each entry but globally for the given journal and period. You will then have a credit line and a debit line centralized for each entry in one of these journals, meaning that both credit and debit appear on the same line.

### 15.2.2 Controls and tips for Data Entry

You can carry out two types of control on Journals in Open ERP – controls over the financial accounts and access controls for groups of users. In addition to these controls you can also apply all of the rights management detailed in *Configuration & Administration*.

To avoid mistakes while entering accounts data, you can place conditions in the general accounts about who can use a given account. To do this, you must list all the accounts or valid account types in the second tab, *Entry Controls*. If you have not added any accounts there, Open ERP applies no restriction on data entry in the accounts or journals. If you list accounts and the types of account that can be used in a journal, Open ERP prevents you from using any account not in that list. This verification step starts from the moment you save the entry.

This functionality is useful for limiting possible data entry errors. Also, in a bank journal it is possible to restrict the accounts that can be linked to a bank to classes 1 to 5. Using this you would help prevent the user from making any false entries in the journal.

**Tip:** Control of data entry

In accounting it is not a good idea to allow a data entry directly from bank account A to bank account B. If you enter a transaction from bank A to bank B the transaction will be accounted for twice. To prevent this problem, pass the transaction through intermediate account C. At the time of data entry the system checks the type of account that is accepted in the bank journal: only accounts that are not of type Bank are accepted.

If your accountant defines this control properly, non-accounting users are prevented from transferring payment from one bank to another, reducing your risks.

### 15.3 Periods and Financial Years

**Note:** Periods and fiscal years

A fiscal year corresponds to twelve months for a company. In many countries, the fiscal year corresponds to a calendar year. That is not the case in others.

The fiscal year is divided into monthly or three-monthly accounting periods.

Open ERP’s management of the fiscal year is flexible enough to enable you to work on several years at the same time. This gives you several advantages, such as creating three-year budgets, and statements straddling several calendar years.

### 15.3.1 Defining a Period or a Financial Year

To define your fiscal year use the menu *Accounting → Configuration → Financial Accounting → Periods → Fiscal Year*. You can create several years in advance to define long-term budgets.
Figure 15.3: Defining a financial year and periods

First enter the date of the first day of your fiscal year and the last day. Then to create the periods click one of the two buttons at the bottom depending on whether you want to create twelve 1-month or four 3-month periods:

- Create monthly periods
- Create 3-monthly periods

15.3.2 Closing a Financial Year

To close the end the year, use the menu Accounting → Periodical Processing → End of Period → Close a Fiscal Year. A wizard opens asking you for the essential information it needs to close the following year.

When the year is closed you can no longer create or modify any financial transactions in that year. So you should always make a backup of the database before closing the fiscal year. Closing a year is not obligatory and you could easily do that sometime in the following year when your accounts are finally sent to the statutory authorities, and no further modifications are permitted.

Figure 15.4: Closing a financial year

It is also possible to close an accounting period. You could for example close a monthly period when a tax declaration has been made. When a period is closed you can not modify any of the entries in that period. To close an accounting period use the menu Accounting → Periodical Processing → End of Period → Close a Period.

15.4 Payment Terms

You can define whatever payment terms you need in Open ERP. Payment terms determine the due dates for paying an invoice.

To define new payment terms, use the menu Accounting → Configuration → Miscellaneous → Payment Terms and then click New.
The figure below represents the following payment term: 5000 within 5 days, 50% payment at the last day of current month, Remaining on 15th of next month.

Figure 15.5: Configuring payment terms

To configure new conditions start by giving a name to the Payment Term field. Text that you put in the field Description is used on invoices, so enter a clear description of the payment terms there.

Then create individual lines for calculating the terms in the section Payment Term. You must give each line a name (Line Name). These give an informative title and do not affect the actual calculation of terms. The Sequence field lets you define the order in which the rules are evaluated.

The Valuation field enables you to calculate the amount to pay for each line:

- **Percent**: the line corresponds to a percentage of the total amount, the factor being given in Value Amount. The number indicated in the Amount must take a value between 0 and 1.
- **Fixed Amount**: this is a fixed value given by the Value Amount box.
- **Balance**: indicates the balance remaining after accounting for the other lines.

Think carefully about setting the last line of the calculation to Balance to avoid rounding errors. The highest sequence number is evaluated last.

The two last fields, Number of Days and Day of the Month, enable the calculation of the delay in payment for each line. The delay Day of the Month can be set to -1, 0 or Any Positive Number. For example today is 20 December 2010, if you want to set payment terms like this:

- **5000 within 5 days** then set Valuation is Fixed Amount, Number of Days 5 and Day of the Month is 0 that creates journal entry for date 25th December 2010.
- **50% payment at the last day of current month** then set Valuation Percent, Number of Days 0 and Day of the Month is -1 that creates journal entry for date 31th December 2010.
- **Remaining on 15th of next month** then set Valuation Balance, Number of Days 0 and Day of the Month is 15 that creates journal entry for date 15th January 2011.

You can then add payment terms to a Partner through the tab Accounting on the partner form.

### 15.5 Opening Entries

To upgrade your various accounts, create a Journal of type Opening/Closing Situation in Centralized counterpart mode to avoid a counterpart on each line.

For each account that needs upgrading, enter account data in the journal. For this operation use the menu Accounting → Journal Entries → Journal Items.

You can also use Open ERP’s generic import tool if you load the balance of each of your accounts from other accounting software.
Example Steps:

1. **Accounting → Configuration → Financial Accounting → Periods → Fiscal Year**: Create a fiscal Year with monthly periods.

2. **Accounting → Configuration → Financial Accounting → Accounts → Accounts**: Create an account ‘Opening Balance Account’ (Account Type: 'Equity' (not sure about that, but it is working)), Reconcile: ‘No’.


4. **Best to create a csv-file with the first line**: “Account”,”Effective date”,”Journal”,”Name”,”Period”,”Debit”,”Credit”

   And the data-lines like this: “1000”,”2008-01-16”,”Opening Bal Journal”,”Opening Balance Entry”,”01/01 - 31/01”,”0”,”53828


6. **Menu Form -> Import data**: Choose the file to import, ‘Auto Detect’, ‘Ok’.
Part V

Effective Management of Operations
Your company is a closely interlinked jumble of people and processes that form the whole system. If you want it to be efficient, and to be able manage it effectively, you have to organize it, make it systematic, and optimize its major operations. Isolated spots of poor management can disturb the whole added value chain.

This part presents an approach to greater efficiency, showing concrete solutions by applying Open ERP to different problems in a services company. For each enterprise function, Open ERP enables you to automate the recurring tasks, systematize complex processes, simplify the transmission of information, and control all your operations.
Sitting at the heart of your company's processes, analytic accounts (or cost accounts) are indispensable tools for managing your operations well. Unlike your financial accounts they are for more than accountants - they are for general managers and project managers, too.

You need a common way of referring to each user, service, or document to integrate all your company’s processes effectively. Such a common basis is provided by analytic accounts (or management accounts, or cost accounts, as they are also called) in Open ERP.

Analytic accounts are often presented as a foundation for strategic enterprise decisions. But because of all the information they pull together, Open ERP’s analytic accounts can be a useful management tool, at the center of most system processes.

There are several reasons for this:

- they reflect your entire management activity,
- unlike the general accounts, the structure of the analytic accounts is not regulated by legal obligations, so each company can adapt it to its needs.

**Note:** Independence from general accounts

In some software packages, analytic accounts are managed as an extension of general accounts – for example, by using the two last digits of the account code to represent analytic accounts. In Open ERP, analytic accounts are linked to general accounts but are treated totally independently. So you can enter various different analytic operations that have no counterpart in the general financial accounts.

While the structure of the general chart of accounts is imposed by law, the analytic chart of accounts is built to fit a company’s needs closely.

Just as in the general accounts, you will find accounting entries in the different analytic accounts. Each analytic entry can be linked to a general account, or not, as you wish. Conversely, an entry in a general account can be linked to one, several, or no corresponding analytic accounts.

You will discover many advantages of this independent representation below. For the more impatient, here are some of those advantages:

- you can manage many different analytic operations,
- you can modify an analytic plan on the fly, during the course of an activity, because of its independence,
- you can avoid an explosion in the number of general accounts,
- even those companies that do not use Open ERP’s general accounts can use the analytic accounts for management.

**Tip:** Who benefits from analytic accounts?

Unlike general accounts, analytic accounts in Open ERP are not so much an accounting tool for Accounts as a management tool for everyone in the company. (That is why they are also called management accounts.) The main users of analytic accounts should be the directors, general managers and project managers.
Analytic accounts make up a powerful tool that can be used in different ways. The trick is to create your own analytic structure for a chart of accounts that closely matches your company’s needs.

For this chapter you should start with a fresh database that includes demo data, with sale and its dependencies installed and no particular chart of accounts configured.

### 16.1 To each enterprise its own Analytic Chart of Accounts

To illustrate analytic accounts clearly, you will follow three use cases, each in one of three different types of company:

1. Industrial Manufacturing Enterprise.
2. Law Firm.
3. IT Services Company.

#### 16.1.1 Case 1: Industrial Manufacturing Enterprise

In industry, you will often find analytic charts of accounts structured into the departments and products that the company itself is built on.

So the objective is to examine the costs, sales and margins by department and by product. The first level of the structure comprises the different departments and the lower levels represent the product ranges that the company makes and sells.

**Note:** Analytic chart of accounts for an industrial manufacturing company

- 1. Marketing Department
- 2. Commercial Department
- 3. Administration Department
- 4. Production
  - Product Range 1
  - Sub-groups
  - Product Range 2

In daily use it is useful to mark the analytic account on each purchase invoice. The analytic account is the one to which the costs of that purchase should be allocated. When the invoice is approved it will automatically generate the entries for both the general and the corresponding analytic accounts. So, for each entry on the general accounts there is at least one analytic entry that allocates costs to the department that incurred them.

Here is a possible breakdown of some general accounting entries for the example above, allocated to various analytic accounts:

<table>
<thead>
<tr>
<th>General accounts</th>
<th>Account</th>
<th>Debit</th>
<th>Credit</th>
<th>Analytic accounts</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Purchase of Raw Material</td>
<td>600</td>
<td>1500</td>
<td></td>
<td>Production / Range 1</td>
<td>-1500</td>
</tr>
<tr>
<td>Subcontractors</td>
<td>602</td>
<td>450</td>
<td></td>
<td>Production / Range 2</td>
<td>-450</td>
</tr>
<tr>
<td>Credit Note for defective materials</td>
<td>600</td>
<td></td>
<td>200</td>
<td>Production / Range 1</td>
<td>200</td>
</tr>
<tr>
<td>Transport charges</td>
<td>613</td>
<td>450</td>
<td></td>
<td>Production / Range 2</td>
<td>-450</td>
</tr>
<tr>
<td>Staff costs</td>
<td>6201</td>
<td>10000</td>
<td></td>
<td>Marketing</td>
<td>-2000</td>
</tr>
<tr>
<td>PR</td>
<td>614</td>
<td>450</td>
<td></td>
<td>Commercial</td>
<td>-3000</td>
</tr>
</tbody>
</table>

The analytic representation by department enables you to investigate the costs allocated to each department in the company.
So the analytic chart of accounts shows the distribution of the company’s costs using the example above:

Table 16.2: Analytic chart of accounts
(Case 1)

<table>
<thead>
<tr>
<th>Account</th>
<th>Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>Marketing Department</td>
<td>-2 450</td>
</tr>
<tr>
<td>Commercial Department</td>
<td>-3 000</td>
</tr>
<tr>
<td>Administration Department</td>
<td>-1 000</td>
</tr>
<tr>
<td>Production</td>
<td>-6 200</td>
</tr>
<tr>
<td>Product Range 1</td>
<td>-3 750</td>
</tr>
<tr>
<td>Product Range 2</td>
<td>-2 450</td>
</tr>
</tbody>
</table>

In this example of a hierarchical structure in Open ERP you can analyze not only the costs of each product range but also the costs of the whole of production. The balance of a summary account (Production) is the sum of the balances of the child accounts.

A report that relates both general accounts and analytic accounts enables you to get a breakdown of costs within a given department. An analysis of the Production / Product Range 1 department is shown in this table:

Table 16.3: Report merging both general and analytic accounts for a department (Case 1)

<table>
<thead>
<tr>
<th>Production / Product Range 1</th>
<th>Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Account</td>
<td>-1 300</td>
</tr>
<tr>
<td>600 – Raw Materials</td>
<td>- 450</td>
</tr>
<tr>
<td>613 – Transport charges</td>
<td>- 450</td>
</tr>
<tr>
<td>6201 – Staff costs</td>
<td>- 200</td>
</tr>
<tr>
<td>Total</td>
<td>- 3 750</td>
</tr>
</tbody>
</table>

The examples above are based on a breakdown of the costs of the company. Analytic allocations can be just as effective for sales. That gives you the profitability (sales - costs) of different departments.

**Note:** Representation by unique product range

This analytic representation by department and by product range is usually used by trading companies and industries.

A variant of this is not to break it down by sales and marketing departments but to assign each cost to its corresponding product range. This will give you an analysis of the profitability of each product range. Choosing one over the other depends on how you look at your marketing effort. Is it a global cost allocated in some general way or does each product range have responsibility for its own marketing costs?

### 16.1.2 Case 2: Law Firm

Law firms generally adopt management by case where each case represents a current client file. All of the expenses and products are then attached to a given file.

A principal preoccupation of law firms is the invoicing of hours worked and the profitability by case and by employee.

Mechanisms used for encoding the hours worked will be covered in detail in the following chapter, *Lead & Inspire your People*. Like most system processes, hours worked are integrated into the analytic accounting. Every time an employee enters a timesheet for a number of hours, that automatically generates analytic accounts corresponding to the cost of those hours in the case concerned. The hourly charge is a function of the employee’s salary. So a law firm will opt for an analytic representation which reflects the management of the time that employees work on the different client cases.
**Note:** Example Representation of an analytic chart of accounts for a law firm

1. **Absences**
   - Paid Absences
   - Unpaid Absences

2. **Internal Projects**
   - Administrative
   - Others

3. **Client cases**
   - Client 1
     - Case 1.1
     - Case 1.2
   - Client 2
     - Case 2.1

All expenses and sales are then attached to a case. This gives the profitability of each case and, at a consolidated level, of each client.

Billing for the different cases is a bit unusual. The cases do not match any entry on the general account and nor do they come from purchase or sale invoices. They are represented by the various analytic operations and do not have exact counterparts in the general accounts. They are calculated on the basis of the hourly cost per employee. These entries are automatically created on billing worksheets.

At the end of the month when you pay salaries and benefits, you integrate them into the general accounts but not in the analytic accounts, because they have already been accounted for in billing each account. A report that relates data from the analytic and general accounts then lets you compare the totals, so you can readjust your estimates of hourly cost per employee depending on the time actually worked.

The following table gives an example of different analytic entries that you can find for your analytic account:

<table>
<thead>
<tr>
<th>Title</th>
<th>Account</th>
<th>Amount</th>
<th>General Account</th>
<th>Debit</th>
<th>Credit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Study the file (1 h)</td>
<td>Case 1.1</td>
<td>-15</td>
<td>705 – Billing services</td>
<td></td>
<td>280</td>
</tr>
<tr>
<td>Search for information (3 h)</td>
<td>Case 1.1</td>
<td>-45</td>
<td>601 – Furniture purchase</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Consultation (4 h)</td>
<td>Case 2.1</td>
<td>-60</td>
<td>613 – Transports</td>
<td>42</td>
<td></td>
</tr>
<tr>
<td>Service charges</td>
<td>Case 1.1</td>
<td>280</td>
<td>6201 – Salaries</td>
<td>35</td>
<td>3 000</td>
</tr>
<tr>
<td>Stationery purchase</td>
<td>Administrative</td>
<td>-42</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Fuel Cost -Client trip</td>
<td>Case 1.1</td>
<td>-35</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Staff salaries</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

You will see that it allows you to make a detailed study of the profitability of different transactions. In this example the cost of Case 1.1 is 95.00 (the sum of the analytic costs of studying the files, searching for information and service charges), but has been invoiced for 280.00, which gives you a gross profit of 185.00.

But an interest in analytical accounts is not limited to a simple analysis of the profitability of different cases.

This same data can be used for automatic recharging of the services to the client at the end of the month. To invoice clients just take the analytic costs in that month and apply a selling price factor to generate the invoice. Invoicing mechanisms for this are explained in greater detail in *Deliver Quality Services*. If the client requires details of the services used on the case, you can then print the service entries in the analytic account for this case.

**Tip:** Invoicing analytic costs

Most software that manages billing enables you to recharge for hours worked. In Open ERP these services are automatically represented by analytic costs. But many other Open ERP documents can also generate analytic costs, such as credit notes and purchases of goods.

So when you invoice the client at the end of the month it is possible for you to include all the analytic costs, not just the hours worked. So, for example you can easily recharge the whole cost of your journeys to the client.
16.1.3 Case 3: IT Services Company

Most IT services companies face the following problems:

- project planning,
- invoicing, profitability and financial follow-up of projects,
- managing support contracts.

To deal with these problems you would use an analytic chart of accounts structured by project and by contract. A representation of that is given in the following example.

**Note:** Example Analytic representation of a chart of accounts for an IT Services company

1. **Internal Projects**
   - Administrative and Commercial
   - Research and Development

2. **Client Projects**
   - Client 1
     - Project 1.1
     - Project 1.2
   - Client 2
     - Project 2.1
     - Project 2.2

3. **Support Contracts – 20h**
   - Customer X
   - Customer Y

The management of services, expenditures and sales is similar to that presented above for lawyers. Invoicing and the study of profitability are also similar.

But now look at support contracts. These contracts are usually limited to a prepaid number of hours. Each service posted in the analytic accounts shows the remaining available hours of support. For the management of support contracts you would use the quantities and not the amounts in the analytic entries.

In Open ERP each analytic line lists the number of units sold or used, as well as what you would usually find there – the amount in currency units (USD or GBP, or whatever other choice you make). So you can sum the quantities sold and used on each analytic account to determine whether any hours of the support contract remain. To differentiate services from other costs in the analytic account you use the concept of the analytic journal. Analytic entries are then allocated into the different journals:

- service journal,
- expense journal,
- sales journal,
- purchase journal.

So to obtain the detailed breakdown of a support contract you only have to look at the service journal for the analytic account corresponding to the contract in question.

Finally, the analytic account can be used to forecast future needs. For example, monthly planning of staff on different projects can be seen as an analytic budget limited to the service journal. Accounting entries are expressed in quantities (such as number of hours, and numbers of products) and in amounts in units of currency (USD or GBP perhaps).

So you can set up planning on the basis just of quantities. Analyzing the analytic budget enables you to compare the budget (that is, your plan) to the services actually carried out by month end.
Tip: Cash Budgets
Problems of cash management are amongst the main difficulties encountered by small growing businesses. It is really difficult to predict the amount of cash that will be available when a company is young and rapidly growing. If the company adopts management by case, then staff planning can be represented on the analytic accounts report, as you have seen. But since you know your selling price for each of the different projects, you can see that it is easy to use the plan in the analytic accounts to more precisely forecast the amounts that you will invoice in the coming months.

16.2 Putting Analytic Accounts in Place

For the initial setup of good analytic accounts you should:

- set up the chart of accounts,
- create the different journals.

16.2.1 Setting up the Chart of Accounts

Start by choosing the most suitable analytic representation for your company before entering it into OpenERP. To create the different analytic accounts, use the menu **Accounting → Configuration → Analytic Accounting → Analytic Accounts** and click the New button.

![Figure 16.1: Setting up an analytic account](image)

To create an analytic account you have to complete the main fields:

- the **Account Name**,
- the **Account Code**: used as a shortcut for selecting the account,
- the **Account Type**: just like general accounts the View type is used for virtual accounts which are used only to create a hierarchical structure and for subtotals, and not to store accounting entries,
- the **Parent Analytic Account**: defines the hierarchy between the accounts.

If the project is for a limited time you can define a start and end date here. The **State** field is used to indicate whether the project is running (Open), waiting for information from the client (Pending), Draft or Closed.

Finally, if the analytic account is a client project you can complete the fields about the partner, which you would need so that you can invoice the partner:

- the **Partner**,
- a **Sale Pricelist**, which shows how services linked to the project should be charged,
• a Max. Invoice Price, showing the maximum invoice price regardless of actual overspend,
• a Maximum Quantity, for contracts with a fixed limit of hours to use,
• an Invoicing Rate per Journal field, which defines an invoicing rate and whether the project should be invoiced automatically from the services represented by the costs in the analytic account.

Tip: Invoicing
You have several methods available to you in OpenERP for automated invoicing:
• Service companies usually use invoicing from purchase orders, analytic accounts or project management tasks.
• Manufacturing and trading companies more often use invoicing from deliveries or customer purchase orders.

Once you have defined the different analytic accounts you can view your chart through the menu Accounting → Charts → Chart of Analytic Accounts.

Figure 16.2: Example of an analytic chart for projects

Tip: Setting up an analytic account
The setup screen for an analytic account can vary greatly depending on the modules installed in your database. For example, you will only see information about recharging services if you have the module hr_timesheet_invoice installed.
Some of these modules add helpful management statistics to the analytic account. The most useful is probably the module account_analytic_analysis, which adds such information as indicators about your margins, invoicing amounts, and latest service dates and invoice dates.

16.2.2 Creating Journals

Once the analytic chart has been created for your company you have to create the different journals. These enable you to categorize the different accounting entries by their type:

• services,
• expense reimbursements,
• purchases of materials,
• miscellaneous expenditure,
• sales,
• situation entries (special situations, such as installation of the software).

Note: Minimal journals
At a minimum you have to create one analytic journal for Sales and one for Purchases. If you do not create these two, OpenERP will not validate invoices linked to an analytic account because it would not be able to create an analytic accounting entry automatically.
To define your analytic journals, use the menu Accounting → Configuration → Analytic Accounting → Analytic Journals then click New.

It is easy to create an analytic journal. Just give it a Journal Name, a Journal Code and a Type. The types available are:

- **Sales**, for sales to customers and for credit notes,
- **Purchases**, for purchases and miscellaneous expenses,
- **Cash**, for financial entries,
- **Situation**, to adjust accounts when starting an activity, or at the end of the financial year,
- **General**, for all other entries.

The type of journal enables the software to automatically select the analytic journal based on the nature of the operation. For example if you enter an invoice for a customer, OpenERP will automatically search for an analytic journal of type Sales.

### 16.2.3 Working with Analytic Levels

You can work with analytic levels using OpenERP by installing account_analytic_default module. It allows you to automatically select analytic accounts based on some criteria:

- **Product**
- **Partner**
- **User**
- **Company**
- **Date**

You can configure these criteria using the menu Accounting → Configuration → Analytic Accounting → Analytic Defaults and click the New button.

### 16.3 Analytic Entries

#### 16.3.1 Integrated with General Accounting

Just as in general accounting, analytic entries must belong to an account and an analytic journal. Analytic records can be distinguished from general records by the following characteristics:
• they are not necessarily legal accounting documents,
• they do not necessarily belong to an existing accounting period,
• they are managed according to their date and not an accounting period,
• they do not generate both a debit and a credit entry, but a positive amount (income) or a negative amount (cost).

Figure 16.5: Analytic account records for a customer project

The figure Analytic account records for a customer project represents the entries on an analytic account for a customer project.

You can see there:
• the service costs for staff working on the project,
• the costs for reimbursing the expenses of a return journey to the customer,
• purchases of goods that have been delivered to the customer,
• sales for recharging these costs.

16.3.2 Manual Entries

Even though most analytic entries are produced automatically by the other Open ERP documents it is sometimes necessary to make manual record entries. It is usually needed for certain analytic operations that have no counterpart in the general accounts.

To make manual record entries, use the menu Accounting → Journal Entries → Analytic Journal Items and click on New button.

Note: Analytic entries
To make an analytic entry, Open ERP asks you to specify a general account. This is given only for information in the different cross-reports. It will not create any new entries in the general accounts.

Select a journal and complete the different fields. Write an expense as a negative amount and income as a positive amount.

Tip: Entering a date
To enter a date in the editable list you can use the calendar widget in the web client or, in the GTK client, if you enter just the day of the month Open ERP automatically completes the month and year when you press the tab key (Tab).

Note: Example Cost redistribution
One of the uses of manual data entry for analytic operations is reallocation of costs. For example, if a development has been done for a given project but can be used again for another project you can reallocate part of the cost to the other project.
In this case, make a positive entry on the first account and a negative entry for the same amount on the account of the second project.
Automated Entries

Analytic accounting is totally integrated with the other Open ERP modules, so you never have to re-enter the records. They are automatically generated by the following operations:

- confirmation of an invoice generates analytic entries for sales or purchases connected to the account shown in the invoice line,
- the entry of a service generates an analytic entry for the cost of this service to the given project,
- the manufacture of a product generates an entry for the manufacturing cost of each operation in the product range.

Other documents linked to one of these three operations produce analytic records indirectly. For example, when you are entering a customer sales order you can link it to the customer’s analytic account. When you are managing by case or project, mark the project with that order. This order will then generate a customer invoice, which will be linked to the analytic account. When the invoice is validated it will automatically create general and analytic accounting records for the corresponding project.

Expense receipts from an employee can be linked to an analytic account for reimbursement. When a receipt is approved by the company, a purchase invoice is created. This invoice represents a debit on the company in favour of the employee. Each line of the purchase invoice is then linked to an analytic account which automatically allocates the costs for that receipt to the corresponding project.

To visualize the general entries following these different actions you can use one of the following menus:

1. To see all of the entries, Accounting → Journal Entries → Analytic Journal Items
2. To see the entries per account, per user, per product or per partner, you can use menu Accounting → Reporting → Statistic Reports → Analytic Entries Analysis.

16.3.3 Analytic Models

Using Analytic Model concept you can distribute your income or expense to your analytic accounts. You can define your analytic plans using menu Accounting → Configuration → Analytic Accounting → Multi Plans → Analytic Plan.

Using the link Distribution Models given on right side of Analytic Plan form, you can define the distribution of either your expenses while creating supplier invoice or revenue when defining customer invoices.
As for example, when you create the invoice (suppose 1000 EUR) for the product ‘Client Project’ with analytic distribution that we defied as above.

When invoice has been validated then you can find the Analytic Journal Entries with distributed amount among the analytic account using the menu Accounting → Journal Entries → Analytic Journal Items.

You can also specify default ‘Analytic Distribution’ for particular product, partner, user and company for specific time interval using the menu Accounting → Configuration → Analytic Accounting → Analytic Defaults.

16.4 Financial Analysis

Various reports designed for financial analysis are based on the analytic accounts. Most of those are available directly from the tree of accounts or from the form view of the account.

16.4.1 Analysis per account

From an Analytic Account form, click on one of the REPORTS buttons to select a report. Open ERP provides the following financial analyses from the analytic accounts (and maybe more, depending on the additional installed modules):

- Cost Ledger,
- Cost Ledger (quantities only),
- Inverted Analytic Balance,
- Analytic Balance,

The cost ledger

The cost ledger provides all of the detailed entries for the selected accounts. It enables you to make a detailed analysis of each operation carried out on one or several projects.
The analytic cost ledger gives a detailed history of the entries in an analytic account

The cost ledger (quantities only)

This report gives the detail of entries for an analytic account and a list of selected journals. Only quantities are reported for this analysis, not costs and revenues.

The cost ledger (quantities only) gives a history of an analytic account

The report is often used to print the number of hours worked on a project, without exposing the costs and revenues. So you can show it to a client as a record of the hours worked on a particular project.

To restrict the report to hours worked, without including sales and purchases, select only the services journal for printing.

Tip: Multiple printing

To print several analytic accounts at once you can make a multiple selection on the different accounts in the tree of accounts. Then click on the appropriate Report in the toolbar (in the web client), or select one of the Print reports (in the GTK client), to export the whole selection into a single PDF document.

Inverted Analytic Balance

The inverted analytic balance provides a summary report relating general accounts and analytic accounts. This report shows the balances of the general accounts broken down by the selected analytic accounts for a selected period.
Figure 16.11: The inverted analytic balance shows a breakdown of operations by analytic account (project)

This enables you to analyze your costs by general account. For example, if you examine your general account for staff salaries you can obtain all your salary costs broken down by the different analytic (or project) accounts.

**Analytic Balance**

Figure 16.12: The analytic balance shows a breakdown of each project by operation in the financial accounts

The analytic balance is a summary report that relates the analytic accounts to the general accounts. It shows the balances of the analytic accounts broken down by general account for a selected period.

This report is useful for analyzing the profitability of projects, giving you the profitability of a project for the different operations that you used to carry out the project.

**Tip:** Multi-company

In a multi-company environment each company can have its own general chart of accounts on the same database. The two general charts of accounts are independent but can be linked in a third chart using a view account to do the consolidation.

If the different companies collaborate on joint projects they may all share the same analytic chart of accounts. In this environment, the cross-related reports like the balance and inverted balance are extremely useful because they enable you to make an analysis per company by linking up to the general accounts.

**Analytic Entries Analysis**

You can have the statistical analysis on all analytic entries from the menu *Accounting → Reporting → Statistic Reports → Analytic Entries Analysis.*
16.4.2 Key indicators

If you use analytic accounts with a structure of accounts by project client you should install the `account_analytic_analysis` module. This module adds three new tabs to the analytic account form:

- management indicators in the *Analysis summary* tab,
- monthly statistics in the *Stats by month* tab,
- statistics on each user in the *Stats by user* tab.

The figure *Management indicators for an analytic account* shows all of the management indicators.

These indicators enable you to quickly see such important information as:

- project profitability,
- whether you can still invoice any services to the client, or not,
- the amount of services to invoice,
- the different margin figures.
The real revenue is given by the amount invoiced to the client. The theoretical revenue is given by the sale price of different project costs which could be invoiced to the client. These give different margin figures.

For example, in the case of a fixed price project contract, the real sale price at the end of the project will be equal to the contract negotiated with the client. The theoretical price gives the amount that would have been invoiced if you had charged for all the time worked.

To give project managers a direct view of their different projects, the `account_analytic_analysis` module creates new menus in the Project management module in `Project → Billing → Overpassed Accounts`.

These different menus give quick views that are useful for live projects. For each project you can check if there are uninvoiced services, see the last invoice date and the last uninvoiced service date, and get reports on the amounts received and those planned. So project managers have all the information necessary to manage their project, shown in a single page.

In the following chapters you will see how project managers can use this information to carry out the various operations needed to manage the project, such as automatic invoicing, project planning, keeping customers up to date, and budgeting for resources.

**Note:** Analytic Budgets

Analytic budgets can be budgeted in the `account_budget` module. They offer:

- forecasting projects in the medium term,
- controlling project costs,
- comparisons with general accounts.
This chapter describes OpenERP’s main Human Resources and Employee Services features. Most of the solutions discussed after this chapter concern management by business or by project and depend mostly on analytic accounting, with each business or project represented by an analytic account.

A company’s effectiveness depends on its employees’ good work. OpenERP’s Human Resources modules enable you to manage important aspects of staff work efficiently, such as their skills, contracts, and working time.

For this chapter you should start with a fresh database that includes demo data. To configure the Human Resource Application you should check the Human Resource in the following configuration wizard.

Figure 17.1: Human Resource application configuration wizard

17.1 Managing Human Resources

To establish a system that is integrated into the company’s management you need to start with a current list of collaborators.

Note: Do not confuse employees and users

For OpenERP, “employee” represents all of the physical people who have a work contract with the company. This includes all types of contracts: contracts with both fixed and indeterminate time periods, and also independent and freelance service contracts.

A “user” is a physical person who is given access to the company’s systems. Most employees are users but some users are not employees: external partners can have access to parts of the system.

Here are some examples of functions which depend on the accuracy of the employee list:

- the cost of a service, which depends on the employee’s working contract,
- project planning, which depends on the work pattern of the project contributors,
- the client billing rate, which probably depends on the employee’s job function,
- the chain of command, or responsibilities, which is related to the hierarchical structure of the company.
17.1.1 Management of staff

To define a new employee in Open ERP, use the menu Human Resources → Employees.

![Figure 17.2: Form describing an employee](image)

Start by entering the employee’s name in Employee and the company that this employee works for in Company. You can then create a new user of the Open ERP system linked to this employee by filling in a new User form through the User field.

Even if the employee is not a user, it is best if you create a system access for most of your staff just so that you can control their access rights from the outset (and you can do that through this field if you need to).

**Tip: Employee and User link.**

If the employee has a user account on the system you always link his or her user account to the employee form. Creating this link enables automatic completion to be done on the Employee field in the relevant forms, such as services and expense records.

Then enter the employee’s address.

This appears in the partner contact form in Open ERP. Since employees are people that have contacts with your company, it is logical that they have entries like any other partner in your database. So enter the name of the employee as a new partner Name and the address in the Contact form. Then all of the functions that apply to a partner can also be applied to an employee. This is particularly useful for tracking debits and credits in the accounts – so you can track salary payments, for example.

You can then set both an analytic journal and a linked product to this employee in the Timesheets tab. If you do it that way, then this information can be used to track services. For now, just complete the form with the following information:

- **Analytic Journal**: usually a Timesheet Journal,
- **Product**: a service product that describes how this employee would be charged out, for example as Service on Timesheet.

17.1.2 Contract Management

If you install the hr_contract module you can link contract details to the employee record. The configuration wizard to install this module is shown below.
Using Human Resources → Human Resources → Contracts you can create and edit new contract.

You can enter information about the employment contract for the employee, such as:

- **Contract Reference**
- **Job Title**
- **Working Schedule**
- **Start Date**
- **End Date**
- **Wage Type** like Monthly Gross or Monthly Net or Monthly Basic

### 17.1.3 Sign in and out

In some companies, staff have to sign in when they arrive at work and sign out again at the end of the day. If each employee has been linked to a system user, then they can sign in on Open ERP by using the menu Human Resources → Attendances → Sign in / Sign out.

If an employee has forgotten to sign out on leaving, the system proposes that they sign out manually and type in the time that they left when they come in again the next day. This gives you a simple way of managing forgotten sign-outs.

Find employee attendance details from their forms in Human Resources → Employees.

To get the detail of attendances from an employee’s form in Open ERP you can use the three available reports:

- **Print Attendance Error Report**
- **Print Attendances By Month**

The first report highlights errors in attendance data entry. It shows you whether an employee has entered the time of entry or exit manually and the differences between the actual and expected sign out time and the time.
The second report shows the attendance data recorded.

17.2 Timesheets

In most service companies where Open ERP has been integrated, service sheets, or timesheets, have revolutionized management practices. These service sheets are produced by each employee as they work on the different cases or projects that are running. Each of these is represented by an analytic account in the system.

Throughout the day, when employees work on one project or another, they add a line to the timesheets with details of the time used on each project. At the end of the day, each employee must mark all the time worked on client or internal projects to make up the full number of hours worked in the day. If an account is not in the system then the time is added to the hours that have not been assigned for the day.

![Timesheet for a working day](image1)

**Figure 17.5: Timesheet for a working day**

The figure *Timesheet for a working day* gives an example of a timesheet for an employee.

**Note:** *Don’t confuse timesheets and attendance compliance*

The timesheet system is not intended to be a disguised attendance form. There is no control over the service times and the employee is free to encode 8 or 9 hours or more of services each day if they want. If you decide to put such a system into place, it is important to clarify this point with your staff. The objective here isn’t to control hours, because the employees decide for themselves what they’ll be entering – but to track the tasks running and the allocation of costs between them.

To enable your system with all the features related to *Timesheet*, your configuration wizard should be like this.

![Configuration wizard for Timesheet](image2)

**Figure 17.6: Configuration wizard for Timesheet**

Amongst the many uses of such a timesheet system for a company, here are some of the most important:

- enabling tracking of the true costs of a project by accounting for the time used on it,
- tracking the services provided by different employees,
- comparing the hours really used on a project with the initial planning estimates,
- automatically invoicing based on the service hours provided,
- obtaining a list of the service hours for a given client,
- knowing the costs needed to run the company, such as the marketing costs, the training costs for a new employee, and the invoicing rates for a client.
17.2.1 Timesheet categories

The different timesheet categories (working time sessions) can be defined in the menu Manufacturing → Configuration → Resources → Working Period and select one of the groups there such as 38 Hours/Week.

![Working Period](image)

**Figure 17.7:** Timesheet category for full time 38 hours per week

17.2.2 Employee configuration

To be able to use the timesheets at all, you must first define those employees who are system users. The employee definition forms contain the information necessary to use that sheet, such as the job title, and hourly costs.

Two fields will be of particular interest to you for managing timesheets: the **Analytic Journal** and the **Product**.

In the analytic journal will be stored all the analytic entries about the costs of service times. These enable you to isolate the cost of service from other company costs such as the purchase of raw materials, expenses receipts and subcontracting. You can use different journals for each employee to separate costs by department or by function.

The employee is also associated with a product in your database in Open ERP. An employee is linked with a product so they can be ‘bought’ (subcontracting) or ‘invoiced’ (project management). You have to create a product for each job type in your company.

The following information is important in the product form:

- **Name**: Secretary Salesperson Project Manager
- **Product Type**: Service
- **Unit of Measure**: Hour Day
- **Cost Price**
- **Sale Price**
- **Costing Method**: either Standard Price or Average Price

**Tip:** Price Indexation

*When the Costing Method is Average Price in the Product form you can have a button beside Cost Price field that open up the wizard for changing the cost price.*

In summary, each company employee corresponds, in most cases, to:

- **Partner**
- an Employee form,
- **System User**.
And each company job position corresponds to a Product.

**Note:** Time charge rates

By default the hourly cost of an employee is given by the standard cost of the product linked to that employee. But if you install the hr_contract module it is possible to manage contracts differently. The hourly cost of the employee is then automatically calculated from their employment contract when they enter their timesheet data. To do this, the software uses a factor defined in the contract type (for example, the gross monthly salary, calculated per day). Ideally this factor should take into account the salary costs, and the taxes, insurances and other overheads associated with pay.

### 17.2.3 Entering timesheet data

To be able to use timesheets fully, install the module hr_timesheet_sheet. Once this module has been installed and the employees configured, the different system users can enter their timesheet data in the menu Human Resources → Time Tracking → Working Hours, then click New.

**Tip:** Shortcut to timesheets

It’s a good idea if all employees who use timesheets place this menu in their shortcuts. That is because they will need to return to them several times each day.

For a new entry:

1. The User: proposed by default, but you can change it if you are encoding the first timesheet for another company employee.
2. The Date: automatically proposed as today’s date, but it is possible to change it if you are encoding the timesheet for a prior day.
3. Analytic Account: for the project you’ve been working on - obviously it should be predefined.
4. Description: a free text description of the work done in the time.
5. Quantity: number of units of time (the units are defined as part of the product).

The other fields are automatically completed but can be modified: the Product which is the service product such as consultancy, the Unit of Measure (predefined, and could perhaps be minutes, hours or days), the Cost of the service (which is calculated by default), and the associated General Account.

The hours are then encoded throughout the day by each employee. It helps to revisit the list at the end of the day to verify that the number of hours of attendance in the company has been properly accounted for. The total entered is shown at the bottom right of the list of service hours.

**Tip:** Hiding service costs

By default, Open ERP is configured to show the cost of each service when an employee encodes the number of hours per project. You can modify this field by adding the attribute invisible=True in the timesheet view. (And the way to do that is either to modify the view on the filesystem, or to use the web client to modify the view in the current database. For the latter, there is a pale grey [Customize] label to the bottom left of each form that gives you access to the Manage Views option. If you have sufficient permissions you can edit the XML that defines the current view.) The value in the cost field shows employees the cost of their time used in the company, so masking this field might not always be the best option.

The accuracy of the services entered is crucial for calculating the profitability of the different jobs and the recharging of services. Different reports are therefore available for verifying employees’ data entry. Employees can verify their own timesheet using the following reports:

- Printing the particular employee’s timesheet, using the menu Human Resources → Reporting → Timesheet → Employee Timesheet.
- Printing the more then one employees’ timesheet, using the menu Human Resources → Reporting → Timesheet → Employees Timesheet. You can print a summary in the form of a table per user and per day.
• Reviewing profit of timesheet, using the menu Human Resources → Reporting → Timesheets → Timesheet Profit.

• You can then use the statistical reports to analyze your services by period, by product or by account using the menu Human Resources → Reporting → Timesheets → Timesheet Analysis and Human Resources → Reporting → Timesheets → Timesheet Sheet Analysis.

The data making up these list view can be varied using the filters available in the upper part of the screen. If you want to see more detail, switch to the graph view.

17.2.4 Evaluation of service costs

You already know that timesheets are closely linked with analytic accounts. The different projects reported on the timesheets correspond to analytic accounts. The timesheet entries themselves are analytic entries. These entries comprise various analytic operations that don’t correspond to any of the general accounts. Therefore all operations that modify and create timesheet lines automatically impact the corresponding analytic line and, conversely are automatically modified by changes in that line.

Note: Timesheets and analytical data

The implementation of timesheets in Open ERP relating to analytic entries is managed by an inheritance mechanism: the timesheet object inherits the analytic entry object.

The information is therefore not encoded into the database as two separate events, which avoids many synchronization problems. They are stored in two different tables, however, because a service is an analytical entry, but an analytical entry is not necessarily a service.

This is not a classical approach but it is logical and pragmatic. Employee timesheets are a good indication of how the costs of a service enterprise are spread across different cases as reported in the analytic accounts. An analytic account should be reflected in the general accounts, but there is no direct counterpart of these analytic accounts in the general accounts. Instead, if the hourly costs of the employees are correctly accounted for, the month’s timesheet entries should be balanced by the salary + benefits package paid out to all the employees at the end of the month.
Despite all this it is quite difficult to work out the average hourly cost of an employee precisely because it depends on:

- the extra hours that they have worked,
- holidays and sickness,
- salary variations and all the linked costs, such as social insurance charges.

The reports that enable you to relate general accounts to analytic accounts are valuable tools for improving your evaluation of different hourly costs of employees. The difference between product balances in the analytic account and in the general accounts, divided by the total number of hours worked, can then be applied to the cost of the product. Some companies adjust for that difference by carrying out another analytic operation at the end of the month in an account created for that purpose. This analytic account should have a balance that tends towards zero.

Because you’ve got a system with integrated timesheets you can then:

- track the profitability of projects in the analytic accounts,
- look at the history of timesheet entries by project and by employee,
- regularly adjust hourly costs by comparing your rates with reality.

**Important: Project Cost Control**

*Controlling the costs and the profitability of projects precisely is very important. It enables you to make good estimates and to track budgets allocated to different services and their projects, such as sales and, R&D costs. You can also refine your arguments on the basis of clear facts rather than guesses if you have to renegotiate a contract with a customer following a project slippage.*

The analyses of profitability by project and by employee are available from the analytic accounts. They take all of the invoices into account, and also take into account the cost of the time spent on each project.

### 17.2.5 Managing by department

When they are used properly, timesheets can be a good control tool for project managers and can provide awareness of costs and times.

When employee teams are important, a control system must be implemented. All employees should complete their timesheets correctly because this forms the basis of planning control, and the financial management and invoicing of projects.

You will see in *Deliver Quality Services* that you can automatically invoice services at the end of the month based on the timesheet. But at the same time some contracts are limited to prepaid hours. These hours and their deduction from the original limit are also managed by these timesheets. In such a situation, hours that are not coded into the timesheets represent lost money for the company. So it is important to establish effective follow-up of the services timesheets and their encoding. To set up a structure for control using timesheets you should install the module `hr_timesheet_sheet`. 
This module supplies a new screen enabling you to manage timesheets by period. Timesheet entries are made by employees each day. At the end of the week, employees validate their week’s sheet and it is then passed to the services manager, who must approve his team’s entries. Periods are defined in the company forms, and you can set them to run monthly or weekly.

To enter timesheet data each employee uses the menu Human Resources → Time Tracking → My Timesheet.

In the upper part of the screen the user starts with the sign-in and sign-out times. The system enables the control of attendance day by day. The two buttons Sign in and Sign out enable the automatic completion of hours in the area to the left. These hours can be modified by employee, so it is not a true management control system.

The area to the bottom of the screen represents a sheet of the employee’s time entries for the selected day. In total, this should comprise the number of hours worked in the company each day. This provides a simple verification that the whole day’s attendance time has been coded in properly.

The second tab of the timesheet By day gives the number of hours worked on the different projects. When there is a gap between the attendance and the timesheet entries, you can use the second tab to detect the days or the
entries that have not been correctly coded in.

Figure 17.12: Detail of hours worked by day for an employee

The action *Timesheet by Account* shows the time worked on all the different projects. That enables you to step back to see an overview of the time an employee has worked spread over different projects.

At the end of the week or the month, the employee confirms his timesheet. If the attendance time in the company corresponds to the encoded entries, the whole timesheet is then confirmed and sent to his department manager, who is then responsible for approving it or asking for corrections.

Each manager can then look at a list of his department’s timesheets waiting for approval using the menu *Human Resource → Reporting → Timesheet → Timesheet Sheet Analysis* by applying the proper filters. He then has to approve them or return them to their initial state.

To define the departmental structure, use the menu *Human Resources → Configuration → Human Resources → Departments*.

**Tip: Timesheet approval**

At first sight, the approval of timesheets by a department manager can seem a bureaucratic hindrance. This operation is crucial for effective management, however. We have too frequently seen companies in the situation where managers are so overworked that they do not know what their employees are doing.

So this approval process supplies the manager with an outline of each employee’s work at least once a week. And this is carried out for the hours worked on all the different projects.

Once the timesheets have been approved you can then use them for cost control and for invoicing hours to clients.

Contracts and their rates, planning, and methods of invoicing are the object of the following chapter, *Deliver Quality Services*.

### 17.3 Keeping Track of Expenses

Employee expenses are charges incurred on behalf of the company. The company then reimburses these expenses to the employee. The receipts encountered most frequently are:

- car travel, reimbursed per unit of distance (mile or kilometer),
- subsistence expenses, reimbursed based on the bill,
- other purchases, such as stationery and books, destined for the company but carried out by the employee.
17.3.1 An integrated process

Expenses generated by employees are grouped into periods of a week or a month. At the end of the period the employee confirms all of its expenses and a summary sheet is sent to the department manager. The manager is responsible for approving all the expense requests generated by his team. The expense sheet must be signed by the employee, who also attaches its receipts to the expense sheet.

Once the sheet has been approved by the head of department it is sent to the Accounting department, which registers the company’s liability to the employee. Accounting can then pay this invoice and reimburse the employee who originally advanced the money.

Some receipts are for project expenses, so these can then be attached to an analytic account. The costs incurred are then added to the supplementary cost of the analytic account when the invoice is approved.

You often need to invoice expenses to a customer, depending on the precise contract that has been negotiated. Travelling and subsistence expenses are generally handled this way. These can be recharged to the customer at the end of the month if the contract price has been negotiated inclusive of expenses.

If you have to go through many steps to reclaim expenses, it can all quickly become too cumbersome, especially for those employees who claim large numbers of different expense lines. If you have got a good system that integrates the management of these claims, such as the one described, you can avoid many problems and increase staff productivity.

If your systems handle expenses well then you can avoid significant losses by setting your terms of sales effectively. In fixed-price contracts, expense reimbursements are usually invoiced according to the actual expense. It is in your interest to systematize their treatment, and automate the process to the maximum, to recharge as much as you are contractually able.

17.3.2 Employee Expenses

Install the module `hr_expense` to automate the management of expense claims. The configuration wizard to install this module is shown below.
Users can then enter and review their expenses using the menu Human Resources → Expenses → Expenses.

Create templates for the various expenses accepted by the company using OpenERP’s product form. You could, for instance, create a product with the following parameters for the reimbursement of travel expenses by car at 0.25 per kilometer:

- **Product**: Car travel,
- **Unit of measure**: km,
- **Standard Cost**: 0.25,
- **Sales price**: 0.30,
- **Type of product**: Service.

The employee keeps its expenses sheet in the Draft state while completing it throughout the period. At the end of the period (week or month) the employee can confirm its expense form using the Confirm button on the form. This puts it into the state Waiting Approval.

At the end of the period the department manager can access the list of expense forms waiting for approval using the menu Human Resources → Expenses → Expenses.

The department manager can then approve the expenses, which automatically creates a supplier invoice in the employee’s name so that the employee can be reimbursed. An analytic account is coded onto each line of the invoice. When the invoice is confirmed, general and analytic accounting entries are automatically generated as they would be with any other invoice.

If you base your invoicing on service time or analytic costs, the expense will automatically be recharged to the customer when the customer invoice is generated for services associated with the project.

Invoicing from timesheets allows you to prepare all your invoices, both expenses and timesheets for a project’s customer.

You can view the statistical analysis of expenses using menu Human Resources → Reporting → Expenses Analysis.
17.4 Hire New People

Using OpenERP you can efficiently manage the process of hiring the new people for your organization. It is a well managed recruitment process from initial contact to hiring the applicant.

17.4.1 Recruitments

You need to install hr_recruitment module to efficiently managed recruitment process. The configuration wizard to install this module is shown below.

![Configuration wizard to install hr_recruitment module](image)

The Applicant form can be seen from the menu Human Resources → Recruitment → Applicants.

![Applicant recruitment form](image)

You can manage following information using applicant form.

- Applicant’s Name
- Applied Job
- Department
- Stage: can be Initial Job Demand, Salary Negotiation, ...
- Responsible: Responsible person who conducts the interview
- Contact Information
- Contract Data: including Availability, Expected Salary, Proposed Salary
- Qualification of Applicant
- Status: reflects the actual status of the recruitment process like In Progress, Pending or Hired

Initially the applicant states is New after that it can be converted into In Progress. If the applicant is at one of the different stages like it may be in Waiting for approval by human resource department or Waiting for offer acceptance by applicant, in these cases applicant states should be Pending. When the status is Hired, you can find that applicant from the list of employees.
The information about the Job Position can be maintained by the menu Human Resources → Recruitment → Job Positions.

![Job Positions Menu](image)

**Figure 17.18: Job Position in the organization**

The key features of OpenERP for the process of hiring the new people using hr_recruitment module.

- Manages job positions and the recruitment process.
- It’s integrated with the survey module to allow you to define interview for different jobs.
- This module is integrated with the mail gateway to automatically tracks email sent to jobs@yourcompany.com.
- It’s also integrated with the document management system to store and search in your CV base.

You can analyse data of recruitment process through the menu Human Resources → Reporting → Recruitment Analysis.

### 17.5 Inspire your People

Motivated workforce of people can give the best out come for the organization. OpenERP can maintain this motivational process by periodical evaluation of employees’ performance and efficient holiday management.

#### 17.5.1 Assessments

The regular assessments of human resources can be benefited to your people as well organization. For efficient periodical evaluation of employees’ performance you need to install hr_evaluation module. The configuration wizard to install this module is shown below.

![Configuration Wizard](image)

**Figure 17.19: Configuration wizard to install hr_evaluation module**

To create and manage new evaluation you can use the menu Human Resources → Evaluations → Evaluations.
Each employee can be assigned to an evaluation plan. These plans define the frequency and the way you manage your periodic personal evaluation. You will be able to define steps and attach interview forms to each step. OpenERP manages all kinds of evaluations: bottom-up, top-down, self evaluation and final evaluation by the manager.

The main features of the evaluation process covered by OpenERP are as follow.

- Ability to create employees evaluation.
- An evaluation can be created by employee for subordinates, juniors as well as his manager.
- The evaluation is done under a plan in which various surveys can be created and it can be defined which level of employee hierarchy fills what and final review and evaluation is done by the manager.
- Every evaluation filled by the employees can be viewed by a nice pdf form.
- Interview Requests are generated automatically by OpenERP according to employees evaluation plan. Each user receives automatic emails and requests to perform evaluation of their colleagues periodically.

You can analyse evaluation data through the menu Human Resources → Reporting → Evaluations Analysis.

### 17.5.2 Holiday Management

You can manage the leaves taken by employees using hr_holidays module. The configuration wizard to install this module is shown below.

![Configuration wizard to install hr_holidays module](image)

Using the menu Human Resources → Holidays → Leave Requests employee can put the leave request.
Leaves requests can be recorded by employees and validated by their managers. Once a leave request is validated it appears automatically in the agenda of the employee. You can define several allowance types (paid holidays, sickness, etc) and manage allowances per type.

OpenERP can provide following features for efficient holiday management process.

- It helps you to manage leaves and leaves’ requests.
- A synchronisation with an internal agenda (use of the CRM module) is possible: in order to automatically create a case when an holiday request is accepted, you have to link the holidays status to a case section.
- You can set up colour preferences according to your leave type like *Seak Leave* should be red in reports.
- An employee can make an ask for more off-days by making a new Allocation

The statistical report for the leaves can be seen using *Human Resources → Reporting → Holidays → Leaves Analysis* menu.
This chapter focuses on the management of contracts, and the services associated with that. The complete process of managing services is studied here: from defining prices and contracts to automatically invoicing the services through planning, and the treatment of additional costs such as expense receipts.

For this chapter you should start with a fresh database that includes demo data, with sale, project and all of their dependencies installed, and no particular chart of accounts configured.

18.1 Managing Service Contracts

Contracts can take different forms within OpenERP, depending on their nature. So you can have several distinct types of service contracts, such as:

- fixed-price contracts,
- cost-reimbursement contracts, invoiced when services are completed,
- fixed-price contracts, invoiced monthly as services are carried out.

**Tip: Contract quotations**
Some companies commit to contracts on the basis of a requested volume at a certain price for a defined period. In such a case, the contract is represented by a pricelist for that specific customer. The pricelist is linked in the Sales and Purchases tab of the Customers form, so that it is brought up whenever anything is bought from or sold to this partner (depending on whether it is a purchase or sales agreement). OpenERP automatically selects the price based on this agreed pricelist.

18.1.1 Fixed Price contracts

Fixed price contracts for the sale of services are represented in OpenERP by a Sales Order. In this case, the supply of services is managed just like all other stockable or consumable products.

You can add new orders using the menu `Sales → Sales → Sales Orders`.

The new Sales Order document starts in the `Quotation` state, so the estimate has no accounting impact on the system until it is confirmed. When you confirm the order, your estimate moves into the state `Manual In Progress`. 
Once the order has been approved, OpenERP will automatically generate an invoice and/or a delivery document proposal based on the parameters you set in the order.

The invoice will be managed by the system depending on the setting of the field *Shipping Policy* on the order’s second tab *Other Information*:

- **Payment Before Delivery**: OpenERP creates an invoice in the *Draft* state. Once this is confirmed and paid, the delivery is activated.
- **Invoice on Order After Delivery**: the delivery order is produced when the order is validated. A draft invoice is then created when the delivery has been completed.
- **Shipping & Manual Invoice**: OpenERP starts the delivery from the confirmation of the order, and adds a button which you manually click when you are ready to create an invoice.
- **Invoice from Delivery**: invoices are created from the picking stage.

**Note:** *Delivery of an order*

The term ‘delivery’ should be taken in the broadest sense in OpenERP. The effect of a delivery depends on the configuration of the sold product.

If its type is either **Stockable Product** or **Consumable**, OpenERP will make a request for it to be sent for picking. If the product’s type is **Service**, OpenERP’s scheduler will create a task in the project management system, or create a subcontract purchase order if the product’s Procurement Method is **Make to Order**.

Invoicing after delivery does as it says: invoicing for the services when the tasks have been closed.

When you sign a new contract, you can just enter the order into the system and OpenERP will track the order. This works well for small orders. But for large valued service orders, you might want to invoice several times through the contract, for example:

- 30% on order,
- 40% on completion,
- 30% one month after the system has gone into production.

In this case you should create several invoices for the one Sales Order. You have two options for this:

- Do not handle invoicing automatically from the Sales Order but carry out manual invoicing instead,
- Create draft invoices and then link to them in the third tab *History* of the Sales Order, in the *Related Invoices* section. When you create an invoice from the order, OpenERP deducts the amounts of the invoices already linked to the order to calculate the proposed invoice value.

### 18.1.2 Cost-reimbursement contracts

Some contracts are not invoiced from a price fixed on the order but from the cost of the services carried out. That is usually what happens in the building sector or in large projects. The approach you use for this is totally different because instead of using the sales order as the basis of the invoice you use the analytic accounts. For this you have to install the module `hr_timesheet_invoice`.

An analytic account is created for each new contract. The following fields must be completed in this analytic account:
• Partner: partner associated with the contract,
• Sale Pricelist,
• Invoicing.

The selection of an invoicing rate is an indirect way of specifying that the project will be invoiced on the basis of analytic costs. This can take different forms, such as delivery of services, purchase of raw materials, and expense reimbursements.

**Note:** Pricelists and billing rates
You can select a pricelist on the analytic account without having to use it to specify billing rates. An example of this is a client project that is to be invoiced only indirectly from the analytic costs. Putting the pricelist on the analytic account makes it possible to compare the actual sales with a best case situation where all the services would be invoiced. To get this comparison you have to print the analytic balance from the analytic account.

Services are then entered onto timesheets by the various people who work on the project. Periodically the project manager or account manager uses the following menu to prepare an invoice Accounting → Periodical Processing → Billing → Bill Tasks Works.

OpenERP then displays all of the costs that have not yet been invoiced. You can filter the proposed list and click the appropriate action button to generate the corresponding invoices. You can select the level of detail which is reported on the invoice, such as the date and details of the services.

![Figure 18.2: Screen for invoicing services](image)

**Note:** Project Management and analytic accounts
Analytic Accounts is only available once you have installed the module account_analytic_analysis. It provides various global financial and operational views of a project manager’s projects.

Select an entry and click Invoice analytic lines link on the right of the form. You can then invoice the selected entry by clicking Create Invoices.

### 18.1.3 Fixed-price contracts invoiced as services are worked

For large-valued projects, fixed-price invoicing based on the sales order is not always appropriate. In the case of a services project planned to run for about six months, invoicing could be based on the following:

- 30% on order,
- 30% at the project mid-point,
- 40% at delivery.

Such an approach is often used in a company but there are other options. This method of invoicing can pose many problems for the organization and invoicing of the project:

- It is extremely difficult to determine if the project is on track or not. The endpoint is fuzzy, which can result in a tricky discussion with the client at the moment of final invoicing.
- If the project takes more or less time than forecast, it will effectively result in under- or over-invoicing during the project.
• Whether you get a proper return can depend on the client. For example, if the client takes a long time to sign off on project acceptance, you cannot invoice the remaining 40% even though you might have supplied the agreed service properly.

• The account manager and the project manager are often different people. The project manager has to alert the account manager about the moment that the client can be invoiced, but that moment can easily be forgotten or mistaken.

• The project can be fixed for service costs but have agreed extras, such as reimbursement for travel expenses. Invoicing from the order does not adapt well to such an approach.

OpenERP provides a third method for invoicing services that can be useful on long projects. This consists of invoicing the project periodically on the basis of time worked up to a fixed amount that cannot be exceeded. At the end of the project, a final invoice or a credit note is generated to meet the total amount of value fixed for the project.

To configure such a project you must set an invoicing rate, a pricelist and a maximum amount on the analytic account for the project. The services are then invoiced throughout the project by the different project or account managers, just like projects that are invoiced by time used. The managers can apply a refund on the final invoice if the project takes more time to complete than permitted under the contract.

When the project is finished you can generate the closing invoice using the Final Invoice button on the analytic account. This automatically calculates the final balance of the bill, taking the amounts already charged into account. If the amount already invoiced is greater than the maximum agreed amount, then OpenERP generates a draft credit note.

This approach offers many advantages compared with the traditional methods of invoicing in phases for fixed-price contracts:

• Fixed-price contracts and cost-reimbursable contracts are invoiced in the same way, which makes the company’s invoicing process quite simple and systematic even when the projects are mixed.

• Everything is invoiced on the basis of worked time, making it easy to forecast invoicing from plans linked to the different analytical accounts.

• This method of proceeding educates project managers just as much as the client because refunds have to be given for work done if the project slips.

• Invoicing follows the course of the project and avoids a supplier’s dependence on the goodwill of the client in approving certain phases.

• Invoicing of expenses follows the same workflow and is therefore very simple.

Note: Negotiating contracts
In contract negotiation, invoicing conditions are often neglected by the client. So it can often be straightforward to apply this method of invoicing.

18.1.4 Contracts limited to a quantity

Finally, certain contracts are expressed in terms of a quantity rather than a fixed amount. Support contracts comprising a number of prepaid hours are a case in point. To generate such contracts in OpenERP you should start by installing the module account_analytic_analysis.

Then you can set a maximum number of hours for each analytic account. When employees enter their time worked on the support contract in the timesheets, the hours are automatically deducted from the maximum set on each analytic account.

You must also name someone in the company responsible for renewing expired contracts. They become responsible for searching through the list of accounts showing negative remaining hours.

The client contract can be limited to a certain quantity of hours, and it can also be limited in time. For that, you set an end date for the corresponding analytic account.
CHAPTER NINETEEN

DRIVE YOUR PROJECTS

If you have a good system to manage tasks, your whole company will benefit. OpenERP’s project management application enables you to efficiently manage and track tasks, work on them effectively, quickly delegate them while keeping close track of your delegated tasks. OpenERP also helps people in the company to organize their personal time, and this chapter proposes a methodology aimed at improving the productivity of managers.

Start with a fresh database that includes demo data, install Sales Management (sale) and Project Management (project) and select the generic chart of accounts.

19.1 Project Management

In the previous chapter you learned more about the financial management of projects, based on OpenERP’s analytic accounts, structured into cases. This way of working enables you to analyze time plans and budgets, to control invoicing and to manage your different contracts.

Here we will explain operational project management to organize tasks and plan the work you need to get the tasks completed. All the necessary operations are carried out from the Project menu.

Tip: Remember that you will have less options in Simplified view than in Extended view.

Note: Project
In OpenERP a project is represented by a set of tasks to be completed. Projects have a tree structure that can be divided into phases and sub-phases. This structure is very useful to organise your work.

Whereas analytic accounts look at the past activities of the company, Project Management’s role is to plan the future. Even though there is a close link between the two (such as where a project has been planned and then completed through OpenERP) they are still two different concepts, each making its own contribution to a flexible workflow.

Most customer projects are represented by:

- one or several analytic accounts in the Accounting System to keep track of the contract and its different phases,
- one or several projects in Project Management to track the project and the different tasks to be completed.

There is a direct link between the project and the analytic account, because for each new project created, OpenERP will automatically create the corresponding analytic account in the Projects analytic chart of accounts. Note that you have no access to the analytic account directly from a project.

19.1.1 Creating Projects and Related Tasks

To define a new project, go to the menu Project → Project → Projects. Click New and give your new project a Project Name.
You can put this project into a hierarchy, as a child of a *Parent Project*, and assign a *Project Manager*. Enter the general duration by completing *Start Date* and *End Date*.

The *Administration* tab displays information about Planned Time and the Time Spent on the project according to the task work completed. By checking the box *Warn Manager*, you configure the system to automatically send the project manager an OpenERP *Request* every time a task is closed. In case a project takes too long, it can also be escalated to another project. In *Project Escalation*, enter the project that will be used for escalated tasks. Define a generic *Reply-To Email Address* linked to all automated mails; this allows you to receive replies directly in OpenERP. You can also link to a *Working Time* category, which will be used to calculate the Project’s time line, i.e. through a Gantt chart.

The status of a project can take the following values:

- **Open**: the project is being carried out,
- **Pending**: the project is paused,
- **Cancelled**: the project has been cancelled and therefore aborted,
- **Closed**: the project has been successfully completed.

On the *Members* tab, add *Members* to the project; this is related to access rights too.

On the *Billing* tab, you find information to invoice your customer. Select the *Customer*; the Invoice address will automatically be filled from the customer form. You also have to complete the invoicing data, such as *Sale Pricelist* and *Invoice Task Work* to directly invoice from task work done. OpenERP allows you to set a *Max. Invoice Price* for the project (or subproject). The *Invoiced Amount* shows the total amount that has already been invoiced for the project concerned.

If you want to automatically keep your customer informed about the progress of the project, check *Warn Partner*. **Note:** *Warn Partner setup*

*If you check Warn Partner, you should define a generic Mail Header and Mail Footer in the Billing tab that will be used in the automated email (Extended view only). OpenERP prepares an email the user can send to the customer each time that a task is completed. The contents of this email are based on details of the project task, and can be modified by the user before the email is sent. OpenERP displays a number of variables at the bottom of this tab.*

**Note:** *Study of Customer Satisfaction*

Some companies run a system where emails are automatically sent at the end of a task requesting the customer to complete an online survey. This survey enables a company to ask several questions about the work carried out, to gauge customer satisfaction as the project progresses. This function can also be used by ISO 9001-certified companies, to measure customer satisfaction. OpenERP also allows you to create your own surveys.

The *Task Stages* tab allows you to define stages that help you dividing your tasks. You can add a sequence number to set the stage order, allowing you to prioritize your task work, i.e. first you will have the Specification stage and then Development.

### 19.1.2 Managing tasks

Once a project has been defined, you can enter the tasks to be executed. You have two possibilities for this:

- click the *ACTION* button *Tasks* to the right of the project form, then click *New*,
- from the menu *Project* → *Project* → *Tasks*, create a new task and assign it to an existing project.

Each task has one of the following states:

- **Draft**: the task has been entered but has not yet been validated by the person who will have to do it,
- **Open**: you can start working on the task, or tasks is in progress,
- **Closed**: task is completed,
- **Cancelled**: task work is no longer required,
• **Pending**: task is waiting for response of someone else (e.g. customer information).

A task can be assigned to a user, who then becomes responsible for closing it. But you could also leave it unassigned so that nobody specific will be responsible: various team members instead are made jointly responsible for working on tasks they have the skills for.

![Tasks in Project Management](image)

**Figure 19.1: Tasks in Project Management**

Each user manages his or her own task using the various menus available. To open the list of unclosed tasks that have been specifically assigned to you, go to the menu *Project → Project → Tasks*. Or to open the unassigned tasks, go to *Project → Project → Tasks* and then click **Clear** button and then **Unassigned** button.

**Tip: Shortcuts**

*Every user should create a link in their own shortcuts to the Tasks menu, because they will have to consult this menu several times a day.*

The *Delegations* tab allows you to define links between your tasks. From *Parent Tasks* set the tasks that are related to this task. Use this feature to define the order in which tasks need to be accomplished, i.e. task 2 may not be executed before task 1.

### 19.1.3 Invoicing Tasks

Several methods of invoicing have already been described:

- invoicing from a sales order,
- invoicing on the basis of analytic costs (service times, expenses),
- invoicing on the basis of deliveries,
- manual invoicing.

Although invoicing tasks might appear useful, in certain situations it is best to invoice from the service or purchase orders instead. These methods of invoicing are more flexible, with various pricing levels set out in the pricelist, and different products that can be invoiced. And it is helpful to limit the number of invoicing methods in your company by extending the use of an invoicing method that you already have.

If you want to connect your Sales Order with Project tasks you should create products such as **Consultant** and **Senior Developer**. These products should be configured with *Product Type Service*, a *Procurement Method of Make to Order*, and a *Supply Method of Produce*. Once you have set this up, OpenERP automatically creates a task in project management when the order is approved. You can even take this further by adding a default project to your product. In the Product form, on the *Procurement & Locations* tab, enter the default project to which the automatically created task (from the sales order) should be linked.

You can also change some of the order parameters, which affects the invoice:
• **Shipping Policy**: Invoice on Order After Delivery (when the task is closed),
• **Invoice On**: Shipped Quantities (actual hours in the task).

Create the *Sales Order* using the product *Consultant* with the above configuration and confirm it. You can find the task created from this sale order using the menu *Project → Project → Tasks*. Once you find that task, click on the *Start Task* button in order to start it. You have to manually assign the project for this task, unless you specified a default project in the Product form. When you complete the task enter the information in the *Task Work* field. Then click the *Done* button in order to indicate to OpenERP that this task is finished. As for example the new task *SO008: Create SRS* generated from sales order *SO0008* as shown in following figure.

![Task created from Sales Order](image)

**Figure 19.2: Task created from Sales Order**

**Tip:** You need to carefully configure the analytic account related to this project. If you use the Billing tab of the project to do this, the analytic account linked to the project will automatically get the related settings.

After finishing this task go to the menu *Project → Invoicing → Invoice Tasks Work* in order to find the list of uninvoiced task works. Click the action *Invoice analytic lines* when you want to create an invoice for this task work.

![Form to Create Invoice from Tasks Work](image)

**Figure 19.3: Form to Create Invoice from Tasks Work**

### 19.1.4 Priority Management

Several methods can be used for ordering tasks by their respective priorities. OpenERP orders tasks based on a function of the following fields: *Sequence*, *Priority*, and *Deadline*.

Use the *Sequence* field on the second tab, *Extra Info*, to plan a project made up of several tasks. In the case of an IT project, for example, where development tasks are done in a given order, the first task to do will be sequence number 1, then numbers 2, 3, 4 and so on. When you first open the list of project tasks, they are listed in their sequence order. You can simply drag and drop tasks to change their sequence.

You can use one of these three ordering methods, or combine several of them, depending on the project.
Note: Agile methods
OpenERP implements the agile methodology Scrum for IT development projects in the project_scrum module. Scrum supplements the task system with the following concepts: long-term planning, sprints, iterative development, progress meetings, burndown chart, and product backlog.
Look at the site: http://controlchaos.com for more information on the Scrum methodology.

Figure 19.4: Gantt chart, calculated for earliest delivery

You can set the Working Time in the project file. If you do not specify anything, OpenERP assumes by default that you work 8 hours a day from Monday to Sunday. Once the time is specified you can call up a project Gantt chart from Tasks. The system then calculates a project plan for earliest delivery using task ordering and the working time.

Tip: Calendar View
OpenERP can give you a calendar view of the different tasks in both the web client and the GTK client. This is all based on the deadline data and displays only tasks that have a deadline. You can then delete, create or modify tasks using drag and drop (only in web).

Calendar View of the System Tasks

19.1.5 Delegate your Tasks

To delegate a task to another user you can just change the person responsible for that task. However the system does not help you track tasks that you have delegated, such as monitoring of work done, if you do it this way.

Figure 19.5: Form for Delegating a Task to Another User
Instead, you can use the *Delegate* button on a task.

The system enables you to modify tasks at all levels in the chain of delegation, to add additional information. A task can therefore start as a global objective and become more detailed as it is delegated down in the hierarchy.

The second tab on the task form gives you a complete history of the chain of delegation for each task. You can find a link to the parent task there, and the different tasks that have been delegated.

### 19.2 Long Term Project Planning

You can plan your projects with Long Term Planning. To do this, use the *Reconfigure* wizard and in the *Project Application Configuration* section, select *Long Term Planning* and click *Configure*. This installs the *project_long_term* module. By using this feature you can link tasks to your planning to have a great view of who will do what at a specific time.

The traditional phased approach identifies the sequence of steps to be completed. *Faces* library is used for scheduling phases and tasks based on calendar resources. So resource availability or resource leaves are tracked using this tool. The Gantt chart allows you to easily manage your resources and plans by mere drag & drop. The Calendar view also helps you map your deadlines and tasks needing attention.

#### 19.2.1 Project Phases

You can subdivide your larger projects into several phases. To define a new phase, go to *Project* → *Project* → *Project Phases* and click *New*. You must link your phase to a project through the *Project* field. For each phase, you can define your resources allocation (human or machine), describe the different tasks and link your phase to previous and following ones. You can also add constraints linked with dates and scheduling. A Gantt view of your project is available from this menu, which you may alternatively open through the *Project* → *Long Term Planning* → *Project Phases* menu.

![Figure 19.6: Form View of Project Phase](image)

#### 19.2.2 Scheduling

You need to define a working schedule and leaves since the project scheduler will use these to calculate the project dates. Ensure that you have entered a working schedule for your project in the *Working Time* field in the *Administration* tab of the *Project* form. This is useful to generate accurate Gantt charts for your project.
If you have tasks related to a phase, you can see them in the Tasks Details tab of your phase form. Schedule them by clicking the Schedule Tasks button. All the tasks which are in draft, pending and open state are scheduled and their dates are calculated based on the starting date of the phase.

Figure 19.7: Schedule Related Unclosed Tasks

You can similarly derive the Gantt charts for Project Phases and Resources Allocation in the following ways:

**Compute Phase Scheduling**

Obtain the Gantt chart for Project Phases through the menu Project → Scheduling → Compute Phase Scheduling. A dialog box will appear allowing you to select all projects or a single project. It will compute the start date and end date of the phases which are in draft, open and pending state of the given project. Click Compute to open Gantt view.

Figure 19.8: Gantt Chart for Project Phases

**Compute Tasks Scheduling**

This feature has the same purpose as the previous one and is used only for projects that are not cut in phases, but only consist of a list of tasks. To access it, go to Project → Scheduling → Compute Task Scheduling. You must and can select only a single project for computation. It shows the Gantt chart for Resources Allocation.
19.3 Planning to Improve Leadership

Planning in a company often takes the form of regular meetings between the different teams. Each team has a certain number of projects and objectives that they must organize and establish priorities for. Ideally, these planning meetings should be short but regular and systematic. They can be weekly or monthly depending on the type of activity. A planning meeting often runs in three phases:

1. Minutes of the preceding period, and analysis of the work done compared to the planned work.
2. Introduction of new projects.
3. Planning the next period.

The planning function covers several objectives which will be described in this section:

- planning live projects against the commitments that have been made to clients,
- determining staffing (HR) requirements in the coming month,
- setting work for each employee or team for the periods to come,
- analyzing the work done in the preceding periods,
- passing the high-level objectives to lower levels in the company’s hierarchy.

**Tip:** The social role of planning

Some project managers think that they can manage planning on their own. They are commonly overworked and think that meetings are a waste of time. Even if staff really can manage their work for themselves, you should recognize that this regular meeting is also aimed at reassurance. Without it you can get into unduly stressful situations from:

- feelings of overwork because they have lost sight of their priorities,
- lack of feedback and tracking of the work actually completed,
- an impression of poor organization if that has not been made explicit.

So the social role of planning should not be neglected. We have often experienced a background of stress in a company stemming from a lack of communication and planning.

19.3.1 Planning by time or by tasks?

There are two major approaches to enterprise planning: planning by task and planning by time. You can manage both with Open ERP.

In planning by task, the project manager assigns tasks from the different projects to each employee over a given period. Employees then carry out precisely the work they have been assigned by the project manager. Planning
by time consists of allocating, for each employee, some time on each of the different projects for the period concerned. The tasks for each project are ordered by priority and can be directly assigned to a user or left unassigned. Each employee then chooses the task that he or she will do next, based on the plans and the relative priorities of the tasks.

![Figure 19.10: Monthly planning for work time of each employee](image)

The figure *Monthly planning for work time of each employee* shows a monthly planning session where plans are being made for each employee to spend a number of days’ work on various different projects.

In this time-focused planning approach, clients’ priorities do not feature in the planning any more, but are explicit in the task list instead. So this approach helps you separate the planning of human resources on projects from the task prioritization within a project.

**Note:** Comparing the two planning methods

To illustrate the difference between planning by time and planning by task, take the case of an IT project that is estimated to be around six months of work. This project is managed by iterative cycles of development of around a month and a presentation is made to the client at the end of each cycle to track the progress of the project. At this meeting you plan what must be carried out for the following month. At the end of the month the account manager for the project invoices the client for the work done on the project.

Suppose that the project encounters a delay because it is more complex than expected. There are two ways of resolving the delay if you have no further resources: you can be

- late in your delivery of the planned functions, or
- on time, but with fewer functions than planned.

If your planning is based on phases and tasks you will report at the client meeting that it will take several weeks to complete everything that was planned for the current phase. Conversely, if you are planning by time you will keep the meeting with the client to close the present development phase and plan the new one, but only be able to present part of the planned functionality.

If the client is sensitive to delay, the first approach will cause acute unhappiness. You will have to re-plan the project and all of its future phases to take account of that delay. Some problems are also likely to occur later with invoicing, because it will be difficult for you to invoice any work that has been completed late but has not yet been shown to the client.

The second approach will require you to report on the functions that have not been completed, and on how they would fit into a future planning phase. That will not involve a break in the working time allocated to the project, however. You would then generate two different lists: a staffing plan for the different projects, and the list of tasks prioritized for the client’s project. This approach offers a number of advantages over the first one:

- The client will have the choice of delaying the end of the project by planning an extra phase, or letting go of some minor functions to be able to deliver a final system more rapidly,
- The client may re-plan the functions taking the new delay into account.
- You will be able to make the client gradually aware of the fact that project progress has come under pressure and that work is perhaps more complex than had been estimated at the outset.
- A delay in the delivery of several of the functions will not necessarily affect either monthly invoicing or project planning.

Being able to separate human resource planning from task prioritization simplifies your management of complex issues, such as adjusting for employee holidays or handling the constantly changing priorities within projects.
19.3.2 Plan your Time

Install the module `project_planning` to get additional functions that help with both planning and reporting on projects. Start a plan by using the menu `Project → Long Term Planning → Plannings`. On each planning line you should enter the user, the analytic account concerned, and the quantity of time allocated. The quantity will be expressed in hours or in days depending on the unit of measure used. For each line you can add a brief note about the work to be done.

Once the plan has been saved, use the other tabs of the planning form to check that the amount of time allocated to the employees or to the projects is right. The time allocated should match the employees’ employment contracts, for example 37.5 hours per week. The forecast time for the project should also match the commitments that you have made with client.

You should ideally complete all the planning for the current period. You can also complete some lines in the planning of future months – reserving resources on different project in response to your client commitments, for example. This enables you to manage your available human resources for the months ahead. Plans can be printed and/or sent to employees by email. Each employee can be given access to a dashboard that graphically shows the time allocated to him or her on a project and the time that has been worked so far. So each employee can decide which projects should be prioritized.

The employee then selects a task in the highest priority project. She ideally chooses either a task that has been directly assigned to her, or one which is high on the priority list that she is capable of completing, but is not yet directly assigned to anybody.

At the end of the period you can compare the duration of effective work on the different project to that of the initial estimate. Print the plan to obtain a comparison of the planned working time and the real time worked.

![Figure 19.11: Comparison of planned hours, worked hours and the productivity of employees by project](image)

You can also study several of your project’s figures from the menus in `Project → Reporting`.

19.3.3 Planning at all levels of the Hierarchy

To put planning in place across the whole company you can use a system of planning delegation.

The planning entry form can reflect the hierarchical structure of the company. To enter data into a plan line you can:

- assign time on a project to an employee,
- assign time on a project to a department manager for his whole team.

You can now allocate the working time on projects for the whole of a department, without having to detail each employee’s tasks. Then when a department manager creates his own plan he will find what is required of his group by his management at the bottom of the form. At the top of the form there is a place for assigning project work in detail to each member of department.

If you do not have to plan time to work on a final draft you can do it on an analytic account that relies on child accounts. This means that you can create plans to meet top-level objectives of the senior management team and then cascade them down through the different departments to establish a time budget for each employee. Each manager then uses his own plans for managing his level in the hierarchy.
19.4 The Art of Productivity without Stress

Now you can take a slight detour away from pure enterprise management by looking at some tools offered by Open ERP to improve your own personal time management. It is not much of a detour because good organization is the key to better productivity in your daily work. Open ERP’s project_gtd module was inspired by the work of two books focusing on efficient time management:

- Getting Things Done – The Art of Stress-Free Productivity, by David Allen (2001), most often referred to by its initials GTD (trademark registered since 2005). This book is built around the principle that people should clearly write down all their outstanding tasks and store the details about these tasks in a trustworthy system.
  
  They then do not have to worry about holding all of this stuff in their head. Since they can be quite sure that it is recorded safely, they can allow themselves to relax and so have the energy and time to concentrate on handling the tasks themselves systematically.

- The 7 Habits of Highly Effective People by Stephen R. Covey (1989) : the author advises organizations on the use of these practices, and reports on the productivity improvements in the organization that result.

<table>
<thead>
<tr>
<th>Note: Managing time efficiently</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Tip: De-stress yourself!</th>
</tr>
</thead>
<tbody>
<tr>
<td>Clear the tasks that clutter your thoughts by registering them in an organized system. This immediately helps you to de-stress yourself and organize your work in the best possible way.</td>
</tr>
<tr>
<td>If you feel stressed by too much work, do the following exercise to convince yourself about the benefits. Take some sheets of blank paper and write down everything that passes through your head about the things you need to do. For each task, note the next action to do on an adjacent line, and rank it by the date that you will commit yourself to doing it.</td>
</tr>
<tr>
<td>At the end of the exercise you will feel better organized, considerably de-stressed and remarkably free of worries!</td>
</tr>
</tbody>
</table>

The objective in this detour is not to detail the whole methodology but to describe the supporting tools provided by Open ERP’s project_gtd module.

19.4.1 Not everything that is urgent is necessarily important

The first modification brought by the module to the basic Open ERP system is a separation of the concepts of urgency and importance. Tasks are no longer classified by a single criterion but by the product of the two criteria, enabling you to prioritize matters that are both urgent and important in a single list.

Many managers with a heavy workload use urgency as their sole method of prioritization. The difficulty is then in working out how to plan for substantive tasks (like medium term objectives). These are not urgent but are nevertheless very important.

<table>
<thead>
<tr>
<th>Note: Example Distinction between urgency and importance</th>
</tr>
</thead>
<tbody>
<tr>
<td>If you are very well organized, urgent tasks can (and should often) be given lower precedence than important tasks. Take an example from daily life as an illustration: the case of having some time with your children. For most people this task is important. But if you have a busy professional life, the days and weeks flow on with endless urgent tasks to be resolved. Even if you manage your time well, you could let several months pass without spending time with your children because the task of seeing them is never as urgent as your other work, despite its importance.</td>
</tr>
</tbody>
</table>

In Open ERP urgency is given by the Deadline of the task and importance by the Priority. The classification of the tasks then results from the product of the two factors. The most important tasks and the most urgent both
appear at the top of the list.

19.4.2 Organizing your life systematically

A methodology of organizing yourself using the concepts of context and timebox is presented in this section.

Context

The context is determined by the work environment you must be in to deal with certain tasks. For example you could define the following contexts:

- **Office**: for tasks which have to be dealt with at your workplace (such as telephone a customer, or write a document),
- **Car**: for tasks that you need to do on the move (such as going shopping, or going to the post office),
- **Travel**: for tasks that you can handle on the plane or in the train while you are doing travelling on business (tasks such as writing an article, or analyzing a new product),
- **Home**: for tasks which have to happen at your private address (such as finding a cleaning contractor, or mowing the lawn).

An employee / system user can create his or her own contexts using the menu Project → Configuration → Tasks → Contexts.

Timebox

You then have to define the timeboxes. You have to complete the tasks in the time interval specified by a timebox. You usually define timeboxes with the following periods:

- **Today**: for tasks which must be handled today,
- **This Week**: for tasks that have to be dealt with this week,
- **This Month**: for tasks which have to be completed within the month,
- **Long Term**: for tasks that can be dealt with in more than one month.

A task can be put in one and only one timebox at a time.

You should distinguish between a timebox and the deadline for completing a task because the deadline is usually fixed by the requirements of the project manager. A timebox, by contrast, is selected with reference to what an individual can do.

To define timeboxes for your company, use the menu Project → Configuration → Tasks → Timeboxes.

Methodology and iterative process

To organize your tasks efficiently, Open ERP uses a method based on the following systematic and iterative process:

1. Identify all the tasks that you have to deal with, including everything that keeps you awake at night, and enter them in Tasks, which you will find in the menu Project → Project → Tasks.
2. Classify the tasks periodically, assigning them a context and a timebox. This indicates both when and where the task should be handled. If a task takes less than 10 minutes then maybe it could be handled immediately.
3. Every day, carry out the following process:
   - First thing in the morning, select those tasks contained in the current week’s timebox that you want to deal with today. These are presented in order of importance and urgency, so you should select the tasks closest to the top of the list.
• Carry out each task, that is to say either work on the task yourself or delegate it to another user,
• Last thing at the end of the day’s work, empty that day’s timebox and return all unclosed tasks into
the week’s timebox.

4. Repeat the same process each week and each month for the respective timeboxes.

**Tip:** Do not confuse Agenda and Timebox
The idea of timebox is independent from that of an agenda. Certain tasks, such as meetings, must be done on a
precise date. So they cannot be managed by the timebox system but by an agenda.
The ideal is to put the minimum of things on the agenda and to put there only tasks that have a fixed date. The
timebox system is more flexible and more efficient for dealing with multiple tasks.

So start by entering all the tasks required by project. These could have been entered by another user and assigned
to you. It is important to code in all of the tasks that are buzzing around in your head, just to get them off your
mind. A task could be:

• work to be done,
• a short objective, medium or long term,
• a complex project that has not yet been broken into tasks.

A project or an objective over several days can be summarized in a single task. You do not have to detail each
operation if the actions to be done are sufficiently clear to you.

You have to empty your Tasks periodically. To do that, use the menu Project → Project → Tasks. Assign a
timebox and a context to each task. This operation should not take more than a few minutes because you are not
dealing with the tasks themselves, just classifying them.

![Figure 19.12: Timebox for tasks to be done today](image)

Then click on the button at the top right Plannify Timebox. This procedure lets you select the tasks for the day
from those in the timebox for the week. This operation gives you an overview of the medium term tasks and
objectives and makes you review them there at least once a day. It is then that you would decide to allocate a part
of your time that day to certain tasks based on your priorities.

Since the tasks are sorted by priority, it is sufficient to take the first from the list, up to the number of hours in
your day. That will only take a minute, because the selection is not taken from every task you know about in the
future, but just from those selected for the current week.

Once the timebox has been completed you can start your daily work on the tasks. For each task you can start
work on it, delegate it, close it, or cancel it.

At the end of the day you empty the timebox using the button at the top right Empty Timebox. All the tasks that
have not been done are sent back to the weekly timebox to sit in amongst the tasks that will be planned next
morning.

Do the same each week and each month using the same principles, but just using the appropriate timeboxes for
those periods.

**Some convincing results**

After a few days of carefully practising this method, users have reported the following improvements:

• a reduction in the number of tasks and objectives that were forgotten,
• a reduction in stress because people felt more in control of their situation,
• a change of the priorities in the types of tasks carried out daily,
• more notice taken of the urgency and importance of tasks and objectives in the long-term organization of time,
• better management of task delegation and the selection of which tasks were better to delegate,

Finally, it is important to note this system is totally integrated with Open ERP’s project management function. Staff can use the system or not depending on their own needs. The system is complementary to the project management function that handles team organization and company-wide planning.
Part VI

Manage your Warehouse and Get your Manufacturing done
This part of the book concentrates on physical materials - the handling of stock and the transformation of materials by assembly and manufacture.

Stocks are the physical embodiment of their product specification, things rather than datasheets. So they need to be stored and moved between locations, and tracked in sets and individually. They have a size, a weight, and a cost. Open ERP manages all of this in some rather useful and unique ways.

Manufacture is the transformation of materials and components, perhaps using measurable resources, into other products and services, adding value to your company on the way.
Open ERP’s stock management is at once very simple, flexible and complete. It is based on the concept of double entry that revolutionized accounting. The system can be described by Lavoisier’s maxim “nothing lost, everything changed” or, better, “everything moved”. In OpenERP you do not talk of disappearance, consumption or loss of products: instead you speak only of stock moves from one place to another.

Just as in accounting, the OpenERP system manages counterparts to each of its main operations such as receipts from suppliers, deliveries to customers, profit and loss from inventory, and consumption of raw materials. Stock movements are always made from one location to another. To satisfy the need for a counterpart to each stock movement, the software supports different types of stock location:

- Physical stock locations,
- Partner locations,
- Virtual counterparts such as production and inventory.

Physical locations represent warehouses and their hierarchical structure. These are generally the locations that are managed by traditional stock management systems.

Partner locations represent your customers’ and suppliers’ stocks. To reconcile them with your accounts, these stores play the role of third-party accounts. Reception from a supplier can be shown by the movement of goods from a partner location to a physical location in your own company. As you see, supplier locations usually show negative stocks and customer locations usually show positive stocks.

Virtual counterparts for production are used in manufacturing operations. Manufacturing is characterized by the consumption of raw materials and the production of finished products. Virtual locations are used for the counterparts of these two operations.

Inventory locations are counterparts of the stock operations that represent your company’s profit and loss in terms of your stocks.

The figure Location structure when OpenERP has just been installed shows the initial configuration of the locations when the software is installed.
Figure 20.1: Location structure when OpenERP has just been installed

Note: Hierarchical stock locations

In OpenERP, locations are structured hierarchically. You can structure your locations as a tree, dependent on a parent-child relationship. This gives you more detailed levels of analysis of your stock operations and the organization of your warehouses.

Tip: Locations and Warehouses

In OpenERP a Warehouse represents your places of physical stock. A warehouse can be structured into several locations at multiple levels. Locations are used to manage all types of storage place, such as at the customer and production counterparts.

For this chapter you should start with a fresh database that includes demo data, with Warehouse Management and its dependencies installed and no particular chart of accounts configured.

20.1 Understanding Double-Entry Stock Management

To illustrate this concept of stock management, see how stock moves are generated by the following operations:

- Receiving products from a supplier,
- Delivery to a customer,
- Inventory operation for lost materials,
- Manufacturing.

The structure of stock locations is shown by the figure Location structure when OpenERP has just been installed. Stocks are assumed to be totally empty and no operation is in progress nor planned.

If you order ‘30 bicycles’ from a supplier, OpenERP will do the following operations after the receipt of the products:
Table 20.1: Stock Move Operation from Suppliers to Stock

<table>
<thead>
<tr>
<th>Location</th>
<th>Products</th>
</tr>
</thead>
<tbody>
<tr>
<td>Partner Locations &gt; Suppliers</td>
<td>-30 bicycles</td>
</tr>
<tr>
<td>Physical Locations &gt; OpenERP S.A. &gt; Stock</td>
<td>+30 bicycles</td>
</tr>
</tbody>
</table>

If you deliver 2 bicycles to a European customer you will get the following transactions for the delivery:

Table 20.2: Stock Move Operation from Stock to European Customers

<table>
<thead>
<tr>
<th>Location</th>
<th>Products</th>
</tr>
</thead>
<tbody>
<tr>
<td>Physical Locations &gt; OpenERP S.A. &gt; Stock</td>
<td>-2 bicycles</td>
</tr>
<tr>
<td>Partner Locations &gt; Customers &gt; European Customers</td>
<td>+2 bicycles</td>
</tr>
</tbody>
</table>

When the two operations are complete, you will see the following stock in each location:

Table 20.3: Resulting Stock Situation

<table>
<thead>
<tr>
<th>Location</th>
<th>Products</th>
</tr>
</thead>
<tbody>
<tr>
<td>Partner Locations &gt; Suppliers</td>
<td>-30 bicycles</td>
</tr>
<tr>
<td>Physical Locations &gt; OpenERP S.A. &gt; Stock</td>
<td>+28 bicycles</td>
</tr>
<tr>
<td>Partner Locations &gt; Customers &gt; European Customers</td>
<td>+2 bicycles</td>
</tr>
</tbody>
</table>

So you can see that the sum of the stocks of a product in all the locations in OpenERP is always zero. In accounting you would say that the sum of the debits is equal to the sum of the credits.

Partner locations (customers and suppliers) are not located under your company in the hierarchical structure, so their contents are not considered as part of your own stock. So if you just look at the physical locations inside your own company those two bicycles are no longer in your company. They are no longer in your own physical stock, but it is still very useful to see them in your customer’s stock because that helps when you carry out detailed stock management analysis.

**Tip:** For Consignment Stock, you need to define the location for the consignment customer or supplier concerned as part of your own stock.

**Note:** Accounts

In managing stock, a gap between the data in the software and real quantities in stock is difficult to avoid. Double-entry stock management gives twice as many opportunities to find an error. If you forget two items of stock this error will automatically be reflected in the counterpart’s location.

You can make a comparison with accounting, where you will easily find an error because you can look for an anomaly in an account or in the counterparts: if there is not enough in a bank account then that is probably because someone has forgotten to enter a customer’s invoice payment. You always know that the sum of debits must equal the sum of the credits in both accounting and OpenERP’s stock management.

In accounting, all documents lead to accounting entries that form the basis of management accounting. If you create invoices or code in statements of account, for example, the results of the operations are accounting entries on accounts. And it is the same for stock management in OpenERP. All stock operations are carried out as simple stock moves. Whether you pack items, or manufacture them, or carry out a stock inventory operation, stock moves are carried out every time.

You have seen a fairly simple example of goods receipt and product delivery, but some operations are less obvious – a stock inventory operation, for example. An inventory operation is carried out when you compare the stock shown in software with real stock numbers counted in the stores. In OpenERP, with its double-entry stock management, you would use stock moves for this inventory operation. That helps you manage your stock traceability. Suppose there are 26 bicycles in real stock but OpenERP shows 28 in the system. You then have to reduce the number in OpenERP to 26. This reduction of 2 units is considered as a loss or destruction of products and the correction is carried out as in the following operation:
Table 20.4: Inventory Operation to Adjust Stock

<table>
<thead>
<tr>
<th>Location</th>
<th>Products</th>
</tr>
</thead>
<tbody>
<tr>
<td>Physical Locations &gt; OpenERP S.A. &gt; Stock</td>
<td>-2 bicycles</td>
</tr>
<tr>
<td>Virtual Locations &gt; Inventory Loss</td>
<td>+2 bicycles</td>
</tr>
</tbody>
</table>

The product stock under consideration then becomes:

Table 20.5: Real and Counterpart Stocks when Operations are Completed

<table>
<thead>
<tr>
<th>Location</th>
<th>Products</th>
</tr>
</thead>
<tbody>
<tr>
<td>Partner Locations &gt; Suppliers</td>
<td>-30 bicycles</td>
</tr>
<tr>
<td>Physical Locations &gt; OpenERP S.A. &gt; Stock</td>
<td>+26 bicycles</td>
</tr>
<tr>
<td>Partner Locations &gt; Customers &gt; European Customers</td>
<td>+2 bicycles</td>
</tr>
<tr>
<td>Virtual Locations &gt; Inventory Loss</td>
<td>+2 bicycles</td>
</tr>
</tbody>
</table>

This example shows one of the great advantages of this approach in terms of performance analysis. After a few months, you can just make a stock valuation of the location Virtual Locations > Inventory Loss to give you the value of the company’s stock losses in the given period.

Now see how the following manufacturing operation is structured in OpenERP. To make a bicycle you need two wheels and a frame. This means that there should be a reduction of two wheels and a frame from real stock and the addition of a bicycle there. The consumption / production is formalized by moving products out of and into physical stock. The stock operations for this are as follows:

Table 20.6: Stock Situation Resulting from Manufacturing

<table>
<thead>
<tr>
<th>Location</th>
<th>Products</th>
<th>Step</th>
</tr>
</thead>
<tbody>
<tr>
<td>Virtual Locations &gt; Production</td>
<td>+2 Wheels</td>
<td>Consumption of raw materials</td>
</tr>
<tr>
<td>Physical Locations &gt; OpenERP S.A. &gt; Stock</td>
<td>-2 Wheels</td>
<td>Consumption of raw materials</td>
</tr>
<tr>
<td>Virtual Locations &gt; Production</td>
<td>+1 Frame</td>
<td>Consumption of raw materials</td>
</tr>
<tr>
<td>Physical Locations &gt; OpenERP S.A. &gt; Stock</td>
<td>-1 Frame</td>
<td>Consumption of raw materials</td>
</tr>
<tr>
<td>Virtual Locations &gt; Production</td>
<td>-1 Bicycle</td>
<td>Manufacture of finished products</td>
</tr>
<tr>
<td>Physical Locations &gt; OpenERP S.A. &gt; Stock</td>
<td>+1 Bicycle</td>
<td>Manufacture of finished products</td>
</tr>
</tbody>
</table>

So now you have got the outcome you need from the consumption of raw materials and the manufacturing of finished products.

**Note:** Assessing created value

You might already have noticed a useful effect of this approach: if you do a stock valuation in the Virtual Locations > Production location you get a statement of value created by your company (as a negative amount). Stock valuation in any given location is calculated by multiplying quantities of products in stock by their cost. In this case the raw material value is deducted from the finished product value.

### 20.2 From Supplier to Customer

Now you will follow a practical example by adapting stock management operations. You will learn how to:

- Define a new product
- Set initial inventory
- Receive products from a supplier
- Deliver to a customer
- Analyse the status of stock

#### 20.2.1 Define a New Product

To start, define the following product:
Table 20.7: Product Definition

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Central Heating Type 1</td>
</tr>
<tr>
<td>Code</td>
<td>CCT1</td>
</tr>
<tr>
<td>Product Type</td>
<td>Stockable Product</td>
</tr>
<tr>
<td>Supply Method</td>
<td>Buy</td>
</tr>
</tbody>
</table>

Use the menu *Warehouse → Product → Products*, then click *New* to define a new product.

Figure 20.2: Definition of a new product

Three fields are important for stock management when you are configuring a new product:

- **Product Type**,
- **Procurement Method**,  
- **Supply Method**.

### 20.2.2 Product Types

The product type indicates whether the product is handled in stock management and if OpenERP manages its procurement. The three distinct product types are:

- **Stockable Product**: This product is used in stock management and its replenishment is more or less automated as defined by the rules established in the system. Examples: a bicycle, a computer or a central heating system.

- **Consumable**: This product is handled in stock management, you can receive it, deliver it and produce it. However, its stock level is not managed by the system. OpenERP assumes that you have got sufficient levels in stock at all time, so it does not restock it automatically. Example: nails.

- **Service**: It does not appear in the various stock operations. Example, a consulting service.
20.2.3 Procurement Methods – Make to Stock and Make to Order

The procurement method determines how the product will be replenished:

- **Make to Stock**: your customers are supplied from available stock. You procure a set quantity of each product when its stock is too low (according to minimum stock rules). Example: a classic distributor.

- **Make to Order**: when a customer order is confirmed, you then procure or manufacture the products for this order. A customer order ‘Make to Order’ will not modify stock in the medium term because you restock with the exact amount that was ordered. Example: computers from a large supplier assembled on demand.

You find a mix of these two modes used for the different final and intermediate products in most industries. The procurement method shown on the product form is a default value for the order, enabling the salesperson to choose the best mode for fulfilling a particular order by varying the sales order parameters as needed.

The figures *Change in stock for a product managed as Make to Stock* and *Change in stock for a product managed as Make to Order* show the change of stock levels for one product managed Make to Order and another managed Make to Stock. The two figures are taken from OpenERP’s *Stock Level Forecast* report, available from the product form.

![Figure 20.3: Change in stock for a product managed as Make to Stock](image)

![Figure 20.4: Change in stock for a product managed as Make to Order](image)

**Note**: Logistical Methods

The Make to Stock logistical approach is usually used for high volumes and when the demand is seasonal or otherwise easy to forecast. The Make to Order approach is used for products that are measured, or very expensive to stock or have a short restocking time.

20.2.4 Supply Methods

OpenERP supports two supply methods:

- **Produce**: when the product is manufactured or the service is supplied from internal resources.

- **Buy**: when the product is bought from a supplier.
These are just the default settings used by the system during automated replenishment. The same product can be either manufactured internally or bought from a supplier.

These three fields (Supply Method, Procurement Method, Product Type) determine the system’s behaviour when a product is required. The system will generate different documents depending on the configuration of these three fields when satisfying an order, a price quotation to a supplier or a manufacturing order.

OpenERP manages both stockable products and services. A service bought from a supplier in Make to Order mode, will generate a subcontract order from the supplier in question.

Figure Workflow for automatic procurement, depending on the configuration of the product illustrates different cases for automatic procurement.

![Workflow for automatic procurement, depending on the configuration of the product](image)

The table below shows all possible cases for the figure Workflow for automatic procurement, depending on the configuration of the product.

Table 20.8: Consequences of Procurement Methods Make to Stock (MTS) and Make To Order (MTO)

<table>
<thead>
<tr>
<th>Procurement Method</th>
<th>Produce</th>
<th>Buy</th>
</tr>
</thead>
<tbody>
<tr>
<td>MTS</td>
<td>Wait for availability</td>
<td>Wait for availability</td>
</tr>
<tr>
<td>MTO</td>
<td>Production Order</td>
<td>Supplier Order</td>
</tr>
</tbody>
</table>

Table 20.9: Consequences of Procurement Methods when using Services

<table>
<thead>
<tr>
<th>Procurement Method</th>
<th>Produce</th>
<th>Buy</th>
</tr>
</thead>
<tbody>
<tr>
<td>MTS</td>
<td>/ Create task</td>
<td>/ Subcontract</td>
</tr>
<tr>
<td>MTO</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

You will learn more about the automated management processes for procurement further on in this chapter.
20.2.5 Units of Measure

OpenERP supports several units of measure. Quantities of the same product can be expressed in several units of measure at once. For example you can buy grain by the tonne and resell it by kg. You just have to make sure that all the units of measure used for a product are in the same units of measure category.

**Note:** Categories of units of measure
All units of measure in the same category are convertible from one unit to another.

The table below shows some examples of units of measure and their category. The factor is used to convert from one unit of measure to another as long as they are in the same category.

<table>
<thead>
<tr>
<th>UoM</th>
<th>Category</th>
<th>Ratio</th>
<th>UoM Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Kg</td>
<td>Weight</td>
<td>1</td>
<td>Reference</td>
</tr>
<tr>
<td>Gram</td>
<td>Weight</td>
<td>1000</td>
<td>Smaller</td>
</tr>
<tr>
<td>Tonne</td>
<td>Weight</td>
<td>1000</td>
<td>Bigger</td>
</tr>
<tr>
<td>Hour</td>
<td>Working time</td>
<td>8</td>
<td>Smaller</td>
</tr>
<tr>
<td>Day</td>
<td>Working time</td>
<td>1</td>
<td>Reference</td>
</tr>
<tr>
<td>Half-day</td>
<td>Working time</td>
<td>4</td>
<td>Smaller</td>
</tr>
<tr>
<td>Item</td>
<td>Unit</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>100 Items</td>
<td>Unit</td>
<td>0.01</td>
<td></td>
</tr>
</tbody>
</table>

Depending on the table above you have 1Kg = 1000g = 0.001 Tonnes. A product in the Weight category could be expressed in Kg, Tonnes or Grammes. You cannot express it in hours or pieces.

Use the menu Warehouse → Configuration → Products → Units of Measure → Units of Measure to define a new unit of measure.

In the definition of a Unit of Measure, you have a Rounding precision factor which shows how amounts are rounded after the conversion. A value of 1 gives rounding to the level of one unit. 0.01 gives rounding to one hundredth.

**Note:** Secondary Units
OpenERP supports double units of measure. When you use this, the whole of the stock management system is encoded in two units that do not have a real link between them. This is very useful in the agro-food industry, for example: you sell ham by the piece but invoice by the Kg. A weighing operation is needed before invoicing the customer.

To activate the management options for double units of measure, assign the group Useability / Product UoS View to your user.

In this case the same product can be expressed in two units of measure belonging to different categories. You can then distinguish between the unit of stock management (the piece) and the unit of invoicing or sale (kg).

In the product form you can then set one unit of measure for sales and stock management, and one unit of measure for purchases.

These units are given suggested titles. For each operation on a product you can use another unit of measure, as long as it can be found in the same category as the two units already defined. If you use another unit of measure, OpenERP automatically handles the conversion of prices and quantities.

So if you have 430 Kg of carrots at 5.30 EUR/Kg, OpenERP will automatically make the conversion if you want to sell in tonnes – 0.43 tonnes at 5300 EUR / tonne. If you had set a rounding factor of 0.1 for the tonne unit of measure then OpenERP will tell you that you have only 0.4 tonnes available.

### 20.3 Stocks

In the product form you can find the Stock by Location action that will give you the stock levels of the various different products in any selected location. If you have not selected any location, OpenERP calculates stocks for
all of the physical locations. When you are in the Stock by Location view, click the Print button to print the Location Content or the Location Inventory Overview reports.

**Note:** Availability of stock

Depending on whether you look at the product from a customer order or from the menu of a product form you can get different values for stock availability. If you use the product menu you get the stock in all of the physical stock locations. Looking at the product from the order you will only see the report of the warehouse selected in the order.

In this respect, two important fields in the product form are:

- **Real Stock**: Quantity physically present in your warehouse,
- **Virtual Stock**: Calculated as follows: real stock – outgoing + incoming.

**Note:** Virtual Stock

Virtual stock is very useful because it shows what the salespeople can sell. If the virtual stock is higher than the real stock, this means products will be coming in. If virtual stock is smaller than real stock, certain products are reserved for other sales orders or work orders.

**Tip:** Detail of future stock

To get more details about future stock, you can click Stock Level Forecast to the right of the product form to get the report Printout of forecast stock levels below. OpenERP shows a graph of the change of stock in the days to come, varying as a function of purchase orders, confirmed production and sales orders.

**Tip:** Filter on Stock by Location

By default in Product list view, the columns Real Stock and Virtual Stock show the stock figures for all stock locations where a product is stored. Use the Extended Filters to enter a specific stock location if you want to see the stock in a specific location.

### 20.3.1 Lead Times and Locations

The tab *Procurement & Locations* contains information about different lead times and locations. Three lead time figures are available:

- **Customer Lead Time**: lead time promised to the customer, expressed in number of days between the order and the delivery to the customer,
- **Manufacturing Lead Time**: lead time, in days, between a production order and the end of production of the finished product,
- **Warranty (months)**: length of time in months for the warranty of the delivered products.
Note: Warranty
The warranty period is used in the Repairs management and after-sales service. You can find more information on this subject in Manufacturing.

Fields in the section Storage Localisation are given for information – they do not have any impact on the management of stock.

Counter-Part Locations Properties are automatically proposed by the system but the different values can be modified. You will find counterpart locations for:

- Procurement,
- Production,
- Inventory.

A procurement location is a temporary location for stock moves that have not yet been finalized by the scheduler. When the system does not yet know if procurement is to be done by a purchase or production, OpenERP uses the counterpart location Procurement. In this location, you will find everything that has not yet been planned by the system. The quantities of product in this location cancel each other out.

20.3.2 Initial Inventory

Once a product has been defined, use an initial inventory operation to put current quantities into the system by location for the products in stock. Use the menu Warehouse → Inventory Control → Physical Inventories to do your initial inventory.

![Figure 20.7: Defining a new inventory operation](image)

Give a name (for example Initial Inventory or Lost Product XYZ) and a date (proposed by default) for each inventory operation.

You have three ways of doing an inventory.

- Click the Import inventory action and select the location concerned. You can choose to include child locations and set the inventory to zero (especially useful to ensure the count is done correctly).
- You can update the inventory from the Product form. Go to the Information tab, Stocks and click the Update button. On confirmation, OpenERP will create a Physical Inventory.
- You can manually add inventory lines. You can then enter data about the quantities available for each product by location. Start by entering the location, for example Stock, and then select the product. OpenERP automatically completes the quantity available for that product in the location shown. You can then change that value to correct the value in stock.

Enter data for a single line in your inventory:
• **Location**: Stock,
• **Product**: PC1 Computers,
• **Quantity**: 23 Units.

**Tip: Periodical Inventory**
You are usually legally required to do a stock check of all your products at least once a year. As well as doing a complete annual stock check, OpenERP also supports the method of periodical inventory. That means you can check the stock levels of a proportion of your products every so often. This system is accepted in France as long as you can guarantee that all of your products have been counted at least once per year. To see the last inventory count per product, use the report Warehouse → Reporting → Last Product Inventories. You can do this the same way for all products and all locations, so you only carry out small inventory operations through the year rather than a single large stock check at one point in the year (which usually turns out to be at an inconvenient time).

When your inventory operation is finished, you can confirm it using the Confirm Inventory button to the bottom right of the form. OpenERP will then automatically create the stock moves to close the gaps, as mentioned at the start of this chapter. You can verify the moves generated using the Posted Inventory tab of the inventory operation form.

The correct levels of your product are now in your stock locations. A simple way of verifying this is to reopen the product form to see the quantities available in stock.

### 20.3.3 Receipt of a Supplier Order by Purchase Order

Incoming Shipments forms are automatically prepared by OpenERP from the purchase management process. You will find a list of all the awaited receipts in the menu Warehouse → Warehouse Management → Incoming Shipments. Use the order number or the supplier name to find the right goods receipt form for confirmation of a goods in. This approach enables you to control quantities received by referring to the quantities ordered.

![List of items waiting](image)

**Figure 20.8: List of items waiting**

You can also do goods-in data entry manually if there is no order, using the same menu by clicking on New button.

A new goods-in data entry form then opens. Enter the supplier data in the Address field and you can type in the reference number from your supplier in the field Origin. You should then enter data about the products received in the lines.

The source location is already completed by default because of your supplier selection. You should then give the destination location where you will place the products. For example, enter Stock. At this stage you can set a lot number for traceability (this function will be described later in this chapter, so leave this field empty for the moment).

Once the form has been completed you can confirm the receipt of all the products at the same time using the Process Now button. If you want to enter data for a goods receipt that you are still waiting for click the button Process Later.
The products then arrive in stock and should reflect the quantities shown on the product form.

In the Incoming Shipments form, the field Invoicing Control lets you influence the way you send invoices to suppliers. If this is set to To be invoiced, a supplier invoice will now be generated automatically in the draft state, based on the goods received. Your accountant then has to confirm this pre-invoicing once the supplier’s invoice is received. This enables you to verify that the invoiced quantities correspond to the quantities received.

### 20.3.4 Receipt of a Supplier Order by Product

From this version on, you can also handle receptions by product, even from List view. Go to Warehouse → Products Moves → Receive Products.

Filters allow you to easily select receipts to be done, and so on. One way to quickly receive products is to Group by Supplier and select To Do.

This is very useful functionality when your supplier sends the goods for several purchase orders at a time. You can now just receive the products, regardless of the purchase order they come from.

The List view offers great flexibility and allows you to rapidly receive products by keeping full functionality! Of course, you can handle both partial and complete receptions and you can add information about the production lots and packs.

Of course, you can also accomplish this from Form view.

### 20.3.5 Customer Delivery

Everything about goods receipt can also be done manually for a customer delivery. But this time, use the automated product delivery processes based on customer orders. Install the sale module so that you can proceed further in this section of the chapter.

Now create a new customer order from the menu Sales → Sales → Sales Orders. Enter the following data in this order:

- **Shop**: OpenERP S.A.
- **Customer**: Agrolait
- **Order Line**:
  - **Product**: Basic+ PC (assembly on order),
  - **Quantity**: 3 PCE
– **Procurement Method**: from stock.

You have already seen that OpenERP shows you the available product stock when you have selected list mode. The real stock is equal to the virtual stock because you have nothing to deliver to customers and you are not waiting for any of these products to be received into stock. The salesperson then has all the information needed to take orders efficiently.

![Figure 20.10: Entering an order for three computers](image)

Then confirm the quotation to convert it to an order. If you return to the product form, you will see the virtual stock is now smaller than the real stock. Indeed, three products have been reserved by the order that you created, so they cannot be sold to another customer.

Start the scheduler through the menu **Warehouse → Schedulers → Compute Schedulers**. Its functionality will be detailed in **Manufacturing**. This manages the reservation of products and places orders based on the dates promised to customers, and the various internal lead times and priorities.

**Tip: Just in Time**

*Install the module mrp_jit to schedule each order in real time after it has been confirmed. This means that you do not have to start the scheduler or wait for its periodic start time.*

Now have a look at the list of deliveries waiting to be carried out using the menu **Warehouse → Warehouse Management → Delivery Orders**. You find a line there for your order representing the items to be sent. Double-click the line to see the detail of the items proposed by OpenERP.

![Figure 20.11: Items on a Customer Order](image)
**Tip:** States

OpenERP distinguishes between the states **Confirmed** and **Assigned**. An item is **Confirmed** when it is needed, but the available stock may be insufficient. An item is **Assigned** when it is available in stock and the storesperson reserves it: the necessary products have been reserved for this specific operation.

You can also confirm a customer delivery using the **Confirm Order** button in the Sales Order. When you click the **Process** button of Outgoing Deliveries, a window opens where you can enter the quantities actually delivered. If you enter a value less than the forecasted one, OpenERP automatically generates a partial delivery note and a new order for the remaining items. For this exercise, just confirm all the products.

If you return to the list of current orders you will see that your order has now been marked as delivered (done). A progress indicator from 0% to 100% is shown by each order so that the salesperson can follow the progress of his orders at a glance.

![Figure 20.12: List of Orders with their Delivery State](image)

**Note:** Negative Stock

Stock Management is very flexible so that it can be more effective. For example if you forget to enter products at goods in, this will not prevent you from sending them to customers. In OpenERP you can force all operations manually using the button Force Assignment. In this case, your stocks risk becoming negative. You should monitor all stocks for negative levels and carry out an inventory correction when that happens.

### 20.3.6 Customer Delivery by Product

From this version on, you can also handle deliveries by product, even from List view. Go to **Warehouse → Products Moves → Deliver Products**.

Filters allow you to easily select deliveries to be done, available deliveries and so on. One way to quickly deliver products is to Group by Customer and select either To Do or Available.

This is very useful functionality when you send the goods to your customer for several sales orders at a time. You can now just deliver the products, regardless of the sales order they come from.

The List view offers great flexibility and allows you to rapidly deliver products by keeping full functionality! Of course, you can handle both partial and complete deliveries and you can add information about the production lots and packs.

Of course, you can also accomplish this from Form view.
20.3.7 Analysing Stock

Have a look at the effect of these operations on stock management. There are several ways of viewing stocks:

- from the Product form,
- from the Locations,
- from the Orders,
- from the Reporting menu.

Open the Product form from the menu Warehouse → Product → Products and look at the list of items. You will immediately see the following information about the products:

- **Real Stock**,  
- **Virtual Stock**.

If you want more information, you can use the actions to the right of the form. If you click the report Stock Level Forecast, OpenERP opens a graphical view of the stock levels for the selected products changing with time over the days and weeks to come.

To get the stock levels by location use the button **Stock by Location**. OpenERP then gives you the stock of this product for all its possible locations. If you only want to see the physical locations in your company just filter this list using the Location Type **Internal**. By default, physical locations are already in red to better distinguish them from the other locations. Consolidated (or View) locations (the sum of several locations, following the hierarchical structure) are displayed in blue.

You can get more details about all the **Stock Moves or Future Stock Moves** from the product form. You will then see each move from a source location to a destination location. Everything that influences stock levels corresponds to a stock move.

You could also look at the stocks available in a location using the menu **Inventory Control → Locations Structure**. You can select the locations for which you want to see the hierarchy by clicking the drop-down list. Click a location to look at the stocks by product (a wizard appears). A location containing child locations shows the consolidated contents for all of its child locations.

![Stock quantities by location for a given product](image)
You should now check the product quantities for various locations to familiarize yourself with this double-entry stock management system. You should look at:

- supplier locations to see how goods receipts are linked,
- customer locations to see how packing notes are linked,
- inventory locations to see the accumulated profit and loss,
- production locations to see the value created for the company.

Also look at how the real and virtual stocks depend on the location selected. If you enter a supplier location:

- the real stock shows all of the product receipts coming from this type of supplier,
- the virtual stock takes into account the quantities expected from these suppliers (+ real stock + quantities expected from these suppliers). It is the same scheme for customer locations and production locations.

From the Reporting have a look at the Dashboard and the Analysis Reports, such as Inventory Analysis and Moves Analysis. The filters allow you to see for instance the current and future stock, for all locations or for a given location. You can use Extended Filters and the Group by functionality to create your own reporting.

### 20.4 Basic Logistics Configuration

In this section you will see how to configure stock management to match your company’s needs. OpenERP can handle many different situations by configuring it to behave as required.

#### 20.4.1 Stock Locations

You have seen in the preceding sections that the whole of stock management is built on a concept of stock locations. Locations are structured hierarchically to account for the subdivision of a warehouse into sections, aisles, and/or cupboards. The hierarchical view also enables you to structure virtual locations such as production counterparts. That gives you a finer level of analysis.

Use the menu Warehouse → Configuration → Warehouse Management → Locations then click New to define new locations.

You should then give a name to your stock location. Now look at the location types.
20.4.2 Location Types

The location must have one of the following types:

- **View**: shows that the location is only an organizational node for the hierarchical structure, and cannot be involved in stock moves itself. The view type is not usually made into a leaf node in a structure – it usually has children.

- **Customer**: destination for products sent to customers,

- **Supplier**: source of products received from suppliers,

- **Internal**: locations for your own stock,

- **Inventory**: the counterpart for inventory operations used to correct stock levels,

- **Production**: the counterpart for production operations; receipt of raw material and sending finished products,

- **Procurement**: the counterpart for procurement operations when you do not yet know the source (supplier or production). Products in this location should be zero after the scheduler run completes,

- **Transit Location for Inter-Company Transfers**, used as an intermediate location in a multicompany environment.

You can have several locations of the same type. In that case your product, supplier and warehouse configurations determine the location that is to be used for any given operation.

The counterparts for procurement, inventory and production operations are given by the locations shown in the product form. The counterparts of reception and delivery operations are given by the locations shown in the partner form. The choice of stock location is determined by the configuration of the warehouse, linked to a Shop Sales → Configuration → Sales → Shop.

![Figure 20.15: Defining Stock Locations in the Product Form](image-url)
20.4.3 Location Addresses

Each location can be given an address. That enables you to create a location for a customer or a supplier, for example. You can then give it the address of that customer or supplier. You should indicate to OpenERP on the partner form that it should use this location rather than the default location given to partner deliveries.

**Tip:** Subcontracting production

You will see in the chapter, Manufacturing, that it is possible to assign a location to a manufacturing workcenter. If this location is at a supplier’s you must give it an address so that OpenERP can prepare a delivery order for the supplier and a receive operation for the manufactured goods.

Creating a location specifically for a partner is also a simple solution for handling consigned stocks in OpenERP.

**Note:** Consigned Stock

Consigned stock is stock that is owned by you (valued in your accounts) but is physically stocked by your supplier. Or, conversely, it could be stock owned by your customer (not valued by you) but stocked in your company. Make sure that you create consignment locations as part of your internal stock.

To enable you to consolidate easily at a higher level, the location definition is hierarchical. This structure is given by the field Parent location. That also enables you to manage complex cases of product localization. For example, you could imagine the following scenario.

**One Company with Two Warehouses**

A company has a warehouse in Paris and in Bordeaux. For some orders you must deliver the products from Paris, and for others from Bordeaux. But you should also specify a fictitious warehouse that OpenERP uses to calculate if it should deliver products from Paris or from Bordeaux.

To do this in OpenERP, you would create a third warehouse ‘France’ which consolidates the warehouses in Paris and Bordeaux. You create the following physical locations:

- Company
  - Output
    * Warehouses France
OpenERP will then deliver the goods from the warehouse that has the ordered product in stock. When products are available in several warehouses, OpenERP will select the nearest warehouse. To formalize the notion of distance between warehouses you should use the geographic co-ordinates (X, Y, Z) of the different stores to enable OpenERP to search for the nearest goods.

The same co-ordinates could also be used to structure the shelves, aisles and interior rooms in a warehouse.

### 20.4.4 Accounting Valuation in Real Time

If you have experience of managing with traditional software you will know the problem of getting useful indicators. If you ask your accountant for a stock valuation or the value added by production he will give you a figure. If you ask for the same figure from your stores manager you will get an entirely different amount. You have no idea who is right!

In OpenERP the management of stock is completely integrated with the accounts, to give strong coherence between the two systems. The double-entry structure of locations enables a very precise correspondence between stocks and accounts.

Each stock movement also generates a corresponding accounting entry in an accounting journal to ensure that the two systems can stay in permanent synchronization.

To do that, set up a general account for each location that should be valued in your accounts. If a product goes to one location or another and the accounts are different in the two locations, OpenERP automatically generates the corresponding accounting entries in the accounts, in the stock journal.

If a stock move will go from a location without an account to a location where an account has been assigned (for example goods receipt from a supplier order), OpenERP generates an accounting entry using the properties defined in the product form for the counterpart. You can use different accounts per location or link several location to the same account, depending on the level of analysis needed.

You use this system for managing consigned stocks:

- a supplier location that is valued in your own accounts or,
- a location in your own company that is not valued in your accounts.

### How to configure Accounting Valuation?

- In the Product form, go to the Accounting tab and select the *Real Time (automated)* option for Inventory Valuation.

To define your accounts, you have two options. Set them on the product category, or on the product.

- From the Information tab, for the Product Category, set the Stock Input Account, the Stock Output account and the Stock Variation account,

OR

- From the Accounting tab, for the Product, set the Stock Input Account and the Stock Output account.

You can also overwrite the accounts from the Product or the Product Category by defining Stock Input and Stock Output account for a Location.

**Note:** You can also install the `account_anglo_saxon` module to value your stock according to anglosaxon principles.

The figure below shows the various accounts that can be used, with and without the `account_anglo_saxon` module installed.
### 20.4.5 Linked locations

Locations in OpenERP can be linked between each other to define paths followed by products. So you can define rules such as: all products that enter the warehouse must automatically be sent to quality control. The warehouse and quality control are represented by two different locations.

Then when a product arrives in a location, OpenERP can automatically suggest that you send the product to another linked location. Three link modes are available:

- **Manual Operation**,  
- **Automatic Move**,  
- **Automatic No Step Added**.

The **Manual Operation** mode will create an internal move order to the linked location once products arrive in the source locations. This order will wait for a confirmation of the move by a user. This enables you to have a list of moves to do, proposed by the system and confirmed by the storesperson.

**Tip:** **Product Logistics**  

*The module stock_location lets you generate paths to follow, not just at the level of locations but also at the level of products. It then enables you to manage default locations for a given product or to refer to the products as a function of operations such as quality control, supplier receipt, and after-sales service. A more detailed explanation of this module, with examples, is given at the end of this chapter.*

The **Automatic Move** mode will do the same but will not wait for a confirmation from the user. Products will automatically be sent to the linked location without any intervening manual operation to do. This corresponds to the case where, for simplicity, you delete a step in the process so the end user can set off the process automatically.

The **Automatic No Step Added** mode will not include the additional stock move but will change the destination move transparently to assign the linked location. You could then assign a destination location to which you send all the products that arrive in your warehouse. The storesperson will modify the goods receipt note.

If there is linking to do, the field **Chained Location Type** lets the destination location be determined. If the field is set to ‘Customer’, the location is given by the properties of the partner form. If the field is set to **fixed**, the destination location is given by the field **Chained Location If Fixed**.

---

**Figure 20.17: Setting up Stock Valuation Accounts**

<table>
<thead>
<tr>
<th>Transaction Type</th>
<th>Asset Account</th>
<th>Liability Account</th>
<th>Expense Account</th>
<th>Income Account</th>
<th>Cost of Goods Sold Account</th>
<th>Price difference Account</th>
<th>Debit</th>
<th>Credit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Purchase</td>
<td>(Stock In)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>(Price diff.)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Supplier Invoice</td>
<td>(Payable)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>(COGS)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Receive</td>
<td>(Stock In)</td>
<td>(Stock Val.)</td>
<td></td>
<td></td>
<td>(Price diff.)</td>
<td>(COGS)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Deliver</td>
<td>(Stock Out)</td>
<td>(Receivable)</td>
<td></td>
<td></td>
<td></td>
<td>(Income)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Sell</td>
<td>(Stock Out)</td>
<td>(Receivable)</td>
<td>(Payable)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

---

<table>
<thead>
<tr>
<th>Transaction Type</th>
<th>Asset Account</th>
<th>Liability Account</th>
<th>Expense Account</th>
<th>Income Account</th>
<th>Cost of Goods Sold Account</th>
<th>Price difference Account</th>
<th>Debit</th>
<th>Credit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Receive</td>
<td>(Stock In)</td>
<td>(Stock Val.)</td>
<td></td>
<td></td>
<td></td>
<td>(Price diff.)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Deliver</td>
<td>(Stock Out)</td>
<td>(Receivable)</td>
<td></td>
<td></td>
<td>(Price diff.)</td>
<td>(COGS)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Sell</td>
<td>(Stock Out)</td>
<td>(Receivable)</td>
<td>(Payable)</td>
<td></td>
<td></td>
<td>(Income)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Pay</td>
<td>(Payable)</td>
<td></td>
<td>(Cash/Bank)</td>
<td></td>
<td></td>
<td>(Price diff.)</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

---

266
Some operations take a certain time between order and execution. To account for this lead time, you can set a value in days in the field Chaining Lead Time. Then the extra move (automatic or not) will be carried out several days after the original move. If you use the mode Automatic No Step Added, the lead time is inserted directly into the initial order. In this way you can add security lead times at certain control points in the warehouse.

20.4.6 Structuring locations

You will see in the next part that linking locations allows you to manage a whole series of complex cases in managing production efficiently:

- handling multiple operations for a customer order,
- tracking import and export by sea transport,
- managing a production chain in detail,
- managing rented products,
- managing consigned products.

To show these concepts, five cases of structuring and configuring these locations are given below. Many other configurations are possible depending on needs.

20.4.7 Handling Customer Orders

Customer orders are usually handled in one of two ways:

- item note (or preparation order), confirmed when the item is ready to send,
- delivery order (or freight note), confirmed when the transporter has delivered the item to a customer.

You use the following stock move in OpenERP to simulate these operations:

- Packing Note: Stock > Output,
- Delivery Order: Output > Customer.

The first operation is automatically generated by the customer order. The second is generated by the stock management, showing that the Output location is linked to the Customer location. The two operations will show as waiting. If the Output location is not situated beneath the stock location you then have to move the item from stock to the place where the item is prepared.

Some companies do not want to work in two steps, because it just seems like extra work to have to confirm a delivery note in the system. You can then set the link mode to ‘Automatic’ to make OpenERP automatically confirm the second step. It is then assumed all the items have automatically been delivered to the customer.

20.4.8 Linked Production

The stock_location module enables you to manage the linkages by product in addition to doing that by location. You can then create a location structure that represents your production chain by product.

The location structure may look like this:

- Stock
  - Level 1
  - Level 2
  * Link 1
    - Operation 1
    - Operation 2
    - Operation 3
· Operation 4

You can then set the locations a product or a routing must go through in the relevant form. All products that enter the production chain will automatically follow the predetermined path.

You can see the location structure using Warehouse → Inventory Control → Location Structure

![Location Structure](image)

Figure 20.18: Logistics for a given product

To improve your logistics, you will see further on in this chapter how you can set minimum stock rules for different locations to guarantee security stocks for assembly operators. Reports on the state of stocks in different locations will rapidly show you the bottlenecks in your production chain.

20.5 Logistics Configuration in a Multi-Company Environment

To configure your logistics in multi-company environment you need to install stock_location module.

This module supplements the Warehouse application by adding support for location paths per product, effectively implementing Push and Pull inventory flows.

Typically this could be used to:

- Manage product manufacturing chains,
- Manage default locations per product,
- Define routes within your warehouse according to business needs, such as:
  - Quality Control
  - After Sales Services
  - Supplier Returns
- Help rental management, by generating automated return moves for rented products.

Once this module is installed, an additional Logistics Flows tab appears in the product form, where you can add Push and Pull flow specifications.

20.5.1 Push Flows

Push flows are useful when the arrival of certain products in a given location should always be followed by a corresponding move to another location, optionally after a certain delay.
A push flow specification indicates what location is chained with another location, as well as the parameters used. As soon as a given quantity of products is moved in the source location, a chained move is automatically foreseen according to the parameters set on the flow specification (destination location, delay, type of move, journal, etc.) The new move may be automatically processed, or may require a manual confirmation, depending on the parameters.

Suppose whenever the product CPU3 enters the Stock location, it first has to be moved to the Quality Control location in order to maintain the quality.

Look up the product CPU3 using the menu Warehouse → Product → Products.

To have OpenERP accomplish this, configure the push flow as follows:

- **Operation:** Receptions to Quality Control
- **Source Location:** Stock
- **Destination Location:** Quality Control
- **Automatic Move:** Automatic No Step Added
- **Delay (days):** 1
- **Shipping Type:** Getting Goods

Figure 20.19: Push Flow Specification for Product CPU3

A push flow is related to how stock moves should be generated in order to increase or decrease inventory.
20.5.2 Pull Flows

Pull flows are a bit different from Push flows, in the sense that they are not related to the processing of product moves, but rather to the processing of procurement orders. What is being pulled is a need, not directly products.

A classical example of Push flow is when you have an Outlet company, with a parent Company that is responsible for the supplies of the Outlet.


When a new procurement order (A, coming from the confirmation of a Sales Order for example) arrives in the Outlet, it is converted into another procurement (B, via a Push flow of the ‘move’ type) requested from the Holding. When procurement order B is processed by the Holding company, and if the product is out of stock, it can be converted into a Purchase Order (C) from the Supplier (Push flow of the ‘Purchase’ type). The result is that the procurement order, the need, is pushed all the way between the Customer and Supplier.

Technically, Pull flows allow to process procurement orders differently, not only depending on the product being considered, but also depending on which location holds the “need” for that product (i.e. the destination location of that procurement order).

To explain pull flow for the product CPU1, first we have to configure the minimum stock rules of CPU1 for the company OpenERP S.A. and Shop 1 using the menu Warehouse → Automatic Procurements → Minimum Stock Rules.

For the company OpenERP S.A.:

- Min Quantity : 10
- Max Quantity : 50

For the company Shop 1:

- Min Quantity : 10
- Max Quantity : 20

Look up the product CPU1 using menu Warehouse → Product → Products in order to define the configuration of the pulled flow.
There are two specifications of a pull flow for product CPU1.

**Specification 1:**

- **Name**: Receive from Warehouse
- **Destination Location**: Shop 1
- **Type of Procurement**: Move
- **Company**: Shop 1
- **Source Location**: Internal Shippings
- **Partner Address**: OpenERP S.A., Belgium Gerompont Chaussee de Namur 40
- **Shipping Type**: Getting Goods
- **Procure Method**: Make to Order

**Specification 2:**

- **Name**: Deliver Shop
- **Destination Location**: Internal Shippings
- **Type of Procurement**: Move
- **Company**: OpenERP S.A.
- **Source Location**: Stock
- **Partner Address**: Fabien
- **Shipping Type**: Sending Goods
- **Procure Method**: Make to Stock
Now sell 1 unit of product CPU1 from the Shop1 and run the scheduler using menu Warehouse → Schedulers → Compute Schedulers. Then check the stock moves for product CPU1 from the menu Warehouse → Traceability → Stock Moves.

These moves can be explained like this:

[ Customer ] ← [ Shop1 ] ← [ Internal Shippings ] ← Stock ← [ OpenERP S.A. ]

When the company Shop 1 sells one unit of CPU1 to a customer, its stock decreases to 10 units. According to the minimum stock rule of the product CPU1, OpenERP generates a procurement order of 21 units of CPU1 for the company Shop 1 (OP/00007). So 21 units of CPU1 move from company OpenERP S.A. to Shop 1 according to their internal configuration of Source and Destination Locations.

A pull flow is related to how the procurement process runs in order to find products to increase or decrease inventory.

### 20.6 Import / Export

Managing import/export with foreign companies can sometimes be very complex. Between a departure port and the destination company, products can get stopped for several weeks at sea or somewhere in the numerous transportation stages and customs. To manage such deliveries efficiently it is important to:

- know where your products are,
- know when they are likely to arrive at their destination,
- know your value in transit,
- follow the development of the different steps.

Linked locations in OpenERP enable you to manage all this rather elegantly. You can use a structure like this:

- Suppliers
  - European Suppliers
20.6.1 Stock

The transit locations are linked between themselves with a manual confirmation step. The internal stock move is validated at each port and customs arrival. OpenERP prepares all the linked moves automatically.

*Note: Intrastat*

Companies that do import/export should install the module report_intrastat. This enables them to prepare the reports needed to declare product exports.

You can use the lead times between different locations to account for real delays. Your lead times and stock forecasts are calculated by OpenERP to estimate the arrival of incoming products so that you can respond to a customer’s needs as precisely as possible.

You can also value the products in transit in your account depending on the chosen stock location configuration.

20.6.2 Rental Locations

You can manage rental locations in OpenERP very simply using the same system of linked locations. Using the module stock_location you can set a return date for rental items sent to customer location after a certain rental period.

Then the set of real and virtual stocks is maintained daily in real time. The different operations such as delivery and receipt after a few days are automatically suggested by OpenERP which simplifies the work of data entry.

You then have the product list found in the customer locations and your own stock in your stock location. The list of waiting goods receipts is automatically generated by OpenERP using the location links.

Suppose you want to give a product (PC3) on rent to your customer (Axelor) for 30 days. Two stock movement entries are needed to manage this scenario:

1. Product goes out from Stock (your company’s location) to Axelor - Rental Location (your customer location).

2. Product will be returned into Stock (your company’s location) from Axelor - Rental Location (your customer location) after 30 days.

To manage rental products by linking locations, configure a rental location (Axelor - Rental Location) as shown in the following figure using the menu Warehouse → Configuration → Warehouse Management → Locations.
Figure 20.22: Configuration of a rental location ‘Axelor - Rental Location’

Using the menu Warehouse → Traceability → Stock Moves, you can create a stock movement entry from Stock to Customer Location (Axelor - Rental Location) in OpenERP for a rental product (PC3).

Figure 20.23: Stock movement entry to send the product ‘PC3’ to the customer location

The stock movement entry from Customer Location (Axelor - Rental Location) to Stock is generated automatically on the proper Scheduled Date by OpenERP when you have confirmed the previous stock movement entry by clicking the Process Now button.

The same principle is used for internal stock to generate quality control for certain products.
20.6.3 Consigned Products

The principle of linked locations is used to manage consigned products. You can specify that certain products should be returned to you a certain number of days after they have been delivered to customers.

When the products have been delivered, OpenERP automatically creates goods receipts for the consigned product. The specified date is obviously approximate but enables you to forecast returns.

20.7 Warehouses

Warehouses are designed for physical locations from which you can deliver to the customer and to which you receive raw materials. When you buy products from a supplier you should take account of the Warehouse you use for this purchase. This also enables the end user to not have to choose from a list of locations but simply a real warehouse.

Use the menu Warehouse → Configuration → Warehouse Management → Warehouses, then click New to configure a new warehouse.

A warehouse is defined by a link between three locations:

- The Location Stock field shows the place of products available for delivery to a customer directly from this warehouse. Availability is given by all the products in that location and any child locations.

- The Location Input field shows where ordered products are received from a supplier in that warehouse. It can be the same as the stock location if, for example, you want to do a quality control operation on your incoming raw materials.

- The Location Output field (called Output in the demonstration database) is designed as a buffer zone in which you store all the items that have been picked, but not yet delivered to a customer. You are strongly advised not to put this location within the stock hierarchy but instead at a higher level or at the same level.

![Figure 20.24: Warehouse Parameters](image)

You can also set an address for the warehouse. This address should ideally be an address of your company. Once the warehouse has been defined it can be used in:

- Minimum stock rules,
- Supplier orders,
- Customer orders (using the definition of a point of sale, which is linked to a warehouse).

20.7.1 Automatic Procurement

Several methods of automatically procuring products can be carried out by OpenERP:

- the workflow used by products that have the procurement mode Make to Order,
- using minimum stock rules for Make to Stock products,
- using the master production schedule for Make to Stock products.

The last two methods are described below.
20.7.2 Minimum Stock Rules

To automatically make stock replenishment proposals, you can use minimum stock rules. To do this use the menu Warehouse → Automatic Procurements → Minimum Stock Rules.

The rule is the following: if the virtual stock for the given location is lower than the minimum stock indicated in the rule, the system will automatically propose a procurement to increase the level of virtual stock to the maximum level given in the rule.

Figure 20.25: List of Minimum Stock Rules

Tip: Conflict Resolution
You may find draft production or procurement orders to be created although they should not exist. That can happen if the system is badly configured (for example if you have forgotten to set the supplier on a product). To check this, look at the list of procurements in the exception state in the menu Warehouse → Schedulers → Procurement Exceptions. More details about processing these exceptions is given in Manufacturing.

We underline that the rule is based on virtual quantities and not just on real quantities. It takes into account the calculation of orders and receipts to come.

Take the following example:

- Products in stock: 15
- Products ordered but not delivered: 5
- Products in manufacturing: 2

The rules defined are:

- Minimum stock: 13
- Maximum stock: 25.

Once the rules have been properly configured, the purchasing manager only needs to look at the list of orders for confirmation with the supplier using the menu Purchases → Purchase Management → Requests for Quotation.

Note: Note that the procurement does not require that you buy from a supplier. If the product has a Supply method Produce the scheduler will generate a Manufacturing order instead of a supplier order.

You can also set multiple quantities in the minimum stock rules. If you set a multiple quantity of 3 the system will propose procurement of 15 pieces, and not the 13 it really needs. In this case it automatically rounds the quantity upwards.

In a minimum stock rule, when you indicate a warehouse it suggests a stock location by default in that warehouse. You can change that location by default when the scheduler completes, by location and not by warehouse.
20.8 Scheduling

The master production plan, sometimes called the MPS (Master Production Schedule), enables you to generate forecasts for incoming and outgoing material. It is based on forecasts of inputs and outputs by the logistics manager.

**Note: MPS, Procurement and Production**

OpenERP distinguishes between Production, Purchase and Procurement. Production is manufacturing, Purchase is the acquisition of goods from another party, and Procurement is either one or both of those. So it would be better to call the MPS the Master Procurement Schedule. Which OpenERP does!

**Tip: Product trading**

Also called the Production Plan, this tool is also very useful for traded products which are not manufactured. You can then use it for stock management with purchased and manufactured products.

To be able to use the production plan, you must install the `stock_planning` module.

20.8.1 Sales Forecasts

The first thing to do to work with a production plan is to define the periods for stock management. Some companies plan daily, others weekly or monthly.

**Tip: Stock Management Interval**

The interval chosen for managing stock in the production plan will depend on the length of your production cycle. You generally work daily, weekly or monthly.

*If it takes several days to assemble your products, you most likely will define a weekly plan. If your manufacturing cycles take several months you can work with a monthly plan.*

Go to the menu **Sales → Configuration → Stock and Sales Periods → Stock and Sales Periods.** A window appears enabling you to automatically define the next periods that will be provided for stock management.

![Stock and Sales Periods](image)

**Figure 20.26: Defining Periods for Stock Management**

Salespeople can then enter their sales forecasts by product and by period using the menu **Sales → Sales Forecasts → Sales Forecasts.** The forecasts can be made by quantity or by value. For a forecast by amount OpenERP automatically calculates for you the quantity equivalent to the estimated amount. This can be modified manually as needed before completion.
20.8.2 Production Plan

The manager responsible for logistics then plans receipts (manufacturing or purchases) and outgoings (consumption or customer deliveries) by period. Go to the menu Warehouse → Stock Planning → Master Procurement Schedule.

For each period and product, OpenERP gives you the following information:

- Stock estimated at the end of the period, calculated as stock in the following period less the total estimated outgoings plus total estimated inputs,
- Closed entries, coming from production or confirmed purchases,
- Forecast inputs for the period, calculated using the incoming entries less the closing amounts,
- Planned inputs entered manually by the logistics manager,
- Closed outgoings which are the consumption of manufacturing waiting and deliveries to be made to customers,
- Forecast outgoings, calculated from the planned outgoings, less the closing amounts,
- Planned outgoings, manually entered by the logistics manager,
- Sales forecasts, which represent the sum of forecasts made by the salespeople.
The production plan enables the logistics manager to play with the forecasted receipts and outgoings and test the impact on the future stock for the product concerned. It enables you for example to check that the stock does not fall below a certain level for that product.

You can also open the production plan for past periods. In this case OpenERP shows you the real stock moves, by period for forecast reports.

If you do not have automated procurement rules for a product you can start procurement at any time based on the estimates of the production plan. To do this press the button Procure Incoming Left (i.e. remaining) on the Master Procurement Schedule. OpenERP plans procurement for an amount equal to the entries forecast.

#### 20.9 Management of Lots and Traceability

The double-entry management in OpenERP enables you to run very advanced traceability. All operations are formalized in terms of stock moves, so it is very easy to search for the cause of any gaps in stock moves.

**Note:** Upstream and Downstream Traceability

*Upstream* traceability runs from the raw materials received from the supplier and follows the chain to the finished products delivered to customers. (Note that the name is confusing - this would often be considered a downstream direction. Think of it as *Where Used*.)

*Downstream* traceability follows the product in the other direction, from customer to the different suppliers of raw material. (Note that the name is confusing - this would often be considered an upstream direction. Think of it as *Where Supplied*.)

#### 20.9.1 Stock Moves

Use the menu Warehouse → Traceability → Stock Moves to track past stock transactions for a product or a given location. All the operations are available. You can filter on the various fields to retrieve the operations about an order, or a production activity, or a source location, or any given destination.
Each stock move is in a given state. The different possible states are:

- **Draft**: the move so far had no effect in the system. The transaction has not yet been confirmed,
- **Confirmed**: the move will be done, so it will be counted in the calculations of virtual stock. But you do not know whether it will be done without problem because the products have been reserved for the move,
- **Validated**: the move will be done and the necessary raw materials have been reserved for the transaction,
- **Done**: the stock move has been done, and entered into the calculations of real stock,
- **Waiting**: in the case of transactions From Order, this state shows that the stock move is blocked waiting for the end of another move,
- **Cancelled**: the stock move was not carried out, so there is no accounting for it in either real stock or virtual stock.

Delivery orders, goods receipts and internal picking lists are just documents that group a set of stock moves. You can also consult the history of these documents using the menu Warehouse → Traceability → Packs.

### 20.9.2 Lots

OpenERP can also manage product lots. Two lot types are defined:

- Production lots (batch numbers) are represented by a unique product or an assembly of identical products leaving the same production area. They are usually identified by bar codes stuck on the products. The batch can be marked with a supplier number or your own company numbers.
- Tracking numbers are logistical lots to identify the container for a set of products. This corresponds, for example, to the pallet numbers on which several different products are stocked.

These lots can be encoded onto all stock moves and, specifically, on incoming shipments lines, internal moves and outgoing deliveries.
To enter the lot number in an operation you can use an existing lot number or create a new pack. A production lot (batch number) is used for a single product. A tracking number can be used several times for different products, so you can mix different products on a pallet or in a box.

**Note:** Simplified View

In the Simplified View the tracking numbers cannot be seen: the field is hidden. To get to Extended View mode, assign the group Usability – Extended View to the current user.

You can also specify on the product form the operations in which a lot number is required. You can then compel the user to set a lot number for manufacturing operations, goods receipt, or customer packing.

You do not have to encode the lot number one by one to assign a unique lot number to a set of several items. You only need to take a stock move for several products line and click the button Split in Production Lots. You can then give a lot number prefix (if you want) and OpenERP will complete the prefix in the wizard with a continuing sequence number. This sequence number might correspond to a set of pre-printed barcodes that you stick on each product.

**Figure 20.30: Entering a Line for Production Receipt**

**Figure 20.31: Splitting a Lot into uniquely Identified Parts**
20.9.3 Traceability

If you key in the lot numbers for stock moves as described above you can investigate the traceability of any given lot number. Go to the menu Warehouse → Traceability → Production Lots, or Warehouse → Traceability → Packs.

Tip: Product Shortcuts
From the product form, the toolbar to the right offers useful information:
- Minimum Stock Rules,
- Stock by Location,
- Product Sales,
- Bills of Material.

Search for a particular lot using the filters for the lot number, the date or the product. Once you can see the form about this lot, several actions can be performed:
- **Upstream Traceability**: from supplier through to customers,
- **Downstream Traceability**: from customer back to suppliers,
- Stock in all the physical and virtual locations.

![Figure 20.32: Tracing Upstream in Make to Order](image)

Finally, on a lot, you can enter data on all the operations that have been done for the product. That keeps a useful history of the pre-sales operations.

20.10 Management by Journal

You can manage stock through journals in the same way as you can manage your accounts through journals. This approach has the great advantage that you can define journals in various ways to meet your company’s needs.

For example, a large company may want to organize deliveries by department or warehouse. You can then create a journal and a manager for each department. The different users can work in a journal as a function of their position in the company. That enables you to better structure your information.

A company doing a lot of transport can organize its journals by delivery vehicle. The different delivery orders will then be assigned to a journal representing a particular vehicle. When the vehicle has left the company, you can confirm all the orders that are found in the journal all at the same time.

20.10.1 The different journals

Install the Reconfigure option Invoicing Journals for Sales Management or the sale_journal module to work with different journals. This adds three new concepts to OpenERP:
• Invoicing journals,
• Order journals,
• Delivery journals.

Invoicing journals (Sales → Configuration → Sales → Invoice Types) are used to assign purchase orders and/or delivery orders to a given invoicing journal. Everything in the journal can be invoiced in one go, and you can control the amounts by journal. For example you can create the following journals: daily invoicing, end-of-week invoicing and monthly invoicing. It is also possible to show the invoicing journal by default in the partner form. Set the Invoicing Method to Grouped (one invoice per customer) or Non Grouped (individual invoices) according to your needs.

Order journals look like orders and are automatically transferred to orders for the corresponding items. These enable you to classify the orders in various ways, such as by department, by salesperson, or by type. Then if a salesperson looks at her own journals after an order she can easily see the work on current items compared with her own orders.

**Tip: Default Values**

To enter all the orders in their own order journal, a salesperson can use the default values that are entered in the fields when creating orders.

Finally the delivery journals are used to post each item into a delivery journal. For example you can create journals dated according to customer delivery dates (such as Monday’s deliveries, or afternoon deliveries) or these journals could represent the day’s work for delivery vehicles (such as truck1, truck2).

### 20.10.2 Using the journals

You will now see how to use the journals to organize your stock management in practice. After installing the module sale_journal look at the list of partners. In the tab Sales and Purchases on any of them you will now see the field Invoicing Method.

![Partner Form in Invoicing Mode](image)

You can create a new Invoicing Journal for a partner on the fly. You can show if the invoices should be grouped or not after you have generated them in the journal. Create a second invoicing journal End-of-Month Invoicing which you can assign to another partner.
Then enter the data for some orders for these two partners. After entering these order data, the field Invoicing Mode is completed automatically from the partner settings. Put these orders into the Invoicing Mode based on items in the second tab.

Look at the History tab of the Sales order to the Picking List that has been created. The field Invoicing Mode is automatically shown there. Confirm the different orders in the list.

At the end of the day, the invoicing supervisor can display the list by journal. Go to the menu Sales → Invoicing → Lines to Invoice. Choose the invoicing journal and all the lists of orders to invoice will then open in list view. You can automatically carry out invoicing by clicking the action Make Invoice (the gears symbol in the application client).

**Tip: Confirming Invoices**
By default, invoices are generated in the draft state which enables you to modify them before sending them to the customer. But you can confirm all the invoices in one go by selecting them all from the list and selecting the action ‘Confirm Draft Invoices’.

At the end of the month the invoicing management does the same work but in the journal ‘month-end invoicing’.

You can also enter a journal to confirm / cancel all the orders in one go. Then you can do several quotations, assign them to a journal and confirm or cancel them at once.

**20.11 Advanced Elements of Stock Management**

In this section you will enter the details for stock management and control.
20.11.1 Requirements Calculation / Scheduling

Requirements calculation is the calculation engine that plans, prioritises and starts the automated procurement as a function of rules defined in the products.

**Note:** Requirements Calculation
Requirements Calculation is often called Scheduling.
By default, it automatically starts once a day. You can also start it manually using the menu Manufacturing → Schedulers → Compute Schedulers. It then uses the parameters defined in the products, the suppliers and the company to determine the priorities between the different product orders, deliveries and purchases from suppliers.

20.11.2 Just in Time

By default, scheduling starts automatically once a day. You should make this run be executed overnight to ensure that the system does not slow down under a heavy load of scheduling when you are also trying to use it interactively yourselves.

To set the start time for the scheduler, go to the menu Administration → Configuration → Scheduler → Scheduled Actions. Select the rule called ‘Run mrp scheduler’ and modify the date and time of the next execution. Some companies want to plan orders progressively as they are entered so they do not wait until procurement orders are planned the next day. Install the module mrp_jit to handle this. Once it is installed, each requirement (that could result in a Production or Purchase Order) will be planned in real time as soon as it has been confirmed.

Then if you make a customer order with a product that is Make To Order the quotation request to a supplier will immediately be generated.

**Tip:** Delivery from the Supplier or to the Customer
The sale_supplier_direct_delivery module enables you to deliver the product directly from the supplier to the customer. At the time of writing this module is in addons-extra. The logic that the product follows is configured individually for each product and affects only those products marked Make to Order.

This mode is not always sensible. Each order is processed immediately when confirmed. So if an order is to be delivered in three months the scheduler will reserve goods in stock for each order once it has been confirmed. It would have been more sensible to leave these products available for other orders.

If a Purchase Order’s Invoicing Control is configured From Order, the scheduler will immediately create the corresponding supplier quotation request. It would have been preferable to delay for several weeks if you could have used the lead time to group the purchase with other future orders.

So the negative effects of working with the Just in Time module are:

- Poor priority management between orders,
- Additionally stocked products.

20.11.3 Planning

You have seen that most OpenERP documents can be changed in a planning view. It is the same for deliveries and goods receipts. You can put them into a calendar view at any time to plan your deliveries or goods receipts.
Planned dates on a packing order are put in each stock move line. If you have a packing order containing several products not all of the lines necessarily need to be delivered the same day. The minimum and maximum dates in a packing order show the earliest and latest dates on the stock move lines for the packing.

If you move a packing order in the calendar view, the planned date in the stock move lines will automatically be moved as a result.

### 20.11.4 Managing Partial Deliveries

Partial deliveries, sometimes called Back Orders, are generated automatically by OpenERP. When you confirm a customer delivery or the receipt of products from suppliers, OpenERP asks you to confirm the quantity delivered or received.

If you leave the quantities alone, OpenERP confirms and then closes the order for delivery or receipt. If you modify a quantity, OpenERP will automatically generate a second delivery or goods receipt document for the remaining quantities. The first will be confirmed and the second will remain in the list of waiting deliveries (or receipts).

When you open the list of current deliveries, you find the field *Back Order of* which shows the reference number of the first delivery sent to the customer. That enables you to quickly find the deliveries for partial orders each day so that you can treat them as a priority.

### 20.11.5 Receiving Supplier Products

OpenERP supports three approaches to control data entry for products ordered from suppliers:

- Manual data entry,
- Using the goods receipt documents pre-generated by the system,
- Selecting from all the products waiting from the supplier, independently from goods receipt documents.

---

**Figure 20.37: Planning the Deliveries of Customer Products**

**Figure 20.38: Confirmation Screen for Delivered Quantities**
You can see how the configuration of the supplier order affects receipts in detail in *Driving your Purchases*.

### 20.11.6 Manual Data Entry of Goods Receipt

To enter data about goods receipt manually go to the menu *Warehouse → Warehouse Management → Incoming Shipments* and click the *New* button. Then enter the necessary data manually in the goods receipt form.

![Manual Data Entry for Product Receipt](image)

**Figure 20.39: Manual Data Entry for Product Receipt**

### 20.11.7 Confirming pre-generated Goods Receipt Documents

If you use Purchase Orders in OpenERP, product receipts are automatically generated by the system when the purchase order is confirmed. You do not have to enter any date, just confirm that the quantities ordered match the quantities received.

In this case OpenERP generates a list of all products waiting to be received from the menu *Warehouse → Warehouse Management → Incoming Shipments* and applying proper filter. Group by *State* to find all incoming shipments with the corresponding state.
Then you just look for the corresponding entry using the supplier name or order reference. Click it and confirm the quantities. If it shows you quantities that differ from the control form, OpenERP will automatically generate another receipt document that will be set open, waiting for the remaining deliveries. You can leave it open or cancel it if you know that products missed by your supplier will never be delivered.

**20.11.8 Confirmation by Selecting Products Waiting**

The approach shown above is very useful if goods receipts correspond to the original orders. If your suppliers deliver items that do not necessarily coincide with the orders, however, it is easier to work by products received rather than by orders.

In this case you can manually create a new goods receipt using the menu Warehouse → Products Moves → Receive Products. OpenERP opens a list of all the receivable/received product from that supplier and you can automatically add some or all of them to your form. You can filter receivable products based on state and confirm it. This method of data entry is very useful when you are entering goods received at one time from several orders.

**20.11.9 Product Routing**

You should install the stock_location module if routing products to customers, from suppliers or in your warehouse is determined by the identity of the product itself.
This will let you configure logistics rules individually for each product. For example, when a specific product arrives in stores it can automatically be sent to quality control. In this case it must be configured with rules on the product form. The fields that make up those rules are:

- **Source Location**: the rule only applies if a product comes from this location,
- **Destination Location**: the rule only applies if a product ends up in this location,
- **Type of move**: automatic, manual, automatic with no steps,
- **Lead time for move**,
- **Name of operations**: a free text field which will be included in the automatic stock move proposed by OpenERP.

There are two main logistic flows:

- **Pushed Flows**
- **Pulled Flows**

Push flows are useful when the arrival of certain products in a given location should always be followed by a corresponding move to another location, optionally after a certain delay. The original Warehouse application already supports such Push flow specifications on the Locations themselves, but these cannot be refined per product.

Pull flows are a bit different from Push flows, in the sense that they are not related to the processing of product moves, but rather to the processing of procurement orders. What is being pulled is a need, not directly products.

You will now see some examples of using these locations and logistics by product:

- A rentable product,
- A product bought in China, following its freight by ship from port to port,
- A product that you want to send to quality control before putting it in stocks.

**Example 1: A rentable product**

A rentable product is just a product delivered to a customer that is expected to be returned in a few days time. When it has been delivered to the customer, OpenERP will generate a new goods receipt note with a forecast date
at the end of the rental period. So you generate a list of goods pending receipt that you confirm when they are returned to your stores. To do this you should configure a product with the following rules:

Table 20.11: Example Product For Rental

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source location</td>
<td>Customer</td>
</tr>
<tr>
<td>Destination location</td>
<td>Stock</td>
</tr>
<tr>
<td>Type of Movement</td>
<td>Manual</td>
</tr>
<tr>
<td>Lead time</td>
<td>15 days</td>
</tr>
<tr>
<td>Operation</td>
<td>Product return</td>
</tr>
</tbody>
</table>

Then when the product is delivered to the customer, OpenERP automatically generates a goods receipt form in draft state ready for returning it to Stock. This is due in 15 days time. With such a system your forecasts and stock graphs can always be correct in real time.

**Example 2: Management of imports by sea**

To manage products that follow a complex logistical import path by sea and then into customs, create as many ‘Supplier’ locations as there are steps, then create rules to move the product from one place to the other during the purchase.

Take a product that has been bought in China and delivered to you stores in Brussels, Belgium. Import by sea takes around 7 weeks and must go through the following steps:

- Delivery from the supplier to the port of Shanghai: 2 days,
- Sea transport from Shanghai to the port of Antwerp: 1 month,
- Customer at the port of Antwerp: 2 weeks,
- Delivery by truck from the port of Antwerp to your stores: 3 days.

You should track the movement of your goods and enter all the documents as each move is made so that you know where your goods are at any moment, and can estimate when they are likely to arrive in your stores. To do this, create all the locations for the intermediate steps:

- Shanghai Port,
- Antwerp Port,
- Antwerp Customs.

Finally, in the product form, create the following rule to show that when purchased, the goods do not arrive at your stores directly, but instead at the port of Shanghai. In this example the stores are configured to enter all the products in a location called ‘Input’.

Table 20.12: Rule to move products automatically to Shanghai Port

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source location</td>
<td>Input</td>
</tr>
<tr>
<td>Destination location</td>
<td>Shanghai Port</td>
</tr>
<tr>
<td>Type of Movement</td>
<td>Automatic without steps</td>
</tr>
<tr>
<td>Lead time</td>
<td>2 days</td>
</tr>
<tr>
<td>Operation</td>
<td>Sending to Shanghai Port</td>
</tr>
</tbody>
</table>

OpenERP will then change the usual product receipt (which has them arriving in the Input location) to a delivery from this supplier to the external port. The move is automatically carried out because operations at this level are too labour-intensive to be done manually.

You then have to create a rule on the product form to move it from one location to another:
Table 20.13: Rule to move products manually from Shanghai Port to Antwerp Port

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source location</td>
<td>Shanghai Port</td>
</tr>
<tr>
<td>Destination location</td>
<td>Antwerp Port</td>
</tr>
<tr>
<td>Type of Movement</td>
<td>Manual</td>
</tr>
<tr>
<td>Lead time</td>
<td>30 days</td>
</tr>
<tr>
<td>Operation</td>
<td>Sending to Antwerp Port by ship</td>
</tr>
</tbody>
</table>

Table 20.14: Rule to move products manually from Antwerp Port to Antwerp Customs

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source location</td>
<td>Antwerp Port</td>
</tr>
<tr>
<td>Destination location</td>
<td>Antwerp Customs</td>
</tr>
<tr>
<td>Type of Movement</td>
<td>Manual</td>
</tr>
<tr>
<td>Lead time</td>
<td>15 days</td>
</tr>
<tr>
<td>Operation</td>
<td>Customs in Antwerp</td>
</tr>
</tbody>
</table>

Table 20.15: Rule to move products manually from Antwerp Customs to Stock

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source location</td>
<td>Antwerp Customs</td>
</tr>
<tr>
<td>Destination location</td>
<td>Stock</td>
</tr>
<tr>
<td>Type of Movement</td>
<td>Manual</td>
</tr>
<tr>
<td>Lead time</td>
<td>3 days</td>
</tr>
<tr>
<td>Operation</td>
<td>Truck transport into stock</td>
</tr>
</tbody>
</table>

Once the rules have been configured, OpenERP will automatically prepare all the documents needed for the internal stock movements of products from one location to another. These documents will be assigned one after another depending on the order defined in the rules definition.

When the company received notification of the arrival at a port or at customers, the corresponding move can be confirmed. You can then follow, using each location:

- where a given goods item can be found,
- quantities of goods awaiting customs,
- lead times for goods to get to stores,
- the value of stock in different locations.

Example 3: Quality Control

You can configure the system to put a given product in the Quality Control bay automatically when it arrives in your company. To do that you just configure a rule for the product to be placed in the Quality Control location rather than the Input location when the product is received from the supplier.

Table 20.16: Rule to move products manually from Input to Quality Control

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source location</td>
<td>Input</td>
</tr>
<tr>
<td>Destination location</td>
<td>Quality Control</td>
</tr>
<tr>
<td>Type of Movement</td>
<td>Manual</td>
</tr>
<tr>
<td>Lead time</td>
<td>0 days</td>
</tr>
<tr>
<td>Operation</td>
<td>Quality Control</td>
</tr>
</tbody>
</table>

Once this product has been received, OpenERP will then automatically manage the request for an internal movement to send it to the Quality Control location.
MANUFACTURING

The management of manufacturing described in this chapter covers planning, ordering, stocks and the manufacturing or assembly of products from raw materials and components. It also discusses consumption and production of products, as well as the necessary operations on machinery, tools or human resources.

The management of manufacturing in Open ERP is based on its stock management and, like it, is very flexible in both its operations and its financial control. It benefits particularly from the use of double-entry stock management for production orders. Manufacturing management is implemented by the mrp module. It is used for transforming all types of products:

- Assemblies of parts: composite products, soldered or welded products, assemblies, packs,
- Machined parts: machining, cutting, planing,
- Foundries: clamping, heating,
- Mixtures: mixing, chemical processes, distillation.

You will work in two areas: on products in the first part of this chapter, and on operations in the second part. The management of products depends on the concept of classifications while the management of operations depends on routing and workcenters.

Note: Bills of Materials

Bills of Materials, or manufacturing specifications, go by different names depending on their application area, for example:

- Food: Recipes,
- Chemicals: Equations,
- Building: Plans.

For this chapter you should start with a fresh database that includes demo data, with mrp and its dependencies installed and no particular chart of accounts configured.

21.1 Management of production

Production Orders describe the operations that need to be carried out and the raw materials usage for each stage of production. You use specifications (bills of materials) to work out the raw material requirements and the manufacturing orders needed for the finished products.

Manufacturing has the following results:

- Stock reduction: consumption of raw materials,
- Stock increase: production of finished goods,
- Analytic costs: manufacturing operations,
- Added accounting value of stock: by the creation of value following the transformation of products.
21.2 Bills of Materials

21.2.1 Use of Bills of Materials

Bills of Materials are documents that describe the list of raw materials used to make a finished product. To illustrate the concept of specification you are going to work on a cabinet where the manufacturing plan is given by the figure *Plan of construction of a cabinet*.

The cabinet is assembled from raw materials and intermediate assemblies:

Table 21.1: Product Definitions before defining Bills of Materials

<table>
<thead>
<tr>
<th>Product Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ARM100</td>
<td>Cabinet</td>
</tr>
<tr>
<td>PANLAT</td>
<td>Wooden Side Panel</td>
</tr>
<tr>
<td>PANA100</td>
<td>Rear Panel</td>
</tr>
<tr>
<td>PROFIL</td>
<td>Metal Strut</td>
</tr>
<tr>
<td>ETA100</td>
<td>Shelf</td>
</tr>
<tr>
<td>PLET100</td>
<td>Shelf Panel</td>
</tr>
<tr>
<td>BOIS002</td>
<td>Wood Panel</td>
</tr>
<tr>
<td>BOIS010</td>
<td>Wood Panel</td>
</tr>
<tr>
<td>TAQ000</td>
<td>Panel Pins</td>
</tr>
<tr>
<td>LIN040</td>
<td>Lintel</td>
</tr>
</tbody>
</table>

To describe how to assemble this cabinet, you define a bill of materials for each intermediate product and for the final cabinet assembly. These are given by the table below.

Table 21.2: Bill of Materials for 1 ARM100 Unit

<table>
<thead>
<tr>
<th>Product Code</th>
<th>Quantity</th>
<th>Unit of Measure</th>
</tr>
</thead>
<tbody>
<tr>
<td>PANLAT</td>
<td>2</td>
<td>Unit</td>
</tr>
<tr>
<td>PANA100</td>
<td>1</td>
<td>Unit</td>
</tr>
<tr>
<td>PROFIL</td>
<td>4</td>
<td>Unit</td>
</tr>
<tr>
<td>ETA100</td>
<td>3</td>
<td>Unit</td>
</tr>
</tbody>
</table>
The bills of materials are then used by the software to calculate the raw material needs based on the requirements of the finished products. Then if you want to manufacture 10 cabinets, the system can calculate what will be consumed:

![Bill of Materials structure](Image)

**Figure 21.2: Bill of Materials structure**

Use the menu Manufacturing → Master Data → Bill of Materials and click on New button to define a new bill of materials.
In the area below the bill of materials you should set the finished product, which will be manufactured or assembled. Once the product has been selected, Open ERP automatically completes the name of the bill of materials and the default Unit of Measure for this product.

The type of BoM (BoM Type: Phantom or Normal) and the Routing field will be described in more detail later in the chapter.

After this you can select the raw materials that are used in the manufacture of the finished product. The quantities are set out in a report based on the quantities of finished product and the quantities needed to produce them from the bill of materials. The second tab, Revisions, is used to set down all the changes made to the bill of materials. After each change you can specify a revision number and some notes on the modifications you carried out.

**Note:** Simplified View

*The Revisions tab is only visible if the user works in the Extended View mode (which means that the user must belong to the group Usability / Extended View).*

In the third tab, Properties, you can put a free text reference to a plan, a sequence number that is used to determine the priorities between bills of materials, dates between which a bill of materials is valid, and values for rounding and product efficiency.
**Rounding** is used to set the smallest *Unit of Measure* for expressing the quantities of the selected product. So if you set the rounding to 1.00 you will not be able to manufacture half a piece. The *Efficiency* of the product lets you indicate the percentage you lose during manufacture. This loss can be set for the finished product or for each raw materials line. The impact of this efficiency figure is to reserve more raw materials for manufacture than you would otherwise use just from the Bill of Materials calculations.

The final part of the third tab lets you set some properties for the product’s manufacturing processes. These will be detailed further on in the chapter in the section on configurable products.

### 21.3 Multi-level Bills of Materials

In Open ERP each line of a bill of materials may itself be a bill of materials. So you can define BoMs with several levels. Instead of defining several BoMs for the cabinet in the figure *Plan of construction of a cabinet* you could define the single bill of materials below:

![Table 21.9: Single Bill of Materials for 1 ARM100 Unit](image)

<table>
<thead>
<tr>
<th>Product Code</th>
<th>Quantity</th>
<th>Unit of Measure</th>
</tr>
</thead>
<tbody>
<tr>
<td>ARM100</td>
<td>1</td>
<td>Unit</td>
</tr>
<tr>
<td>PANLAT</td>
<td>2</td>
<td>Unit</td>
</tr>
<tr>
<td>BOIS002</td>
<td>0.166</td>
<td>m2</td>
</tr>
<tr>
<td>PANA100</td>
<td>1</td>
<td>Unit</td>
</tr>
<tr>
<td>BOIS002</td>
<td>0.25</td>
<td>m2</td>
</tr>
<tr>
<td>PROFIL</td>
<td>4</td>
<td>Unit</td>
</tr>
<tr>
<td>LIN040</td>
<td>1</td>
<td>m</td>
</tr>
<tr>
<td>ETA100</td>
<td>3</td>
<td>Unit</td>
</tr>
<tr>
<td>PLET100</td>
<td>3</td>
<td>Unit</td>
</tr>
<tr>
<td>BOIS010</td>
<td>0.249</td>
<td>m2</td>
</tr>
<tr>
<td>TAQ000</td>
<td>12</td>
<td>Unit</td>
</tr>
</tbody>
</table>

Open ERP behaves differently depending on whether the bill of materials is defined in several small BoMs each on a single level or in one BoM tree-structured on several levels.

So if you select a BoM using intermediate products that automatically generates production orders based on calculated requirements, Open ERP will propose manufacturing an intermediate product. To manufacture a cabinet, you would create 6 production orders:

![Table 21.10: Production Order](image)

<table>
<thead>
<tr>
<th>Product Code</th>
<th>Quantity</th>
<th>Unit of Measure</th>
</tr>
</thead>
<tbody>
<tr>
<td>PLET100</td>
<td>3</td>
<td>Unit</td>
</tr>
<tr>
<td>BOIS010</td>
<td>0.249</td>
<td>m2</td>
</tr>
</tbody>
</table>

![Table 21.11: Production Order](image)

<table>
<thead>
<tr>
<th>Product Code</th>
<th>Quantity</th>
<th>Unit of Measure</th>
</tr>
</thead>
<tbody>
<tr>
<td>ETA100</td>
<td>3</td>
<td>Unit</td>
</tr>
<tr>
<td>PLET100</td>
<td>3</td>
<td>Unit</td>
</tr>
<tr>
<td>TAQ000</td>
<td>12</td>
<td>Unit</td>
</tr>
</tbody>
</table>

![Table 21.12: Production Order](image)

<table>
<thead>
<tr>
<th>Product Code</th>
<th>Quantity</th>
<th>Unit of Measure</th>
</tr>
</thead>
<tbody>
<tr>
<td>PROFIL</td>
<td>4</td>
<td>Unit</td>
</tr>
<tr>
<td>LIN040</td>
<td>1</td>
<td>m</td>
</tr>
</tbody>
</table>

![Table 21.13: Production Order](image)

<table>
<thead>
<tr>
<th>Product Code</th>
<th>Quantity</th>
<th>Unit of Measure</th>
</tr>
</thead>
<tbody>
<tr>
<td>PANA100</td>
<td>1</td>
<td>Unit</td>
</tr>
<tr>
<td>BOIS002</td>
<td>0.25</td>
<td>m2</td>
</tr>
</tbody>
</table>
Table 21.14: Production Order

<table>
<thead>
<tr>
<th>Product Code</th>
<th>Quantity</th>
<th>Unit of Measure</th>
</tr>
</thead>
<tbody>
<tr>
<td>PANLAT</td>
<td>2</td>
<td>Unit</td>
</tr>
<tr>
<td>BOIS002</td>
<td>0.17</td>
<td>m2</td>
</tr>
</tbody>
</table>

Table 21.15: Production Order

<table>
<thead>
<tr>
<th>Product Code</th>
<th>Quantity</th>
<th>Unit of Measure</th>
</tr>
</thead>
<tbody>
<tr>
<td>ARM100</td>
<td>1</td>
<td>Unit</td>
</tr>
<tr>
<td>PANLAT</td>
<td>2</td>
<td>Unit</td>
</tr>
<tr>
<td>PANA100</td>
<td>1</td>
<td>Unit</td>
</tr>
<tr>
<td>PROFIL</td>
<td>4</td>
<td>Unit</td>
</tr>
<tr>
<td>ETA100</td>
<td>3</td>
<td>Unit</td>
</tr>
</tbody>
</table>

In the case where a single bill of materials is defined in multiple levels, a single manufacturing order will be generated for each cabinet, including all of the sub-BoMs. You would then get the following production order:

Table 21.16: Single manufacture from a tree-structured BoM

<table>
<thead>
<tr>
<th>Product Code</th>
<th>Quantity</th>
<th>Unit of Measure</th>
</tr>
</thead>
<tbody>
<tr>
<td>ARM100</td>
<td>1</td>
<td>Unit</td>
</tr>
<tr>
<td>BOIS002</td>
<td>0.17</td>
<td>m2</td>
</tr>
<tr>
<td>BOIS002</td>
<td>0.25</td>
<td>m2</td>
</tr>
<tr>
<td>LIN040</td>
<td>1</td>
<td>m</td>
</tr>
<tr>
<td>BOIS010</td>
<td>0.249</td>
<td>m2</td>
</tr>
<tr>
<td>TAQ000</td>
<td>12</td>
<td>Unit</td>
</tr>
</tbody>
</table>

21.3.1 Phantom Bills of Materials

If a finished product is defined using intermediate products that are themselves defined using other BoMs, OpenERP will then propose the manufacture of each intermediate product. This will give several production orders. If you only want a single production order you can define a single BoM with several levels.

Sometimes, however, it is useful to define the intermediate product separately and not as part of a multi-level assembly even if you do not want separate production orders for intermediate products.

In the example, the intermediate product ETA100 is used in the manufacture of several different cabinets. So you would want to define a unique BoM for it even if you did not want any instances of this product to be built, nor wanted to re-write these elements in a series of different multi-level BoMs.

If you only want a single production order for the complete cabinet, and not one for the BoM itself, you can define the BoM line corresponding to product ETA100 in the cabinet’s BoM as type Phantom. Then it will automatically put ETA100’s BoM contents into the cabinet’s production order even though it is been defined as multi-level.

This way of representing the assembly is very useful because it allows you to define reusable elements of the assembly and keep them isolated.

If you define the BoM for the ARM100 cabinet in the way shown by the table below, you will get two production orders when the order is confirmed, as shown in the tables below that.

Table 21.17: Definition and use of phantom BoMs

<table>
<thead>
<tr>
<th>Product Code</th>
<th>Quantity</th>
<th>Unit of Measure</th>
<th>Type of BoM</th>
</tr>
</thead>
<tbody>
<tr>
<td>ARM100</td>
<td>1</td>
<td>Unit</td>
<td>normal</td>
</tr>
<tr>
<td>PANLAT</td>
<td>2</td>
<td>Unit</td>
<td>normal</td>
</tr>
<tr>
<td>PANA100</td>
<td>1</td>
<td>Unit</td>
<td>phantom</td>
</tr>
<tr>
<td>PROFIL</td>
<td>4</td>
<td>Unit</td>
<td>phantom</td>
</tr>
<tr>
<td>ETA100</td>
<td>3</td>
<td>Unit</td>
<td>phantom</td>
</tr>
</tbody>
</table>
Table 21.18: Production Order from phantom BoMs

<table>
<thead>
<tr>
<th>Product Code</th>
<th>Quantity</th>
<th>Unit of Measure</th>
</tr>
</thead>
<tbody>
<tr>
<td>ARM100</td>
<td>1</td>
<td>Unit</td>
</tr>
<tr>
<td>PANLAT</td>
<td>2</td>
<td>Unit</td>
</tr>
<tr>
<td>BOIS002</td>
<td>0.25</td>
<td>m²</td>
</tr>
<tr>
<td>LIN040</td>
<td>1</td>
<td>m</td>
</tr>
<tr>
<td>BOIS010</td>
<td>0.249</td>
<td>m²</td>
</tr>
<tr>
<td>TAQ000</td>
<td>12</td>
<td>Unit</td>
</tr>
</tbody>
</table>

Table 21.19: Production Order from normal BoM

<table>
<thead>
<tr>
<th>Product Code</th>
<th>Quantity</th>
<th>Unit of Measure</th>
</tr>
</thead>
<tbody>
<tr>
<td>PANLAT</td>
<td>2</td>
<td>Unit</td>
</tr>
<tr>
<td>BOIS002</td>
<td>0.17</td>
<td>m²</td>
</tr>
</tbody>
</table>

21.3.2 Assembly Bills of Materials

**Note:** Sales Bills of Materials

In some software this is named a Sales Bill of Materials. In Open ERP the term assembly is used because the effect of the bill of materials is visible not only in sales but also elsewhere, for example in the intermediate manufactured products.

Assembly bills of materials enable you to define assemblies that will be sold directly. These could also be used in deliveries and stock management rather than just sold in isolation. For example if you deliver the cabinet in pieces for self-assembly, set the ARM100 BoM to type Assembly.

When a salesperson creates an order for an ARM100 product, Open ERP automatically changes the ARM100 from a set of components into an identifiable package for sending to a customer. Then it asks the storesperson to pack 2 PANLAT, 1 PANA100, 4 PROFIL, 3 ETA100. This is described as an ARM100 not just the individual delivered products.

**Example: Large distributor**

As an example of using these assemblies, take the case of a supermarket. In a supermarket, you can buy bottles of cola individually or in a pack of 6 bottles. The pack and the bottles are two different products and the barcodes used are also different.

But customers have the right to open a pack and extract some bottles to take them individually to the checkout. The supermarket can not track its stock in packs and bottles any more, but only individually in bottles.

So you can define a bill of materials for sale which defines a pack as an assembly of 6 bottles. Then when you have sold a pack, you can find a pack on the invoice or bill of sale but the associated stock operation will still be 6 bottles.

In the case of this assembly, this is not a production order to transform the product. The transformation is done directly between the order and the set.

**Note:** Assemblies and Purchases

The use of assemblies for selling to customers has been described here, but this functionality works just as well for purchases from suppliers. So in the example of a supermarket, you can buy cola in packs and the storesperson will see a number of bottles at goods in reception.

21.3.3 Configurable Bills of Materials

In Open ERP you can define several bills of materials for the same product. In fact you can have several manufacturing methods or several approved raw materials for a given product. You will see in the following
section that the manufacturing procedure (the routing) is attached to the Bill of Materials, so the choice of bill of materials implicitly includes the operations to make it.

Once several bills of materials have been defined for a particular product you need to have a system to enable Open ERP to select one of them for use. By default the bill of materials with the lowest sequence number is selected by the system.

To gain more control over the process during the sale or procurement, you can use properties. The menu Manufacturing → Configuration → Master Bill of Materials → Properties enables you to define properties, which can be defined arbitrarily to help you select a bill of materials when you have a choice of BoMs.

**Note: Properties**

Properties is a concept that enables the selection of a method for manufacturing a product. Properties define a common language between salespeople and technical people, letting the salespeople to have an influence on the manufacture of the products using non-technical language and the choices decided on by the technicians who define Bills of Materials.

For example you can define the properties and the following groups:

**Table 21.20: Properties**

<table>
<thead>
<tr>
<th>Property Group</th>
<th>Property</th>
</tr>
</thead>
<tbody>
<tr>
<td>Warranty</td>
<td>3 years</td>
</tr>
<tr>
<td>Warranty</td>
<td>1 year</td>
</tr>
<tr>
<td>Method of Manufacture</td>
<td>Serial</td>
</tr>
<tr>
<td>Method of Manufacture</td>
<td>Batch</td>
</tr>
</tbody>
</table>

Once the bills of materials have been defined you could associate the corresponding properties to them. Then when the salesperson goes to encode a product line he can attach the properties there. If the product must be manufactured, Open ERP will automatically choose the bill of materials that matches the defined properties in the order most closely.

Note the properties are only visible in the Bills of Materials and Sales Management if you are working in the Extended View mode. If you can not see it on your screen add the group Useability / Extended View to your user.

**Figure 21.5: Properties on a customer order line**

Example: Manufacturing in a batch or on a production line

As an example, take the manufacture of the cabinet presented above. You can imagine that the company has two methods of manufacturing this cabinet:
• Manually: staff assemble the cabinets one by one and cut the wood plank by plank. This approach is usually used to assemble prototypes. It gets you very rapid production, but at a high cost and only in small quantities.

• On a production line: staff use machines that are capable of cutting wood by bandsaw. This method is used for production runs of at least 50 items because the lead times using this method are quite lengthy. The delay to the start of production is much longer, yet the cost per unit is much lower in this volume.

You define two bills of materials for the same cabinet. To distinguish between them, you will define to properties in the same group: manual assembly and production line assembly. On the quotation, the salesperson can set the method of manufacture he wants on each order line, depending on the quantities and the lead time requested by the customer.

Note: bills of materials and substitute products
In some software, you use the term substitute for this principle of configurable properties in a bill of materials.

By putting a bill of materials on its own line, you can also implement substitute products. You set the bill of materials to type Assembly to make the substitution transparent and to prevent Open ERP from proposing an intermediate production order.

21.4 Manufacturing

Once the bills of materials have been defined, Open ERP becomes capable of automatically deciding on the manufacturing route depending on the needs of the company.

Production orders can be proposed automatically by the system depending on several criteria described in the preceding chapter:

• Using the Make to Order rules,
• Using the Order Point rules,
• Using the Production plan.

Clearly it is also possible to start production manually. To do this you can use the menu Manufacturing → Manufacturing → Manufacturing Orders.

If you have not installed the Just-In-Time planning module mrp_jit, you should start using Open ERP to schedule the Production Orders automatically using the various system rules. To do this use the menu Warehouse
→ Schedulers → Compute Schedulers.

21.5 Workflow for complete production

To understand the usefulness and the functioning of the system you should test a complete workflow on the new database installed with the demonstration data. In the order you can see:

- The creation of a customer order,
- The manufacturing workflow for an intermediate product,
- The manufacture of an ordered product,
- The delivery of products to a customer,
- Invoicing at the end of the month,
- Traceability for after-sales service.

Tip: Demonstration data
To follow the workflow shown below exactly, you should keep the same quantities as in the example and start from a new database. Then you will not run into exceptions that would result from a lack of stock.

This more advanced case of handling problems in procurement, will be sorted out later in the chapter.

21.5.1 The customer order

Begin by encoding a customer order. To do this, use the menu Sales → Sales → Sales Order. Enter the following information:

- **Customer**: Agrolait,
- **Shipping Policy**: Invoice from Delivery(second tab),
- **Order Line**:
  - **Product**: PC2 – Basic PC (assemble on demand),
  - **Quantity (UoM)**: 1,
  - **Product UoM**: PCE,
  - **Procure method**: Make To Order.

Once the quotation has been entered you can confirm it immediately by clicking the button Confirm Order at the bottom to the right, the manufacturing order automatically generated.
Figure 21.7: Automatically generated manufacturing orders from sale order

Keep note of the order reference because this follows all through the process. Usually, in a new database, this will be SO007. At this stage you can look at the process linked to your order using the Process button above and to the right of the form.

Figure 21.8: Process for handling Sales Order SO007

Start the requirements calculation using the menu Warehouse → Schedulers → Compute Schedulers.

21.5.2 Producing an Intermediate Product

To understand the implications of requirements calculation, you must know the configuration of the sold product. To do this, go to the form for product PC2 and click on the link Bill of Materials to the right. You get the scheme shown in Structure of BoM for product PC2 which is the composition of the selected product.
Manufacturing the PC2 computer must be done in two steps:

1: Manufacture of the intermediate product: CPU_GEN

2: Manufacture of the finished product using that intermediate products: PC2

The manufacturing supervisor can then consult the manufacturing orders using the menu \textit{Manufacturing} $\rightarrow$ \textit{Manufacturing} $\rightarrow$ \textit{Manufacturing Orders}. You then get a list of orders to start and the estimated start date to meet the ordered customer delivery date.

You will see the production order for PC2 (MO/00034) and also CPU_GEN(MO/00034) because PC2 depends on an intermediate product CPU_GEN. Return to the production order for CPU_GEN. If there are several of them, select the one corresponding to your order using the reference that contains your order number (in this example SO007:MO/00034).
The system shows you that you must manufacture product CPU_GEN using the components: CPU1, MB1, FAN, RAM. You can then confirm the production twice:

Start of production: consumption of raw materials,

End of production: manufacture of finished product.

At this stage, you should click to edit the line for the product MB1 to enter a lot number for it. The lot number is usually shown the parent chart, so you should just copy that over. To do that put the cursor in the field Production Lot and press \(<F1>\) to create a new lot. Set a lot reference, for example: MO:PL/0000001. The system may then show you a warning because this lot is not in stock, but you can ignore this message.

The production order must be in the closed state as shown in the figure "Production order after the different stages."
21.5.3 Manufacture of finished product

Having manufactured the intermediate product CPU_GEN, Open ERP then automatically proposes the manufacture of the computer PC2 using the order created earlier. So return to the menu for production orders to start **Manufacturing → Manufacturing → Manufacturing Orders**.

You will find computer PC2 which has been sold to the customer, as shown in the figure *Complete the production of PC2*.

![Figure 21.13: Complete the production of PC2](image)

Just as for product CPU_GEN, confirm the production order between two dates: start of production and end of production.

The product sold to the customer has now been manufactured and the raw materials have been consumed and taken out of stock.

**Tip:** **Automatic Actions**

As well as managing the use of materials and the production of stocks, manufacturing can have the following automatic effects which are detailed further on in the chapter:

- adding value to stock,
- generating operations for assembly staff,
- automatically creating analytical accounting entries.

21.5.4 Delivery of product to the customer

When the products have been manufactured, the storesperson automatically finds the order in his list of items to do. To see the items waiting for picking, use the menu **Warehouse → Warehouse Management → Outgoing Deliveries**. You will find lists of packing to be done, there, as shown in the figure *List of packing operations to be done*.
Figure 21.14: List of packing operations to be done

The packing orders are presented in priority order of despatch so the storesperson must begin with the orders at the top of the list. Confirm that your packing list has been created by looking for the customer name (Agrolait) or by its reference (SO007).

Tip: Packing and Delivery
Depending on whether you work in the simplified or extended mode you may need a further step to make a delivery to your customer, so you would have to carry out the two steps:
• picking list,
• delivery order.

21.5.5 Invoicing at delivery

Periodically the administrator or an accountant can send invoices based on the deliveries that have been carried out. To do that, you can use the menu Warehouse → Warehouse Management → Outgoing Deliveries. You then get a list of all the deliveries that have been made but have not yet been invoiced.

So select some or all of the deliveries. Click on the action Create Invoice. Open ERP asks if you want to group the deliveries from the same partner into a single invoice or if you would prefer to invoice for each delivery individually.

Figure 21.15: Invoicing of deliveries
Invoices are generated automatically in the Draft state by Open ERP. You can modify invoices before approving them finally.

Figure 21.16: List of invoices generated by the system based on deliveries

Once you have reviewed the different invoices that were generated, you can confirm them one by one or all at once by using the available actions. Then print the invoices using the multiple print option and send them to your customers by post.

21.5.6 Traceability

Now suppose that the customer phones you to tell you about a production fault in a delivered product. You can consult the traceability through the whole manufacturing chain using the serial number indicated on the product MB1. To look through the detailed history, use the menu Warehouse → Traceability → Production Lots.

Find the product corresponding to the product or lot number. Once it is been found you can use traceability as described in the section Management of Lots and Traceability in the Your Warehouse chapter.

21.6 Production order in detail

To open a Production Order, use the menu Manufacturing → Manufacturing → Manufacturing Orders and click on New button. You get a blank form for entering a new production order as shown in the figure New production order.
The production order follows the process given by the figure *Process for handling a production order*.

The *Scheduled date*, *Product Qty* and *Reference*, are automatically completed when the form is first opened. Enter the product that you want to produce, and the quantity required. The *Product UOM* by default is completed automatically by Open ERP when the product is first selected.

You then have to set two locations:

The location from which the required raw materials should be found, and

The location for depositing the finished products.

For simplicity, put the Stock location in both places. The field *Bill of Materials* will automatically be completed by Open ERP when you select the product. You can then overwrite it with another BoM to specify something else to use for this specific manufacture then click the button *Compute Data*.

The tabs *Scheduled Products* and *Work Orders* are also completed automatically when you click *Compute Data*. You will find the raw materials there that are required for the production and the operations needed by the assembly staff.

If you want to start production, click the button *Confirm Production*, and Open ERP then automatically completes the *Products to Consume* field in the *Consumed Products* tab and *Products to Finish* field in *Finished Products* tab.

The information in the *Consumed Products* tab can be changed if:

- you want to enter a serial number for raw materials,
- you want to change the quantities consumed (lost during production).

For traceability you can set lot numbers on the raw materials used, or on the finished products. Note the *Production Lot* and *Pack* numbers.

Once the order is confirmed, you should force the reservation of materials using the *Force Reservation* button. This means that you do not have to wait for the scheduler to assign and reserve the raw materials from your stock for this production run. This shortcuts the procurement process.
If you do not want to change the priorities, just leave the production order in this state and the scheduler will create a plan based on the priority and your planned date.

To start the production of products, click Start Production. The raw materials are then consumed automatically from stock, which means that the draft (Waiting) movements become Done.

Once the production is complete, click Produce. The finished products are then moved into stock.

21.7 Scheduling

The requirements scheduler is the calculation engine which plans and prioritises production and purchasing automatically from the rules defined on these products. It is started once per day. You can also start it manually using the menu Warehouse → Schedulers → Compute Schedulers. This uses all the relevant parameters defined in the products, the suppliers and the company to determine the priorities between the different production orders, deliveries and supplier purchases.

You can set the starting time by modifying the corresponding action in the menu Administration → Configuration → Scheduler → Scheduled Actions. Modify the Run mrp Scheduler configuration document.

![Scheduled Actions](image)

Figure 21.19: Configuring the start time for calculating requirements

Tip: Calculating requirements / scheduling

Scheduling only validates procurement confirmed but not started. These procurement reservations will themselves start production, tasks or purchases depending on the configuration of the requested product.

You take account of the priority of operations in starting reservations and procurement. The urgent requests, or those with a date in the past, or those with a date earlier than the others will be started first so that if there are not enough products in stock to satisfy all the requests, the most urgent will be produced first.

21.8 Calculation of lead times

All procurement operations (that is, the requirement for both production orders and purchase orders) are automatically calculated by the scheduler. But more than just creating each order, Open ERP plans the timing of each step. A planned date calculated by the system can be found on each order document.

To organize the whole chain of manufacturing and procurement, Open ERP bases everything on the delivery date promised to the customer. This is given by the date of the confirmation in the order and the lead times shown in each product line of the order. This lead time is itself proposed automatically in the field Customer Lead Time shown in the product form. This is the difference between the time on an order and that of the delivery.

To see a calculation of the lead times, take the example of the cabinet above. Suppose that the cabinet is assembled in two steps, using the two following bills of materials.
Table 21.21: Bill of Materials for 1 ARM100 Unit

<table>
<thead>
<tr>
<th>Product Code</th>
<th>Quantity</th>
<th>Unit of Measure</th>
</tr>
</thead>
<tbody>
<tr>
<td>PANLAT</td>
<td>2</td>
<td>Unit</td>
</tr>
<tr>
<td>BOIS002</td>
<td>0.25</td>
<td>m2</td>
</tr>
<tr>
<td>LIN040</td>
<td>1</td>
<td>m</td>
</tr>
<tr>
<td>BOIS010</td>
<td>0.249</td>
<td>m2</td>
</tr>
<tr>
<td>TAQ000</td>
<td>12</td>
<td>Unit</td>
</tr>
</tbody>
</table>

Table 21.22: Bill of Materials for 2 PANLAT Units

<table>
<thead>
<tr>
<th>Product Code</th>
<th>Quantity</th>
<th>Unit of Measure</th>
</tr>
</thead>
<tbody>
<tr>
<td>BOIS002</td>
<td>0.17</td>
<td>m2</td>
</tr>
</tbody>
</table>

The PANLAT is made from an order using the workflow shown. The BOIS02 is purchased on order and the other products are all found in stock. An order for the product ARM100 will then generate two production orders (ARM100 and PANLAT) then produce two purchase orders for the product BOIS02. Product BOIS02 is used in the production of both ARM100 and PANLAT. Set the lead times on the product forms to the following:

Table 21.23: Lead Times

<table>
<thead>
<tr>
<th>Product Code</th>
<th>Customer Lead Time</th>
<th>Manufacturing Lead Time</th>
<th>Supplier Lead Time</th>
</tr>
</thead>
<tbody>
<tr>
<td>ARM100</td>
<td>30 days</td>
<td>5 days</td>
<td>10 days</td>
</tr>
<tr>
<td>PANLAT</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>BOIS02</td>
<td>5 days</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

A customer order placed on the 1st January will set up the following operations and lead times:

- Delivery ARM100: 31 January (=1st January + 30 days),
- Manufacture ARM100: 26 January (=31 January – 5 days),
- Manufacture PANLAT: 16 January (=26 January – 10 days),
- Purchase BOIS02 (for ARM100): 21 January (=26 January – 5 days),
- Purchase BOIS02 (for PANLAT): 11 January (=16 January – 5 days).

In this example, Open ERP will propose placing two orders with the supplier of product BOIS002. Each of these orders can be for a different planned date. Before confirming these orders the purchasing manager could group these orders into single order.

### 21.8.1 Security days

The scheduler will plan all operations as a function of the time configured on the products. But it is also possible to configure these factors in the company. These factors are then global to the company, whatever the product concerned. In the description of the company, on the Configuration tab, you find the following parameters:

- **Security Days**: number of days to deduct from a system order to cope with any problems of procurement,
- **Purchase Lead Time**: additional days to include for all purchase orders with this supplier,
- **Manufacturing Lead Time**: number of additional days needed for manufacturing,
- **Scheduler Range Days**: all the requests which are for procuring for a later date to the number of days which are not calculated in the scheduler.

**Note:** Purchasing lead time

The security delay for purchases is the average time between the order generated by Open ERP and the real purchase time from the supplier by your purchasing department. This delay takes account of the order process in your company, including order negotiation time.

Take for example the following configuration:

- **Security Days**: 2,
• **Purchase Lead Time**: 3,
• **Manufacturing Lead Time**: 1.

The example above will then be given the following lead times:

• Delivery ARM100: 29 January (=1st January + 30 days – 2 days),
• Manufacture ARM100: 23 January (=29 January – 5 days – 1 day),
• Manufacture PANLAT: 12 January (=26 January – 10 days – 1 day),
• Purchase BOIS02 (for ARM100): 15 January (=26 January – 5 days – 3 days),
• Purchase BOIS02 (for PANLAT): 4 January (=12 January – 5 days – 3 days).

### 21.9 Operations

In the first part of this chapter, manufacturing management was handled in terms of products and materials. This section focuses on manufacturing operations. To manufacture or assemble products, as well as using raw materials and finished product you must also handle operations such as assembly, drilling wood, and cutting timber.

The different operations will have different impacts on the costs of manufacture and planning depending on the available workload.

#### 21.9.1 Definition of concepts

To manage operations you should understand the following concepts

• Workcenters,
• Routing,
• Operations.

#### 21.9.2 Workcenters

Workcenters represent units of product, capable of doing material transformation operations. You can distinguish two types of workcenter: machines and human resources.

**Note:** Workcenter

Workcenters are units of manufacture consisting of one or several people and/or machines that can be considered as a unit for the purposes of forecasting capacity and planning.

Use the menu *Manufacturing → Configuration → Resources → Work Centers* to define a new workcenter. You get a form as shown in the figure *Definition of a workcenter*.
A workcenter must have a name and a code. You then assign a type: machine, human resource, tool, and a description of operating hours or functionality. The figure Definition of a workcenter represents the hours from Monday to Friday, from 08:00 to 18:00 with a break of an hour from 12:00.

You should show a description of the workcenter and its operations.

Once the database is encoded you should enter data about the production capacity of the workcenter. Depending on whether you have a machine or a person, a workcenter will be defined in cycles or hours. If it represents a set of machines and people you can use both cycles and hours at the same time.

**Note:** A Cycle

A cycle corresponds to the time required to carry out an assembly operation. The user is free to determine which is the reference operation for a given workcenter. It must be represented by the cost and elapsed time of manufacture. For example, for a printing workcenter, a cycle will be the printing of 1 page or of 1000 pages depending on the printer.

To define the capacity properly it is necessary to know, for each workcenter, what will be the reference operation which determines the cycle. You can then define the data relative to the capacity.

*Capacity per Cycle (CA)*: determine the number of operations that can be done in parallel during a cycle. Generally the number defines the number of identical machines or people defined by the workcenter.

*Time for 1 cycle (hour) (TC)*: give the duration in hour for that or the operations defined by a cycle.

*Time before production (TS)*: give the wait in hours to initialise production operations. Generally this represents the machine setup time.

*Time after production (TN)*: give the delay in hours after the end of a production operation. Generally this represents the cleaning time necessary after an operation.

*Efficiency factor (ET)*: is a factor that is applied to the three times above to determine the real production time. This factor enables you to readjust the different times progressively and as a measure of machine utilization. You can not readjust the other times because generally they are taken from the machine’s data sheet.

The total time for carrying out X operations is then given by the following formula: \((\frac{C}{CA} \times TC + TS + TN) \times ET\). In this formula the result of the division is rounded upwards. Then if the capacity per cycle is 6 it takes 3 cycles to realize 15 operations.

**Tip:** Multi-level routing

It is possible to define routing on several levels to support multi-level bills of materials. You can select the routing on each level of a bill of materials. The levels are then linked to hierarchies of bills of materials.
The *Hour Account* and *Cycle Account* lets you define the links to analytical account to report the costs of the workcenter operations. If you leave the different fields empty Open ERP will not have any effect on the analytic accounts.

### 21.9.3 Routing

Routings define the assembly operations to be done in workcenters for manufacturing a certain product. They are usually attached to bills of materials which will define the assembly of products required for manufacture or for finished products.

A routing can be defined directly in a bill of materials or through the menu *Manufacturing → Configuration → Master Bill of Materials → Routings*. A routing has a name, a code and a description. Later in this chapter you will see that a routing can also be associated with a stock location. That enable you to indicate where assembly takes place.

![Figure 21.21: Definition of a routing with three operations](image)

**Note:** Subcontracting assembly

You will see further on in this chapter that it is possible to link a routing and a stock location for the customer or the supplier. You do this after you have subcontracted the assembly of a product to a supplier, for example.

In the routing you must show the list of operations that must be done. Each operation must be done at a workcenter and possess a number of hours and/or cycles be done.

### 21.9.4 Impact on the production order

The routings are then attached to the bills of materials which are then also used to generate product order. On a production order you will find assembly operations for manufacture on the *Work Orders* tab.
Figure 21.22: Operations on a production order

The times and the cycles shown in the production order are, in the same way as the materials, theoretical data. The user can change the values to reflect reality for manufacture.

So if you use routings, Open ERP automatically calculates the operations required for the production order. If the workcenters are linked to analytic accounts, at the end of production, Open EEP will generate the analytic accounts representing the costs of manufacture. This will allow you to work out profitability per workcenter or manufacturing unit through analytic accounting.

But the routings also enable you to manage your production capacity. You will be able to leave the demand charts for the days / weeks / months ahead to validate that you do not forecast more than you are capable of producing.

To see a demand chart, list the workcenters using the menu Manufacturing → Configuration → Resources → Workcenters. Then select one or several workcenters and click on the action Workcenter Load. Open ERP then asks you if you work in cycles or in hours and your interval is calculated (by day, week or month).

Figure 21.23: Charge by workcenter

Tip: Theoretical times

Once the routings have been clearly defined, you determine the effective working time per assembly worker. This is the time actually taken by the assembly worker for each operation. That enables you to compare the real working time in your company and work out the productivity per person.
21.9.5 Work operations

A production order defines the use of the products defined in the Bills of Materials, and the operations defined in
the routing. You have seen how to handle manufacturing production as a top-level process, but some companies
prefer to have finer-grained control of operations where instead of specifying just the production process itself,
they enter data on each constituent production operation.

21.9.6 Management of operations

Note: Operations
Operations are often called work orders.
To work using work orders you must install the optional module mrp_operations. Once the module is
installed you will find a new menu called Manufacturing → Manufacturing → Work Orders.

The assembly workers must then encode each step operation by operation and, for each step, the real working
time for it. OpenERP support the editable workflow through the menu Administration → Customization →
Workflows → Workflows. You can find the operation workflow and edit according to necessity.

Operations must then be carried out one by one. On each operation the operator can click on Start button. The
time is then worked out automatically on the operation between the two changes of status. The operator can also
put the operation on hold and start again later.

The following process is attached to each operation.

![Mrp Operations Process Diagram](image)

Figure 21.26: Process for handling an operation

Thanks to this use by operation, the real working time is recorded on the production order.

The production order is automatically put into the state ‘In Production’ once the first operation has been started. That consumes some raw materials. Similarly the production order is closed automatically once the last operation is completed. The finished products are then made.

### 21.10 Events and barcodes

If the company wants to work with barcodes in manufacturing you can work on each operation using events. Here are some examples of events for an operations:

- Starting an operation,
- Pausing an operation,
- Restarting an operation,
- Closing an operation,
- Cancelling an operation.

You can print barcodes for the workcenters using the menu *Manufacturing → Configuration → Resources → Work Centers*. Click on the report action *Work Centers Barcode* to generate the barcodes for that work center.
Open ERP then applies the events to the relevant operation.

### 21.10.1 Subcontracting manufacture

In Open ERP it is possible to subcontract production operations (for example painting and item assembly) at a supplier’s. To do this you must indicate on the relevant routing document a supplier location for stock management.

You must then configure a location dedicated to this supplier with the following data:

- **Location Type**: Supplier,
- **Location Address**: Select an address of the subcontractor partner,
- **Chained Location Type**: Fixed,
- **Chained Location If Fixed**: your Stock,
- **Chaining Lead Time**: number of days before receipt of the finished product.

Then once the manufacture has been planned for the product in question, Open ERP will generate the following steps:

**Delivery of raw materials to the stores for the supplier,**

**Production order for the products at the suppliers and receipt of the finished products in the stores.**

Once the production order has been confirmed, Open ERP automatically generates a delivery order to send to the raw materials supplier. The storesperson can access this delivery order using the menu `Warehouse → Warehouse Management → Internal Moves`. The raw materials will then be placed in stock at the supplier’s stores.

Once the delivery of raw materials has been confirmed, Open ERP activates the production order. The supplier uses the raw materials sent to produce the finished goods which will automatically be put in your own stores. The confirmation of this manufacture is made when you receive the products from your supplier. It is then that you indicate the quantities consumed by your supplier.

**Tip: Subcontract without routing**

*If you do not use routing you can always subcontract work orders by creating an empty routing in the subcontract bill of materials.*

Production orders are found in the menu `Manufacturing → Manufacturing → Manufacturing Orders`. A production order is always carried out in two stages:

2. Production of finished products.
Depending on the company’s needs, you can specify that the first step is confirmed at the acknowledgment of manufacturing supplier and the second at the receipt of finished goods in the warehouse.

21.11 Treatment of exceptions

The set of stock requirements is generated by procurement orders.

In normal system use, you do not need to worry about procurement orders because they are automatically generated by Open ERP and the user will usually work on the results of a procurement: a production order, a purchase order, a sale order and a task.

But if there are configuration problems, the system can remain blocked by a procurement without generating a corresponding document. For example, suppose that you configure a product **Procurement Method** as **Make to Order** and **Supply method** as **Produce** but you have not defined the bill of materials. In that case procurement of the product will stay blocked in an exception state. **No Bill of Materials defined for this product.** You must then create a bill of materials to unblock the problem.

Possible problems include:

- No bill of materials defined for production: in this case you have got to create one or indicate that the product can be purchased instead.
- No supplier available for a purchase: it is then necessary to define a supplier in the tab **Supplier** of the product form.
- No address defined on the supplier partner: you must complete an address for the supplier by default for the product in consideration.
- No quantity available in stock: you must create a rule for automatically procuring (for example a minimum stock rule) and put it in the order, or manually procure it.

Some problems are just those of timing and can be automatically corrected by the system.

Use the menu **Warehouse → Schedulers → Procurement Exceptions** to see all the exceptions.

If a product must be ‘in stock’ but is not available in your stores, Open ERP will make the exception in ‘temporary’ or ‘to be corrected’. The exception is temporary if the system can procure it automatically, for example if a procurement rule is defined for minimum stock.

![Figure 21.28: Example of a procurement in exception](image)

If no procurement rule is defined the exception must be corrected manually by the user. Once the exception is corrected you can restart by clicking on **Retry**. If you do not do that then Open ERP will automatically recalculate on the next automated requirements calculation.
21.12 Manual procurement

To procure internally, you can create a procurement order manually. Use the menu Warehouse → Schedulers → Procurement Exceptions and click on New button to do this.

![Diagram of Procurement Order Encoding](image)

Figure 21.29: Encoding for a new procurement order

The procurement order will then be responsible for calculating a proposal for automatic procurement for the product concerned. This procurement will start a task, a purchase order form the supplier or a production depending on the product configuration.

![Diagram of Procurement Workflow](image)

Figure 21.30: Workflow for handling a procurement, a function of the product configuration

It is better to encode a procurement order rather than direct purchasing or production. That method has the following advantages:

- The form is simpler because Open ERP calculates the different values from other values and defined rules: purchase date calculated from order date, default supplier, raw materials needs, selection of the most suitable bill of materials, etc
- The calculation of requirements prioritises the procurements. If you encode a purchase directly you short-circuit
the planning of different procurements.

**Tip: Shortcuts**

On the product form you have an ACTIONS shortcut button Create Procurements that lets you quickly create a new procurement order.

### 21.13 Management of waste products and secondary products

For the management of waste you must install the module `mrp_subproduct`. The normal behaviour of manufacture in Open ERP enables you to manufacture several units of the same finished product from raw materials \((A + B > C)\). With waste management, the result of a manufacture can be to have both finished products and secondary products \((A + B > C + D)\).

**Note: Waste material**

In Open ERP waste material corresponds to secondary products that are a by-product of the main manufacturing process. For example, cutting planks of timber will produce other planks but these bits of timber are too small (or the offcuts may have value for the company if they can be used elsewhere).

If the module `mrp_subproduct` has been installed you get a new field in the Bill of Material that lets you set secondary products resulting from the manufacture of the finished product.

![Bill of Material](image)

**Figure 21.31: Definition of waste products in a bill of materials**

When Open ERP generates a production order based on a bill of materials that uses secondary product you pick up the list of all products in in the the third tab of the production order ‘Finished Products’.
Secondary products enable you to generate several types of products from the same raw materials and manufacturing methods – only these are not used in the calculation of requirements. Then if you need the secondary products Open ERP will not ask you to manufacture another product to use the waste products and secondary products of this manufacture. In this case you should enter another production order for the secondary product.

Note: Services in Manufacturing
Unlike most software for production management, Open ERP manages services as well as stockable products. So it is possible to put products of type Service in a bill of materials. These do not appear in the production order but their requirements will be taken into account.
If they are defined as Make to Order Open ERP will generate a task for the manufacture or a subcontract order for the operations. The behaviour will depend on the supply method configured on the product form Buy or Produce.

21.14 Management of repairs

The management of repairs is carried out using the module mrp_repair. Once it is installed this module adds new Manufacturing → Manufacturing → Repair Orders menu under the Manufacturing menu for creating repair jobs and reviewing repairs in progress.

In Open ERP a repair will have the following effects:

- Use of materials: items for replacement,
- Production of products: items replaced from reserved stock,
- Quality control: tracking the reasons for repair,
- Accounting entries: following stock moves,
- Receipt and delivery of product from and to the end user,
- Adding operations that can be seen in the product’s traceability,
- Invoicing items used and/or free for repairs.

21.14.1 Entering data for a new repair

Use the menu Manufacturing → Manufacturing → Repair Orders to enter a new repair into the system. You will see a blank form for the repair data, as shown in the figure Entering data for a new repair below.
Figure 21.33: Entering data for a new repair

Start by identifying the product that will be repaired using the product lot number. Open ERP then automatically completes fields from the selected lot – the partner fields, address, delivery location, and stock move.

If a warranty period has been defined in the product description, in months, Open ERP then completes the field Guarantee limit with the correct warranty date.

You must then specify the components that you will be adding, replacing or removing in the operations part. On each line you must specify the following:

Add or remove a component of the finished product:

- Product Component,
- Quantity,
- Unit of Measure
- Price of Component,
- Possible lot number,
- Location where the component was found,
- To invoice or not.

Once the component has been selected, Open ERP automatically completes most of the fields:

- Quantity : 1,
- Unit of Measure : unit for managing stock defined in the product form,
- Component Price : calculated from the customer list price,
- Source location : given by the stock management,
- To invoice or not : depends on the actual date and the guarantee period.

This information is automatically proposed by the system but you can modify it all yourself.

You can also encode additional charges in the second tab of the repair - applicable list price, address and type of invoice, as well as additional line items that need to be added to the repair bill.
The third tab is for encoding information about the internal notes like picking, invoice and locations.

### 21.14.2 Repair workflow

A defined process handles a repair order – both the repair itself and invoicing the client. The figure *Process for handling a repair* shows this repair process.

Once a repair has been entered onto the system, it is in the 'draft' state. In this state it has no impact on the rest of the system. You can print a quotation from it using the action ‘Quotation / Order’. The repair quotation can then be sent to the customer.

Once the customer approves the repair, use the menu *Manufacturing → Manufacturing → Repair Orders* to find the draft repair. Click to confirm the draft repair and put it into the running state. You can specify the invoicing...
mode in the second tab:

• no invoicing,
• invoicing before repair,
• invoicing after repair.

You can confirm the repair operation or create an invoice for the customer depending on this state.

21.14.3 Invoicing the repair

When the repair is to be invoiced, an invoice is generated in the draft state by the system. This invoice contains the raw materials used (replaced components) and any other costs such as the time used for the repair. These other costs are entered on the second tab of the repair form.

If the product to be repaired is still under guarantee, Open ERP automatically suggests that the components themselves are not invoiced, but will still use any other defined costs. You can override any of these default values when you are entering the data.

The link to the generated invoice is shown on the second tab of the repair document.

21.14.4 Stock movements and repair

When the repair has been carried out, Open ERP automatically carries out stock movements for components that have been removed, added or replaced on the finished product.

The move operations are carried out using the locations shown on the first tab of the repair document. If a destination location has been specified, Open ERP automatically handles the final customer delivery order when the repair has been completed. This also lets you manage the delivery of the repaired products.

For example, take the case of the cabinet that was produced at the start of this chapter. If you have to replace the shelf PANLAT, you must enter data for the repair as shown in figure Repair of a shelf in a cabinet.

![Figure 21.36: Repair of a shelf in a cabinet](image)

In this example, you would carry out the following operations:

• Removal of a PANLAT shelf in the cabinet and put the faulty shelf in the location Defective Products,

• Placement of a new PANLAT shelf that has been taken from stock.

When the repair is ready to be confirmed, Open ERP will generate the following stock moves:
• Put faulty PANLAT into suitable stock location *Default Production > Defective Products*.

• Consume PANLAT: *Stock > Default production*.

If you analyze the traceability of this lot number you will see all the repair operations in the upstream and downstream traceability lists of the products concerned.
Part VII

Manage your Business
These two chapters are about selling and purchasing products and services.
CHAPTER
TWENTYTWO

DRIVING YOUR SALES

This chapter describes OpenERP’s sales management, following the complete sales order process from quotation to customer order, including the management of deliveries and invoicing. It does not look at customer relations and pre-sales, which are handled by the CRM (Customer Relationship Management) modules described in an earlier part of the book.

It also describes the management of carriers, margin control and reporting, price management and the handling of various types of sales discount campaigns.

For this chapter you should start with a fresh database that includes demonstration data, with sale and its dependencies installed and no particular chart of accounts configured.

22.1 Sales Quotations

In OpenERP, a quotation and an order are handled by the same underlying object, but in different states. You can consider an order to be a quotation that has evolved because it has been confirmed by the customer. Or, conversely, that a quotation is an order that has not yet been validated or cancelled. All of the orders and quotations in the system can be reached using the menu Sales → Sales → Sales Orders.

To enter details of a new quotation, you can use the menu Sales → Sales → Sales Orders and then select New. OpenERP then opens a new window so that you can enter data into a new blank quotation form.

Some information is automatically specified by the system:

- an internal reference for the quotation or order,
• the sale point that the order will be delivered from,
• the order date,
• the pricelist for the current sales order.

You can modify any of that information before validating the quotation. The customer reference is shown in the header of the order. This optional field is for the customer’s own reference – if the customer does not supply one then just leave it empty.

You then enter all the data about the order in the Sales Order tab. Start by entering the customer name, selecting the correct customer from the list of customers in the system. You can create a new customer on the fly at this stage if necessary – press `<F1>` in the empty Customer field to do that.

Once the customer name has been selected, different fields of the order are completed automatically, based on the configuration of the partner form for that customer:

• **Ordering Contact**: person handling the order at the customer end. By default, OpenERP proposes the Ordering Contact at the selected partner.

• **Shipping Address**: address used on the delivery order. By default, OpenERP proposes the shipping address from the partner form. If nothing is defined in that slot, it uses the default address instead.

• **Invoice Address**: address used to send the invoice to the customer. By default, OpenERP proposes the address labelled Invoice from the partner form. If nothing is defined there, it uses the default address instead.

• **Pricelist**: will determine both the currency of the quotation and the price that will be used for each product.

• **Payment Term**: available in the Other Information tab, it shows the payment method that the customer will follow, for example 30 Days End of Month.

You can modify any of these fields on the order as you go.

You can also set an analytic account for your order. This account will be used during invoicing to generate accounting entries corresponding to the invoice automatically. This is extremely useful for assigning revenues to the project or case specified by this order.

---

### Tip: Analytic Accounts

*If you are managing by task, the analytic account to be selected is the one that corresponds to the project for the order. The sale carried out by the order can be allocated to the project so that profitability calculations can be made.*

---

Once the information has been entered, you can enter data for the order lines. To do that, create a new order line as shown in the figure *Entering a new sales order line*:
First of all, select the product that is to be sold to the customer. OpenERP shows some useful information in the list of products to help you during your sale:

- **Real Stock**: physically present in your warehouses. This value depends on the sale point selected in the order header. Different sale points can be linked to different warehouses, giving different stock levels, or can use the same warehouse.

- **Virtual Stock**: shows a salesperson the quantity that can be sold, taking into account both stock reserved for other orders and amounts that could arrive in the short term.

- **Pricelist**: (may not be shown, depending on the installed modules) depends on the conditions attached to the customer, calculated on the list price. This is the price that is proposed by default in the customer quotation, unless it has been modified by the salesperson.

- **Public Price**: the base sale price for the given product. It provides a base for the salesperson to be able to judge whether to offer a discount to the customer, and how much the discount should be.

- **Cost Price**: shows the cost price of the product. If the salesperson sells at less than this amount, then the company incurs a loss.

When the product that is to be sold to the customer has been selected, OpenERP automatically completes all the other required fields: quantity, unit of measure, description, unit price, discount, procurement method, lead times and applicable taxes. All of this information comes from the product form.

**Tip: Visible Discount**

If a discounted price is taken from a price list, then by default that figure is shown as the sale price to the customer. He will see a discount of 0% along with unit price that is different from the list price. If you install the module `product_visible_discount` from addons-extra you can configure whether you want to make the discount explicitly visible on an order form as a percentage difference from the list price, or just show a reduced unit price as it does by default.

In the form, the selected product is presented in the language of the user so that he can see what he is selling. The description of the product sold can also be expressed in the customer’s language. The translation to the customer’s language is used on the quotation or order when it is printed.
Note: One-off Sales
If a product is sold to a customer only once, you do not have to enter data into a complete new product form just for that sale. You can manually complete all the information in the order without putting it into a product: description, price, quantity, lead time, taxes. In this case OpenERP will not generate a delivery note because the product is not held in stock.

When all of the products are entered, you can print the quotation and send it to the customer. To do this, click on the link Quotation / Order in the Reports section to the right. OpenERP opens the quotation in PDF to enable to you to see it before printing.

You can then confirm the quotation to move it on to an order if the order is confirmed by the customer, or just cancel the window without confirming the order to leave it in quotation state. To find all of the current quotations, you can use the menu Sales → Sales → Sales Orders and click the Quotations filter button.

To follow the process for your order, you can click on the process view from the order form. OpenERP shows you an interactive process view of that order. For more information about its use, look at Process.
22.2 Packaging

Products can be managed in several different packaged forms. For example, if you sell batteries you can define the following packages for a given battery product:

- Piece: a battery,
- Blister Pack: a pack of 4 batteries,
- Pack of 100 blisters: 400 batteries,
- Palette: 40 packs for a total of 16,000 batteries.

OpenERP’s package management enables you to sell the same product in several different forms. The salesperson could sell separately, one battery or a palette of batteries. In the order, you can select the default packaging type as a function of the quantities ordered.

For example, if the customer wants to buy 30,000 batteries, the salesperson can select the package palette. OpenERP will then propose the sale of 32,000 batteries, which corresponds to two palettes. Or the salesperson can select 75 packs.

The available packages are defined in the product form, in the Packaging tab. The first item on the list is the one that will be used by default.

Once a package has been defined on the order, OpenERP will throw up an alert if the ordered quantities do not correspond to the proposed packages. The quantity must be a multiple of the field Quantity by Package defined on the packaging form.

Do not confuse the management of packaging with the management of multiple units of measure. The Units of Measure is used to manage the stock differently in its different units. With packages, the stock is always managed...
by individual items, but information about the package to use is supplied to the storesperson along with that item. Even if the effects are the same, the printed documents will be different. The two following operations have the same effect on stock movement levels but will be printed differently on the sales order and the packing order:

- 32,000 batteries, delivered on two palettes,
- 2 palettes of batteries, with no information about packaging.

If the customer wants to order a palette and 10 packs, the salesperson can put two order lines on the sales order using the same product but different units of measure.

It is sometimes more useful to define different products than to define several possible packages for the same product. A case of beer in a supermarket is a good example. A case holds 24 bottles, plus the empty case itself. The customer can buy bottles by the piece or a case of 24 bottles at one go.

You could define two packages for the product Bottle of beer: PCE and case. But this representation does not let you manage the stock and price of empty cases. So you might instead prefer a Bill of Materials for the sale, defining and using three different products:

- the empty case for the beer,
- the bottle of beer,
- the case of 24 bottles of beer.

You also define the bill of materials below which determines the make-up of the case of 24 beers:

- Case of 24 bottles of beer: 1 unit,
- Bottle of beer: 24 units,
- Empty case of beer: 1 unit.

Each of these three products has a different price. The products Bottle of beer and Empty case of beer have a stock level that needs to be managed. The Case of 24 bottles of beer has no stock because, if you sell the product, OpenERP automatically moves the stock in two lines, one for the empty case and the other for the 24 individual bottles of beer. For more information on bills of material for sale, see chapter Manufacturing.

### 22.3 Alerts

To manage alerts on products or partners, you can install the warning module. Once that is installed, you will be able to configure a series of alerts on the partners or products by setting parameters in the new Warnings tab on each of the forms.

You can select any of the following types of warnings and create different warnings for purchase and for sales:

- **No Message**: This option will not display a message.
- **Warning**: This option will show the user the message entered.
- **Blocking Message**: The message displayed will cause an exception and block the workflow.

You can activate alerts for a series of events. For each alert, you should enter a message that will be displayed when the event concerned is started.
The available warnings in the partner form are:

- Create a warning for a sales order,
- Create a warning for a purchase order,
- Create a warning for a delivery to a partner (or receiving an item),
- Create a warning when invoicing a partner.

For example, if you enter an alert for the invoicing of a customer, for an accountant entering an invoice for that customer, the alert message will be attached as shown in the figure Alert from invoicing a customer.
The alerts that can be configured on a product form are related to:

- The sales of that product,
- The purchase of that product.

### 22.4 Control Deliveries and Invoicing

#### 22.4.1 Order Configuration

Depending on the configuration of the order, several different possible consequences can follow. Three fields determine the future behaviour of an order:

- **Picking Policy**: Partial Delivery or Complete Delivery,
- **Shipping Policy**: Shipping & Manual Invoice, Payment Before Delivery, Invoice on Order After Delivery, and Invoice from Delivery,
- **Invoice on**: Ordered Quantities or Shipped Quantities.

**Tip: Configuring your interface**

If you work in the Simplified view mode, only the Shipping Policy field is visible in the second tab on the order. To get to the Extended view mode, use the Reconfigure wizard and configure your interface as Extended, or assign the group Usability – Extended View to the current user. You can also alternate between these modes through the EDIT PREFERENCES link and selecting the interface of your choice.

#### 22.4.2 Picking Mode

The picking mode determines the way that the storesperson will do the picking. If the order is put into Partial Delivery mode, the picking order will appear in the list of things for the storesperson to do as soon as any of the products on the order is available. To get the list of items to be done, you can use the menu Warehouse → Outgoing Deliveries. By default, the Available filter button is selected, hence this is the list of available pickings.

The storesperson will then be able to make a partial delivery of the quantities actually available and do a second picking operation later when the remaining products are available in stock.

If the picking mode is Complete Delivery, the picking order will not appear in the list of pickings to do until all of the products are available in stock. This way there will only be a single delivery for any given order.

If the storesperson wants, the delivery mode can be modified on each picking list even after the order has been confirmed.
In the case of invoicing on the basis of picking, the cost of delivering the products will be calculated on the basis of multiple deliveries. This risks incurring a higher cost because of each delivery. If invoicing is on the basis of the orders, the customer will only be invoiced once for the whole delivery, even if the delivery of several items has already been made.

22.5 Management of Carriers

To manage deliveries in OpenERP, install the delivery module. To do that, use the Reconfigure wizard and select Delivery Costs under the Sales Application Configuration section for installation.

This module enables you to manage:

- the different carriers with whom you work,
- the different transport methods,
- cost calculation and invoicing of each delivery,
- the transport methods and their tariffs.

Once the delivery module has been installed, the first thing to do is to configure the different modes of delivery accepted by your company. To do that, use the menu Warehouse → Configuration → Delivery → Delivery Method.

For each delivery mode, you should define the following elements:

- Name of the delivery mode,
- The partner associated with the transport (which can be your own company),
- The associated product.

Let’s give you an example:

<table>
<thead>
<tr>
<th>Carrier</th>
<th>Carrier Partner</th>
<th>Delivery Product</th>
</tr>
</thead>
<tbody>
<tr>
<td>Express Track</td>
<td>Mail Office</td>
<td>Express Track Delivery</td>
</tr>
<tr>
<td>Priority Courier</td>
<td>Mail Office</td>
<td>Courier Express Delivery</td>
</tr>
<tr>
<td>EFG Standard</td>
<td>EFG Inc</td>
<td>Delivery EFG</td>
</tr>
<tr>
<td>EFG Express</td>
<td>EFG Inc</td>
<td>Delivery EFG Express</td>
</tr>
</tbody>
</table>

Information about the invoicing of transport (such as accounts, applicable taxes) is entered in the product linked to the delivery mode. Ideally the product should be configured as Product Type Service and Procurement Method Make to Stock.

You can use the same product for several delivery modes. This simplifies the configuration, but it has the disadvantage that you will not be able to separate your sales figures by delivery mode.

22.5.1 Tariff Grids

Unlike ordinary products, delivery prices are not proposed through pricelists but through delivery grids, designed specifically for this purpose. For each delivery mode, you enter one or several tariff grids. Each grid is used for a given region/destination.

For example, for the postal tariffs for Priority Courier, you generally define the three tariff grids for Mail Office:

- Courier National,
- Courier Europe,
- Courier Outside Europe.
To define a new delivery grid, use the menu Warehouse → Configuration → Delivery → Delivery Pricelist. Give a name to your delivery grid and define the region for which the tariffs in the grid will apply in the second tab Destination. There you can set:

- A list of countries (for UK or Europe, for example),
- A list of states,
- A range of postal codes (for Paris you might have 75000 – 75900).

You must then set the rules for calculating the transport price in the first tab Grid definition. A rule must first of all have a name. Then set the condition for which this rule is applicable, for example Weight < 0.5kg.

**Note:** Weights
Weights are expressed in kilograms. You can define a number with a decimal point or comma, so to set 500g you would put 0.5 in the weight rule.

Next you can set the sale price and the cost price. Prices can be expressed in various ways:

- a fixed price,
- a variable price, as a function of weight, volume, weight x volume or price.

For example, mailing within France using current tariffs would be defined as shown in the table below:

<table>
<thead>
<tr>
<th>Name</th>
<th>Condition</th>
<th>Price</th>
<th>Price Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>S</td>
<td>Weight &lt; 3 kg</td>
<td>6.90</td>
<td>Fixed</td>
</tr>
<tr>
<td>M</td>
<td>Weight &lt; 5 kg</td>
<td>7.82</td>
<td>Fixed</td>
</tr>
<tr>
<td>L</td>
<td>Weight &lt; 6 kg</td>
<td>8.53</td>
<td>Fixed</td>
</tr>
<tr>
<td>XL</td>
<td>Weight &lt; 7 kg</td>
<td>9.87</td>
<td>Fixed</td>
</tr>
</tbody>
</table>

You can also define rules that depend on the total amount on the order. For example to offer fixed price delivery if the total order amount is greater than 150 USD, add the following rule:

<table>
<thead>
<tr>
<th>Name</th>
<th>Condition</th>
<th>Price</th>
<th>Price Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Franked &gt; 150 USD</td>
<td>Price &gt; 150 USD</td>
<td>10</td>
<td>Fixed</td>
</tr>
</tbody>
</table>

### 22.5.2 Delivery Modes

Once the delivery modes and their corresponding tariffs have been defined, you can use them in a Sales Order. There are two methods for doing that in OpenERP:

- Delivery based on Ordered Quantities,
- Delivery based on Shipped Quantities.

### 22.5.3 Delivery based on Ordered Quantities

To add the delivery charges to the quotation, use the button Delivery Costs available on the Sales Order tab of the form. A dialog box opens, asking you to select a delivery mode from one of the preconfigured available ones.
Once the delivery mode has been selected, OpenERP automatically adds a line to the draft order with the amount calculated by the delivery function. This technique enables you to calculate the delivery charge based on the order and then, separately, how the products will really be delivered to the customer.

If you want to calculate the exact delivery charges depending on the actual deliveries, you must use invoicing based on deliveries.

### 22.5.4 Delivery based on Shipped Quantities

To invoice the delivery according to the items shipped, you set the delivery mode in the *Delivery Method* field on the second tab of the order, *Other Information*. Do not add delivery lines to the Sales Order but to the Invoices after they have been generated for the delivered items.

For this to work properly, your order must be set to the state *Invoice from Delivery*. You can then confirm the order and validate the delivery.

When the manager has generated the invoices corresponding to the deliveries carried out, OpenERP automatically adds a line on each invoice corresponding to the delivery charge, calculated on the basis of the items actually sent.

### 22.6 Keep Track of your Margins

It is important to keep good control of margins in every company. Even if you have a good level of sales, it will not guarantee company profitability if margins are not high enough. OpenERP provides a number of systems for monitoring margins. The main ones are:

- Margins on a sales order,
- Margins by product,
- Margins by project,
- Using pricelists.

#### 22.6.1 Margins on Sales Orders

If you want to check your margins on sales orders, you can install the *sale_margin* module by selecting *Margins in Sales Orders* for installation in the *Reconfigure* wizard. This will add margins calculated on each order line and on the order total.
The margin on each line is defined as the quantity sold multiplied by the sale price for the customer less the cost price of the products. By default, products are managed using standard price in OpenERP (cost price fixed manually and reviewed once per year). You can change that to *Average Price*, meaning that the product cost fluctuates with purchases from suppliers. After product receipt you can add fixed costs, such as delivery costs, in the cost of each product. OpenERP supports a third method of updating the cost price of products. This is through the button *Update* on the product form which lets you automatically recalculate the cost price for the selected product. The cost price is calculated from the raw materials and the operations carried out (if the products have been manufactured internally, so that you have set their costs).

### 22.6.2 Margins by Product

To track margins by product, install the module *product_margin*. Once the module is installed you can see the margins by product by using the menu *Sales* → *Products* → *Product Margins*.

When you have clicked on the menu, OpenERP asks for an analysis period and the state of invoices. If no period is given, OpenERP will calculate margins on all of the operations without restriction. By default, however, OpenERP proposes a period of the last 12 months for analysis.

You can also filter the analysis on certain types of invoice:

- All invoices, including draft invoices not yet validated,
- All open and/or paid invoices,
- Paid invoices only.

You then get a margin analysis table. The following fields are given by product for sales:

- *Avg. Unit Price*: the average unit sale price,
- *Catalog Price*: the list price based on this product,
- *# Invoiced*: the number of sold products that have been invoiced,
- *Sales Gap*: the difference between the revenue calculated from list price and volume, and the actual sales,
- *Turnover*: the actual sales revenue for the product selected,
- *Expected Sale*: the number of products sold multiplied by the list price.
The following fields are given by product for purchases:

- **Avg. Unit price**: the average unit purchase price,
- **Standard price**: the standard cost price of the product for the company,
- **# Invoiced**: the number of purchased products,
- **Purchase gap**: the difference between the total actual cost and the standard cost multiplied by the number of units purchased,
- **Total cost**: the total cost of purchases for the product under consideration,
- **Normal cost**: the number of products sold multiplied by the standard cost price.

The following fields are given by product for margins:

- **Total Margin**,
- **Expected Margin**,
- **Total Margin in percent**,
- **Expected Margin in percent**.

### 22.6.3 Margins by Project

To manage margins by project, you must install the analytical accounts with management by task. Use of these accounts is described in *Analytic Accounts*. Install the module `account_analytic_analysis` and all of its dependencies. This module adds a tab on the analytic account form to handle the different margins in an analytic account representing a project or a case, and several new reports on those accounts.
Start by opening a project’s analytic account through Project → Billing → Overpassed Accounts and selecting one of them. In the form’s Analysis summary tab you will find the following information:

- The total costs for the analytic account,
- The total amount of invoiced sales,
- The number of hours worked,
- The number of hours remaining to be worked,
- The remaining income,
- The theoretical income (hours worked multiplied by their sale price),
- The number of hours invoiced,
- The real income per hour,
- The real margin,
- The theoretical margin taking into account everything yet to be invoiced,
- The real margin rate in percent,
- The last invoicing date,
- The last worked hours,
- The number of hours remaining to be invoiced,
- The amount remaining to be invoiced.

For detailed information on the analytic account you can use any of the several reports available in the toolbar to the right.

### 22.7 Pricing Policies

Some companies are notorious for their complicated pricelists. Many forms of price variation are used, such as end-of-year refunds, discounts, change of terms and conditions with time, various prepayments, cascaded
rebates, seasonal promotions, and progressive price reductions.

**Note:** Rebate, Refund, Reduction

In some accounting jurisdictions you have to differentiate between the three following terms:

- **Rebate:** reimbursement to the client, usually at the end of the year, that depends on the quantity of goods purchased over a period.
- **Refund:** reduction on the order line or invoice line if a certain quantity of goods is purchased at one time or is sold in a framework of a promotional activity.
- **Reduction:** a one-off reduction resulting from a quality defect or a variation in a product’s conformance to a specification.

Intelligent price management is difficult, because it requires you to integrate several conditions from clients and suppliers to create estimates quickly or to invoice automatically. But if you have an efficient price management mechanism you can often keep margins raised and respond quickly to changes in market conditions. A good price management system gives you scope for varying any and all of the relevant factors when you are negotiating a contract.

To help you work most effectively, OpenERP’s pricelist principles are extremely powerful yet are based on simple and generic rules. You can develop both sales pricelists and purchase pricelists for products capable of accommodating conditions such as the date period, the quantity requested and the type of product.

**Tip:** Do not confuse the different price specifications

Do not confuse the sale price with the base price of the product. In OpenERP’s basic configuration, the sale price is the list price set on the product form but a customer can be given a different sale price depending on the conditions.

It is the same for purchase price and standard cost. Purchase price is your suppliers’ selling price, which changes in response to different criteria such as quantities, dates, and supplier. This is automatically set by the accounting system. You will find that the two prices have been set by default to the same for all products with the demonstration data, which can be a source of confusion. You are free to set the standard cost to something different.

Each pricelist is calculated from defined policies, so you will have as many sales pricelists as active sales policies in the company. For example a company that sells products through three sales channels could create the following price lists:

1. Main distribution:
   - pricelist for Walbury,
   - pricelist for TesMart,
2. Postal Sales.
3. Walk-in customers.

A single pricelist can exist in several versions, only one of which is permitted to be active at a given time. These versions let you set different prices at different points in time. So the pricelist for walk-in customers could have five different versions, for example: Autumn, Summer, Summer Sales, Winter, Spring. Direct customers will see prices that change with the seasons.

Each pricelist is expressed in a single currency. If your company sells products in several currencies you will have to create as many pricelists as you have currencies.

The prices on a pricelist can depend on another list, which means that you do not have to repeat the definition of all conditions for each product. So a pricelist in USD can be based on a pricelist in EUR. If the currency conversion rates between EUR and USD change, or the EUR prices change, the USD rates can be **automatically** adjusted.

### 22.7.1 Creating Price Lists

To define a pricelist use the menu `Sales → Configuration → Pricelists → Pricelists`.

For each list you should define:
• a Name for the list,
• a Type of list: Sale for customers or Purchase for suppliers,
• the Currency in which the prices are expressed.

**Price List Versions**

Once the list is defined you must provide it with at least one version. To do that use the menu Sales → Configuration → Pricelists → Pricelist Versions. The version contains all of the rules that enable you to calculate a price for a product and a given quantity.

So set the Name of this associated version. If the list only has a single version you can use the same name for the pricelist and the version. In the Price List field select the pricelist you created.

Then set the Start Date and End Date of this version. The fields are both optional: if you do not set any dates the version will be permanently active. Only one version may be active at any one point, so bear this in mind when creating them. Use the Active field in the versions to activate or disable a pricelist version.

**Note:** Automatically updating the sale pricelist
You can make any sale pricelist depend on one of the other pricelists. So you could make your sale pricelist depend on your supplier’s purchase pricelist, to which you add a margin. The prices are automatically calculated as a function of the purchase price and need no further manual adjustment.

**Calculation Rules**

A pricelist version is made up of a set of rules that apply to the product base prices.

![Figure 22.16: Detail of a rule in a pricelist version](image)

You define the conditions for a rule in the first part of the definition screen labelled Rules Test Match. The rule applies to the Product or Product Template and/or the named Product Category. If a rule is applied to a category then it is automatically applied to all of its subcategories too (using the tree structure for product categories).

If you set a minimum quantity in Min. Quantity, the rule will only apply to a quantity the same as or larger than that set. This lets you set reduced rates in steps that depend on the quantities ordered.

Several rules can be applied to an order. OpenERP evaluates these rules in sequence to select which to apply to the specified price calculation. If several rules are valid, only the first in sequence is used for the calculation. The Sequence field determines the order, starting with the lowest number and working up.

Once a rule has been selected, the system has to determine how to calculate the price from the rule. This operation is based on the criteria set out in the lower part of the form, labelled Price Computation.

The first field you have to complete is labelled Based on. Set the mode for partner price calculation, choosing between:

• the Public Price set in the product file,
• the Cost Price set in the product file,
• an Other Pricelist given in the field If Other Pricelist,
• the price that varies as a function of a supplier defined in the Partner section of the product form.

Several other criteria can be considered and added to the list, as you will see in the following section.

Next, various operations can be applied to the base price to calculate the sales or purchase price for the partner at the specified quantities. To calculate it you apply the formula shown on the form: \[ \text{Price} = \text{Base Price} \times (1 + \text{Field1}) + \text{Field2}. \]

The first field, Field1, defines a discount. Set it to 0.20 for a discount of 20% from the base price. If your price is based on standard cost, you can set -0.15 to get a 15% price uplift compared with the standard costs.

Field2 sets a fixed supplement to the price, expressed in the currency of the pricelist. This amount is just added (or subtracted, if negative) to the amount calculated with the Field1 discount.

Then you can specify a rounding method. The rounding calculation is carried out to the nearest number. For example if you set 0.05 in this example, a price of 45.66 will be rounded to 45.65, and 14,567 rounded to 100 will give a price of 14,600.

\[ \text{Note: Swiss special situation} \]

In Switzerland, the smallest monetary unit is 5 cents. There are not any 1 or 2 cent coins. So you set OpenERP’s rounding to 0.05 to round everything in a Swiss franc pricelist.

The supplement from Field2 is applied before the rounding calculation, which enables some interesting effects. For example, if you want all your prices to end in 9.99, set your rounding to 10 and your supplement to -0.01 in Field2.

Minimum and Maximum margins enable you to guarantee a given margin over the base price. A margin of 10 USD enables you to stop the discount from returning less than that margin. If you put 0 into this field, no effect is taken into account.

Once the pricelist is defined, you can assign it to a partner. To do this, find a Partner and select its Sales & Purchases tab. You can then change the Purchase Pricelist and the Sale Pricelist that is loaded by default for the partner.

### 22.7.2 Example

Take the case of an IT systems trading company, for which the following product categories have been configured:

All products

1. Accessories
   • Printers
   • Scanners
   • Keyboards and Mice

2. Computers
   • Portables
   • Large-screen portables
   • Computers
   • Office Computers
   • Professional Computers

In addition, the products presented in the table below are defined in the currency of the installed chart of accounts.

TABLE
Table 22.4: Examples of products with their different prices

<table>
<thead>
<tr>
<th>Product</th>
<th>Sale Price</th>
<th>Cost Price</th>
<th>Default supplier price</th>
</tr>
</thead>
<tbody>
<tr>
<td>Acclo Portable</td>
<td>1,200</td>
<td>887</td>
<td>893</td>
</tr>
<tr>
<td>Toshibai Portable</td>
<td>1,340</td>
<td>920</td>
<td>920</td>
</tr>
<tr>
<td>Berrel Keyboard</td>
<td>100</td>
<td>50</td>
<td>50</td>
</tr>
<tr>
<td>Office Computer</td>
<td>1,400</td>
<td>1,000</td>
<td>1,000</td>
</tr>
</tbody>
</table>

**Default Price Lists**

When you install the software two pricelists are created by default: one for sales and one for purchases. These each contain only one pricelist version and only one line in that version.

The price for sales defined in the Default Public Pricelist is set by default to the Public Price of the product in the product file, which is the Sale Price in the Product file.

The price for purchases defined in the Default Purchase Pricelist is set by default in the same way to the Cost Price of the product in the product file.

**Trading Company**

Take the case of a trading company, where the sale price for resellers can be defined like this:

- For portable computers, the sale price is calculated from the list price of the supplier Acclo, with a supplement of 23% on the cost of purchase.
- For all other products the sale price is given by the standard cost in the product file, on which 31% is added. The price must end in .99.
- The sale price of Berrel keyboards is fixed at 60 for a minimum quantity of 5 keyboards purchased. Otherwise it uses the rule above.
- Assume that the Acclo pricelist is defined in OpenERP. The pricelist for resellers and the pricelist version then contains three lines:

  1. **Acclo line:**
     - **Product Category**: Portables,
     - **Based on**: Other pricelist,
     - **Pricelist if other**: Acclo pricelist,
     - **Field1**: -0.23,
     - **Priority**: 1.
2. Berrel Keyboard line:
   - **Product Template**: Berrel Keyboard,
   - **Min. Quantity**: 5,
   - **Field1**: 1.0,
   - **Field2**: 60,
   - **Priority**: 2.

3. Other products line:
   - **Based on**: Standard Price,
   - **Field1**: -0.31,
   - **Field2**: -0.01,
   - **Rounding**: 1.0.
   - **Priority**: 3.

It is important that the priority of the second rule is set below the priority of the third in this example. If it were the other way round the third rule would always be applied because a quantity of 5 is always greater than a quantity of 1 for all products.

Also note that to fix a price of 60 for the 5 Berrel Keyboards, the formula \( \text{Price} = \text{Base Price} \times (1 + 1.0) + 60 \) has been used.

### Establishing Customer Contract Conditions

The trading company can now set specific conditions to a customer, such as the company TinAtwo, who might have signed a valid contract with the following conditions:

- For Toshiba portables, TinAtwo benefits from a discount of 5% of resale price.
- For all other products, the resale conditions are unchanged.

The sale price for TinAtwo, called **TinAtwo contract**, contains two rules:

1. Toshiba portable:
   - **Product**: Toshiba Portable,
   - **Based on**: Other pricelist,
   - **Pricelist if other**: Reseller pricelist,
   - **Field1**: 0.05,
   - **Priority**: 1.

2. Other Products:
   - **Product**:
   - **Based on**: Other pricelist,
   - **Pricelist if other**: Reseller pricelist,
   - **Priority**: 2.

Once this list has been entered you should look for the partner form for TinAtwo again. Click the **Sales & Purchases** tab to set the **Sale Pricelist** field to **TinAtwo Contract**. If the contract is only valid for one year, do not forget to set the **Start Date** and **End Date** fields in the **Pricelist Version**.

Then when salespeople prepare an estimate for TinAtwo the prices proposed will automatically be calculated from the contract conditions.
22.7.3 Pricelists and Managing Currencies

If your trading company wants to start a product catalog in a new currency you can handle this several ways:

- Enter the prices in a new independent pricelist and maintain the lists in the two currencies separately,
- Create a field in the product form for this new currency and make the new pricelist depend on this field: prices are then maintained separately but in the product file,
- Create a new pricelist for the second currency and make it depend on another pricelist or on the product price: the conversion between the currencies will then be done automatically at the prevailing currency conversion rate.

22.8 Rebates at the End of a Campaign

If you want to provide discounts on an order, use the pricelist system in OpenERP. But it is better to work with end-of-campaign rebates or year-end rebates. In this case, the customer pays a certain price for the whole of the campaign or the year and a rebate is returned to him at the end of the campaign that depends on the sales he has made throughout the year.

Take the case of a contract negotiations with a wholesaler. To get the best selling price, the wholesaler will ask you for a good deal and will sign up to a certain volume of orders over the year.

You can then propose a price based on the volume that the wholesaler agrees to sell. But then you do not have any control over his orders. If at the end of the year the wholesaler has not taken the agreed volumes then you can do nothing. At most you can review his terms for the following year.

Rebates at the end of a campaign can help you avoid this sort of problem. You can propose a contract where the price is dependent on the usual wholesaler’s terms. You can propose a rebate grid which will be assigned at the end of the year as a function of the actual sales made. Install the discount_campaign module (in extra-addons at the time of writing) to generate rebates at the end of the campaign. Once the modules have been installed you can configure your campaign using the menu Sales → Configuration → Sales → Discount Campaigns.

Note: Year-end rebate

Most companies use the term year-end rebate, where rebates are applied at the end of the year. But if you are using rebates at the end of a campaign, this would only actually be the case if the campaign lasts exactly one year.

A campaign must have a name, a refund journal, a start date, and an end date. After entering this information, you should describe the lines of the campaign. Each line can be applied to a product or a category of products. Then set the quantity of products sold from which the discount is applied, and the amount of the rebate as a percentage of the actual sales volume.
When you have defined the campaign, you can activate it by clicking the Open button. The figure Configuring a discount campaign for computers shows a campaign with a rebate on computers which is between 10% and 20% depending on the sales volume.

![Discount Campaigns Screenshot](image)

Figure 22.19: Configuring a discount campaign for computers

Once the campaign has been defined and activated, you can assign it to various partners. To do that set a Discount Campaign in the second tab Sales & Purchases of the partner form.

Finally, at the end of the campaign, you should close it and OpenERP will automatically generate invoices or credit notes for your partner associated with this campaign. OpenERP opens credit notes in the Draft state that you can modify before validating them. To calculate the amount on the credit note, OpenERP uses all of the invoices sent out during the period of the campaign as its basis.

You can also reach all of the draft credit notes using the menu Accounting → Customers → Customer Refunds.

### 22.9 Open Orders

In some industries, customers commonly place orders for a certain volume of products and ask for regular deliveries from an order up to the total amount on it. This principle, called open orders, is managed by the sale_delivery module in OpenERP.

OpenERP handles open orders easily. An open order is an order for a certain quantity of products but whose deliveries are planned for various dates over a period of time.

To do that, you must install the sale_delivery module (in extra-addons at the time of writing). A Sales Order is entered as a normal order but you also set the total quantity that will be delivered on each order line.

Then you can use the new tab Deliveries on the order to plan the quantities sold and enter your delivery planning there.
In the order lines, OpenERP shows you the quantity planned in addition to the quantity sold so you can verify that the quantities sold equal the quantities to be delivered. When you confirm the order, OpenERP no longer generates a single delivery order but plans scheduled despatches.

**Tip: Invoicing Mode**

*If you work with Open Orders, you should set Invoice Control to the mode Shipped Quantities. Then the stores-person will be able to re-plan and change the quantities of the forecast deliveries in the system.*

### 22.10 Layout Templates

Install the `sale_layout` module by selecting *Sales Order Layout Improvement* and clicking *Configure* in the *Reconfigure* wizard. It enables you to have a more elaborate template than the standard order forms.

For example, you could put the following in the order lines:

- a horizontal separator line,
- titles and subtitles,
- subtotals at the end of the section,
- comments,
- a page break.

This enables you to lay out a more elaborate, professional-looking quotation page. The module `account_invoice_layout` (installed automatically on installation of `sale_layout`), also gives you the same functionality for invoice templates.

The two figures *Invoice line using improved layout* and *Printed invoice* show an invoice template in OpenERP and the resulting printed invoice.
Figure 22.21: Invoice line using improved layout

<table>
<thead>
<tr>
<th>Description / Taxes</th>
<th>Quantity</th>
<th>Unit Price</th>
<th>Disc. (%)</th>
<th>Price</th>
</tr>
</thead>
<tbody>
<tr>
<td>(PC) Basic PC (1)</td>
<td>1.00 PCE</td>
<td>450.00</td>
<td>0.00</td>
<td>450.00 €</td>
</tr>
<tr>
<td>(KEY) Keyboard - AZERTY (1)</td>
<td>1.00 PCE</td>
<td>7.00</td>
<td>0.00</td>
<td>7.00 €</td>
</tr>
<tr>
<td>(MOD) Mouse (1)</td>
<td>1.00 PCE</td>
<td>7.00</td>
<td>0.00</td>
<td>7.00 €</td>
</tr>
<tr>
<td>Services</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Online intervention (1)</td>
<td>1.00 PCE</td>
<td>30.75</td>
<td>0.00</td>
<td>30.75 €</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Document</th>
<th>Invoice Date</th>
<th>Partner Ref.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Draft Invoice</td>
<td>12/10/2010</td>
<td></td>
</tr>
</tbody>
</table>

Net Total: 494.75 €

Figure 22.22: Printed invoice
CHAPTER TWENTYTHREE

DRIVING YOUR PURCHASES

In the preceding chapters you saw how to use customer invoices and delivery notes in OpenERP. This chapter is about the management of purchases, the process ahead of these two operations. You will now see how OpenERP handles and simplifies this and the control of purchases from suppliers.

For this chapter you should start with a fresh database that includes demonstration data, with purchase and its dependencies installed and no particular chart of accounts configured.

23.1 All the Elements of a Complete Workflow

The supplier order is the document that lets you manage price negotiations, control supplier invoices, handle goods receipts and synchronize all of these documents.

Start by looking at the following order workflow:

1. Price request to the supplier,
2. Confirmation of purchase,
3. Receipt and control of products,
4. Control of invoicing.

23.1.1 Setting up your Database

To set up a system for these examples, create a new database with demonstration data in it, and select the Extended interface when you log in as the admin user. You can enter your own company details when asked, or just use the default if you want. Then, using the Configuration Wizard, select Purchase Management in the Install Applications section to install the purchase module, which also installs several other modules as dependencies. Continue the remainder of this chapter logged in as the admin user.

23.1.2 Price Request from the Supplier

To enter data for a new supplier price request, use the menu Purchases → Purchase Management → Request for Quotation. On clicking New, OpenERP opens a blank request for quotation form that you use for requesting prices from a supplier. This is shown in the figure Data entry for a supplier order. If the price request came from an automatic procurement created by OpenERP, you will find a reference to the document that generated the request in the Origin field.
Managing Alerts

If you install the warning module, you will be able to define alerts that appear when the purchaser enters a price request or order. You can set alerts on the product and on the supplier.

The internal reference, the date, and the warehouse that the products should be delivered to are completed automatically by OpenERP but you can change these values if you need. Next, when you select a supplier, OpenERP automatically completes the contact address for the supplier. The pricelist is also automatically completed. This should bring in all of the conditions that you have negotiated with the supplier for a given period.

Tip: Supplier Selection

Searching for a supplier is limited to all of the partners in the system that have the Supplier checkbox checked. If you do not find your supplier, it might be worth checking the whole list of all partners to make sure that the supplier has not been partially entered into the system.

Once the main body of the purchase order has been completed, you can enter the product lines.

When you have selected the product, OpenERP automatically completes the other fields on the form:

- Product UoM, taken from the Purchase Unit of Measure field on the product form,
• The Description of the product in the supplier’s language,
• Scheduled Date, calculated from the order date and the lead time
• Unit Price, provided by the supplier pricelist,
• Taxes, taken from the information on the product form and partner form, depending on the rules seen in Financial Analysis.

Tip: Product wording and code
When you enter supplier names on the product form, you can set a name and a product code for each individual supplier. If you do that, OpenERP will then use those details in place of your own internal product names for that selected supplier.

If you work with management by case, you can also set the analytic account that should be used to report all the purchase costs. The costs will then be reported at the receipt of the supplier invoice.

Tip: Management by Case
Analytic accounts can be very useful for all companies that manage costs by case, by site, by project or by folder. To work with several analytic axes, you should install the module purchase_analytic_plans, by selecting Purchase Analytic Plans in the Reconfigure wizard and clicking Configure.

So that the analytic account is automatically selected as a function of the partner, the date, the products or the user, you can install the module account_analytic_default (which is installed automatically as a dependency of purchase_analytic_plans, since the latter depends on it).

In the Notes tab of the product line, you can enter a note that will be attached when the order confirmation or price quotation is printed. This note can be predefined on the product form to automatically appear on each order for that product. For example, you can enter “Do not forget to send by express delivery as specified in our contract reference 1234.”

Once the document has been completed, you can print it as a price estimate to send to the supplier. You can set a note for the attention of the supplier in the form’s third tab.
Then leave the document in the Request for Quotation state. When you receive a response from the supplier, use the menu Purchases → Purchase Management → Requests for Quotation. Select the order and complete its details.

When you want to approve the order, use the button Convert to Purchase Order. The price request then passes into the Approved state. No further changes are possible.
23.1.3 Goods Receipt

Once the order has been approved, OpenERP automatically prepares the goods receipt order in the draft state for you. To get a list of the products you are waiting for from your suppliers, use the menu Warehouse → Warehouse Management → Incoming Shipments.

**Tip: Purchasing Services**
*If you buy services from your supplier, OpenERP does not generate a goods receipt note. There is no service receipt equivalent to a goods receipt.*

Select the document that corresponds to the item that you are receiving. Usually, the goods receipt note is found by making a search on the order reference or the supplier name. You can then confirm the receipt of the products.

As you saw in Your Warehouse, if you receive only part of the order, OpenERP manages the remainder of that order. A second receipt note is then automatically created for the goods not received. You can cancel it if you think that you will never receive the remaining products.

After receiving the goods, OpenERP will show you which orders are open and the state of their receipt and invoicing if you return to the list of orders.
23.1.4 Control of Invoicing

To control supplier invoicing, OpenERP provides three systems as standard, which can differ order by order:

- **From Order**: invoicing based on quantities ordered,
- **From Picking**: invoicing based on quantities received,
- **Manual**: manual invoicing.

The mode of invoicing control is set in the second tab of the purchase order in the field *Invoicing Control*.

![Purchase Orders](image)

**Figure 23.6: Supplier order, invoice control**

**Tip**: Default Value

A company generally uses a single invoicing control method for all of its invoices. So you are advised to set a default value in the Invoicing Control field after installation.

23.1.5 Control based on Orders

If you selected your invoicing control based on orders, OpenERP will automatically generate a supplier invoice in the draft state when the order is confirmed. You can obtain a list of invoices waiting using the menu *Accounting → Suppliers → Supplier Invoices* and enabling the Draft filter.

When you receive a paper invoice from your supplier, all you need to do is validate the invoice pre-generated by the system. Do not forget to check the price and the quantities. When the invoice is confirmed, the accounting entries represent the cost of purchase and are automatically entered into the system.

The supplier order is then automatically set as *Paid* when you pay the supplier invoice.

This method of controlling invoices is often used in service companies, because the invoiced amounts correspond to the ordered amounts. In logistics, by contrast, you most often work with invoicing controlled by goods receipt.

23.1.6 Control based on Goods Receipt

To control your supplier invoices based on goods receipt, set the field *Invoicing Control* on the second tab of the order to *From Picking*.

In this case, no invoice, draft state or any other, is generated by the order. On the goods receipt note, the field *Invoice Control* is set to *To Be Invoiced*. 
The storesperson can then receive different orders. If he wants to generate the draft invoice for a goods receipt, he can click the action *Create Invoice*. *OpenERP* then asks you for the journal for this invoice. It then opens that or the generated invoices (in the case of creating invoices for several receipts at one time) which enables you to modify it before confirming it.

This approach is useful when you receive the invoice at the same time as the item from the supplier. Usually, invoices are sent by post some days later. In this case, the storesperson leaves the item unchanged without generating an invoice. Then, once per day or once per week the accountant will create the draft invoices based on all the receipts for the day. To do that, he uses the menu *Purchases* → *Invoice Control* → *Purchase Lines Not Invoiced*. He clicks on the action *Create invoices* to generate all draft invoices from the list of receipts that have not yet been invoiced. At that point, the accountant can decide if he wants to generate an invoice per item or group all items for the same partner into the same invoice.

Invoices are then handled just like those controlled from *On Order*. Once the invoice arrives at the accounting service, he just compares it with the invoices waiting to control what the supplier invoices you.

---

**Tip: Delivery Charges**

*To manage delivery charges, install the module* `delivery` *using the Reconfigure wizard and selecting Delivery Costs in Sales Application Configuration section. This will automatically add delivery charges to the creation of the draft invoice as a function of the products delivered or ordered.*

---

### 23.1.7 Tenders

To manage tenders, you should use the module `purchase_requisition`, installed via the *Purchase Requisition* option in the *Reconfigure* wizard. This lets you create several supplier price requests for a single supply requirement. Once the module is installed, *OpenERP* adds a new *Purchase Requisitions* menu in *Purchases* → *Purchase Management*. You can then define the new tenders.

![Figure 23.7: Defining a tender](image)

To enter data for a new tender, use the menu *Purchases* → *Purchase Management* → *Purchase Requisitions* and select *New*. *OpenERP* then opens a new blank tender form. The reference number is set by default and you can enter information about your tender in the other fields.

If you want to enter a supplier’s response to your tender request, add a new draft purchase order into the list on the *Quotation* tab of your tender document. If you want to revise a supplier price in response to negotiations, edit any appropriate purchase order that you have left in the draft state and link that to the tender.

When one of the orders about a tender is confirmed, all of the other orders are automatically cancelled by *OpenERP*. That enables you to accept just one order for a particular tender.
23.1.8 Price Revisions

OpenERP supports several methods of calculating and automatically updating product costs:

- Standard Price: manually fixed, and
- Standard Price: revalued automatically and periodically,
- Average Price: updated at each receipt to the warehouse.

This cost is used to value your stock and represents your product costs. Included in that cost is everything directly related to the received cost. You could include such elements as:

- supplier price,
- delivery charges,
- manufacturing costs,
- storage charges.

Standard Price

The mode of price management for the product is shown in the tab Information on the product form. On each individual product, you can select if you want to work in Standard Price or on weighted Average Price.

Tip: Simplified Interface

If you work in the Simplified interface mode you will not see the field that lets you manage the price calculation mode for a product. In that case, the default value is Standard Price.

The Standard Price setting means that the product cost is fixed manually for each product in the field Cost Price. This is usually revalued once a year based on the average of purchase costs or manufacturing costs.

You usually use standard costs to manage products where the price hardly changes over the course of the year. For example, the standard cost could be used to manage books, or the cost of bread.

Those costs that can be fixed for the whole year bring certain advantages:

- you can base the sale price on the product cost and then work with margins rather than a fixed price per product,
- accounting is simplified because there is a direct relationship between the value of stock and the number of items received.

To get an automated periodic revaluation of the standard price you can use the action Update on the product form, enabling you to update prices of all the selected products. OpenERP then recalculates the price of the products as a function of the cost of raw materials and the manufacturing operations given in the routing.

Average Price

Working with standard prices does not lend itself well to the management of the cost price of products when the prices change a lot with the state of the market. This is the case for many commodities and energy.

In this case, you would want OpenERP to automatically set the price in response to each goods receipt movement into the warehouse. The deliveries (exit from stock) have no impact on the product price.
Tip: Calculating the price
At each goods receipt, the product price is recalculated using the following accounting formula: \[ NP = \frac{OP \times QS + PP \times QR}{QS + QR} \], where the following notation is used:

- \( NP \): New Price,
- \( OP \): Old Price,
- \( QS \): Quantity actually in Stock,
- \( PP \): Price Paid for the quantity received,
- \( QR \): Quantity Received.

If the products are managed as a weighted average, OpenERP will open a window that lets you specify the price of the product received at each goods receipt. The purchase price is, by default, set from the purchase order, but you can change the price to add the cost of delivery to the various received products, for example.

![Figure 23.8: Goods receipt of products managed in weighted average](image)

Once the receipt has been confirmed, the price is automatically recalculated and entered on the product form.

23.2 Purchase Analysis

23.2.1 Elementary Statistics

OpenERP enables you to perform analysis of purchases by period (current year, current month, previous month), by state (quotations, orders), supplier, user, product, category, warehouse and so on. This is made possible through a search view accessed through the menu **Purchases → Reporting → Purchase Analysis**.

![Figure 23.9: Analysis of purchases over the month by product](image)

This analysis is carried out on supplier orders and not on invoices or the quantities actually received. To get an analysis by product, use the module *product_margin*. The function of this module is described in detail in the chapter *Driving your Sales*.

To analyze the received quantities, you can use the statistical reports in Warehouse.
23.3 Analytic Accounts

To manage purchases by project, you should use analytic accounts. You can set an analytic account on each line of a supplier order. The analytic costs linked to this purchase will be managed by OpenERP from the goods receipt and confirmation of the supplier invoice. The hr_timesheet_invoice module lets you re-invoice the analytic costs automatically using parameters in the analytic accounts such as sale pricelist, associated partner company, and maximum amount.

So you can put an invoice order with a defined invoice workflow in place based on the analytic accounts. If you are working Make to Order, the workflow will be:

1. Customer Order,
2. Procurement Order on supplier,
3. Receive invoice and goods from the supplier,
4. Delivery and invoicing to the customer.

When re-invoicing based on costs you would get the following workflow:

1. Enter the customer contract conditions from the analytic accounts,
2. Purchase raw materials and write the services performed into the timesheets,
3. Receive the supplier invoice and the products,
4. Invoice these costs to the customer.

Tip: Analytic Multi-plans
If you want several analysis plans, you should install the module purchase_analytic_plans. These let you split a line on a supplier purchase order into several accounts and analytic plans. Look back at Analytic Accounts for more information on the use of analytic accounts.
Part VIII

Process and Document Management
CHAPTER TWENTYFOUR

PROCESS

If you have reached this far in the book, your mind may well be reeling with the number of new documents (based on business objects) and processes that you need to encounter to model and manage your business.

OpenERP’s process module, which is installed automatically when a process-aware module is installed, shows you cross-functional processes and technical workflows for those nodes in the process that have them. This visualization is invaluable for documentation - but it also goes a step further. You can modify processes and workflows and even generate entirely new processes and workflows for your various document types.

If your starting point is a specific document, such as an invoice or order, then you will also be shown the exact position of that document on its process and workflow diagrams.

For this chapter you should start with a fresh database that includes demonstration data, with sale and its dependencies installed and no particular chart of accounts configured. process is one of those dependencies. Also install some of the hr modules for the second example in this chapter, such as hr_attendance, hr_contract, and hr_holidays.

24.1 Process Integration in the Management System

Processes are at the heart of a company: they form a structure for all activities that enable the company to function effectively. A company’s human dimension is often disconnected from its processes at the moment, preventing individual employees’ aspirations from being directed towards a collective objective.

From a mapping process, integrating management and the changing needs of each employee becomes very useful for the fulfilment of each. Based on that, each employee becomes aware of his own personal contribution to the company’s value chain. This representation also helps an employee’s own personal management because it shows his place and his role in the overall process, very often over several departments.

The system of ‘Corporate Intelligence’ will also be highly useful to system implementers who, after studying the requirements, have to formalize a company’s processes to put them into operation in OpenERP.

24.1.1 Examples of Process

To understand the aims of the system of Corporate Intelligence (process) better, you will now see an overview of the functions available to you in a the study of two processes:

- A customer order quotation,
- The engagement of a new employee.
Following a customer sales order

The example *Example of a process handling a customer order quotation* shows the process for handling a customer sales order. Use the menu *Sales* → *Sales* → *Sales Orders* to list all orders, then choose Order SO001 – you can either check the checkbox to its left, or you can open the order itself by clicking the row containing the order.

To view the process for that specific order, click the *Corporate Intelligence* button (displayed as a question mark) at the top right of the title of the list or form. The process for this order is shown in the window, and the current state of this document can be seen by looking for the node whose left edge is colored maroon rather than grey.

This order is in the *Quotation* state. The whole of some nodes is greyed out because the selected document will never enter into that state, such as invoicing based on deliveries (the order is in an invoicing mode that is based on orders, not deliveries).

The process is completely dynamic and based on that specific sale order document. You can click each of the process nodes (*Quotation, Sale Order, Procurement, Draft Invoice, Outgoing Products*) using one of the links or icons on it:

- Obtaining the documentation and the corresponding process in the quality manual, using the *Help* (or *Information*) icon,
- Obtaining the documents that an employee needs to carry out the process by clicking the green arrow icon,
- Seeing the menu that OpenERP uses to get the document by hovering over the green arrow icon.

New employee induction

Open the employee form for Fabien Pinckaers from the menu *Human Resources* → *Human Resources* → *Employees*. Click the *Corporate Intelligence* button to open the detailed process of engagement.
You can immediately see things that might interest the HR manager. On a single screen she has all of the documents about the selected employee. She can then zoom into each document to look at associated documents or the user account in the system.

### 24.2 Workflows and User Processes

Workflows are used to define the behaviour of a given document. They are used by developers and system implementers to determine which object should execute which actions and at which moments. These are principally technical processes defined in a vertical way on the lifecycle of a complete object (represented by a document). Changing a workflow will have a direct impact on the behaviour of the software in response to user actions. You handle all possible exceptions there, so that the software is robust.

![Example of a workflow handling a customer order](image-url)
Unlike workflows, user processes represent workflows across all of a company and its documents. They are used by end-users to locate an action for more complete handling. A change of user process will not have any effect on the software but will show the user another way of working on a given problem.

Processes are used by end-users to help them understand the problems which have not been handled in OpenERP. You can find actions that have no influence on the software, such as “Telephone customer to thank him”, and “Send a fax to reassure him”. Along with providing user help, processes provide functions such as:

- integration with OpenERP Help and the company’s quality manual,
- showing the user the menu for finding a specific document.
User processes are thus connected to technical workflows. If you modify the software’s behaviour with a workflow, the changes will be directly visible in the user processes that are based on the modified document. So if you modify certain transitions on a workflow they will automatically be shown in the process corresponding to the modified document.

To get maximum benefit from the power of user processes and the workflow engine, OpenERP provides an integrated workflow editor and user process editor. These enable you to modify them through the client interface.

You will only work with the process editor in this chapter. If you want to view and edit the workflow of a document, click on the link Edit Workflow to the right of the document. OpenERP opens a graphical view of the workflow for the selected document type.

If you want to edit a workflow in a text-based editor, you can use the menus under Administration → Customization → Workflows.

### 24.2.1 Using processes effectively

Regardless of which OpenERP screen you are in you can call up a process on the current document by clicking the Corporate Intelligence (question mark) icon. Depending on the document, you can have several processes defined using it. OpenERP then asks you to choose which one of them you want.

For example, if you are in a meeting form, OpenERP will ask you to choose from the processes it knows about that involve such forms:

- processes for selecting and inducting new employees,
- tracing customer orders in pre-sales,
- processes for visiting customers and handling expenses.
Figure 24.6: Button for entering a user process from a form

The element colored red shows the active process for the selected document. Elements in grey are the states that the selected document will not go through because of its configuration. You can use the different icons to open the document, print it, or get its documentation. Some states have an image inside of arrows formed into a circle. These show that the state refers to another process. To go to this other process, you can click on the title of the state. For example, you can click on the invoice in the customer order management workflow to see in detail how that invoice is handled.

Figure 24.7: A state that refers to another workflow

24.2.2 Defining your own user processes

Use the menus under Administration → Customization → Enterprise Process to define new processes or modify existing processes. When entering a process, OpenERP shows you the list of states available for that process.
You can add a new state or modify an existing state. A state can be associated with an object (whose instances are represented by documents). If that is the case, choose it in the case object. You can set an expression that shows if the object can be found in that state or not. Expressions are in Python format. For example, for the quotation state choose the object `sale.order` and set the following expression `object.state == 'draft'`.

You can also link to a menu so that users can learn which menu to use to access objects in a state. You can set the conditions in which this object is in a greyed-out state in the section `Conditions`. These expressions, too, are encoded in Python format.

Once the node has been defined, you should set the transitions leaving this object. For each transition you can:

- Give the leaving and destination states,
- Set up a list of buttons that start various transitions in the process,
- Map between workflow transitions and the document that is selected,
- Put an explanatory notice in different languages.

The organization and quality of a company is typically related to its maturity. A mature company is one where processes are well established, and where staff do not waste much time searching for documents or trying to find out how to do their different tasks.
From this need for effective organization and explicit quality improvement, have appeared numerous tools:

- The ISO9001 quality standard,
- Business Process Management (BPM) tools,
- Use Case workflows, and formalized standards such as UML,
- The company Quality Manual.

The problem is that these tools are usually quite separate from your management system and often reserved for the use of just a few specific people in your company. They are treated separately rather than put at the heart of your management system. When you ask company staff about ISO9001 they usually see it as a constraint rather than a helpful daily management tool.

To help the company meet its quality requirements and to form these processes into assistance integrated with everyday work, OpenERP supplies a Corporate Intelligence® tool that enables you to put company processes at the heart of your management system.

The system enables:

- new employees to learn how to use the software by graphically and dynamically, discovering how each document and action works,
- easy access to the all the links to a document and everything that is attached to it,
- people to see both a high-level map and the detail of all the company’s processes,
- access to a graphical model and integrated quality manual for rapid access that depends on the work context,
- use of a knowledge base and capitalization of that knowledge for all of the company’s actions in the form of interactive processes,
- an employee to become more aware of his role in the whole environment.
Information management has become a major strategic factor in companies’ development. It is important to get the right information circulated to the right people, as efficiently as possible, yet still keep it secure. Document management provides a way for companies to organize their information, in all its forms, in one place.

The objectives of document management include easier archiving, access and reference, intelligent classification and distribution of documents and the information they contain. It concerns sets of all sorts of company documents such as work procedures, meeting reports, documents received from customers and suppliers, documents sent to customers, faxes, sales presentations and product datasheets.

For this chapter you should start with a fresh database that includes demo data, with sale, document and their dependencies installed and no particular chart of accounts configured.

25.1 The importance of good document management

Globalization means that workplaces are ever more geographically dispersed. This means that documents are also used more than ever by people in several countries and continents for communicating and collaborating.

You will see communication problems even between employees in the same office because they do not have easy access to the documents that they need. You find some documents kept by someone in the accounts office, shared directories that serve everybody, some documents in paper form, others in electronic form – quite a free-for-all.

An explosion in the number of documents that a company needs does not help. If their storage and indexation are badly organized, these documents become useless because they are almost impossible to find.

The results of poor document management can lead to a significant loss of time. Ask yourself how often you find yourself looking for:

- A supplier catalogue that has been sent to a purchasing manager,
- A customer contract signed several months ago,
- The final set of Terms and Conditions offered to a specific customer,
- The documents required for employing a new member of staff,
- An order confirmation sent by a customer to one of your salespeople or, perhaps even more common, when the relevant salesperson has gone on vacation, if you ever received such an order confirmation,
- A procedure from your quality manual if there has been a process fault,
- An email which was sent to one of your colleagues,
- A document that you need to be a template for a specific type of contract,
- A complete history of communications between yourselves and a supplier about a given contract.
Even worse than the loss of time, perhaps, the lack of good document management is bad for the quality of your organization and the service provided by your company. In such a company it is likely that:

- sets of documents do not follow a standard layout,
- all the salespeople prepare quotations in their own way and gradually change the way they do it for themselves but not for the group,
- a correction to a type of contract stays with a small group of people and does not percolate back into the rest of the company to benefit other users,
- version management is chaotic or even non-existent.

So a good integrated document management system can be a powerful tool to help in day-to-day company management. With it you could also easily:

- Continue the work started by a colleague if she has gone on vacation, and respond to her customers if needed,
- Get hold of examples of all document types with just a few clicks, so that you can follow company standards in such areas as order confirmation, price requests, meeting minutes, customer deliverables, contract examples, and models for faxes and letters,
- Retrieve procedures and other associated documents if you do not know how to do a certain task – such as things you should do when hiring a new employee, organizing a conference, or structuring meeting minutes,
- Reuse work done by a colleague to meet similar needs and build on all the individual work done in your own company,
- Find all the orders for a customer or from a supplier in just a few seconds to answer questions or to continue a discussion when the initial contact point in your company is not available,
- Build on your working methods and enable your colleagues to benefit from each improvement in a document type or a procedure.

From these examples you can see the importance of a good document management system, and what it might contribute to the improvement of productivity and the quality of the output from each employee.

### 25.2 Classic document management solutions

Faced with the need to organize documents, companies have looked at a number of document management solutions that are promoted today, from simple email archiving to complete electronic management systems dedicated to arbitrary documents.

Unfortunately, these solutions have not always been very useful because they are too little integrated in companies’ management systems. Most solutions that we have come across, are underused by the employees – often used by some of them but not by all.

The primary reason for this is that a document management system that is not integrated imposes extra work on an employee. For example, a salesperson should ideally save each customer confirmation in the document management system. Only that means quite a heavy additional workload just for an order confirmation:

1. Receive and read the email from the customer,
2. Save the email and its attachments on the desktop,
3. Connect to the ERP system and confirm the order,
4. Connect to the document management system,
5. Look for the best place to store the document,
6. Create a directory for the customer and the order if it does not yet exist,
7. Copy the files from the desktop to the right place in the document management system.
This is obviously a lot of operations just to handle a simple order confirmation. You can understand why many companies hardly use their document management system even if they have gone to the cost and effort of purchasing and installing one.

**Tip:** Free document management systems
A number of free document management applications exist. The most well known are:

- Alfresco: http://www.alfresco.com
- Quotero: http://www.quotero.com

It is very difficult to keep information in the company’s management system synchronized with that in the document management system. For example, when a customer changes his address, users will modify the details in the management software, but usually, not in the document management system.

Furthermore, since users should create the same storage structure in both systems, you quickly find after only a few months that the information in the document management system is quite disconnected from that in the company’s management system, if the two are separate. For example, how do you know where to store your least-frequently used documents such as (perhaps) employee car-leasing documents? Also, document management systems are typically very complex because they must manage user access rights in just the same way as those that are available in the company management system. This means that you have to enter the same sort of data about access rights twice for the system administrators.

You will see that the total integration of OpenERP’s document management system with the main company management system, and plugins to Outlook and Thunderbird email clients, offers an elegant solution that addresses these problems.

### 25.3 The OpenERP Solution

OpenERP’s management of documents is unique and totally innovative in its integrated approach. Its complete integration with the company’s management system solves most of the problems that are encountered when you use independent document management systems:

- Login and the management of access rights is integrated with that of OpenERP for controlling access to different document types,
- Ultra-rapid access to documents, which are directly accessible through your email client or through the company management software,
- Automatic assignment of meta-information comes directly from information contained in your OpenERP login registration,
- Document workflow, which automatically follows OpenERP’s documentation process, provides complete synchronization between the systems,
- Document classification is determined by OpenERP itself so that the structure that is created is always synchronized between the systems,
- Automatic indexation and classification of all documents produced by OpenERP for maximum efficiency.

#### 25.3.1 Getting Started

This section is about how to get started with the document management system from its installation to advanced use with FTP access.

**Installation**

To install OpenERP’s document management system, you just need to install the `document` and `document_ftp` modules through the Reconfigure wizard by selecting Knowledge Management, and further on, Shared Repositories (FTP) for installation. As the module installation proceeds, the system automatically proposes that you configure the FTP server.
Once the module has been installed, you will see a new entry in the main menu called Knowledge.

The first configuration step is to create a directory structure that will be used to classify your document set. You can use the structure automatically proposed by OpenERP from the menu Knowledge → Configuration → Document Management → Directories’ Structure.

In addition to the usual access to documents through OpenERP, you will be able to connect to them directly through the file system using the FTP protocol. To connect to the FTP server, use the following address:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Server</td>
<td>Your OpenERP server, for example 127.0.0.1</td>
</tr>
<tr>
<td>Port</td>
<td>8021</td>
</tr>
<tr>
<td>Path</td>
<td>The ‘/’ character, for the root</td>
</tr>
<tr>
<td>User</td>
<td>Your user account in OpenERP</td>
</tr>
<tr>
<td>Password</td>
<td>Your OpenERP password</td>
</tr>
</tbody>
</table>
Note: FTP Server

These comments about an FTP server may appear a bit technical, but it is just a general standard for getting hold of files without worrying too much about the platform (Windows, Mac, Linux, or other Unix-like system). So FTP is just a way of getting access to files without needing to use an OpenERP client. There could have been other ways, but FTP proved itself to the developers to be the one that performed best at lowest cost.

Once you are connected using FTP, you get to the root of a directory for the document management system. Once you enter that directory you find a structure that matches the structure defined in OpenERP.

![Figure 25.4: Root of the database directory seen through FTP](image)

![Figure 25.5: Structure of the directories in the document management system](image)

### 25.5 Mapping between OpenERP Resources and Directories

Each directory can either have the type **Static** or **Folders per resource**. A static directory, as with operating systems, is the classic directory that can contain a set of files. On the other hand, the directories linked to systems resources automatically possess sub-directories for each of the resource types defined in the parent directory.

**Tip: Directories in English**

To keep them synchronized to the working language, directory names are not translatable. But OpenERP’s demonstration data automatically creates directories in English. You can rename them through the menu **Knowledge → Configuration → Document Management → Directories**.

For example, you can look at the directory shown in **Documents → Sales Order → All Sales Order**. You will see the directory for all the orders present in OpenERP that was created automatically by the system.

![Figure 25.6: Orders in OpenERP](image)
Directories can follow a tree structure, like the tree of resources in OpenERP. For example, if you go to the directory Documents → Projects you will see the structure of the analytic accounts.

To define a directory containing a specific type of resource, you have to define parameters when you define the directory itself:

- **Type**: Folders per resource
- **Resource model**: Choose one of the system objects
- **Domain**: an event filtered so that it sees only a subset of the resources
- **Tree Structure**: to show the resources hierarchically

This is a very flexible approach because any modification of the resource in OpenERP is automatically reflected in the document management system. So when the quotation gets confirmed in OpenERP the directory no longer appears as a quotation through FTP access.

Here are some examples of directories linked to OpenERP resources that could be helpful when configured in the document management system:

- Quotations and Order: storing documents that relate to orders,
- Products: for storing products’ technical datasheets,
- Users: to automatically define a directory owned by each user of the system,
- Employees: to store documents about employees, such as their CVs, your interview notes, contract details, and their annual assessments,
- Support Requests: storing items about requests or about technical support responses,
- Analytic Accounts or Project: to store project management and tracking documents.
25.6 Managing Attachments

As you see, you can connect any directory in the document management system to an OpenERP resource. The system then manages its creation and keeps the directory synchronized with the reports generated by OpenERP from its own data. You do not have to create or rename these directories because OpenERP does all this automatically as it resynchronizes with its own database.

You can then copy the files in the directories that correspond to any of the resources. The files are automatically attached to OpenERP’s documents through attachment management. Conversely, if you attach a document to one of OpenERP’s resources then that document will automatically become visible over FTP in the document management system.

**Note: File Storage**

If you do not install the document management system then the files that are attached to an OpenERP resource are stored directly in the database. Once the document management system has been installed, the contents of the files are no longer stored in the database but are stored instead on the OpenERP server filesystem in a directory named ‘filestore’.

You can then read and add attachments to OpenERP resources quite independent of the OpenERP interface or the FTP server using simple drag and drop.

25.7 Virtual Files

The most well-organized companies keep track of all the documents they have sent to customers in their document management system. It is very useful to be able to retrieve every document about a customer or a project. But the work of storing these documents can itself often take up quite a bit of time for staff. Each report must be saved in the document management system as well as simply being sent by email to the customer.

That is not the case in Open ERP. To automatically make Open ERP reports available in the FTP server, Open ERP automatically uses virtual files. You can put virtual files into directories that have the special type of linked resource and link the virtual files to Open ERP’s reports.

**Note: Virtual Files**

Virtual files do not actually exist in Open ERP but are made visible with a size of 0 in the FTP server. Once these files have been read by the client software, Open ERP prints the document related to this file and returns a PDF document linked to the resource.

When you copy or open a virtual file you print the selected resource. You do not then have to go and print a document through Open ERP – you just open the file containing that document in the document management system. The PDF file is then created in real time by Open ERP by reading the relevant data.

The screen Virtual files for Sales Orders in Open ERP shows the parameters of the virtual files in Orders. You define the virtual files using the name ORDERNUM_print.pdf, where ORDERNUM represents the reference to the order. To do this you must check the option Include Record Name of the file for a directory. You can then find a virtual file for each report associated with an order.

![Virtual files for Sales Orders in Open ERP](image)

**Figure 25.9: Virtual files for Sales Orders in Open ERP**
To see the effect of this configuration, connect to the FTP server and go into a directory for an order such as Documents → Sales Order → All Sales Order → SO003. You can then just click the file SO003_print.pdf to get a printout of Order SO003. You can attach it to an email or put it on your desktop.

Figure 25.10: Virtual files for Sales Orders through FTP

This system of virtual files is very useful in a lot of situations. For example if you must quickly re-send a quotation to a customer you do not have to open Open ERP, you can just attach the relevant virtual file to your email.

Importantly, once files have been read or copied they become real files, taking up real space, rather than just virtual. This means that you can keep a legal record of all documents that have been created and sent to customers and suppliers.

25.8 Standardizing Structures

You now have a configuration that enables you to automatically get a directory structure linked to Open ERP for each resource, such as for projects and orders. The ideal situation would now be to automatically structure the documents about projects, say. For example, you could classify them depending on their type:

- Quotations,
- Meeting Minutes,
- Delivery Documents,
- Documentation.

Open ERP provides you with a system that lets you create a structure type for each type of a given document. It then provides that classification for all documents in the directories structured in that type.

So create the structure above for your project management system. To do that, create the four directories above and give them the following data:

- **Type** : Static Directory,
- **Parent Model** : Analytic Account.

Then in each project (represented by analytic accounts) you will get this substructure for organizing your documents efficiently.
In practice, Open ERP does not create directories or files for every resource. It actually manages this by mapping between Open ERP resources and the FTP interface. This approach gives a lot of flexibility because there is no synchronizing to do, nor any redundancy. Changes in either the document management system or in Open ERP will automatically be reflected over in the other side. And system resources are obviously not used up by storing things twice.

Once a new project has been defined in Open ERP, the system automatically creates a directory corresponding to the project in the right place in the document management system, and creates a structure type there for classifying documents.

### 25.9 Searching for documents

You have seen several methods of accessing documents quickly:

- From attachments to an Open ERP resource,
- Through FTP access to Open ERP,
- Using the menu Document Management → Structure of Directories.

But if you do not know where a specific document can be found, Open ERP also has a search tool integrated into its document management. To search for a file use the menu Knowledge → Documents → Documents. You get to a document search view that lets you search amongst all the attachments and all the documents in the FTP server.

You can search for a file using various different criteria:

- The attachment name,
- The attachment type,
• The filename,
• The owner of a file,
• The directory that it is found in,
• The indexed content

Notice here an important advantage for an integrated document management system. Information such as which partner is associated with a document is automatically detected by Open ERP when the document has been stored in a directory. This information is never input by the user – it is detected automatically using the information about the resource when it is being saved as a file.

But your search is not limited to these few fields. You can also search on the content in the files. Each file is automatically indexed by the system to give you a search engine rather like Google’s on the whole set of company documents.

### Note: Supported file formats

The Open ERP document management system can index the following file formats:

- **TXT**: text files,
- **PDF**: PDF files,
- **SXW**: Open Office V1 files,
- **ODT**: Open Office V2 files,
- **DOC**: Microsoft Word files.

The other file formats are properly handled in the document management system but their content is not indexed automatically.

This functionality is very significant. All you need to do is search for a partner name or an order number to automatically get all the documents that are referenced there. And you can use a fragment of text to find the document you need from within that subset.

### 25.10 Integration with emails

#### 25.10.1 Using Outlook and Thunderbird

![Image](image.png)

*Figure 25.12: Sending an attachment that is in the document management system from Outlook*

### 25.11 Working with users’ changes

To make the document management system’s use as unobtrusive as possible the system’s users should easily be able to store all the documents that they produce or receive from their customers and suppliers. So Open ERP supplies dashboards to help system users approve their acceptance of such documents.
So you will find two dashboards in the menu Knowledge → Reporting → Dashboard. One dashboard is for the document management system manager and one dashboard is for tracking use by different users.

The first lets you track the change of documents by month, by customer and by type of resource. You could also quickly assess the use that is made of the system by the various users.

Figure 25.13: Dashboard for the document management system manager

The second dashboard shows you how different employees use the system. You can see the number of files sent by each user and who uses the document management system the least. That tells you something about your user training and whether you need to do something about changing work methods.

Figure 25.14: Dashboard for the document management system analyzed by user

25.12 Version Management

There is usually a need to keep track of all the important documents that you have printed. For example, when you send an invoice to a customer it is a good idea to store a copy of that invoice internally in paper or electronic form. Then you can reprint it exactly in the same format as when you sent it, even if the company’s details have changed in the meantime.

To do this, Open ERP can automatically store as attachments the different reports printed by users. By default, only invoices are saved as attachments, and they are saved when they are printed. That is because they are commonly legally required.

But you can configure the system so that it does not matter which type of report is printed - they can all be stored automatically. To activate that functionality on another type of report, modify this in the menu Administration →
Low Level Objects → Actions → Reports. To be able to access this menu, the user should be added to the group Useability / No One.

Figure 25.15: Modifying the definition of a report

Select the report that you want to change and complete the field Save As Attachment Prefix. Once you have done that, each document print action will automatically be saved as an attachment to the document.
SYNCHRONIZING YOUR CALENDARS
(CALDAV)

As from OpenERP Version 6.0, document_webdav v2.2, the iPhone has been thoroughly tested and is now supported as a Calendaring client for the OpenERP CalDAV module. The same applies to the Android phones, of course.

However, keep in mind that OpenERP is not a straightforward calendaring server, but an ERP application (with more data + structure) which exposes those data to calendar clients. That said, the full features that would be accessible through the GTK or Web OpenERP clients cannot be included into Calendar clients (such as iPhone).

26.1 OpenERP Server Setup

Some modules need to be installed on the OpenERP server. These are:

- **caldav**: Required, has the reference setup and the necessary underlying code. Will also cause document & document_webdav to be installed.
- **crm_caldav**: Optional, will export the CRM Meetings as a calendar.
- **project_caldav**: Optional, will export project tasks as a calendar.
- **http_well_known**: Optional, experimental. Will ease bootstrapping, but only when a DNS srv record is also used.

When you install the above module(s), a ready-to-go reference setup of the folders is provided. The OpenERP administrator can add more calendars and (re)structure if needed.

26.2 DNS Server Setup

To be documented.

26.3 SSL Setup

It is highly advisable that you also set up SSL to work for the OpenERP server. HTTPS is a server-wide feature in OpenERP, which means a certificate will be set at the openerp-server.conf which will be the same for XML-RPC, HTTP, WebDAV and CalDAV. The iPhone also supports secure connections with SSL, although it does not expect a self-signed certificate (or one that is not verified by one of the “big” certificate authorities).
26.4 Calendars on iPhone

To set up the calendars, proceed as follows:

1. Click **Settings** and go to the **Mail, Contacts, Calendars** page.
2. Go to **Add account**.
3. Click **Other**.
4. From the **Calendars** group, select **Add CalDAV Account**.
5. Enter the host name. (E.g. if the url is http://openerp.com:8069/webdav/db_1/calendars/, openerp.com is the host)
6. In **Username** and **Password**, type your OpenERP login and password.
7. As a description, you can either leave the server’s name or something like “OpenERP calendars”.
8. If you are not using a SSL server, you’ll get an error, do not worry and push “Continue”
9. Then click **“Advanced Settings” to specify the correct** ports and paths.
10. Specify the port for the OpenERP server: 8071 for SSL, 8069 without SSL.
11. Set the **Account URL** to the right path of the OpenERP webdav: the url given by the wizard (e.g. http://my.server.ip:8069/webdav/dbname/calendars/ )
12. Click **Done**. The phone will connect to the OpenERP server and verify whether the account can be used.
13. Go to the main menu of the iPhone and open the Calendar application. Your OpenERP calendars will be visible inside the selection of the “Calendars” button. Note that when creating a new calendar entry, you will have to specify which calendar it should be saved to.

If you need **SSL** (and your certificate is not a verified one), you will first need to let the iPhone trust the certificate. Follow these steps:

- **s1. Open Safari and enter the https location of the OpenERP server:** https://my.server.ip:8071/ (assuming you have the server at “my.server.ip” and the HTTPS port is the default 8071)
- **s2. Safari will try to connect and issue a warning about the certificate** used. Inspect the certificate and click “Accept” so that iPhone now trusts it.

26.5 Calendars on Android

26.5.1 Prerequisites

There is no built-in way to synchronize calendars with caldav. So you need to install a third party software: Calendar (CalDav) Sync BETA from Hypermatrix Software (for now it is the only one).

26.5.2 How to configure?

1. Open the **Calendar Sync** application. You get an interface with 2 tabs.
2. On the **Connection** tab, in CalDAV Calendar URL, type a URL such as http://my.server.ip:8069/webdav/dbname/calendars/users/demo/c/Meetings.
3. Type your OpenERP username and password
4. If your server does not use SSL, you will get a warning. Answer **Yes**.
5. Then you can synchronize manually or customize the settings (Sync tab) to synchronize every x minutes.
26.6 Calendars in Evolution

1. Go to Calendar View
2. File -> New -> Calendar
3. Enter the data in the form:
   - type : CalDav
   - name : Whatever you want (e.g. Meeting)
   - url : http://HOST:PORT/webdav/DB_NAME/calendars/users/USER/c/Meetings (e.g.
     http://localhost:8069/webdav/db_1/calendars/users/demo/c/Meetings) the one given on top of this window
   - uncheck “User SSL”
   - Username : Your username (e.g. Demo)
   - Refresh : every time you want Evolution to synchronize the data with the server
4. Click OK and enter your OpenERP password.
5. A new calendar with the name you entered should appear on the left side.

26.7 Calendars in Sunbird/Lightning

26.7.1 Prerequisites

If you are using Thunderbird, first install the Lightning module
http://www.mozilla.org/projects/calendar/lightning/

26.7.2 Configuration

1. Go to Calendar View
2. File -> New Calendar
3. Choose “On the Network”
4. As a format, select CalDav and as a location type the url (e.g.
   http://host.com:8069/webdav/db/calendars/users/demo/c/Meetings)
5. Choose a name and a colour for the Calendar, and we advice you to uncheck “alarm”.
6. Enter your Openerp login and password (to give the password only once, check the box “Use Password
   Manager to remember this password”).
7. Then click Finish; your meetings should now appear in your Calendar view.
Part IX

System Administration and Implementation
After you have tested and evaluated Open ERP, you will need to configure it to match the software to your company’s needs. Its flexibility enables you to configure the different modules, adapting them to your industry or sector of activity.

Designed for ERP project managers, this section deals with the administration and configuration of the system, giving you powerful tools for integrating the software in a company and driving and tracking the project, taking account of different problems, a range of supplier types, implementation risks, and the options available to you.
This chapter is for the administrators of an Open ERP system. You will learn to configure Open ERP to match it to your company’s needs and those of each individual user of the system.

Open ERP gives you great flexibility in configuring and using it, letting you modify its appearance, the general way it functions and the different analysis tools chosen to match your company’s needs most closely. These configuration changes are carried out through the user interface.

Users can each arrange their own welcome page and their own menu, and you can also personalize Open ERP by assigning each user their own dashboard on their welcome page to provide them with the most up to date information. Then they can immediately see the information most relevant to them each time they sign in.

And Open ERP’s main menu can be entirely reorganized. The management of access rights lets you assign certain functions to specific system users. You can also assign groups to the user, which lets him move system documents from state to state (such as the ability to approve employee expense requests).

**Note:** Configuration, Parametrization, Personalization, Customization

The word personalization is sometimes used in this book where you might expect to find configuration or customization.

Customization generally refers to something that requires a bit of technical effort (such as creating specialized code modules) and creates a non-standard system.

Configuration is less radical – it is the general process of setting all the parameters of the software to fit the needs of your system (often called parametrization or setup). Configuration is also, by convention, the name of the sub-menu below each of Open ERP’s top-level menus that is accessible only to the administrative user for that section.

Personalization is just that subset of configuration options that shapes the system to the particular operational and/or stylistic wishes of a person or company.

Using the OpenOffice Report Designer module you can change any part of any of the reports produced by the system. The system administrator can configure each report to modify its layout and style, or even the data that is provided there.

**Note:** The OpenOffice Report Designer

The OpenOffice Report Designer plug-in enables you not only to configure the reports of the basic products in Open ERP but also to create entirely new report templates. When the user uses Open ERP’s client interface, OpenOffice can create a report template that has access to all the data available to any Open ERP document type. You can easily create fax documents, quotations, or any other commercial document. This functionality enables you to considerably extend the productivity of your salespeople who have to send many proposals to customers.

Finally, you will see how to import your data into Open ERP automatically, to migrate all of your data in one single go.

For this chapter you should start with a fresh database that includes demo data, with sale and its dependencies installed and no particular chart of accounts configured.
27.1 Creating a Configuration Module

It is very helpful to be able to backup your specific configuration settings in an Open ERP module dedicated just to that. That enables you to:

- automatically duplicate the configuration settings by installing the module in another database,
- reinstall a clean database with your own configuration in case you have problems with the initial configuration,
- simplify migrations, if you have modified some elements of the basic configuration, there is a risk in returning them to their original state after the migration, unless you have saved the modifications in a module.

Start by installing the module base_module_record in the usual way. Manually make all your configuration changes through the user interface as you would normally do (such as menu management, dashboard assignments, screen configuration, new reports, and access rights management – details of some of these possibilities are described later in this chapter). Then start recording your data using the menu Administration → Customization → Module Creation → Export Customizations As a Module. This opens a wizard through which you may select the date to record from, choose records that have been Created, Modified or both Created & Modified. You have to select the objects for recording and then start recording by clicking Record. After the recording operation is complete, a dialog box appears giving you the opportunity to save the recorded module at a desired location.

Open ERP then creates a ZIP file for you containing all of the modifications you made while you were carrying out your configuration work. You could reinstall this module on other databases. This could turn out to be useful if you want to install a test server for your company’s users and give them the same configuration as the production server.

To install a new module saved in ZIP file form, use the menu Administration → Modules → Import Module.

27.2 Configuring the menu

Open ERP’s menu organization is not subject to any restriction, so you can modify the whole structure, the terminology and all access rights to it to meet your specific needs in the best possible way. However, before you do all that and just as you would for any other customizable software, you should balance both the benefits you see in such changes and the costs, such as the need to train users, to maintain new documentation and to continue the alterations through subsequent versions of the software.

This section describes how to proceed to change the structure of the menu and the welcome page, to configure the terminology of the menus and forms in the user interface and for managing users’ access rights to the menus and the various underlying business objects.

27.2.1 Changing the menu

You can change the way menu items appear and the actions they trigger by using the menu Administration → Customization → User Interface → Menu Items. This opens a search view where you may locate the menu item to be edited by entering its entire name (specified as menu hierarchy) in the Menu field or specifying its immediate parent menu name in Parent Menu.

As an example, locate the menu item Administration/Translations/Import / Export/Export Translation and click on this entry to open its corresponding form. You could now edit this form (but do not do that, read the next paragraph first!) – change its Parent Menu, which moves the entry to a different part of the menu system; edit its Menu name to change how it appears in the menu tree, or give it a new Icon. Or you could give it a new Action entirely (but this would lose the point of this particular exercise).

Instead of editing this form, which is the original menu entry, duplicate it. With the web client you must first make the form read-only by clicking the Cancel button, then you click the Duplicate button that appears (in the
GTK client, click **Form → Duplicate** from the top menu). The form that remains is now the duplicate entry, not the original.

To move this duplicate entry, change the **Parent Menu** field by deleting what is there and replacing it with another menu that everyone can see, such as **Tools** or **Human Resources**, and make sure that the entry moves to the end of the menu list by replacing the **Sequence** with 99. You can experiment with icons if you like. Save the form and then reload the page to see the results.

**Tip:** **Duplicating the menu**
If you are planning to modify a menu you should duplicate it first. In this way you will always keep a link to the original menu that works if you need it to.

### 27.2.2 Personalizing the welcome page for each user

The administrator can change both the welcome page and the main menu page individually for each user of the system, and can adapt Open ERP to each role in the company to best fit the needs of everyone.

To make modifications for a particular user, edit the user configuration again in **Administration → Users → Users**. Open the form for a particular user, and select different menu entries for the two fields **Home Action** and **Menu Action**.

![Figure 27.1: Selecting a new welcome page](image)

The **Home Action** is the menu item that is automatically opened when you first sign on, and is also reached when you click the **Home** link in the top right toolbar of the web client. There you can choose any page that you would reach through any menu – one of the dashboards could be most useful. The **Menu Action** is the one you reach through the menu **Form → Menu** in the GTK client. You can choose the main menu and the dashboards there.

**Tip:** **Actions on the administrator’s menu**
*It is very easy to change the welcome page and the menu of the different users. However, you should not change the main administrator’s menu because you could make certain menus completely inaccessible by mistake.*

### 27.2.3 Assigning default values to fields

You can quite easily configure the system to put default values in various fields as you open new forms. This enables you to pre-complete the fields with default data to simplify your users’ work in entering new documents. Let us use the Customer form to demonstrate this feature. Create a new customer with **Country** set as **New Zealand**

- If you are using the web client, click the small button at the right of the **Country** field.
• If you are using the GTK client, you just need to right-click the mouse while the pointer is in the field. Select **Set as default** from the pop-up menu. An administrator has the choice of making the default work just for that user, or for all users of the database.

![Field Preferences](image)

**Figure 27.2: Inserting a new default value**

To check this new configuration, open a new partner form: the field **Country** should now contain the entry **New Zealand**.

This is a very powerful feature! An administrator can use this functionality to redefine the behavior of your whole system. You can test that in database `openerp_ch13` by opening up a new **Purchase Order** form, clicking the second tab **Delivery & Invoicing**, selecting **From Picking** in the **Invoicing Control** field and then making that the default.

From that moment on, you would automatically create draft purchase invoices only when goods are received, so you could very easily restrict your accountants from paying any invoices that turn up until you were sure you had received the goods. It would not stop anyone from selecting another method of invoice control, but they would start with the default definition.

### 27.2.4 Changing the terminology

You can use Open ERP’s language translation functionality to substitute its standard terminology with terminology that fits your company better. It is quite straightforward to adapt the software with different terms specific to your industry. Moreover, this can strengthen acceptance of your new Open ERP system, because everybody will be able to retain their usual vocabulary.

You can do this one of two ways:

- translate them in a CSV file, which gives you a global overview of all of the system terms so that you can search and replace specific occurrences everywhere,
- translate the phrases directly in the client, which means that you can change them in their context, and that can be helpful to you while you are translating.

The same approach is used to translate terms that have not been created yet. This can be useful, for example, with modules that have not yet been translated into English or any other language that you want.

**Translation through a CSV file**

To translate or modify all of the system’s phrases you first have to export a translation file in CSV form. And to do that, you have to install a language into Open ERP. To load a translation that already exists in Open ERP use **Administration → Translations → Load an Official Translation** choose a language and then click **Load**.
Then export it using Administration → Translations → Import/Export → Export Translation. Select the language, then the CSV File format, then one or more (or all) modules. Click Export to start the export process, then click the small Save As icon to save the file somewhere.

**Note:** UTF-8 format

The CSV file is encoded in the UTF-8 format. Make sure that you retain this format when you open the file in a spreadsheet program because if you do not retain it you risk seeing strange character strings in place of accented characters.

![Figure 27.3: CSV translation file with a translation in view](image)

The file contains six columns: module, type, name, res_id, src, and value. You have to ensure that the first line, which specifies these column names, remains untouched.

The **src** field contains the base text in English, and the **value** field contains a translation into another conventional language or into a specialist technical phrase. If there is nothing at all in the **value** field then the English translation will automatically be used on the the form you see.

**Tip:** Where should you modify the text?

Most of the time, you will find the text that you want to modify in several lines of the CSV file. Which line should you modify? Refer to the two columns type (in column B) and name (in column C). Some lines have the name ir.ui.menu in the name column which shows that this is a menu entry. Others have selection in the type column, which indicates that you would see this entry in a drop-down menu.

You should then load the new file into your Open ERP system using the menu Administration → Translations → Import/Export → Import Translation. You have then got two ways forward:

- you can overwrite the previous translation by using the same name as before (so you could have a special ‘standard French’ translation by reusing the Name Français and Code fr_FR),
- you could create a new translation file which users can select in their Preferences.

If you are not connected to the translated language, click Edit Preferences, select the language in Language from the Preferences tab and finally click Save to load the new language with its new terminology.

**Tip:** Partial translations

You can load a selection of the lines in a translation file by deleting most of the lines in the file and then loading back only the changed ones. Open ERP then changes only the uploaded lines and leaves the original ones alone.

### Changes through the client interface

You can also change labels and other screen items on screen in the web client. To do that, open the form that you want to translate, then click the Translate icon to its bottom right. You then have the choice of translating:

- the data in the system (contained in the Fields),
- the field titles (the Labels),
- all of the Action buttons to the right of the form (the Relates option),
- the terms used in the form View.

You can modify any of these.

The procedure is slightly different using the GTK client. In this you just right-click on a label or button with the mouse. You can choose to translate the item itself or the whole view.
This method is simple and quick when you only have a few entries to modify, but it can become tiresome and you can lose a lot of time if you have got to change some terms across the whole system.

In that case it would be better to use the translation method that employs a CSV file.

**Tip:** Taking account of translations

_In the GTK client the modified terms are not updated immediately. To see the effects of the modifications you must close the current window and then reopen the form._

### 27.3 User Login

**Tip:** Managing Passwords

_If you let users change their passwords for themselves you will have no direct control over the password they choose. You should have a written policy about password strength to try to maintain a level of security in your system._

**Tip:** Managing users through LDAP

_With the users ldap module, user accounts can be managed through an LDAP directory that can be made common to various different company resources._

_Connection parameters for the LDAP directory are then registered with the company definition. You can provide a user profile template there from which new users are automatically created during their first connection to Open ERP._

**Note:** LDAP

_The LDAP protocol (Lightweight Directory Access Protocol) enables you to manage common directories for various different resources through your standard TCP/IP network._

_This enables users in the company to have the same username and password to access all their applications (such as email and intranet)._

### 27.4 Managing access rights

One of the most important areas in configuring Open ERP is how to manage access rights to the information in it.

You are planning to put everything significant to your business into the system, but most of your staff need see only part of it, and may need to change even less of it. Who should have rights to what, and how do you manage that?

Open ERP’s approach to rights management is highly flexible. Each user can belong to one or more groups, and the group(s) you belong to determine(s):

- the visibility of each menu item and
- the accessibility of each table in the database.

For example, the group Warehouse / User may only be given access to some of the menus in Warehouse, and may have no access to any of the accounting information. Each system user who works in stores is given membership of the Warehouse / User group. If some users also work elsewhere, they would also be given membership of other groups.

### 27.5 Groups and Users

To configure access rights you would start by defining the groups. It is important for the groups to be representative of your company’s job functions rather than of its individual employees.

So if your finance director is also your sales director, you should create both a Finance Director group and a Sales Director group, even though they are both the same person, and would both be assigned to this user in practice. This gives you flexibility for the future.
You should also create groups within a departmental areas that have different levels of access rights. For example, if you create a Sales Director group and a Sales group avoid assigning exactly the same rights to each group. The first could see all the reports, while the second could be restricted to seeing quotations. You could either make the Sales Director a member of both groups, and give the Sales Director group a limited set of extra rights, or give the Sales Director group all the rights it needs for a Sales Director to belong only to this one group. You should choose the scheme that gives you most flexibility and then stick with it to maintain consistency.

Tip: Flexibility in managing access
To give yourself flexibility, you can ensure that a trusted staff member (perhaps a director or someone in accounts, or even the system administrator) is given wide rights to use the system, and is authorized by the management to carry out specific tasks for people.

27.5.1 Access rights for menus

To get a feel for rights management in Open ERP you will create a new Stock1 group, with access to the Warehouse menu items. You will then create a stores person user who is a member of the Stock1 group.

To create a new group, use the menu Administration → Users → Groups. Enter the group name Stock1.

Then to create a new user linked to this, use Administration → Users → Users to enter the following:

- **User Name**: Stores Person,
- **Login**: stores,
- **Password**: stores,
- **Menu Action**: Menu.

In the Groups section of the user form, add the Stock1 group that you just created.

Save the user, then go into the menu Administration → Customization → User Interface → Menu Items to get a list of menus. Filter this list using the search field Menu to get the Warehouse menu item. In the form describing the menu, add Stock1 into the Groups field. From now on, only members of the Warehouse / Manager, Warehouse / User and Stock1 group will be able to see this menu item in their main menu list.
Tip: Menu hierarchy
Since menus are hierarchical there is no need to hide access to lower menus: once you have configured Warehouse this way, all lower-level menus become invisible to members of other groups.

Tip: Security
This method of managing access to menus does not guarantee that users are prevented from reaching hidden business objects in the system in other ways. For example, hiding the Invoices menu will not prevent people reaching invoices through purchase and sales orders, or by guessing the URL. For effective security management you must use the methods for managing access rights to objects presented in the following section.

Note: Initial access configuration
In the initial configuration, Open ERP’s admin user, a member of the Administration / Configuration group, is given access to the Configuration menu in each section of the main menu. This is a general convention. For example, Sales → Configuration is visible in the administrator’s menu amongst the other Sales menu items. But only the menu items other than Sales → Configuration are visible to other users. Similarly, the main menu item Administration is, by convention, visible only to users who are members of the Administration / Configuration group.

27.5.2 Access Rights to Objects

The menu access rights determine who can access which menu, but does not define what you can do once you are in the menu.

Access controls on the objects give you the possibility of defining what your users have the right to do with your data when they get access to it. Access control of objects is structured the same way as access to menus.

Note: Object
An object represents a document in the system. Objects are linked to database tables and also have additional concepts, such as the functions of fields, inheritance from other objects, and class methods that give them behavior.

If no group is assigned to an object, all users can access it without any restriction of any sort. Conversely, when an access control is defined for an object, a user must be a member of a group owning appropriate access rights to have any sort of access to that object.

You must always ensure that you do not lock the Administration / Access Rights group out of any objects that control administration and configuration options, such as the ir.model.access model.

You can manage four access modes on objects independently:

- **Read access**: members of the group can read the data in the object,
- **Create access**: members of the group can create a new record in the object,
- **Write access**: members of the group can modify the contents of records in the object,
- **Delete access**: members of the group can delete records from the object.

Figure 27.5: Access control to invoices for the Finance/Admin group
To configure access rights on a Open ERP objects, use the menu Administration → Security → Access Controls List and click New or choose an existing one and click Edit. You give a Name to the access control, select a Group, and the Object, then check the checkbox corresponding to each of the four Access modes.

If you do not specify any group in the access rules, the rule is applied to all groups. So to remove access to an object for all users you could create a rule:

- which is defined for a specific object,
- which is linked to no group,
- for which none of the four access options is checked.

You can then create additional rules on the same object to give specific rights to certain groups.

### 27.5.3 Record Rules For Objects

Record rules determine who can access the objects depending on the rules set for the particular object. A record rule has some tests to be performed on objects.

You can manage four access modes on objects independently depending on the test:

- **Read access**: can read the data in the object,
- **Create access**: can create a new record in the object,
- **Write access**: can modify the contents of records in the object,
- **Delete access**: can delete records from the object.

To configure rule on object, use the menu Administration → Security → Record Rules. The fields in the `ir.rule` object describe:

- **Object**: Object on which to have the rule
- **Name**: Name of the rule
- **Global**: If global is checked then that rule would be applied for all the groups and if it is unchecked then that rule would be applied only for the groups selected for it
- **Domain**: A list of all the tests for the object. It is specified through a Python expression as a list of tuples.
  - If there are multiple tests on same object then all of them are joined using **AND** operator and depending on the result the rule would be satisfied
  - If there are multiple rules on same object then all of them are joined using **OR** operator
- **Access Modes**: Read, Write, Create, Delete as described earlier
  - If only one access mode is checked, then only that mode would be applied
  - If all of them are checked then all the access modes would be applied
  - But at least one access mode has to be checked, all of them can not be unchecked. If all of them are unchecked it would raise an exception.

**For example**: If we have a rule defined on `res.partner` object which tests if the user is the dedicated salesman of the partner `[(‘user_id’, ’=’, user.id)]`. We check only the create and write access modes and keep other access modes unchecked.

So this means that a user in the group for which the rule is applied can only create/write records where he himself serves as the dedicated salesman and can not create/write records where he is not the dedicated salesman. As other access modes are unchecked the user can read/delete the records of partners where he is not the dedicated salesman.
27.5.4 Modification history

![Partner Record history](image)

Figure 27.6: Partner Record history

Each record in an Open ERP database carries a note of its history. You can find out who it was created by and when that occurred, and who last modified it and when that occurred. Click the View Log link at the right of any form in the web client to display a dialog box showing this information, as shown in the figure Partner Record history. It can help you identify who to contact if there are any problems with the data in the records.

**Tip: Audit Trail**

Open ERP has an Audit Trail module `audittrail` which can be used to track any or all of the changes to one or more objects. It should be used with care, because it can generate huge amounts of data in the live database, but can be an invaluable tool.

27.6 Configuring workflows and processes

Workflows represent the company’s different document flows. They are completely configurable and define the path that any individual Open ERP object (such as an order) must follow depending on the conditions (for example an order over a certain value must be approved by a sales director, otherwise by any sales person, before the delivery can be triggered).

The figure Workflow for order SO005 shows the standard workflow for an order. You can show it from the GTK client starting with `Sales → Sales → Sales Orders`. Select an order, then go to the top menu `Plugins → Execute a plugin → Print Workflow` to show the menu below.

In the web client you can reach a workflow from the associated cross-company process (the process itself is reached by going to the sales document and then clicking the `Corporate Intelligence` button above it). The chapter Process provides all of the information needed to create and modify technical workflows and cross-company processes.
27.7 Configuring reports

Open ERP has two distinct report types:

- Statistical reports: these are calculated data, often represented in the form of lists or graphs. These reports are dynamic and you can navigate through the data that comprise the figures through the client interface.

- Report documents: they are used to print system documents. The result is usually a PDF generated by a selection made on the screen. Furthermore, Open ERP enables you to open these reports in OpenOffice.org to edit in any changes you want before sending them to your customer.

Because of the power of the Open ERP engine, these two types of report can be created or modified without needing any development and this can be done directly in the client interface of Open ERP or from OpenOffice.org.

27.7.1 Managing statistical reports

Many reports are configured in advance in Open ERP. You can find them in the Reporting sub-menus under each main menu entry.

Modelling a new report

Open ERP gives you the possibility of developing your own analyses to meet your specific needs. To define a new analysis of the system’s data you should install the module base_report_creator. You can do by using the Reconfigure wizard and installing Advanced Reporting. Then as you configure the reporting tools, select Query Builder for installation. This enables you to create complex queries on the database, in a simple and visual way.

Once the module is installed, create a new report using the menu Administration → Customization → Reporting → Custom Reports.

Give a Report Name to your new report and select the objects that you are going to analyze. For example, select Partner, Sale Order, Sale Order line.

Then turn to the second tab View parameters to select the views that you want in your report. Select Tree in the First View and Graph in the Second View. You can choose the type of graph displayed using the Graph View fields. You could also select Calendar as a view if you were going to add the Date field in your report.

**Tip:** The MS Excel plug-in

The Microsoft Excel plug-in enables you to connect to Open ERP and automatically extract the selected data. You can then apply formulas and graphs to make your own dashboards of measures directly in Excel. The .xls file can be saved and, when it is reopened, it reconnects to Open ERP to refresh the different lists and graphs with live data.
In the third tab Fields to Display you must indicate which of the fields in the list you want to be shown in your report. Complete the screen along the lines of the figure below.

1. The Sequence field gives the order of the fields displayed.

2. Field, the second column, enables you to select a field from any of the three objects you selected in the first tab.

3. Grouping Method, the third column lets you to determine the grouping operation that is to be applied to this field:
   - Grouped: Enables you to group document entries with the same value in this field.
   - Sum: Gives the sum of values in this field.
   - Minimum: Gives the minimum of all the values that appear in this field.
   - Maximum: Gives the maximum of all the values that appear in this field.
   - Average: Gives the arithmetic average of all the values in this field.
   - Count: Gives the count of all the values in this field.

4. Graph Mode, the fourth column, determines if the field will appear in the graph view and, if so, on which axis (X or Y).

5. Calendar Mode, the fifth column, enables you to specify if the field can be the basis of a calendar view.

In the fourth tab Filters on Fields you can add filters on all the fields of the selected objects. To do that, use the button Add filter at the top of this tab. For the moment, do not add a filter.

You can now Save the report you defined. Click on the Open Report button to the right of the form on the General Configuration tab to get the requested analysis.
Configuring the dashboards

A dashboard is a selection of reports previously defined in Open ERP. You can choose from hundreds of predefined reports and, for each report, indicate its position on the dashboard.

Just like fields on reports, the Sequence field determines the order in which views appear in the dashboard.

Once the dashboard has been defined through the menu Administration → Customization → Reporting → Dashboard Definition you can use the Create Menu button to create a menu entry for your dashboard anywhere in the menu system.

27.7.2 Managing document templates with OpenOffice.org

To configure your printable documents in Open ERP, use the module base_report_designer. To install this module use the Reconfigure wizard and ensuring that Advanced Reporting is installed, configure OpenOffice Report Designer for installation.

Tip: The OpenOffice.org Writer plug-in
You can create your own reports in just a few minutes using the OpenOffice.org Writer plug-in. This tool can give your team a big productivity improvement. Using it, you can create templates for all of your company’s documents, reducing the work of creating and laying out data and customer documents.
The system is both simple and powerful, because it gives you the benefits of all of the layout facilities offered by OpenOffice.org Writer as well as all of the data and calculation provided by Open ERP. You could create or modify reports directly from OpenOffice.org and then use them in Open ERP.

**Note:** Independence from OpenOffice.org

OpenOffice.org is only used to generate new document templates. The system administrator is the only person who has to install it. Once the document templates have been defined the users do not need it to carry out their normal work. They can use either Microsoft Office or OpenOffice.org as they choose.

The OpenOffice.org plug-in enables you to search for fields in Open ERP and integrate them into your document templates. You can use data loops in tables or sections, enabling you to attach several lines to an order, for example.

Once the new report has been defined it appears directly in the Open ERP client for the system users.

There are two modes of using reports:

- make the report produce a PDF document with data in it reflecting the selected record (for example, an invoice).
- make the report open a document for modification in OpenOffice.org, with data in it reflecting the selected record. This enables you to modify the document in OpenOffice.org before sending it to the customer (such as with a Quotation).

The personalized reports are stored in the Open ERP database and are accessible to everyone who has rights to use your database without any need for the installation of OpenOffice.org on their own computers. The document modifications are applied to a single database.

**Installing the OpenOffice.org module**

You should install two components before using the report editor:

- the module `base_report_designer` – first in your Open ERP installation if it is not already there, and then in the Open ERP database, you want to use it in.
- the OpenOffice.org Report Designer in the OpenOffice.org installation on your system administrator’s computer.

You start by installing the module `base_report_designer` just like all the other Open ERP modules.

To install the OpenOffice.org extension, save the file `openerp_report_designer.zip` supplied during the OpenERP Report Designer Configuration. Check that OpenOffice.org is properly installed on your computer and that you have administration rights for installation.

![Figure 27.12: Menu Open ERP Report in OpenOffice.org Writer](image)

Start OpenOffice.org Writer, select **Tools → Extension Manager...** to open the Extension Manager dialog box and then search for the `openerp_report_designer.zip` file to install it. Then close the application and restart Writer: a new menu appears in the top menu bar – **OpenERP Report Designer**.
Connecting OpenOffice.org to Open ERP

Select OpenERP Report Designer → Server parameters in the top menu of OpenOffice.org Writer. You can then enter your connection parameters to the Open ERP server. You must select a database in which you have already installed the module purchase. A message appears if you have made a successful connection.

Modifying a report

The report editor lets you:

- modify existing reports which will then replace the originals in your Open ERP database,
- create new reports for the selected object.


OpenOffice.org then opens the report in edit mode for you. You can modify it using the standard word processing functions of OpenOffice.org Writer.

The document is modified in its English version. It will be translated as usual by Open ERP’s translation system when you use it through the client interface, if you have configured your own setup to translate to another language for you. So you only need to modify the template once, even if your system uses other languages – but you will need to add translations as described earlier in this chapter if you add fields or change the content of the existing ones.

Tip: Older reports

The older reports may not all have been converted into the new form supported by Open ERP. Data expressions in the old format are shown within double brackets and not in OpenOffice.org fields. You can transform an old report format to the new format from the OpenOffice.org menu OpenERP Report Designer → Convert Brackets -> Fields.

From the Open ERP toolbar in OpenOffice.org it is possible to:

- connect to the Open ERP server: by supplying the connection parameters.
- add a loop: select a related field amongst the available fields from the proposed object, for example Order lines. When it is printed this loop will execute for each line of the order. The loop can be put into a table (the lines will then repeat) or into an OpenOffice.org section.
- add a field: you can then go through the whole Open ERP database from the selected object and then a particular field.
- add an expression: enter an expression in the Python language to calculate values from any fields in the selected object.
Tip: Python Expressions

Using the Expression button you can enter expressions in the Python language. These expressions can use all of
the object’s fields for their calculations.

For example if you make a report on an order you can use the following expression:

`
%.2f' % (amount_total * 0.9,)
`

In this example, amount_total is a field from the order object. The result will be 90% of the total of the order,
formatted to two decimal places.

You can check the result in Open ERP using the menu Purchases → Purchase Management → Requests for
Quotation.

Creating a new report

The general template is made up of loops (such as the list of selected orders) and fields from the object, which
can also be looped. Format them to your requirements then save the template.

The existing report templates make up a rich source of examples. You can start by adding the loops and several
fields to create a minimal template.

When the report has been created, send it to the server by clicking OpenERP Report Designer → Send to the
server, which brings up the Send To Server dialog box. A Technical Name for the report is assigned by default, to
make it appear beside the other sales order reports. Rename the template as Sale Order New in Report
Name, check the checkbox Corporate Header and finally click Send Report to Server.

To send it to the server, you can specify if you prefer Open ERP to produce a PDF when the user prints the
document, or if Open ERP should open the document for editing in OpenOffice.org Writer before printing. To do
that choose PDF, OpenOffice (SXW) or HTML in the field Select Rpt. Type.

27.7.3 Creating common headers for reports

When saving new reports and reports that you have modified, you are given the option to select a header. This
header is a template that creates a standard page header and footer containing data that is defined in each
database.

This template can be customized by changing the company information through the menu Administration →
Companies → Companies. You may select your parent company from the list and edit the fields Report Header,
Report Footer 1, Report Footer 2 in the General Information tab. If your company has a logo that you would
want to appear in all reports, you may add it using the Logo field. You can also change the appearance of the
header/footer by editing the XML code in the tabs Header/Footer and Internal Header/Footer.

For any kind of troubleshooting problems kindly mail us at cde@tinyerp.com.

27.8 Importing and exporting data

Every form in Open ERP has a standard mechanism for importing data from a CSV file through the client user
interface. That is the same format as used in the language translations.

Note: Forms and Lists

You have access to the Import and Export functions in the web client on a single form view in read-only mode –
you cannot reach Import or Export in any other view or when the form is editable. If you are using the GTK client
you can find the functions from the top menu Form → Import data... and Form → Export data....

The CSV file format is a text format compatible with most spreadsheet programs (such as OpenOffice Calc and
Microsoft Excel) and is easily editable as a worksheet. The first line contains the name of the field in the form. All
the subsequent lines are data, aligned in their respective columns.
27.8.1 Exporting Open ERP data to CSV

Start exploring Open ERP’s use of the CSV format by exporting a modestly complex set of data, the partners and partner addresses in the demonstration data.

Go to Sales → Address Book → Customers for a list of partners and select the records to export by clicking the checkbox on the left of each record. Then look for the Other Options section on the right of the list and click the Export link. This pops up the Export Data dialog box. Select the following fields:

- Name,
- Contact Name under the Contacts menu,
- City under the Contacts menu.

You can either select and add them one at a time, or Ctrl-click them and add the multiple selection - the order in which you select them is the order in which they will be displayed.

If you do not wish to export your your data just yet or would like to use the same fields for future exports, you have the option to save these settings. To do that click Save List and give your export a name.

Then click Export and save the resulting data.csv file somewhere accessible - perhaps your Desktop. You can open that file in a spreadsheet program or a text editor.

You will see that you have a list of partners, with the name and city of each partner’s contacts alongside. In the couple of cases where there is more than one address, the partner name is left out. So it is important to note that the order of entries is critical - do not sort that list!

Tip: List limits
There is a limit to the number of items you can export in the clients - it is the number you can actually see and that is 20 items by default in the web client, but is arbitrary in the GTK client.
You can change the number of items viewed by clicking on the link which shows the count of the items. You can then make a selection of limiting it to fixed number of items at a time, for example, 50 or 100, or you can choose to view unlimited number of items at a time.

27.8.2 Importing CSV data to Open ERP

Use this export file as a template for an import file by deleting all of the data and using new data (here you will just import new data alongside the demonstration data, but the principle is the same for a blank database).

For example, to import partners with several contacts for which you specify a name and a city, you would create the following CSV file from the export file:

<table>
<thead>
<tr>
<th>Name</th>
<th>Contacts/Contact Name</th>
<th>Contact/City</th>
</tr>
</thead>
<tbody>
<tr>
<td>Whole Globe Technologies</td>
<td>Graham Global</td>
<td>Athens</td>
</tr>
<tr>
<td></td>
<td>Wanda World</td>
<td>Rome</td>
</tr>
<tr>
<td></td>
<td>Emerson Earth</td>
<td>New York</td>
</tr>
<tr>
<td>Miles A Minute</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

From the list of partners, click the Import button and then in the Import Data window click Browse to search for and import the new data.csv file. The web client automatically matches column names but the GTK client requires that you click the Auto detect button. You can use the default Options or change them according to preference. Then click Import.

You will get a dialog box showing that you have imported 2 objects, and you can see the new partners and partner addresses when you refresh the list on screen.
27.8.3 The CSV format for complex database structures

When you import data you have to overcome the problem of representing a database structure in .csv flat files. To do this, two solutions are possible in Open ERP:

- importing a CSV file that has been structured in a particular way to enable you to load several different database tables from a single file (such as partners and partner contacts in one CSV file, as you have just done above),
- importing several CSV files, each corresponding to a specific database table, that have explicit links between the tables.

**Note:** **Server-side importing**

You can also import CSV data in through the server interface. The file format is the same, but column headings differ slightly. When importing through the user interface it checks that the column heading names match the names seen in the forms on the user interface itself. In contrast, when importing through the server the column heading names must match the internal names of the fields.

Start by building the header of the CSV file. Open the import tool on the object that you are interested in and select the fields that you want to import into your Open ERP database. You must include every field that is colored blue because those fields are required (unless you know that they get filled by default with an appropriate value), and also any other field that is important to you.

![Figure 27.14: Selecting fields to import using a CSV file](image)

Use the field names as the column names in the first line of your CSV file, adding one field per column. If your CSV file has these names in the first line then when you import your CSV file, Open ERP will automatically match the column name to the field name of the table. When you have created your CSV file you will do that by clicking the Nothing button to clear the Fields to Import, then select your CSV file by browsing for a File to import, and then clicking the Auto Detect button.

To import CSV data that matches your database structure, you should distinguish between the following types of field in the Open ERP interface: many-to-many fields (between multiple sources and destinations), many-to-one fields (from multiple sources to a single destination), and one-to-many fields (from a single origin to multiple destinations).
Note: Foreground table
Each of these types is described in relation to a foreground table – the table whose entry form you are viewing and whose entries would be updated by a simple CSV file.
Just because one of these relations fields appears on the foreground table, does not mean that there is an inverse field on the related table – but there may be.
So there is no one-to-many field in the User form to reflect the many-to-one user_id Salesman field in the Customer form, but there is a many-to-one partner_id Partner Name field in the Addresses form to reflect the one-to-many child_ids Partner Contacts field in the Customer form.

Have a look at the screenshots below to see the differences.

Figure 27.15: A many-to-one field: a salesperson linked to a partner

Figure 27.16: A many-to-many field: partner categories

Figure 27.17: A one-to-many field: partner contacts

All of the other fields are coded in the CSV file as just one text string in each column.

Many-to-one fields

Many-to-one fields represent a relationship between the foreground table and another table in the database where the foreground table has a single entry for the other table. Open ERP tries to link the new record in the foreground table with the field in the other table by matching the field values.

Tip: Field identifiers
If you are working on the server side you can use identifiers rather than the names of resources to link tables. To do this you import the first file (for example, Products) with a column named id in your CSV file that contains a unique identifier for each product. This could be an incrementing number.
When you import other files which link to the first table, you can use the identifier in preference to the names (so, for example, when you are saving inventory you can use product:id instead of the product name). You then do not need any complex conversion to create links between the two tables.
This considerably simplifies the importation of another database into Open ERP. You just create a linking id column for each table that you are importing that contains the identifier used in the first table.
Many-to-many fields

Many-to-many fields are handled just like many-to-one fields in trying to recreate the relationship between tables: either by searching for names or by using identifiers.

There are several possible values in a single many-to-many field. Therefore a partner can be given several associated categories. You must separate the different values with a comma.

One-to-many fields

One-to-many fields are a bit different. Take as an example the Partner Contacts field in the Customer form, which contains all of the linked contacts.

To import such a field you do not have to link to an existing entry in another table, but can instead create and link to several partner contacts using the same file. You can then specify several values for different fields linked to that object by the one-to-many field. Each field must be put in a column of the table, and the title of that column must be expressed in the form field_one-to-many/field_linked-object. The partner data you imported earlier took that form.

Note: Symmetry in relation fields

Depending on the structure of your data it can be easier to use the one-to-many form or the many-to-one form in relating two tables, so long as the relevant fields exist on both ends of the relationship.

For example, you can:
• import one partner with different contact in a single file (one-to-many),
• import the partners first, and then contacts with the field linking to the partner in a many-to-one form).

27.8.4 Another example of a CSV import file

To illustrate data importing, you can see another example below. First import partner categories, and then import some partners and their contacts along with links to the categories just created. Although you can create new contacts at the same time as creating partners (because you can do this for one-to-many relations), you cannot create new categories this way (because they use many-to-many relations). You must create new categories in a separate step.

Partner categories

Start by creating partner categories in a CSV file:

1. Create the following table in your spreadsheet program:

<table>
<thead>
<tr>
<th>Column A</th>
<th>Column B</th>
</tr>
</thead>
<tbody>
<tr>
<td>Line 1 Category Name</td>
<td>Parent Category</td>
</tr>
<tr>
<td>Line 2 Quality</td>
<td></td>
</tr>
<tr>
<td>Line 3 Gold</td>
<td>Quality</td>
</tr>
<tr>
<td>Line 4 Silver</td>
<td>Quality</td>
</tr>
<tr>
<td>Line 5 Bronze</td>
<td>Quality</td>
</tr>
</tbody>
</table>

On the first line, Category Name and Parent Category are the column titles that correspond to field names in the Partner category form.

Column A is for the different partner categories and Column B indicates if that category has a parent category. If Column B is blank then the category sits at the top level.

2. Save spreadsheet file in CSV format – separated by commas – and name the file categories.csv.

3. In Open ERP, select Sales → Configuration → Address Book → Localisation → Partner Categories.
4. Click *Import* (to the bottom right of the list) to bring up the *Import Data* dialog box, in which you will find the list of fields that can be imported.

5. Click *Browse...* on the *File to import* field and select the CSV file you just created, *categories.csv*. If you are using GTK client, click *Auto Detect* to match the column names in the CSV file with the field names available in *Partner Categories*.

6. Click *Import* at the top-left of the dialog box to load your data. You should get the message *Imported 4 objects* in a new dialog box. Close both this and the *Import Data* dialog box to return to the original page.

7. Refresh the *Partner Categories* list to view the tree of categories, including the new Quality branch and its child branches that you loaded.

**New partners**

Here is how to create new partners with more than one contact, as you did before, and how to link them to these new categories:

1. Enter the table below into your spreadsheet program.

<table>
<thead>
<tr>
<th>Line</th>
<th>Column A</th>
<th>Column B</th>
<th>Column C</th>
<th>Column D</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Name</td>
<td>Categories</td>
<td>Contacts/Contact Name</td>
<td>Salesman</td>
</tr>
<tr>
<td>2</td>
<td>Black Advertising</td>
<td>Silver,Gold</td>
<td>George Black</td>
<td>Administrator</td>
</tr>
<tr>
<td>3</td>
<td>Jean Green</td>
<td></td>
<td>Jean Green</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Tiny sprl</td>
<td></td>
<td>Fabien Pinckaers</td>
<td>Administrator</td>
</tr>
</tbody>
</table>

2. The second line corresponds to the creation of a new partner, with two existing categories, that has two contacts and is linked to a salesman.

3. Save the file using the name *partners.csv*

4. In OpenERP, select *Sales* → *Address Book* → *Customers* then import the file that you have just saved. You will get a message confirming that you have imported and saved the data.

5. Verify that you have imported the data. A new partner should have appeared (Black Advertising), with a salesman (Administrator), two contacts (George Black and Jean Green) and two categories (Silver and Gold).

**27.8.5 Exporting data in other forms**

Open ERP’s generic export mechanism lets you easily export any of your data to any location on your system. You are not restricted to what you can export, although you can restrict who can export that data using the rights management facilities discussed above.

You can use this to export your data into spreadsheets or into other systems such as specialist accounts packages. The export format is usually in the CSV format but you can also connect directly to Microsoft Excel using Microsoft’s COM mechanism.

**Tip:** Access to the database

Developers can also use other techniques to automatically access the Open ERP database. The two most useful are:

- using the XML-RPC web service,
- accessing the PostgreSQL database directly.
**Tip: Module Recorder**

If you want to enter data into Open ERP manually, you should use the Module Recorder, described in the first section of this chapter.

By doing that you will generate a module that can easily be reused in different databases. Then if there are problems with a database you will be able to reinstall the data module you generated with all of the entries and modifications you made for this system.
IMPLEMENTATION METHODOLOGY

You may have mastered the technical aspects of administering and using your enterprise management system, but you still have a great deal of work to do integrating Open ERP into your company. This work is more business-related and social in nature than technical.

The Open ERP implementation process encompasses several different phases: evaluation, planning, configuration, data migration, deployment, and user training, and affects both support and maintenance.

The management of ERP projects, and IT project management in general, are the subject of very many other books that you might want to investigate for yourself. The elements of the methodology presented here are not intended to be an exhaustive review, just a brief overview of the different phases necessary to implement Open ERP in your company.

Tip: Implementation
Implementation encompasses the whole process of integrating and deploying Open ERP, including evaluating it, establishing specifications, planning the deployment, the configuration of the software, loading data, installation and training the users. It does not generally extend to software customization, nor support and maintenance.

28.1 Requirements Analysis and Planning

Requirements analysis and planning are the keys to the success of an implementation. At this stage you should set up a management team to define the costs and benefits of the project, select a project team, and set out the detailed stages that will have to be carried out.

Open ERP is so easy to start using that it is not always obvious, particularly to IT staff, that a clear requirements plan is necessary for implementing the system successfully. The difficulty is not particularly in installing the software nor in configuring it, but rather more about:

- knowing what to configure,
- deciding if you should adapt the software or perhaps change your method of working, for some of your specialized processes,
- forming teams that can specify and work on some of the changes,
- ensuring that your users are committed to the change.

ERP system implementation is a project carried out using information technology but it is a business project rather than an IT project in itself. The challenge of this type of project is in changing the behaviour of those involved at all levels of the enterprise.

People in the IT department will certainly be an integral part of the project but they should be managed by someone in a senior position who both understands the business impact across the organization and has experience of technical projects. Ideally the project manager should know the company well, both its specific quirks and its different standard cross-company processes.
If the enterprise does not have its own IT group, you are probably better off opting for a SaaS offer. This means that you subcontract all the difficult technology, from the installation of the server to its maintenance, all the while being assured of the installation of a robust architecture with its redundancy, backed-up servers, and separation of authentication and data.

### 28.1.1 Planning methods

Planning methods vary in their degree of complexity, formality and level of automation. It is not the intention of this chapter to steer you towards one method or the other.

Open ERP’s menus are organized to lead you through an implementation in a sensible order, so that information that has to be entered first is encountered first in the menu system. Forms are also organized so that if you enter data in the natural order you will get later fields completed automatically by the earlier ones where possible. And demonstration data illustrates how Open ERP’s functional areas are linked from one to the other.

The menus themselves hint at several helpful implementation suggestions, for example the sub-menus of Administration → Configuration are useful for the configuration of the software. New functions such as the Module Recorder enable you to significantly accelerate the configuration of data.

### 28.2 Deployment

As you have seen, the complete architecture of Open ERP includes the following elements:

- a database server,
- an Open ERP application server,
- an Open ERP client-web server,
- several clients that access the Open ERP server: they can either be web clients if the client-web server is installed, or GTK clients.

**Note:** Deployment

*Deployment is the process of putting a Open ERP database into a production-ready state, where it can be used by everyone in your business for their daily work. You would usually configure Open ERP and load data into it on one development system, train staff on that or another training system and deploy it onto a production system that has better protection against failure, better security and more performance.*

### 28.2.1 Deployment Options

To deploy Open ERP in your company, several options are available to you:

- a SaaS (Software as a Service) or On-Demand offer which includes the equipment, the hosting, the maintenance and the support on a system configured to your needs in advance,
- an internal installation, that you manage yourselves or have managed by an IT services company such as an Open ERP partner,
- hosting by a server supplier on which Open ERP is installed, which enables you to proceed to add adaptations on your server.

The first two approaches are the most commonly used.

**The SaaS (Software as a Service) offer**

SaaS is a complete package hosted at a supplier, that includes the following services: server hardware, hosting of the generic solution, installation and initial configuration, redundancy of the architecture, backups, system maintenance and support. It is also known as On-Demand.
It is provided in the form of a monthly subscription with a fixed price per user. You can find the detail of Tiny’s SaaS packages at http://ondemand.openerp.com/.

SaaS packages do not permit you to develop specific modules to your needs. On the contrary, they offer a service at a set price based on standard software modules that contain few migration risks. SaaS suppliers are limited generally to the modules certified and validated by the original author and project manager, Tiny.

Here are the main advantages of an Open ERP SaaS solution:

- an unbeatable return on investment (cost of implementation: 0, cost of licenses: 0),
- costs that are controlled and without surprises (the offer includes maintenance, frequent migrations and support),
- a turnkey solution, installed in less than twenty-four hours,
- packages adapted and preconfigured for different sectors of activity,
- a very robust architecture guaranteed to have constant and permanent access, reachable from anywhere.

So this server is recommended for small companies with fewer than about fifteen employees.

**Hosting by a supplier**

At first sight a hosted Open ERP system appears similar to SaaS: it provides Open ERP from a remote installation through a web browser. But in general the similarities stop there.

To compare it with an SaaS package you should check if the hosting offer properly includes the following elements:

- server hardware,
- hosting,
- maintenance,
- future migrations,
- backups,
- server redundancy,
- telephone and email support,
- frequent updates to the modules.

Also get yourself up to speed on the following points:

- the version of Open ERP proposed,
- the costs of implementation (configuration, data loading, training),
- the cost of configuration (if it is proposed),
- the technology and the procedure used for securing your database,
- the technology and the procedure for preventing system faults,
- the technology and the procedure for restoring a faulty system,
- limitations on the number of users, the number of simultaneous users, and the size of the database,
- the level of support and its costs,
- the procedure used to update Open ERP (to fault-fixed versions)
- the procedure adopted for Open ERP upgrades (to versions that have both fault fixes and new functionality).

Calling such suppliers can be a good solution if you are willing to entrust all the technical specifications for the functioning of Open ERP to them, especially if you need to use customized or extension modules that are not in the stable version released by Tiny.
**Internal Installation**

Large and medium-large companies typically install Open ERP using their own internal company resources. They usually prefer to have their own IT service in charge of maintenance.

Such companies can do the implementation work themselves internally, or turn to an Open ERP partner who will do the ERP implementation work or assist them with it. Generally companies prefer to adopt an intermediate solution which consists of:

1. Turning the initial implementation over to a partner to limit the risks and delays of integration. That enables them to be managed by experts and obtain a high quality configuration.
2. Taking charge of the simple needs for themselves once the software has been implemented. It is quite a lot more convenient for them to be able to modify the database tables, forms, templates and workflows internally than routinely depend on a supplier.

An internal installation will probably prove more costly than an SaaS package or hosted service. Even if you put yourself in charge of it all, you will take quite a bit of time learning how to manage the implementation unless the team already has an experience of Open ERP. This represents a significant risk.

However, an internal implementation can be particularly interesting where:

- you want to keep your data within your company,
- you think you want to modify your software,
- you want a specific package of modules,
- you would like a very fast response time,
- you want the software to be available even if your Internet connection goes down.

These factors, and access to the resources needed to handle an implementation and the subsequent maintenance, are the reasons that large and medium-large companies usually do it for themselves, at least partly.

### 28.2.2 Deployment Procedure

The deployment of a version of Open ERP is quite simple when your server has been configured in your production environment. The security of data will then be a key element.

When you have installed the server you should create at least two databases:

- a test or development database, in which the users can test the system and familiarize themselves with it,
- a production database which will be the one used by the company in daily use.

**Note:** Version numbering

*Open ERP uses a version numbering model that comprises 3 numbers A.B.C (for example 4.2.2 or 5.0.0) where changes in the number A signify a major functional change, changes to number B signify an update that includes a batch of fault fixes and some new functionality, and the number C generally refers to some limited updates or fixes to the existing functionality.*

*The number B is special: if it is an odd number, (for example 4.3.2 or 5.1.0) it is for a development version which is not designed for a production environment. The even numbers are for stable versions.*

If you have prepared a data module for Open ERP (that is a module that consists just of data, not altered functionality), you should test it in your development version and check that it does not require any more manual adjustments. If the import runs correctly, it shows that you are ready to load your data in the production database.

You can use the Open ERP database backup procedure at different stages of configuration (see *Installation and Initial Setup*). Then if you have made a false step that you cannot recover from you can always return to a prior state.

Since your data describes much of your company’s value, take particular care both when you need to transfer it (in backups and across your network) and when you are managing the super-administrator password. Make sure...
that the connection between a PC client and the two servers is correctly secured. You can configure Open ERP to use the HTTPS protocol, which provides security for data transfer.

**Note: HTTPS**

The HTTPS protocol (Secure Hyper Text Transfer Protocol) is the standard HTTP protocol secured by using the SSL (Secure Socket Layer) or TLS (Transport Layer Security) security protocols. It allows a user to verify her identify to the site to which she wants access, using a certificate of authentication. It also guarantees the integrity and confidentiality of the data sent between the user and the server. It can, optionally, provide highly secure client authentication by using a numbered certificate. The default HTTPS port is 443.

You could also use the PostgreSQL database directly to backup and restore data on the server, depending on access rights and the availability of passwords for the server.

### 28.3 User training

Two types of training are provided by the Tiny company and its partners:

- Technical training in Open ERP: the objective of this intensive training is to enable you to develop your own modules by modifying and adapting the existing ones. It covers the creation of new objects, menus, reports and workflows, and also of interfaces with external software. It lasts for five days and is designed for IT people.

- User training: this enables you to be productive as rapidly as possible in the use of Open ERP. All of the modules there are detailed with concrete examples and different exercises. For the sake of realism the training uses data for a fictitious company. This training also lasts for five days. It is designed for those responsible for an ERP project, who will then be capable of training employees internally.

Tiny’s training calendar is available on the official Open ERP site at [http://www.openerp.com/services/training-schedule](http://www.openerp.com/services/training-schedule). The training is delivered in either French or English depending on the course.

Both Tiny, the creators of Open ERP, and the Open ERP partners can also provide customized training. This, although more expensive, is focused on your own needs.

Your training needs depend on the type of deployment you have chosen. If you have opted for a SaaS development, technical training is not very useful.

In summary, you should arrange both user training and self-paced training (perhaps based on this book series) if you can. Technical training is strongly advised if you see yourselves developing your own modules. Although it is not obligatory it gives you quite a time advantage in any serious Open ERP engagement.

### 28.4 Support and maintenance

It is when you actually use your ERP that you will obtain value from your investment. For that reason maintenance and support are critical for your long term success.

- Support aims to ensure that end users get the maximum productivity from their use of Open ERP by responding to their questions on the use of the system. Support can be technical or functional.

- Maintenance aims to ensure that the system itself continues to function as required. It includes system upgrades, which give you access to the latest functionality available.

Some partners offer preventative maintenance. This makes sure that all the specific developments for your system are revised and tested for each new version so that they remain compatible with the base Open ERP.

Tiny themselves have changed their support strategy from time to time. At the time of writing they propose a maintenance contract supplied either direct to the end user or through partners that guarantees a quick fix to any faults discovered in the covered code. Although you can expect these fixes to become available to all users of the
code in time, maintenance guarantees quick attention. And you are likely to get quicker migration support to new
upgrades.

If you have not anticipated your needs with a preventive maintenance contract, the costs of migration after a few
years can become significant. If special modules that you developed have been allowed to become too old you
may eventually need a new development according to your specifications.

28.4.1 Updates and Upgrades

There are four sources of code change for Open ERP:

- patches supplied by Tiny to correct faults: after validation these patches should not cause any secondary
effects,
- minor updates, which gather the fault corrections together in one package, and are generally announced
with a modification of the version number, such as from 6.0.0 to 6.0.1,
- upgrades, which bundle both the fault corrections and the improvements to the functionality in a major
release such as from 6.0.3 to 6.2.0.
- new functions generally released in the form of new modules.

You should establish a procedure with your supplier to define how to respond to changes in the Open ERP code.

For simple updates your maintenance team will evaluate the patches to determine if they are beneficial to the use
of your Open ERP. These patches should be tested on an offline instance of Open ERP before being installed in
your live production version.

The maintenance team would also take charge of regular updates to the software.

Patches and updates can only be installed if you have the necessary access to the Open ERP server. You must first
install the patch or update and then restart the server using the command line: 
update=all.

Once Tiny has released a new upgraded version your response should be a cautious one. If you are perfectly
satisfied with the existing system it would be best to not touch the new version. If you want to have access to the
new functionality supplied by an upgraded version, you have a delicate operation to carry out. Most upgrades
require your data to be migrated because the databases before and after the upgrade can be a little different.

28.4.2 Version Migration

Open ERP has a system to manage migrations semi-automatically. To update specific modules, or the whole
database, you only need to start the server with the argument: update=NAME_OF_MODULE or
update=all (that is minor module changes).

New stable versions of Open ERP sometimes require operations that are not provided in the automated
migration. Tiny, the creator and maintainer of Open ERP, has a policy of supporting migration from all official
stable releases to the latest. Scripts are provided for each new release of a stable version. These carry out the
upgrade from the previous major version to the new major version.

Managers responsible for the migration between two versions of Open ERP will find the documentation and the
necessary scripts in the directory doc/migrate of the Open ERP server.

The changes between version 4 and 5 made the migration process more difficult than in the past so there was a
greater delay in the provision of migration assistance and more manual work than usual.

The procedure for migrating runs like this:

1. Make a backup of the database from the old version of Open ERP
2. Stop the server running the old version
3. Start the script called pre.py for the versions you are moving between.
4. Start the new version of the server using the option update=all
5. Stop the server running the new version.

6. Start the script called post.py for the versions you are moving between.

7. Start the new version of the server and test it.

A migration is never an easy process. It may be that your system does not function as it did before or that something requires new developments in the functionality of the modules that have already been installed. So you should only move to a new version if you have a real need and should engage a competent partner to help if the version that you use differs greatly from the basic version of Open ERP.

Similarly you should take care that this migration does not incorrectly change any setting that has already been made. The main menu structure might have been modified in place without proper recording of the changes. So you could find that you are making the wrong assumptions about that structure when later loading data that was recorded with the Module Recorder.
Part X

Google Modules
We have integrated some Google applications with OpenERP, which allow users to view OpenERP data on Google. Please take a look at the module descriptions.

Path to get Modules: lp:-~openerp-commiter/openobject-addons/trunk-extra-addons
Name of the module: google_translate

This module translates OpenERP terms/fields/objects etc. in any language with the integration of Google Translate.

You can find the menu here: Administration/Translation/Application terms/Translation Terms and Need review terms.

Check below screenshots which translate string “how are you” in Chinese language.

Note: If the Need Review field is True then it will translate the source value to destination by given language.
Name of the module: google_calendar

This module synchronizes Google Calender repeating and non-repeating events with OpenERP events. So, now get updates of calendar schedules from Google calendar in OpenERP and vice versa. A user can change the event schedule from anywhere, through his Google calendar which updates Events in OpenERP.

You can find the menu here: Event Organization/ Google Import Export/ Synchronize Events

**Google Calendar Event**

**OpenERP Event**
Name of the module: *google_blogger*

This module integrates Google Blogger and Open ERP Task Management, which exports tasks to blogger and one can get comments on their activity on mentioned tasks in blogger.

A very useful feature of blogger, that is open discussion will be enhanced the development efforts.

This feature helps in managing large projects with many tasks and many users working on different tasks (simultaneously), with this functionality all users can share their progress for the task with others and give their comments for the same.

Check below screenshots which send Open ERP tasks to blogger.

**Blogger**

**Openerp Tasks**
CHAPTER THIRTYTWO

GOOGLE EARTH

Name of module: google_earth

Features:

1. See partners information on google map (name, code, address, ...) with icon on map
2. And Turnover of country by partners, country appears in light red color => low turnover and with dark red color => high turnover.
3. Delivery routes from Warehouse location to Customer location by cities with 10 different colors (by number of delivery to that city from warehouse).
4. It can create network link kml file for dynamic updates of data on google earth.
5. It can directly open google map in your browser with different information.
6. It generates KML file so you can save it on your computer and upload it on google map/google earth.

Menus

You can find 5 wizards on Partners/Google Map/Earth.

KML File:

If you want to use google_earth module you have to know about what is kml file and how to use it on google/map.

Tip: KML

KML is a file format used to display geographic data in an Earth browser such as Google Earth, Google Maps, and Google Maps for mobile. KML uses a tag-based structure with nested elements and attributes and is based on the XML standard. All tags are case-sensitive and must be appear exactly as they are listed in the KML Reference. The Reference indicates which tags are optional. Within a given element, tags must appear in the order shown in the Reference.

For more information:
http://code.google.com/apis/kml/documentation/kml_tut.html
http://code.google.com/apis/kml/documentation/topicsinkml.html
http://code.google.com/apis/kml/documentation/kmlreference.html

Now How to upload kml file on Google Map:

Step1: go to create map link
Step2: import
Step3: upload kml

Difference between Google Map and Google Earth:

Google Maps is available through the window of your browser, Google Earth is a downloadable application which can be installed on your computer in order to view the satellite imagery straight from your desktop. However, the super giant Google updates the two products every once in a while so they have almost the same functions

After uploading KML files to google map look below:

1. KML for Partner-Country

   ![Partner-Country KML](image1)

   This is the screen shot which shows the partner’s country, turnover of partners reside in that country. Here we can see country wise partners and country wise turnover. By clicking on selected country we can get Number of partners, Number of invoices made and Turnover of the country.

   Note: High Turnover => Dark red & Low Turnover => Light red

2. KML for Delivery Route

   ![Delivery Route KML](image2)
This is the screen shot for finding the delivery routes from warehouse location to customer location. Here we can see there are different routes in different colours. By clicking on particular route we get the information about Customer Location, Warehouse Location, Number of Products sent and Number of deliveries made.

### 3. KML for Partners

![KML for Partners](image)

This is the screen shot showing all partners from different countries. This will make a point on particular partner address on map. By clicking on any point we can get the information about the partner, e.g. Name of partner, Code, Type(customer/supplier), Address, Turnover of Partner, Number of customer invoice, Number of supplier invoice, Total receivable, etc...

### 4. Wizard for KML for Network link

![Wizard for KML for Network link](image)

**Tip:** Network link kml:

*A special kind of kml file which has networklink tag inside it which contains link of your kml file.*

This wizard will create network link in kml for different objects and save it to your computer and then you have to upload network link kml to google earth/map. It can update data periodically by looking networklink kml files parameters(refreshtime,interval....). For e.g if you have inserted new partner then google earth can able to fetch that new partner from webservice of etiny.

**Note:** If you ticked partner and country, wizard will create two link tag with url/path of two kml file. now whenever you will upload this kml file it will show both partner and country information on earth and update that information by given interval time (using url/path ).

The wizard of network link shown above:

First, path shows a url (HTTP address) means your web-client path with port number where your etiny services running.

RefreshMode specifies a time-based refresh mode, which can be one of the following:
onChange - refresh when the file is loaded and whenever the Link parameters change (default).

onInterval - refresh every n seconds (specified in <refreshInterval>).

onExpire - refresh the file when the expiration time is reached.

RefreshInterval indicates to refresh the file every n seconds.

ViewRefreshMode specifies how the link is refreshed when the “camera” changes.

never (default) - Ignore changes in the view. Also ignore <viewFormat> parameters, if any.

onStop - Refresh the file n seconds after movement stops, where n is specified in <viewRefreshTime>.

onRequest - Refresh the file only when the user explicitly requests it. (For example, in Google Earth, the user right-clicks and selects Refresh in the Context menu.)

onRegion - Refresh the file when the Region becomes active.

View Refresh Time specifies the number of seconds to wait before refreshing the view, after camera movement stops.

5. Wizard for Open Google Map

This wizard will directly open google map in browser.

For e.g. If you want to open that map for partner-country, then it will directly open google map for partner with countries in browser.

In above figure, You can see Path field. In that, http://maps.google.com/maps?q=, will be common and later is shown your web-client path with port. Another field is Map For which is selection for Partner, Partner-Country and Delivery-Route. Whatever option you select from Map For field, it will directly open map for that option and with that url(Path).

Part XI

Conclusion
OpenERP has become established as the main free market-changing alternative for enterprise management systems in amongst software from giants such as SAP, Oracle and Microsoft, and from the small software developers in their own niches.

Until now only two main alternatives existed for systems that manage a company’s information: install a proprietary ERP system, complete but usually overweight, inflexible, and expensive; or develop a solution internally, adapted to current needs but often expensive to develop, not integrated, and incomplete.

With its free business model, OpenERP combines the advantages of a complete ERP system with the flexibility of an in-house solution. The open source code, the project’s general flexibility, and its hundreds of modules let you construct a solution from a selection of the modules already available and you can then freely update it as your needs evolve.

The results will be at the top end of what you might expect from any ERP system, let alone an Open Source system. The considerable gains in productivity, efficiency and visibility become apparent only a few months after implementation. And you can gain from increased operational quality even if you reduce your human resourcing intensity. Because there are fewer repetitive tasks for your staff to do, they can concentrate on higher added-value work. We frequently receive the gratitude of senior management who get better results from their business because they have adopted OpenERP.
CHAPTER THIRTYTHREE

YOU ARE NOT ALONE

Many resources are at hand to accompany you on your OpenERP adventure.

33.1 Bypass the technical difficulties by using the SaaS offer

For a quick low-cost start, you can make use of a month’s comprehensive free trial of Tiny’s OpenERP SaaS package found at http://ondemand.openerp.com/. Using this you sidestep any technical difficulties and get a comprehensive set of system administration services, server hosting, configuration to your environment, maintenance, support and initial training.

An SaaS package is suited to the needs of small enterprises that do not have very specific needs, and where the initial cost and the delay of implementation are critical factors.

To meet its objectives of minimal cost, the SaaS package aims for highly automated standardized data migrations, minimal support load by training customers well, and a strict limit to the number of modules offered. So you cannot use your own modules, and are limited to the standard modules that are included in various package levels.

33.2 Consult the available resources

Larger companies often prefer a more classic implementation path. Even though OpenERP’s simplicity makes this task easier than with other systems, you cannot hide the fact that a project implementation is complex and introduces big changes to a company.

So you can turn towards some of the different actors in this free software ecosystem to help you out:

- the community of users and developers,
- Tiny’s OpenERP partner companies,
- the main project developers, Tiny, themselves.

33.2.1 The community of users and developers

The community, supported by Tiny, hosts a set of communication tools which can help you in your OpenERP investigation.

- The forum http://openerp.com/forum

The forum enables you to discuss issues with other OpenERP users. It is very active and you have a good chance of receiving some form of response to your questions within twenty-four hours or so.

- The wiki http://openobject.com/wiki

The OpenObject wiki is used to manage activities around OpenERP.

You will find informations about:
• Shared Funding Projects
• IRC Meetings
• Real Life Meetings (eg. Community Days)
• Business Intelligence
• Open Report (eg. OpenReport, OpenOffice Plugin)
  • Database of OpenERP modules http://doc.openerp.com/py-modindex.html
    A database of all the modules available for use gives you free access to most of the known OpenERP extensions.
  • Launchpad https://code.launchpad.net/~openerp/
    The most recent communication tool is the launchpad system, which now hosts all of OpenERP’s source code
    (using the bzr source code control system) and is used for reporting faults. It is become the central location for
    OpenERP technology.

33.2.2 OpenERP partners

If you need contract-backed guarantees for implementing and maintaining OpenERP you can contact an official
OpenERP partner. OpenERP partners offer various services such as user training, prototype installations, and
change management services. The complete list of partners by country and by type can be found on the official
OpenERP site: http://openerp.com/partners

33.2.3 The main developer, Tiny

Finally you can call the main project developers, Tiny, who can help you in your OpenERP project. Tiny offers
various services such as free demonstration days for the software, user training and technical training, support
contracts, maintenance contracts and developments as required. Depending on the demand, they can also put you
in contact with partners most aligned to your requirements.

  • The mailing list To keep up to date with all OpenERP’s news you can subscribe to the mailing list using

To conclude, do not forget that OpenERP has more than two hundred modules available and that many of them
have not been covered in this book. So if you have not found a solution to your problems here, look amongst
those modules, talk to other OpenERP users on the forum, and do not hesitate to contact a partner.

Wishing you the greatest of success in your ERP project,

— Geoff Gardiner and Fabien Pinckaers.
A
absences, 195
access, 42
   LDAP, 41
   menu, 401
   objects, 402
   user, 41, 377, 400
access rights, 400
account
   chart, 82
   type, 183
   user, 41
account types, 74
accountant, 164, 265, 361
accounting, 164
   analytical, 164
   auxiliary, 164
   bank statement, 155
   budgetary, 164
   dashboard, 165
   entry, 154
   financial, 164
   invoicing, 145
   multi-company, 164
   workflow, 145
Accounting and Finance, 64
accounts
   chart, 181
   configuring, 74
   due date, 153
   start of year, 187
action
   multiple, 154
Actions, 129
Activity, 129
adjustment, 156
limit, 159
Administration, 393
administration
   system, 43
administrator, 31, 46, 49
   system, 43, 401
advanced, 110
agenda, 241
agile (method), 232
alerts, 336
allocation
  cost, 194, 197, 201, 212
  time, 236, 238
analytic
  accounts, 198
  balance, 204
  chart of accounts, 194
  cost ledger, 203
  entries, 201
  records, 200
Analytic Accounts, 191
architecture
  OpenERP, 28
asset, 164
attachments, 380
Attributes, 129
B
back order, 286
backup
database, 82
balance
  aged, 166
  analytic, 204
balance sheet, 172
bank
  statement, 155
barcode, 317
benefits, 215
bill of materials, 66, 293
  phantom, 298
BOM, 66
BoM, 293
  multi-level, 297
  revisions, 296
BoM, substitute products, 301
Boolean, 129
budget revisions, 178
budgeting, 177
buttons
  reports, actions, links, 61
C
CalDAV, 66
calendar, 66
calendars, 110
Campaigns, 91, 129
 carriers, 339
case
  create and maintain, 117
  rule, 113
cash management, 157
category
  partner, 78, 109
  product, 80
chained location, 265
chart of accounts, 82, 181
  analytic, 194
  virtual, 183
client
  caching, 28
  GTK, 37
  web (thin) and GTK (thick), 28
client-web
eTiny, 29
Communication Tools, 120
Conditions, 129
Configuration, 393
configuration, 395
  customization, 395
  parameterization, 395
  personalization, 395
  setup, 26, 395
configuring
  dashboard, 407
  module, 395
  report, 405
Configuring Accounts, 179
consolidation (accounting), 183
Contact, 109
contact
  partner, 78
contract
  service, 225
control
  delivery, 338
  invoicing, 338
cost
  allocation, 194, 197, 201, 212
cost ledger
  analytic, 203
credit note, 147
Credit Notes, 154
creditor, 165
Criteria, 129
CRM, 63, 107
CSV export
data, 410
CSV import
data, 411
CSV structured
data, 411
ctrl-right-click, 149
customer, 110
Customer Relationship Management, 63, 105

D
dashboard, 407
  accounting, 165
Dashboards, 66
data
  CSV export, 410
  CSV import, 411
CSV structured, 411
export, 410
import, 410
import example, 414
data, export in other forms, 415
database, 40
backup, 82
create, 40
duplicate, 42
manage, 42
debtor, 165
declarations, 153
DEEE tax, 151
delegation (task), 233
Deliver Quality Services, 224
delivery, 226
control, 338
delivery grid, 339
department, 216
deployment, 418
directory, 378
document, 66
search, 383
Document Management, 66, 374
Dot Notation, 129
Drive your Projects, 228
due date
accounts, 153

E
employee, 209
configuring, 213
sign in / sign out, 211
entry
accounting, 154
eTiny
client-web, 29
export
data, 410
stock management, 272

F
features, 56
fetchmail, 116, 117
field
default value, 397
properties, 149
relation, 413
filesystem
permissions, 43
Filter, 109
Financial Analysis, 164
financial analysis, 176
Financial Management, 64
financial reporting, 164
fiscal year, 185
follow-up, 167
forecasts, 277
FTP, 66, 378

G

gateway, 116
Getting Things Done, 239
goods receipt, 287
Google, 423
group
    user, 400
GTD, 238, 239
Guided Tour, 43

H

hosting, 419
HR, 64
    management, 209
HTTPS, 421
Human Resources, 64, 207

I

Implementation, 416
import
    data, 410
    stock management, 272
indicators, 176
Initial Setup, 26
Installation, 26
installation
    administrator, 30
    eTiny web server, 38
    GTK client, 37
    language, 47
    Linux (Ubuntu), 33
    Open ERP client-web server, 38
    Windows (all-in-one), 30
    Windows (independent), 30
internal installation, 419
inventory, 256
invoice layout, 150
Invoice to Payment, 143
invoices, 145
    types, 147
invoicing, 145, 199
    at delivery, 307
    control, 338
    repair, 325
    tasks, 231

J

journal, 174
    configuring, 184
    minimal journals, 199
journals
    configuring, 77
Just in Time, 285

K

knowledge, 66
L
LDAP, 41, 400
Leads, 91
ledger, 166
liability, 164
linked production, 267
location
   chained, 265
location structure, 82
Logistics, 245
Long Term, 234

M
Main Company
   configuring, 77
maintenance, 421
Manufacturing, 66, 291
manufacturing
   routing, 314
manufacturing order, 308
Marketing, 129
Master Procurement Schedule, 276
Master Production Schedule, 276
menu
   configuring, 396
duplicating, 396
Methodology, 416
methodology
   GTD, 240
migration, 422
minimum stock rule, 275
modification history, 403
module
   account, 73, 85, 164
   account_analytic_analysis, 199, 206, 227, 228, 343
   account_analytic_default, 357
   account_budget, 207
   account_followup, 167
   account_invoice_layout, 150, 352
   account_payment, 161
   account_report, 176
   account_simulation, 173
   account_tax_include, 150
   audittrail, 404
   base_contact, 94
   base_module_record, 396
   base_report_creator, 405
   base_report_designer, 110, 407
   base_synchro, 164
   board_account, 165, 179
   board_document, 377
   board_project, 238
   configuring, 395
   crm, 107, 117
   crm_configuration, 117
   crm_partner_assign, 103
   crm_profiling, 110, 120
delivery, 339, 361
dependencies, 56
discount_campaign, 350
document, 377, 378
fetchmail, 110
google maps, 55
hr, 64
hr_attendance, 367
hr_contract, 214, 367
hr_expense, 219
hr_holidays, 367
hr_holidays_request, 367
hr_recruitment, 221
hr_timesheet, 214
hr_timesheet_invoice, 199, 226, 364
hr_timesheet_sheet, 216
import_export, 172
installing, 56
importing, 56
li10n_fr, 181
membership, 63
mrp, 293
mrp_jit, 86, 259, 285, 301
mrp_operations, 316
mrp_repair, 322
mrp_subproduct, 321
new_functionality, 53
outlook, thunderbird, 110
product, 43, 73
product_electronic, 63
product_expiry, 63
product_index, 213
product_lot_foundry, 63
product_margin, 342, 363
product_variant_multi, 62
product_visible_discount, 333
profile_manufacturing, 339
project_gtd, 239
purchase, 43, 73, 355
purchase_analytic_analysis, 357
purchase_analytic_plans, 357, 364
purchase_journal, 174
purchase_tender, 361
report_analytic_planning_delegate, 238
report_intrastat, 169
report_intrastat, 273
sale, 73, 258, 367
sale_delivery, 351
sale_journal, 174, 282
sale_layout, 352
sale_margin, 341
sale_supplier_direct_delivery, 285
scrum, 232
stock, 55, 73, 248
stock_location, 266, 273, 288
stock_planning, 277
upgrading, 53
users_ldap, 41, 400
warning, 336, 356
modules
hr_, 64, 367
l10n_, 181
motivation, 222
MPS, 276
multi-company, 205
accounting, 164
multi-level BoM, 297
multi-lingual, 182
multiple
action, 154
selection, 154

N
navigating relationships, 149
NET-RPC, 32
new, 56

O
Object, 129
On-Demand, 418
Open ERP Book, 8
OpenOffice.org
report, 408
Opportunities, 91
opportunity, 108
order
manufacturing, 308
production, 308
Outlook (Microsoft), 121
overdue payments, 168

P
packing, 306
Partner, 107
partner, 78
category, 51, 78, 109
contact, 78
managing, 50
search, 59
view form, 60
Partners, 59
password
super-administrator, 40
superadmin, 40
username, 41
payable, 165
payment terms, 186
payments, 160
performance analysis, 112
period, 185
permissions
filesystem, 43
pgAdmin III, 39
phantom
recruitments, 220
relation
  field, 413
reminder, 108, 167
rent, 273
repair
  invoicing, 325
repairs, 322
report, 110, 405
  modify, 409
  new, 410
  OpenOffice.org, 408
requests, 48
requirements analysis, 417
requirements planning, 310
right-click, 149
routing, 314
  logistics, 288
  manufacturing, 314
rule
  case, 114

S
SaaS, 27, 418, 443
sales, 65
Sales Management, 64, 329
scheduler, 310
  lead time, 310
search
  document, 383
selection
  multiple, 154
semi-finished product, 303
send SMS, 108
service
  contract, 225
setup
  configuration, 26
shortcut, 59
simple: The 7 Habits of Highly Effective People, 239
single
  report
  common headers, 410
Software as a Service, 418
SRM, 63, 107
stable versions, 30
Startflag, 129
statement
  bank, 155
stock, 65
  analysis, 260
  double-entry, 248
  inventory operation, 249
  journal, 282
  localization, 264
  location, 81, 262
  location type, 262
  negative, 260
orderpoint, 275
real time valuation, 265
stock check, 249
warehouse, 275
stock check, 256
Stock Management, 245
Subscribe Start, 23
Supplier Relationship Management, 63
support, 421
system
  administration, 43
  administrator, 43, 401

T
tasks, 236
tax, 169
taxation, 164
tender, 361
Thunderbird (Mozilla), 125
time
  allocation, 236, 238
timebox, 241
timesheet, 212
  entering data, 214
timesheets
  evaluation, 215
timezone, 46
Tiny ERP, 27
traceability
  downstream, 279
  upstream, 279
traceability (stock), 281
trading company, 348
training, 421
translation, 398
TVA, 175
type
  account, 183

U
unit of measure, 253
UoM, 253
update, 422
upgrade, 422
user
  access, 50
  account, 41
  configuration, 49
  group, 50, 400
  role, 50
username
  password, 41

V
VAT, 175
virtual
  chart of accounts, 183
  file, 381
stock, 254

W
warehouse management, 65
warning, 336
waste products, 321
welcome page, 397
work operations, 315
work orders, 312
workcenter, 312
workcenter, cycle, 313
Workflow, 129
workflow, 367, 369, 404
Workitem, 129

X
XML-RPC, 32

Y
your Invoicing & Payments, 137